Tofu 11 and DHCP Renew

Discussion in 'HyperWRT Firmware' started by pitch78, Dec 17, 2005.

  1. pitch78

    pitch78 Network Guru Member

    Hello, since i upgrade to the Tofu 11, i've problem with DHCP Release/Renew.
    I can do it one time, but after it's impossible !
    i can release, but never renew until i reboot the router...
    i use kaid startup script:

    i don't think that change something but, just in case...
    Someone else have the same problem ?
    thx in advance
  2. rotor

    rotor Network Guru Member

  3. pitch78

    pitch78 Network Guru Member

    ok, i've read the other posts :
    1) my router is a WRT54G v2 (it often seems to be v2 that have problem, i don't know...)
    2) i have my ISP's DNS setting in the router
    3) no problem with my modem (a freebox : sagem modem of a french ISP) because, just reboot the router solve my problem

    Wait until next release and hope...

    thx for attention & help rotor !
  4. placoboy

    placoboy Network Guru Member

    Same here

    Same issue here :sad:
    Since my upgrade to TOFU11 I cant get an IP on the Wireless netork which is established correctly (WEP encryption).
    (the laptop does not get any IP and cannot connect)
    I have tried manual IP but no success

    I use a WRTG v2
    Any help would be appreciated !!!
  5. placoboy

    placoboy Network Guru Member

    I switched to DD-WRT and it works now ! :clap: as well as the original Linksys firmware by the way
    Something is wrong with TOFU 11 and WRTG54 v2 :sadbye:
  6. DallasFlier

    DallasFlier Network Guru Member

    Have you done a factory reset and did you try clearing the nvram totally? I'm running a WRT54G v2 here, and am at 12 days uptime currently and everything works great. Numerous release/renew cycles during that time as I've rebooted computers here for various reasons.
  7. placoboy

    placoboy Network Guru Member

    Interesting ... I guess now I am on this DD-WRT firmware and it works but you may be well right ... I did the factory reset with DD-WRT but I dont remember with TOFU ...

    Would it be worth it going back to TOFU ? any particular advantage ?
    I was interested in getting the script facility at start up and I have it now with DD so ...

    Any advice is welcome ;)
  8. Thibor

    Thibor Super Moderator Staff Member Member

    the script facility you were interested in was already available via "Startup_Script" & "Firewall_Script" in Management.asp
  9. placoboy

    placoboy Network Guru Member

    Thanks Thibor. I did use it when I was using Tofu 11 but I had to give up because of this DHCP issue.

    Next time I upgrade my router I will try again next release of TOFU.
  10. placoboy

    placoboy Network Guru Member

    Hi again

    Just tried TOFU11 again ... it does not work 8O
    even after a reset to factory

    DDWRT was not working either :cry: :cry: the network would seem overloaded and I could connect to the router (web interface) with difficulty

    So for the time being I will stick to the Linksys official until TOFU release something that works for me

    Something is wrong with addressing, I also tried to plug my laptop on the ethernet port and I didnt get an IP address either :cry:

    With the Linksys, everything was immediately back to normal ... too bad for the script
  11. DallasFlier

    DallasFlier Network Guru Member

    I still don't think there's anything wrong with either Tofu11 or DD-WRT, as many are using both of those successfully. As I say, I'm using Tofu11 on a v2 here, and it works great.

    I still think you have some corrupted memory, which is common when you switch back and forth between different custom firmware like you've obviously done with DD-WRT and HyperWRT/Tofu. After installing Tofu11, follow the instructions here to clean your nvram, and I bet things will work just fine:
  12. placoboy

    placoboy Network Guru Member

    Ok I understand what you mean and I will give it a try.
    Thanks :thumb:
  13. robsonn

    robsonn Network Guru Member

    Check out this link

    Tofu 11 has bug with WAN DHCP delegation. Most people cant renew lease, only reboot helps. Temporary solution for this problem might be some script and using cron to reboot router after 23h (if your lease is 24h). Maybe somone have that type of script ?
  14. placoboy

    placoboy Network Guru Member

    My problem is not on the WAN but on the LAN

    LAN fixed IP ok
    LAN dhcp not ok
    Wireless dhcp not ok
    Wirless fixed ip not ok

    in Wireless mode the link is up and I am connected at the wireless layer (ssid + WEP ok) but not at the IP level

    this does not happen with regular f/w
  15. placoboy

    placoboy Network Guru Member

    I got it working!!!

    I did erase the NVRAM but that didnt do it.
    Then I realized I was using WEP key number 2 ... I switched to key no. 1 and .... BINGO :cheering: it does work now !!!!

    TOFU11: use key no.1 only (at least not no.2) :thumb:

    Incident closed.
  16. Top_Gun

    Top_Gun Network Guru Member

    Re: I got it working!!!

    Even better: Use WPA - WEP is a thing of the past and has been compromised.

  17. placoboy

    placoboy Network Guru Member

    I know, thanks top Gun but my old 802.11b 3COM pcmcia card does not support it ... :eek:
    risk is quite moderate and I change the key manually once in a while

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice