Discussion in 'HyperWRT Firmware' started by tofu, Dec 2, 2005.

  1. tofu

    tofu Network Guru Member

    whoops... not sure what happened. I think I accidentally killed the tofu10 thread. Sorry! :eek:


    * Minor changes internally to fix problem with WRT54G v1.


    * Linksys 4.30.1 (GL) code base. Nothing really new here, just nice to have a new version number. :)
    * Downgraded iptables to 1.2.11 from 1.3.3 since it was causing problems with UPnP. u32 and CLASSIFY added.
    * Fixed a problem with QoS auto mode not working. The estimated bandwidth is now fed back into the web page so the user can see it. And a warning is now shown if the end device about to be profiled is on a private address (the modem for example).
    * In Client Mode, clone mac now sets the wireless interface.
    * DHCP server now acts as the authoritative server. An initial request for an unknown or stale IP address is now denied.
    * UPnP page added. It lists current mappings and allows you to delete them. Also added is an option to always clear UPnP entries at startup.
    * Messed around with UPnP code. The router now identifies itself as "Linksys WRT54G/GL (" which should be visible in Windows' My Network Place. This can be disabled from the UPnP page.
    * Factory defaults page now also has an option to clear the entire nvram.
    * Changed backup/restore page. The file naming has been changed to include a config version and a checksum of the router's mac. A warning is given when restoring from a file whose filename doesn't match this name. Also fixed a small leak in backup.
    * Changed upgrade page... It looks nicer. :)
    * Added an option for enabling Spanning-Tree Protocol which is used to prevent loops if there are multiple paths in a network.
    * Fixed some issues with NAS which may have caused problems with WPA/WPA2.
    * Fixed a problem with WEP and index > 0.
    * Enabled channel 14.
    * WDS interfaces are now shown in Device List.
    * Fixed ifconfig chopping off last character of WDS name.
    * Added an option to run telnetd at startup. Also added is an option to reject wireless access to shell.
    * When a wireless computer is not allowed to access the admin page, the connection is now just closed silently.
    * Site survey page added (finished). You need a browser that supports XMLHTTP like Firefox, Opera or Internet Explorer.
    * And a lot of mini changes I no longer remember...

    download (Coral CDN seems to be down right now [12/02] so older files might not download...)
  2. pharma

    pharma Network Guru Member

    Thanks for your excellent work! Looking good on my two wrt54g's (v1.1 & v4.0).

  3. envoid

    envoid Network Guru Member

    Tofu, thanks for updating the fw for the WRTs! I haven't tried another fw on my v1.0 since HyperWRT 2.0b1 and had so many problems with it and even 1.4 I stayed with 1.3 for the longest time. I plan on trying yours to see how it works this weekend and will let ya know. But mostly just wanted to say Thanks!! :thumbup:

  4. chilli4u

    chilli4u Network Guru Member

    I am totally desperate... :cry:

    Can someone write me the link to tofu's hyperwrt 10 fw I couldn't find it anywere... PLEASE.

    I need it for my WRT54GL....

    I bricked it already and recovered it back 1 hour ago...

    Please... send me the link..

  5. Eric

    Eric Network Guru Member

    Is-it possible to install it on a WRT54GS ?
  6. sollie

    sollie Network Guru Member

    no, look for a thibor version not tofu. tofu is only compatible withe the wrt54g
  7. zaphod

    zaphod Network Guru Member

    is this the problem sometimes the wpa-psk wds-link dont work correctly and you got to fix it with rebooting the wds-routers??
  8. gaster

    gaster Network Guru Member

    Come on chilli4u, there is a link to Tofu 11 in the first post by Tofu in this thread.

    People who can't even find a link to download firmware probably should not be flashing their router.
  9. PrimalScream

    PrimalScream Network Guru Member

    Thanks again tofu! :thumb:
  10. pion

    pion Network Guru Member

    do i still need to enter:

    "echo "600 1800 120 60 120 120 10 60 30 120" > /proc/sys/net/ipv4/ip_conntrack_tcp_timeouts"

    in startup to use bittorrent using this firmware?
  11. polakatl

    polakatl Network Guru Member

    i flashed from 10 to 11 and it won't connect to internet anymore. I will see if flashing to 10 will solve the problem.

    54g v2
  12. polakatl

    polakatl Network Guru Member

    odd, linksys origional gives me internet, but now neither 10 or 11 get wan ip
  13. virgil

    virgil Network Guru Member

    Hi tofu

    I was trying out a firewall script on my WRT54G v3.1 running tofu10 so I could access the DSL modem from within the router LAN. AFAIK this script works for DD-WRT:

    ifconfig vlan1:0 netmask
    iptables -t nat -I POSTROUTING -o vlan1 -d -j SNAT --to-source
    but couldn't connect to the modem (in bridge mode)

    so I erased the firewall script, rebooted and tried entering the lines individually under Administration > Management > Run Command but at the second line, i got

    Which seems to indicate the a problem with SNAT in iptables ? :(

    A quick check recommended by 4Access shows:
    Why the ERROR at the bottom ? :cry:
  14. ofbarea

    ofbarea Network Guru Member

    working fine in my wrt54g v2.2

  15. Somebodympc

    Somebodympc Network Guru Member

    Thanks again for the wonderful firmware!
  16. sded

    sded Network Guru Member

    Did a little more characterization of the site survey problem I am having with tofu10/11 on a G4. Works fine with manual commands, as before. To get it to work from the site survey page, need to go to active mode, hit disable, up, up, scan. But this only works with a wired connection, since it kills the AP. And setting the expire time to 15 seconds doesn't restore it-have to reenable wl manually from the wired link. Fields are also not persistent and can't be saved. Passive mode does nothing. So is marginally usable for setup, doesn't work like it should (or does in dd-wrt). :shock: What are others seeing-does it work in passive mode without a hitch?
  17. tofu

    tofu Network Guru Member

    pion, I have no definite answers for you... Keep it if it helps. Some people tweak them and claim it's better, some don't use it and it also works fine.

    virgil, SNAT is not in this firmware. "ERROR" is an internal target afaik (like SNAT), not an error message.

    sded, afaik ap must be disabled or it doesn't scan all the channels. I have an idea how to minimize this downtime, but ap still needs to be turned off even if for only a few seconds. Expire time sets how much time before an entry is deleted between the last scan time and when it was last seen. Passive is scanning without actively poking around. It's only an option, so use whatever works best for your environment.
  18. sded

    sded Network Guru Member

    Thanks Tofu, confirms what I would expect to see (but don't). The procedure listed is the only one that works for me. Passive does nothing. Active does nothing unless I take things offline manually as mentioned. I have a very basic setup on a G4, WPA/TKIP with a wired connection and 2 wireless connections accessing the internet through a DSL bridge, DHCP connection to the WAN. There is only one wireless router visible in the neighborhood. Nothing special, yet the automatic site survey doesn't work for me. Very pleased with the firmware effort; just don't understand the (minor) anomaly. Any ideas? Thanks; Ed.
  19. tofu

    tofu Network Guru Member

    sded, I'm not sure I get your question since I thought they were covered above, but I'll try to expand on what I said if it helps...

    AP mode needs to be disabled, manually or by not using AP mode. There's no getting around it (it's a Broadcom thing). Yes it does kill wireless clients, so no you can't use it from a wireless. I do have an idea for future versions on how to make this work from a wireless client, although it will still disrupt wireless traffic... You have to remember though that site survey makes most sense when the router is in client mode.

    Active and passive are different modes, so try not to expect both to produce the same results.
  20. sded

    sded Network Guru Member

    Thanks Tofu; I understand. I was just confused about how it was supposed to work. Regards; Ed.
  21. polakatl

    polakatl Network Guru Member

    My tofu 11 problems were due to using firefox to update. I don't know if thats common knowledge, but it might be worth noting that firefox is not reliable with firmware uprgades
  22. drdivago

    drdivago Network Guru Member

    Which version of Firefox are you using, the latest official 1.5?


  23. NateHoy

    NateHoy Network Guru Member

    Interesting. My upgrade from stock Linksys firmware to Tofu 10 last week went flawlessly using Firefox 1.5. I know you had some post-installation problems, but were there any symptoms during the upgrade? Is it possible that the upgrade just didn't take the first time, or did you do repeated Firefox tests?

    What version did you use, and how many times did you try?
  24. whozyodaddy

    whozyodaddy Network Guru Member


    I am running tofu 10 on my v4, and ever since upgrading to 10 my internet seems to be going as slow as an arse. Can anybody help me? Thanks.
  25. compuworm

    compuworm Network Guru Member

  26. NateHoy

    NateHoy Network Guru Member

    I assume you've done the NVRAM cleanup or at least pushed the reset button for 30 seconds to do a memory cleaning?
  27. polakatl

    polakatl Network Guru Member

    I was on tofu 10 then did an upgrade using latest stable firefox. Tofu 11 worked for ~30min then I lost internet. I thought it was ISP but when I hooked up to modem internet was fine. I then tried to do tofu 10 again using firefox and when i hit update it said something about no data and then upgrade bar wen through a couple times until timeout. Did this a few times with the same results. Next i tried linksys firmware with firefox and same thing happened. I then tried IE with linksys and everything worked. I decided I want tofu 11 no matter what so i used IE to flash tofu 11 and everything works fine now.

    Basically i'm not gonna use firefox to upgrade firmware any more. It worked a bunch of times but recently it has failed me.
  28. NateHoy

    NateHoy Network Guru Member

    Odd. But good information - THANKS.

    I am running Tofu 10, and haven't upgraded to 11 because I have a WRT54G V4 and there are no changes to Tofu that affect my router. So I obviously haven't run into the problem you have.

    Was this Firefox 1.5 or one of the 1.0.x releases?
  29. sollie

    sollie Network Guru Member

    I have the same problems with tofu 11, internet connection lose:
    I diasbled encryption, enables mac filtering (litle more safe) and enabled isolation (people cant access your pc within the same network (also for safety).

    It workt for me this way.

    PS: the problem is because the wep or wpa i think

    WRT54G v2: tofu11
  30. polakatl

    polakatl Network Guru Member

    ^^ yeah i can't get encryption on my wireless either. I have two wireless laptops and one works with one encryption and the other with the other type, but they can't both work on one way like WEP.

    firefox 1.07... I just checked mozilla and noticed 1.5 is final now. upgrading...
  31. whozyodaddy

    whozyodaddy Network Guru Member

    I'll look into that...

    Yep, I did that. I did both actually.
    2.Upgrade firmware
  32. squallcn

    squallcn Guest

    it's toooooo slow to downloading it from my computer,and i must restart from 0% if i lost the connect.but it's allways happend. -_-

    now what another site have the same file yet? tell me please ..thanks for your help .

    :sadbye: :sadbye: :sadbye:
  33. pharma

    pharma Network Guru Member

    Here is another mirror for Tofu 11:
  34. envoid

    envoid Network Guru Member

    Tofu, upgraded my WRT54G v1.0 without any issues except the WAN link died after adjusting all the settings again (upgraded, nvram clear & fact rest, changed settings) but it came back after a reboot. Also, FF 1.5 is fine in uploading the firmware. Did it here and am running on tofu11 now. Seems to be a little quicker than HyperWRT 1.3 but I'm only 15mins in now. :thumb:

    I did have a question about the LAN/WLAN/WAN tx/rx statistics. How often does it update this? At first it wasn't showing any usage (1 min in) even though I went to my homepage, but looking again it's showing stats.

    Tofu, thanks again!!! :clap:
  35. jedi69

    jedi69 Network Guru Member

    I just upgraded from a G to GS and put tofu on it by mistake. What can I do to get back to a GS firmware. Tofu is on the router now, but I can't upgrade the firmware to anything but tofu, they all fail to upgrade. I can get into the router and all, it is just that the GS firmwares always fail. I have also tried the tftp methods as well. Any ideas?
  36. Thibor

    Thibor Super Moderator Staff Member Member

    jedi: load dd-wrt on it and then the GS fw
  37. jedi69

    jedi69 Network Guru Member

    Thanks Thibor that worked after flashing dd-wrt generic. I was try the dd-wrt gs firmware prior.
  38. ViperGX

    ViperGX Network Guru Member

    I have a litle problem with STA mode. I have WL54GL and when i set STA mode the Ap cannot conect to network, when i check device list there is only br0. WET mode work fine. How should i set the STA mode to work ?
  39. helldriver

    helldriver Network Guru Member

    Hello People,

    at first sorry for my bad english it will be better if i can write in german.

    Tomorow i will become my new router a Linksys WRT54gl, now my question is what firmware is the best for that guy? Can i flash the Tofu firmware or what is the better opinion?
    I will use the router for 3 pcs and there is no WLAN, all pcs are wired.

    There will be some websurfing and sometimes a bittorent or emule download.

    Thanks you very much for your work.

    Helldriver from Germany.
  40. NateHoy

    NateHoy Network Guru Member

    helldriver -

    Any current aftermarket firmware will give you the tools you need to fix BitTorrent problems with the factory Linksys firmware.

    I recommend Tofu 12 because it is very much like the factory firmware, so it's not a huge change to go to it. I have been using Tofu 10 and was running and stable for over 31 days. I only reset my router today to load Tofu 12. Since going to Tofu, my router has never had the slightest problems, and I run BitTorrent, multiple VPN clients, and a Vonage VoIP phone line on it.
  41. helldriver

    helldriver Network Guru Member

    so thank you NateHoy but where i can get the tofu 12 from?

    So long Helldriver!
  42. NateHoy

    NateHoy Network Guru Member

    Tofu's site:

    Be sure to read the README on the site.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice