Tomato 1.07, WHR-HP-G54, can't flash, help please.

Discussion in 'Tomato Firmware' started by brjoon1021, Aug 1, 2007.

  1. brjoon1021

    brjoon1021 LI Guru Member

    This is a fresh install, brand spanking new router, Win XP SP2

    I just tried to flash the tomato firmware and the installation or flash is going pretty pretty badly. I went through the steps:
    -pushing the reset button on the router
    -plugging the computer into one of the LAN ports with a cable
    -going to the control panel to make the TCP/IP settings just as the tomato instructions say (static).
    -unplugged the router and plugged it back in waiting for the diagnostic light to turn off.
    But...When I double click on the whr_install.bat file, I get this black cmd.exe window that repeatedly says:

    Can't read from local file tomato.trx

    over and over again very quickly, endlessly.

    If I run "tftp -i put code.trx", I see the quickest flash of the black command screen and then it is gone.

    the firmware is not getting flashed. I do have a working router, but it is using whichever version of Buffalo firmware that came with it. can you help ? I would just as soon install dd-wrt, but those instructions look a lot more complicated. The tomato instructions are too sparse IMHO, on the other hand.

  2. ifican

    ifican Network Guru Member

    Sounds like timing is just a bit off, though i have not done a buffalo and tomato. DD-wrt went on pretty easy but what i used for timing is a continuous ping in another dos window. Start your ping, before rebooting then unplug the power and watch the ping drop, plug it back in and as soon as it starts to ping again (no matter what the diag light is doing) start the tftp session.
  3. brjoon1021

    brjoon1021 LI Guru Member

    I am kind of little further along the process now. Now I at least get some kindof message:
    timeout occurred
    timeout occurred
    over and over again in the cmd screen.

    Why are the tomato instructions so lame ? There are a lot of steps or concepts left out. When what is plugged in where is totally absent. I don't know when the router should be powered up, when down, when the ethernet cable is to be plugged in , etc...
  4. ifican

    ifican Network Guru Member

    You plug everything together and leave it, then start your ping in one dos window, unplug replug and when the ping starts answering again start your tftp, its as simple as that.
  5. brjoon1021

    brjoon1021 LI Guru Member

    Thanks, but I don't understand the last part:
    "and when the ping starts answering again start your tftp, its as simple as that".

    There is a file called whr_install.bat. When do I double click on that ? As far as I have any idea, doubleclicking on it starts the ping so I don't know how to start the ping firts and then start my tftp. I assume that starting the tftp means to double click the whr_install.bat file.
  6. GeeTek

    GeeTek Guest

    With your router powered up and the PC with the static IP, are you able to log into the factory firmware at or ping ? If yes, then you need to un-plug the router, start the batch file, then read and follow the on screen directions in the batch file. It will tell you exactly what to do and when, and it will flash the router perfectly every time with no possability of missing. It is the simplest flashing process of any flashers out there.
  7. ifican

    ifican Network Guru Member

    I suppose this goes back to never having had to flash tomato to a fresh buffalo router. Good to know..... though can you not still flash it via tftp?
  8. GeeTek

    GeeTek Guest

    Yes, the conventional tftp process works fine also. The tomato batch file that comes with Tomato has some fancy DOS options to control timeouts, and honest to god, the thing simply does not miss. I use the Tomato flasher for other firmwares because it works so well. It is better than the Linksys TFTP utility, which will miss sometimes if there is no switch between the PC and the radio. The Tomato batch file is on it's toes toes so well that it flashes at the very last possible moment and you never even need a switch. You should really have a look at it. It's a work of art.
  9. brjoon1021

    brjoon1021 LI Guru Member

    No, I can not login to with my NIC set to that static IP. I can do it as soon as I go back to the NIC and change its properties to DHCP.

    The tomato instructions say to set the NIC to
    IP of
    mask to
    and gateway to

    After I do that and click OK, I can't access the buffalo firmware at that address.

    as an aside, this is the hardest damn thing I have ever tried to do on a computer.
  10. GeeTek

    GeeTek Guest

    When you are set for DHCP and are able to log into the router, what address are you using to log into the router ? Is the router address still ? You can open a command window and type ipconfig to get the gateway address. That will be the router address, and should also be
  11. brjoon1021

    brjoon1021 LI Guru Member

    I can't log into the router control panel at all now, neither DHCP, nor as static for the IP
  12. GeeTek

    GeeTek Guest

    For us to keep this in perspective, would you please tell us what the next most difficult project was and the simplest project was that you have ever managed to successfuly accomplish ? :eek:
  13. brjoon1021

    brjoon1021 LI Guru Member

    Yeah, I have installed and tweaked 30+ different versions of Linux.

    As for what went wrong and why I had to put my brand new $85 router in yesterday's trash, I will be very clear.

    The frigging whr_install.bat that is supposed to be such a work of art "wait two minutes" and also "press any key to continue". I have installed dozens of apps, flashed several motherboard bioses and they all depend on computer speed. The faster the computer, the faster the installation/flash that says, "this may take several minutes" is accomplished. In other words, it may not take several minutes, but several seconds if the computer is fast. So, I pushed any key to continue.

    When the tomato cmd screen says to wait two minutes and right below that says press any key to conitinue - that is confusing. Apparently, I had to wait two minutes before I pressed any key to continue because when I pressed a key the cmd interface went away and the flash f#$%#d up and I lost my router. I spent at least 4 hours figuring out what happened.

    The dd-wrt instructions are on orders of magnitude better. I wish that I had flashed it instead.

    Absolutely nothing that I will gain form Tomato or dd-wrt is worth the time, hassle and stress, not to mention the $170 that I now have in this router when compared to just leaving it alone and using the Buffalo firmware.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice