tomato 1.25 ND can't connect to modem

Discussion in 'Tomato Firmware' started by doorjam, Jul 16, 2009.

  1. doorjam

    doorjam Addicted to LI Member

    I have AT&T DSL with a Motorola modem. I have been using an Asus 520gu router with the manufacturer's firmware. It worked, but at certain times, I would lose connection with the internet over and over. The only remedy that worked was restarting the modem. I never had the disconnect problems using just the modem.

    Others say that the manufacturer firmware is buggy and tomato will solve all problems. So I installed tomato 1.25 ND with USB. The installation worked fine. The router shows that it is connected and lists the gateway as, which is the modem's ip address. The modem provides the PPOE negotiation. I think this is required because AT&T looks for the modem access code. Tomato is setup, I hope properly, as the DHCP server to receive the dynamic ip from the modem. However, I have no internet access with the router connected.

    If anyone knows the solution, I would certainly appreciate the help.

    Here is what the Overview page looks like.

    Attached Files:

  2. Planiwa

    Planiwa Network Guru Member

  3. mstombs

    mstombs Network Guru Member

    Your problem is that the modem IP address is the same range as the Router's LAN IP address. Change the router address to, for example then the OS will know which side is which.

    You will not need any special commands to access the modem gui in this half-bridge mode.
  4. doorjam

    doorjam Addicted to LI Member


    Very good suggestions. Everything is working very snappily now.
    Interesting that the Asus firmware worked fairly well with the settings that didn't work at all with tomato. But the changes suggested have seemingly cleared up all the problems and given the whole shebang a little more spunk.

    I hereby dub you both Knights of the Tomato.
  5. thor2002ro

    thor2002ro Addicted to LI Member

    probably some iptables tinkering could have fixed it here..... probably asus added a workaround
  6. mstombs

    mstombs Network Guru Member

    Yes or a combination of ifconfig, route and iptables! Maybe just the order in which they are executed.

    One possibility is just the default gateway route command. Tomato default routes to the Gateway IP, which is routed via the wan port. It is possible to assign the default route to the wan port directly without specifying the IP.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice