Tomato and Access Point

Discussion in 'Tomato Firmware' started by gulogulo, Apr 27, 2013.

  1. gulogulo

    gulogulo Reformed Router Member

    Hi All

    First post here prompted by my troubles. I have tried to do my due diligence by reading various sources and I think I have set up my tomato wireless router to act as an Access Point. These were my main resources:

    My problem is this. It seems to work for a few hours, then I can't obtain IP address from my router. I can watch my tablets authenticate and they have messages that indicated that they are trying to get IPs but they fail. Is there an obvious area for me to look at to resolve this issue? I have included screen shots of my tomato AP and the summary of the configuration of my uverse router.


  2. gulogulo

    gulogulo Reformed Router Member

  3. Victek

    Victek Network Guru Member

    Set your Tomato LAN IP in the DHCP range given by the main router. Avoid double NAT as the last link posted. Don't see nothing weird.
  4. Monk E. Boy

    Monk E. Boy Network Guru Member

    UVerse's 2Wire routers are really, um, strange. I would certainly recommend disabling wireless on the AT&T router and just using Tomato. One hiccup I know about is that the DHCP lease for the Tomato router with the UVerse modem sometimes won't renew at 50%, which means it ends up doing a full DHCP release/renew cycle. It succeeds, but this causes systems behind Tomato to not be able to talk to the internet for a couple minutes. To fix it, drop the following command into the Firewall tab under Scripts, which itself is under Administration.

    iptables -I INPUT -p udp --sport 67 --dport 68 -j ACCEPT

    In your existing configuration though you've got yourself a bit of an oddity. You have, in effect, two wireless networks but with only one DHCP server for the two networks. I imagine your devices are getting stuck when roaming between the two wireless networks for this reason. Change the two wireless network names and wireless network passkeys to be exactly the same. Then you should be able to roam between APs while staying on the same network.
  5. Monk E. Boy

    Monk E. Boy Network Guru Member

    Iif he did that he'd need to also setup a static lease (on the 2Wire) for the Tomato router, otherwise a client could DHCP its IP address and both will get knocked offline due to the address conflict.
  6. gulogulo

    gulogulo Reformed Router Member

    Wow. I will have a lot to try (and learn). I blindly set static DNS addresses to the google servers listed in the article above. IT has been working for a while. My objective is to not use the 2wire wireless so I will turn it off.

    Thanks all. I will report back again once I tinker, given all your advice.
  7. jbcdidgosir

    jbcdidgosir Serious Server Member

    Set the LAN IP out of DHCP's range. It will have no conflict with the IP assigned by DHCP server. Try.
  8. Monk E. Boy

    Monk E. Boy Network Guru Member

    Oh. I kind of remember having to setup a static DNS mapping in DNSMasq advanced options for the 2wire modem, so I could use the weird DNS name 2wire expected and go to the correct IP address. I only needed to do that if I had the WAN port on Tomato connected to a LAN port on 2Wire, otherwise I couldn't get to the 2Wire administration interface through Tomato.

    If you're just tying a Tomato router's LAN port to a 2wire LAN port then that wouldn't apply. The hiccup then is to be sure that only one DHCP server is on the network; doesn't really matter whether its 2wire or Tomato, you just need to only have one (not two or more).
  9. gulogulo

    gulogulo Reformed Router Member


    Thanks for the input so far. I am slow to try things because the AP seems to work for a while and then fails. So, I have only tried changing the LAN IP to something withing the DHCP range. I set it to and I had the same behavior. One thing that I left out of my original post was that the Tomato AP is connected to an unmanaged switch. I plugged the Tomato AP directly into the U-Verse 2Wire Router and it seems to be working. I am not sure what this means. Just because I would like to be able to use it being plugged into the switch, is there some special care that needs to be taken when doing so?
  10. Monk E. Boy

    Monk E. Boy Network Guru Member

    It's possible the switch is, well, junk. The good news is 8-port 100Mb switches are available for <$10. I've been pleasantly impressed by the Monoprice desktop switches.
  11. gulogulo

    gulogulo Reformed Router Member

    Thanks. Seems to be the case since it now works. The switch was a TRENDnet TEG-S16DG. I look into the Monoprice desktop switches.
  12. gulogulo

    gulogulo Reformed Router Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice