Tomato and WRE54G?

Discussion in 'Tomato Firmware' started by ggravier, Aug 19, 2007.

  1. ggravier

    ggravier Network Guru Member


    I have a WRT54G... was working nicely in collaboration with a WRE54G to extend its range... and Tofu firmware. I replaced Tofu by Tomato 1.07 (as I did on all my other WRTs)... but now the WRE doesn't want to do it's extension role anymore.

    Has anybody succesfully used a WRE54G to extend the range of a WRT54G running Tomato? Any specific settings I may have missed?

    Thanks in advance,
  2. nathan7

    nathan7 Network Guru Member

    Just got mine working...

    I just dug out my WRE54G and after an hour of screwing with it, got it working. In Tomato on the main router (WRT54GS) I have my security settings as WPA/WPA2 with TKIP/AES. I had to make it channel 1 as the WRE54G's web UI is so buggy it would not change channels.

    Power down the router and reset the WRE54G to defaults, then plug it in and connect to it. You will have to set your PC's IP to and gateway/router set to (the WRE54G). With your browser connect to and enter admin as the pass, no user.

    Set the Name if you wish. Set the SSID identical to your router's. Save and let it reboot. Now set your wireless to connect to the new SSID and browse to again.

    Set Wireless Security to Enable and click Edit Security Settings.

    Set Security Mode to WPA Pre-Shared Key and WPA Algorithm to TKIP. I was unable to make it work with AES.

    Enter the same WPA Pre-Shared Key as you use on your router.

    Click Save Settings and then click Continue.

    The WRE54G should reset. After several seconds, reconnect to the wireless SSID and enter your WPA key if asked.

    Browse to If all is OK, unplug the WRE54G, change your wireless IP back to DHCP or your prior static IP, then power on the router.

    Once the router is up, connect to it wirelessly and make sure it is working as before. Next, plug in the WRE54G. If all was successful, after a couple minutes both blue lights will be on.

    Good luck. Hope this helps.
  3. ggravier

    ggravier Network Guru Member

    Nope... still no go...


    OK... So I tried again. Both my WRT and WRE were on channel 6. I moved them to Chanel 1.

    They are both configured to use WEP (the WRE is a v1, and firmware is v1.5.06-EU and v1.06-USA - I tried both firmwares).

    If the WRT is the only one up, I see the internet and the WRT. As soon as I turn the WRE on, I see the WRE but nothing else (given that it's closer to my PC than the WRT, I hook up to the WRE, which is what I want).

    My current settings are:

    Channel 1
    WEP - 128 bits
    WRT IP
    WRE IP

    Again, the WRE by itself is perfectly seen by my PC... But if the PC is hooked to the WRE, then it doesn't see anything else... DHCP requests don't even go through. I have to set IP address on PC manually to be able to talk to the WRE...

    Really strange. What version WRE do you have? Hardware v1, v2, v3? Mine is a v1... Maybe incompatible with the newer firmware on the Tomatoed WRT...

  4. nathan7

    nathan7 Network Guru Member

    My WRE54G is a version 1. At the time of my previous post, it had the latest firmware on it. I think it was only operating in client mode. You might try version 1.04 of the firmware which lets you enter the MAC to bond with manually. It should work fine with WEP.

    Good luck.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice