Tomato Bugs / Issues

Discussion in 'Tomato Firmware' started by der_Kief, Mar 16, 2007.

  1. der_Kief

    der_Kief Super Moderator Staff Member Member

    Hi @ All,

    please report bugs/issues with Tomato here.

    Important: Before posting be sure to check the README and the FAQ's as well as the Tomato Forum !

    Use the following style:

    Tomato Version :
    Router Brand/Model/Rev. :
    Bug/Issue Description :
    cfe.bin; nvram.txt

    Workaround :

    Please reply to posts only by "Private Messages" ! If you have new findings about a bug/issue than please edit your post !
    This should be no discussion thread ! THX

    Hopefully with this buglist its easier for Jon to fix them.

  2. shadow_empire

    shadow_empire LI Guru Member

    Tomato Version : 1.05.0977
    Router Brand/Model : Linksys WRT54G
    Bug/Issue Description : Cannot upload files via WinSCP 3.8.2
    Workaround : none! except for text files: paste it in vi

    Hi this is a really annyoing isssue, but maybe not related to this firmware.
    (I have this router for one week now and still experimenting)

    When I open winscp session to my router (SCP protocoll) and browse the directories I CAN download files to my local pc (which is connected via WLAN).
    But when I try to upload a file, the destination file is created BUT as an empty file.

    This was resolved with 1.06
    *Fixed scp to router not working.

    Another issue:
    I can not connect to my router from outside via ssh. Is there some portforwarding I have to install?

    This can be done under administration->admin access -> enable SSH daemon and allow remote access !

    thx for any help!


    I already enabled ssh daemon and I can access my router via ssh (directly connected via wlan).
    BUT I a cannot access the router from outside my LAN. So I think I have to setup some port forwarding?
    But maybe it is a problem that I did not delete th NVRAM after the firmware installation.
    I will try this evening with the new released firmware 1.06...

    I installed the new firmware 1.06.
    SCP to linksys is working now.

    But I still can not access my router via ssh from outside my LAN.
    Any idea?
    Some port-issue?
  3. GhaladReam

    GhaladReam Network Guru Member

    I believe I may have found a small issue with Tomato 1.06. Prior to 1.06 this had not been a problem.

    I use a custom script I got off Thibor's website that makes it so that the SES led is lit amber when a wireless client is connected, and white when wireless data is being transmitted. This script dosn't seem to behave as it should in 1.06. Here's the init script:

    I=`nvram get wl0_ifname`
    while sleep 1; do
    if [ "`wl assoclist`" != "" ]; then
    XFER=`ifconfig $I|grep bytes`
    if [ "$XFER" != "$PXFER" ]; then
    LED="am on wh on"
    LED="am on wh of"
    LED="am of wh of"
    if [ "$LED" != "$PLED" ]; then
    led $LED
    I tried rebooting, but that didn't help. I tried restoring factory settings, clearing NVRAM, but this script just won't work the way it should anymore... It seems that the LED constantly stays lit white, even if no one is connected wirelessly and even if no data is being transmitted.

    Edit: It seems the LED stays completetly dark until the first wireless client connects (which is normal), then it remains white for the whole duration of that client's connection, regardless if data is being transmitted or not. And remains lit indefinately when that client disconnects. (it SHOULD go back to its un-lit state after all wireless clients disconnect, and simply be amber when wireless clients are connected but no data is being transmitted.)
  4. fastpakr

    fastpakr Network Guru Member

    Tomato Version : 1.06
    Router Brand/Model/Rev. : Buffalo WHR-HP-G54
    Bug/Issue Description : Channel display on client in Wireless Ethernet Bridge mode

    When a device is connected in Wireless Ethernet Bridge mode, the channel selection option is still present, despite being irrelevant. No matter what channel is selected, the client will still connect to the AP with the strongest signal on the matching SSID. Recommend eliminating the selection option in WEB mode.
  5. pdampier

    pdampier Guest

    VPN not allowing remote LAN web access

    Tomato Version : 1.06
    Router Brand/Model/Rev. : WRT54GS v1
    Bug/Issue Description : IPSEC VPN not allowing remote LAN web access
    Workaround : None

    When I VPN into work with Tomato I cannot access work WEB URL's.

    For instance:

    \\server_share - works


    http://website_name does not

    The web site seems to resolve to the DDNS IP I'm registering. I register with for say The web URL above will be resolved to versus the local VPN LAN's name....

    Accessing regular SMB shares works per above.

    Also I've noticed the once VPN'd in I can still type and access the Tomato firmwar - previously when VPN'd in this was not possible (Linksys firmware)....


    I think this may have been due to having the default "Allow NAT Loopback" option selected.

    I disabled that, turned off "Use Internal Caching DNS Forwarder" and my DDNS Settings and the VPN started working for internal sites. I then re-enabled both the caching DNS option and DDNS and its still working....
  6. Odin-60

    Odin-60 LI Guru Member

    "Routing Mode" collides with WDS

    Tomato: Version 1.06.0981
    Router model: WRT54GL
    Description: various strange effects in WDS mode
    Workaround: Set Routing Mode to "router" rather than "gateway"

    I wanted to set up a WDS bridge between two routers #1 and #2.
    Router #1 is a WRT 54Gv3.1 w/ Tomato 1.06, running flawlessly
    as my DSL gateway and WLAN AP.

    The actual problem would affect router #2, a WRT54GL. As to
    its configuration, I followed the advice provided under
    The only difference is, that I configured #2 as "WDS" rather
    than "AP+WDS", because I need no wireless clients at #2.

    WDS connection between #1 and #2 came up as expected,
    and bridging seemed to work perfectly at first glance. However,
    when I telnet'ed into #2 and tried to ping anything in the local
    subnet, for example #1 (, I got the following result:

    # ping
    PING ( 56 data bytes
    ping: sendto: Operation not permitted


    Also, router #2 would never get the correct time, even though
    I had entered a valid ntp server address. Very strange...

    Finally I opened the web GUI of #2, page "Advanced/Routing",
    and changed the "Mode" from "Gateway" to "Router".
    Result: the above problem went away!

    Now I'm asking myself, why the routing mode matters at all,
    when the WAN is already "disabled". In that case, the
    routing mode should be ignored. And, of course, WDS should
    work out-of-the-box, i.e. without any need to change a
    setting that has -- seemingly -- nothing to with the chosen
    mode of operation.
  7. MadPriest

    MadPriest LI Guru Member

    Tomato: Version 1.06.0981
    Router model: WRT54GL v1
    Description: since Tomato version 1.04 once in 3-4 days none of the wireless clients can connect
    Workaround: None

    The only thing that solves it (for the next 3-4 days) is physical reboot :(
  8. windsurfer

    windsurfer Network Guru Member

    Loaded Tomato 1.06 on some very old hardware today and had problems. It is a WRT54G version 1. This is the old 5 volt version.

    It comes up and I can connect to it wireless but it will not connect with a wire. The computer thinks something is connected to the wire but it does not receive a DHCP address or allow any traffic.

    I have now loaded Tomato twice once loading it over the wire and the other time loading it over the wifi. Either way it comes up correctly after a reset on the wifi side. It will not connect via the cable.

    The software that was on the machine was DD-WRT V23 if that makes a difference. The LAN ports work just fine running DD-WRT.

    Any ideas?



    I just tested a WRT54G version 2 and it works correctly. It appears that Tomato 1.06 does not work correctly on version 1.

  9. Mike

    Mike Network Guru Member

    Ping from LAN port waits for WDS

    I just noticed a bug in Tomato 1.06. I have a WT54GL running Tomato 1.06. It is running WDS in a point-to-point mode to another WRT54GL. The WDS wireless link was running poorly (i.e. low bandwidth). If I ping the LAN port (from a 100Mbit LAN), the ping times were very long (equiv to <.5 mbit/second bw). I discovered that the ping times (for large size pings) was determined by the bw of the WDS link not the LAN, even though the ping should never traverse the WDS link.

    I suspect the ICMP response packet is being sent on all links, but I'm just guessing.
  10. Odin-60

    Odin-60 LI Guru Member

    Tomato: Version 1.06.0981
    Router model: WRT54 G + GL
    Description: WDS is lost after reboot

    Two routers (#1 and #2) connected via WDS.
    #1 is WRT54G, wireless mode is "AP+WDS".
    #2 is WRT54GL, wireless mode is "WDS"

    After #1 was rebooted via the web GUI, the WDS connection
    was broken and did not come up again. In the device list of
    #1 a device named "wds0.49153" was shown, but any attempt
    to ping the ip address of #2 would result in "Host is down.".

    Only after #2 was rebooted, too, the WDS connection started
    to work again.
  11. devilkin

    devilkin LI Guru Member

    Tomato: Version 1.06.0981
    Router model: Linksys WRT54G 2.1
    Description: DHCP to Mac/Linux based machines doesn't work

    I cannot get the Tomato-powered WRT54G to hand out IP adresses to my macbook or any linux box, not over WiFi, nor wire connections.

    The WRT gets the DHCP DISCOVER, sends out an OFFER but this is never received by the mac/linux machines - checked with tcpdump & wireshark/ethereal on the mac / linux boxes.

    I can reproduce this behaviour constantly, and this is not an issue with other firmwares (DD-WRT v23SP2)

    If the WRT sends out the offer, and the mac never receives it, how is that a wrt problem?

    Did you read the last line of his post?

    Yes, but his post does not make sense. If the wrt is sending out the packet, it's up to the OS to grab it, not wrt.

    Now, if the packet is corrupt, then yes, that is wrt's fault.

    True, yet it has to do with the Tomato firmware - it does not occur with DD-WRT. I just don't see any incoming packets with tcpdump. I'll check tomorrow with ethereal to see 1. if i see them and 2. if they're valid.

    -- EDIT --

    Further testing: loaded a working windows box with an ubuntu live-cd - system is unable to get any address over DHCP. I've also checked with wireshark/ethereal, I don't see anything coming back from the router.
    Just tested dhcp on a spare router I have (loaded with dd-wrt v23sp3 beta), works.

    There are no notable differences in the ddnsmasq config file. The only difference I can see is that dd-wrt uses dnsmasq 2.35, and depends on
    Whereas tomato uses 2.38. I tried loading 2.35 on the tomato, but it just segfaults. Is there a place where I can get my hand on 'just' the older binary of dnsmasq for tomato?

    It seem as if I can confirm devilkin's bug report.
    See this message.


    I got in contact with Jon, and it seems it all had to do with enabling NAT Loopback in my router. Now Linux gets an IP address without a problem.
  12. devilkin

    devilkin LI Guru Member

    Tomato: 1.06.0981
    Router model: Linksys WRT54G 2.1
    Description: WiFi doesn't always start at bootup / gets disabled after a while

    If I power on the router, and only after a while want to connect using WiFi, the wifi doesn't work. The interface of the router sees no clients, WDS doesn't work, my laptops don't see any access points.

    Powercycling always fixes the problem (rebooting doesn't seem to help)

    -- EDIT --

    I have tried re-keying all settings, and clearing nvram, and reflashing.
  13. Kibe

    Kibe LI Guru Member

    Well, have some rebooting/freezing issues on a WRTSL54GS v1.1 running Tomato. Same unit runs more than 15 days with HyperWRT Thybor 17rc3 withou any issue.
  14. larsrya8

    larsrya8 LI Guru Member

    Did both of you clear the NVRAM and manually re-key all your settings each time you flashed a new firmware?
  15. Damiani

    Damiani LI Guru Member

    Tomato: Version 1.06.0981
    Router model: WRT54GL v.1.1
    Description: Many many connections from google


    That's strange :confused:
    Even i close the browser - connections still active :frown:
    When this connections are active the internet runs slowly....

    Under conntrack you need to increase the number of connections to 9999 and reduce the values for connection times. There is a good thread in here somewhere that has some examples of shortened timings. I can't seem to find it right now. It will make your expired connections time out much sooner and leave resourses available for new connections.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice