Tomato builds for ASUS RT-AC66U

Discussion in 'Tomato Firmware' started by electrocaine, Feb 1, 2013.

  1. DanTheManu2y

    DanTheManu2y Serious Server Member

    One thing I've noticed so far with my AC66U is that the ports are reversed for vlan
  2. sparks305

    sparks305 Reformed Router Member

    Thanks, I got it shortly after I realized I didn't clear nvram and reboot after flash.
  3. DanTheManu2y

    DanTheManu2y Serious Server Member

    is there something special that has to be done to show 80MHz bandwidth?

    I only see 20/40 on the 5GHz band
  4. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Erase NVRAM after flashing, select EU in advanced wireless settings.
  5. lefty

    lefty Networkin' Nut Member

    Should be in the administration subtab, but i'm not sure it works with this unit or not.
  6. Huang

    Huang Reformed Router Member

    Hi Shibby Thanks for all your awesome work! I've just tried your latest build,Everything is great,but when i enable stealthMode,All led light is disable without 5ghz led.I think this is a bug.
  7. Huang

    Huang Reformed Router Member

    Hi Shibby Thanks for all your awesome work! I've just tried your latest build,Everything is great,but when i enable stealthMode,All led light is disable without 5ghz led.I think this is a bug.
  8. shibby20

    shibby20 Network Guru Member

    @Huang - correct. I will fix it.

    @DanTheManu2y: jffs is not supported by AC66u (not yet)
  9. RMerlin

    RMerlin Network Guru Member

    Want code for this? :)
  10. shibby20

    shibby20 Network Guru Member

    not supported in tomato ;) I have you code RMerlin. Thx. But as you remember mtd partition is wrong detected by tomato :/ well i have to disable jffs suport for now. Manually i`m able to mount jffs.

    I must figure out where is the problem.
  11. GreyFox

    GreyFox Reformed Router Member

    It is very hard to add FastNAT support?
  12. shibby20

    shibby20 Network Guru Member

    maybe not very hard but we will have to disable a LOT of tomato features like QoS, BW Limiter, IP Traffic, BW Monitor and Web usage. :)
  13. GreyFox

    GreyFox Reformed Router Member

    And what about to make a button to switch to FastNAT (disable other features automatically) and back?
  14. RMerlin

    RMerlin Network Guru Member

    I remember now... Unfortunately I don't have much free time these days to take a closer look at what could be the issue.
    Elfew likes this.
  15. haarp

    haarp LI Guru Member

    I've been using Shibby's Tomato on my AC66U for a few days now and I must say that it's working quite well. It doesn't even crash randomly like my old TomatoUSB did. Thank you!

    I do however notice some bugs here and there. I took the time to write them down as I noticed them.

    1) Route Modem IP seems broken. I tried giving it (router is, but I get no response on that IP. I used to use Iptables rules for that before, but those also stopped working.

    2) The device list sometimes displays broken values. Wrapping unsigneds?

    3) QoS "Transfer Rates" also sometimes displays broken (very high) values. Also, this screen really needs some indicator about the units used (it appears to be KB/s, I think)

    4) QoS "View Graphs" shows an empty outbound chart when WAN reconnects. This can be fixed by restarting QoS (e.g. by saving the settings under "Basic Settings"), but it will break again when WAN reconnects.

    5) QoS "View Details" swaps the source and destination when a connection originates from the router itself

    6) I'm using a PPPoE to a DSL modem. When my connection fails, I have to wait around 5 minutes for the timeout to occur on my ISP before I can reconnect again (The Tomato logs also don't tell me why, I had to hook up another machine to find the answer - "session limit exceeded")

    Tomato should disconnect properly prior to terminating pppd, rebooting, etc. It is not very clean to simply kill the service.

    7) Saving the BW limiter hangs up the modem. Is this necessary? Sounds like a bug to me.
  16. dtyxx

    dtyxx Serious Server Member

    That's got it working. Thanks, man!
  17. dtyxx

    dtyxx Serious Server Member

    Shibby, this is excellent work. I can now finally replace my E3000 (running one of your builds) with my AC66U. My ISP provides native IPv6 and I couldn't get the Asus stock firmware to work (all its IPv6 stuff seemed to expect tunnels, not native). Your Tomato build just works seamlessly. Thank you so much for your work.
  18. shibby20

    shibby20 Network Guru Member

    nice to hear this :)
    Sid10 likes this.
  19. Rene Popken

    Rene Popken Networkin' Nut Member

    Shibby, thank you very much for the excellent builds.
    I bought the router to replace an old WRT54GL which has been running Tomato firmware since ages and discovered that the VLAN support of the standard ASUS firmware, the Merlin builds en DD-WRT builds in the GUI were not working on the Asus.
    There ars some command-line work-arounds, but they are too technical for me.
    Your firmware works flaweless with VLAN's which are very easy to setup.

    For 5GHZ channels i can only select the lower bands (40 and 48, upper) with te latest build. My country is set to EU (I live in the Netherlands).
    They work fine and i have no problems with it.

    I will replace the WRT54GL with the Asus as my main router very soon.
    Thank you angain and keep up the good work.
  20. kthaddock

    kthaddock Network Guru Member

    And now "source code" Version
  21. marcus13

    marcus13 Networkin' Nut Member

    It's very stable for me, with both WiFi bands going, including the 5ghz led which was not active on the previous build. Regardless of which country I pick I still only get 20 and 40mhz choices; yes I tried a reset to defaults but it didn't fix it. 80mhz did appear at one point but I couldn't set the channel (only listed Auto) and now it's gone.

    I'm hoping that the Australia option will enable 80mhz at some point; it's the correct one for me to use and opens up a whole lot more frequency options.

    Great work!
  22. kthaddock

    kthaddock Network Guru Member

    Have you tried to set country to EU?
  23. dtyxx

    dtyxx Serious Server Member

    I have a similar issue. I'm in the UK and it took 4 or 5 goes to get the 5GHz radio to change from EU to UK. Once it did, I didn't have the full range of channels available (i.e. all the 100+ ones were missing). And now I've just looked again, my only choices (with 80MHz channel width) are Auto and channel 40.

    Something's not quite right there!

    Still, Auto does a perfectly good job and I can't see any other 5GHz stations from here, so I guess hand-picking a channel for least interference isn't really a big issue for me!
  24. Monk E. Boy

    Monk E. Boy Network Guru Member

    If you read the thread you'd see shibby's build only fully supports 5Ghz when the country is set to EU.
  25. marcus13

    marcus13 Networkin' Nut Member

    Yep, and I'm saying that even when it was set to EU, it didn't show the options I expected. I'll see how the next build goes. So yes, I *had* read the thread.
  26. Monk E. Boy

    Monk E. Boy Network Guru Member

    Oops, I was actually directing my sleepless bleary-eyed grumpiness towards dtyxx. He changed his region from EU to UK and is having problems...
  27. dtyxx

    dtyxx Serious Server Member

    I too had read the thread. Every single day until a 5GHz, 80MHz build was released. And, like marcus13, I see the same issues with EU too.

    As a developer myself, I find it useful for people to report problems even if they're already known as they may contain extra information which makes tracking them down easier.
  28. Monk E. Boy

    Monk E. Boy Network Guru Member

    Please point out the part where you stated you were having the same issues in EU.

    Personally, as a 20+ year veteran of numerous software developers, I find that valid, detailed notes are helpful in tracking down bugs. Bug reports along the lines of "I switched to an unsupported configuration and it stopped working" always get immediately closed by every developer I've ever worked with.

    I assume you've tried to clear NVRAM and set everything up from scratch using the GUI (not a configuration file) under EU and didn't just flip from UK to EU?
  29. cpxazn

    cpxazn Reformed Router Member

    I was able to see the channels in the 80mhz drop down after making following changes in Advanced->Wireless.
    CTS Protection Mode: Auto
    Country / Region: UNITED STATES
    DTIM Interval: 3
    Frame Burst: Enable
    Overlapping BSS Coexistence: On

    If I keep Channel on Auto, it automatically changes to a lower Channel Width, so be sure to pick a specific channel.

    This is what it shows me in Overview
    Channel 40 - 5.200 GHz
    Channel Width 80 MHz
    Interference Level Acceptable
    Rate 300

    Rate is probably at 300 because I'm still on N
    Last edited: Aug 22, 2013
  30. dtyxx

    dtyxx Serious Server Member

    Man, you really have got a bee in your bonnet haven't you? Perhaps you could stop being so aggressive?

    1) I never said I was having the issues in EU in my initial post. I never claimed to have said such a thing either. My post was primarily about the fact that I had to select UK 4 or 5 times before it finally stayed on that setting. That's got nothing to do with what channels are available, whether UK works, etc. It's just about the fact that having changed from EU to UK, hit save and then hit F5, I was still in EU mode. And then suddenly, UK mode stuck. Seems to me like a bug that nobody else has mentioned and I thought reporting it might be useful.

    2) Having got UK mode working, I wasn't expecting the full range of channels. But I pointed out that the choices I had varied depending on whether I selected 20/40MHz channel width compared with 80MHz channel width. I don't believe anybody else had mentioned this, so I thought reporting it might be helpful.

    3) You will notice that I never actually asked for any help, or complained, or anything. I was merely reporting behaviour as I observed it because I thought reporting it might be helpful.

    4) Yes, I cleared the NVRAM and set everything up from scratch using the GUI - just as the standard instructions have been for flashing custom firmware for as long as I can remember.

    5) Please let me know what software you develop so that I can ensure I never go anywhere near it, because if this is the way you treat users' attempts to be helpful then I don't want to have anything to do with your software. If my bug report had been "I tried something someone else already tried and got the same result", then fine. But I don't believe it was. If I was as aggressive with my customers as you have been with me, I'd have been fired decades ago.

    Shibby, I apologise if the information I've given wasn't very helpful to you as "Monk E. Boy" appears to believe. Let me state again how grateful I am for your work and for allowing my to use my new router in native IPv6 mode.
  31. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Monk E. Boy recently suffered a personal tragedy. Cut him some slack. We're all people with outside lives and outside stresses. As people, we're sometimes not at our best.
    mito, koitsu and dc361 like this.
  32. Monk E. Boy

    Monk E. Boy Network Guru Member

    My point was that we know that this build only works properly in EU mode. Changing it to any other zone and reporting bugs related to that change is less than helpful, because bugs are known to occur... which is why we were told to run in EU.

    I come from a professional background where testers are actually paid to test, and I can assure you that when testers repeatedly failed to follow developer instructions they were fired for it. You have your testing criteria and you test within those criteria, because when you move outside those criteria bugs are known to occur so it's not helpful to report them.

    The funny thing about free software is it tends to attract more lackadaisical approaches, which tends to irk me because these guys are doing it for free in their spare time, which in my mind means we should work harder to not waste their time.
    mito likes this.
  33. dtyxx

    dtyxx Serious Server Member

    Which is exactly why my post wasn't about (and didn't mention) stuff not working outside of EU mode. It was about the act of changing from EU mode to UK mode. I didn't expect stuff to work when I got there. Two completely separate things. "Hey guys, I'm totally awesome and I got non-EU working!" "But Shibby, we can't switch out of EU mode using the GUI!" "Well, why the hell didn't any of you mention it before?"
  34. Cumulonimbus

    Cumulonimbus Networkin' Nut Member

    How do you set it up?

    I set up my two routers with a startup-script like this commands:

    nvram set wl1_country_code=US
    nvram set wl1_country=US
    nvram set wl1_channel=56
    nvram commit
    wlconf eth2 down
    wlconf eth2 up

    This works for me, but the signal strength is very poor and the transfer rate also.

    I Need the upper channels. 36-48 are full with some 5GHz WLANs. :-(
    Last edited: Aug 24, 2013
  35. GreyFox

    GreyFox Reformed Router Member

    Can anyone tell me please, how can i limit the internet speed for specific IP in Merlin firmware?

    I tried to paste the file services-start into jffs/scripts and run command chmod a+rx /jffs/scripts/services-start but nothing happend!!!

    services-start file:

    TCA="tc class add dev br0"
    TFA="tc filter add dev br0"
    TQA="tc qdisc add dev br0"
    SFQ="sfq perturb 10"
    tc qdisc del dev br0 root
    tc qdisc add dev br0 root handle 1: htb
    tc class add dev br0 parent 1: classid 1:1 htb rate 77777kbit
    $TCA parent 1:1 classid 1:10 htb rate 2kbit ceil 222kbit prio 2
    $TQA parent 1:10 handle 10: $SFQ
    $TFA parent 1:0 prio 2 protocol ip handle 10 fw flowid 1:10
    iptables -t mangle -A POSTROUTING -d -j MARK --set-mark 10
    TCAU="tc class add dev imq0"
    TFAU="tc filter add dev imq0"
    TQAU="tc qdisc add dev imq0"
    modprobe imq
    modprobe ipt_IMQ
    ip link set imq0 up
    tc qdisc del dev imq0 root
    tc qdisc add dev imq0 root handle 1: htb
    tc class add dev imq0 parent 1: classid 1:1 htb rate 77777kbit
    $TCAU parent 1:1 classid 1:10 htb rate 2kbit ceil 2kbit prio 2
    $TQAU parent 1:10 handle 10: $SFQ
    $TFAU parent 1:0 prio 2 protocol ip handle 10 fw flowid 1:10
    iptables -t mangle -A PREROUTING -s -j MARK --set-mark 10
    iptables -t mangle -A PREROUTING -j IMQ --todev 0

    What im douing wrong?
  36. sysnetarea

    sysnetarea Reformed Router Member

    I'd like to install the newest version on my RT-AC66U. Everytime I try to install I get a error message. I'm on Mac OS X (Mountain Lion). Instead I'm running Merlin now but I want to use ARP. Can someone help me? Please let me know if you need some more information. Thank you guys in advance.
  37. sysnetarea

    sysnetarea Reformed Router Member

    I guess it's not working with a virtual machine. Do I have this right?
  38. humba

    humba Network Guru Member

    After upgrading (had to install merlinwrt first to get the restore working), I wanted to start configuring. Started with WLAN first, and found that no matter what change I made, I was getting a wl_something value invalid - please report this. I didn't write down the actual variable but it sounded like it's the wpa key.
    Since I never did a full nvram reset, I then did that, and after the reboot, my 5GHz WLAN is gone altogether from the GUI. SSH'ing into the router tells me WLA1 is still up and running, but configuring via ssh isn't quite my cup of tea.

    Any suggestsions? I'll probably go back to merlin for the time being.

    @edit: I forgot to mention... eth2 is not there anymore in linux either.
  39. dtyxx

    dtyxx Serious Server Member

    I just changed the country from the UI. Changing from EU to UK took several attempts. However, as mentioned above, there are several known issues when not using EU mode. In particular, many of the channels won't be correctly listed. And since this is precisely what you want, I would recommend either sticking with EU mode or else sticking with the stock firmware (or Merlin, or whatever) for now.

    It's funny - I live in a town in the UK (not known for being a low-density place) and I can't see a single other 5GHz network. In fact, I can barely see my own in some parts of the house. And bear in mind that just because there are other networks around (even on the same channel), it's not necessarily going to have too bad an impact on your network.
  40. Cumulonimbus

    Cumulonimbus Networkin' Nut Member

    Okay, for now i use Merlins Firmware on tne primary AC66. On the second AC66 are now Kong_ac-DD-WRT installes. Conect to primary AC66 via Client Bridge works fine. But overall, Tomato is the better OS and i will wait the Time, if Shibby has successfulls integrates 5GHz for all international Users. So, Shibby. If you will have any donations, tell us now. :)
    Some bottles of Wine or Beer for long codiing nights? :) Thanks for your hard working.
  41. Malitiacurt

    Malitiacurt Networkin' Nut Member

    Probably more beneficial/useful to post in a forum dedicated for Merlin's Asus firmware.
  42. Cumulonimbus

    Cumulonimbus Networkin' Nut Member


    Bugreport: Tomato Firmware 1.28.0000 MIPSR2-112 K26 USB AIO-64K

    I have configured a secondary AC66 as Wireless Ethernet Bridge at 5GHz and changed the Changed Country / Region to United States. Now i can succesfull connect to a primary AC66. But before i can use 80MHz-Bandwidth, i must configured the 5GHz-Controller one time to Accecpoint-Mode with 80Mhz. Than switch to Wireless Ethernet Bridge and the Bandwitdh is now 80MHz.

    And a Question: Does the current Build support beam forming? If not, can i enable it manualy with nvram?
    Last edited: Aug 30, 2013
  43. sysnetarea

    sysnetarea Reformed Router Member

    Anybody out there who can help me? I'm not able to use TOMATO (coming from MERLIN). Same thing when having the original fw installed. HELP, please!!!
  44. Cumulonimbus

    Cumulonimbus Networkin' Nut Member

    Install with Asus "Firware Restoration" Tool.
  45. nmalinoski

    nmalinoski Networkin' Nut Member

  46. sysnetarea

    sysnetarea Reformed Router Member

    I would like but I'm on Mac OS X (Mountain Lion). It's not running with my virtual machine (Parallels Desktop 8).
  47. Cumulonimbus

    Cumulonimbus Networkin' Nut Member

  48. ksergey2012

    ksergey2012 Serious Server Member

    Dear Shibby20, first of all, I want to thank you for BA that favorite Tomato firmware for the router appeared Asus rt-ac66u. I would like to ask you, why do I have WAN (PPoE) connects three minutes after the router is fully rebooted, original OS Asus was not like this. And firmware is very stable! Sorry for the google translation.
  49. princenigma

    princenigma Reformed Router Member

    Dear Shibby. you firemware is rock stable !
    But I have a problem with 5G AC speed.
    My 2013 macbook air read speed is about 33MB/s with ASUS Firmware.
    After flash tomato, in EU it's 8MB/s,change to CHINA 15MB/s
    In advanced -> wireless I set all 5G parameters to default value .
    Any clue for this ? Thanks
  50. shibby20

    shibby20 Network Guru Member

    AC mode is still in work. I tested RT-AC66u with Asus card PCE-AC66 and i`ve got better speed on Tomato than OFW :)


    But i tested also Tenda W1800R with PCE-AC66 and speeds was much lower.
  51. princenigma

    princenigma Reformed Router Member

    Dear Shibby ,can you post you 5g settings including advanced settings so I can follow your setup ?
    THanks .
  52. shibby20

    shibby20 Network Guru Member




    and the result:

    cronexiler likes this.
  53. Cumulonimbus

    Cumulonimbus Networkin' Nut Member

    Does Tomato currently support Beamforming Technologie of the AC66?
  54. princenigma

    princenigma Reformed Router Member

    Dear shibby , I follow your setup, the results is this .
    Don't know why,I already set to 40 and 80 ,it still get 20.

    Attached Files:

  55. nickelfault

    nickelfault Serious Server Member

    I'm also stuck on the 20 MHz channel on the RT-AC66U. Even though I select 80, it still goes back to 20. When I change it to 80 and hit scan, it doesn't show any channels, just "Auto". Another issue I've come across is when clearing the NVRAM, I lose my 5 GHz radio.
  56. shibby20

    shibby20 Network Guru Member

    did you set country as EU? I suggest you make a backup of you settings and erase nvram. After reboo MAKE REBOOT AGAIN. After that try setup 5GHz radio and check-out channel width. If it will be correct then setup other settings manually. If it will be still wrong then restore configuration from file.
  57. princenigma

    princenigma Reformed Router Member

    I do some research, here is my steps:
    1. erase nvram reset. use nvram cmd to active 5g settings.set 5G to 80mhz
    2. check status, 2.4g show 450mb OK, 5G show 20mhz 2xxMB not OK. 5G auto scan show nothing.
    3. change country to CHINA. 5G auto scan show only one channel.
    4. check status, 2.4g show 450mb OK, 5G show 80mhz 1300MB OK.
    5. Macbook air 2013 connect to 5g ,transfer some files ,check status, 5G change to 2xxMB even 1xxMB.
    looks like there's some wirless driver problem

    and one interest thing is : when I change LAN ip from to,wifi status also half drop
    2.4g show 20MHZ ( should be 40MHZ) 216mb, 5g show 20MHZ ( should be 80MHZ) 288mb
    This is really a bug , I think .
    Last edited: Sep 18, 2013
  58. nickelfault

    nickelfault Serious Server Member

    The country is set to EU by default after flashing and clearing NVRAM. I have tried multiple changing the country to others and setting back to EU but still can't seem to get any channels to show up under the 80 MHz channel width. Setting the country to China though as princenigma outlined I can get a channel! Now I have 800 - 1300 mbps :) But still after clearing NVRAM I lose my 5 GHz band :(

    Thank you very much for your hard work Shibby, there will be a donation on it's way to you very soon.
  59. ashman5

    ashman5 Reformed Router Member

    My country defaults to US after clearing NVRAM and reboot. I've tried several solutions listed above and still see no 80MHz channels. If 80MHz is chosen, the only channel option is "AUTO". This results in 20MHz and Channel 36 to be reported in Status>Overview.
  60. shibby20

    shibby20 Network Guru Member

    [root@RT-AC66u root]$ wl -i eth2 country
    EU (EU/13) <unknown>
    [root@RT-AC66u root]$ wl -i eth2 channels
    36 40 44 48

    And what you have?
  61. LtHummus

    LtHummus Reformed Router Member

    Can someone post the md5sum for tomato-RT-AC66U_RT-AC6x--112-AIO-64K.trx? When I download it, wget wants to use text/plain mode instead of binary mode which I expect. Is there a place where these are put (or can someone who has successfully flashed the firmware post their MD5 checksum)? Thanks.
  62. PetervdM

    PetervdM Network Guru Member


    CRC32: 063233DC
    MD5: 0EEDBCFD965EF21B1288C806F8E2D06D
    SHA-1: 6740A3B3B72B7B71CE7FCE2EFD50AA08A8C0CB8C
  63. ilkevinli

    ilkevinli Network Guru Member

    I have the EXACT same problem. When I install shibby tomato using the Asus Recovery tool, it completes fine and I have both 2ghz and 5ghz bands. When I try an configure any option, I get the "wl_key is invaild" error. When I do a nvram reset, the 5ghz band disappears but the "wl_key" error is fixed. My unit is hardware version A2. Not sure if that is making a difference.

  64. shibby20

    shibby20 Network Guru Member

    one more time:
    1) erase nvram
    2) after reset DO NOT set nothing! Just rebbot router ONE MORE TIME
    3) after 2nd reboot you can set wireless interfaces.
  65. ilkevinli

    ilkevinli Network Guru Member

    Thanks shibby for posting that. I was able to get it to work following those directions. My findings are similar to what others have posted. I'm just going to be a little more specific. After flashing from the asus firmware to shibbys version 112, it showd a connection of 1300. After resetting the nvram and doing the reboot, it showed a connection of 288 (Country set to EU). When I set the channel width to 80Mhz, the only channel choice was Auto. I slected 80 Mhz and left the channel on Auto and then saved it. When you click on Overview, it still showed the channel width set to 20Mhz even though it was set to 80.



    Thanks for all your work shibby.

  66. shibby20

    shibby20 Network Guru Member

    can you check yours result?
  67. ilkevinli

    ilkevinli Network Guru Member

  68. shibby20

    shibby20 Network Guru Member

    channels are detected well it should works :/ I have available 2 channels with 80MHZ width.
    channel 40 is Control Sideband is upper and 36 if Control Sideband is lower.
  69. psykix

    psykix Reformed Router Member

    I'm struggling to get a cron job set up (to update my IP address for UnoTelly).. I used the following line :-

    cru a UnoTelly */60 * * * * root wget

    I replace your_token with my actual hash.

    It never seems to run though?

    If I do cru l then it lists it ok.. also on a reboot it disappears.

    Where am I going wrong? Bit of a noob when it comes to cron jobs I am afraid!

  70. psykix

    psykix Reformed Router Member

    I realised that the syntax seemed to be incorrect, and I also read that I needed to edit the /var/spool/cron/crontabs/root file and add it in there with the other cron jobs - so I did.. (using Vi) but after a reboot the root file had reverted to it's original (removed my cron job)

    I'm obviously doing something dim here...

    EDIT : Seem to have got it working - I used
    cru a UnoTelly “60 * * * * wget”

    It does seem that cron jobs don't survive a reboot though?

    Spoke too soon.. what do I have wrong?

    Sep 26 19:25:01 unknown crond[575]: crond: USER root pid 1275 cmd root wget
    Sep 26 19:26:02 unknown cron.err crond[575]: user root: parse error at 60
    Sep 26 19:26:02 unknown crond[575]: crond: USER root pid 1294 cmd wget
    Sep 26 19:26:11 unknown cron.err crond[575]: user root: parse error at 60
    Sep 26 19:27:01 unknown crond[575]: crond: USER root pid 1296 cmd wget
    Sep 26 19:28:01 unknown crond[575]: crond: USER root pid 1298 cmd wget
    Last edited: Sep 26, 2013
  71. rssluca

    rssluca Reformed Router Member

    Hi, I am having exactly the same issue as ilkevinli . I can set 80Mhz only in the basic settings page but it doesn't really apply it and stays at 20Mhz channel 36...
  72. mercurio_

    mercurio_ Reformed Router Member

    hy shibby, first of all thanks for your great work. that's the only reason i bought the ac66u!

    i wonder if someone is using the eth1 interface in wireless client mode?

    i'm trying to get it running, but no luck so far. i have a linksys e900 tomato router and configured it there (basically i would like to replace it), so i suppose that all i read for the e900 should also be valid for the ac66u (in terms of wireless client operation under tomato).

    the bridged mode works great. and also when connecting to the router i wanna connect to by ethernet trough the wan port it works flawlessly.

    i found out that some other guys also have problems on other dual band routers. maybe it's a general tomato dualband problem?

    the client router (ac66u) behaves as follows:
    it seems to get authorized by the host router (also running tomato).
    but then it looks like it doesn't ask for a dhcp lease. setting the correct ip manually (i verified it using the wan connection) also doesn't lead do a connection.
    one other point is that it seems that it's not able to make a stable connection because it jumps from channel one to six and back (this does not happen in bridged mode!)

    if you find some time to have a look at this it would be really great.

    thanks anyway for all your work!


    one more thing: by playing around with client mode i tried to disable the 5ghz interface and rebooted. this kicked it out of the web interface. only a reflashig of the firmware, a hard reset followed by a nvram delete, a firmware flash mode start and a restart brought it back!
  73. elcarrot

    elcarrot Reformed Router Member

    Hi Shibby / all,

    I just started using Tomato and so far it's been exceeding expectations. However I am running into one issue when I try to use the build of Dnsmasq that comes with tomato.


    Router: ASUS RT-N66U
    Build of Tomato: Tomato Firmware 1.28.0000 MIPSR2-112 K26 USB Mega-VPN-64K

    Issue: When I try to use a dhcp-range entry in the DnsMasq section, no matter what values I enter, it doesn't take - and no errors are reported in the logs.

    I have tried using the following to set a range:

    dhcp-mac and dhcp-host work fine - it's just dhcp-range that doesn't seem to work.

    I've searched - but been unable to find anything about this. I believe I have the latest version - but if there's a newer one I'd be willing to try it.

    Note: What I was trying to do was have a device assigned one set of DNS servers when connected to one network, and another set of DNS servers when connected to another. I was eventually able to get it to work using the following:


    What this does is whenever the device with mac address 11:22:33:44:55:66 is connected to a VLAN which is assigned to a bridge where it is possible for it to be assigned the IP address, then it will also be assigned the DNS servers below.

    However, if the device is not able to be assigned the desired IP address, then it will also not be assigned the DNS servers.

    I would much prefer to use the dhcp-range option if possible though.

  74. gof

    gof Networkin' Nut Member

    Today i bought the AC66U because my router was due for an upgrade, so flashed the latest 80mhz channel enabled firmware and started setting the router up as i wanted it.

    My problem is that everytime i change the 5ghz radio to 40mhz or 80mhz my Asus AC53 USB adapter loses connection and stops working until it has been taken out and put back in the usb port.

    If i connect it to the 2.4Ghz radio and set the 5ghz radio back down to 20mhz i can connect again.

    The connection works for a min or 2 in 40mhz mode, but just plain fails in 80mhz.

    Any idea if this is a big with the router wireless driver, or the usb netcard?

    I bought 2x AC53 usb and tried both, they both have the same behaviour.


    After surfing the web for about an hour the usb adpater again cut out, not after being connected to the 5ghz radio at 20mhz channel width, so it lasted alot longer but still cut out in the end. Im now testing it against the 2.4ghz for a longer duration.
    Last edited: Oct 4, 2013
  75. koitsu

    koitsu Network Guru Member

    Please contact the dnsmasq author and explain the situation.
  76. akyboy

    akyboy Network Guru Member

    Hi there,

    I did read so many posts/forums etc. Re-flashed router so many times,.. but i cannot get this 80Hz to work.

    Have no idea what to do anymore,... my laptop has ac card, but i am not getting more than 173Mbps.

    Any help would be appreciated.

  77. gof

    gof Networkin' Nut Member

    New day, fresh look at my problem.

    Recap from yesterdays tests.

    With AC enabled Shibby firmware installed my wireless network cards (2x Asus AC53) would not connect to 5Ghz radio without shutting down, requiring to be taken out of the usb port and put back in. The channel width seems to affect how long until this shutdon happened. If 20Mhz it lived for almost 1 hour, 40Mhz a couple of minutes and at 80Mhz it died instantly.

    I tested it with both computers in the house, Windows 7 and Windows 8, and with both netcards in either configuration, all was consistent with the fail pattern.

    Today i reflashed the latest Asus firmware and now im having no issues connecting to 80Mhz on 5Ghz radio and im getting very good throughput.

    This seems to indicate that its unfortunately not something to do with my usb netcards but instead something in the AC radio settings on the Shibby firmware.

    Ill be ready to do more tests if anything is needed to help find this error, as i would of course like to run tomato and not Asus firmware :)


    And after 1 hour ish, the usb device died again, it lived longer with the Asus firmware but died non the less. Ill return the AC53 usb adapters on Monday and try getting another AC adapter to test the router with instead.
    Last edited: Oct 5, 2013
  78. AndiiiHD

    AndiiiHD Reformed Router Member

    Hi @ all, i am a proud owner of an Asus AC66u for one week now. Just had installed the tomato firmware. Did an nvram reset after flash. Logged into GUI and did a reboot without setting any other settings. After the reboot i set the country to EU (by default it was US) and did a reboot again. After that i could see 2,4GHz and 5GHz in the wireless settings menu and could set my channel to 40 and 80MHz bandwith.

    i found one bug:

    I wanted to know if there are existing 5GHz WLANs from any neighbors using the same channels.

    But the "scan" for wireless networks in "Basic Network" settings locks up for the 5GHz radio.
    Sometimes even the tomato GUI crashes and i had to powercycle my router.

    Nevertheless the 2,4GHz Scan works fine.

    Can someone confirm this behaviour?
    Last edited: Oct 7, 2013
  79. mercurio_

    mercurio_ Reformed Router Member

    I just tried it. For me it works, although maybe it's cause there are no 5GHz networks in my neighborhood (i verified it with my notebook).

    Could someone may check if the client mode works?
  80. AndiiiHD

    AndiiiHD Reformed Router Member

    okay thanks for cross checking, did some reboots and now the scan for 5GHz works fine. There are no 5GHz networks in range of my router...

    One more question - transmit power was set to only 42mW by default - isn't it set to 80mW in Asus stock firmware and Merlin builds? Why is it set so low by default in tomato?
    Last edited: Oct 10, 2013
  81. Tyler Yokley

    Tyler Yokley Reformed Router Member

    Ok so I have completely flashed this firmware. So a little about my environment. I have 2 AC66R's. 1 is set as an Access Point and the other is set as Wireless Ethernet bridge. The 2 routers Communicate Flawlessly except when... the 5ghz 80mhz band comes into play. I've played around with some of the settings, however the main router will always drop down to 20mhz. When I continue to play I do finally get it to go to 80mhz but the max speeds I have seen thus far is only 600mbits/s. I have also seen some of the other issues people have been having between the EU,US, CHINA, etc. The best results I have seen thus far on my routers have been US. EU will not recognize the 80mhz band. Also on the bridged, even if the access point says 80mhz, the bridge will only recognize 20mhz band and my IE speeds drop 20mbits/s below my package. I have also noticed that I can not have multiple br's... On the LAN page, I have tried creating another subnet of ip's and every i click save, it deletes the subnet. My main subnet is the secondary is Any suggestions?

    Shibby, for some reason I can not see your configuration photos. It says: - Error
    You do not have permission to view this page or perform this action.
  82. CardinS2U

    CardinS2U Network Guru Member

    its all set like that for all tomato builds. Just change it to your manufactor settings
  83. goreen

    goreen Reformed Router Member

    Hello Shibby
    first thanks for your work.
    It is realy great.
    can you post you 2.4g and 5g settings including advanced settings, please?
    I cant open the Pics from 5g, why i am new on this site.

    THank you very much .
  84. Tyler Yokley

    Tyler Yokley Reformed Router Member

    Ok So I got the wl0.1 solved and attached the network and everything is working good. now just trying to figure out why the 1300mbs range will not work. Only thing I can think of that other people are saying is a driver issue. Shibby, if we wanted to donate money to you for all the hard work you have done, how might we do so?
    Last edited: Oct 12, 2013
  85. mercurio_

    mercurio_ Reformed Router Member

    @shibby20 :
    i tried some more times to get the wireless client mode running and it seems that it only works if the encryption is turned off or WEP. the bridged mode also works for WPA/WPA2
    furthermore i found victek's beta ( for the ac66u and there the stealthMode works for all leds.
    i wonder if you also put your beta builds somewhere.


    i did some more tests. the wireless client mode somehow behaves different than in your build for the e1200v2. there the wireless interface is somehow mapped to the wan port. in the overview page you see a connection to the wan port if client mode is activated.
    for the ac66u build it's somehow different. the wan port stays off and all ports are shifted by one to the right (i.e. if 1 and 3 are connected to ethernet devices after changing from wifi bridge to wifi client it gets confused and shows connections on 2 and 4. if 1 and 4 were connected 1 moves to 2 and 4 disappears ...). could it be that there is some wrong mapping?

    or can it be that the driver is only capable of client mode for wep? although this sounds somewhat strange to me because bridged mode works in every case.

    any idea how i could see what's going on when the client wifi interface comes up?

    i also found that it seems to connect to the second router (i think it gets an authentication because the e1200 lists it in its devices) but somehow either it does not put an dhcp request or something else goes wrong.
    Last edited: Oct 18, 2013
  86. mvalpreda

    mvalpreda Network Guru Member

    I have an ASUS RT-N16 with Toastman Tomato USB right now and looking to upgrade to an AC router. I am wondering if shibby built has support for a 6in4 static tunnel (Hurricane Electric). Thanks!
  87. shibby20

    shibby20 Network Guru Member

    of course it does. I`m using HE tunnel myself.
  88. shibby20

    shibby20 Network Guru Member

    on my site ( you can find "donate" button ;)
  89. shibby20

    shibby20 Network Guru Member

    Victek taked stealthMode from me. It is exacly the same stealthMode script in my and Victect builds. BUT ... Victek didn`t (propably forget) include 5G led suport, well in his build 5G led does not work and it`s always turned off. In my builds 5G leds is working (blinking) but stealthMode cannot turn it off. I`m working on it.
  90. Victek

    Victek Network Guru Member

    Yes, I think the difference is the constructor, I took rainlake approach to build AC66U (using the tomato shared directories) while I think you use a dedicate build for this model, not? as always ... without having a physical unit to test is worst to solve all these issues ....
  91. mercurio_

    mercurio_ Reformed Router Member

    first of all thanks for your reply,

    and yes, that can be, probably i activated stealth mode and didn't notice that the 5ghz led does not work at all.

    do you have any idea why the client mode is broken for wep encrypted networks? from all i tried (to manually get it running using wl) i have the feeling that it is a driver problem. the only wired thing is that the bridged mode works great.

    on the other hand on ddwrt it works without any problems for all encryptions the main difference (beside the 3.x kernel, yes i know its a big diff) is the driver version
    DD-WRT: 6.30 RC163.1 wl0: Jun 1 2013 03:09:45 version (r391398)
    Tomato (your build): 6.30 RC102.9 wl0: Jul 4 2013 20:58:53 version (r366174)

    could you may build a test with the RC163 (i think rmerlin has even a never one on his github:

    from what i saw on git you recoded the ethernetstatus and i suppose it's gonna solve the misbehaving when putting an wireless device in sta mode.

    one last question: aren't the ports in the advanced/vlan page miss mapped for you?

    thanks once more
    Last edited: Oct 19, 2013
  92. shibby20

    shibby20 Network Guru Member

    Tomato has the same wl driver as Asus/RMerlin mod

    I see i have newer driver than Victek. In my v114 (not released yet) it is:
    DD-WRT team have access to broadcom SDK well they can compile newer (non-published) version of broadcom driver. They don`t publish this driver well we (tomato devs) can`t build tomato with RC163 driver.
    Last edited: Oct 19, 2013
  93. mercurio_

    mercurio_ Reformed Router Member

    oh, that's really sad. i was using dd wrt for some years but i like your work a lot more. i looked around a little bit and it seems that also the openWRT guys have access to the wl sources. i understand that they don't publish the sources, but they could be at least so open to give you tomato guys access to it.

    what about the vlan mapping is it working for you?
  94. shibby20

    shibby20 Network Guru Member

    openwrt guys haven`t access to BCM SDK. They made own b43 driver, but it`s old. This is why openwrt is not support new broadcom router like RT-N66u. Even old man like Asus RT-N16 is not supported officially by openWRT yet:

    vlan mapping is working correct for me.
  95. mercurio_

    mercurio_ Reformed Router Member

    thanks a lot for clarifying. i still hope that some change in the driver / tomato brings the wireless client back to life.
  96. RMerlin

    RMerlin Network Guru Member

    Access to the whole source code involves paying for an SDK licence from Broadcom. We're talking thousands of dollars here.
  97. Victek

    Victek Network Guru Member

    No problem .. open a donation account for users wanting to access full wireless functions ;)
  98. RMerlin

    RMerlin Network Guru Member

    And more money to pay an engineer who actually understands the lowlevel stuff involved in the wireless driver :D
    koitsu likes this.
  99. Tyler Yokley

    Tyler Yokley Reformed Router Member

    So Shibby I still am unable to receive the 1.3gb/s the 5g spectrum. I will reflash and retry tomorrow, but here is my channels showing. I have no clue what is going on.. Like I can select the channels from the drop down. Only thing I can select is Auto.


    But as you can see All the channels are showing. Any Ideas how to force it to one of the higher channels?

    Also, expect some money coming your way. I get paid this Thursday!
  100. shibby20

    shibby20 Network Guru Member

    did you clear nvram after flash firmware? After claring eth2 will disapear. Do not do nothing but just reboot router onle again. After that you will see eth2 and you will be able to set channel.

    @Victek - rainlake added suport for tenda w1800r, but he didnt touch AC66u supoprt. Well i had to do this.
    here is the commit with 5g led support

    Yuo should also look into rc.init.c file in my branch, because there may be more updates for AC66u, not included to your branch.

    Best Regards.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice