Tomato builds for ASUS RT-AC66U

Discussion in 'Tomato Firmware' started by electrocaine, Feb 1, 2013.

  1. mercurio_

    mercurio_ Reformed Router Member

    it's wired, from what i read 80MHz bandwidth should only work in EU, right?

    if i set the region to EU i get the following:
    EU (EU/13) <unknown>
    36 40 44 48

    when i set it to US i get:
    34 36 38 40 42 44 46 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 144 149 153 157 161 165

    this leaves only two channels for 80MHz in eu BUT 6 IN US !

    i cleared nvram and am running shibby's build. for me it works great. no idea why. if i can somehow help with a log / dump let me know.
  2. mercurio_

    mercurio_ Reformed Router Member

    i noticed that wl0 is set to PL and wl1 to US.
    when configuring it you changed it to those settings using the web interface, right?

    for me the web interface only works if i set either EU or US. all the other settings are not reflected in what wl shows. what happens if you set it manually to EU/13?
  3. Victek

    Victek Network Guru Member

    Thanks, @shibby20 without having a unit to test it's difficult to run 100% first try. I think our branches are different right now due to AC-66u merge., rainlake did the integration with different approach as I can see.
  4. shibby20

    shibby20 Network Guru Member

    right. rainlake merge RT-AC to RT-N. I merge RT-N to RT-AC.
  5. Victek

    Victek Network Guru Member

    This is the way (rainlake) needed to include another models and platforms in tomato ... I don't say if it's better or not, just more flexible.
  6. Tyler Yokley

    Tyler Yokley Reformed Router Member

    So all my changes were made in the interface. For some reason I got better bandwidth transmission on the PL than I did the EU. EU would cap out at like 134Mbs. With PL it caps out at like 200 and something. I'm just going to clear nvram and see if that Fixes it. I did clear it last time by doing a 30/30/30 reset, but should this be done in the interface?


    So after clearning out nvram and after each change I rebooted the router, I saw an increase in my Mbps. So my Environment: I have 2 AC66R's. One is acting as a Access Point and the other is acting as a wireless ethernet bridge. The one that is an access point is in the US wireless mode on the 5g. It will actually let me select 1 channel on the 80mhz range:153. The rate of this access point is 40.5Mbps.

    Now my 2nd router (the wireless bridge mode) reads the channel 153. but it only sees the 40mhz spectrum. and a rate of 405Mbps. This is from a fresh clean start with NVRAM cleared. And both in the US setting. If i chose EU and the 80mhz, it would not allow me to select channels. Any Suggestions?
    Last edited: Oct 20, 2013
  7. titanous

    titanous Reformed Router Member

    Last edited: Oct 23, 2013
  8. shibby20

    shibby20 Network Guru Member

    correct :)
  9. titanous

    titanous Reformed Router Member

    Last edited: Oct 23, 2013
  10. shibby20

    shibby20 Network Guru Member

    i need more information.
  11. titanous

    titanous Reformed Router Member

    Last edited: Oct 23, 2013
  12. ksergey2012

    ksergey2012 Serious Server Member

    Dear Shibby, I'm on the test your new firmware v.114 (version VPN) for asus rt-ac66u. I want to say that the firmware - great! Internet flies! Everything is stable, WAN connects - instantly (I had problems with a long connection to the WAN some firmwares from Dear Victek). Thank you very much! I made a small donation to you for your great work.
  13. PetervdM

    PetervdM Network Guru Member

    installed v114, but had to revert to v112. the br0 mac address is not that of my router, and has some randomness in the last octets. this conflicts with my firewall. back to v112 everything is OK again.
    nevertheless thx for all our efforts.
  14. ksergey2012

    ksergey2012 Serious Server Member

    Strangely, I'm okay - MAC address is the same, I specifically unfastened router from the wall to watch.
  15. mercurio_

    mercurio_ Reformed Router Member

    hey shibby, thanks for the upgrade. great work!

    the wireless client bug still consists (just to let you know).

    i found one bug:
    now in wireless bridge and also in wireless client (wep/open) mode the ethernet ports on the status page seem wrong mapped. i suppose this is because the eth1 device is mapped to the wan and gives back a bad value. therefore the content of the ethernet.state file reads as follows:
    Port 0: DOWN
    Port 1: DOWN
    Port 2: 100FD
    Port 3: DOWN
    Port 4: DOWN
    Port 5: 100FD
    the bug is because the VPORT value and the VWAN value are empty.
    i think a fast (and maybe dirty) fix would be to add a query after line 14:
    VPORT=`nvram get $VWAN'ports' | awk '{print $1}' | sed 's/[^0-9]*//g'`
    if [ -z "$VPORT" ]; then                                                                                                                                                        
    Last edited: Oct 22, 2013
  16. tim28taft

    tim28taft Reformed Router Member

    Shibby Hello I upgraded to Tomato Firmware 1.28.0000 MIPSR2-114 K26 USB VPN-64K
    My Router is
    Asus RT-N66U
    Did you remove the CTF Cut Thru Forwarding option in this build ?
  17. titanous

    titanous Reformed Router Member

    Last edited: Oct 23, 2013
  18. jerrm

    jerrm Network Guru Member

    tim28taft and titanous - read the release notes (and links therein).
  19. titanous

    titanous Reformed Router Member

    Last edited: Oct 23, 2013
  20. mercurio_

    mercurio_ Reformed Router Member

    @shibby20 :
    can you give me some hints to help fixing the wireless client bug? could you may write some keywords (maybe the source code file name) that bring up the wifi interfaces?

    am i right to start with having a look at:
    release/src/router/rc/network.c ?
  21. kthaddock

    kthaddock Network Guru Member

  22. shibby20

    shibby20 Network Guru Member

  23. Victek

    Victek Network Guru Member

    The ctf.ko module had conflicts with QoS and other tomato features.
  24. mercurio_

    mercurio_ Reformed Router Member

    @shibby20 :

    i really don't won't to bother you with something you're not interested at all, so please if it's the case tell me.

    i am still trying to find the problem with the client mode on dual band routers. to debug it further i got hostapd and dnsmasq running and grabbed the logs. i had a look at the connection process for wet and sta mode both on one ac66u and a e1200.

    in wet mode the ac66u fails to respond to the 1/4 msg of the 4way wpa handshake. after that it disconnects and retries once more, this time the log says association OK (aid 2). the second time the authentication works and the ac66u connects in wet mode.

    in sta mode it behaves the same way but the difference is that it reassociates with aid 1 and doesn't acknowledge the association anymore. after that it hangs somehow. and restarts the whole process again and again without ever getting to the second step of the handshake.

    maybe you want to have a look at the 4 log files? (imo they are easy to understand)

    i had a look at the source code, but as i'm new to tomato i had to find out the structure first. sadly the lines that catched my attention where not the right ones.

    thanks anyway,
  25. mvalpreda

    mvalpreda Network Guru Member

    I have a Asus RT-AC66R and running Merlin on there now. I was trying to extend the wireless network with an Apple Airport Express and found that I can't do that. Does the shibby build allow the wireless network to be extended? Or am I missing something on the Asus in order to extend the network?
  26. eangulus

    eangulus Network Guru Member


    Not sure if this is the place to report it or not.

    I am having some odd behaviour with TomatoUSB 114 and RT-AC66U.

    Firstly my experience to date is I have used Tomato on my own and customer units for past 5 or so years. From the WRT54GL to RT-N16 to RT-N66U and now the RT-AC66U. I have fixed various issues myself simply by reading and/or awaiting a bug fix. This is the first time I have reported what I think may be at least one issue.

    1. Original Flash using Asus Recovery method, took a long time to come back up (over 10min). Usually allot quicker on RT-N66U. I am comparing to the N as it was my last router prior to upgrading to AC. So it may be normal but I did notice a difference and hence reporting it incase it isn't normal.

    2. Did a NVRAM reset. Seemed to take a long time to boot again (10+min), and seem to be a bit glitchy in settings and stability. Repeated process which seemed to work.

    3. Originally set Wifi to AU. Setup 2.4G as normal and the 5G to 80Mhz and set channel to 153. Noticed that the throughput was 450Mbps (N Mode). Did some forum reading and found that for 80Mhz to work it had to be set to EU.

    Set the 5G to EU and it then showed as 1300Mbps throughput. Went into setting to set a channel, and there was nothing but Auto available. Change to 40Mhz and I got about 3 channels shown and same for the 20 but as soon as I put back to 80 I only had auto.

    Thought oh well leave as is hit save.

    5G went back to N mode as it was only showing the 450mbps again.

    Went back to settings and changed to AU mode again, this time was able to select a channel and set to 80mhz. Saved.

    All seems to be fine as it is showing 1300Mhz.

    Not sure if there is a glitch or what, but if you want some more information give me a yell.

    On another note, is there a way to export the QOS settings and the Static DHCP settings? I am getting tired of manually copying them between routers. With 5 kids and a computer business you can imagine the QoS and DHCP setup I have to make it all work smooth.

    In saying that I thank you for your firmware. If it wasn't for Tomato and the effort you have put in I wouldn't be able to manage.
  27. CowMix

    CowMix Addicted to LI Member

    Hey Shibby and Victek,

    I have a pretty major bug with Shibby 114 and Victek 1.2n for AC66U. If I enable QOS it will work fine but if the router reboots or any network settings are changed with QOS enabled the router crashes/fails to startup and I have to hard reset my nvram using the WPS button.

    Thanks :)
    Last edited: Oct 24, 2013
  28. kthaddock

    kthaddock Network Guru Member

    Have you updated to 114 or 1.2 without nvram reset and reconfigure by HAND?
    Most all of trouble comes from that.
  29. CowMix

    CowMix Addicted to LI Member

    I clicked "After flashing, erase all data in NVRAM memory", are you saying I should upgrade without that checked? I set up the router using a couple nvram set values that I have saved. I'll try to see if the bug occurs if I don't do anything except enable qos on a fresh install.
  30. kthaddock

    kthaddock Network Guru Member

    Well thats isn't enough sometimes. You have to go to: Administration => Configuration => Restore Default Configuration => and pull down and choose: Erase all data in NVRAM memory (thorough) click OK and wait after that you can configure by HAND.
  31. CowMix

    CowMix Addicted to LI Member

    Ok I figured out the problem. My nvram sets we're enabling IPv6 which seems to cause the router to crash if qos is also enabled. I went through setting up each value hand by hand and as soon as I enabled IPv6 the whole thing crashed. I'll just leave IPv6 disabled for now. Thanks :)
  32. CowMix

    CowMix Addicted to LI Member

    Has anyone had any luck with enabling Jumbo Frames on the AC66U?
  33. Tyler Yokley

    Tyler Yokley Reformed Router Member

    What did this current release: 114 fix? or what did you add in it?
  34. kthaddock

    kthaddock Network Guru Member

  35. Toastman

    Toastman Super Moderator Staff Member Member

  36. Mortin1986

    Mortin1986 Reformed Router Member

    Hi shibby,

    Thx For all the great work done, i been looking into the bug about LED lights 5G and i can't find any way to fix it.
    can you make and patch for this so i can turn it off thx :)

  37. eangulus

    eangulus Network Guru Member

  38. mercurio_

    mercurio_ Reformed Router Member

    hey toastman, you wrote a really nice guide for a lot of people there. what i normally do using a script is the following: get a dump of the fresh flashed nvram (std config) and after fully configuring my router i get a second one. then it compares the two files an creates a nvram config script that only commits the changes.

    what do you think about integrating such a feature in the tomato gui? it would be easy to implement and probably help a lot.

    i think it would be nice to have the following options:
    *)download nvram config diff
    *)restore nvram config diff

    if the files would be plain text everyone could then also cherry pick the entrys he wants and i.e. create a own basic config for all router he uses.

    sorry for being off topic, didn't know where i should post it if not here
  39. nickelfault

    nickelfault Serious Server Member

    So I just finished updating to v114, and now I've lost my 5 GHz channels. I tried an NVRAM reset, rebooted twice, got my eth2 back and still can't see any 5 GHz channels. I've tried changing the country to both China and EU and still the scan shows nothing. The country defaulted to EU on both wireless interfaces as well, but I can't get the channels. I lucked out changing my country to China last time, but it doesn't want to work this time. Any ideas?

    Here's my output from the commands posted previously:

    root@unknown:/tmp/home/root# wl -i eth2 country
    EU (EU/0) <unknown>
    root@unknown:/tmp/home/root# wl -i eth2 channels
    36 40 44 48

    Yet scanning results in nothing. How do I get those channels back :(
    Last edited: Oct 30, 2013
  40. ksergey2012

    ksergey2012 Serious Server Member

    Dear Shibby, I wanted to ask you, in the new firmware v.114 for asus rt-ac66u when choosing Country / Region - EU and the width of the channel - 80MHz, added a choice of two channels - 56, 104. But when you select a channel at least - 56, my Wi-Fi client (asus pce-ac66) - will not see the network. I understand that my Wi-Fi client is unable to see the network when the channel is selected more - 48. Could you add in the new firmware selection of channels 44 and 48 (as in the original firmware from Asus)? Thank you for your great work!
  41. mercurio_

    mercurio_ Reformed Router Member

    are you really sure that there are 5G networks in your neighborhood? they are still not wide spread! or what do you mean by scanning results in nothing?
  42. nickelfault

    nickelfault Serious Server Member

    The only channel I have available to select is 'Auto' in the Basic Network Settings for 80 MHz. With this selected I am stuck on 20 MHz:


    And here's a look at my basic wireless settings:


    Before and after doing a scan, I still cannot select a channel. Previously (before the upgrade) with my country set to China I had one channel show up that I was able to select. During the scan I used Chrome developer tools to monitor the network requests/responses and there is in fact data coming back when I do a scan:

    Req #1
    wlscandata = [ ['08:86:3B:3D:42:6B','Wong (5 Ghz)',40,17,-91,0,[140,18,152,36,176,72,96,108],1,96,20]];
    Req #2, #3 & #5
    wlscandata = [ ['C8:BE:19:68:56:17','claynor-media',36,1297,-87,0,[140,18,152,36,176,72,96,108],1,98,40]];
    Req #4
    wlscandata = [ ['C8:BE:19:68:56:17','claynor-media',36,1297,-86,0,[140,18,152,36,176,72,96,108],1,98,40]];

    But yet nothing shows in the drop down. Not sure if it helps but in the 'Wireless Network Mode' I have 'A Only' and 'N Only'.

    And finally here's a screen of my advanced wireless settings:


    EDIT: For the 20 and 40 MHz widths, I have channels available. Just none for the 80 MHz one.
    Last edited: Oct 30, 2013
  43. Victek

    Victek Network Guru Member

    Use ASCII character in your Hotspot .. avoid ... ' ...
  44. nickelfault

    nickelfault Serious Server Member

    I don't think that has to do with the channel issue though... I never had any problems with that SSID running Merlin or the previous Shibby build. Also it's a good laugh when people come over and say, "sweet, you can get McDonald's free wifi from here!".
  45. darkknight93

    darkknight93 Networkin' Nut Member

    Dont Know if this is related to your issue but I have European Union not EU to select for 5 ghz to work
  46. nickelfault

    nickelfault Serious Server Member

    In your advanced wireless settings? I checked every "E" in the list and don't see any European Union in there...
  47. darkknight93

    darkknight93 Networkin' Nut Member

    Yes in my Advanced Wireless Settings:

    Device Info: Asus RT-N66U on
    1.28.0000 MIPSR2-114-NEWDRIVER K26 USB AIO-64K

    Shibby 114
  48. nickelfault

    nickelfault Serious Server Member

    Ahhh you're not even on the same router, lol. Thanks for the info though. My 5 GHz band works, but no 80 MHz channels. Just falls back to 20 MHz. I'm going to try rolling back to 112 tonight, and if I still can't get the channels I'm going to have to revert to stock :( No AC is a showstopper for me.
  49. mercurio_

    mercurio_ Reformed Router Member

    just to be sure, did you really erase the nvram completely after flashing?

    a lot of people reported errors like you do because of simply being to lazy to config it from scratch after a firmware upgrade.
  50. nickelfault

    nickelfault Serious Server Member

    I did. It only takes me 5-10 minutes to put all my settings back in. I didn't try using the hardware buttons to do it, but did it through the tomato interface. As I mentioned I did lose my 5 GHz interface, and after another reboot it was back, but no channels. I am going to spend some more time with it tonight, but I tried for about 2 hours last night to get that 80 MHz width working.
  51. nickelfault

    nickelfault Serious Server Member

    Well, I tried this again and to no avail. I created a screencast so you could see exactly the steps that I went through tonight, you can find it here: (3:49). I hope that after seeing that it's acknowledged as a bug. I do have some good news however. I used exactly the same process and ended reverting back to v112 and I was able to select China as my country again and had the one 80 MHz channel that I could pick, so I'm back to AC mode. I definitely won't be upgrading again until this bug has been fixed.

    Here's my screenies (v112) now for those interested:



    Last edited: Oct 31, 2013
  52. joew333

    joew333 LI Guru Member

    Hi Shibby! I am using your W1800R build 114. It works very well. The one main issue is that the 2.4Ghz and 5.0Ghz radios I guess are reversed in hardware on the W1800R compared to the RT-N66U. One consequence of that is that when I run the 114 VPN build, the green LED for the 5GHz radio cannot be turned off. Even when I disable the radio, the LED stays on. How can that be fixed? Lastly, I am wondering if this router has any CFE or recovery mode as I have not found one. All the Asus routers do have a recovery mode. How is a Tenda router recovered if something messes up as I have never owned Tenda before. Thanks very much and it is great to have Tomato on a modern router like the W1800R thanks to your efforts!
  53. mercurio_

    mercurio_ Reformed Router Member

    i don't get why you select one option without hitting save and reboot afterwards.

    anyway for me everything related to 5ghz works and i proceed as follows:

    *)flash firmware - let the rooter reboot
    *)erease nvram from menu (you could leave out this step, i do it just to be on the safe side)
    *)wait some minutes (on the overview page 5ghz is missing)
    *)wait some minutes (on the overview page 5ghz should be visible)
    *)config basic
    *)config advanced - wireless (set region to eu)

    after each page on a page i hit save, i.e. if i change the wireless settings in basic setup or if i set the region to eu. in any case i hit save before leaving the config page. i think if you don't hit save the values are not written to the nvram so if you change the wireless to 80mhz bw hit save.
    the scan button only scans the interface for routers in your neighborhood. don't get why you do that.
  54. nickelfault

    nickelfault Serious Server Member

    To answer your first question, that was a mistake on my part, I forgot I had to reboot first. When I seen the 5 GHz radio was missing, I knew I had forgotten to reboot. So that's why I didn't save. Shibby said don't change any settings after the first flash, make sure to reboot first. So I did.

    Secondly, I hit scan to show that no networks show up, even though THERE ARE 5 GHz networks in my range, they're just not populating in the dropdown.

    Trust me, I've tried many different combinations (including erasing NVRAM many times after the flash) to try and get those 5 GHz channels, and they still don't want to show up. So I'll be sticking with v112 where I can at least get one channel.
  55. jdunst

    jdunst Reformed Router Member

    Thank you for all of the help I have found in this forum. @shibby20 I have made a small donation to you for continuing the Tomato work for the Asus RT-AC66U (v114.) All working well--5GHz, Dual tunneling (mostly VPN, some not), DDNS, Static DHCP, Admin scripting, & Access Restrictions. This is quite a feet for a newb like me. You've all made this a great learning process with an awesome outcome.
    Last edited: Oct 31, 2013
  56. joew333

    joew333 LI Guru Member

  57. Hans90

    Hans90 Reformed Router Member

    Hi guys,

    May I know is there any idea to enable 5Ghz or AC Wlan?

    I've flashed 114 on my RT-AC66U. But theres no 5Ghz or Ac connection.

    please advise what can I do to enable it. I've read few posts behind, but not a solution for me.

    I've even clear Nvram, reflash..but still same
  58. joew333

    joew333 LI Guru Member

  59. Hans90

    Hans90 Reformed Router Member

    The 5Ghz suddenly appeared and don't know what's the reason.

    By the way @shibby20 , Can I suggest you to make the channel with to auto? because the devices support different frequency , so I feel it's better to make it auto (20/40/80) to let the device choose which one to connect.
  60. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Not sure if I understand your request, but if the router is set to 80, clients set to 80/40/20 can all connect. If set to auto, the router may drop to 40 or 80 and you will lose the top speeds.
  61. Hans90

    Hans90 Reformed Router Member


    Sorry that i'm still a newbie, thanks for your explanation. Now I know how it works.

    But weird thing at my side is, I set 2.4Ghz to 40, some of my devices can't connect at all. It need to be set at 20 only they can connect. or maybe I will try it again.

    For 5Ghz , I thought it's same as 2.4Ghz that has individual channel width. and there's a bug for 5Ghz band, even though I've set to 80, when check the channel in overview, it's shows 20.

    Sorry for my bad explanation. I've less knowledge about the router setting, trying hard to learn about it.
    Last edited: Nov 3, 2013
  62. Tyler Yokley

    Tyler Yokley Reformed Router Member

    Hey does anyone know if there is a way to setup VPLS on this build?
  63. shibby20

    shibby20 Network Guru Member

    if you have any issues with 5GHz radio like:
    - cannot select channel
    - cannot select 80MHz width
    - speed is limited to N-mode
    - many other problems...

    just watch:
    Charles Curley likes this.
  64. nickelfault

    nickelfault Serious Server Member

    Why after the reboot does it show 80 MHz on the overview page, but when you go into the basic wireless settings it shows it's on 40 MHz? Also I swear I have tried this a dozen times and I still get no channels for the 80 MHz width. What hardware revision do you have Shibby (A1/A2)?
  65. nickelfault

    nickelfault Serious Server Member

    Same thing, here's my video of trying it yet again. Tried it in both Chrome and IE, still a no go. Reverted back to v112 and selected China as my country and back at one channel.

  66. shibby20

    shibby20 Network Guru Member

    Strange. I have revision A1.
    I had this situation when i set country as Poland - zero channels. Did you try change country to China, US, Singapure (after change i suggest reboot). Maybe country cannot be forced to EU for all :/
  67. PetervdM

    PetervdM Network Guru Member

    intruiging! i don't know which revision i have and how to find it, but this is the board information:

    what catched my eye in the movies is the difference in the OUI's of the mac addresses:
    shibby20: 10BF48 belongs to InterAir Wireless
    nickelfault: 60A44C belongs to ASUSTek COMPUTER INC.
    PetervdM: AC220B belongs to ASUSTek COMPUTER INC.
  68. shibby20

    shibby20 Network Guru Member

    hmm very strange. I didn`t check OUI base ;)

    revision you can find on the bottom of router, near model name.
  69. nickelfault

    nickelfault Serious Server Member

    I'm on revision A2... I did try changing to China in v114 and can't get any channels, but I do get one on v112. For now I'm satisfied since my AC band is at least working, but it'd be nice to upgrade or have a bigger selection of channels :) Let me know if there's anything else I can do to help investigate.
  70. PetervdM

    PetervdM Network Guru Member

    there is nothing like that on the bottom of the router. i am pretty sure that i have one of the first units available in the netherlands. might that mean that it's pre A1?
  71. RMerlin

    RMerlin Network Guru Member

    Hardware revision is usually written on the retail box as well (same sticker that states serial number and FW version).

    Not sure about the sticker on the router itself (I'm not at home to check at the moment).

    Assume revision A1 unless it was bought in the past few months.
  72. dbareis

    dbareis Networkin' Nut Member

    I only just found a comment made a while ago by Shibby that only "EU" would work for (Country / Region). I have changed mine to "AU", I get slow speed in 5Ghz. I see people using (unsuccessfully?) other country codes, so is the "EU only" statement only still valid? Is there a FAQ about this somewhere?

    I have finally worked out how to get SSH to connect so I have this SSH output:

    root@TomatoUSB:/tmp/home/root# wl -i eth2 country
    root@TomatoUSB:/tmp/home/root# wl -i eth2 channels
    36 40 44 48 52 56 60 64 100 104 108 112 116 132 136 140 144 149 153 157 161 165

    Overview shows:

    Wireless (5 GHz / eth2) (hide)
    MAC Address: 11:D1:3B:84:EB:64
    Wireless Mode: Access Point
    Wireless Network Mode: Auto
    Interface Status: Up (LAN)
    Radio: Enabled
    Broadcast: Enabled
    Security: WPA / WPA2 Personal + TKIP / AES
    36 - 5.180 GHz
    Channel Width: 20 MHz
    Interference Level: Acceptable
    Rate: 86.5

    Network Configuration:

    • Wireless Network Mode: Auto
    • Channel Width: 80MHz
    • Control Sideband: Upper

    Any ideas or will I need to reset and reenter my lengthy config?

  73. Hans90

    Hans90 Reformed Router Member

    I've change the country to United Stated and change the channel to Channel 56. and I can get 80Mhz and also rate: 1300. :)
    dbareis likes this.
  74. dbareis

    dbareis Networkin' Nut Member

    I also saw 80/1300 when I first went into the overview but it has now gone to around 433 and my Android phone says 390. I'll play with the channels some more, thanks for the info.

    Can someone tell me what the [scan] button does apart from making the width of the channel control wider? It doesn't do any more than that on mine ever (tooltips in the interface would be nice).

    Is there anyway to tell whether a device is connected to 2.4/5 GHz? My device list says "eth1" for both (I refreshed the browser just in case)? OK it eventually changed, definately not in the 3 second auto refresh and I'm 99% sure I reloaded browser page with F5 (might be a bug).
    Last edited: Nov 10, 2013
  75. tincansandtwine

    tincansandtwine Reformed Router Member

    I'm on Shibby 114, and I've got my 5ghz radio set up so that I get 1300, but my 2.4ghz radio seems capped around 65mbps when I have any security turned on. If I switch to WPA AES, it shows 450 for a few seconds and then goes back to 65mbps.

    Here are my settings.


    Edit: It's the same when set to N-Only as well.
    Last edited: Nov 10, 2013
  76. Nite

    Nite LI Guru Member

    I created a separate thread for this issue thinking it may just be a configuration mishap on my part, but posting here just in case it's a bug or you folks might have some insight:

    I'm currently using Shibby build 114 on my Asus AC66U. I have two AC66us and I configured one of them as a Wireless Ethernet Bridge to connect my media area to the rest of my network.

    All clients have unfettered internet access with no issues (including the bridged clients). Clients on the main router can ping any clients on the second router. The problem is, clients on the second router cannot ping clients on the main router. This causes issues with media streaming from my NAS and PC.

    I am unable to identify what is causing the issue, but my configuration is as follows:

    Main router is set as Second router is set as

    I have the second router's default gateway set to and static DNS set to If I remove the static DNS entry nothing changes. The second router is connected over 5GHz

    with WPA2. Finally, the second router routing option is set to "Router", not Gateway.

    Thanks for your time and any help would be much appreciated!
  77. joew333

    joew333 LI Guru Member

    Hi Team Denelus,
    Will Victek tomato-RT-AC66U_9013-RAF-V1.2u-VPN.trx work for the W1800R? Please confirm if this build recognizes the W1800R. And, thanks to the team!
  78. Aleksazhko

    Aleksazhko Reformed Router Member

    Hi to everyone. Forst of all, thanx a lot to tomatousb developers. I love that builds so much!
    So, i found a little bug. Even not a bug. LAN port columns in web-interface in VLAN section are misordered. For.ex. 4-th is actually first one, etc... Wan is OK.
    I've spent about half of hour to realize what's going on when i've created just another vlan for 4-th lan port, which only intended to be used with wireless network (br1 in my case). And suddenly router dissapeared).

    darkknight93 likes this.
  79. PetervdM

    PetervdM Network Guru Member

    in basic, network, Ethernet Ports State - Configuration pls check or uncheck "Invert Ports Order"
  80. noremacyug

    noremacyug Reformed Router Member

    what android phone do you have that has giga wifi?

    just wanted to confirm this for build 114. switching to united states gave me channels on the 80Mhz band. i'm now back to giga wifi. much obliged to you Hans90 and of coarse to Shibby!!!
  81. Aleksazhko

    Aleksazhko Reformed Router Member

    Yep, i've seen that checkbox. But will it change ports order in all other place where order is ok? Main status page shows right ports.
    VLAN section is the only place with such mistake.
  82. dbareis

    dbareis Networkin' Nut Member

    NEXUS 5 :)

    Sent from my Nexus 5 using Tapatalk
  83. Bobby2781

    Bobby2781 Reformed Router Member

    I've successfully installed K26RT-AC/114-EN/RT-AC66U/tomato-RT-AC66U_RT-AC6x--114-AIO-64K.trx and everything "basic" is working smooth, also the 5GHz WLAN. So thank you for that. :)

    But now I'm trying to be a bit more advanced and do some USB stuff, more specifically try to get some audio out of and old USB sound card I have. I'm partially following

    Optware is successfully installed, and I'm at the point where I try to insmod some of the optional kernel modules provided in

    The order of modules I'm supposed to insert, is
    soundcore snd snd-seq-device snd-timer snd-rawmidi snd-hwdep snd-usb-lib snd-page-alloc snd-pcm snd-mixer-oss snd-pcm-oss snd-usb-audio
    `insmod soundcore` seems to work, but `insmod snd` gives me an error:
    insmod: can't insert 'snd.ko': unknown symbol in module, or unknown parameter
    and `dmesg` yields
    snd: Unknown symbol kmalloc_caches

    So my question is, is the extras package properly updated?
    Can someone point me in the direction as to how I can build the modules myself?
  84. leandroong

    leandroong LI Guru Member

    works ok on my router, fw 114-mipsr1-aio. Proper syntax should have path and extension:
    insmod /opt/audio-modules/r1/soundcore.ko
    insmod /opt/audio-modules/r1/snd.ko
    insmod /opt/audio-modules/r1/snd-hwdep.ko
    insmod /opt/audio-modules/r1/snd-page-alloc.ko
    insmod /opt/audio-modules/r1/snd-timer.ko
    insmod /opt/audio-modules/r1/snd-pcm.ko
    insmod /opt/audio-modules/r1/snd-seq-device.ko
    insmod /opt/audio-modules/r1/snd-seq.ko
    insmod /opt/audio-modules/r1/snd-rawmidi.ko
    insmod /opt/audio-modules/r1/snd-seq-midi-event.ko
    insmod /opt/audio-modules/r1/snd-seq-midi.ko
    insmod /opt/audio-modules/r1/snd-mixer-oss.ko
    insmod /opt/audio-modules/r1/snd-pcm-oss.ko
    insmod /opt/audio-modules/r1/snd-usb-lib.ko
    insmod /opt/audio-modules/r1/snd-usb-audio.ko
  85. shibby20

    shibby20 Network Guru Member

    just load module by each one as @leandroong said.
  86. Bobby2781

    Bobby2781 Reformed Router Member

    Great stuff, my Asus is now playing music!

    Although I found out the real reason it didn't work.. Too much coffee and doing it in the middle of the night.
    I scp'ed the kernel modules to a misspelled directory, so I always used the old wrong ones. Doh.
    md5sum is your friend.

    Thanks a lot!
  87. AlexZ

    AlexZ Reformed Router Member

    I found new 115 firmware.
    I didn't find anything about AC66 hardware nat in change log. Does it mean hardware nat isn't implement for AC66 yet?
  88. zadigre

    zadigre Reformed Router Member

    here is my report with the latest version (115).

    I had some troubles getting 80MHz working on the 5GHz band...
    The only way to get it working for me was to set the country to United States (no problem as I'm in Canada and we have the same regulations).
    EU, Poland or Canada did not work. With those settings, the only possible choice for channels on the 5GHz band was Auto... and the maximum width I was able to get in the Overview section was 40MHz.

    with "US" setting, it works fine on all my AC capable devices.
  89. shibby20

    shibby20 Network Guru Member

    Alex - not for now. I didn`t finish FastNAT for RT-AC yet.
  90. matthew_eli

    matthew_eli Networkin' Nut Member

  91. shibby20

    shibby20 Network Guru Member

    thx, i will look on it.
  92. Sharpshot

    Sharpshot Serious Server Member

    Hi Shibby,

    First I wanted to thank you for all of your hard work - it is greatly appreciated! I am having the exact same problem noted above by Nickelfault. However, when I change the country to the US it allows me to change the channel and I see the rate changed to 450 and 1300. However, after enabling WPA2 security, the rate dropps to 135 for the 2.4 band and 702/855 for the 5ghz band. Is this a known issue? Thank you.
    Last edited: Nov 25, 2013
  93. AlexZ

    AlexZ Reformed Router Member

    Hello, Shibby!

    I have strange issue with RT-AC66U router.
    I make connection to the router using onboard Broadcom BCM4352 AC adaptor with latest drivers.
    Band is 5GHz. I’ve turned off 2.4 radios(Status doesn't make sense).
    Connection rate is 866 RX and 468 TX. It’s OK.
    But, If I turn my PC of or just disable and enable the onboard adapter at tens of minutes rate of new connection if 175/175 sometimes 356/175 TX/RX.
    Short disconnect (reboot of the PC) doesn't have the issue.
    I found one solution – execute this command “wl -i eth2 down ; wl -i eth2 up”.
    After the command execution connection rate become normal.
    Is there a solution ? What is it mean ?

    And second question.
    My RX rate 866 and TX 486. During my "games" with other firmware I saw that dd-wrt speed was 866/866.
    After some investigation I believe I found problem.
    wl -I eth2 5g_rate set to auto. It cause low rate.
    After I executed command wl -i eth2 5g_rate -v 9x2 -b 80 -l -g I got speed 866/866.
  94. Dark_Shadow

    Dark_Shadow LI Guru Member

    Anybody else having problems with Transmission in build 115 on this router?
  95. nmalinoski

    nmalinoski Networkin' Nut Member

    Yeah, I've had it go unresponsive on me several times, and I had to go disable and re-enable it using the Tomato UI, and even then it would take a while before the list of torrents would show up. Maybe I'm just impatient, but responsiveness is very important to the user experience.
  96. bobyang

    bobyang Serious Server Member

    Hi Shibby,

    thanks for your hard works!! by the way, I ahve an AC56u unit, I don't use wifi, do you think I can use your version tomato-RT-AC66U_RT-AC6x--115-AIO-64K.trx for my AC56u router? thanks!
  97. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Different processor architecture (ARM), not compatible.
  98. bobyang

    bobyang Serious Server Member

    thank you!! I just found that!! I am sorry about my wrong information earlier!
  99. ScottNY

    ScottNY Reformed Router Member

    hello all, newbie here.

    although money is tight, i knew it was time to say good-bye to my old Linksys WRT-54GL. it has served me well for years with TomatoUSB, Toastman build, but now, we have a VOIP phone line and several streaming devices in my household. i went looking, found a good price on an open-box ASUS RT-AC66U and bought it. [it was $5 more than the open-box RT-N66U.]

    after reading the posts in this thread, however, i realize you are all way more tech-savvy than i am and i can't find the one thing i am looking for, a step-by-step way to install TomatoUSB on a factory-fresh RT-A66U. and believe me, guys, i do mean step-by-step.

    i am in the US and am looking to get the most from my router. although QOS would be nice, it is not necessary; same with USB support. my cable modem does support IPv6. can anyone point me in the right direction?

    once i get this up and running, i will definitely make a donation. all of those guys working hard to provide us better firmware to get the most from our products deserve to benefit from our appreciation.

    P.S. i just found this link: . is this accurate and can i use the proper settings for the US with the latest, 115-EN build? thanks again!
    Last edited: Dec 28, 2013
  100. mAlex

    mAlex Reformed Router Member

    Hello and thank you for the incredible work on Tomato for the RT-AC66U.
    I love the Tomato firmware and prefer it to the stock. But I'm having a problem with the throughput. On Tomato it's much slower than on the stock FW.

    These speed tests are taken shortly after another.

    On stock Asus FW

    On Tomato FW

    Am I doing something wrong? Are there any settings that I need to change? Or why am I experiencing this?
    Thank you!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice