Tomato by Shibby won't save/remember VLAN port settings

Discussion in 'Tomato Firmware' started by olymind1, Jan 15, 2016.

  1. olymind1

    olymind1 Reformed Router Member

    I have an ASUS RT-N12 D1 router with the latest tomato-K26-1.28.RT-N5x-MIPSR2-132-Mini firmware flashed on it.

    Under the Advanced - VLAN settings i can't change anything, well i can, but after i change the ports order, and save it, then reboot the router, the ports are returning to their default values, tried command lines too, no luck.

    I can change the WAN port to a LAN port on the original firmware, don't know why it keeps resetting on tomato.

    My WAN port died so i really need to change to a LAN port, doesn't really matter to which lan. Tried with v131 and v130, same case.

    Can anyone help me?

    Thank you!
     
  2. Pess0g

    Pess0g Networkin' Nut Member

    Capture.PNG This box should be unchecked.If you checked it,please uncheck and click "save" and then try to set vlan again.
     
  3. eibgrad

    eibgrad Network Guru Member

    As it happens, I have this same router running Shibby Tomato v132 (Max). It's configured as an AP and patched to my primary router LAN to LAN. I've created two additional VLANs (vlan2 and vlan3), two additional VAPs (wl0.1 and wl0.2), and two additional bridges (br1 and br2). Each additional bridge is assigned one of those VLANs and VAPs.

    So I know VLANs work.

    However, I can assure you the problem is NOT you. This thing is flakey when it comes to VLAN setup. I remember running into a problem when I tried to assign the WAN bridge to another VLAN. It just wouldn't stick. Finally figured out the only way to make it work was to change the VLAN assigned to the line currently associated w/ the WAN bridge. It's as if the WAN bridge is hardcoded to that line in the GUI! Goofy.

    Then a few days ago I was messing around on the command line w/ VLANs and inadvertently made a change. It messed them up badly. So I went to the GUI and no matter what I did from that point on, NOTHING would stick. NOTHING. Ended up having to delete all the additional VLANs, rebooting, and it seemed to set everything back to defaults. Then I was able to setup my VLANs again.

    Doesn't help either that the ports on the GUI (and command line via vlan.*ports) don't map correctly. Because it's so confusing, I created a cheat sheet w/ the proper mappings.

    Physical Port to VLAN Port Mapping
    WAN Port = Port 4
    Port 1 = Port 3
    Port 2 = Port 2
    Port 3 = Port 1
    Port 4 = WAN Port

    Given just how goofy it is, it's hard to provide specific guidance, because I still don't know why it behaves this way. All I can recommend is that you make VERY small changes, save, and reboot. If at some point it stops accepting changes, you may have to undo all your changes and start over. And hopefully if that happens enough times, you'll discover what changes in what order work best. That's what happened w/ me when I was changing the WAN.

    In your case, instead of trying to just move the ports around, try creating a new VLAN, assign it a port (the one you eventually want to become the WAN), then change the line w/ the WAN bridge to that VLAN.
     
  4. olymind1

    olymind1 Reformed Router Member

    Thank you for the help.

    Avoid performing an NVRAM commit was and is unchecked.

    Now it is working properly, all i had to do is delete the default 2 lines, and add them again with new settings/port order, save and reboot.

    I looked pictures for the correct port.

    Everything is perfect, i can use tomato again :)
     
  5. tvlz

    tvlz LI Guru Member

  6. Richard K

    Richard K Networkin' Nut Member

    A whole year later and it is still utterly buggered. I'm manually copying my settings from a v131 router (RT-AC66U) to v138 one, and for the life of me cannot figure out how to clear "Port 1" and "Port 2" from the first (VLAN 1) line in the GUI. It's impossible. I've tried every sequence of clicks to do it - unassigning one port at a time and moving it to another VLAN, deleting all lines and recreating them, and even temporarily renaming VLAN1 to VLAN10 to configure it there then change it back. The GUI for this seems totally busted.

    Also tried this, which appears to clean it up temporarily, but doesn't survive a reboot:

    nvram set vlan1ports="2 1 8*"


    I recall having a heck of a time trying to set it up originally in v131. Wish I could remember the trick I used.

    Anyone reading this who has the skills to fix - please, please do so! Let me know if you need more info to recreate the issue.
     
    Last edited: Feb 23, 2017
  7. Richard K

    Richard K Networkin' Nut Member

    To illustrate, here is what I want (and through some kind of voodoo clicking contortions somehow managed to achieve once before):

    [​IMG]

    But here is what I invariably end up with:

    [​IMG]

    Seems impossible to clear Port 1 and Port 2 from the first line and make it stick!
     
  8. koitsu

    koitsu Network Guru Member

  9. tvlz

    tvlz LI Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice