Tomato can't use Custom DNS with PPPoE connection?

Discussion in 'Tomato Firmware' started by Michael Cosmas, Apr 1, 2014.

  1. Michael Cosmas

    Michael Cosmas Network Newbie Member

    I have Tomato 1.28 with VPN (v1.28.7500 MIPSR2Toastman-RT K26 USB VPN) on an Asus RT-N16. It was configured with the ISP's modem connected to WAN, and just getting a DHCP address from that (with double natting). The OpenVPN is configured as a client to connect to the second office site which has our Domain Controller ( So I set one of the DNS servers to be our internal DNS server so the computers could find the Domain controller . At this point everything worked fine.

    Then I bought a modem that is Bridgeable, and set the WAN connection in Tomato from DHCP to PPPoE, so Tomato now has control over everything. This connects to the internet fine. Trouble is, it doesn't use the manual DNS entry I have set up.

    In the WAN status page, it says

    which are the three DNS servers I have manually entered. But when I try and get to a device on the other office, it can't resolve the address. If I force it to use the Domain controller as DNS, nslookup works fine.

    I have also tried the following DNSMASQ configuration, but still doesn't work:

    Is there any way to get Tomato to use my DNS servers as well when it is in PPPoE mode?
  2. Spyros

    Spyros LI Guru Member

    You don't need DNS in Basic Network Setup
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice