Tomato for ARM routers

Discussion in 'Tomato Firmware' started by kthaddock, Feb 28, 2014.

  1. xiaobb

    xiaobb Network Guru Member

    I have ping issue. I did full reset and I started pinging while I navigated to some of the setup pages and all of a sudden, the ping began to spike.
    I have a feeling that the ping issue follow even you do a full reset.
    Because I was not have ping issue until recently I was trying to play with the dnsmasq and wireless. Then I noticed the setting pages load very slow and the ping issue. So I reset it couple times and the ping issue keep coming back even I didn't modify any settings.

    I don't have any usb attached.

    R7000 Shibby v125
  2. Netwet

    Netwet Reformed Router Member

    20pings??? That is no test!

    I can do 500pings with dd-wrt and not a single one will be >1ms.
    If you have a single ping over >1msif connected through ethernet you already have a problem, maybe not as bad as other but still a problem.
  3. Netwet

    Netwet Reformed Router Member

    DD-WRT splash page will only be shown if setting "Enable Info Site" is enabled and "Info Site Password Protection" is disabled.

    If tomato devs can't make a simple button work (in this case reset button) I don't trust their expertise when it comes to security.
  4. RMerlin

    RMerlin Network Guru Member

    Security is about good programming practices, while making a button work involves having low-level information on hardware and how to manipulate it through specific gpios - something Tomato devs have to do without a single line of the Broadcom SDK documentation. Those are totally unrelated.
    cybrnook, digiblur and rickmav3 like this.
  5. Engineer

    Engineer Network Guru Member

    While I can get the R7000 to reproduce the ping issue while on the modem (DHCP), I cannot get the R7000 to have the ping issue AT ALL while using it as an access point only (WAN OFF). I have not tried to use the WAN port as a LAN port.

    Edit: Just changed the WAN port to be mapped to the LAN and connected the LAN cable and still cannot reproduce the ping issue while in AP mode.
    Last edited: Feb 21, 2015
  6. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    ive only really used mine as an AP so that explains that
  7. blackwind

    blackwind Networkin' Nut Member

    I'm having a bunch of issues with TomatoARM on an ASUS RT-AC68U:

    Web UI: Pages randomly get stuck indefinitely while loading. Hit refresh enough times, and they eventually load... most of the time.

    CIFS: It correctly reads "Total / Free Size" but is otherwise totally broken:
    root@ROUTER:/cifs1# ls
    ls: can't open '.': Value too large for defined data type
    JFFS: I had remnants from Merlin's firmware, so I formatted it. Now I'm getting this:
    root@ROUTER:/jffs# ls
    ls: ./syslog.log: No such file or directory
    Feb 20 22:59:41 ROUTER kern.err kernel: JFFS2 error: (6900) jffs2_do_read_inode: requestied to read an nonexistent ino 30
    Feb 20 22:59:41 ROUTER kern.warn kernel: iget() failed for ino #30
    Are these known issues? And is there anything that can be done about them?
  8. WaLLy3K

    WaLLy3K Networkin' Nut Member

    I can't say I've ever had issues on my RT-AC68U, even when I've played around with CIFS and JFFS. Have you performed a full NVRAM wipe from Admin > Configuration since upgrading to v125?
  9. blackwind

    blackwind Networkin' Nut Member

    Yep. First thing that came to mind, but it didn't help.
  10. Mr.CTT

    Mr.CTT Serious Server Member

    That page is enabled by default and does not explicitly say how to shut it off during install/in every routers wiki, it also does not warn it is a security risk that could identify the firmware giving a hacker more info about the firmware, leading them to a better understanding of how to exploit it. Heck that page will tell em if it is patched for heart-bleed and the other one they patched... cant remember name...

    Tomato's button does work or else pushing it wouldn't start the ssh session bud, to make something respond when pressed, you have to program the inputs for it or else it wouldn't do squat. They chose to implement it in that manner and i appreciate that they did as it is more secure this way than nvram reset. Merlin also makes an amazing point. I still have yet to see a single person address how NVRAM/factory reset is more secure than this.

    I cant spend a lot of time doing this when im getting paid to work on other issues and for me to do it i have to stand there with an 8lb laptop in my arms, and connect to a cable that hangs down. 20 ping cimmands should be ample considering the up time and the infrastructure they have, all of their ports are full and they have multiple switches. My device page is like 30-40 entries long just counting active devices, if it were going to do it, it would have. 20 ping commands is 100 pings overall. I also had to stay 2 hours late to troubleshoot another issue, so i really didn't have the time, but i wanted to give info to try to help.

    p.s. 1 ping out of 100 doesn't mean squat when you have as much goin on as mine does. It would be easy for a single one of those devices to make the traffic required to lag the router for 9ms if it timed out on a server it wanted. Before i put them out i had done hundreds of thousands of pings no issues(via script). I also check em randomly.

    if it is usb related, i feel like it would be more likely tied to 3g, hdd spin, or printer functions as i do not use them.
    Last edited: Feb 21, 2015
  11. Mr.CTT

    Mr.CTT Serious Server Member


    AP with wan off mode or the attach to br0 shuts off a significant amount of stuff... there has to be at least 20 things it shuts off i can think of in 1 min :/

    capt portal, 3g, firewall, dnsmasq, vlan2, bw monitor, ip monitor, qos, bw limiter, etc. if it doesn't kill it, it could put it in a state of low use or isolation that stops the issue. we don't know what fixes it, or exactly what causes it so that narrows it but still leaves a lot. did anyone try setting the logs to like 10 and tracing the time it happens?

    one thing this ping issue makes me think of is the older computers running win98. if you pinged em fast enough or made them ping something else fast enough, they would lag or ping time would increase. if something is hanging bad enough and taking a while to time out or stop couldn't it cause this?
  12. spykos

    spykos LI Guru Member

    I also have the ping issue. Laptop running windows 7 connected via cable directly to the n7000.
  13. johaug

    johaug Networkin' Nut Member

    High ping issue back after upgrade from 124 to 125, up to 400.0 ms. Ping low (ca 1 ms) when downloading data. Restarted R7000 four times to resolve the problem. Now about 0.3 ms
  14. Mr.CTT

    Mr.CTT Serious Server Member

    I hate to give you bad news, but most people having this issue would see it return soon after rebooting. you should check in on it some more and ensure it is not happening so that you do not see disconnects during times when you dont want them. 400ms... thats rough.
  15. Engineer

    Engineer Network Guru Member

    Mine did not return to high pings at all during normal operation once I finally stabilized it. However, I had to unplug it to do some testing and high pings returned after the reboot. I did not spend the time to do the rebooting again (took 15 times the first time).
  16. Mr.CTT

    Mr.CTT Serious Server Member

    Oh, good to know. I just remember someone saying that they would reboot loop it like that, but in a few hours it would be back, and everyone complaining and saying the were going to use ddwrt/kong. I am glad to hear there is something that helps. Sorry for misleading @johaug , but i would still suggest you check in on it for the next 24 hours to see if it is ok.

    @Engineer does the ping issue return when you reboot it, so you have to run it till it dies, or does it need power loss type of shutdown to bring the ping issue back? What have you observed.

    When i do the firmware on these, I do a lot of reboots to apply all the changes i need to make as it forces reboot on the GUI. I wounder if i could have rebooted it enough while setting it up i killed the issue, but it has been unplugged before, so that made me curious.
  17. Engineer

    Engineer Network Guru Member

    To be honest, I don't know if a simple reboot will cause it to return or not (warm reboot). It took 15 tries to get rid of the ping issue and it didn't return until I pulled the plug for the first reboot (cold reboot) since that time (over a week+ of time). I didn't feel like rebooting multiple times again. I moved to DD-WRT right after that with the updated Broadcom driver and then moved it to an AP so that I could test the RT-AC68U on Tomato (currently running as main router). I just moved the R7000 back to 125 Tomato ARM and tested both as an AP and main router and as soon as I turned it on as a main router, the high ping returned.
  18. Mr.CTT

    Mr.CTT Serious Server Member

    I see.
    if you still have it set up for tomato, could you turn off spindown, 3g, and printer support. Then reboot and see if it affects the ping? I am wishing i would have played with the bad ping router i had more before i sent it back for a new one haha.
  19. Engineer

    Engineer Network Guru Member

    I'll try a little later. It's back as an AP running off of a Tomato RT-AC68U right now (which runs well for what I'm doing by the way). The R7000 runs fine as an AP with Tomato. No issues that I can tell and no disconnects with devices either.

    I still think it's a hardware issue (race issue perhaps) based on comments from Netgear beta testers as well as Kong's statement in the ARM thread when I asked the question about the R7000 and how it was solved via DD-WRT.

    From Kong: "No we don't have the any ping issue, the issue was already present on older 4706 models and fixed it long time ago."

    When asked this..."So the issue is only on older 4706 hardware and has been fixed with an update of the 4706?"

    From Kong: "No the issue existed on all broadcom AC models, but it had different effects on mipsel and arm, since the arm is dual core."

    Eldrik and I could get no further comment on the subject.
  20. MrDoh

    MrDoh Addicted to LI Member

    When I was getting the ping time issue (latest v125), any reboot would re-trigger it. That's the biggest reason that I'm not using tomato on my R7000 as we speak. Get tired of rebooting to stabilize after reboot destabilized ping times. I hear people saying that the problem "just went away" (including Shibby), and keep hoping that'll happen for me. No luck. Also, no USB connected to it, nothing exotic, just using the routing and wireless.
  21. Mr.CTT

    Mr.CTT Serious Server Member

    This may be a hardware issue, but the fact it doesn't exist when in AP mode implies that one or more things that is turned off or changed when it switches to AP mode causes the issue. During this mode change, it disables or changes the setting(s) that causes it and although something may be crapping out hardware wise, putting the router in AP mode is done by software changes, and this appears to fix it.

    In my eyes, fixing it is a matter of figuring out what AP mode does or shuts off that causes the ping issue, as removing something from a bread board and replacing it isn't feasible.It is possible that the problem lies within the proper use of WAN's features itself and that it may not be fixable in our kernel or require back-port of a feature. This is based on a significant amount of assumptions made by me and i could be totally wrong about what is going on so take this with a grain of salt as i am human and i am not always right.

    Based on everything i have read, Bridging the Wan to lan doesn't cause the issue, i have seen many people state this before but just remain skeptical as they never really update after that. If this is true, it rules out it is a physical incompatibility problem with the wan port. All of the hardware works in this mode, so it isn't fully hardware related meaning a specific piece may break, but is still compatible given the right settings. This leaves only leaves software testing left to find the problem. Turning 1 thing off that differs each time between the two is the only real way to figure it out, but rebooting fixes the issue sometimes, so figuring out how to restore it 100% of the time, back to it's broken state is essential. Then tracking potential fixes and trying them multiple times is the only way to go. There is no specific ping issue thread, so finding useful posts is difficult because i see some in the normal shibby thread and some here, and the conversation topic changes frequently in-between with feature request and people asking about other stuff.

    @shibby20 could probably tell us what every single difference is between the two modes, but trying all the permutations possible before the solution is found could be tedious and difficult as I can think of many differences and he would probably have a much much longer list. There is also the fact that multiple things could trigger it with different circumstances. If you have the time to play with it, and would really like it fixed, i suggest people play with it, and collaborate together to find out how to cause the problem and what each has tried to fix it and the settings they use.

    The thing that stands out to me is that it seems like a hanging issue, and implies that something is breaking and accessing the router at a rate that is so fast, it will not allow a connection till a time out or link to what it is trying to talk to occurs. However it could be a broken wire type of thing there it randomly makes the connection, then looses it. Another possibility is something is looping and randomly breaks out of the loop given the right situation then re-enters it again and repeats the process until the trigger is hit pulling it out. Because no one really has given any great clues, it is hard to make assumptions. Kong is very very smart, he probably spent a great deal of time playing around to find a fix, or saw something. I would play with it to try to figure it out, but i don't have one for personal use yet, but plan to get one soon when i can sell my R6300 or i get a stroke of good luck on ebay.

    @Engineer do you think you could point me to where you acquired the information you gave? I tried looking a couple times for stuff like this but never really found really good results, mostly people complaining and offering no useful information.

    final edit 7:30 est

    less related info that could totally be wrong now

    The way that WiFi and LAN (copper connection) work as i was taught is with WiFi, only one device supposedly works at one time, however i have not read about the newer routers with more than 2 antennas and use multiple MIMO and could change this information drastically. when two devices talk at the same time on wifi, they hear each other and stop, then wait a random interval before trying to talk again and this happens at speeds so fast its ridiculous and you never usually feel it, but explains part of the latency lags you experience over wifi and see in pings / speed tests.

    Lan or cable connections are continuous, one devise can send and receive data at the speed of electricity via the cable and multiple devices can talk at one time because of the direct link through the pairs.

    The time out implies that somehow the router is either too busy or ignoring the pings, but why WiFi still works with no interference confuses the crap out of me as packets would enter the WAN cable to go to the internet and come back then be transmitted again.
    Last edited: Feb 22, 2015
  22. Engineer

    Engineer Network Guru Member

  23. Mercjoe

    Mercjoe Network Guru Member

    I do believe that in post #1296 I stated:

    Same as Toastman here with my R7000. Even set up as an AP the ping issue can just happen. There is no consistent trigger.

    It does not have to do what mode of operation you are in. It just happens. We have been unable to pin it down to a single trigger. If we could find a reliable way to duplicate it then it will be much easier to diagnose than just plain guesswork.
  24. Engineer

    Engineer Network Guru Member

    It's crazy because when I reboot when in DHCP mode, it ALWAYS happens if the router was having a good ping moment on the previous reboot. When in AP mode, I couldn't get it to happen in 10 reboots.
  25. Mercjoe

    Mercjoe Network Guru Member

    I feel your frustration.

    I have yet to get the ping problem on reboot when used as an AP. We stream our TV so I can tell when it starts. Just out of nowhere the ping issue will start up. SOMETIMES it will die off in a few minutes. Sometimes I just reboot the router and it does not come back for days.

    When I have enabled the R7000 for the network head to test how the builds are progressing I have had the ping problem happen three times on boot. I recently when from DSL to U-Verse. So I went from PPPoE to DHCP assignment in WAN setup. I have not had an opportunity to test the R7000 with the new U-Verse setup so I do not know it DHCP will set it off. I can tell you for sure that it happened with WAN set by PPPoE
  26. Mr.CTT

    Mr.CTT Serious Server Member

    Did you try putting the router in Gateway DHCP mode, but not use the WAN port? You would keep your Asus as the main one, but use only the ports on the R7000. If the Ping doesn't happen, it would mean it is something to do with the wan port's use and DHCP on the ISP side.

    I don't understand how this is possible or why you would have DHCP enabled. ATT U-verse to my knowledge does not have a transparent mode or rather modem mode, and it does not have a DMZ. You will create a double nat if you use the WAN port at all using this setup.
  27. Engineer

    Engineer Network Guru Member

    Mr.CTT, turned on DHCP and the ping was below 1ms for all pings. Connected the WAN port to the cable coming from my Asus router and it pulled an address (as expected) but did not let me connect to the web (again, as expected). However, a local PC attached to the R7000 had pings to the R7000 of all below 1ms (hundreds of them). Rebooting again to see if it goes up or not.

    On reboot, pings were still below 1ms.

    Turned on VPN Server (PPTP) and QOS and still pings below 1ms. Rebooted and pings below 1ms.

    Only time I get the high pings is when connected to cable modem (at least that I can reproduce).
    Last edited: Feb 22, 2015
  28. Mr.CTT

    Mr.CTT Serious Server Member

    I think you misread, I said not to use the wan port, but keep it in DHCP.
    Reguardless of whether you have DHCP, PPoE, Static, or any other setting set up for the WAN, if you only use the LAN ports, it will put the router in transparent mode.
    The only settings you need to change are you need to uncheck DHCP the LAN portion of Basic -> Network and ensure that your address in your LAN settings is within the subnet of your ASUS's DHCP. Setting bogus Static DHCP for the address your router is on will prevent any devices from causing a conflict as your router can only be set up statically on the LAN ports. You will have internet access when plugging the cable from the ASUS into a LAN port of the R7000. it will detect that it is downstream and transparently redirect the packets as it if were an un-managed switch.

    Additionally you could do what I do with all of my networks. I leave the subnet mask so that all 254 addresses are allocated by leaving the subnet mask at, but set my DHCP server from 1 to 248. Addresses 249,250,251,252, and 253 are for special equipment. I reserve 249 for pixelserv, and 250-253 for access points. This ensures the dhcp never hands out an address that is assigned to an access point. I normally set my routers LAN address to .254 as most people look for a router to be at .1

    My intent was to leave the DHCP WAN stuff running, but never connect the WAN port to the ISP. If the ping issue stopped 100% when doing this, then it could insinuate it was caused by an incompatibility between the ISP and the WAN setup on the R7000 or something that is within that environment. Note that if the ping issue doesn't show up, it doesn't necessarily mean it is caused by wan settings, but insinuates that it is related to them somehow in addition to the fact disabling WAN stops the issue. I feel like you will have 0 ping issue when doing this setup based on the fact that other people have DHCP enabled and do not have problems, but i could be wrong.

    Don't feel like you have to do anything I suggest, it is just how I would try to trouble shoot the problem and why.

    My next step i would try after this is switching going to Advanced -> VLAN and un-checking any port 1-4. Then I would check it under VLAN 2 where the WAN port is and uncheck the WAN port. Then go back to where the rest of the ports were selected and check the wan port there apply and save.

    This would rule out it is a port incompatibility and essentially switch the WAN setting from the WAN port to the port you selected and turn the WAN port into a LAN port.

    But this also requires someone both be comfortable with changing these settings, and they have the time to move the router to be the main router handing the gateway to their ISP. On top pf that they would want to back up their config prior to doing this to be safe. so I don't suggest anyone attempt it unless they know what they are doing. I can do this for myself later and have a lot of other safe suggestions that would go along with the test from above.
    Last edited: Feb 23, 2015
  29. Engineer

    Engineer Network Guru Member

    I did that. I tried everything with and without WAN port being connected. All pings below 1ms. Even when WAN port was connected, it was connected to a LAN port of my main AC68U router and not directly to the ISP. All pings below 1ms.
  30. Mr.CTT

    Mr.CTT Serious Server Member

    Oh, I see. That is my bad then. I read that you used the WAN in the previous post and thought you didn't attempt it the other way. That is interesting however. Who is your ISP, and what modem do you have if you don't mind answering? I haven't been a able to reproduce the ping issue at all, and use SB6121's and SB6141's.
  31. Engineer

    Engineer Network Guru Member

    Time Warner Cable and SB6141.
  32. Mercjoe

    Mercjoe Network Guru Member

    DHCP is used to get the IP passed from the U-Verse modem when said modem is set up in IP passthrough mode.

    Not a double NAT as the U-Verse modem is not using a NAT in that mode.

    Anyway, the ping problem exists regardless of the mode used.
  33. Edrikk

    Edrikk Network Guru Member

    @shibby20 @RMerlin

    Might be a red-hearing, but I found this in the dd-wrt git repository, dated Sept 11, 2013 - Changeset 22327:

    allow to change passive mode through et_dispatch_mode in order to improve pings
    The change appears to be specific to the Northstar board (i.e. ARM).

    I also found references to it here which I believe is openwrt (fork?) for the 6250 (also ARM).

    I could not find any references in the Tomato code (simply searching git, not a proper grep).

    I personally haven't experienced the 'ping' issue, but since we don't know the root cause, I wanted to hopefully help...

    From that last link, there is clearly a difference between the "ET ALL PASSIVE" and "ET ALL PASSIVE with runtime setting"... No idea what this is though...

    @shibby20 A test build to see if this fixes people's issue might not be a bad idea... ;)
    Mr.CTT likes this.
  34. Engineer

    Engineer Network Guru Member

    Thanks for your searching Edrikk. I'll be happy to test any changes that are made in this area. Already have the R7000 on Tomato and will move it from AP to main router to test.
  35. Mr.CTT

    Mr.CTT Serious Server Member

    That is so friggin weird.... You use the same ISP as I do so why do i suffer the pings and you do not... do you use custom DNS on your router and have the option unchecked so that you don't use TWC's DNS? They have given me a lot of issues! Sometimes in DNS Benchmark, they say they are down.... This makes me think that the above fix will not work for you, but I hope it does. Please update.

    There was another person with a U-Verse, but he did not have this feature as far as i am aware. I will have to follow up with him and ensure he knows it is available on a model. What model do you have? Do you have full WAN capabilities?

    I really really hope this helps... but i feel like if it were that simple, shibby would have caught it, and it would be more known about.

    @Edrikk, @Engineer, and anyone. Do you know how you would apply this? I would assume you could make an NVRAM entry, but I am unsure if it would do anything and what to type. I will try to telnet and play with it later in my 6300v1 as it is an ARM I believe Nope its Broadcom SoaB.
    Last edited: Feb 24, 2015
  36. Engineer

    Engineer Network Guru Member

    I use level 3 DNS ( and I do not use TWC's DNS.
  37. Mr.CTT

    Mr.CTT Serious Server Member

    Well I hope that helps. I know that i have been through NVRAM on the R7000 and I have never seen that before. Hopefully there is a way to implement that for you. But If it were an ISP incompatibility, I believe that I would have the same issues that you do, unless something i change standard fixes it.

    (Please) Do you think you could add the temperatures of wl0 and wl1 to the overview of your builds as seen in Hyzoom's firmware? It would be very very helpful to me as I force overclock on most of my router's wireless due to ceiling tiles causing reduced distance in drop ceilings. I would appreciate it greatly... If you could tell me how to do it myself, that would work also.
    Shibby Request.png
  38. Mercjoe

    Mercjoe Network Guru Member

  39. Mr.CTT

    Mr.CTT Serious Server Member

    yep exactly what i was thinking of. So you found an option that fixed this for ya? Do you still have all your normal stuff working like QoS and such?

    also late response but

    no i was more looking for
    Last edited: Feb 24, 2015
  40. Engineer

    Engineer Network Guru Member

    I should have said Netgear Beta Tester instead of Testers. It was via PM so I'm not sure whether that person wishes to be disclosed or not. Sorry.
  41. tvlz

    tvlz LI Guru Member

    This was already tried, no luck - dd-wrt also made changes in wl code(Changeset 22328), maybe this will work?

    nvram set wl_dispatch_mode=0
    nvram commit
    EDIT:Fix typo

    It would be easy if the Hyzoom source was released - I think it needs to be smuggled out of China:(
    Last edited: Feb 24, 2015
  42. RMerlin

    RMerlin Network Guru Member

  43. Mr.CTT

    Mr.CTT Serious Server Member

    i dont that that will work..

    nvram set wl_dispatch_mode=1 (or maybe 2?)
    nvram commit

    is what it needs to be. you never saved it to nvram, or does that do the same thing as nvram commit? Also 0 generally means off you would want it to be 1 for yes. however we want the special one so maybe 2 would work? I feel like this wouldn't work at all tho.

    I feel like @RMerlin would have commented if he thought this would work also, but no comment seems like bad mojo.

    sorry merlin, this is a bit over my head. could you provide some guidance an a link? i have never modified the fw before... i wouldn't mind learning... but if i went that far i would prolly add cpu temps in also. and any other status i could find
    Last edited: Feb 24, 2015
  44. Edrikk

    Edrikk Network Guru Member

    Is it just me, or are a lot of "innocent" posts being deleted? One of RMerlin's, one of mine, and one from Shibby at least that that I read are not here any longer...
  45. Mr.CTT

    Mr.CTT Serious Server Member

    I have thought some were missing before, or rather that i knew i had read them, but when i searched for them they were nowhere to be found... but i have a bad memory so i just figured i was looking in the wrong place. however for spams sake of making this thread useful, deleting isn't that bad an idea... like this post for example... doesn't really help archive or solve issues. so it could be deleted haha. I really do get irritated when i have to go through 3 pages of junk just to find what i needed.
  46. myersw

    myersw Network Guru Member

    I don't understand how this is possible or why you would have DHCP enabled. ATT U-verse to my knowledge does not have a transparent mode or rather modem mode, and it does not have a DMZ. You will create a double nat if you use the WAN port at all using this setup.

    ATT U-Verse. Some U-Verse residential gateways (RG) do have a DMZ setting. My 3600 has a DMZ and I have my R7000 setting it it.
    Last edited: Feb 25, 2015
  47. dskete

    dskete Networkin' Nut Member

    I few posts are indeed missing, including one from shibby where he said that the DD-WRT change pointed out by user 'Edrikk' is already included. He has noticed other differences w.r.t. Netgear sources which might affect pings.
  48. Engineer

    Engineer Network Guru Member

    Now that you mention it, yes, posts are gone. Not sure why any of those posts would have been deleted especially since they were (are) trying to track down a current issue with Tomato in regards to the R7000 high ping.
  49. Thomas Begley

    Thomas Begley Serious Server Member

    Can anyone please confirm if QoS on 1.25 for the R7000 is supposed to be fully functional or not please.
  50. RMerlin

    RMerlin Network Guru Member

    I'm afraid I can't help you with that. It's not a 5 mins task, you will have to implement it in the httpd daemon, and then modify the webui to retrieve that information from the httpd daemon, render and display it on the webui.

    I have never compiled or modified Tomato myself, so I'm even less able to guide you as to how this should be done, sorry. I was just showing that the hardest part (the backend code) can be based on my own code, at least for the newer Broadcom devices. This is something Shibby/Toastman would easily be able to implement most likely, if they have the desire to.
  51. tvlz

    tvlz LI Guru Member

  52. dskete

    dskete Networkin' Nut Member

    shibby indicated in one of his deleted posts that "wl_dispatch_mode" is not implemented in the firmware and setting it should have no effect.
  53. RMerlin

    RMerlin Network Guru Member

    That's why I pointed at my own, open source code, which contains everything you really need to add temperature monitoring to your own Tomato forks. No need to hold for that Chinese fork. The code I pointed to is what retrieve the temperature from a Broadcom radio, by querying its driver.
  54. Mr.CTT

    Mr.CTT Serious Server Member

    that is definitely... a lot... ill try to work on it. I wanted to figure out how to view all the code in the firmware but never could figure out what to do to make it viewable. Is there any way for me to extract shibby 124 and open the html file with something like notepadd++ to edit the file directly, then re-pack it and use that to flash from 122 to 124?

    it is probably way more complicated than that?

    Given Engineer and I are using the same equipment, and the same ISP, i feel as though this wouldn't affect it at all. I get my router Friday.

    @Engineer would you mind sending me your nvram dump? Please make sure to delete all your passwords and change any names you want of the networks. I would like to start with a known broken build, use telnet to change all of the settings, commit, and tinker with it over the weekend to see if i can isolate the problem. If anyone has ping so bad it is dropping your connections or ping is horrible no matter what you do, i would really like that nvram dump. If I mimic someones exact settings, and it works 100% fine, then i will be puzzled.
  55. Engineer

    Engineer Network Guru Member

    I will if you can give me the commands to do so. Also, there is a chance, with the hardware talk that I've had with another, that your router has a different revision of something in it that has corrected the issue. Given that my router came from a rural Walmart, it's possible that it sat on the shelf for some time (especially with a shelf price of $200 on it) before I picked it up (at a much lower...much much lower rate! :D ). Maybe I can find the manufacturing date on it somewhere and we can somehow compare that.
  56. RMerlin

    RMerlin Network Guru Member

    You need to modify the source code of the httpd server. It's not just an HTML-level change. That means writing C code and recompiling the whole firmware.
  57. ipse

    ipse LI Guru Member

    I suggest using PingPlotter for your tests as it's very configurable (ping interval, data gathering, stats):

    Target Name: NTHWK-R7000
    Date/Time: 2/25/2015 11:46:37 to 2/25/2015 11:46:49

    Hop Sent Err PL% Min Max Avg Host Name / [IP]
    2 200 0 0.0 0 1 0 NTHWK-R7000 []

    These are pings sent every 50ms...cuts down your test time significantly :) test was over wireless.
  58. dskete

    dskete Networkin' Nut Member

    'nvram dump' can be used ...

    Here is my dump. I switched from DD-WRT; I did a nvram reset from the GUI but not an 'nvram erase'. I have the ping issue but haven't gotten disconnected from WAN.


    Attached Files:

  59. Engineer

    Engineer Network Guru Member

    Not sure if you're aware but the ping issue, strangely enough, is only over the wired LAN ports.
  60. ipse

    ipse LI Guru Member

    I am...I was just stating that my test was over wireless - just in case someone asks :)
    FWIW...I get stellar results only over 5GHz despite my 2.4GHz not being crowded or anything. I have significant variations over 2.4 (but still, 1-15ms only, with very rare 50+ms)

    PS Just curious: the "ping issue" is it only client->router or also from router->client? (not talking round trip, but initiating the ping from router).
    Last edited: Feb 25, 2015
  61. shibby20

    shibby20 Network Guru Member

    [RELEASE] v126 for ARM

    Please read changelog first. The most important changes is support of 2 new routers: Netgear R6250 and R6300v2.

    Best Regards.
  62. Toastman

    Toastman Super Moderator Staff Member Member

    On my R7000, the ping issue is on both Wireless and Wired ports.

    The ISP used is irrelevant - if we can't even get reliable pings from connection to a LAN port.
  63. XVortex

    XVortex Addicted to LI Member

    Just wondering, where is the ws880 fw?
  64. Mr.CTT

    Mr.CTT Serious Server Member

    oh, so it's not like an exe where you have files paced together that work towards separate things in a program?

    That is different... I have never heard of someone saying it affected WiFi.

    Administration -> DEBUG -> "Download NVRAM dump. save it somewhere and open with notepad++.
    every password you have to anything, look for with cntrl F. then browse it to ensure you dont see something that you dont want me to see like a mac ID or something if you are that security conscious. I never really understood why ppl black out MACs.. you can change them at will and it isn't hard to do.. but to each his own.

    Buy a new one at walmart, and return the old one using the new one's receipt... they buy those things for literally like 45% what they cost by the time you factor in shelf priority... i friggin hate walmart...(sorry to flame, but i can't help it, i just have nothing good to say about them other than i would buy dog food there since Sam Walton actually fed it to his dog.)

    if its not here there isnt one for shibby
    download here
  65. The Master

    The Master Network Guru Member

    Changelog:RAID module and mdadm tool

    WTF Raid @ Router?? How? Whhy? Please explane me for what this is? THX
    126 Working like 125 -> OK No Ping Problem


    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Ping-Statistik für
        Pakete: Gesendet = 4059, Empfangen = 4059, Verloren = 0
        (0% Verlust),
    Ca. Zeitangaben in Millisek.:
        Minimum = 0ms, Maximum = 3ms, Mittelwert = 0ms
    Last edited: Feb 26, 2015
    Edrikk likes this.
  66. dskete

    dskete Networkin' Nut Member

    Ping times are more stable on WiFI, but every 10 pings or so, there is one that jumps to 50 ms or 60 ms.

    I have uploaded my nvram dump a few posts back.

  67. MrDoh

    MrDoh Addicted to LI Member

    Same here, I see the random ping time issue on both wired ports and on wireless on the R7000.
    Last edited: Feb 26, 2015
  68. Mr.CTT

    Mr.CTT Serious Server Member

    has anyone ever had issues with shibby's firmware re implementing its WAN bridge to br0 after changing from DHCP back to disabled? i am on 123, still and it is apparently broken now for me.
  69. TheSteve

    TheSteve Addicted to LI Member

    Finally experienced the R7000 ping issue today after a power down to update some wiring. It was insanely bad over the wired connection, some pings were as high as 1 second. A reboot did nothing to improve it but I did observe a few things and am wondering if others see the same.
    Reboot the router and leave a wired connection pinging. When the pings start responding I found them to be under 1ms as they should be. At this point the web interface is not yet available. I attempted to reload the web interface a few times, as soon as it loaded the ping issues began. I rebooted and was able to get the exact same results. I then rebooted again but didn't try loading the web interface for at least a minute after I was receiving a response to the pinging. This time pings remained under 1ms as they should. Is it possible the ping issues could be related to the router receiving traffic over the wired lan interface before or while it is being configured and that is confusing it from then on - as in it never quite configures properly. Or perhaps it doesn't like the traffic on the wired interface before the wireless interface is also up(wired comes up before wireless).

    If I think back this is the first time I have rebooted the router and tried to access it right away via the wired network, in the past I always used wireless which comes up after the wired interface. Which would have given the wired interface time to settle down/configure. I have never seen the ping issue before and have always first accessed the router via wireless, not the wired interface.
    Hopefully someone else can give it a try and see if they can repeat my results.
  70. ghoffman

    ghoffman Network Guru Member

    @TheSteve - i have an r6300v2. it has had experience with ping issues on dd-wrt and tomato. for the pst two weeks, (against shibby's advice) i had it running quite well on the r7000 v125 build of shibby's tomato. the ping issue was present (lan and wlan) from the start, but disappeared after two reboots.

    yesterday i was almost ecstatic when shibby released v126 build for r6300v2. after reflashing, doing a complete nvram erase, and reconfiguring - the ping issue was back. multiple reboots have not solved it.

    i too thought maybe it is a particular module that was causing the problem, because wathcing the serial console while also pinging during a reboot, it appeared that pings went up during booting after the initialization process.

    so i tested your observation a couple times. result: i usually had high pings starting with the first ping response. (there are occasional ping<1ms in a perisstent ping test, but the average for me is in the 15-45 range.) i also killed off processes after aboot and watched the pings - but no effect on pings (i was not able to stop crond - it kep reappearing). deactivating wireless has had no effect on pings for me.

    so - now in v126 for r6300v2 - i'm stuck with high pings. i'm not sur ewhta my next step is. i love tomato but this is a significant step backward from my trust e4200 on tomato v121......which was almost perfect.
  71. Mr.CTT

    Mr.CTT Serious Server Member

    I know that it sucks, but try backdating to shibby 122 and see if your ping problem changes. I base that on no factual evidence or sufficient proof, and do not know that it will help you, but it is a hunch based off a similar router i use.
  72. somms

    somms Network Guru Member


    Never saw this ping issue using Shibby's builds exclusively on my R7000.

    While using v124 up to v125 and now v126 no ping issue as pictured above. I did have a random reboot for the short time I was using v125 but after taking Shibby's advice to completely flush the NVRAM, I am hopeful this has corrected this!;)
  73. TheSteve

    TheSteve Addicted to LI Member

    Perhaps I came across a different issue. Hopefully I can spend more time experimenting this weekend. The ping issue I saw was very bad, much worse from the sounds of it compared to the ping issue other people see.

    One other thing I have observed. While I saw the very high ping if I transferred a file from the router via ftp it transferred at the expected speed and while transferring the file the ping time was under 1ms. When the file was done the ping times went back up again. I have seen something similar when transferring via wireless. I get the odd high ping on both 2.4 GHz and 5 GHz but it never happens during a file transfer.
  74. lepa71

    lepa71 Networkin' Nut Member

    You don't think it could be your drivers. I had big issues with Intel 7260AC card drivers when got it, but after last update it's much better. This is on Netgear fw. I have R6250.
  75. TheSteve

    TheSteve Addicted to LI Member

    The random wireless high ping seems to occur with all devices on my network. It doesn't matter the wireless band, protocol or connection speed.
  76. dskete

    dskete Networkin' Nut Member

    I can confirm TheSteve's observation; when I was doing a speed test, ping times became 1 ms and no fluctuation. It's as if the router becomes bored and does not want to respond to ICMP packets in a timely fashion when there's not much data to be processed :)
  77. crashnburn

    crashnburn Network Guru Member

    Awesome chart.

    Would this hold true for most routers as they DB numbers correspond to country based specs they have to adhere to.

  78. The Master

    The Master Network Guru Member

    @shibby20 after 2 days with V126 no ping Problem:

    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Antwort von Bytes=32 Zeit<1ms TTL=64
    Ping-Statistik für
        Pakete: Gesendet = 2906, Empfangen = 2906, Verloren = 0
        (0% Verlust),
    Ca. Zeitangaben in Millisek.:
        Minimum = 0ms, Maximum = 1ms, Mittelwert = 0ms
  79. somms

    somms Network Guru Member

    Fix for Erratic Windows 7 Ping

    No way it could be that easy!?

    Wonder why some always are experiencing the ping 'issue' while other like myself aren't!?
  80. stuffedtiger

    stuffedtiger Networkin' Nut Member

    While attempting to set up virtual wireless I noticed two things.
    First, under the 5ghz wl1 tab there is no option for 80MHz channel width, but there is in Basic -> Network.
    Second, I set wl0.1 to LAN1 so I could manage bandwidth separately for the virtual wireless, but when I try to connect a device it won't connect. The device will connect if I set wl0.1 to LAN0 though.
  81. Engineer

    Engineer Network Guru Member

    SNB is down but was the post specific to an R7000 wired ping? I've been able to replicate it both via Windows 7 and via the command line interface of another router (RT-AC68U to the R7000).

    I still think there is a hardware issue that has been patched via firmwares (DD-WRT and Netgear have it) and later fixed via hardware fix.
  82. juggie

    juggie Addicted to LI Member

    I set up v126 last night on my R6250, before I went to sleep everything was ok but when I woke up this morning super slow. I logged in to the router over SSH and rebooted it and it is fine (for now). I also had this problem with DDWRT on this router but stock is fine.
  83. Mr.CTT

    Mr.CTT Serious Server Member

    OK, so I received my R7000. I banged my head all day trying to set it up so that i could run the R7000 3rd in line (and still have 2 in Gateway mode) but yet keep it out of transparent mode. I ended up putting it in static mode and editing my VLANs to set it up so that I could ensure all traffic was routed through the DMZ but separated from the traffic on the 2nd router in line.

    I was having a lot of difficulties with pings. they would jump between 1-4ms then spike to 150-500 and return to 1-4ms for 20-30 more pings and repeat on all devices

    At first I thought this was because my VLANs that were causing latency and did reboots. I found this helped with the low pings making 1ms much more common(probably because I had to make 10-15 VLAN changes trying to get everything to snyc the way i wanted. Today I was looking at it and noticed I had an Inconsistent TTL between the 3 routers and on the R7000. Everything else runs at 64, it was running at 63. So I went under the contrac/netfilter and changed the TTL to custom and set it to 64 on all of my routers. this helped a little.

    I then thought about it a little and how most people say it seems like then you run the router harder the pings are more responsive and stable, so i adjusted my TTL to 32 on all of my routers... This helped me A LOT over all, I have no more big lag spikes when talking to anything but the R7000... I believe that my VLANs are causing most of the latency from 1-4. I am unsure about the spikes still and what cause them, but as you can see 300 pings and the highest is now 31. I would post my previous ones from last night, but I apparently didn't save them. which is my bad.

    There is one very big thing, TTL adjustment on the R7000 in 126 is broken. I have it set to 32 and it is still showing 64...

    Attached Files:

    Last edited: Mar 1, 2015
  84. juggie

    juggie Addicted to LI Member

    The win fix did not do anything, when I awoke this am all my devices had huge wifi problems android, etc until I did a reboot of the router.
  85. Mr.CTT

    Mr.CTT Serious Server Member

    I see, I could see this helping in some environments. My sister uses a 4 year old Dir-655 that had factory firmware on it. The biggest problem with that is it did not support time being after 2012 i believe, so her time was always off. This ended up causing conflicts between all devices and when she connected to her ISP, it literally took 10-15 minutes to sync before she had a connection. After the time fix, it was a few seconds and it fixed alot of her weird issues. I don't believe it was the FW changes as I had one during the time the clock was right years ago in the FW and it ran like a boss.

    I honestly wish that router could run tomato, it is literally the most rock solid router I have ever seen with the longest 2.4ghz range. I honestly think it's better than the RT-N16 range wise requiring a 80-100mw overclock to match it.
    Last edited: Mar 1, 2015
  86. shibby20

    shibby20 Network Guru Member

    using this you can create a RAID0 or RAID1 between 2 or more storage devices.
    The Master likes this.
  87. Edrikk

    Edrikk Network Guru Member

    I think what was meant was, is this really useful on a router?
    Software Raid requires some processing, and as it is, routers can barely push data straight from a single 'normal' usb disk.

    Also because of the various problems that exist in the ARM builds (ping, QoS, etc), bolting on another piece is (no disrespect meant at all) "weird"... ;)
  88. ShaRose

    ShaRose Reformed Router Member

    If you are adding on new bits, might I suggest a ui based optware control, and a way to set a storage device's mount location in the usb support tab?

    Another feature that'd be neat is adding CUPS and a few printer libraries to the optware repo, to allow actually sharing a printer over samba instead.

    Also, adding ui support for selecting a https certificate. Currently, you can't do it at all because there isn't a nvram setfb64 currently.
  89. Mr.CTT

    Mr.CTT Serious Server Member

    I have been testing port 1 in the GUI, which is actually labeled port 4 on the router's outside as my WAN port using the vlan page. It seems to have helped a little with my ping issues, but I want to give it some more time before i post pings. all my pings max out at 8ms now, but i have probably rebooted 12-13 times playing with stuff.

    Just kind of a heads up any of you who like to play with VLANs.

    Port 4 on the outside is port1 in the GUI
    Port 3 on the outside is port 2 in the GUI
    Port 2 on the outside is port 3 in the GUI
    Port 1 on the outside is port 4 in the GUI.
    The WAN port is correct.
    If you think that inverting port order will help you, it won't. It is broken still in 126.
    VID is also broken, so be sure to match them up.

    Does anyone know if "NVRAM Commit" is broken? Every time i type it in, the changes never seem to get made. Putty also says nothing when i type it in, instead of the normal committing changes.... blabla.....
    Is it just a different command now?
    Last edited: Mar 4, 2015
  90. MrDoh

    MrDoh Addicted to LI Member

    Some nvram variables may be re-written at boot by the firmware itself. I'm guessing, but the variables that you've set and then committed might be some of those. In that case, it doesn't matter if you change and commit your changes, they'll be overwritten when you reboot. In that case, you'd need to change them in a script that runs after the firmware changes them.
  91. Mr.CTT

    Mr.CTT Serious Server Member

    unless the webgui is incorrect, my changes work when I use "Administration" -> "Debugging" -> "NVRAM Commit" but they don't seem to take when I use nvram commit in telnet. here is why I am asking. Two puttys side by side, left is the R7000(Shibby126) and right is my RT-N16(Shibby125). The R7000 acts like it is not a command.

    (ignore the = sign I accidentally hit this when I took the screen shot)

    There are problems with virtual wireless...
    -You can only have 1 Virtual wireless access point per band(126 and older).
    -You can only have a maximum of 2 LANs wirelessly
    (I have only tested br0 in 2.4ghz & 5ghz and br1 on virtual 1 of both 2.4ghz and 5ghz)
    -There is also a problem with MAC addresses overlapping.

    I suggest you check your MAC's. I will post up my settings for my virtual wireless when I can get them to see if it helps you because i wrote my specifics from memory and I'm only 90% sure about them.

    P.s. Can anyone tell me the best way to post items that are broken so that @shibby20 can see them? I posted multiple of these issues in 122 and none of them were addressed or even acknowledged, so I have no clue if he even noticed them. I don't mean to push, I know he is one person, but I do want to make sure that they get put on the list for a later release.
    Last edited: Mar 4, 2015
    Iceman_jkh likes this.
  92. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    if ur gonna commit you might wanna save so the commit is applied on reboot
  93. Mr.CTT

    Mr.CTT Serious Server Member

    I don't follow? I thought NVRAM was loaded on reboot? Any changes i have ever made to NVRAM then done a commit for, have taken (shown on GUI) after re-booting... is the GUI separate or something?

    there are some that haven't done this like "pa0maxpwr=" that I have found are overwritten in NVRAM upon reboot.

    Would you mind elaborating more as to what you mean please? I have never used save before, doing a commit has worked for most everything I have tried to edit so far.

    also that doesn't address why nvram commit isn't saying that it is doing a commit, then saying it is done.
  94. MrDoh

    MrDoh Addicted to LI Member

    Okay, when I type nvram commit after doing an nvram set, it just gives me the next prompt. I don't recall this ever being any different, but I don't use nvram commit very often. What you're saying is odd, though, since I'm pretty sure that the GUI nvram commit would just invoke the same Linux nvram commit that the shell does when using telnet. So why one would act differently than the other, I suppose you'd have to go back to source code and see.

    I did do a simple-minded test...just did an nvram set of a variable name not currently in use. Then an nvram commit. Rebooted, and the nvram variable that I set was still there and set to the value that I set it to. So I'm still not sure what you're seeing, since nvram commit seems to work for me from telnet.
    Last edited: Mar 5, 2015
  95. Mr.CTT

    Mr.CTT Serious Server Member

    The only reason I really asked was mainly because of how one says it does the nvram commit and the other doesn't. It only does it every once in a while, where I could swear I set something, then did an NVRAM Commit, rebooted and noticed something wasn't set how I thought I had set it. I don't really have any proof of it because every time i tried to make it happen, it didn't happen =/ , but I remembered it and wanted to mention it to see if anyone else had the problem, while bringing up the difference in nvram commit between ARM and not ARM.
  96. MrDoh

    MrDoh Addicted to LI Member

    Yes, I was reacting to your first question of whether anyone else had noticed that "nvram commit" is broken. I don't think it is, at least not for me. Neither of the ARM-based routers that I have here that I can telnet into have have any special output for the nvram commit command, they just do it (quickly) and then issue the prompt for the next command.
  97. stuffedtiger

    stuffedtiger Networkin' Nut Member

    I turned off the 5ghz wireless and was able to connect to the wl0.1 on LAN1. I then went to the bandwidth limiter page and set it up, but when I hit save nothing happened.
    I didn't check MAC addresses since I could successfully connect to wl0.1.
  98. shibby20

    shibby20 Network Guru Member

    HOW TO FIX PING ISSUE ON R7000 (alnd probably on R6250/R6300v2 too).

    Run all those commands:
    and do reboot. It will:
    1) disable second *FAKE* LAN (eth1) interface
    2) WiFi 2,4GHz becomes eth1 (now it`s eth2) and 5GHz becomes eth2 (not it`s eth3)
    3) Ethernet Ports State should works now

    Big thanks to @tvlz. He found a clue to unset et1macaddr variable!!

    Solution has been tested by few users (including Me, Jacky444 and Toastman).

    Feedback welcome.

    Best Regards.
    mmosoll, btaroli, cybrnook and 7 others like this.
  99. bogderpirat

    bogderpirat Network Guru Member

    yeah, works now. good job!
  100. stuffedtiger

    stuffedtiger Networkin' Nut Member

    After running these commands on my RT-AC68U, it appears that my virtual wireless problem was fixed. I can successfully connect to wl0.1, whose bridge is set to LAN1, while wl0 and wl1 are both enabled. The commands were run after a thorough reset as I didn't know if they would mess anything with my current settings.
    I also tested QoS (forgive me, I didn't know if this problem was related) and came to the conclusion that ipv6 connections were getting properly classified, but ipv4 connections were not. This might have been the case prior to the nvram changes, but I can't remember.
    Last edited: Mar 5, 2015
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice