Tomato for ARM routers

Discussion in 'Tomato Firmware' started by kthaddock, Feb 28, 2014.

  1. jsmiddleton4

    jsmiddleton4 Network Guru Member

    I don't have those lan port graphics. Did the first bootup after install but they went away.
  2. AKSN74

    AKSN74 Network Newbie Member

    Thanks for ur reply, now I know what that means.

    And back to the problem, does anyone got a same problem when updated to v121 /w AC56U?
  3. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Having trouble with WPA2 and not connecting and version 121. Had this before with very early releases. If I change security so as Apple devices connect, Atheros chipsets don't, etc. Have cleared all previous wireless accounts. Did not have this with Netgear, previous Shibby releases nor with DD-WRT.
  4. MrDoh

    MrDoh Addicted to LI Member

    Not seeing that here. Our iPhone 4 and iPad 3 both connect as usual with v121. And so does all our other wireless stuff *smile*. Don't have any Apple laptops or computers at the moment, though.
  5. jsmiddleton4

    jsmiddleton4 Network Guru Member

    If the ipads, iphones connect, the Intel and Atheros based chipset clients do not. Intel Atheros based clients connect, iPads and iPhones do not. It is something in the WPA2 AES/TKIP stuff. Just as before. Turn off wireless security and all clients connect. Just as before as well.

    Back to DD-WRT, channels, frequency, wireless security, passwords the same settings and all clients connect.
  6. thedak

    thedak Connected Client Member

    I have 121 on my R7000 configured with 2.5GHz using mixed WPA/WPA2 PSK (AES/TKIP) and 5.0GHz using WPA2 PSK (AES). I have a mix of Intel laptops, Android tablets/phones, and iOS devices. My iPhones (4S and 5), and iPads (Gen 1 and Gen 3) connect without issue.
  7. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Glad it is working for you. No options worked for me.

    As noted WPA2 Personal Mixed for both channels working with dd-wrt. Did with Shibby 120 as well. Did not with earlier version of Shibby. Does not for me with 121.
  8. James Good

    James Good Serious Server Member

    Hello all,

    Running Shibby's 121 here on an AC68U. Very nice work, really nice to have QOS working, has really improved my experience with Crashplan (stopping it from crippling my entire network when backing up). I did clear the NVRAM after the initial install (upgrade from 120), and everything has been rock solid for a few days now.

    However, can anyone confirm the status of the QOS 'Transfer Rates' and 'View Details' screens? These appear to be showing some mixed up info; IP addresses showing incorrect rules applied, transfers to addresses which I'm sure those machines are not doing (but others should be). Or am I going crazy? Those screens would be useful in developing my QOS rules further...


  9. MaX PL

    MaX PL Networkin' Nut Member

    Either my config is off somehow, or theres interference somewhere, but i can't get my 2.4ghz speeds(speedtest) to match those on 118 or to match my 5ghz speeds on 121.

    i'm going back to 118 to test this.
  10. MaX PL

    MaX PL Networkin' Nut Member

    ok i figured it out.

    USA set for 2.4 and Singapore for 5ghz.

    121 defaults to something else i believe and i missed that change.
    Last edited: Jul 19, 2014
  11. thedak

    thedak Connected Client Member

    Is there anything special for getting web logging on 121? I have it enabled but it appears to only capture data sporadically.
    ak907 likes this.
  12. MrDoh

    MrDoh Addicted to LI Member

    I found that as well. It fooled me at first, since it started to capture "real-time" data, but didn't continue or save data.
    ak907 likes this.
  13. Victek

    Victek Network Guru Member

    Thanks for feedback about Tomato RAF version on ARM routers. We follow..
  14. ipse

    ipse LI Guru Member

    Guys...I have atrocious ping response times TO my Note 3 phone running 4.4.2. Two tablets on the same 5GHz network have sub-10ms response times, but this is what I get with the phone:

    PING ( 56 data bytes
    64 bytes from seq=0 ttl=64 time=259.577 ms
    64 bytes from seq=1 ttl=64 time=39.565 ms
    64 bytes from seq=2 ttl=64 time=211.565 ms
    64 bytes from seq=3 ttl=64 time=367.316 ms
    64 bytes from seq=4 ttl=64 time=201.678 ms
    64 bytes from seq=5 ttl=64 time=279.561 ms
    64 bytes from seq=6 ttl=64 time=48.988 ms
    64 bytes from seq=7 ttl=64 time=229.852 ms
    64 bytes from seq=8 ttl=64 time=304.641 ms
    64 bytes from seq=9 ttl=64 time=162.251 ms
    This is with Shibby 121...can someone help me keep my sanity and tell me i'm not alone? To be clear, all other devices in the house (10-12) have 1ms ping times (except when ping goes berserk) but the phone is nuts.
    Oh, to make it worse, the pings from the phone to router are in the 20+ms range...what you see above are pings FROM router (R7000). And yes, this is puzzling, as I know what ICMP echo-request and replies are :)
    While testing the phone is awake and wifi is NOT in power-saving mode or something.

    PS I HOPE this is the right thread to post this is an ARM router and ...oh get my drift.
  15. kamaaina

    kamaaina Serious Server Member

    Used a second R7000 with original Netgear FW as an access point behind the first R7000 w/Shibby. Took only 48h for all users to complain on a variety of (Apple) devices that the Netgear FW box has wireless signal issues. Flashed that one to v121 now as well. Was wondering about losing the 5th port but then figured it out. You can disable DHCP WAN service and click the checkbox to map the WAN port to LAN and bingo you have a 5-port AP. Set the first routers IP for GW and DNS and everything works great. You obviously need to disable DHCP and NAT on the second box and set a LAN IP outside of the range of the first router. It's really all coming together now. Great work.

    Somebody else was wondering about VPN. I have the VPN client running on router 1 since version 118 and it has been stable with 118-121 so far. VPN client works great. I have not tested the server functionality.
    Last edited: Jul 22, 2014
  16. Grimson

    Grimson Networkin' Nut Member

    Try another Note 3. This could be a hardware problem on the phone, for example the connection from the wlan antenna could not sit tight.
  17. ipse

    ipse LI Guru Member

    But you see the mind-blowing question: when I launch the ping FROM the Note, it's constant and around 20ms (which is also high). Unfortunately I don't have access to another Note 3, will borrow another smartphone to try.

    /EDIT: I tested at work on (obviously) different wifi network and with 3 different phones...I guess we can thank Google for this shitty behavior, as all 3 (mine included) had the same ridiculous ping response time variation (2-350ms).
    Worse even, JB 4.2 is BETTER than KK 4.4 - it seems the googs have lowered the priority of ICMP or something...
    Anyhoo, I posted the conclusion in case someone else runs into the same issue.

    FWIW, my VoIP is NOT affected on the Note 3 - I see sub-50ms packet delay to the server, with 5ms jitter.
    Last edited: Jul 21, 2014
  18. zatoom

    zatoom LI Guru Member

    router r7000 and the 121 version and galaxy S3 with Cyanemod with openvpn version 0.6.17
    A openVPN server problem.
    So far i know are the sertivaten oke on the server and android. It worked on a e2000 router.
    Socked 4 problem !!
    It try to make contact with the router but than ??

    Is this a firewalll problem ?
  19. ipse

    ipse LI Guru Member

    Are you able to use the OpenVPN client with another server (a public service)? I can provide feedback in a few days when I get around setting up my server.
    FWIW I was 100% able to use the same client on my older E4200v1 running 120.
    Last edited: Jul 22, 2014
  20. Malitiacurt

    Malitiacurt Networkin' Nut Member

    R7000 on 121. Openvpn server running, no issues with my phone connecting (Android 4.4.4, OpenVPN Connect 1.1.14)

    Also no issues with Openvpn client on R7000, successfully connecting to an Openvpn server on Tomato Shibby 117.
  21. zatoom

    zatoom LI Guru Member

    thank you, then i know something else is wrong...
  22. jnitis

    jnitis Reformed Router Member

    I seem to be having an issue getting 80MHz channel width to work in 121 on an AC68U.

    I upgrade the firmware (selecting clear NVRAM on reboot), then clear the NVRAM and reboot, then reboot again as in the video and that's the only time it shows up as 80MHz. As soon as I go into the Basic->Network menu and change the SSID or security and click save when I go back to the Status->Overview page the 5GHz radio forever shows 40MHz channel width. I've tried setting it to 80MHz (the option is there) and no joy. Tried setting countries to Singapore for both radios and still no joy. Tried rebooting several times as well.

    Little more info: the same thing happens with TomatoRAF. Also, at some point along the way in configuring the Basic networking options the router will lock up and must be power cycled: this also happens with both shibby and RAF.

    Is this a reported issue? Couldn't find my specific issue here on 121 with the AC68U and after following the proper procedures.

    Last edited: Jul 23, 2014
  23. AKSN74

    AKSN74 Network Newbie Member

    Hello guys, the problem I met just solved...maybe.
    Because shibby uploaded new v121 firmware at July 23. After I flashed it, Now RT-AC56U won't hangs anymore.
    But I still need to observe if it will happen again or not.
  24. MrDoh

    MrDoh Addicted to LI Member

    Interesting...looked at the Changelog and don't see what's new as of July 23, no changes to Changelog *smile*. Guess I should look at the source repository and see what was fixed/added for the new build of v121.
  25. shibby20

    shibby20 Network Guru Member

    i was not uploaded new 121 at July 23. I only moved firmware to manufacture directories (asus and R7000). Thats all ;)
  26. MrDoh

    MrDoh Addicted to LI Member

    Great, thanks for clarifying! Much appreciated.
  27. rs232

    rs232 Network Guru Member

    Potentially related to the ping issue we're experiencing... on my R7000 (Shibby v121) I occasionally get the following warning in the log:

    kern.warn kernel: br1: received packet on wl0.1 with own address as source address
    Is the ping problem perhaps linked to loops?
  28. Daky

    Daky Network Guru Member

    I am getting the same error in dd-wrt, also, i was getting high ping on R7000 (pinging IP of the router, 200-400ms) so, i had to flash back to dd-wrt until this is resolved.
  29. cavemandaveman

    cavemandaveman Reformed Router Member

    can someone go over update procedure for r7000 please? its been a while since i fresh installed 120 and have never done an upgrade yet...
  30. ak907

    ak907 Connected Client Member

    Administration>upgrade ... if you wish to keep old settings don't reset to defaults. If no 5ghz, reboot. Don't save config from a previous version and load into a different version ... could cause a bunch of issues. If u make that mistake do thorough nvram erase. Some people do it every update (good practice) but ur left manually configuring everything again at that point
    cavemandaveman likes this.
  31. ladra

    ladra Networkin' Nut Member

    Hello everyone,

    I've been using several N66u's for over a year now with Shibby's and it has been great, with few hiccups here and there. Just upgraded one of the N66u to AC68u with Shibby's 1.21 and I noticed that the "Bandwidth" log/page only shows in "Real-Time" and nothing for the "Last 24 hours", or "Daily"... Is this a known bug on the AC68u or is my AC68u acting up already?

    Thank you in advance for your input.
  32. ladra

    ladra Networkin' Nut Member

    Okay, did more research. So the Bandwidth logging is a known issue, along with QOS, and few others. I guess I should've done the research beforehand, darn. I might have to go back to my N66u...

    In any case, thank you Shibby for your hard work on these routers. I love my N66u's and I hope the AC68u will be just as great when it's ready!
  33. LanceMoreland

    LanceMoreland Network Guru Member

    I am a long time Tomato user but several months back I upgraded my routers to Asus AC68U’s and had been running Merlin’s firmware on them with the idea that I would eventually load Tomato on them. The most recent Asus builds (which are the basis for Merlin’s builds) have been seriously locked down. Channels are reduced to the lowest common denominator for many counties and the ability to increase signal strength has been locked.

    Long story short, I loaded Shibby’s ver. 121 on my units this weekend and I can say that I am very happy with the results. I was able to unlock all channels and increase signal strength using nvram commands that previously worked on the Asus builds and I am back to the old familiar interface of Tomato. Thank you for your efforts Shibby.

    A quick observation. One of my units is set up as an access point only and hardwired into the main router. I have most all network devices set up on static ip addresses. In the past I had setup the static ip addresses on the access point also because the device name and ip address would show up on the device page of the access point. This is no longer possible. It appears that if DHCP is not running and you try to insert static ip addresses in the Static DHCP/ARP/IPT section the access point will crash. No big deal but if anyone knows of a work around, I would appreciate it.

    Edit: I have several D-Link Cameras in the house, each one is accessed via port forwarding. I can not reach them from outside of my network via my ddns with CTF enabled.
    Last edited: Aug 3, 2014
  34. Mercjoe

    Mercjoe Network Guru Member

    I am currently using my R7000 as an access point as well in a similar configuration as yours.

    I currently have copied the NVRAM (inputted not restored) from my main router (WNR3500lv1 running Toastman's latest) to the R7000 and all my static addresses are in it currently. It is duplicated in all respects with the exceptions of the additional items in Shibby's firmware.

    I have DHCP off on the AP and it works fine. I have it set up this way so that with a simple turning on of the DCHP and flipping the WEB interface from <disabled> to PPPOE I can switch it out to the main router.

    It has been pretty darn stable with only an infrequent reboot due to the dang high ping bug.

    Something's strange here.


    I did put this all together on the initial 118 AIO version and just flashed over as updates came out.

    Let see what happens now;

    Nope. I just removed and added Static IP's to the AP and no crash.

    You may want to erase NVRAM and start over. Something might have gotten corrupt.
    LanceMoreland likes this.
  35. LanceMoreland

    LanceMoreland Network Guru Member

    Thanks Mercjoe... You are correct. Hand imputing the entries worked. I was trying to write them in bulk via command line. Thanks again.
  36. greenythebeast

    greenythebeast LI Guru Member

    Is it possible to flash Shibby's AC68R firmware directly from ASUS Merlin firmware? Or do I have to use the firmware recovery tool?
  37. Infinity

    Infinity Reformed Router Member

    Hi, may I ask you which nvram command did you use? Cause my best result on 5ghz is to obtain up to channel 153, while the same command on Merlin's build, gave me the full channel list.

  38. LanceMoreland

    LanceMoreland Network Guru Member

    These are the commands that I used on both of my AC68U's. It will unlock all channels and signal power levels. I am not sure if it will work on other Asus models. It used to work with Merlin's firmware but recent changes by Asus on the base firmware now prevent it from working. I tried it on Shibby's 121 and it works fine.

    nvram set pci/1/1/ccode=#a
    nvram set pci/2/1/ccode=#a
    nvram set pci/1/1/regrev=0
    nvram set pci/2/1/regrev=0
    nvram set wl0_country_code=#a
    nvram set wl0_country_rev=0
    nvram set wl0_reg_mode=off
    nvram set wl1_country_code=#a
    nvram set regulation_domain=#a
    nvram set regulation_domain_5G=#a
    nvram set wl1_country_rev=0
    nvram set wl1_reg_mode=off
    nvram commit
  39. Infinity

    Infinity Reformed Router Member

    Correct, the very latest firmware from Asus/Merlin is what led me to move back to Tomato.
    I'm using exactly the same code as above, excluded the first 4 lines, which should work only on AC66U and no on AC68U, but maybe I'm wrong. Also I use those to unlock the power:

    nvram set wl0_TxPower=1000
    nvram set wl_TxPower=1000
    nvram set wl1_TxPower=1000

    on Merlin 374.43 works fine and I can see the channel up to 161 (not 165 anyway) but on latest Tomato my list end up to 153.
    Odd I'll try once again
  40. LanceMoreland

    LanceMoreland Network Guru Member

    If you set the channel width to 20 MHz you should see all of them. At 40 MHz you can toggle back and forth between Lower and Upper control sideband to see them all.
  41. Infinity

    Infinity Reformed Router Member

    That's a good point, I didn't try that! I've set the channel width straight to 80Mhz cause was my test purpose :)
  42. Jack Freeman

    Jack Freeman Connected Client Member

    I have a Netgear R6300v2 router running tomato shibby firmware for R7000 AIO 121, since I flashing succeed, everything works fine, so stable, better then all dd-wrt version. So thank you shibby and all of you guys in tomato project, nice works.

    I saw the ipkg repo of TOMATO ARM is without updated, I think maybe I can build some by my self and share to everyone. So I try to use the toolchain hndtools-arm-linux-2.6.36-uclibc-4.5.3 building aria2, but it throw "segmentation fault" when running on device.

    Is it my toolchain version wrong? Or my configure parameters wrong?

    Here is my command line for configure:

    ./configure CC=arm-uclibc-linux-2.6.36-gcc CXX=arm-uclibc-linux-2.6.36-g++ AR=arm-uclibc-linux-2.6.36-ar RANLIB=arm-uclibc-linux-2.6.36-ranlib LD=arm-uclibc-linux-2.6.36-ld --prefix=/opt/bin/aria2c --host=arm-linux --build=arm && make
    and my config.log
    Last edited: Aug 7, 2014
    AlpineMan likes this.
  43. Alex Gao

    Alex Gao Network Newbie Member

    I have runing shibby tomato121 on my R6300 V2 too,but the router could not get the correct system time as i have set the time region and ntp server.the time shows"not avalaible".Have you meet the same problem?I do not know how to solve it.
  44. Jack Freeman

    Jack Freeman Connected Client Member

    Yes, I had the same problem, but seems correct now. I think router can't synchronize the new time to hardware clock, if you set a ntp server / timezone, and you got the wan port online, it should be work correctly, at least works for me.

    Maybe you can try to ping the ntp server on console something.
  45. mcouture

    mcouture Network Guru Member

    I am running 121 on my AC68u and it is stable. However, the WIFI range is horrible. I had to up the TX power to ~300 to get any range at all. I'm estimating the range has been reduced 50% compared to the Merlin build I was using before.

    Any options on gaining the range back or is it a driver thing in shibby121 ?
  46. LanceMoreland

    LanceMoreland Network Guru Member

    Your answer is 8 posts above yours. Post number: 738
  47. mcouture

    mcouture Network Guru Member

    After I set these parameters in post #738, what do I use in the GUI for TX power? I have box 2.4 and 5...
  48. LanceMoreland

    LanceMoreland Network Guru Member

    I set mine to the max at 400 before I ran the parameters and did not touch it afterward and my signal strength was as good as it ever has been. I think you may overwrite some of the entries from the command line if you change that parameter and potentially lower your signal strength.
  49. Jaap-Jan van der Veen

    Jaap-Jan van der Veen Network Newbie Member

    I too am bitten by the ping problem bug Netgear R7000 with the latest Tomato firmware (1.28.0000 -121 K26ARM USB AIO-64K).

    It seems to occur only on the wired (WAN and LAN ports). The wireless network is unaffected. Very strange to see latencies of 30ms - 300 ms on LAN and 1ms or less on WLAN. :)

    My IPv6 tunnel broker (SIXXS) also notices:
    Yesterday I tried out DD-WRT, found out I didn't like it and went back to Tomato. Thankfully I now have a low latency connection, probably only until the router needs a reboot. I had a high ping after I was done configuring the router, but disabling CTF (or possibly the reboot which is necessary to apply the changes) brought me low ping times.
  50. lancethepants

    lancethepants Network Guru Member

    Aria has a few dependencies that first need to be compiled.

    This is how I compile aria for arm (with a different toolchain).

    And the binary it creates.
  51. Jack Freeman

    Jack Freeman Connected Client Member

    I tried your binary in my device, it's running perfect! Thank you @lancethepants.

    So, the toolchain's version is not really important or must be arm-linux-musleabi? How about compiling with shared library.
  52. lancethepants

    lancethepants Network Guru Member

    I guess so long as the firmware you're running has all the shared libraries you need, you can do it that way. Toolchain doesn't matter so long as it's made for the right architecture.
    I've been using this particular toolchain cause it was easier to get going than the one in asuswrt (which is kind of older and wouldn't compile some stuff) I like to make them static so it's an all-in-one portable package.
    Last edited: Aug 8, 2014
  53. Jack Freeman

    Jack Freeman Connected Client Member

    Thanks for your quick response, that make me clear on cross compilation toolchain. I'll try.
  54. Infinity

    Infinity Reformed Router Member

    Sorry to insist on this point, but definitely it seems not working in AC mode/80Mhz

    Selecting 40Mhz I get a full channels list, but in 80Mhz only up to 153. I'm the only with this "bug" or is it intended like the lock-down on the latest Merlins's release?
  55. jsmiddleton4

    jsmiddleton4 Network Guru Member

    There's been some chatter about Broadcom releasing a patched wireless driver, the one that Tomato can use and RMerlin can use, being used in these newer Tomato variant.

    What you could be seeing in terms of the channel selection and 80mhz is about that newly released Broadcom driver. If so there's nothing RMerlin nor Shibby can do about it. They are dependent on the Broadcom driver as it is, they can't mess with it.
  56. kamaaina

    kamaaina Serious Server Member

    I have it setup as an AP as well, wired from WAN (AP) to LAN (main router). Traditionally I used a LAN port for this and then realized Merlin/Asus has a great AP mode that with one click turns off firewall, NAT, DHCP, maps WAN to LAN etc. Tomato does not not have that, but after some poking around I realized you can use the WAN port as a 5th LAN as well. My main router has, the AP has a static, and the DHCP comes from the main router giving out addresses from .10-.50. I set the gateway and DNS in the AP to the main router and I can see all "static DHCP" working (from main router) on the AP as well. I don't use static addresses on the devices themselves, but rather static DHCP based on MAC address. If you want to set further static dhcp you need to do it in the main router, as the AP will just provide access to the network and uses the config from the main router. Make sure NAT, firewall, and DHCP are turned off on the AP router. Below WAN config on the AP.
    shot 2014-08-08 at 12.42.26.png
  57. RMerlin

    RMerlin Network Guru Member

    That's news to me.
  58. LanceMoreland

    LanceMoreland Network Guru Member

    The purpose of entering the static IP addresses into access point is so that you can see the device names and their respective IP addresses listed in the devices listing of the AP.
  59. TyShawn

    TyShawn Reformed Router Member

    You heard it here first ;)
  60. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "news to me"

    Didn't say it was true. Chatter about it on DD-WRT forum. In the discussions about for some folks they have random reboots which is supposed to have been addressed with some hotfix by Broadcom to the wireless driver.
  61. LanceMoreland

    LanceMoreland Network Guru Member

    Has anyone been successful setting up a virtual wireless (Guest) SSID? My first attempt blew everything up and I had to wipe and start over. Is this not yet compatible on Tomato ARM? I am running Shibby 121 on an Asus AC68U.
  62. tbjerret

    tbjerret Network Guru Member

    yes, I did that. No problems, sorry.
  63. LanceMoreland

    LanceMoreland Network Guru Member

    Which version of Tomato ARM? Shibby or Victek's? Which router?
  64. José Fernández

    José Fernández Networkin' Nut Member

    I was able to do it too. ASUS RT-AC56, Victek 1.3g firmware.
  65. ladra

    ladra Networkin' Nut Member

    My AC68U is setup with br1, vlan3, and virtual wireless on both 2.4 and 5 from day one without any issues so far. I'm on Shibby 1.21
  66. tbjerret

    tbjerret Network Guru Member

    Same as yours two.
  67. ladra

    ladra Networkin' Nut Member


    I would like to ask the community if someone can confirm that their AC68U with Shibby 1.21(or lower) allows external connections to the built-in FTP Server on ports other than 21. My tomato FTP server is working just fine with port 21 but when I change it, to say 2121, it does not allow any connections from the WAN side. It seems like the firewall is blocking it... Maybe it's a bug?

    I never tried the FTP server on my N66u so I don't know if this is specific to the AC68u or not... Thanks.
  68. Jack Freeman

    Jack Freeman Connected Client Member

    Hi @lancethepants, I try to build aria2 by myself use your aria2-arm-musl-static script and I got a really huge binary file:

    root@ubuntu:/home/router/packages/aria2# echo $PATH
    Here is my config.log:

    root@ubuntu:/home/router/packages/aria2# ls -lah aria2/opt/bin/aria2c
    -rwxr-xr-x 1 root root 72M Aug 12 01:45 aria2/opt/bin/aria2c
    I don't know why, if I build it as shared library I will get a small one, but throw an error when I running it on device.

    root@Router:/jffs/tools# ls -lah /jffs/tools/aria2c
    -rwxr-xr-x    1 root     root      190.1K Aug 12 16:17 /jffs/tools/aria2c
    root@Router:/jffs/tools# /jffs/tools/aria2c
    -sh: /jffs/tools/aria2c: not found
    root@Router:/jffs/tools# ldd /jffs/tools/aria2c
    -sh: /jffs/tools/aria2c: not found
    And I tried arm-linux-musleabi and hndtools-arm-linux-2.6.36-uclibc-4.5.3 toolchain on ubuntu 12 32bit and debain 7 64bit, got same result. Sorry, I'm a newbie of cross compile works, thanks for you patients.
  69. lancethepants

    lancethepants Network Guru Member

    The last thing I do when making a static binary file is to strip it
    arm-linux-musleabi-strip ./aria2c
    This should cut it down more to size of the one I've uploaded. Typically I also like to compress the binaries using upx, but binaries built with this toolchain (never had issues with others) sometimes don't work when compressed, so I don't compress these ones. Stripping should significantly help on size though.
  70. Jack Freeman

    Jack Freeman Connected Client Member

    I see, thank you! I have try it just now, after stripped I got 6MB binary file and works perfect on device. I'm trying to build MySQL server use your way. Thanks a lot.
  71. Kev18

    Kev18 Network Newbie Member

    Hi, how many 5GHz channels did you get? are we supposed to have those DFS channels.....I got a total of 9channels when set to 20MHz
  72. Johnathon

    Johnathon Connected Client Member


    I am running an AC68U and have flashed both Shibby and Vickteks build on my router. Both routers indicate they are operating at 1600 MHz. Within a few minutes everything locks up, I have to reboot and clear the nvram using the wps button. Is there anything I can do to help capture or trouble shoot this with you guys?

    Thanks in advance
  73. ladra

    ladra Networkin' Nut Member


    I understand that the ARM build of tomato currently does not have the "setfile2nvram" feature installed. How can I go about saving "/etc/minidlna.alt" to nvram for it to survive a reboot?

    Or, is there a away to save the minidlna.alt file on my usb drive and have it copied over to /etc/ directoy on boot before minidlna service starts?

    Thanks in advance for any input.
    Last edited: Aug 14, 2014
  74. koitsu

    koitsu Network Guru Member

    That is usually what the Administration / Scripts section is for.

    However, be aware that the Scripts area does not have a UI element (tab) for "do this when the USB drive is attached/filesystem mounted" -- so people using Scripts / Init will often find that their stuff doesn't work because the USB drive filesystem isn't mounted yet (and do stupid things like use "sleep" to delay it -- bad, bad solution).

    Instead, you can use the Run after mounting section of the USB and NAS / USB Support section to run commands/copy files/do whatever. Or if you need something more extravagant, you can place a file on your USB flash drive (hopefully formatted ext2 or ext3; the permissions on the file need to be 755) called mount.autorun which is a shell script that will be automatically run when the drive is mounted. You can also make one called unmount.autostop which will be automatically run when the drive is cleanly unmounted (through the GUI, umount command, etc. -- but NOT if you just physically pull the drive (there's no way to handle that situation, obviously)).

    And remember: after putting the config file in place, you will need to stop, then start, the relevant daemon/service that uses it (minidlna). Don't ask me how to do that -- I don't use it myself so I don't know.


    * Search Google for "linksysinfo koitsu mount.autorun"
    pzlmg, ladra and Mercjoe like this.
  75. Mercjoe

    Mercjoe Network Guru Member

    Thank you for that insight on scripts.

    I had not realized the after USB mounting could be used for like that.
  76. ladra

    ladra Networkin' Nut Member

    Koitsu, thank you for the idea. Not sure if you remember but you solved another problem I had few months back. Really appreciate your help once again. I'll do my homework on mount.autorun and report back.
  77. MrDoh

    MrDoh Addicted to LI Member

    I get a choice of two 5GHz wireless channels, one upper and one lower. This is with 80MHz channel bandwidth.

    Update: let me make it perfectly clear *smile*, I'm not complaining about having only two 5GHz. 80MHz. channel width channels available, that's fine. That's one more than I need, and yes, I know that these are Beta releases. I'm enjoying using them, thanks much for making them available to Shibby and Victek!
    Last edited: Aug 17, 2014
  78. Infinity

    Infinity Reformed Router Member

    Correct, I can get a full channel list, only set the bandwidth to 40Mhz
    My feeling is that's a gui limitation, maybe can be override setting the channel manually, if exists this option on tomato
  79. rs232

    rs232 Network Guru Member

    I think we should specify very clearly that ARM build are still in beta.
    I see more and more people buying ARM devices and find them self surprised that a dozen of services (ping issue, long booting time, bandwidth monitoring, jumbo frames and QoS just to mentioned few) are still not operational. No pressure on the mod developers at all! I just want to make a point that until fully working, no matter what we are talking about, we must inform the users.
    Then you get people like me that like to test the betas and help if possible, where other that can save money for the time being.

    my 2 cents
    Last edited: Aug 31, 2014
    Bruce Kelley likes this.
  80. motoolfan

    motoolfan Networkin' Nut Member

    Is the Netgear AC1450-100NAR supported? If not, will it be?
  81. MrDoh

    MrDoh Addicted to LI Member

    Looks like Shibby v122 has been posted as of yesterday. Going to try it today or tomorrow, as soon as I get a chance *smile*.

    Thanks so much Shibby!

    [RELEASE] 122
    All version:
    - openssl update to 1.0.1i
    - libsodium update to 0.7.0
    - grow-up „Remote Host /IP” field on admin-log.asp page
    - allow to change directory with GUI`s files (only for devs and advanced users)
    - tinc: integration and gui. Thx @lancethepants
    - nginx: add new option „Run As” (root or nobody)
    - add a lot of PHP modules required by ownCloud
    - add libpng 1.2.51
    - add libxml2 2.9.1
    - SQLite update 3.8.6
    - libiconv update 1.14
    - allow run spawn-fcgi as root
    - nginx: fix php support for ownCloud
    - fix display CPU Freq on status page. Detect core numbers.
    - disable TOR from ARM builds for now. Got Segmentation fault
    - fixed CPU support for RT-N18U
    - use different wl, ctf, paragon drivers for RT-N18U (dedicated)
    - optware: add Shibby`s packages repository to install script for ARM
    Last edited: Aug 31, 2014
    kamaaina likes this.
  82. kamaaina

    kamaaina Serious Server Member

    Up and running on my two R7000 now for 5 min, all good so far.
  83. MrDoh

    MrDoh Addicted to LI Member

    Got it up here, too. Took some rebooting to get the ping down again (darn it, at least no CTS required this time), but doing well now. Nice to see the correct CPU information.

    Again, thanks to Shibby!
  84. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Might look at it. Something about that ping thing though is unsettling. Not a big deal and not trying to make it a big deal. But it is a tad troubling. I know kong had mentioned a new Broadcom driver that fixed the reboot issue but have not seen any more about it.
  85. MrDoh

    MrDoh Addicted to LI Member

    Yes, the stock Netgear firmware was up for me for the last two weeks, only took it down to try out this new version of tomato. I was pretty disappointed with dd-wrt when IPv6 was added, and it didn't work right for me, so that's my criteria for going back to dd-wrt, that IPv6 is fixed. IPv6 works right on both stock firmware and tomato...haven't had any problems in the last months with the wireless driver on any firmware I've tried, so that's not an issue for me. Didn't have reboots on either dd-wrt (recently up for a month) or stock firmware.

    Really do like tomato, if this version is stable I'll stay with it.
  86. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Will watch your real world results. I don't do IPV6. I'm on stock Netgear at the moment. For all the versions Shibby-Tomato is the easiest to reconfigure. So if you have good results I might try it. Netgear's is solid for me so I'm not too motivated to swap at this time. Might just to play IF 122 is stable.
  87. boghea

    boghea Reformed Router Member

    Hi all,

    I have installed OwnCloud 7 on shibby's TomatoUSB v122 and I am wondering if there is a way to enable nginx (web server) to use https instead of http. I don't want to use OwnCloud without https.

  88. sandspike

    sandspike LI Guru Member

    Thanks Shibby and all contributors. Are we able to save config files yet?
  89. Image This

    Image This Reformed Router Member

    Can any AC56U user tell me how stable the current ARM build is for it? Any drawbacks? Like having the High Ping Difficulties as well and most importantly - is QoS working properly as of now? Are the 2.4GHZ Bugfixes implemented that fixes the unusable 2.4GHZ Frequency?

    I'm thinking about using one as my Main-Router (that 's mostly getting only a single 5.8GHZ connection from a Repeater which will take-over some of it 's work) however I want to use Tomato on it due to it 's lovely QoS and of course it 's DHCP-Server that is.
  90. tbjerret

    tbjerret Network Guru Member

    You can save it, but must use telnet to restore.
  91. MrDoh

    MrDoh Addicted to LI Member

    Are you referring to extracting variable values using telnet, and making a script out of that? Or is there some way to import a .cfg file made by tomato's "Backup Configuration" functionality using telnet?

  92. tbjerret

    tbjerret Network Guru Member

    You save a cfg file on a mounted usb stick and use something like this:

    cd /tmp/mnt/sda1
    nvram restore bkp.cfg
    nvram commit
    MrDoh likes this.
  93. MrDoh

    MrDoh Addicted to LI Member

    Ah, didn't know that you could do that, interesting. You could also use scp or WINSCP to move the .cfg file to /tmp on your router, of course.

    Thanks very much.
  94. Toastman

    Toastman Super Moderator Staff Member Member

    Dr Strangelove, kthaddock and MrDoh like this.
  95. MrDoh

    MrDoh Addicted to LI Member

    Agreed, especially since a potential workaround was posted in the other thread, and not seen by those that are only reading this thread. Now I guess I'm reading both so that I don't miss anything *smile*.
  96. Image This

    Image This Reformed Router Member

    Asus AC56U with "tomato-RT-AC56U-ARM--122-AIO-64K.trx" hasn't any LED working beside the Ethernet-Ports at the Back and the Power-LED (sorry if that 's already known). :)
  97. Dean Peak

    Dean Peak Network Newbie Member

    I have been researching Tomato. I have the R7000. I was wanting to confirm if the network monitoring is working in V122? I have several people streaming in the home and keep going over my monthly cap and the monitoring would be a big help. Also can I go straight from NetGear stock firmware to tomato? It is the latest upgraded netgear firmware if that matters?

    A couple of places leads me to believe I should update to a certain netgear version before move to Tomato?
  98. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Sorry but the ping issues are on our ARM routers. How is that not an ARM issue then?

    But it does look like I'll not be trying 122.
  99. LanceMoreland

    LanceMoreland Network Guru Member

    I pinged my AC68U running 122 from both a wireless and a wired connection and all return times were reported as <1ms. Then again I haven't noticed this issue in the past either.
  100. Image This

    Image This Reformed Router Member

    Build 122 pinged my repeater (N66U currently) over my (which is used as an Wireless Ethernet Bridge and connected via Ethernet to my PC) - Distance about ~4-5m with 1 thin wall inbetween.

    > 500 times pinged with ping -t -l 100

    Min: <1ms Max: 4ms Avg: 2ms Lost: 0 (0%)

    Can't reproduce that issue with my device (AC56U, Build 122) as well.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice