Tomato freeze, CPU overload, unresponsive (even to reboot, etc)

Discussion in 'Tomato Firmware' started by ImGeo, Aug 2, 2010.

  1. ImGeo

    ImGeo Addicted to LI Member

    I tried to access a file via Samba (windows file share), and the router would no longer allow samba file access. It was a 600k text file.

    Next, I went to the router's admin interface, and every router page worked except "USB and NAS"-- that one would just not work. I checked the status page, and watched the CPU load go up gradually (over the course of a minute or so) to about 4.0 and stay there. Determined not to just pull the plug, I tried a reboot from the admin interface, to no avail. The reboot page showed up, but the router was not actually rebooting. Same with shutdown.

    I pulled the USB drive from the router, but nothing changed.

    Next, I connected via SSH, and did "ps" to show the active processes. With so many things on the list, I did not know what to kill to release system resources. However, I did see that there was a shutdown command and a shutdown-linked script (that I made) pending. They obviously were not being run. A "reboot" command from putty didnt do anything either.

    I've used the USB before, reliably. I think this time something went out of control though. In the future, what can I do to solve this (assuming I did not have physical access to unplug the router). Many people use the router besides me, and I use remote access to administer it.
  2. teetee1

    teetee1 Networkin' Nut Member

    What's the software and hardware info on the router? Where is the 600K text file located? What's the client system/version? If the problematic file is located on a usb drive plugged into the router, what's the model/size of the drive?

    Have your tried using "top", "htop"(available through optware installation), free, lsusb -v, or open the 600k text file under the command line console through ssh to see where the problem might be? I assume the figure "4" you saw on the router status page is the system load of the router, which does not tell where the bottleneck is(cpu, I/O, memory, or kernel module got stuck and jobs keep piling up,etc) It would help to know the situation better with the test results.

    You mentioned lots of people use the router. Do they have the admin access to the router, or do they simply use the network (and access the file by samba) through/on the router?
  3. ImGeo

    ImGeo Addicted to LI Member

    wl-520gU running Tomato ND (teddy_bear) 1.25 (1.25 is not the latest version).

    Windows 7 64-bit trying to access a file saved on a USB flash drive (plugged into wl-520gU USB port. The USB is a no-brand chinese freebie, but has been tested and works just fine. I've even put large files (enough to fill the drive) over FTP and checked them for consistency, no errors.

    Have not tried those commands, or installed any optware yet. However, it seems like no commands would have run anyways. Based on what I can tell (and I'm kinda a newb) its either the CPU overloaded and unable to process jobs including things like reboot (since I waited for at least a minute before I pulled the plug) (however, i tried a killall and I think that did run properly, but still did not fix the CPU overload).

    Maybe I'll try to simulate this again and do some more diagnostics. I'll look into what you suggested, but any tips for what to do?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice