Tomato install on Tenda W1800R

Discussion in 'Tomato Firmware' started by heyitsYMAA, Mar 15, 2014.

  1. heyitsYMAA

    heyitsYMAA Reformed Router Member

    I picked up a W1800R recently on the cheap with a Shell Shocker sale on Newegg. I didn't see a guide on how to install the Tomato firmware on this router, so I assumed one would simply flash it through the firmware upgrade page on the router's web configuration. I did this and apparently bricked the router because while it did respond to ping it never loaded the configuration page even after several reboots and hard resets.

    Please forgive my stupidity when it comes to Tomato (only used DD-WRT in the past) but what is the proper or preferred method of installing Tomato on the W1800R?

    Thanks in advance.
  2. shibby20

    shibby20 Network Guru Member

    if i good remember i installed first time tomato via webgui.
  3. szpunk

    szpunk LI Guru Member

    Last edited: Mar 15, 2014
  4. heyitsYMAA

    heyitsYMAA Reformed Router Member

    Alright, tried it this time and it worked fine. Made sure to wait ~10 minutes before trying to access the web GUI after flashing. Not sure what happened with the flash before, but it appears to be running great now. Thanks everybody!
  5. xdrag

    xdrag LI Guru Member

    Hi Everyone,

    I recently got the w1800R and wanted to write a good tutorial on the flashing procedure. I unfortunately bricked my router before finally figuring out how to put tomato on it.

    Advanced Tomato has complied a good guide that I will be borrowing from here. Assuming you are currently on STOCK firmware:

    Step 1: Preparation
    i) Download Tomato 120 image. tomato-W1800R_RT-AC6x--120-AIO-64K.trx

    (please note: as of January 7th, 2015, the newer releases 123 and 124 have flash image larger than the 16mb flash on the w1800r. They cannot be used. This may be fixed in the future - check image size. 121 also has a AC channel bug.)

    Also a good idea to do a M5SUM to make sure your image is the correct size.

    Step 2: Flashing the firmware
    i) Navigate to
    ii) enter admin/admin as username and password (default settings)
    iii) Click on "Advanced" on the right hand corner
    iv) Go to "TOOLS"
    v) Select "Upgrade" and browse to the 120 image that was downloaded earlier
    vi) click "Upgrade"

    vii) WAIT


    The flash will take approximately 20 minutes. During this time, the Tenda status bar will reach 100%. It may direct you to a blank page or become unresponsive. This is NORMAL but.....

    DO NOT REBOOT manually or you will brick your router.

    viii) After the router reboots automatically (you can monitor this by pinging, you should be able to navigate to tomato @

    Step 3: Housekeeping
    At this point, I would erase the NVRAM (thorough) under the administration tab before setting up the router or upgrading to a newer version if available.

    Hope this helps and saves a few bricked routers.
    Last edited: Jan 9, 2015
    AndreDVJ likes this.
  6. GaChris

    GaChris Network Newbie Member

    Anyone know if Shibby will trim the fat on the latest FW? I would try it myself but I do not know squat about compiling FW.
  7. ierwin

    ierwin Networkin' Nut Member

    For most Tenda routers running Shibby's tomato, they boot up very slowly, don't know why.
    I have a Tenda N6 and a Tenda N60 both running Shibby's mod, both need more than 1min for boot up.
  8. eviltone

    eviltone Network Guru Member

    FWIW... i jsut upgraded the firmware on my w1800r -- took 7 minutes for the flash from an older version of Tomato with an NVRAM wipe. then another 1.5 minutes or so for the reboot process. So in total.. somewhere around 10 minutes or more for this thing to flash.
  9. rkopunk

    rkopunk Network Newbie Member

    Hi to all.
    I`ve tried to flash the latest tomato firmware for W1800R and bricked my router. This forum and the warnings i found them too late. Is it possible to unbrick the W1800R? Are there any tutorials or something? I`ve searched the web, but i found nothing so far. Please ANY help will be greatly appreciated. Thanks,
  10. ierwin

    ierwin Networkin' Nut Member

    return to the store where you buy this router, and get a new one
  11. xdrag

    xdrag LI Guru Member

    TTL (as shown above) if you know what you're doing

    Or you have to warranty the router

    Unlike the ASUS routers, these cannot be recovered using TFTP.
  12. leo5111

    leo5111 New Member Member

    i bricked mine and its too old to return to store that site is in chinese i cant tell what to press can someone link me that file? and instructions im willing to try sucker is dead if i cant so nothing to lose
  13. leo5111

    leo5111 New Member Member

    whats with releasing a firmware for the tenda 1800r and not paying attention to the fact the flash size is to big for the router? and before anyone comes in and trys to mention crap about flash at your own risk, a experienced dev releasing a firmware without checking the flash size is the DEV making a mistake, a miscelanious flash error is 1 thing but this is something else i found another thread somewhere talking about the wrong flash size for this model
  14. Katjubu

    Katjubu Network Newbie Member

    Not sure what you mean. Shibby is the only one I know of that supports the W1800(1)R and the flash size is ~10mb. The Tenda has a 16mb flash capacity.

  15. leo5111

    leo5111 New Member Member

    hmm i saw a thread, saying something about wrong image size i flashed latest 1 left it alone for at least 30 minutes to flash it never came back, also the thread mention tomato firmware for tenda w1800r, so i dont know
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice