Tomato limits download speed

Discussion in 'Tomato Firmware' started by daveteee, Sep 27, 2007.

  1. daveteee

    daveteee LI Guru Member

    Hi, I'm using a WRT54GSv4 with the latest version of tomato and when I use QoS and Azureus my download speeds are around 2kb/s total. I was using DD-WRT on my router before and the speeds were normally around 200kb/s.

    I've tried it without QoS turned on and the speeds are normal but I'd like to be able to use it so I web sites don't take ages to load. Another thing I've noticed is that when I was downloading using DCC on IRC the speeds were low while Azureus was open but went back to normal as soon as I closed it.

    I'm using the default QoS settings and haven't changed anything to do with connections either, all I've done is forwarded the port and adjusted outbound bandwidth rate. Does anyone know what's wrong?
  2. Mastec

    Mastec Network Guru Member

    I used to use Azureus. Disable QoS and set your upload speed limit within Azureus to 15kb while downloading and 40kb while seeding. You will see web sites load normally. This worked for me which doesn't mean it will work for you, its just a suggestion.
  3. Odin-60

    Odin-60 LI Guru Member

    Turn QoS on,
    enable "Prioritize ACK",
    and enter the correct upstream bandwidth.
    Save these settings and reboot the rooter.
  4. daveteee

    daveteee LI Guru Member

    The default settings for QoS already had Prioritize ACK enabled. I'll guess I'll just leave it off. Thanks
  5. Mastec

    Mastec Network Guru Member

    What I suggested does work. I can even play first person shooters such as Call of Duty online while Azureus is running in the background without experiencing lag. It worked when I used DD-WRT and now with Tomato. But like I said above, it's just a suggestion.
  6. mstombs

    mstombs Network Guru Member


    I wonder if you have the windows XP SP2 tcpip.sys issue which I used to get with Azureus and Fasterfox, solved a similar problem here:-

    Could Azureus be reacting to being QOS's by trying to open more connections which causes the OS to slow all internet apps on the PC?
  7. daveteee

    daveteee LI Guru Member

    Sorry I forgot to mention I'm actually using Azureus on a Mac, but I tried increasing the maximum simultaneous outbound connection attempts in the Azureus options from 10 to 50 but that didn't work either.

    I've noticed now that enabling QoS also seems to cut my upload speed too, I usually have it limited in Azureus at 18kb/s and with QoS off it's maxed constantly but with QoS on it keeps jumping around, this is with nothing else running that's using bandwidth so I'm not sure why the speed would be jumping up and down.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice