Tomato MultiWAN

Discussion in 'Tomato Firmware' started by shibby20, Dec 8, 2015.

  1. nmalinoski

    nmalinoski Networkin' Nut Member

    My limited understanding of the Multi-WAN functionality is that connections are round-robin or fail-over, not ganged/aggregated.
  2. Malakai

    Malakai Networkin' Nut Member

    Try using a p2p service (as torrent) on a file with a lot of seeds and see if you get more than 15mb of download speed. When using 2 wans but only 1 connection (let's say http download) you won't get past the maximum of 1 line. So you have to use a protocol that gets more than 1 connection active, so the connections would be distributed over the 2 wans.
  3. Herb Radford

    Herb Radford Serious Server Member

    Shibby, I've been using your firmware for a number of years and I like it. Thanks.
    I have an RT-AC66U and a R7000 and have been having a problem with port forwarding for my VOIP service on the R7000 (all recent releases) and the RT-AC66u on build 136 whereas build 132 works just fine. The settings from the port forward page do not show up when I enter iptables -L from an ssh session. Do I have to use a DMZ for my voip service??

    .ezhik likes this.
  4. remlei

    remlei Networkin' Nut Member

    my objective is to make wan1 as default route while wan2 for policy based routing, so for trial run, I put a policy rule that all unlisted connections goes to wan1, and then I created a 2nd rule for steam games based on UDP protocol and to port 27000-27030 and that goes to WAN2, third is a file server for linux that goes only in wan2 as a test, I did re-arrange the rules based on FIFO, so I make sure that all traffic to WAN2 is on top while the default route is at bottom for WAN1.

    My ISP is based on DHCP IP leasing. btw

    the problems are:

    - setting a policy based routing with ICMP protocol will make the CPU go 100% on process /sbin/init noinitrd
    - policy based routing will not work at all, guaranteed.
    - if you reset either one of the wan interfaces,l ike release one of the wan interfaces and then renew it, loadbalancing breaks. all traffic will just go to last interface that works, eg, if you release/renew wan1, only wan2 works until reboot.
    - if you disconnect any of the wan interfaces (without releasing/disconnecting the wan interface), the internet wont work at all, I didnt have this issue in OpenWRT's mwan3, it only just makes the browsing experience slow but not totally disconnected to internet.
    - steam games session that I done so far make me disconnect to the game session probably due to loadbalancing feature of the router making my connection changes IP everytime, thus I get disconnect, because the policy routing I set didnt work at all.

    I have the same setup with OpenWRT's mwan3 and it all work just fine without breaking a sweat.

    using the version tomato-K26USB-1.28.RT-N5x-MIPSR2-136-VPN and AIO one
    present in all routers that I tested. WAN connection are based on DHCP.

    my concern is make WAN1 for all default traffic and WAN2 for policy based routing, like I only specify what goes to WAN2, all traffic just go to WAN1 if not specified.
    Last edited: Apr 25, 2016
    Darkbing likes this.
  5. Mazhor

    Mazhor Network Newbie Member

    Hello Shibby.
    I apologize for my English, used a translator.

    Router RT-N66U.
    Use two Lan ports from different providers.
    C firmware tomato-RT-N66U_RT-AC6x--136-AIO-64K all very bad.
    Every time something doesn't work. In this firmware the router Internet is, but
    when you connect via wifi there is no Internet access.

    Have installed firmware tomato-K26USB-1.28.RT-N5x-MIPSR2-136-AIO-64K.
    On this firmware everything works, except that when setting the Load Balance Weight in both the WAN with a value of 0, you still get Internet on both WAN. That is, the presence of the Internet in the first WAN second WAN is not disabled.
  6. lefting

    lefting New Member Member

    Tomato Firmware 1.28.0000 MIPSR2-136 K26 Max
    After restarting the router does not set a time.
    I have to do manually
    root@unknown:/tmp/home/root# date -s '2016-05-04 11:16:30'
  7. koitsu

    koitsu Network Guru Member

    1. Administration -> Logging -> Events Logged -> Make sure "NTP" is checked
    2. Reboot the router
    3. Once the GUI page comes up, wait approximately 60 seconds
    4. If the GUI page still says the time is not available/not set: Status -> Logs -> View All -- provide this output somewhere. Please do not edit it if at all possible -- (it will contain IP addresses and MAC addresses). Otherwise you can try to diagnose it yourself: there should be lines that say something like this:

    Apr 28 23:30:02 gw ntpc[1272]: Time Updated: Thu, 28 Apr 2016 23:30:02 -0700 [+1s]
    However it really depends on if your WAN connection is working, and if the NTP servers are correct, and if set to FQDNs, if those can be resolved with DNS at startup or not (may depend on WAN connection).

    NTP clock syncing is configured via a cronjob (see cru l), running the Busybox utility called ntpsync, which actually runs ntpc, at a periodic interval (default is, I think, every 4 hours -- it's configured under Basic -> Time), but also runs it at router startup. Misconfiguration here could result in a non-syncing clock.

    I would also suggest trying to sync the clock with NTP manually. Take one of the NTP servers configured under Basic -> Time and try using ntpc {server} and see what happens. The output should look something like this, if successful:

    root@gw:/tmp/home/root# ntpc my.ntp.server
    Trying my.ntp.server []:
    Time Updated: Wed, 04 May 2016 03:15:38 -0700 [+1s]
    If you're using a WAN connection like PPPoE, or have some "weird setup" involving VPNs or punting of traffic across different/weird methodologies on boot-up, then this could probably cause complexity for packet routing when ntpsync/ntpc runs at boot. There are (semi-crummy) workarounds if that's the case, but I'm not going to provide those until the root cause can be determined.
  8. rs232

    rs232 Network Guru Member

    Shibby, 2 questions about the MultiWAN

    - I have 1 WAN at the moment and can see the wireless client option greyed out in the basic network settings, is this meant to be?

    - Can wireless client be used as WAN option in MultiWan? I have a specific case where I would actually like to have 2 wireless clients (2.4 + 5) as default gateways using 2x different SSID/ISP.

  9. skygunner

    skygunner New Member Member


    This MultiWAN mod does support the Belkin Share MAX N300 F7D7301 V1 right?
    How to flash it?

    I tried to flash the tomato-K26USB-1.28.RT-MIPSR2-136-Big-VPN via CFE web interface, but it says invalid file.

  10. Threedeenabua

    Threedeenabua New Member Member

    First of all thanks a lot for the MultiWAN version... I really like the fast enabling/switching on MultiWAN routing. Would be perfect if WAN1/2/OFF can be switched with one click without the Save button. Just asking too much I know :D

    I have 4 VLANs setup, had an internet connection problem, first DNS was not assigned the VLANs, or it was not picking up the default DNS settings from WLAN for secondary VLANs. Using DNSMasq to assign manually now.

    Also had a weird internet connection problem, again in other VLANs (not the first default one), was not stable until I disabled the default setting Advanced/Routing/DHCP Routes

    A few questions:
    Will you support Dynamic DNS for Multiple WANs?

    In Advanced/Misc. section there is CTF option, is it hardware acceleration? and if it works for multiwan settings?

    My Router is Asus RT-AC56U

    Thanks again for your great efforts...
  11. Oldo69

    Oldo69 Network Newbie Member

    Hello all, I tired to find solution for setting that I would like to use, but I did not. May be I just skipped that so please if you know how to set:

    ! am using Asus RT-N66U with firmware MIPSR2-136 K26 USB AIO-64K
    WAN - static IP

    I would like to set WAN2 that will be connected to Portable Wifi hotspot created by my mobile phone. I tried to set but without success.

    Any ideas how to do it?

  12. gvekony

    gvekony New Member Member

    Hey people!
    I have a minor problem on my RT-N18U with fw 136-MultiWAN-Tomato-RT-N18U-ARM--136-AIO-64k.

    I have installed optware/ipkg via the built in scripts, mounted a hdd, created an opt partition, etc. I've installed the sftp package, and it looks like I cannot log into the router via sshfs unless I do the following mount:
    mount /opt/libexec /usr/libexec

    My question would be, that can this error be solved somehow, and via this mount shall I loose some functinality of the fw? The /usr/libexec is read-only, thou symlinking does not work and it contains mysqld and /nocat/ by default.

    Without the mount command I get the following error:
    $ sftp root@
    sh: /usr/libexec/sftp-server: not found
    Connection closed

    With the mount the sftp-server is available in /usr/libexec/ and everything works fine. Thanks for your help in advance!
  13. koitsu

    koitsu Network Guru Member

  14. Greg_B

    Greg_B Reformed Router Member

    I posted this in tomato DOT groov DOT pl/?page_id=334&bugerator_nav=display&bug_project=1&issue=2061 - which appears to be unmanned (I can't determine whether it is as no replies to other bugs - My apolgies if this isn't so)

    "root@gateway:/tmp/home/root# nvram export --set | grep wan44
    nvram set wan44_qos_obw="700"

    (should be wan4)

    This is a default & I haven't actually used WAN 4 - I'm just reporting it in case it's causing the wider problems like NaN% on Zoom Graphs & Max/Min values not shown after the % Rates / Limits in QoS Basic Settings"

    (Also, it's Version 136)
  15. Threedeenabua

    Threedeenabua New Member Member

    Does OpenVPN work properly on version 136?
    Can it use multi WANs automatically?
    Does MultiWAN Routing works with it enabled?

    I am having a hard time getting internet while OpenVPN is on...

    Thanks for your input.
  16. Pess0g

    Pess0g Networkin' Nut Member

  17. rs232

    rs232 Network Guru Member

    @shibby20 I have installed 136 on an old RT-N16. It appears like the GUI fools the user into believing that this device can operate as AP and wireless client at the same time (e.g. is you choose wireless client the AP option is not greyed out).
    Something you might want to correct.

  18. The Master

    The Master Network Guru Member

    Thank you for the MultiWan Version.

    It is working but in a wired way... i dont see what connection at the Moment is used for the Download. Sometimes i uses Wan 1 and on the other Download Wan 2 (wan 1 is dhcp// wan 2 LTE).

    So sometimes my download speed is at a 1 connection good and on the other side not. wan1=75mbit wan2=30 mbit

    in the download Manager or Steam or other Multi Connection Downloads i got my 105mbit.

    But it is a bit anoiing :( Is there any Workaround?

  19. gennis

    gennis New Member Member

    Hello everyone.

    I don't know where to post a new thread but I badly need anyone's help.

    I have flash my dual wan with tomato to updated tomato version router management but it did not finished flashing because of power black out. Now i cannot log in to it tells me unidentified network. I have try resetting the router but nothing happen anyone here can help me please..

  20. kim11

    kim11 Networkin' Nut Member

    Hi, I've been trying the firmware right now and I can't get portfowarding to work as well.

    Tested on Asus N10u
    With firmware v136 tomato-K26USB-1.28.RT-N5x-MIPSR2-136-BTgui-VPN
    Cleared NVRAM before hitting upgrade and after initial boot just to double check.
    I'm using an ADSL setup(DSL Modem in Bridge+Wifi Router in DHCP)
    PPPoE is not used.

    If I missed something please kindly tell me.

    I switched to tomato-K26USB-1.28.RT-N5x-MIPSR2-136-VPN.trx and did the same process and now port forwarding works for some reason.


    Need help accessing my DSL modem in route modem IP.
    It works fine when only WAN1 is enabled but in multiwan mode it just goes to time out.
    route modem IP in WAN2 is disabled/

    I can also ping my DSL modem on both modes.
    Last edited: Jun 8, 2016
  21. val bete

    val bete Network Newbie Member


    Auto detect/config QoS when activated or enabled.
  22. joksi

    joksi Serious Server Member

    I would also like to report some bugs in v 136 on Netgear R6250.

    1. When making changes to the multiWAN priorities and saving the router more often the not reboots and restores to default values.

    2. Wireless 2.4ghz only works with some devices, you have to go in wireless advanced and change antenna from auto to B and A, then it starts working with all devices I have. However, the speed is terrible for N-clients, 20-25Mbps.

    3. PPTP-client doesnt work, it doesnt start on reboot (even if checked "Start with WAN") and when starting it manually it does connect, but not change any routes. I have it checked to send all traffic over the VPN and apply NAT, but nothing works. The routes are missing and the IPtable masquerade command too. I haven't tested in single WAN-mode, only with 2 WAN's connected, maybe it's conflicting with the multi WAN feature?

    4. Fail-over mode seems broken regarding to DNS.

    5. Policy based routing in GUI works sporadically. Also, if a WAN connection is in failover mode it doesnt work, only when changed to load balance.

    6. The WAN status report in overview is buggy, at the moment I have three WAN-ports + 1 USB-modem, only WAN1 and 2 are reporting IP-adresses and connected status. However, when issuing "ifconfig" i can see that all WAN have IP's. In GUI it just says undefined, or and so on.

    UPDATE: Tried with only WAN1 enabled, PPTP-client config from GUI seems pretty broken. It does start a ppp-connection, but that's about it. Nothing else of the options on the page works.

    And now to some request of changes.

    1. Because it's now a multi WAN feature, you should be able to setup more parameters independently per WAN in GUI. Ie DDNS, DHCPc options, IGMPproxy upstream interface etc.

    2. You should be able to use the extra WAN even if set in fail-over mode (weight 0), ie policy routing. Now policy routing in GUI only seem to work when all WAN's are in round-robin. Not smart.

    3. Notification/alerting of some kind when changing WAN-connection (failover), also in GUI a nice idea if you could see which connection is used at the moment. Something like a status health report.

    Last edited: Jun 30, 2016
  23. Eddie55

    Eddie55 Serious Server Member

    Thank you for all your hard work with MultiWAN Shibby

    I have 4 questions for or anyone that might know the answers

    1) How quickly is the router supposed to detect a problem or connection with the WAN X and fail over or load balance to WAN Y?

    2) Can this value be adjusted?

    3) For Load balancing with values 1 - 256 what do these Values mean?

    4) For Load balancing the higher the number the more priority?

    Thanks in Advance
  24. joksi

    joksi Serious Server Member

    1 & 2. "Check connections every..." under Basic network settings I suppose is where it's adjusted.

    3 & 4. The values means what priority each connection has, ie 1/1 is equally used. However, this unfortunately isn't completely true, because of something called route cache in Linux. Even when set with equal priority, the cache will result in different connections going out the same WAN if there already is a cached route out of that WAN recently. Yes, the higher the number the higher priority.
  25. cooroxd

    cooroxd New Member Member


    I have an asus router rt-n12 d1. I'm not sure which tomato firmware I need to flash. There's a 136 multi-wan, 132, max, mini, aio etc. I just want something stable with wifi extender.
    So which firmware should I download?
  26. nmalinoski

    nmalinoski Networkin' Nut Member

    My RT-N12/D1s report 8MB flash, so whatever fits, I guess. A quick scan of the 136/Asus RT-Nxx directory shows all non-USB firmwares are under 8MB, so any will probably do.

    Personally, I run Toastman RT-N K26 Std on these routers; VPN would probably work, too.
    cooroxd likes this.
  27. cooroxd

    cooroxd New Member Member

    Any special procedures of flashing it? Do I need to download the recovery tool to flash it or I can flash from the asus stock firmware via browser? And do I need to do the 30-30-30 reset after flashing?
  28. acidman

    acidman Network Newbie Member

    I love the adblock feature.... Thanks

    Sent from my Nexus 7
  29. nmalinoski

    nmalinoski Networkin' Nut Member

    I didn't have to do anything out of the ordinary for getting Tomato on an Asus router. Like other routers, you'll need to use recovery mode, as the stock Asus firmware won't accept Tomato as a valid replacement firmware.

    For my N12/D1s, I put them into recovery mode(1), uploaded Tomato via the CFE web interface(2), and let the routers reset themselves. There should be an option in the CFE web interface to wipe nvram, or you can power the router off, hold in WPS button, and then power it on while continuing to hold the button for 20-30 seconds. The 30-30-30 reset is bunk.

    (1) Power off, hold Reset button in with a paper clip, power on, wait until power light starts flashing really slowly.
    (2) Set a static IP on your desktop, or a VM with bridged networking (Should be 192.168.1.x where 1 < x < 254), then access in a web browser.
    cooroxd likes this.
  30. Frequenzy

    Frequenzy Networkin' Nut Member

    were there any enchancements for multiwan on v137?
  31. remlei

    remlei Networkin' Nut Member

    multiwan policy routing is slightly usable now but still very buggy.

    just like if you set a routing to wan2 im sure that certain app is connected to a certain port, but when I unplugged wan1 port that app's network connection gets lost for no freakin reason.

    I had the same setting with openwrt mwan3 and this doesnt act like what tomato multiwan does.

    I just hope that shibby adds a new multiwan mode for policy based routing, instead of having only a loadbalancing and failover.
  32. cooroxd

    cooroxd New Member Member

    after following all of your steps i get greeted with this message and then the router won't start or progress to the tomato firmware:

    Settings have been updated. Web page will now refresh.
    Changes have been made to the IP address or port number. You will now be disconnected from RT-N12D1.
    To access the settings of RT-N12D1, reconnect to the wireless network and use the updated IP address and port number.
  33. CBR900

    CBR900 Network Guru Member

    @The Master

    I am interested in adding the speeds of my vdsl line (40mbit-pppoe) and the speed of my 4g (20mbits) router when downloading with multi connections accelerators or torrents...

    can you show me your setup/configurations will be good.

    Will this setup work with the latest "Tomato Firmware 1.28.0000 -137 K26ARM USB AIO-64K"?
    Last edited: Jul 2, 2016
  34. nmalinoski

    nmalinoski Networkin' Nut Member

    I'm sorry you had trouble; I was recalling from memory, so I may have left something out by mistake.

    Tomato was successfully flashed--this is good. Are you able to ping the router at all? I would try erasing the NVRAM again; try SSHing in and running 'nvram erase' and 'reboot', or try erasing the NVRAM from the CFE/recovery mode web interface.

    Which firmware did you use: Toastman or Shibby?
  35. mvogel

    mvogel New Member Member

    Using the RT-N16 and the latest release - tomato-K26USB-1.28.RT-MIPSR2-137-AIO

    set up vlan for wan2 and set it to failover. when wan1 fails, wan2 does take over but dns does not work. I can browse sites all day if I use the ip address. I tried using the same dns as wan1 and different dns and neither seems to work. any ideas?
  36. eangulus

    eangulus Network Guru Member

    Can't find a clear answer so I will ask.

    Did a clean install of 137 to a RT-AC66U yesterday.

    It seems that the QoS rules are working fine for outgoing connections, but inbound seems to be assigned to the default class only. I have DSL Overhead Value set to None also (fixed the issue last time I had a similar problem).

    Is this a known issue or something wrong with my end?
    Last edited: Jul 11, 2016
    xtcbt likes this.
  37. lucidamike

    lucidamike Reformed Router Member

    I have a Linksys/Cisco EA6700 router and since change to Multiwan (all versions) after updating BIOS and setting up router, after next router restart, lost 2.4GHz wifi

    After seeing that there was an issue with memory on these routers (32K NVRAM bug), changing from using the AIO build to the smaller VPN build seems to have resolved problems
  38. Brian_E

    Brian_E Reformed Router Member

    I tried Shibby build 137 earlier this week and had similar problems with no Internet on many of my wi-fi devices, although some seemed to be working OK, except the download speed was lower than usual and got worse over the course of an hour or so. Another weird thing was, a NowTV box that I had recently installed for a second TV would initially connect but with no Internet access, but after rebooting the router, it would even connect to the network any more. I've had to put Merlin's firmware back on my Asus RT-AC68U to restore normality.
  39. val bete

    val bete Network Newbie Member

    Thanks for adblock feature... hope you can upgrade it to block https ads
  40. joksi

    joksi Serious Server Member

    Where is the changelog for v. 137?
    I can't notice that any of my previous reported errors were fixed...

  41. mmosoll

    mmosoll Networkin' Nut Member

    Shibby's changelog:
  42. lefting

    lefting New Member Member

    Tomato Firmware 1.28.0000 MIPSR2-137 K26 Max
    Linksys E900 v1.0
    Don't work L2TP

    MAC Address C0:56:27:2E:63:25
    Connection Type L2TP
    IP Address must be
    Subnet Mask
    MTU 1460

    Status Disconnected
    Connection Uptime - it's IP from modems DHCP

    LOG: Attached File e900.txt and e900reboot.txt

    Attached Files:

  43. Mirko Baila

    Mirko Baila Networkin' Nut Member

    you can use a stick to get 4g with multi-WAN a backup connection?
  44. joksi

    joksi Serious Server Member

    I think this should'nt even work. If you connect your two WAN-assigned ports to two LAN-ports on your primary router, both WAN1 and WAN2 will receive IP's in the same subnet from the primary router. So your Wan1 and WAN2 will have two identical routes to ie network, and the default gateway will be likely which means the router won't know which route ( WAN-interface) to choose. Even if it does work, according tyo your statement, maybe this is what interferes with the load balancing feature.
  45. Malakai

    Malakai Networkin' Nut Member

    Don't remember if I used vlans with 2 different subnets or not... but those are the results I got. You don't have to trust what I say, you can test it yourself, cause frankly I don't remember exactly the steps I took and I don't have a router at hand anymore to retest that.
  46. joksi

    joksi Serious Server Member

    It seems like multiWAN routing won't stick, after reboots and even after a while when the router is running it stops working. I have to go into the GUI and save (unchanged) settings and then it starts working a while again.

    EDIT: I think I've found the reason, multiWAN/policy routing is nothing else than IP-table rules added to the mangle table referencing the right route table. If I construct and add the same rules manually to firewall script, it sticks, but not by way of multiWAN GUI. Probably a bug.

    Last edited: Aug 5, 2016
  47. salar

    salar Serious Server Member


    Thank you very much for your support and contribution. Recently I flashed your multiWAN build on Belkin F7D3302. I intend to used my android phone to USB tether to router to share the net to other devices at home. Is it possible ? Please suggest.

    Your humble FAN, using your builds for long time.
  48. remlei

    remlei Networkin' Nut Member

    it will work as long as the IP address it self is not the same, like connecting a DUAL NAT connection to your multiwan router. If this thing is a issue, it should be a major issue right now not only tomato but other multiwan router based solution. IN fact I got 2 WAN IP (public IP) that is sometimes assigned in same gateway and same subnet. and my multiwan setting works (barely for tomato multiwan because of the bugs, but im using openwrt mwan3 so im good).
  49. joksi

    joksi Serious Server Member

    Well I dont agree. As i wrote, maybe it dos work, but theoretaclly it should cause some problems with choosing routes. The whole point with multiwan is to not ute same provider, that is same network and subnet. I would guess The most usual seetup is two completely different providers and /or different connection methods, and naturally because of this different networks.
  50. remlei

    remlei Networkin' Nut Member

    why would it cause problems? ive work on this kind of scenarios many many times before and there was no issue whatsoever. I assume you didnt encounter this kind of setup yet, specifically in linux ip which actually tomato also uses the same thing.

    prove it to me that it will have some issues and ill take all the shame for my stupidity.
  51. joksi

    joksi Serious Server Member

    I'm not here to prove anything :) I'm just discussing.
    Maybe i'm wrong, however, the fact still stands that the whole point with multiWAN is actually to have multiple internet connections with different service providers, and different service providers means different IP-adresses and networks / subnets. I don't see the point with two redundant connections to the same gateway and network.

    I know it was a test the guy made, because he didn't actually have two internet connections, but I think that simulation didn't make it fair.

    Please also do read following link:
    At the top it states, "Note: Multiwan will NOT work if the WAN connections are on the same subnet and share the same default gateway."
    Last edited: Aug 5, 2016
  52. joksi

    joksi Serious Server Member


    I see you have released a new version, 138.
    I cannot see any improvements on 2.4Ghz WLAN performance on my Netgear R6250. In your changelog I can spot the following: – Updated wireless settings for R6250/R6300v2/R7000
    What does this mean?

    Also, PPTP-client is still not working properly.
    Will test multiWAN routing too and give feedback.
  53. AndreDVJ

    AndreDVJ LI Guru Member

    What it does is to align TX beamforming parameters with Genie.

    Beamforming for 802.11n clients are optional, so I don't believe this will make a difference to you.
  54. joksi

    joksi Serious Server Member

    Okey, were are these new settings?
    I have AC clients too.

    Im still forced to manually set receive and transmit antenna for 2.4ghz manually for my clients to connect at all, default "auto" does not work.
  55. joksi

    joksi Serious Server Member


    I would like to report another issue. It seem it's in both v137 and 138.
    The WAN-up-script is just run sometimes after reboot.

    ls -la /tmp | grep sh
    -rwx------ 1 root root 902 Jan 1 01:02
    -rwx------ 1 root root 52 Jan 1 01:00
    drwxr-xr-x 2 root root 40 Jan 1 01:00 share
    drwxr-xr-x 2 root root 40 Jan 1 01:00 splashd
    -rwxr-xr-x 1 root root 186 Jan 1 01:00
    -rwxr-xr-x 1 root root 126 Jan 1 01:01
  56. AndreDVJ

    AndreDVJ LI Guru Member

    1) Yeah that's it. Probably only AC clients will honor beamforming these days.
    2) Wi-Fi settings changes do not mean improvement. We just carry over whatever the hardware vendor says.
    3) Your 2.4Ghz issue, I have no idea. Whatever I connect to my R7000 works out of box. Which was the last version that worked for you?
    4) About the wanup script, does this command nvram show | grep script_wanup return something?

    Also about the Wi-Fi settings, if you can build Tomato, you can try getting settings from Genie sources.

    Sometimes, if you wanna see something fixed, sometimes you have to get the sources and try. I compiled and flashed Tomato on my device I'm pretty sure about 100 times, and bricked it few times as well :)
  57. joksi

    joksi Serious Server Member

    2 & 3. Okey I see, well, ever since I bought the Netgear R6250 and immediately put Tomato on it the issue have been there. Receive and transmit antenna must be set manually, from default "auto", so that clients can connect. With default, my wireless PC, cell phone and TV won't connect at all to 2.4Ghz. 5Ghz works flawlessly. Also, when finally connected the speed is about 20Mbps on 2.4Ghz, while on my old Netgear also with Tomato the speed was 60Mbps (300mbps mode). There are several people complaining about the same issues in this thread, regarding the 2.4Ghz operation.

    4. The command returns only the first line of the WAN-up script, but so does the script_fire and script_init too, however these do actually run and I can see the scripts in the tmp-folder. It's just the WAN-up script that seem to run/get created sporadically after each reboot.

    EDIT: When disabling WAN4 (3G-dongle) WAN-up script is working...
    Last edited: Aug 7, 2016
  58. WaJoWi

    WaJoWi Reformed Router Member

    I have some issues with multiWAN.

    After a reset of the router no time synchronization is performed with the NTP servers. The date and time are unknown. The OpenVPN server will not start, and sometimes the Web server.

    My modem stick (4G / LTE) can not connect (after a reset of the router). I have to unplug the AC power and thus restart the modem stick working again.

    This is annoying because after a reset still a manual intervention is necessary so that the router is working properly.

    I already deleted the NVRAM and everything reconfigured.

    Is there a solution for this?
  59. joksi

    joksi Serious Server Member

    IGMPproxy stopped working with my IPTV-provider in last version... 137 work
  60. AndreDVJ

    AndreDVJ LI Guru Member

    I updated igmpproxy with the latest sources from the repository where it is currently maintained.

    I did some research, and looks like someone is actually looking after this:

    Disablee igmpproxy from the GUI, and post output of the following command, let it run for like 10 seconds:
    igmpproxy -d -v /etc/igmp.conf
    From what I could understand from that thread, maybe you could be using IGMPv2. Perhaps adding stuff for IGMPv3 broke the former.

    Does anyone else use igmpproxy? Otherwise, it's better to fall back to previous version.
    Last edited: Aug 31, 2016
  61. WaLLy3K

    WaLLy3K Networkin' Nut Member

    Shibby v138 still has an issue that was introduced when the MultiWAN builds were released: QoS "Zoom Graphs" don't work. (Asus RT-AC68U)

    What I'd expect to see: The graph would correctly scale to show how much bandwidth is being used, compared to the Max Bandwidth Limit

    What I currently see: NaN%, and the graphs do not zoom.
  62. joksi

    joksi Serious Server Member

    I have switched back to 137 because my TV stopped.
    However, I could see IGMP-traffic hitting the WAN-interface while igmpproxy was running, and stopped when shut down.
    Yes, I think my provider is using v2.
  63. joksi

    joksi Serious Server Member

    I have switched back to 137 because my TV stopped.
    However, I could see IGMP-traffic hitting the WAN-interface while igmpproxy was running, and stopped when shut down.
    Yes, I think my provider is using v2.
  64. AndreDVJ

    AndreDVJ LI Guru Member

    Well I have a commit ready to backout the update, though I have not pushed to my git repository. I will do it soon.

    I guess it's a better idea to just backout. The audience for igmpproxy is pretty limited. My ISP don't provide IPTV services. They offer cable TV instead.

    What is your router? I can get ARM images compiled tomorrow morning. If it's a mips router, you'll have to wait a little longer.
  65. joksi

    joksi Serious Server Member

    Okey. It's an ARM-router, Netgear R6250.
  66. joksi

    joksi Serious Server Member

    By the way, is it possible to add which WAN to operate IGMPproxy config in GUI? I mean if it's a quick fix?
    Because now I have to have a startup script that kills igmpproxy, copys a new config to /etc with upstream interface changed from default WAN to WAN2.
  67. AndreDVJ

    AndreDVJ LI Guru Member

    Should be possible to add which WAN will operate, but unfortunately isn't a quick fix. Both GUI and rc (services.c) need new code in there. Anyway it's a good suggestion.
  68. joksi

    joksi Serious Server Member

    I have another problem regarding the 5ghz WLAN.
    I have two stationary N-clients connection to 5ghz, one is in same room as the router (3-4 m away, free sight) and The other is like two rooms away with concrete walls in between, say 15 m.

    Now the issue is that if i set the channel to 36 and lower control channel, The client in the same room gets really poor connection and big packet loss. The other works great despite the distance. Then if i changes channel to 40 and upper control channel the client in The same room works great with great babdwidth, however the client in The other room barely connects at all and when it does its The one with bad performance.

    Why is this and is there any way solving this?
  69. AndreDVJ

    AndreDVJ LI Guru Member

    No easy way to put this, but sometimes a given wi-fi client from a given brand, doesn't like the wi-fi chipset or driver.

    I'd suggest to try a different channel, such as 149.

    The last thing I did related to wi-fi *should* honor AC clients only, and greatly improved connection stability of my cellphone (the only hardware I have which supports 802.11ac).
  70. joksi

    joksi Serious Server Member

    Okey, thats too bad.

    Well, ive tried both 149 and 153, but then none of them connects at all...

    I too only have one AC client, also my Phone, but it doesnt have any problems at all on any channel.
  71. ruggerof

    ruggerof Network Guru Member

    In regards to 5Ghz channels you also have to check if the wifi client accepts certain channels according to the regulations it is sold to.

    My European spec MacBook for instance doesn't even detect if I set channel 54 in the router simply because channel 54 is forbidden in Europe.
  72. joksi

    joksi Serious Server Member

    I see. Well, the problem with Tomato is that only the region USA seem to work on 5Ghz, if I choose EU or Sweden where I'm located at there is no channels available under 80Mhz-mode at all (only 40Mhz). Don't know if this is also one of Tomatos existing bugs..?
  73. AndreDVJ

    AndreDVJ LI Guru Member

    Actually how Wi-fi behaves in this case, is up to the wireless driver, so it's all up to Broadcom, since the driver is a closed-source binary blob.
  74. joksi

    joksi Serious Server Member

    Hmm. But this problem doesnt exist in Netgear factory firmware?

    Also 2,4ghz is like three times faster then Tomato...
  75. AndreDVJ

    AndreDVJ LI Guru Member

    That's the point. Tomato doesn't use wireless driver coming from Genie, but from AsusWRT instead, and we are unable to replace the wireless driver with anything else. I personally tried and the router simply bricks.
  76. ruggerof

    ruggerof Network Guru Member

    Mine is set for Australia and channel 100, however I don't have any AC client to test, only N.
  77. joksi

    joksi Serious Server Member with other words, your saying there wont be any performance increase in Tomato firmware for these routers?
  78. joksi

    joksi Serious Server Member

    Okey...sounds strange that only some regions offer channel selection.

    Are your n client 2.4ghz or 5? IF 2.4, whats your throughput?
    Is there anyone getting faster then about 20mbps..?
  79. ruggerof

    ruggerof Network Guru Member

    Much faster than 20Mbps, in 2.4GHz with the severe interference my neighbours provide me I can get 70+ Mbps in WAN-WLAN (, in 5GHz I can almost top up my WAN-WLAN reaching 98 Mbps. Both using my MacBook at approx 5 m from my RT-AC68U

    I have never tested WLAN-LAN.
  80. joksi

    joksi Serious Server Member

    Then something is really wrong here, or the problem lies within the Netgear R6250. I'm trying both my phone and my PC with Netgear N-card 2.4ghz dongle, both gives me max 21-22mbps on With 5ghz N-client 70-80Mbps, AC on my phone ~250Mbps (my Internet is 250/100). I'm satisfied with 5ghz, but 2.4 ghz is really poor. My old Netgear with Tomato handled about 70-8Mbps on 2.4ghz!

    I have tried switching 2.4 ghz channels, both 20 and 40Mhz, it doesnt matter!

    Are your region Australia for 2.4 ghz too..?
  81. ruggerof

    ruggerof Network Guru Member

    For me the 2.4Ghz works well only if I'm very close to the router, otherwise the speed drops substantially. I don't know if it is due to the wireless driver or if it is due to the interference.

    In 5GHz on the other hand is great for me, my flat is completely covered and the drop in speed is minimum.

    My 2.4Ghz is set to Anguilla as region.
  82. joksi

    joksi Serious Server Member

    I dont get it, sure we have two differen router models but i suppose the driver is the same..?
    Can the region affct performance?

    I have minimal signal strenght on 5 ghz at The far end of The aoartment , but i guess this is known, however the throughput is almost unaffected.
  83. joksi

    joksi Serious Server Member

    I just compared with my old Netgear in N-mode (40mhz) with Tomato v 101 and I can straight away see that the PC reports connection speeds fluctuting between 250 and 300Mbps, and the real througput is about 6-7MB/s (LAN->WLAN), but when I disable the radio on the old router and enable it on R6250 the connection speed is 100-150Mbps and the throughput while transferring the same file is 3-3,5MB/s.

    To me it seems that somehow the driver in Tomato ARM is locked to 150Mbps max, like it's only using one of the antennas? That would explain 25-30Mbps throughput (good G-standard speeds) vs. 50-55Mbps on 300Mbps. I have double checked the R6250 and its setup in 40Mhz-mode...
  84. xtcbt

    xtcbt Serious Server Member

    Hey there, I have the same problem like yours and I'm using 138 on a rt-n66u today. I did nvram erase and built my configuration from scratch but still no go. Have you resolved your issue? Can someone help in regarding this issue? Thanks in advance!
  85. romariolele

    romariolele New Member Member

    I've got 2 connections; primary VDSL (real 85 megabit/s ds) secondary VDSL (real 80 megabit/s ds).

    I would like to bind them (160 megabits when I use download manager or torrent)

    I have set On my ASUS RT68 (Tomato 1.38) dual wan mode, but I are not able to get no increase of speed.

    where am I wrong?
  86. joksi

    joksi Serious Server Member

    If you set the same weight/priority on both connections it technically should round robin the connections from bittorrent out on the two interfaces, but to me it looks like Tomato MultiWan is still in very much beta with many bugs and issues.
  87. CBR900

    CBR900 Network Guru Member

    I hope this will work with you:

    and let us know...
  88. ryans1

    ryans1 Network Newbie Member


    I have a suggestion regarding the AdBlock feature, which is very nice, but would be great if we would have the following features/possibilities:

    • being able to choose whether we want to autoupdate the blacklist everyday at 1AM, or being able to customize this option to choose when to autoupdate, or even have a button to manual update
      • this would be useful because:
      • I want to add my own blacklist, which can not be loaded through the custom blacklist (for example, with 60000 hosts the browser will either crash when pasting it in that textbox or the data is too big to be saved in nvram)
      • if I want to use my own list, there is no point to autoupdate it everyday because it will not change that often
    • being able to upload a file from my computer or use one from the router local files, not only from HTTP sources
      • I know wget dos not support "file:///" protocol, so it would be nice to have an option to specify a path on the router from which to get the hosts file (for example, /usr/tmp/hosts.txt)
      • this would be helpful when you can not easily find a host on which to host your own blacklist and have a direct download link, and that would keep your file forever
      • another option would be to have an extra column in the Blacklist URL table, which allows you to set the type of the source (HTTP, local file, etc) and then you would know to use wget or curl, or even to have a button to upload a file from your computer
    Thank you, and please tell me what do you think about this.
    Last edited: Sep 22, 2016
  89. JesseWV

    JesseWV Network Newbie Member

    I'm a little confused as to which firmware image I should be using for my router. Can someone tell me what the difference is between these two?

    /download/K26RT-N/build5x-138-MultiWAN/Asus RT-N66u 64k/


    Which one should I be using?

    I have Model Asus RT-N66U.
    (Chipset Broadcom BCM5300 chip rev 1 pkg 0, CPU Freq 600MHz, Flash Size 32MB)
  90. joksi

    joksi Serious Server Member

    There is still issues with DNS in v138.
    I have three WANs, but in mi /tmp/etc/resolv.dnsmasq only DNS servers from WAN1 is saved. The IP rules is correct and contains all DNS servers out on the correct interface, but because only WAN1 DNS servers are used connections forced out on other interfaces wont work.

    Temporary solutions is to setup Google DNS on WAN1 so that everything works, but this should be fixed.
    Last edited: Sep 24, 2016
  91. joksi

    joksi Serious Server Member

    Just a question regarding performance. I have one ethernet cable going to WAN on my router, through this cable I have two providers (one with VLAN tagging and one without). I have this setup working as it should, however, when I'm trying to simulate and max out each connection (>100mbps) I only get like fluctuatng 50/50 on both connections, like it's sharing 100mbps bandwidth (not > 200Mbps). I'm doing this by running to Wget instances on a Linux machine downloading a zip file, where I'm running each command bound to a specific local IP (IP aliasing in Linux) and in Tomato I have MultiWan routing configured so that each of these IP-adresses are forced out on each of the connections. I have verified this part working, cause I get different WAN IPs. When I start the first instance it settles at around 11MB/s, but then when I start the second it slows down to like 5/5, or 7/4 etc. instead of both transfers peaking at 11;B/s.

    I should also add that the Linux machine is connected with gigabit to the router, and the WAN ethernet cable is also connected at gigabit speed to my provider. So that should not be an issue, > 200mbps is far less then 1 gbps...

    I tried this because when I first tried some different torrents with round robin (same priority on WAN-connections) I could see any faster speeds then about 100mbps. Now in this test I specifcally route one download through one interface, and the other through another...

    Anyone having any ideas?
  92. khetan

    khetan New Member Member

    I have a query on Tomato v138 on a Linksys E1550 (Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB VPN)

    I have 3 WAN links, and would like to use WAN1 (primary), WAN2 (secondary) and WAN3 (tertiary) in that order. I current have WAN1 set to weight 1, and WAN2 and WAN3 to weight 0.

    How do I achieve this waterfall WAN failure given the current implementation of MultiWAN ?
  93. joksi

    joksi Serious Server Member

    That doesn't work with the current implementation, at least not through the GUI.
    However, a work around would be if you set priority 256 on WAN1, 1 on WAN2 and 0 on WAN3. That *should* result in what your requesting.
  94. Jerezano

    Jerezano Reformed Router Member

    I am new with TOMATO firmware Before I had DDWRT , Testing the lasted build 138 on my Linksys E2500 v1 and got in to the same issue some of you are reporting with QOS routing all incoming traffic to the default class, The only solution for me was to install Built 132 that has no multiwan.

    Did anyone else have a different experience or solution?
  95. Jerezano

    Jerezano Reformed Router Member

    I downgrade my E2500 from 138 o 132 because qos was not working on builds 133-138.
    I had the same problem even with build 132 I check I browser console for the error and clear all errors, them
    strangely the problem was fix with it. But to be sure I erase all my browers cache!
  96. khetan

    khetan New Member Member

    Thanks for responding! Afraid it just included WAN0 and WAN1 as equal partners in the load balancing scenario, with failover to WAN3 when required.
  97. joksi

    joksi Serious Server Member

    Well that's odd. How did you test it? Because equal is when having the same priority.
    This settings should almost exclusively use WAN1 (because the priority is 256 times higher...), then WAN2 if WAN1 doesn't work, and lastly WAN3 which is in standby-mode with priority 0.

    It works for me when testing now, the WAN set to 256 is only being used.
  98. joksi

    joksi Serious Server Member


    Some more bug reporting.
    3G-modem WAN connection has some problems, every reboot of the router it often has hard time and takes long time to connect. Even worse when combining one WAN with 3G and another WAN with PPTP (as is in my case).

    Next thing, when running PPTP on WAN it seems like the PPTP-connection is not always established on the said interface, but other WAN-interfaces. I have tried setting a static route to the PPTP-server and interface MAN1 (my PPTP-connection is called WAN1), but this only works partially. Looks like the routing tables isn't always respected and other of my WAN-connections is randomly used.

    Further on, there has to be a way of defining which interface the router itself are going to use for certain traffic (instead of strictly round robin). MultiWAN routing policy only seem to affect clients in the network, and not the router itself. This should be corrected too.
  99. WRTed

    WRTed Serious Server Member

    Have been using multiwan for a week on my cable and fiber connections on my r8000 router

    Works great.

    Only request, for DDNS. I would like to assign Wan1 to dynamic dns 1, and Wan2 to dynamic dns 2. Currently you can just pick one wan to be used for both, unless I am missing something.

    Otherwise keep up the good work.
  100. jsantosv

    jsantosv Network Newbie Member

    Hello! I've been trying to use the multiwan feature with my mobile hotspot and wired adsl. I'm using a Lumia 640 LTE as hotspot. It works flawlessly, only limitation is that it only accepts WPA2. I've been following these instructions by shibby:
    So I make a new vlan (vlan3) without ports assigned and reboot the router. Then go to Basic -> Network and configure WAN like this:

    Router: ASUS RT-N66U Firmware: tomato-K26USB-1.28.RT-N5x-MIPSR2-138-VPN-64K

    WAN Settings
    Type: DHCP
    Weight: 1

    WAN2 Settings
    Type: DHCP
    Weight: 0 (I don't want it to be used unless I set a static route for it)
    Wireless Client Mode 2Ghz
    SSID (same as hotspot)
    Security: WPA/WPA2 Personal
    Encription TKIP/AES

    After this, the router only connects with the hotspot but the wan doesn't work. It stays "connecting" forever. I also tried using a static IP for WAN (after configuring my adsl router) and it says "connected" but nothing passes to WAN.

    Also, if I change the interface of the vlans like vlan2 (WAN) for WAN2 and vlan3 (WAN2) for WAN, the router still uses vlan2 as WAN for the hotspot, even if I configured only WAN2 in the GUI for wireless. Also noticed that when I do this, the port order in the GUI gets all mixed up.

    Ultimately, what I want to do is this: Use my hotspot AND wired adsl at the same time, use the adsl (WAN) as the default route and redirect specific traffic through the hotspot (WAN2). Is this even possible? The default firmware completely disables WAN when the router is set as a repeater.
    Last edited: Nov 4, 2016
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice