Tomato N66U WAN ISP connection setting guidance

Discussion in 'Tomato Firmware' started by 90Ninety, Apr 13, 2018.

  1. 90Ninety

    90Ninety New Member Member


    I recently dipped my toe into the Tomato Firmware (version 1.28 Shibby AIO) for my 'Dark Knight' RT-N66U Asus Router ( B1 Revision )

    I got really excited with all the features but , I am also quite lost with the WAN setting for my ISP modem , I have not been able to get the router to connect to the ISP cable modem ( Virgin UK cable modem - Hitron CGNV4 )

    Previously with the same enviroment and hardware , The dark night worked fine with the Asus stock firmware when connecting to the ISP modem , with the 'ethernet' WAN port setting - without further setting . The Modem is technically a router with all of the router settings disabled , this is known as 'Modem Only Mode' . The modem uses port 1 and connects to the WAN port of the Dark Knight ( RT-N66U)

    Below is the Wan Options Of the Tomato Knight :p , can someone advise/guide me on what this should be :

    DHCP ( Tried )
    PPOE ( Tried)
    Static (Tried)
    3G Modem

    I tied static , then specifying the route modem IP ( which did not work - However I noticed what appeared to be public IP appeared somewhere on this page ( sorry it was very late )

    Can anyone help?
  2. eibgrad

    eibgrad Network Guru Member

  3. 90Ninety

    90Ninety New Member Member

    It turns out the tomato Knight can access the internet. The problem is that the tomato Knight DHCP isn't leasing IP addresses. If I manually set the LAN client IP, Gateway and DNS , then the client gets to the internet. The DHCP is enabled with the default scope - just not working
  4. 90Ninety

    90Ninety New Member Member

    Anyone know why the LAN clients are not receiving an IP ? Did I miss a step ?
  5. mvsgeek

    mvsgeek LI Guru Member

    Make sure that Mode is set to "Gateway" and not "Router". Don't know about Shibby's GUI, but in Toastman it's in Advanced --> Routing --> Miscellaneous.
  6. 90Ninety

    90Ninety New Member Member

    This was resolved by doing a factory reset , through the interface . The Physical reset weren't enough, or this WPS switch did not initially reset the DVRAM - after the initial Tomato flashing, or I weren't doing it properly?
    The DHCP is now working both from the WAN and on the LAN . However I discovered another issue with the DHCP WAN , as per the link below , I cannot port forward with the WAN on DHCP . I will open another thread , as this is now solved .
  7. koitsu

    koitsu Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice