Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. lsiguy10

    lsiguy10 LI Guru Member


    I just bought a refurb Linksys WRT160N v3.

    I tried to load tomato-K26-1.27.9045MIPSR2-beta10.01-Std.trx from the Linksys GUI, but it says wrong format.

    How were you able to load it? Do I just rename it to .bin at the end of the file name then load it?

    I just don't want to brick it on the first day of getting it.

    Your help would be greatly appreciated.
  2. Count0

    Count0 Addicted to LI Member

    Wow.... I feel stupid... I had a brainfart and thought I was doing -Z... Sorry.
  3. humba

    humba Network Guru Member

    My feedback from the WNR3500L:

    WDS LED is now off :)
    Power LED is now green once the device has booted :)

    WAN LED remains orange when the device has booted :(
    WLAN LED is now permamently off :(

    One thought.. I did not clear NVRAM - could it be that since I made the NVRAM changes you suggested for the WLAN LED on beta7 that this NVRAM setting which still lingers around interferes with your fix?
  4. teddy_bear

    teddy_bear Network Guru Member

    In beta10? Yes, that's what others reported as well. A few posts above is the patch for beta10 sources to correct this. If anyone tries it and confirms that it works, I'll apply it for the next build.
  5. though

    though Network Guru Member


    do you use the same wireless driver in your releases (beta02, 07, 10) as the 'standard' tomato 1.27-ND release? i have been using the -ND 'standard' release and maybe that is why my AP wireless keeps cutting out. so, should i try the 'standard' non-ND or give your K26-1.27.9045MIPSR1-beta10-Std release a shot?????
  6. humba

    humba Network Guru Member

    And upgrading my RT-16N resulted in a bricked router. I'm running the restoration utility now.
  7. pharma

    pharma Network Guru Member

    You should read the step-by-step guide link on the first post by soldier and cariyawa. It will help explain the process and what to expect.

    First you need to load the DD-WRT mini for the WRT160Nv3 (dd-wrt.v24-13309_NEWD-2_K2.6_mini_wrt160nv3). Then you should be able to directly load the Tomato beta (tomato-K26-1.27.9045MIPSR2-beta10.01-Std). Rename it to .bin as DD-WRT is looking for bin extensions.

    It's very hard bricking this router ... very resilent!

    You might also want to download WRT160N_3_0_02_004.code.bin from Linksys.
  8. murphm4n

    murphm4n Network Guru Member

    did anyone try beta 10 on the new linksys e1000 yet????

    isn't it supposed to be 160n in a new dress?
  9. Toastman

    Toastman Super Moderator Staff Member Member

    Haha, like your description...

    The new series isn't available here yet, so haven't seen one, but there have been many posts in reviews that say they are exactly the same motherboards. It would be nice if anyone who also has one of the newer models, if they could confirm this? I'm also very suspicious of many reviews that say only one L model comes with Linux, not sure I believe this.
  10. pharma

    pharma Network Guru Member

  11. murphm4n

    murphm4n Network Guru Member

    pharma.. looks like that's a yes.. anyone brave enough to flash one?
  12. pharma

    pharma Network Guru Member

    I don't think "brave" comes into play --- since it's primarily the same chipset there shouldn't be any problem -- similar to my case. You should work with the developers and expect to help troubleshoot.
  13. Rasky

    Rasky Addicted to LI Member

    Just upgraded to beta10 (RT-N16). Everything seems smooth, but boot time went through the roof. Wifi SSID was available after about 15 seconds from reboot; not it takes almost one minute.
  14. iroot

    iroot Addicted to LI Member

    Beta10 (RT-N16). PPPoE connection under a typical load dies in ≈10 min, then reconnects. Without any load PPPoE stays connected.
  15. gingernut

    gingernut LI Guru Member

    On beta 10 my PPPoE connection is fine. 2 days uptime and counting without problems.

    Thanks Teddy Bear.
  16. gearmato

    gearmato Networkin' Nut Member

    This patch works. Now Wireless LED is on from bootup and starts to blink when wireless connection is used.
  17. azuwis

    azuwis Guest

    Hi, teddy_bear, thanks for the usb mod, it rocks.

    Recently upgraded my Asus wl-520gc(cfe wl-520gu, ram 64m, flash 8m, 1 usb port added) from tomato-NDUSB-1.27.8744-vpn3.6 to tomato-K26USB-1.27.9045MIPSR1-beta10-vpn3.6. Everything works except there is I/O error on the external usb disk from time to time.

    This is how I connect the usb hard disk:
    |router|------|usb hub with power supply|------|2.5 inch hard disk in usb enclosure without external power supplay|
    Before upgrading, the router worked quite well. Rtorrent, amule and vsftpd were often used, I/O error only happened twice in one month.

    After upgrading, I/O error happened twice in 2 days. Both happened when hard disk was under heavy usage, one was when using vsftpd, the other was amule.

    dmesg gave something like:
    scsi 0:0:0:0: rejecting I/O to dead device
    EXT3-fs error (device sda2): ext3_find_entry: reading directory #2 offset 0
    scsi 0:0:0:0: rejecting I/O to dead device
    EXT3-fs error (device sda2): ext3_find_entry: reading directory #63517 offset 0
    scsi 0:0:0:0: rejecting I/O to dead device
    kernel modules:
    root@router:/tmp/home/root# lsmod
    Module                  Size  Used by    Tainted: P  
    ehci_hcd               38832  0 
    ext2                   70816  0 
    ext3                  141408  2 
    jbd                    71904  1 ext3
    mbcache                 7408  2 ext2,ext3
    usb_storage            51424  3 
    sd_mod                 27440  4 
    scsi_wait_scan           960  0 
    scsi_mod              108256  3 usb_storage,sd_mod,scsi_wait_scan
    usbcore               145360  3 ehci_hcd,usb_storage
    tomato_ct               2304  0 
    wl                   2051584  0 
    igs                    17936  1 wl
    emf                    22656  2 wl,igs
    et                     59296  0 
    How can I do some test and determine where the problem is? Or should I just use K24 for now? Thanks in advanced.
  18. lsiguy10

    lsiguy10 LI Guru Member


    I followed your advice and it worked!

    Now I'm using the WRT160N v3 (tomato-K26-1.27.9045MIPSR2-beta10.01-Std) as my main router. My RT-N12 will be my backup router in case something goes wrong with the WRT160N.
  19. lsiguy10

    lsiguy10 LI Guru Member

    Yes, the E1000 is the same as the WRT160N v3.

    Tomato support will come soon for sure.

    First, we have to wait for DD-WRT to support the E1000, since DD-WRT is used to flash to Tomato (at least for the WRT160N, but should be the same for both).

    Someone already got DD-WRT working on the E2000 (same as the WRT320N). He used hex edit to change the DD-WRT firmware header to match the Linksys E2000 stock firmware.

    Someone else is trying to get DD-WRT working on the high-end E3000 (same as the WRT610N v2) using the same hex edit method.
  20. pharma

    pharma Network Guru Member

    Glad it worked out for you! My WRT160N has been rock solid, and a few days ago overclocked it to 400, 200 without issue.

  21. prince

    prince Addicted to LI Member

    i have one noobie question
    how these 2 are different ?
    and which one should i install on my rt-n16 ....??


  22. pharma

    pharma Network Guru Member

    If you read the first post in the thread below the differences will be explained.
  23. HKPolice

    HKPolice Network Guru Member

    I just got an Asus RT-N16 and the first thing I did was yank off the cover. I was shocked at how LOOSE the heatsink was. A simple twist yanked it off to reveal cheap double sided tape underneath and ONLY TWO EDGES were making physical contact with the chip. ABOUT 90% OF THE CHIP SURFACE HAD NO PHYSICAL CONTACT WITH THE DOUBLE SIDED THERMAL TAPE.

    This is a brand new sealed in box router, not refurb.

    NO WONDER Asus had to downclock the CPU to 480Mhz. I'm sure with a proper heatsink + maybe fan and a solid 12v adapter (rewired from a good PC PSU is my plan) 533Mhz will be stable.
  24. prince

    prince Addicted to LI Member

    im very upset with this router......
    it connects me sometime and sometime it doesn't
    sometimes it shows internet acces then i cant access my isp webpage to login
    and sometimes it show no internet access.....
    but when i connect my isp lan wire to my pc without this router it works


    any one have any idea wat im facing ......
  25. maurer

    maurer Network Guru Member

    i'm guessing: incorrect configuration
  26. HKPolice

    HKPolice Network Guru Member

    I've been downloading off the internet through the router @ 532Mhz for the last ~40minutes at max speed of around 1.1MB/s (maxing out my connection) without any errors or lock ups.

    But I've made a SERIOUS bottleneck observation:

    The router seems to be limited to around 7.5MB/s combined throughput.

    Example: If I'm downloading files off the Router's NAS share, I'll get around 7.3-7.5MB/s. But if I'm downloading files from the internet AND the NAS share at the same time, the COMBINED throughput is STILL 7.3-7.5MB/s, with about 1.1MB/s from the internet and the NAS transfer slowing down to about 6.3MB/s.

    If I pause the internet download, the NAS transfer speed instantly goes back to 7.3-7.5MB/s with NO gap (I'm using NetMeter to graph real time transfer rates).

    Can anyone else please confirm this?? I know my PC setup is fine because I can copy files from another PC at 125MB/s (gigabit with 9k jumbo frames).
  27. Catalin

    Catalin Addicted to LI Member

    On a 100Mbps internet connection I have +9MB/s throughput both ways at the same time.
  28. HKPolice

    HKPolice Network Guru Member

    Can you try downloading off the net + a NAS share at the same time? Technically you should be able to get +15MB/s combined?
  29. humba

    humba Network Guru Member

    Since data transfer from USB storage is speed-limited by the CPU, combined use of both USB storage and Internet means one of the two components will be starved for CPU cycles.
    As a router alone, throughput can go higher (according to the tests at, the max WAN to LAN throughput is 141mbit/s), and you can slow it down again by running CPU intensive tasks (like QoS, NAS functionality, etc.)

    And if you really care about high NAS throughput, here's something to ponder: 176 MB/s. Forget about routers.. they aren't meant to be used as serious NAS - if you want a combined box that is still small and runs quiet, look at a fanless dual core atm box and run Linux on it - seeing as an atom powered NAS can get such a high throughput, there should be a few CPU cycles left to do some routing, too. Oh, and did I mention that serious NAS boxes have more horespower to run your downloads, too?

    Personally, I find that unless you're the box just as a print server (but even that.. nowadays the price difference for a networking printer is negligible and when you get network scanning and faxing, too, why go for a limited edition?) and to store some additional software you want to run on your router (that have something to do with the primary functionality of the device.. which is routing after all), you had better cough up the dough for a device that is meant as a NAS. I know about AXP, but there's a reason why even enterprise routers that pack a lot of hoursepowers just do routing and other boxes do network storage.
  30. HKPolice

    HKPolice Network Guru Member

    Just tried clocking it back to stock 480Mhz and NAS transfers topped out at 6.7MB/s vs 7.4MB/s average @ 532Mhz. Also tried downloading while NAS was transferring and experienced the same bottleneck (NAS transfer slowed down to around 5.6MB/s + 1.1MB/s from internet transfer).

    So this isn't a stability issue from overclocking to 532Mhz.

    I'm not planning on using the router as a NAS in the long run, I was just using NAS transfers to stress the CPU to see if my 532Mhz overclock was stable. This bottleneck does annoy me though because NAT file transfers obviously take less CPU time than NAS transfers, so wouldn't running both simultaneously be able to push max throughput past the 7.4MB/s NAS limit?

    I've read the smallnetworkbuilder review but that was on the stock Firmware, I remember reading some posts on this thread where people were complaining about lower throughput with Kernel 2.6 vs 2.4. I wonder if this issue is related?
  31. rhester72

    rhester72 Network Guru Member

    K26 _does_ lower throughput, without a doubt. The RT-N16 can't run 2.4. Hence, I concur with the above suggestion that NAS doesn't belong on a soho router.

  32. marian3k

    marian3k LI Guru Member

    Have anyone tried loading this Tomato on to Linksys WRT350N version 1.0?
    If yes which one? Is Broadcom 4785 release 1 or release 2 CPU? On wikipedia it says 4785 r2 - does it stand for relese 2?
    I know it is many questions but I'd love to give it a go and load this firmware.

  33. humba

    humba Network Guru Member

    @marian3k: your best bet would be to search for the router name in this forums. If you search on this thread only, you get two results - your post, and this - which is a failure mention.
    Since small changes are usually necessary to fully support a new model, I'd just keep watching this thread - or if you feel adventurous (or better: have the means to restore your router if somebody goes wrong), just try it - I'm sure teddy_bear would appreciate feedback.
    And r2 usually stands for a second revision/release/whatever.
  34. humba

    humba Network Guru Member

    I think you missed part of my explanation - when you run the NAS full throttle, the CPU is maxed out - so if you run something else, it's up the task scheduler in the kernel to decide which process gets priority.. since you can't really influence that (I didn't find the nice command and I'm not sure how to change process priority), you get whatever distribution the kernel decides on and both the NAS and routing process get whatever CPU cycles they get - and that sets the speed you get from WAN <-> LAN and NAS <-> LAN transfer.
    Of course, if you had the option to decide how many CPU cycles each process gets, you could take some cycles from the NAS process and give it to the routing process to effectively increase the average throughput - but that's purely theoretical.

    And as the tests by smallnetbuilder and Catalin prove, the router's total throughput can be higher.. you just need to give the routing process all the CPU cycles it needs to attain that speed.
  35. Slimey

    Slimey Network Guru Member

    This is a MIPSR1 cpu. Also see Im sure it would work if someone could see exactly what was happening via serial.
  36. paulvb

    paulvb Addicted to LI Member

    Before I get myself in trouble. What's the recommended way to install on a WRT160Nv3 currently running Linskys FW? I see instructions for some other supported routers, but I did not notice anything about this model.

    TIA, Paul
  37. pharma

    pharma Network Guru Member

  38. WilsonB

    WilsonB Addicted to LI Member

    Pair of RT-N16s working very nicely with the beta10 firmware.
  39. mau108

    mau108 Addicted to LI Member

    Sorry if this question has been answered elsewhere but I could not find anything. I plugged in a usb stick, the drive mounted successfully but how do I access it via my Win 7 and XP rigs?
  40. pandora

    pandora Addicted to LI Member

    Teddy Bear,

    Today I was able to flash the MIPS 1 version of your 2.6 firmware onto an old Linksys WRTSL54GS router. There seems to be a problem with USB 1 support on that router (enabling it and attaching a USB 1 device to it hung the router). However USB 2 seems to work fine. Other than the USB issue, the rest seemed to work fine.

    I installed the USB Extras version of your firmware (with no VPN support).
  41. cariyawa

    cariyawa Addicted to LI Member

    You can use ftp/ssh or configure samba. If it is not permanently connected, I think , it is easy to use FTP or SSH rather than samba.
  42. wxl23

    wxl23 Networkin' Nut Member

    linksys wrt160nv3 + tomato-K26-1.27.9045MIPSR2-beta10-vpn3.6.rar = good?

    i'm happy to see this, but i'm wondering if i can, similarly, use the vpn version. file size seems like it's borderline too big. anyone with experience?
  43. marian3k

    marian3k LI Guru Member


    Thanks for the answer. I've seen your post few pages back in the thread but wondered maybe something is now changed/fixed. I haven't got a serial or jtag so I'll rather wait for someone to tell me it works ;)


    P.S. Where did you get modded CFE from? Could you PM me? Ta.
  44. Guzel

    Guzel Network Guru Member

    hi m8s
    I have wnr3500l whit tomato beta10, I have 100/100 mbits internet c. Whit the Netgear fw I get 266/168 Mbits and whit tomato beta10 l get 89/68 Mbits, l think tomato beta10 dosent support gigabit in WAN. Can you place add support for that in the next beta.
  45. humba

    humba Network Guru Member

    @Guzel: can you check the CPU usage when you make those measurements?
  46. Guzel

    Guzel Network Guru Member

    Cpu is att 3% m8
  47. bogderpirat

    bogderpirat Network Guru Member

    what does `top`s "sirq" say? mine is usually pretty high when i max the connection.
  48. Guzel

    Guzel Network Guru Member

    `top`cpu 6,1% its no problem whit the cpu , The problem is that WAN port an tomato beta10 dosent support gigabit, I have tryd allso ddwrt it dosent support gigabit to.
  49. Hitmrrr

    Hitmrrr Networkin' Nut Member

    how to install on this firmware (tomato-K26USB-1.27.9045MIPSR2-beta10-Ext) rtorrent?
  50. mstombs

    mstombs Network Guru Member

    What speed is the device the port is connect to? When I had WAN port issues on an earlier rev I found the Tomato web gui had no effect on Wan port speed, the hardware was clearly in auto-detect and would connect to a PC at whatever speed the PC set to - up to and including gigabit.
  51. Guzel

    Guzel Network Guru Member

    In the Web gui, I have in Auto,
  52. cariyawa

    cariyawa Addicted to LI Member

  53. Hitmrrr

    Hitmrrr Networkin' Nut Member

  54. jovev007

    jovev007 Addicted to LI Member

    I use Tomato Firmware v1.27.9045 MIPSR1-beta10 K26 Std on WRT54GL and a notice that QOS for "Outbound Rate" works OK but QOS for "Inbound Limit" it's allways max value download for any class. I think it's a bug. Can some one check?
  55. TehBeck

    TehBeck Guest

    "invalid architecture -march=mips32"

    Any ideas why i get the error message "invalid architecture -march=mips32" when i'm trying to build FW image from the source code of this firmware from the git repository - "tomato-RT" branch? I'm really looking forward to build some custom FW images but i'm not sure how to proceed. Sorry for such a noob question. Thanks in advance guys!
  56. hk5354

    hk5354 Addicted to LI Member

    hope to support for the wrt610n v1
  57. cariyawa

    cariyawa Addicted to LI Member

    "sirq"s are software interrupt requests. This is often used by device drivers to do extended processing out side of the normal hardware interrupts. Very high network traffic creates large number of sirqs.
  58. bogderpirat

    bogderpirat Network Guru Member

    ... which is why i was asking him if his were high. those don't get counted into userspace cpu load, thus in a networking appliance such as a router, the load value is a bit deceiving as the box might actually be under a lot of load.
  59. andy

    andy Addicted to LI Member


    Two questions regarding the kernel 2.6 build :
    1. Is the performance of 2.6 better than 2.4 ?
    2. Can I use the same optware that I am using so far for 2.4. If not, which one I can used.

  60. Rasky

    Rasky Addicted to LI Member

    Teddy_bear, I'm getting these kernel crashes while using the router with beta10:

    After these crashes, usually r/w access to my USB disk dies (lots of I/O errors in the logs), though the USB pendrive still works. After reboot, the configuration I lost the whole router configuration and had to restore it from backup (I am not sure if this is related or another bug).

    I've got a RT-N16, and I have some swap space mounted in a partition of the USB pendrive (though I set swapiness to 0 at startup, to reduce swap usage only when absolutely necessary).

    Any idea?

    EDIT: this seems the bug: The patch does not apply cleanly to your beta10 tree, though the code it tries to fix is there, and looks as buggy.
  61. teddy_bear

    teddy_bear Network Guru Member

    What is that device? Does it work with only USB 2.0 enabled? Do you have another USB-enabled router capable to run K26 builds, and if so - have you tried the same USB 1.1 device on the other router? Do other devices work with only USB 1.1 enabled?
    If you have a serial console, the console crash dump can help to troubleshoot the problem. Otherwise it's hard to say what's going on...
    1. No.
    2. Yes.
    Of course the patch doesn't apply cleanly since it's already there in beta10 ;). If that code still "looks as buggy" to you, please do not hesitate to point out what exactly seems to be buggy - tbh I don't see anything clearly wrong there...
    Despite of this patch, I too can easily reproduce page allocation errors with beta10 - but only in one case - when I max out the connection when running torrent client on the router. Since you're running amule as well, check out this post for some suggestions on how to deal with it. Increasing min_free_kbytes to 8MB solved the problem for me - although I can still see occasional (and rare) page allocation errors in the log, they do not cause any harm anymore. If you search' bugzilla, you will find a bunch of still unresolved issues resulting in page allocation errors. Possibly some of these errors are specific for SLUB allocator - I'm going to test it again with SLAB to see if it changes anything. I'd like to stay with SLUB though, as switching to it fixed some of the wireless disconnect problems in early betas, and SLUB in general seems to be more appropriate for this platform.
    BTW, I don't use any additional swap when running transmission on N16 - it seems that 128MB is quite enough...
  62. vinuneuro

    vinuneuro Networkin' Nut Member

    Is anyone using this on the RT-N12? I tried searching the thread, but there's no mention of this router despite being listed on the first page. Would appreciate any feedback on how stable the latest build is on this model. I've generally been reading the wireless can drop-out when using it in router mode with the stock firmware and dd-wrt so am wondering if there are h/w issues in which case I'll avoid it.
  63. jnappert

    jnappert LI Guru Member

    @teddy_bear: Is there a place in git where i can dowload the latest revision with the newer broadcom driver before your reverted it? To get WPA/WPA2 (AES) up and running is at the moment more important to me as the recent changes...
  64. pharma

    pharma Network Guru Member


    Have you tried just WPA2 Personal and AES? It's working well here on the latest beta.

  65. lsiguy10

    lsiguy10 LI Guru Member

    You must have missed my posts in this thread mentioning that I use the RT-N12. It works great! I was having some wireless drops when using channel 1, but when I switched to channel 6 there were no drops at all.

    I'm using the WRT160N v3 now. I still have the RT-N12 as my backup router.

    I think teddy_bear also has an RT-N12.
  66. teddy_bear

    teddy_bear Network Guru Member

    Here's the last commit before reverting the driver: Click on the "tree" link at the top, and then on the "snapshot" to get the code.
    Are you sure it was the driver that fixed the WPA/WPA2 combined security issue? I tried it with the new driver as well, and was unable to get WPA/WPA2 to work with WDS - while WPA2 or WPA - both worked fine. Also, please note that even Asus reverted the driver in their latest firmware release - it does have more new issues than it resolves.
    I'm using it in Wireless Ethernet Bridge mode, and it's very stable. As for the router mode - I don't know. As lsiguy10 said, it could be a wireless channel that makes a big difference.
  67. jnappert

    jnappert LI Guru Member

    Yes. But only WPA/AES establishes any connection to my routers running WPA/WPA2-AES in WDS-mode. BTW, they are running vanilla tomato 1.27 as they are WRT54GLs1.1. Could it be that in this mode, the WDS-Links are running WPA and the mixed mode WPA/WPA2 is used for clients that connect to this devices?
  68. vinuneuro

    vinuneuro Networkin' Nut Member

    Sorry about that, with 128 pages I just used the search function to search the thread for 'RT-N12', but nothing comes up. Might manually check them all now. :)

    Any issues at all with multiple devices connected at the same time (ethernet and wifi)? That's another one I read. I usually have 5-6 connected at once.

    Btw lsiguy10, why are you switching to the WRT160N with it being the same chipset as the RT-N12.

    Thanks for the help.
  69. though

    though Network Guru Member


    i use (2) N12's in client bridge mode at 2 different places. it's rock solid.

    never used it as a router, so can't comment on that...

  70. lsiguy10

    lsiguy10 LI Guru Member

    I didn't have any issues when using the RT-N12 with multiple devices.

    This is what I had connected:

    main desktop (wired)
    secondary desktop (wireless)
    laptop (wireless)
    Wii (wireless)
    PlayStation 3 (wireless)

    Yes, the WRT160N v3 and RT-N12 use the same chipset. I just like the sleek look of the WRT160N better, it's just a personal preference. Also, I got a good deal on the refurb WRT160N. I could use either router and it would be rock solid for me.
  71. dswann

    dswann Networkin' Nut Member

    What is the filename for the non-USB builds now? :confused:

    (I have the Asus RT-N12)
  72. though

    though Network Guru Member

  73. dswann

    dswann Networkin' Nut Member

  74. vinuneuro

    vinuneuro Networkin' Nut Member

    teddy_bear, is TCP Vegas implemented like in other versions of Tomato?
  75. though

    though Network Guru Member

    yes it is.
  76. vinuneuro

    vinuneuro Networkin' Nut Member

    Thanks. Tomato's QoS is the main reason I'm switching routers despite my Buffalo router being a bit more powerful than the RT-N12. With even 1000-1200 ip (from p2p) connections, my wrt54g (216mhz) would go to 100% cpu load and start choking; this Buffalo whr-hp-g300n (Atheros 400mhz) doesn't go past 10%. How well does the RT-N12 handle many simultaneous connections?

  77. mau108

    mau108 Addicted to LI Member

    Hey Guys,

    I find the wifi slow. I originally had the following setting for Wifi

    Channel: 4
    Width: 40mhz
    Security: WPA/WPA2 Persona
    Encryption: TKIP

    Transfer speeds were about 800kb/s (file transfer from my server!)
    Changed Encryption from TKIP to AES and transfer speeds average about 5mb/s

    This is with the laptop 3 feet away from the router.

    What is the best setting? Consider also my notebook has the latest wifi drivers (5100 card) but I also have an ipod that connects.

    This is no where near N speeds, kind of a disappointment.
  78. cariyawa

    cariyawa Addicted to LI Member

    I think some Intel cards has this issue. My one(4965AGN) never go more than 144MBps. RT-N16 is not dual band while these cards needs to have a dual band router to get the full throttle.
  79. mau108

    mau108 Addicted to LI Member

    In adapter status it says im connected at 300Mbps.
  80. cariyawa

    cariyawa Addicted to LI Member

    I am using Linux...I need to find a way to get the corresponding value in Linux.

    In beta 10, first page displays rate. Does it shows 300 MBps, when you connect that card only to the router?
  81. mau108

    mau108 Addicted to LI Member

    im running beta07. Is that option only available in Beta10?
  82. cariyawa

    cariyawa Addicted to LI Member

  83. mau108

    mau108 Addicted to LI Member

    well I guess I'm updating tonight.

    Be back in 5
  84. mau108

    mau108 Addicted to LI Member

    well after the flash and reconfigure it's transferring at between 7-8mb/s to the same machine.

    Same setup

    But that number on the first page fluctuates, seems to idle at 243 lol but it goes up and down.
  85. though

    though Network Guru Member

    i may be wrong but i think that's about right for a transfer rate.....

  86. mau108

    mau108 Addicted to LI Member

    meh it's going down but I think it may be my desktop machines wireless mouse sitting next to my laptop?
  87. cariyawa

    cariyawa Addicted to LI Member

    Yes.. I also think it is about right
  88. Bad Wi-Fi signal quality WNR 3500L w/ b10 and IPhone 2g

    Although Notebooks work fine (with excellent signal quality) in every room my IPhone 2G losses connection due to bad signal quality. Max. distance to router is about 7 meters.

    I run Wi-fi in G-Only mode, transmit power is 42mW, MAC-Adress filter disabled, WPA2 personal with AES encryption, Channel 13. All other settings on Wireless advanced left default.

    I resetted the IPhone's network settings, checked for other WLan's with inSSIDer (btw signal strength at about 40db), played with different channel settings and so on but still got no clue.

    So, is this WNR3500L crap or am I running it on false settings? :confused:
  89. pharma

    pharma Network Guru Member

    Interesting! I get pretty good coverage with my 3G iphone -- router is centrally located upstairs and can get good signal on iphone downstairs or in garden outside. My channel is on Auto (usually channel 1 or 6), G- only, trans power 55, WPA2 personal/AES .... Advanced Wireless chgs. - Distance/ACL Timing 200, DTIM Interval 2, Fragmentation Threshold 2306, RTS Threshold 2306, CTS Protection mode AUTO.

    Usually if you keep tinkering with settings after checking Google, you end up with pretty good connectivity. It just takes awhile ...
  90. AeN0

    AeN0 Network Guru Member

    Hi everyone,

    I'm looking for some answer for very specifics needs.

    My current ISP provides an IPv6 native connection along with the IPv4 one. In the past, I have successfully compiled Tomato (kernel 2.4) with IPv6 support and achieved to get IPv6 and IPv4 NAT working together (with a ipv6 bridge) but it was buggy (losing connection randomly). I assumed that the 2.4 kernel wasn't ready for this ...

    Today, I saw this Tomato kernel 2.6 and I thought that I could do the same thing again hoping that it will work better with the 2.6 kernel.

    Basically, I need the following : IPv6 enabled kernel, ebtables and brouting filter activated.

    Now the questions :

    - I'm currently retrieving the source from the git repo. Could I just enable IPv6 (and its dependencies), activate ebtables, compiling the mod and tada?
    - Does it work on wrt54gs v4? (I assume yes based on various posts on this same topic)
    - I'm not very skilled to do this type of thing so is IPv6 officially planned for this mod?
    - EDIT 2 : looks like there are references to ebtables in src/router/Makefile...
    - EDIT 2 : ipv6 kernel is maybe not needed, just ebtables module and its userspace tool.

    Thank you !

    EDIT : my previous attempt to this with 2.4 kernel :
  91. though

    though Network Guru Member

    try channel 1, 6, or 11 and report back if it's improved...

  92. teddy_bear

    teddy_bear Network Guru Member

    I'm planning to add IPv6 support, but there's no timeline yet as of when it's gonna happen. Definitely not sooner than in a few months... Turning on the IPv6 support in the kernel, busybox, dnsmasq etc is only a small percentage of what needs to be done - the bigger part is the proper firewall configuration, ddns support, etc with appropriate GUI settings.

    If you can live with just IPv6 enabled kernel, ebtables and brouting filter, just go ahead and recompile the firmware with these options turned on. If you do that, please share your experience and configuration - it would be very helpful for implementing the "official" IPv6 support.
  93. AeN0

    AeN0 Network Guru Member

    Well, initially, I was not thinking about the GUI part but now you mention it, it's going to need a lot of work indeed.

    I'm compiling right now the firmware with ebtables. I just hope that it will not brick my router :chuckle:.
  94. lsiguy10

    lsiguy10 LI Guru Member

    I don't use P2P much. When I do, I limit my uTorrent to 40-80 connections so I don't bog down whichever router I'm using.

    I assume the RT-N12 would perform similar to the Buffalo router, even with the mhz disadvantage.
  95. ghostzip

    ghostzip Networkin' Nut Member

    I can confirm this problem. I received a new WNR-3500L and wanted to test the maximum throughput that it can offer, to see if it can handle my new 100mbps connection (i don't have it yet). So I started making offline tests with my laptop, static ips and iperf ( ). I tested both computers with the gigabit switch and they give 930Mb/s (all values in the post that have Mb are in Mbits) so they can handle the 100Mb/s test case.

    After getting the router I flashed tomato-K26USB-1.27.9045MIPSR2-beta10-Ext , reseted to defaults, defined static ips and started the tests.
    With QoS DISABLED I get around 68Mb/s. With QoS enabled I get around 56Mb/s. I set 100.000 in both output and input settings in QoS btw. The "sirq" value of top said something like 92% (the ssh / http connection lags a lot with this kind of throughput, the cpu seems not to handle it).

    I then tried to flash the latest DD-WRT firmware to see if the router could handle this 100mb or not. After re-flashing the firmware I tried iperf and it gave me 109Mb/s. It then gave me consistent results around 107Mb/s ~ 110Mb/s. The "sirq" value was around 96% but the ssh connection lags (but not as quite as tomato's). I also noticed the internet light was green instead of orange.

    I then re-flashed tomato to see if I had any new outcome. The results were the same. Tried to fiddle with the settings, NO usb drivers, NO qos, NO igmp proxy, NO samba mounts, NO jffs, disabled inbound layer 7, no access restrictions, NO upnp, only wireless and port forward and it gives me the same results.
    But when I disabled the RTSP tracker the speed went to 82Mb/66Mb (Down/up) (as expected, this layer 7 stuff need the cpu to process the connections/packets), but still not as fast as DD-WRT.

    I'm going to configure this router to replace my old wrt54gs (running tomato original 1.27) and stay with tomato beta10, and see where the new betas takes us.

    (on a side note, DD-WRT uses 2.6.24 .111 kernel, BCM47XX 10/100/1000 Mbps Ethernet Controller , while beta10 uses the
  96. teddy_bear

    teddy_bear Network Guru Member

    Thanks for making these very interesting tests and posting the results. Could you please also tell us your WAN connection type - DHCP/PPPoE/etc?
  97. Guzel

    Guzel Network Guru Member

    I am yousing DHCP an WAN Teddy_bear
  98. ghostzip

    ghostzip Networkin' Nut Member

    It's not a connection yet. It's just my macbook connected to the wan port. So it has a 1000mbps network port, and can do 930mbps throughput rate, so it should be "maximum enough" for the router. Also I set static ip (used but it's not relevant anyway, because I didn't test "the internet").
    I also tested the "jumbo" frames, didn't do anything. I also set the WAN port to 100mb full duplex and same result.

    On a side note, not related to the Tomato issue,my uncle wen't by my house, and brought his WRT310N. He only has DD-WRT and the maximum rate was I could get was 75Mb/s (versus the 109Mb/s of the 3500L). Also the QoS in DD-WRT put down the throughput to 46.3Mb (vs the 56Mb on the 3500L). The WRT310 only has 330Mhz (or something like that) vs the ~416Mhz of the 3500L.
  99. vinuneuro

    vinuneuro Networkin' Nut Member

    Does cpu speed typically affect QoS performance even if it's not at 100% load?
  100. AeN0

    AeN0 Network Guru Member

    I'm back with some infos :

    - My first attempt to tweak and compile the firmware with ebtables was a success! I have managed to enable ebtables (kernel) and compiled ebtables userspace tool. Flashed right away to my router and after a 30/30/30 reset, it was working! Entered some commands to get ipv6 and ipv4 nat working and tada!
    - From my first attempt, I forgot to include in the firmware the file /etc/ethertypes, I fixed that and recompiled the firmware BUT for unknown reason, after flashing, it bricked my router :(. A 30/30/30 did nothing and I have to go through the short pin method (15&16).

    Now, I bored of this stuff... I will retry next weekend.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice