Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. humba

    humba Network Guru Member

    It works just fine on both WAN and LAN ports according to my uplink switch and my cable modem (which both say the link runs at 1000mbit whereas with the WRT54GL they report 100mbit).
  2. teddy_bear

    teddy_bear Network Guru Member

    You need to install Optware sane-backend package, and Windows sane client (there are several) on your Windows machine.
    Search the other USB Mod thread for "saned".
  3. Guzel

    Guzel Network Guru Member

    Hi m8
    Whit netgear fw l get 266/168mbps WAN-LAN and whit
    tomato l get 86/69 mbps WAN-LAN, I have Gigabit internet
  4. groosh

    groosh Addicted to LI Member

    applied the settings to the init script and the TLS Renegotiation Time accepts -1 as a valid entry.

    the vpn server appears to be running fine.
  5. cariyawa

    cariyawa Addicted to LI Member

    Yep.. it works great... thanks LOT TB. :clap2:
  6. groosh

    groosh Addicted to LI Member

    not sure if the wireless is fully working or not but I believe that the wired connections are working fine.

    Dec 31 16:00:08 netgear init[1]: Tomato 1.27.9045 MIPSR2-beta11 K26 USB vpn3.6
    Dec 31 16:00:08 netgear init[1]: Netgear WNR3500L/U/v2

    my PC is connected over the wire at 1Gbps
    my laptop is connected at 144/104

    did not really run on the netgear firmware... only long enough to boot up and flash dd-wrt so I could flash in tomato.

    I am not sure if I should be hitting the ~300 mark or not but I do know that the gig wired connection on my PC works perfect. Regardless the 144/104 speed is faster then the 54/48 speed I would normally get when connecting my laptop to my wrt54gl so I am happy.
  7. habskilla

    habskilla Network Guru Member

    Is there a install doc to install this on a WRT160n V3? Or is it download the file and use the web UI to update?
  8. Isildur

    Isildur Addicted to LI Member

    Guzel, tomato work with WAN in 100mb mode, it support 1gb only for LAN ports, as I know.
  9. ladysman

    ladysman Network Guru Member

    My RTN16 is connected to a Motorola SB6120 DOCSIS 3.0 modem. The modem displays it's connected via GB to my RT-N16 (Blue LED instead of Green LED). So this statement is false.
  10. pharma

    pharma Network Guru Member

  11. gingernut

    gingernut LI Guru Member

    Here are two screen shots of Tomatos device list page on my Asus RT with a before the wireless transfer started and a 20 sec into the transfer.
    I was in the same room as the router but for some reason the RX link speed drops all the way down from 270 to 7 but the TX speed doesn't. This happens with the three wireless adapters that I've tested.

    Before transfer

    While transfering

    I don't understand why this happens with an rssi value of -10dBm and a link quality of 89.
  12. Toastman

    Toastman Super Moderator Staff Member Member

    I have never seen such a high signal strength here unless the client's radio antenna is right next to the router. And if it is right next to the router, one or both of the radio receivers will overload and the speed will drop.

    It seems in your circumstance something is very wrong.

    For example, I am measuring -40dBm and quality is 57 - with my router - and my USB card is at present only 1 metre away from the router antenna, near the floor.

    Yet yours is 30dB stronger at -10 dBm !!! It can't be this high ... see if you can do a few tests at different distances, maybe an NVRAM reset is needed, but something is nuts!
  13. Elbereth

    Elbereth Networkin' Nut Member

    Just flashed beta11 on my brand new Asus RT-N16, everything went smoothly (flashed using the TFTP method).

    I am using PPPoE to connect to WAN (Sagem F@st3464 VDSL2 20Mbps/2Mbps) and for the moment the transition from a Tomato ND v1.27 WRT54GL is smooth. :)

    I hope the Broadcom driver will get the jumbo frame update.

    Thanks Teddy Bear, nice work. :clap2:
  14. peter_m

    peter_m Addicted to LI Member

    Any chance to get MLPPPoE ?
  15. Maxwell

    Maxwell Addicted to LI Member

    I'm wondering about MLPPP as well. There is a fork of Tomato at that supports it but I have no idea if that work could be integrated into teddy bear's build.

    A bounty was raised in the DD-WRT forums for this feature and I believe it was eventually implemented.

    Is this only of interest to Canadian users and those bonding two lines together?
  16. gingernut

    gingernut LI Guru Member

    Thanks for your reply.

    These screen shots are from just before and while I was doing a few large wireless transfer tests for a friend to see if I could make the little Asus reboot or freeze using a laptop at about 2/3 meters from the router with a clear line of sight. This was also just after doing a full nvram erase for the test, no tweaks nothing, straight stock Tomato RT settings.
    The RX rate would be steady at around 2/7 and wouldn't go back up to around 270 untill the transfer had finished. I did try from a little further away just incase but didn't want to leave the same room as the router for testing purposes.
  17. eRd12

    eRd12 LI Guru Member

    Did somebody test r/w speed from/to usb on beta 11 and beta 10? I've heard some opinions that new beta is much much slower than beta 10. Can anybody confirm that ?
  18. dareino

    dareino Network Guru Member

    Moving a large .iso over from my external usb hdd, I am getting 3.5mb per sec...Uploading is a dismal 1.6mb. I am using the latest ver.
  19. kanstin

    kanstin Addicted to LI Member

    I just flashed the Std version of beta11 onto a Buffalo WHR-HP-G54. It works great so far! Nice work! I tried to flash the Lite and no-usb vpn but those were too big.
  20. mstombs

    mstombs Network Guru Member

    OK this is a different issue, on the Asus RT-N16 LAN and WAN connect at the hardware layer in Gigabit mode, but throughput still within 100Mbps range. This has been reported before, it appears that the performance of the new 480MHz hardware is not double that of a older 200MHz WRT54GL.

    But as the Netgear with similar chipset can do so much more on your line - exactly what firmware and where's the OpenSource code, is it still K24?

    We want that potential speed in Tomato as well!
  21. pandora

    pandora Addicted to LI Member

    Last night my ISP lost connection to the house. There was a fire nearby in some forest and their node seemed to get nailed. Fortunately our electricity still worked. Which is a bit unusual. My cell phone has a wireless access point app, and I enabled it. Devices like my laptop, iPad, and anydevice that had native wireless in it (HDTV) were able to access internet via the wireless access point. Speeds were about 1mb down and 800kb up, pings were awful (500 ms).

    I set my router up as an access point, and it did connect to my cell phone, and did use it to perform DNS lookup. However no data (other than DNS lookup) worked. I tried just about everything I could think of. Nothing worked.

    The phone is a Palm Pre and the app is the Palm (Verizon?) wireless hotspot. Celarly the router got an IP address from it, and provided DNS lookup, however for whatever reason no data was able to pass from my LAN.

    Does anyone know if there is a bug, or a secret to setting up this firmware as a wireless client? The routing tables looked correct. Should I have disabled DHCP? That is about the only thing I didn't do.
  22. teddy_bear

    teddy_bear Network Guru Member

    Have you tested it yourself? With my USB drives, performance stayed the same in beta11 - but of course YMMV...

    If you experience noticeably slower USB transfers in the last beta, try to run the following command in the telnet/ssh session:
    1. Remove USB 2 (ehci) module:
    rmmod ehci-hcd
    You may need to disconnect your USB devices to successfully remove the module.
    Verify that the module is unloaded by running lsmod.
    2. Reload USB 2 module with different value of log2_irq_thresh parameter value:
    insmod ehci-hcd log2_irq_thresh=0
    Verify the module is loaded by running lsmod. Verify that the parameter is set to the value you specified:
    cat /sys/module/ehci_hcd/parameters/log2_irq_thresh
    3. Reconnect your USB drives and retest the transfer speed.

    Does that improve the speed? If it does, try the same commands with different values of log2_irq_thresh parameter. In the above example it's set to 0. You can try values from 0 to 3 (4 is what it's set to by default in beta11, 0 is what it used to be in previous builds). The lower the value, the faster the transfers should be, but it's more likely to crash too during intensive usage (such as downloading to this drive via torrent).

    Let me know your results please.
  23. iloveramen

    iloveramen Networkin' Nut Member

    I have flashed my Buffalo WHR-HP-G54 successfully with the beta11 build. After I cleared my nvram after the flash, whenever I tried configuring the wireless in advance settings I get this error "The field "wl_nmode_protection" is invalid." I am not sure why.
  24. teddy_bear

    teddy_bear Network Guru Member

  25. iloveramen

    iloveramen Networkin' Nut Member

  26. KyleChen

    KyleChen Addicted to LI Member

    finally forum is back...

    is there a schedule for per ip qos come out?
    I am really tired for solving some ppl in our LAN (rt-n16), downloading with special p2p protocal occupying 1000+ connections per ip and huge WAN bandwidth.i wrote scripts to limit them per ip, but weird things happens following the script either. Still have lots to learn.

  27. though

    though Network Guru Member

    welcome back all!
  28. roflcopter

    roflcopter Networkin' Nut Member

    Access restriction and torrents


    I am using Tomato Firmware v1.27.9045 MIPSR2-beta11 K26 USB vpn3.6

    I used to think the access restriction rules I had to stop all bittorrent traffic from 12pm - 12 am worked, but I have done some tests and they seem to have no impact.

    I have deleted and reinstated the rules, even specified the ports used to restrict but to no avail.

    The logs show the rule(s) activate and deactivate at the right times.

    I have been testing with uTorrent and also a torrent client on my NAS, using ports 56881 and 46881 respectively.

    Anyone had success doing this? Can anyone else test this?
  29. mwsealey

    mwsealey Addicted to LI Member


    Any chance of the MLPPP patches for 1:1 NAT and multiple (static) IP addresses getting into TomatoUSB?

    I'm desperate to be able to give my Linksys all 12 of my useful IP addresses and then tell the NAT module, this port on this external IP forwards to this port on this internal IP. All we're missing on the current firmware is

    a) the ability to set more than one static IP address
    b) the ability to set the external IP address the original transfer came in on to be forwarded to the internal port

    The rest of MLPPP isn't really useful unless you want to bond 2 modems on the same ISP, or do some really tricky stuff otherwise.. but in my case I'm talking about a 10Mbit bonded T1 with a nice block of IPs.

    Is this really that hard to knock in?
  30. greenythebeast

    greenythebeast LI Guru Member

    Does anyone know what these errors signify:

    May 5 16:18:26 RT-00248C65E3A7 dnsmasq-dhcp[485]: DHCPREQUEST(br0) 00:1f:5b:cf:03:3a
    May 5 16:18:26 RT-00248C65E3A7 dnsmasq-dhcp[485]: DHCPNAK(br0) 00:1f:5b:cf:03:3a wrong network
    May 5 16:18:28 RT-00248C65E3A7 dnsmasq-dhcp[485]: DHCPREQUEST(br0) 00:1f:5b:cf:03:3a
    May 5 16:18:28 RT-00248C65E3A7 dnsmasq-dhcp[485]: DHCPACK(br0) 00:1f:5b:cf:03:3a MBPW

    Especially the second one where it says wrong network. My laptop was having trouble where it would drop a connection to the router then reconnect then drop, etc. I found that error when searching through the logs. A reboot fixed the problem but it would be nice to know what happened. Thanks.
  31. teddy_bear

    teddy_bear Network Guru Member

    You forgot to post the exact access restriction rules you're trying to use, what you expect them to do, why you think they are not working (i.e. how exactly you tested them), and the output of "iptables -L -n" while the rules are supposed to be active.

    If you can extract relevant changes from MLPPP project sources, and prepare working and tested patches against current Tomato USB source code, then it really won't be hard to knock in :).
    Alternatively, you may choose to wait until I (or someone else) will get to it...

    These are no "errors" - just a log of dhcp packets exchange between clients and dnsmasq. With only 4 lines from the log it's hard to be certain, but it looks like your client was trying to renew an IP, and these attempts were correctly denied by the router since it's not a valid address in your network. Why your client computer was doing this - well, you should know better ;).
  32. greenythebeast

    greenythebeast LI Guru Member

    I wasn't doing anything wrong! My iPod Touch was obviously not having a good day, but it's all fixed so no big deal.
  33. akawoz

    akawoz LI Guru Member

    USB Performance on RT-N16

    Hi team, I am currently running my Asus RT-N16 on DD-WRT build 14205. I'm getting pretty average USB performance of around 3.6MB/sec (formatted as ext3).

    Can anyone confirm if the USB performance under teddy bear's build for this router is any better?

    Seems like poor USB performance is pretty common on this router.

    Incase you are wondering - I went with DD-WRT for complete Optware support as I use this router to run transmission.
  34. roflcopter

    roflcopter Networkin' Nut Member

    I am trying to limit 1 computer on the network using Utorrent between 12pm - 12 am

    I have managed to control the BT client in my NAS, however unsure if Utorrent is able to get around the restrictions - I have disabled encryption preference in outbound. DHT is enabled.

    Iptables dump when active

    Chain INPUT (policy DROP)
    target prot opt source destination
    DROP all -- state INVALID
    ACCEPT all --
    ACCEPT all --
    ACCEPT 2 --

    Chain FORWARD (policy DROP)
    target prot opt source destination
    ACCEPT all --
    DROP all -- state INVALID
    TCPMSS tcp -- tcp flags:0x06/0x02 TCPMSS clamp to PMTU
    restrict all --
    L7in all --
    wanin all --
    wanout all --
    ACCEPT all --
    upnp all --

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain L7in (1 references)
    target prot opt source destination
    RETURN all -- LAYER7 l7proto bittorrent

    Chain restrict (1 references)
    target prot opt source destination
    rres00 all --

    Chain rres00 (1 references)
    target prot opt source destination
    DROP all -- ipp2p v0.8.2-pomng --bit
    DROP all -- ipp2p v0.8.2-pomng --ipp2p

    Chain rres01 (0 references)
    target prot opt source destination
    DROP tcp -- mport ports 56881 ipp2p v0.8.2-pomng --ipp2p
    DROP udp -- mport ports 56881 ipp2p v0.8.2-pomng --ipp2p
    DROP tcp -- mport ports 56881 LAYER7 l7proto bittorrent
    DROP udp -- mport ports 56881 LAYER7 l7proto bittorrent

    Chain upnp (1 references)
    target prot opt source destination
    ACCEPT tcp -- tcp dpt:46881
    ACCEPT udp -- udp dpt:46881
    ACCEPT udp -- udp dpt:35307
    ACCEPT tcp -- tcp dpt:35307
    ACCEPT udp -- udp dpt:3658

    Chain wanin (1 references)
    target prot opt source destination
    ACCEPT udp -- udp

    Chain wanout (1 references)
    target prot opt source destination
  35. Elbereth

    Elbereth Networkin' Nut Member

    I am using Tomato Firmware v1.27.9045 MIPSR2-beta11 K26 USB vpn3.6 on my Asus RT-N16 router for a little more than a week now and I noticed that the Wifi stops working after some time (it happened twice already, my router is up 24/7). I have to reboot the router for the netbook (that's the most often connected device, it is using 802.11g) to retrieve Wifi connectivity. Wired connection is still working when this happen and I can still access the web interface.

    I did not have this problem before with a WRT54GL and Tomato Firmware 1.27 (non modded), I sometimes had the router up for months without any problem with the wifi and that same netbook.

    Any idea what could be the problem?
  36. gingernut

    gingernut LI Guru Member

    Sounds like you've got your wireless channel selection on auto, which usually defaults to channel 1, or you've manually selected channel 1.
    I had loads of disconnects using this channel, for some reason, even if the wireless clients were idle. The solution seemed, for me at least, to manually select a higher channel. So if you can try using channel 6 or 11 and see how it goes.
  37. gingernut

    gingernut LI Guru Member

    I haven't done any real benchmarking but wireless transfers over ftp to a usb connected hard drive formatted as ext3 I get around 6MB/s, sometimes a little higher.
  38. Elbereth

    Elbereth Networkin' Nut Member

    I actually force using channel 6 because that's the less crowded channel in my place. That's the same settings I used when I still was using the WRT54GL.
  39. teddy_bear

    teddy_bear Network Guru Member

    Do not assume that the same settings you used with WRT54 will work as good on N16 - this is totally different radio, and new wireless driver, so you may need to find the best setup and re-tune it all over again.

    Remember that the interference can be caused by various devices - microwaves, phones, wireless mouses etc - not only by other routers. Try different channels. For example, I have horrible connection speed and unstable wireless on all channels from 6 and below, but have absolutely no issues on channels 7 to 11 - even though there seems to be more active APs around here running on channel 11.

    Playing with Advanced Wireless settings can also help sometimes, depending on your exact environment.

    You won't be able to completely disable torrents by L7 or IPP2P filters - at best you can only slow them down since these filters simply can't reliably detect all 100% of torrent packets. Disabling the listening port of the torrent client also will only slow it down. As an alternative, you can try to disable all TCP/UDP ports in the 1024-65535 range for a particular IP/MAC (both - in and out) - of course it may disable other services as well but the web browsing should still work.

    Also, there's no sense to use rules combining the port restriction with L7 or IPP2P filters - the rule will trigger only when all conditions are met, not just any of them. So in case of the rule "DROP tcp -- mport ports 56881 LAYER7 l7proto bittorrent" the packed will be dropped only if the port is 56881 AND it's recognized by L7 filter as torrent packet.
  40. Elbereth

    Elbereth Networkin' Nut Member

    Might try that. Actually I think I was not using channel 6 with the WRT54GL, I switched after a Wireless scan.

    The thing is I am not complaining about the speed, the fact is after a while I am unable to connect to the AP anymore and the only way to be able to do so is by reboot the router.

    I will try other settings and see if I don't loose Wifi after some days anymore. If I do I will just add a cron to reboot. ;)
  41. roflcopter

    roflcopter Networkin' Nut Member

    Thanks - I was really just trying anything with those rules! The NAS BT client is limited perfectly by using access restriction. I will try the port range drop for that specific MAC/IP and see if that helps.

    Thanks for your help.
  42. KyleChen

    KyleChen Addicted to LI Member

    DLNA boys, get your ps3/xbox ready~~~
  43. joew333

    joew333 LI Guru Member

    Wireless goes to sleep

    I have had the same experience as others with Beta 10 and 11 using both an RT-N12 and an RT-N16. I have tried "auto" channel selection, Channel 1 and Channel 11. The wireless driver seems to go to sleep after a couple days (router is up and running on wireline side, but wireless is asleep). There are also frequent connection drops.

    With the WRT54GL router and latest Teddy Bear firmware 1.27 8745 on 2.4 Linux kernel, I can run for weeks and weeks with no reboot and solid signal 24x7. For sure, the 2.4 kernel is mature and stable along with mature Broadcom drivers.:)

    Would be interesting to test different versions of the Broadcom wireless drivers on a new 2.6 kernel release as I pretty well believe that is the way forward on this.
  44. pkdick

    pkdick LI Guru Member


    I have one question: after installation of the last Tomato beta11 firmware on my WNR3500L, I tried to flash the NETGEAR original firmware and I got an error. However, I read that this new beta was allowing this operation: what is the procedure ?

    Thank you in advance
  45. teddy_bear

    teddy_bear Network Guru Member

    If it doesn't work, you may need to flash dd-wrt first, and then the Netgear image.
    What's the exact error you're getting, and at what point?
  46. mwsealey

    mwsealey Addicted to LI Member

    It's gonna have to wait for someone else unless I magically get some time to do it. I'm not even sure what the relevant changes are in the web interface and so on, so it's going to be some time-consuming picking. I have a ton of kernel and U-Boot stuff to do at work, and we're moving our server infrastructure to a new place this week, so :)

    If nobody does it by the end of May I'll pick through.
  47. kerbdog

    kerbdog LI Guru Member

    Just donated to yea teddy_bear :)
    Thanks for all the hard work your putting into the Tomato firmware USB mod and also the Kernel 2.6 update! Nice to have a 'n' network in the house :cool:

    Keep up the great work
  48. roflcopter

    roflcopter Networkin' Nut Member

    Please elaborate??!!
  49. cariyawa

    cariyawa Addicted to LI Member

  50. though

    though Network Guru Member

  51. cariyawa

    cariyawa Addicted to LI Member

    Seems like TB is going to integrate miniDLNA media server.:biggrin:
  52. though

    though Network Guru Member

    can you give an example on how we would use it??
  53. KyleChen

    KyleChen Addicted to LI Member

    hi teddy bear, is it safe enough to build from source and test miniDLNA now?

    safe enough i mean, router can successfully boot up.
  54. akawoz

    akawoz LI Guru Member

    I've moved to TB's Beta 11 with LA's Optware install. I'm now getting approximately 5.5MB/sec reads on my RT-N16's USB - guess that's better than nothing. If anyone has any ideas about increasing this performance please let me know.
  55. teddy_bear

    teddy_bear Network Guru Member

    All I can say is that I'm now running this version...
  56. dlawley

    dlawley LI Guru Member

    running v1.27.9045 MIPSR1-beta11 K26 Std on various wrt54g models mainly -TM

    I have noticed that when I set up a unit in Bridge mode that upon reboot the power led keeps flashing.

    Units work ok, and I have 2 that seem ok after messing with them. Sometimes flashing back to "stock" tomato then back to tomatousb will fix the issue. Thinking maybe some gpio not getting fullfilled.???
  57. gingernut

    gingernut LI Guru Member

    Extract straight from the wiki:
    So miniDLNA is a DLNA media server that will allow users to stream video/music content from the routers usb attached storage to a PS3/LCD TV or similar I would imagine.
  58. pkdick

    pkdick LI Guru Member

    Hello teddy_bear,

    When I select the NETGEAR file to be flashed, using the Tomato Upgrade Menu, there is no warning then I get a message like "bad header" after having uploaded the file.

    I know that there is another flash procedure using the DD-WRT firmware, but I was hoping to have one easier than what is described on the myopenrouter site...

    Anyway thank you for your support!
  59. teddy_bear

    teddy_bear Network Guru Member

    There was a several pages long discussion earlier in this thread about the power led on TM routers. Yes, it's GPIO-related issue, and doesn't affect anything else besides power led. I tried to add some code from other sources, like dd-wrt, to deal with it but it didn't work. Without the actual router on hands to experiment with I can't do much more for now as I'm out of ideas... So I'm just waiting on other smart guys with TM to figure it out ;).

    Can you give me a link to the Netgear firmware you're trying to flash?
    It might be that there're different header versions, and my code only deals with one of them... I'll try to fix it for the next build - but for now it looks like you still have to take dd-wrt route to flash back to the OEM firmware.
  60. mstombs

    mstombs Network Guru Member

    I'm waiting too - dd-wrt is OK. But for anyone who wants to test I found that soft-reboot and nvram commits don't always trigger flashing power led, but power cycle always does. My guess is that something is unhappy and trying to signal alarm so not a wrong GPIO assignment, but what - who knows!
  61. pkdick

    pkdick LI Guru Member

    The firmware was the last one from Netgear: WNR3500L-V1.0.2.26_30.0.98.chk
    You can find it here:

    Thanks !
  62. Elanzer

    Elanzer Addicted to LI Member

    It seems that VPN is broken in beta 11, try saving settings on VPN page (even when making no changes) and it should popup with an invalid value error. This is on a fresh flash with full nvram clear. Going back to beta 10 fixed the issue.
  63. teddy_bear

    teddy_bear Network Guru Member

  64. dlawley

    dlawley LI Guru Member

    Thank you sir, really not much of an issue. Sorry got a bit lazy on the search of the hundred or so pages. The one that is still flashing is off in another room. Wish I could say how I got the other 2 to stop. Maybe I can come across something.

    Comment was mainly FYI, thanks for the feedback.
  65. vinuneuro

    vinuneuro Networkin' Nut Member

    teddy_bear, not sure if you're still interested in beta 10.01, but I was having a problem this last week where wifi was crawling for browsing. It did fine in speed tests though. Ethernet computers were normal.

    Finally what I did was back up my configuration and erased the NVRAM. After restoring the config, all is well now. Is there any explanation for this? I'm still going to keep an eye on it just in case it's h/w related with a week left in the newegg rma window.

  66. mic1982

    mic1982 Networkin' Nut Member

    Are there any plans to have G/N mixed networks? I can just choose B/G mixed, G- or N-only :(
  67. KyleChen

    KyleChen Addicted to LI Member

    cheers teddy bear the minidlna works crazily :)

    all my pics/songs/videos in usb are showing up, play well, forward backward movies smoothly and fast. scan new media took only a little cpu and usb resource.

    absofackinglutely cool!

    Sorry for no bug report cuz i did find any yet.
  68. though

    though Network Guru Member

    if you choose auto, it will accept mixed clients....

  69. mic1982

    mic1982 Networkin' Nut Member

    Ah great. Was not known to me :) Thanks.
  70. rasa

    rasa LI Guru Member


    I have some problems with tomato (K2.6 beta11) and 3G modem.
    1. Parameter maxSize is not accepted during loading usbserial module (without specify this parameter my internet connection is much slower than should be, usbserial+option is very unstable)

    2. After some time of using 3G connection I get error:
    hub 1-0:1.0: port 1 disabled by hub (EMI?), re-enabling...
    usb 1-1: USB disconnect, address 5
    I found information that this patch can help

    And one more thing.
    3. 'Run after mounting' script is executed twice if I have two partitions (in build with 2.4 kernel only once)

    Thanks for your help
  71. KyleChen

    KyleChen Addicted to LI Member

    minidlna fail to start after router reboot, need manually turn on, i guess teddybear you knew this already.

    and i am interested in how you're gonna deal with dlna rescan schedule for keeping database update?
  72. nitr8

    nitr8 Network Guru Member

  73. idigg

    idigg Addicted to LI Member

    Good to see Tomato is available for my newly purchased Linksys WRT160Nv3. Just a question on which version I need to load...

    Linksys WRT160N version 3

    I know I need to install K26-MIPSR2, but curious on what file to install...

    tomato-K26.1.27.9045MIPSR2-beta11-vpn3.6.rar or tomato-K26-1.27.9045MIPSR2-beta11-Std.rar. What is VPN3.6 vs Std? Thanks!
  74. idigg

    idigg Addicted to LI Member

    I'm sorry, I figured out I need to load dd-wrt mini first, and then load tomato-K26-1.27.9045MIPSR2-beta11-Std.rar - I don't use OpenVPN. Hopefully all goes well. Thanks Teddy!
  75. dareino

    dareino Network Guru Member

    the .std version has no usb support! want the .Ext version if usb is needed. I found out the hard way :)
  76. idigg

    idigg Addicted to LI Member

    Works PERFECTLY! I installed the dd-wrt mini first, then renamed the tomato .trx to .bin and then loaded Tomato ND USB 2.6 standard (no usb). Good ole' tomato interface I love with wireless N support! My throughput is the same with my desktop vs. my laptop now with Road Runner Turbo. My laptop can do the 23-24Mbps on downloads just like my desktop!

    I picked up the Linksys WRT160N v3 from Circuity City from $33 shipped.

    Thanks Teddy Bear.
  77. Terror1

    Terror1 Addicted to LI Member

    Okay, seems that there is a small problem with the DHCP BROADCAST flags that I have just tracked down. My Vista machines on the network would send a request for an IP address that they wanted typically a 192.168.0.* address and after a DHCP offer the DHCP client would set itself to whatever it wanted. My network is on a 192.168.1.* with a subnet.

    I did locate a fix for this

    As far as I can tell this would likely be due to the dnsmasq configuration needing to be fixed.
  78. rhester72

    rhester72 Network Guru Member

    re: DHCP BROADCAST...I've never encountered this with Vista or 7 64-bit clients on Tomato - what specific version of the Tomato firmware are you using?

  79. belliash

    belliash Addicted to LI Member

    What about kernel support for IPv6?
  80. mstombs

    mstombs Network Guru Member

    How is this a Tomato problem if your client is ignoring the offer?
  81. Terror1

    Terror1 Addicted to LI Member

    It's a FEATURE of Vista, apparently from what I read that it is either an update to specific systems or Vista itself. The computers that are having the problems have nVidia chipsets so that could be part of it. So with careful shuffling it can be avoided. Not defending MS but for users it can and would be a PITA.

    I am using the current RT-N16 Beta 11 firmware.
  82. myersw

    myersw Network Guru Member

    I am running a RT-N16 with beta 11 firmware. The ext version. I have Windows XP, Vista and 7 all connecting to the RT-N16 without any issues with dhcp. It just works for me. I am aware of the issue with the differences between XP and Vista but has never caused me an issue.
  83. Terror1

    Terror1 Addicted to LI Member

    Yeah, until more recently it all worked without a problem so I am thinking that it might be something more specific to an update MS released. Just thought I would toss that out there to perhaps save someone else their sanity.
  84. teddy_bear

    teddy_bear Network Guru Member

    MiniDLNA integration is not quite ready for prime-time yet - I'm still trying to figure out how it works with inotify (supposedly it should automatically pick up any file and directory changes, but it's not always working), and come up with some reasonable handling of rescans...
    But I have not seen it not to start after reboot - thanks for reporting this! It always started properly in my testing. Are you sure it didn't actually start? Did you check with "ps" that it was not running?

    1. maxSize was added to K24 module by OpenWRT patch. I was not sure if this parameter is still needed for K26, so I didn't apply this patch yet. Will do it for the next build.

    2. The patch you posted is to fix a bug introduced by another kernel patch which is newer than our kernel ;). So the code it's trying to fix is not there... However, I'm working on some USB driver backports - maybe that will help.

    3. Yes, in K26 builds the after-mount script is called for every mounted partition. You can check the DEVICENAME environment variable in your script - it will contain the name of the partition getting mounted (i.e. "sda1", "sda2").
  85. teddy_bear

    teddy_bear Network Guru Member

    The SourceForge' wiki doesn't allow anonymous edits, so if anyone would like to contribute, please register SourceForge account if you don't have one yet (it's free, and you don't have to start a project), and let me know your user name - and I'll add you to the wiki editors.
  86. TexasFlood

    TexasFlood Network Guru Member

    I've never had much luck with the auto setting. Typically either 1, 6 or 11 should work. I had good luck with 9 for years. Eventually after changing some of my hardware I ended up switching to 1 to avoid the occasional microwave interference and have been having good luck with that.

    To be honest I'm not sure whether this is happening to me or not. I have the RT-N16 as my primary WAN gateway router also supporting wireless clients. I also have some older 802.11g routers acting as clients to provide wired ports where needed. I have scripts running on all of them which check that they can all ping each other so haven't lost wireless connectivity. If the ping fails, they will all reboot. Therefore if the wireless "went to sleep", it would fix itself, very likely before I ever noticed the problem.

    I can, of course, disable the scripts to test it. You said others were experiencing this? I haven't been able to follow the thread closely enough to keep up really. How many others are seeing this?
  87. sziggle

    sziggle Networkin' Nut Member

    i have seen a symptom that matches this description several times since i got my new RT-N16 about 3 weeks ago. i am running beta 11. i have tried switching channels around and am currently on 6 and have not seen a problem (as far as i know, and i am in front of the box a lot), for about the last week.

    TexasFlood: if you would be so kind as to post the code to your reboot on failed ping scripts, i would be very grateful.
  88. Engineer

    Engineer Network Guru Member

  89. TexasFlood

    TexasFlood Network Guru Member

    Sure. It's pretty simple. I probably posted it here before but would have to search for it and perhaps I changed it since posting it last, can't recall. Note that you can also do this with a custom scheduler script. I just used this method because I was used to it since before custom scheduler scripts were an option. But either way should work fine.

    So let's say you have a primary router and two remote wireless routers, connected either via WDS or as Wireless Ethernet Bridge routers. In this example, the primary WAN gateway router IP is and the remotes are and I put the scripts in the Administration -> Scripts -> Init tab of each router. Just navigate to that page, paste the script in, after editing as required for your setup, save it and you're done.

    This is the script for the primary WAN gateway router
    #  Wireless network keep alive script TexasFlood 2009
    #  Script for primary router in example, IP
    #  All output typically suppressed (redirected to /dev/null)
    #  The following line creates a script file in the /tmp directory
    cat <<END > /tmp/keepalive
    #  The following two lines ping the remote routers once each and reboots if either fails
    ping -c1 >/dev/null || reboot
    ping -c1 >/dev/null || reboot
    #  The following line tries to ping google out the WAN port and reboots my Motorola Surfboard (won't work on other devices) if it fails
    ping -c1 >/dev/null || wget >/dev/null 2>&1
    #  Next line closes write to script file
    #  Makes script file executable
    chmod 755 /tmp/keepalive
    #  Sets script to run in cron every 15 minutes
    cru a KeepAliveScript "*/15 * * * * /tmp/keepalive >/dev/null 2>&1"
    Then for the first remote router,, it's basically the same, I just modify it to ping the appropriate IPs and delay it by 3 seconds. This really goes back to when I first wrote this for WDS. I no longer use WDS but when I did, I found that if I rebooted the primary router then the others in a delayed sequence that all would come up working every time. Perhaps the remote routers really only need to ping the WAN router ( in this example) but not the other remotes as well. In fact now that I think about it I'm going to change mine to do that. Sharing information is good, forcing me to think about it resulted in a couple of improvements, :D
    #  Script for first remote wireless router in example, IP
    cat <<END > /tmp/keepalive
    sleep 3
    ping -c1 >/dev/null || reboot
    ping -c1 >/dev/null || reboot
    chmod 755 /tmp/keepalive
    cru a KeepAliveScript "*/15 * * * * /tmp/keepalive >/dev/null 2>&1"
    Finally for the last remote in our example,, it would be:
    #  Script for second remote wireless router in example, IP
    cat <<END > /tmp/keepalive
    sleep 6
    ping -c1 >/dev/null || reboot
    ping -c1 >/dev/null || reboot
    chmod 755 /tmp/keepalive
    cru a KeepAliveScript "*/15 * * * * /tmp/keepalive >/dev/null 2>&1"
    Notes on customizing:

    You can delete all lines starting with # as they are only comments for clarity. You could add, for example, some logging to syslog or other creative ideas. Note that unless you are logging to a separate syslog server, the log entry would get lost on reboot anyway. To change the number of pings, change the number after "-c" in the ping command. As shown, "ping -c1" pings one time, "ping -c2" would ping twice. To change the frequency when running from cron, change the cru command. For example changing "*/15" to "*/10" would change the run frequency from every 15 minutes to every 10 minutes. For more detail refer to documentation such as the Wikipedia Cron page.

    To run as custom scheduler script, copy the lines between "cat <<END > /tmp/keepalive" and "END". Log into the router and navigate to Administration -> Scheduler -> Custom 1 or whichever is free if you already have some custom scripts. Enable a free custom script, paste the copied lines into the box then set the desired run frequency with the GUI checkboxes and dropdown. Save it and you're done.
  90. KyleChen

    KyleChen Addicted to LI Member

    Answere teddy bear about miniDLNA:

    yes, ps checked. in my rt-N16 it won't start after reboot. After I get in Web Gui and resetting DLNA page, few DLNA processes will show up in PS and start working.

    If it works on your router, may be because I point the media path and database path to a USB NTFS partition. Maybe a delayed start is needed.
  91. rhester72

    rhester72 Network Guru Member

    Pretty likely - mDLNA will die a horrible death if you ask it to use a database that doesn't actually exist (at the time).

  92. teddy_bear

    teddy_bear Network Guru Member

    Yep, that's what it is. Not actually "horrible" but rather "planned" ;) - it exits immediately if the database file can't be opened or created - for example, if the USB drive it points to is not mounted (yet).

    I made some changes to the code to handle minidlna similarly to ftp/samba - if it's not yet running, the attempt to start it will be made after each mount.
  93. joew333

    joew333 LI Guru Member

    Router Falls Asleep

    With both RT-N12 and WRT160Nv3, I have seen the router fall asleep after 3 days or so. I am running right now Tomato K26-1.27.9045MIPSR2-beta11-Std. Power cycling or rebooting the router brings it back up.

    Has anyone else seen their router either in full, or just the wireless interface, fall asleep...and what is the solution?
  94. TexasFlood

    TexasFlood Network Guru Member

    Now I'm curious, so just disabled my keepalive script on all my routers and will track how long they stay up before it either "falling asleep" or perhaps rebooting themselves.
  95. cariyawa

    cariyawa Addicted to LI Member

    My RT-N16 is up for 22 days with beta11 loaded. I am running FTP, Samba, VPN Server, optware(lighttpd with php for a wiki). I didn't have any reboot issues.
  96. joew333

    joew333 LI Guru Member

    Static DHCP question

    Thanks! The only other issue I have noticed with Tomato K26-1.27.9045MIPSR2-beta11-Std on the WRT160Nv3 is that when I set a static IP address for a VOIP device, the router has a very hard time assigning that IP address to the Linksys PAP2 device. Even when I reboot the router, it might be hours (or never) that it appears in the log file or the Device List. If I unplug the VOIP device and plug it in, the router and VOIP device line up on the static IP address set in Tomato. Any ideas?

    By comparison, when I use the old K2.4 Tomato on a WRT54GL, it assigns the static IP address to the VOIP device within a minute of the router rebooting. So something appears to be going on with Static DHCP addresses with K2.6 Tomato.

    Other than these 2 sniggles, the Teddy Bear Tomato is huge. Low processor load and great stability. This is a huge leap forward. TB, awesome man!
  97. teddy_bear

    teddy_bear Network Guru Member

    I too have a similar VOIP adapter (Linksys SPA2102) connected to my RTN16. The adapter itself is configured to get IP by DHCP, and on the router it's configured by MAC to get a static IP (the same way as all my other clients are set up). It never had any issues getting an IP address. I have no idea why it could be happening - but it could be a problem with adapter itself, not the router.
    Does the router even log the DHCP requests from the adapter? If it does, maybe something can be derived from the log messages... You may also try to activate additional DHCP logging on the router (add "log-dhcp" line to the "Dnsmasq Custom Configuration" box) to help in troubleshooting.

    As for the wireless dying from time to time - I'm also not experiencing this problem at all. With all the experiments and the firmware updates I don't usually have too long uptimes, but just recently it was 12 days and then 7 days - and wireless always worked with 8 different wireless clients (2 of them are being RTN12 and WL520GU in the wireless bridge mode). Have you tried to use different channels? The N radios seem to be more sensitive to interference, so the channel may be very important - and others confirmed that as well, for example:
  98. TexasFlood

    TexasFlood Network Guru Member

    Out of curiosity, saw an old post of yours where you said you were using TKIP /AES for security. I don't know if this is still the case but I have had nothing but trouble with TKIP in the past. So if you're still using that, I'd suggest try switching to just AES as a test to see if things improve. If you post your settings, someone else might notice something.
  99. achoi

    achoi Networkin' Nut Member

    I am a novice, please excused me asking this question. I switched to tomato on my RT-N16 a few days ago, and enjoy using it very much. I beleive I have flashed in firmware 1.27 built 9042. Now, I realised that there is a built 9045/beta 11 available. If I want to upgrade the firmware to the latest beta (K26USB-1.27 9045 MIPSR2-beta11 Ext.rar) do I need to revert back to dd-wrt, or I can just using the upgrade firware function in my current tomato firmware. Can I revert back using the same upgrade function if there is any problem with beta 11? Many thanks. alex
  100. joew333

    joew333 LI Guru Member

    Static DHCP

    I think I found out the issue with static DHCP. I played around with the settings on the Linksys PAP2 and the hostname was the default one on the PAP2, not the one I had put into Tomato on the router. As soon as I changed the hostname on the PAP2 to match the router, bingo the router offers. On the K2.6 versions of Tomato, if the hostname does not match exactly between router and the VOIP device, it seems like the router does not offer the static DHCP address. Only strange in that the older K2.4 versions of Tomato behave as if they ignore the hostname. This is what I have learned anyway.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice