Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. Catalin

    Catalin Addicted to LI Member

    Guys, those Intel cards DO NOT WORK on 40MHz wide channels when connected on 2.4 GHz band.

    To use 40 MHz wide channels on those cards, you have to buy a dual band (2.4 and 5GHz) router.
    The other, simpler way, is to avoid buying Intel ****ty cards next time.
  2. TexasFlood

    TexasFlood Network Guru Member

    You may be right. I don't have one to test. However I found an earlier post in this thread from gingernut that reported test results showing an Intel 5300 connected @ 300Mbps.
  3. rhdcheme

    rhdcheme Addicted to LI Member

    That may be. But I have a variety of N adapters (USB - e.g., Airlink) which worked fine with the previous build 9045 but do not on 9046
  4. rhdcheme

    rhdcheme Addicted to LI Member

    Do you mind sharing your router wireless settings on the 9047 that gives you 40 wide? Thanks.
  5. Catalin

    Catalin Addicted to LI Member

    As I said before, I reverted to Beta11 because of some problems with latest version. Sorry.
  6. gingernut

    gingernut LI Guru Member

    It's only the Intel wifi link 4965AGN that has this restriction and for the 5300AGN to connect at 300Mbps you have to change one of the adapters advanced settings.
  7. rhdcheme

    rhdcheme Addicted to LI Member

    I am able to get 40 wide channel again by reverting to 9045. Try it.
  8. rhdcheme

    rhdcheme Addicted to LI Member

    teddy - in 9046, I had the same problem of not being able to renew the WAN IP lease properly with my FIOS connection, as I had reported before. I reverted back to 9045, added the iptables rule, and checked reduced UDP packet size.

    All is well again.
  9. komugi

    komugi LI Guru Member

    I'm not sure about you guys, but i have the Intel 6300 AGN adapter and I have beta 11 (9045), can I can connect as 300Mbps fine. All I did after setting it up was go into the Adapter Configuration -> Advanced and changed he Channel Width for 2.4 from 20Mhz to Auto.

    Screen here:
  10. onehomelist

    onehomelist Addicted to LI Member

    I am using your latest bug fix release on RT-N16. Its working great. Both QOS and upnp are functioning well for me.
    My router provides access for about 300 users, along with 7 access points and several wired switches. Right now my network is open. I am planning to go for mac based access restriction. Your release supports 140 MAC ids. I edited it in the source code and made it 400, by following the advice given by Toastman. Wherever there was 140, i made it into 400 ( i guess totally 3 files). Before implementing I wanted to make sure that if it will work. Toasman says it may not work above 255 limit. Teddy_bear, is it possible to fix it?
  11. tsanga

    tsanga LI Guru Member

    I'm not sure if this question belongs here or somewhere else, since I'm not sure if this is a firmware issue or user issue....

    I'm attempting to set up a router as a LAN-only transparent wireless access point. So I set:
    WAN = Disabled
    Use WAN port for LAN = checked
    Router IP = static
    Subnet Mask =
    Gateway = IP of primary router running Tomato
    DNS = IP of primary router running Tomato
    DHCP server = off

    Everything works great with the router as an access point, except for internal wireless traffic using Apple Bonjour. If the wireless device is associated with the primary Tomato router running vanilla Tomato (with WAN connection, DHCP server, etc.), then everything works fine. When I'm at the other end of the house and the device is associated with the second Tomato access point running teddy_bear mod, Bonjour advertising stops working properly. It's as if a firewall is up.

    From my research, I need to have TCP port 3689 and UDP port 5353 open for Bonjour.

    I've tried port forwarding, DMZ, routing settings on the secondary router, but to no avail. What am I missing?

    An additional observation is that the secondary router seems to be blocking wired traffic over Bonjour as well. For example, PC#1 connected to the access point through a wired connection back to the main router cannot see Bonjour traffic from PC#2 wired directly to the primary router.
  12. XiaofengXu

    XiaofengXu Guest

    From my test, I can see the router is not responding to SSDP M-SEARCH requests. After enabling multicast on the router, the UPnP starts to work.

  13. gingernut

    gingernut LI Guru Member

    This just gets better and better.


    Thanks TB.
  14. Toastman

    Toastman Super Moderator Staff Member Member

    It should be pointed out that using 40MHz wide channels on 2.4GHz band causes severe interference to other class "G" routers. Because of this many routers default to turning off the option. It was originally intended to ban 40MHz wide transmissions in this band altogether, but it seems that didn't happen and the specification still allows it. However, Intel have decided to disable the option rather than be the scapegoat when things go horribly wrong.
  15. ladysman

    ladysman Network Guru Member

    I've noticed this as well in my previous posts. When my apple TV's are wired, they work fine but when wireless, they quit functioning completely. Looks like i'm in the same boat as you since I need these ports as well. I'm going to reflash my other RT-N16 with an older firmware and see if that fixes it.
  16. maurer

    maurer Network Guru Member

    Gingernut, what HDD are you using?
  17. tsanga

    tsanga LI Guru Member

    If you run out of ideas, I found that DD-WRT has none of these issues, so it's a good fall-back solution.
  18. gingernut

    gingernut LI Guru Member

    A SAMSUNG HD160JJ formatted as ext3 in a LaCie Box.
  19. maurer

    maurer Network Guru Member

    is that connected through usb or lan? - i'm trying to find the best solution to replace my usb powered-only hdd to improve speed.
  20. ladysman

    ladysman Network Guru Member

    I've been using TB's mod with these apple tv's since January. However, I was on Beta 5 and decided to upgrade. I guess I shouldn't "Fix" something that isn't broken. :biggrin:
  21. gingernut

    gingernut LI Guru Member

    It's USB connected.

    On earlier builds I was getting around 7-8MB/s over FTP transfers but the changes TB made in the latest has made nearly a 2MB/s difference :smile:.
  22. tsanga

    tsanga LI Guru Member

    So maybe I should step down to beta 5....
  23. teddy_bear

    teddy_bear Network Guru Member

    Heh... The betas 14 and 15 have the new Broadcom wireless driver, which I marked as "experimental" :). It's already confirmed that the updated driver is responsible for these weird UPnP-related problems some of you are experiencing. As XiaofengXu posted above, enabling multicast might be a workaround - but not a complete solution of course.

    Unfortunately, there are no sources for the wifi driver, and to make it even worse, Broadcom added another binary conntrack module which is required by the new driver. I'm trying to find a fix for the issue, but it does look like rolling back the driver to the previous version might be the only solution :(...

    In the meantime, I believe downgrading to beta 11 should work for you, or just wait a few days until I release the next beta with this issue fixed - one way or the other.
  24. Lost_Animal

    Lost_Animal Addicted to LI Member

    T_B thank you again for your nice Firmware.
    Installed and running Good so Far.
    The only problem i see with beta 15 is that WDS+Access Point mode has some random connection problems, but i am not 100% sure yet.

    Also my new optware packages running fine also.

    Great Support m8 :biggrin:
  25. ladysman

    ladysman Network Guru Member

    Yep, it worked. I'm on beta 11 and the apple tv's immediately synced.

    I enabled multicast and it didn't work for me.

    Sorry Teddy if I sounded like an ass. Great firmware. Pretty stable as you can tell since I was running Beta 5. :)
  26. Lost_Animal

    Lost_Animal Addicted to LI Member

    Sorry if this question already answered (i didn't find).

    Have you fully erased nvram after your Upgrade - Downgrade ?
  27. komugi

    komugi LI Guru Member

    I can confirm that only when multicast is enabled (in Firewall section), the upnp works.
  28. ladysman

    ladysman Network Guru Member

    Yes. First did it without NVRAM erase then erased and built my router from scratch. Same problems.

    Went to beta 11 and it worked. And no animal, I never mentioned that :)
  29. ladysman

    ladysman Network Guru Member

    That didn't work for me but i'm pretty sure I didn't reboot the router though. Maybe thats the cause? I mean it restarted services but I didn't do a full reboot.
  30. Lost_Animal

    Lost_Animal Addicted to LI Member

    Then, i am sure T_B will fix this issue on next update. :wink:
  31. tsanga

    tsanga LI Guru Member

    Ditto. Great firmware. I hope I don't sound like an a$$ either...just helping to report bugs and troubleshoot. :tongue: I don't like having to roll back to DD-WRT.

    Enabling multicast didn't do anything for me either. Trust me, I tried every toggle and rebooted every time - multicast, gateway/router mode, port forwarding, DMZ, enabling/disabling WAN, toggling using WAN port for LAN,....

    Guess I'll give beta 11 a shot. That was the one that gave me fits trying to upgrade from DD-WRT with a linux partition that was too small. I'll try stepping to beta 14, then back to beta 11.

    I'll never learn to stop fixing what isn't broke... :biggrin:
  32. mwsealey

    mwsealey Addicted to LI Member

    I can confirm the TM LED thing is fixed (yay, not that it broke anything in the first place, but I got my button LED back as well as the blinking power light being solid again) and the whole wireless network in Ethernet Bridge mode (1 gateway, two WEB routers around the apartment) has gone back to the speed I remember (3-4Mbyte/s over wireless, 5-6Mbyte/s file transfers if it's two wired units on different WEB routers with Afterburner making that little bit of difference for once). This is pretty much the performance level I came to expect a long long time ago with the newer Broadcom driver with other Tomato mods.. a good 33Mbit/s peak.

    Very very pleased with how my network looks and feels tonight, keep up the good work :D
  33. db3l

    db3l Networkin' Nut Member

    I have been comparing Beta 14 and 15 and so far, Beta 15 got worse in terms of raw WAN<->LAN throughput on my Asus RT-N16. Given the list of changes, I'm presuming it's due to the removal of the different NAT module.

    I've got a 100Mbps WAN connection. While I'm not sure that any builds yet can fully saturate the link, Beta 14 seems to be able to hold a higher throughput while showing less load on the router.

    In tests with Beta 14, I can generate what looks almost like a square wave on the bandwidth monitor graph at perhaps 90-95Mbps while only showing 70-75% sirq in top on the router. During the transfers the web interface and telnet session remain very responsive.

    Conversely, Beta 15 bounces all over the place, and runs out of steam (95%+ sirq in a slowly updating top) at similar throughput rates. It looks like the router maxes out the cpu, drops data, killing throughput, until it climbs up again and again saturates the CPU. So while peak rates are similar to Beta 14 the average across the whole transfer is much less. During that time, even getting onto the router via telnet is extremely sluggish.

    This is between a Gigabit WAN connection to Gigabit connected PCs, no wireless involved.

    I don't know if the "fast" NAT module is causing problems in other scenarios, but it does seem to achieve better performance with fewer resources in my tests. I still hope that eventually things can get even a little faster than Beta 14 (tests with an EnGenius ESR9850 can hit the full 100Mbps), but for the moment I'm willing to give a few Mbps in throughput to be able to use the Tomato firmware.

    -- David
  34. oldkuang

    oldkuang Addicted to LI Member

    I just upgraded to Beta15 from beta11. When I tried to restore the configuration saved before upgrade, I got message said something as invalid hardware 0..0c:0..0d, and the restore failed. Any suggestion and advice are appreciated. Is anyway to convert the configuration backup into pure text? At lease I can manually re-enter it. I did not have this problem on previous upgrade. I used Asus firmware restore function, it has worked every time.
  35. RdBw

    RdBw Networkin' Nut Member

    Till a few days ago, I prefere to use an original firmware from Asus for RT-N16. It has so much problems, that I start to search something better and Tomato is really fantastic piece of software (still not perfec, but much much more better and stable). My problem with Tomato is p2p download, where uTorrent works on my PC, which is wired connected with RT-N16. But despite port forwarding in router, downloads are not as fast as my connection provides. With Asus FW that DL speed was as high as it is possible, but now with tomato DL speed was reduced, but don' know why? uTorrent shows that port is properly open.
    Any idea, please??
  36. someguyfromhell

    someguyfromhell Addicted to LI Member

    Will I need a NVRAM erase after upgrading from build 9045 to build 9047?

    Thanks in advance!:)
  37. komugi

    komugi LI Guru Member

    P2P Downloads is always dependent on other connections, while some torrents might max a connection out, and some might not, there is no guarantee on the speed of any P2P downloads.
  38. cariyawa

    cariyawa Addicted to LI Member

    It is a pain to configure to the old settings, but I think it is really essential to clear the nvram after every firmware flash.
  39. magician

    magician Guest

    Asus RT-N16: Flashing tomato!
    The quick way:

    * ASUS RT-N16, Hard reset: Unplug power, press and hold WRT switch, reattach power.
    * ASUS RT-N16, Restore mode: Unplug power, press and hold black restore switch, reattach power. Power LED starts flashing.

    To upload to ASUS RT-N16:

    1. Enter restore mode (see above)
    2. Upload firmware with the ASUS utility
    3. Goto and see; you have tomato.
    4. Reset NV RAM values in: "Admin/Configuration/Restore Default Configuration"
    5. logon/PWD is now admin/admin

    Regards. -Thanks to Teddy Bear for this mod.
  40. karog

    karog Networkin' Nut Member

    I would love to put Tomato VPN on a WHR-HP-G54 (also have RT-N16 with TB Extras) but instructions say:
    at least for the Teddy Bear mod. Even the beta 15 looks a wee bit too big.

    Can you tell me exactly what version you put on the WHR-HP-G54?

    I currently have a DD-WRT with VPN on it. Anything special required to get the Tomato VPN on it?

  41. RdBw

    RdBw Networkin' Nut Member

    I know that, but i'm talking about torrents, that has max speed with Asus FW, but with Tomato it looks like there is Qos enabled and it blocked max speed of same torrent. The difference is obvious and Qos is not enabled in my case.
  42. tinmanchris

    tinmanchris Networkin' Nut Member

    I'm getting really slow HDD transfer via FTP or SMB (1.5MB-2MB) from a WIRED computer and I can't figure out why. Currently I'm using a 1TB Seagate SATA drive in a powered docking station hooked to my ASUS router via USB running the latest Tomato Teddy Firmware. I also tried this on a wireless G laptop and got the same transfer speed.. Any help would be greatly appreciated! Thanks! :smile:
  43. tinmanchris

    tinmanchris Networkin' Nut Member

    After more research from other threads I will try the following tonight:
    • Try another powered external drive
    • Try another format either ext2 or ext3 (still debating between the two)

    Will keep everyone posted with results. Thanks.
  44. elitenoobboy

    elitenoobboy Networkin' Nut Member

    For an asus rt-n16, do I have to use this mod with kernel 2.6? It seems kind of beta-ish, so I want to avoid it. It says on this page that if you have this model to look at getting the kernel 2.6 version, but it doesn't flat out say if the non kernel 2.6 version will work or not. At the same time, I have also seen other guides that direct me to the non kernel 2.6 version as well, implying that it will work. Can this be clarified?
  45. ppttpp

    ppttpp Networkin' Nut Member

    I installed beta 14 to my rt-n16, which is then set as Wireless Ethernet Bridge mode, another router is set as AP. Everything is working fine, except that the rt-n16 router time is unavailable. I can telnet to the box, and found the time is jan, 1970. I can change the time by date command. However, if the router is rebooted, the time is unavailable once again. Is it a bug?
  46. rhester72

    rhester72 Network Guru Member

    Wireless N requires the 2.6 kernel.

  47. rhester72

    rhester72 Network Guru Member

    There is no persistent time source in home routers. Assuming you have Internet access, the default settings under Basic/Time (considering a correct time zone ;) should suffice. Make sure you do not have auto-update disabled!

  48. ppttpp

    ppttpp Networkin' Nut Member

    The auto-update is enabled, but the time is not updated. I even checked "Trigger Connect On Demand" to force the time update, still no luck. I think maybe the wireless mode "Wireless Ethernet Bridge" cause the problem.
  49. rhdcheme

    rhdcheme Addicted to LI Member

    Can anyone confirm that 40 Mhz wide channel is working in beta 15 on an rt-n16?
  50. xybsh

    xybsh Guest

    It works fine for me. One thing is I can only get 144M with asus 16n, not 300M. I tried wndr3300 at 5g, I can get 270M. But 130M at 2.4g. Anyone can give a quick answer? Thanks.
  51. rhdcheme

    rhdcheme Addicted to LI Member

    In the previous build, it was possible to select 40 MHz, but the status actually showed 20 MHz. Can you please confirm it shows 40 MHz in both selection AND status? Thanks.
  52. teddy_bear

    teddy_bear Network Guru Member

    Not really, wireless-N works in my builds based on kernel 2.4 as well. The problem is not the wireless-N but MIPS release 2 CPU and the new ethernet switch which are currently only supported in kernel 2.6 builds.
    No, it works fine in the "Wireless Ethernet Bridge" if you configure everything correctly. Make sure you specify "Default Gateway" and "Static DNS" to point to your main router, configure NTP servers properly, and set the "Mode" on the Advanced->Routing page in the GUI to "Router" (not the Gateway).
    It does work (and yes - when it works the status will show 40MHz as well). Make sure you set a specific channel, not the "Auto". Do not use "TKIP" encryption - by the final N-standard it's not supported in 40MHz mode. You may also need to play with different channels to find the one which works best for you.
    It depends on the client. Some wireless clients only support 150Mbps at 2.4GHz.
  53. rhdcheme

    rhdcheme Addicted to LI Member

    Thanks teddy!
  54. ppttpp

    ppttpp Networkin' Nut Member

    Wow... It works. Thx a lot.
  55. rhester72

    rhester72 Network Guru Member

    N in 2.4? No kidding? Wow. I thought the whole binary-blob-only-in-2.6 issue was still present...neat!

    A couple of minor usability nitpicks (not related to latest beta):

    - Any changes to the NAS configuration results in overwrite of /etc/passwd - which means any manual user changes to same are silently lost. Is this necessary, given that the nas user appears regardless of whether NAS is enabled or disabled?

    - Any chance of getting physical memory and swap separated on the overview status page, instead of adding swap to physical and presenting it as if it were all "memory"? (Ideally, swap figures would appear - separately - only if swap is actually present and enabled.)

  56. palmfans

    palmfans Addicted to LI Member


    I am new to Tomato and updated to Beta15 on my Asus RT-N16. I have a problem that my company PC only have PPTP vpn connection. It is possible to setup PPTP vpn server on Tomato and how to do it.
  57. RobNC

    RobNC Network Guru Member

    The field "wl_nmode_protection" is invalid. Please report this problem.

    I saw the message in the wireless area as well:

    The field "wl_nmode_protection" is invalid. Please report this problem.

    Please note that I went to this website:
    and downloaded the non-USB standard MIPSR1-beta15 version for my Buffalo WHR-HP-G54
    I noticed that the nvram parameter was set to none. I changed it to "auto" via:

    # nvram set wl_nmode_protection='auto
    # nvram commit

    # nvram get wl_nmode_protection
  58. teddy_bear

    teddy_bear Network Guru Member

    The passwd file is recreated because the user name might have been changed. Not overwriting it when restarting NAS won't solve the problem anyway - the file is also rewritten every time the admin services are restarted (when you save changes on the Admin Access page). Do you really need additional users in Tomato? If so, I believe adding the content of "/etc/[passwd|group|shadow|gshadow].custom" files to the end of corresponding "/etc/[passwd|group|shadow|gshadow]" file whenever it's recreated should work - the similar technique is used for most other config files in Tomato.
    Agreed - they should be separated. Purely cosmetic thing that I keep forgetting to implement ;). Maybe for the next build...
    You can install Optware poptop.
    I think the problem reported earlier by iloveramen has been fixed in beta 14. In your case, it sounds like you didn't erase the nvram after installing this mod for the first time.
  59. ollobollo

    ollobollo LI Guru Member

    Having installed beta 11 on a newly arrived RT-N16, the whole family is thoroughly impressed with the improvement over our previous Netgear WGT624. The QoS, in particular, works wonders.

    There is one problem, however. When trying to apply port forwarding or static DHCP settings, the settings are not saved. They disappear when refreshing the page. I did some searches in the thread, but didn't find other posts mentioning problems with this. For now, it's solved with UPnP, but it would be nice to get both port forwarding and static DHCP properly working. Do you know of any solution to this?

    Thank you, again!
  60. teddy_bear

    teddy_bear Network Guru Member

    Did you erase nvram ("thorough" option) after installing Tomato?
  61. karog

    karog Networkin' Nut Member

    After you put the settings in for one of these you have to hit Add before Save. Once in awhile I mindlessly forget to do the Add. Maybe this is what happened to you?
  62. rhester72

    rhester72 Network Guru Member

    I have a user tor that I use to do UID tracking for QoS, and a few user IDs that I use for srelay authentication - so yes, this is a pretty desirable thing. ;) I think the .custom solution would work just fine...I'm assuming it doesn't currently exist.

  63. ollobollo

    ollobollo LI Guru Member

    Let me facepalm myself for a couple of minutes. I did do the Add, but forgot to press the Save button. This solved it. :redface:


    Yes, I did that a few minutes after installing, and the problem was evidently exclusively my own stupidity's fault, but thank you for your help! :smile:
  64. TexasFlood

    TexasFlood Network Guru Member

    I've done it to, both in port forwarding and static IPs, but remember after a time or two, ;-)
  65. teddy_bear

    teddy_bear Network Guru Member

    So far all drives I formatted as Ext2/Ext3 on my Ubuntu box worked fine.

    Based on the log it looks like it could not even find the partition table on your drive, so it fails before any filesystem support modules even start working...
    You may try to repartition and then reformat the drive - possibly using fdisk and mke2fs utilities on the router. BTW, do you have Ext2/Ext3 support enabled in the GUI?
    True. But it's easy to add, so I'll do it shortly.
  66. rhester72

    rhester72 Network Guru Member

    One other random thing...

    Any change the reboot watchdog timeout can be configured via NVRAM? The hardcoded value is VERY short, such that when a reboot command is issued, none of the Shutdown scripts even get a chance to finish half the time before the watchdog alarms and forces a hardware reset. This is Not Good(TM) for applications that need to spool data back to disk during SIGTERM. :)

  67. teddy_bear

    teddy_bear Network Guru Member

    Hardcoded value (not nvram-configurable now) is 10 seconds - is it not enough?? Seems like plenty of time for shutdown scripts to complete...
  68. rhester72

    rhester72 Network Guru Member

    In practice, it sure seems like more than 10 seconds - it actually seems to elapse in about _one_ second on my setup.

    tor likes at least 30 seconds to shutdown to gracefully close connections, and darkstat definitely couldn't always manage to fully flush its data before the watchdog fired, which resulted in data loss...that's what I'm more worried about.

    The request to make it configurable via NVRAM is just so it can be tuned for oddball cases like tor. ;) A sensible default (like 10 seconds) would be fine if the NVRAM variable isn't present/is invalid (negative, ASCII, etc.).

    Have you actually timed it? I just tried it again, and there's no way there is no way 10 seconds elapsed.

  69. iloveramen

    iloveramen Networkin' Nut Member

    Since I got the Asus RT-N16, I haven't really tested my Buffalo WHR-HP-54G. Today, I had some free time and uploaded Beta 15 to my Buffalo and it still has the error "The field "wl_nmode_protection" is invalid." I also tried TB's 2.4 kernel and got the same error as well. I did erase nvram thorough after each upgrade. After all that, I went back to the original tomato. Thanks for your hard work Teddy Bear!
  70. teddy_bear

    teddy_bear Network Guru Member

    Interesting... When do you get the error - when saving settings on the "Advanced -> Wireless" GUI page?
    Does anyone else get the same error with non-Buffalo router?
  71. iloveramen

    iloveramen Networkin' Nut Member

    Yup, that is where I got the error. When I erase nvram on the buffalo it does not reset to the default settings for the Buffalo. So I went in and tried to set them back to default manually and when I hit save that is when I get the error.
  72. Spyros

    Spyros LI Guru Member

  73. teddy_bear

    teddy_bear Network Guru Member

    Ah... Found the problem - indeed it is specific for Buffalo models. Will be fixed in the next update. Thanks!

    Yes, it is ("reset_gpio" is set to 5 - but I don't have this router to test it).
  74. KapaT

    KapaT Networkin' Nut Member

    Periodically at log...:
    03:20:24 10-06-2010 (err|kern|kernel) CIFS VFS: No response for cmd 50 mid XXX

    CIFS1 is Windows share.
  75. teddy_bear

    teddy_bear Network Guru Member

  76. KapaT

    KapaT Networkin' Nut Member

    I dont know what it affects.
    Probably is a samba issue when doing shutdown.
  77. teddy_bear

    teddy_bear Network Guru Member

    If you don't know - then why do you care ;)?
    Logs are not for your viewing pleasure. They help to diagnose and troubleshoot the problem - but you have to have a problem first.

    If there's no problem, then forget that the log is even there, and don't bother posting it here... Do you use Windows? How often do you run "Event Viewer" there?
  78. KyleChen

    KyleChen Addicted to LI Member

    LOL "Do you use Windows? How often do you run "Event Viewer" there? " hahaha

    I need some advice here.
    When I use VPN version, run it as a client, I'd like to know:

    How can I let certain user ports or certain destination ip using VPN, other use the normal WAN?

    For example, I pay for a VPN to lower the Ping of WOW, and connect to the VPN with tomato-vpn as a client, and I want only the WOW to use VPN, but not other programs and browsers. How can I do it like this?

    Is it possible?
  79. karog

    karog Networkin' Nut Member


    I want to be able to sftp to/from my router. When I try, it complains:

    sh: /usr/libexec/sftp-server: not found

    I have optware running and I installed openssh-sftp-server which gives me:


    I tried to make a link from /usr/libexec to /opt/libexec but /usr is a read only file system so that didn't work.

    Then I made /etc/ssh/sshd_config with Subsystem sftp /opt/libexec/sftp-server in it and restarted sshd but that did not work; it still looked in /usr/libexec

    Any ideas on how to solve this?
  80. karog

    karog Networkin' Nut Member

    Try this. Under VPN Client config, select the Advanced tab and make sure that "Redirect Internet traffic" is unchecked so that default traffic uses the WAN.

    Then go to top level Advanced>Routing where in the second section you want to add a Static Route. Look in the section above named Current Routing Table to get an idea of what the parameters are. You probably want to be connected to the VPN when you set this up.

    I think Destination will be your target WOW ip address, Gateway will be your VPN Client's vpn ip address, mask as appropriate, metric 0, description whatever, and finally interface which will probably be some version of TUN.

    I cannot try this but I think it is roughly correct and you should be able to figure out the rest.
  81. Rasky

    Rasky Addicted to LI Member

    Try sftp -s /opt/libexec/sftp-server.

    I don't know if dropbear (which is the ssh server in Tomato) allows to configure the path of the sftp server. Another solution is to shutdown dropbear (disable SSH from web administration) and configure your own OpenSSH sshd from Optware; this sshd will use /opt/etc/sshd_server as you expect. Or you can run both dropbear and OpenSSH on different ports.
  82. karog

    karog Networkin' Nut Member

    Thanks, that works. Seems a bit weird for the client to specify a path on the server but whatever.

    I did a bit more digging. The /usr/libexec/sftp-server path is hardwired into dropbear or more correctly dropbearmulti. Since usr and opt are the same length, some use sed to modify the binary to change the path. I can't do that since the binary sits in a read only dir. Unless, of course, I copy it elsewhere and run the modified copy rather than the GUI managed one.
  83. cr00kedview

    cr00kedview Network Guru Member

    Also confirming that UPNP does not work on my RT-N16 if multicast is disabled. Using beta15.
  84. vandy

    vandy Addicted to LI Member

    Just flashed beta15 onto RT-N16. Anyone getting a problem where channel is stuck at 1 and channel width is at 20mhz when the region is set to Japan? Havent tried other regions aside from US but when it is set to Japan, no matter what channel I choose for the wireless, it is stuck at 1.
    Changing back to US works normally.

    Thanks for all the hard work Teddybear!
  85. though

    though Network Guru Member

    my guess is that's a japanese restriction???
  86. danimaltron

    danimaltron Networkin' Nut Member

    Thanks for the great work! In general, it works well on my RT-N16.

    However, I noticed something peculiar. I set my router to work in N-only mode. I then could not get my Macbook Pro (early 2008) and Macbook (new unibody) to connect. In my error console it said something about "uknown rate". This same problem happened with the same router using DD-WRT.

    If I switched to G-Only or mixed mode, it worked fine. But both laptops will only connect as G clients.

    I then began to fiddle randomly with the advanced wireless settings. Changing 1 thing at a time, rebooting and trying to connect again. I eventually got it to work (i.e. Macbooks could connect while router was set to N-only).

    However, I noticed that when I was connecting, 80% of the time it was at G speeds. This did not make sense to me, because it was set to N-Only! So the router is not respecting those settings, depending on what is configured in the advanced wireless settings.

    While testing, I turned off all security. However, after I did that, I noticed someone connected to my unsecured network with an iPod Touch... so maybe their G speeds was the culprit (bringing down the maximum network speed). But regardless, if it says N-Only, why are G clients allowed to connect?

    In the Overview page, it also says 54mbps as soon as any client connects. But if no wireless clients are connected, it says 130 or 144, etc.
  87. lxiaob

    lxiaob Guest

    I am wondering if ipt_length.ko could be added into the img, because my QoS scripts need this file.

    Running on my RT-N16, working like a charm so far.
  88. danimaltron

    danimaltron Networkin' Nut Member

    I fixed my own problem! yay!

    For some reason, macbooks don't like the default wireless N-only implementation of this router. As I mentioned, I had the same trouble with DD-WRT, so perhaps the same combination of settings will work for that firmware as well.

    The attached screenshot is the advanced wireless setting combination that enables N-only to work on Macbooks and get speeds of 130. On a RT-N16 40Mhz does not seem to ever take affect. The Overview page ALWAYS says 20Mhz regardless of which is selected. But 130mbps is a lot better than 54mbps at least.

    Basic Wireless Settings:

    Access Point mode
    WPA2 Personal + AES

    See screenshot for advanced settings. Most are left default.

    Attached Files:

  89. rhdcheme

    rhdcheme Addicted to LI Member

    Using 9047 on my RT-N16 (N-only), I cannot get 40 MHz no matter what channel/wireless settings I try. It is stuck at 20 MHz and at most I get 144 Mbps. Also, usb share does not seem to work. If anyone is having better luck, please share your wireless and usb settings.

    I have reverted to 9045 and all is fine. I get full speed (270-300) and 40 Mhz using the same WPA2-AES and wireless settings.
  90. vandy

    vandy Addicted to LI Member

    No, the point of setting it to Japan region is so you can use channels above 11. Like 12 and 13. Very useful for my network bridging here with two RT-N16s. This worked in beta14 and prior.
  91. maurer

    maurer Network Guru Member

    i saw beta 16 on git with changelog.
    when can we expect general availability ?
  92. rhester72

    rhester72 Network Guru Member

    The updates I requested worked like a charm, Fedor - thank you! Also appreciated the clarification in the gitlog of what BSS coexistence really does - may explain the rash of "I can't get 40MHz no matter what I do!" complaints.

  93. bigpimpatl

    bigpimpatl Networkin' Nut Member

    i posted this in the main tomato page, but got no suggestions. hopefully i can get some help here. Copy and pasted from original thread:

    Hi folks

    would appreciate any help with my problem. The printer is wireless and is connected to the router with all the correct credentials, and I can see it under the device list. But none of my computers can recognize the printer even when I manually type in the IP address, it just doesn't show up. Have the firewall off and don't have virus scan/checker.

    Before my new RT-N16 I had a WRT54G v2.2 that didn't have this problem at all; i had absolutely no problem setting up the printer under tomato. I could try plugging it in via USB but obviously that would negate the wireless benefit. I would try as a last resort. please help! TIA
  94. bigpimpatl

    bigpimpatl Networkin' Nut Member

    Printer: Brother MFC-685CW
    using Asus Rt-N16 with 9047

    Edit: I want to add that initially I had used WPA/WPA2 with TKIP/AES encryption on the network and thought that was the issue, but I changed many settings and tried WPA, WPA2, and even WEP but still nothing. On the WRT54G I had only used WEP.
  95. rhdcheme

    rhdcheme Addicted to LI Member

    What are the recommended transmit power settings for RT-N16 on build 9045? I noticed that TB's tomato usb mod defaults to 42 mW but dd-wrt defaults to 17 mW. Right now, using 9045, I have it set to 21 mW and it seems to work great, but I don't want it to overheat, for which rt-n16 is known to do. Thanks in advance.
  96. pharma

    pharma Network Guru Member

    I believe DD-WRT defaults to 71 mw with all models - which I believe is too high for the best SNR. Basically I tested through trial and error with my setting around 55 - 60 as my best signal/noise ratio for wireless transmit power.

  97. rhdcheme

    rhdcheme Addicted to LI Member

    Actually, for RT-N16, dd-wrt (at least the recent k26 builds) defaults to 17 mW.
  98. karog

    karog Networkin' Nut Member

    DEFAULT_PATH in options.h

    I noticed in git that Fedor changed the default sftp server path for dropbear to the above path. Thanks.

    Similarly, I installed rsync and when I run rsync from my hackintosh to the router, it tries to run rsync via ssh and fails to find it. I can get around this using --rsync-path=/opt/bin/rsync

    But perhaps DEFAULT_PATH in options.h for dropbear could also include /opt/sbin:/opt/bin?
  99. maurer

    maurer Network Guru Member

    It's already on sourceforge :biggrin:
    get it while it's hot !!!!
  100. danimaltron

    danimaltron Networkin' Nut Member

    I have narrowed down some of my problems on My MacBook to my network card incorrectly setting the country code. network cards listen for 802.11d packets that tell the computer which country their in, thus which channels are OK.

    For some reason, my Macbook often thinks it's in Zimbabwe, country code ZW. I can't tell if this is coming from my Tomato flashed RT-N16 or not, but I have a feeling that it is.

    On the advanced wireless settings, USA or Canada has been selected, but nothing changes.

    Teddy: Could you look into this, and see if the proper country code is being sent out in the beacon packets?

    This would explain why Wireless-G would work fine, but not N.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice