Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. teddy_bear

    teddy_bear Network Guru Member

    1. Yes.
    2. So far there was one report that it does happen with Tomato, and one that it doesn't. I could not reproduce this issue myself. If you install this mod, please report your experience.
    3. Yes.

    When installing Tomato from DD-WRT, do not forget to select "Reset to defaults" in the drop-down on the DD-WRT Upgrade page, and (to be on the safe side) do "thorough nvram erase" once Tomato is installed.
  2. teronzhul

    teronzhul Addicted to LI Member

    Newegg has the rt-n16 in stock as of today. For anyone interested.
  3. cariyawa

    cariyawa Addicted to LI Member

  4. teddy_bear

    teddy_bear Network Guru Member

    Probably a configuration issue... Why wouldn't you try yourself?

    I don't have any N-clients now, but when a friend was visiting with N-capable notebook, it was able to connect at 300Mbps. Maybe some combination of settings is needed for it to work properly, or causes it not to work - but we really need more test data. So far nobody in this thread reported their experience with N-speed connections.

    And guys, when posting your negative or positive experiences, please state the detailed configuraion. Don't just say "it doesn't work" - it means nothing...
  5. though

    though Network Guru Member

    ok, below are my results. the problem still exists after i used Dr. TCP to change the Tcp Receive Window to 128480. it was at 64000 before... i assume you *are* referring to the 'Tcp Receive window' in Dr. TCP on the pc's and not on any settings on the RT-N16's, correct?

    « TCP Analyzer Results »
    Tested on: 01.15.2010 19:23
    IP address:
    Client OS: Windows XP

    TCP options string: 020405b40103030101010402
    MSS: 1460
    MTU: 1500
    TCP Window: 128480 (multiple of MSS)
    RWIN Scaling: 1 bits (2^1=2)
    Unscaled RWIN : 64240
    Recommended RWINs: 64240, 128480, 256960, 513920, 1027840
    BDP limit (200ms): 5139kbps (642KBytes/s)
    BDP limit (500ms): 2056kbps (257KBytes/s)
    MTU Discovery: ON
    TTL: 119
    Timestamps: OFF
    SACKs: ON
    IP ToS: 00000000 (0)

  6. TurtleFang

    TurtleFang Addicted to LI Member

    I get higher than G speeds, though not the highest that N can theoretically support.

    I have two Apple laptops, each of which support some form of N (pre-N, N.. I don't recall)

    Here is the output from one, you can see that it's max datarate is 130Mbps:

    $ /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -I
    agrCtlRSSI: -46
    agrExtRSSI: 0
    agrCtlNoise: -96
    agrExtNoise: 0
    state: running
    op mode: station
    lastTxRate: 130
    maxRate: 130
    lastAssocStatus: 0
    802.11 auth: open
    link auth: wpa2-psk
    MCS: 13
    channel: 2

    The other laptop connects with a max rate of 144Mbps. When I connect each to my WL500GPv2, both report a max value of 54Mbps.

    I didn't check against Asus firmware, and have no plans to go back just for that.

    My setup at the house is less than optimal, so I'm not surprised that I can't reach 300. Also, I've not tweaked the wireless settings much at all.

    So yes, RT-N16 with teddy_bear's image does support higher than G data rates. The driver works as expected. For me not the uber-300Mbps max theoretical but that's more an environmental issue with my setup, me thinks.

    Rest assured, you are NOT capped at G speeds.

    Hope this helps,
  7. Azuse

    Azuse LI Guru Member

    Umm, in theory G is 54mb, in reality its around 22-28mb. N follows the same pattern, although 130-145 is perfectly reasonable with afew walls/interference.
  8. cariyawa

    cariyawa Addicted to LI Member

    OK.. you told me to be brave and I did. Right now everything is working fine.

    Local transfer rate from my server in LAN is higher than that I can get from DD-WRT. I am happy :biggrin:

    I am going to transfer a large file(~20GB) from my LAN and see what happens. As I said this was the problem that I had with DD-WRT. I'll post what happens!
  9. cariyawa

    cariyawa Addicted to LI Member

    transfered 20GB file, two times. Didn't see any problem. No re-starting...Great and thanks TB for your excellent work :)
  10. though

    though Network Guru Member

    i, too, can confirm that i have transferred huge files to/from my RT-N16's both by wired and wireless and they are rock solid, no crashes....

    just having a speed issue that i am trying to figure out a few posts back.....
  11. joew333

    joew333 LI Guru Member

    For mixed mode to work so your devices always run at the highest speed:

    1) In Basic Wireless, select Wireless Mode = Auto (default setting)
    2) In Advanced Wireless, select Transmission Rate = Auto (default setting)
    3) In Advanced Wireless, select WMM = Enable (not a default setting)

    Now my G devices connect at 54 MB/s and N devices at speeds from 130 MB/s to 300 MB/s
  12. cariyawa

    cariyawa Addicted to LI Member

    Can you please tell us your settings:
    1. TX power ?
    2. Wireless security using?
  13. joew333

    joew333 LI Guru Member

    Wireless Settings RT-N16 Teddy Bear Tomato

    1) In Basic Wireless
    --select Wireless Mode = Auto (default setting)
    --select Channel Width = 40 Mhz
    --select Security = WPA/WPA2 Personal
    --select Security = TKIP /AES

    2) In Advanced Wireless
    --select Transmission Rate = Auto (default setting)
    --select Country/Region = Japan (default setting to get 14 channels)
    --select WMM = Enable (not a default setting)
    --select 802.11n Preamble = Mixed Mode (default setting)
    --select transmit power = 39 Mw (not a default setting, this is the same as 16db)

    I have been running like this for more than a week. It is very stable and the unit does not run hot. Connections are strong and stable from devices all over the house. Under Tools -> Commands run "wl txpwr" and "wl txpwr1" to confirm your wireless transmit power result as below:

    16.0 dBm = 40 mw.
    TxPower is 64 qdbm, 16.0 dbm, 40 mW Override is Off

    GO TEDDY BEAR!!!!!!!!!!!
  14. mau108

    mau108 Addicted to LI Member

    SWEET! got mine setup right now. Used the Asus Firmware Recovery tool.

    Loving it soo far, haven't done much of a wireless test, just replaced my dlink gigabit switch/wrt54g v2 combo.
  15. cariyawa

    cariyawa Addicted to LI Member

    I am HAPPY as it can get. I am running RT-N16 for almost 2 days with huge LAN load. I don't have any problem. I set the TX power to 20mw for the safe side. Still I have a really good signal strength(80-85%) every where in my house. Actually I don't see this as a BETA version.:biggrin:

  16. deboyz1014

    deboyz1014 Addicted to LI Member

    Updated report.

    Changed from 20mhz to 40mhz
    Changed from TKIP + AES to AES only

    So far no disconnection after about ~20 gig of wireless transfer.
  17. HKPolice

    HKPolice Network Guru Member

    Is there jumbo frame support with this switch??
  18. soldier

    soldier LI Guru Member

    Hi everybody

    First of all THANK YOU teddy bear for this release. I was hoping that RT-N16 would be able to run Tomato. Before a got it I was all over the dd-wrt forum and Wiki.
    I first installed dd-wrt (big edition) and I was testing it for couple of hours and really can’t say much about it, just that it has a lot of settings. I said OK, I will try also tomato, just to see a little and compare with and I think I will stick with it. I read all the posts and they are very very helpful. Thank’s for that to everybody. Right now I don’t have any isuses with this great firmware, I was transferring some files (not much, about 500Mb) wired and wireless, opened some ports, everything OK, no issues.
    Connected my HP Photosmart C4380 and WD Passport 500Gb, recognized immediately, but didn’t have time to see if everything works OK.

    Will continue testing
  19. ledan

    ledan Addicted to LI Member

    Hi. Just got a new Asus RT-N16 I tested large file transfer with a 6 gigs file with 40mhz bandwidth, 20mhz bandwidth, with WPA2-AES, without security, network mode AUTO, network mode N only....result is always de same ! My laptop is using Dell 1510 wireless card with lastest broadcom driver. I tested with my laptop being around the router to obtain higher speed(between 8 and 12 mbyte/s). The only difference I have been able to see is when I use 20mhz or 40mhz bandwidth....

    Asus firmware :
    The connection drop within 30 second on 40mhz with speed around 10-12mbyte/s.
    The connection drop within 5 minutes on 20mhz with speed around 8-9mbyte/s.

    Asus firmware:
    The connection drop within 30 second on 40mhz with speed around 10-12mbyte/s.
    The connection drop within 5 minutes on 20mhz with speed around 8-9mbyte/s.

    Tomato fimware:
    The connection drop within 30 second on 40mhz with speed around 10-12mbyte/s.
    The connection drop within 5 minutes on 20mhz with speed around 8-9mbyte/s.

    DD-WRT firmware:
    The connection drop within 30 second on 40mhz with speed around 10-12mbyte/s.
    The connection drop within 5 minutes on 20mhz with speed around 8-9mbyte/s.

    I suspect the problem to be hardware and not firmware related. I am going to exchange mine and hope to have another without the problem. What do you think ?
  20. bogderpirat

    bogderpirat Network Guru Member

    tried with a different laptop/nic? at least that seems to be lowest common denominator here...
  21. ledan

    ledan Addicted to LI Member

    No I didn't because I only have one with wireless N and the connection drop seems to occur et higher speed.
  22. ledan

    ledan Addicted to LI Member

    Can someone who does not have large file transfer problem can confirm that it works great with a large file at speed of 10-12 mbytes/s ?
  23. cariyawa

    cariyawa Addicted to LI Member

    nope.. I did transferred a large 20GB file twice.. but didn't reach that speed. probably 6-8MB/s(using N)... and also I was quite happy about that.. but I noticed one other thing.. The G client that I had some intermittent disconnections.. I'll post future findings... ::confused:
  24. teddy_bear

    teddy_bear Network Guru Member

    I too, as cariyawa, can't get file transfer speeds over wireless faster than 6-8 MB/s ("Auto" mode, 40 MHz, WPA2PSK+AES) - which is still 3 to 4 times faster than I could get with my G clients. But with these speeds I have no connection drop-outs or lock-ups.

    My only N client now is another Tomato RT-N12 router running in Wireless Ethernet Bridge mode. Both routers have all default settings in "Advanced-Wirelss" except WMM enabled, country set to US, and Tx power set to 20 mW.
  25. though

    though Network Guru Member

    teddy bear,

    WMM is disabled by default. what does it do or not do????
  26. ledan

    ledan Addicted to LI Member

    To obtain this speed, I was close to the router. I suspect that it can be related to the speed as it require more from the router. Faster the transfer was and faster the connection drop occured...
  27. teddy_bear

    teddy_bear Network Guru Member

    The thing is that with WMM being off I could not get N-speed connection between RT-N16 and RT-N12 - they only communicated at G-speed. Maybe because of other G-clients being connected at the same time, I don't know. Turning WMM on fixed that (who knows why!), so I'll probably make WMM on by default in the next build.

    Yep, could be the higher speed. However, I can't get more than 8 MB/s even with routers next to each other... Maybe I need to try with security off.

    Have you been able to achieve higher speed with dd-wrt than with Tomato? If so, did dd-wrt crash during the higher speed transfers? Also, do you have more details on your G-clients "intermittent disconnections"? Any special conditions for this to happen? What are these clients?
  28. cariyawa

    cariyawa Addicted to LI Member

    Nope. It is almost the same

    For DD-WRT, speed doesn't matter. It crashes. But I believed that it happens when dealing only with N- wireless clients. I'll check that too!

    I noticed this only once. I'll try to repeat the process again. G-Client is a WinXP and security is same as yours in your early post. As I have noticed it happened while the 20GB transfer is occurring between N-Client and the wired Server. As I have said earlier, I'll try to repeat the process after I go home, with the same conditions.
  29. gingernut

    gingernut LI Guru Member

    I linked to an article by Tim Higgins at SNB in one of my earlier posts where he explained why WMM has to be enabled by default on wireless N routers/access points to achieve higher than wireless G thoughtput.

    Here's an extract from it:

    Basically, the 802.11n spec requires devices to support 802.11e (Quality of Service [QoS] enhancements for wireless LAN) in order to use HT (High Throughput) link rates, i.e. higher than 54 Mbps. (WMM is a subset of 802.11e that was created by the Wi-Fi Alliance as a stop-gap measure while 802.11e made its way slowly through the IEEE review process.) WMM's Traffic Identifier (TID) field is key to aggregation mechanisms, including block acknowledgement (block ACK), that enable 802.11n's high throughput rates.

    Since WMM support is required for products to be certified for 802.11n, WMM comes enabled by default in all Wi-Fi Certified n APs and wireless routers. So even if you don't have any WMM-aware devices on your network, leave WMM enabled or you may find your clients connecting only at 54 Mbps rates.
  30. gingernut

    gingernut LI Guru Member

    These are my test results using JPerf.

    Wireless Network mode: Auto
    Wireless Channel: 11 (Upper Channel 9)
    Channel Width: 40MHz
    Security: WPA/AES
    TX Power: 20
    WMM Enabled

    Client 1: Intel Wifilink 5300 AGN Connected @ 300Mbps (RSSI:-35dBm Quality:42)
    Client 2: Intel wifilink 4965 AGN Connected @ 144Mbps (RSSI:-35dBm Quality:42) (Max for this adapter on 2.4GHz band)

    Wlan to Wlan: Max 4.73 MB/s

    Lan to Wlan: Max 6.55 MB/s
  31. TurtleFang

    TurtleFang Addicted to LI Member

    Just a friendly reminder for those newer to networking, and might be confused by what appears to be slow data rate speeds.

    Data rates are usually advertised (and the specs defined) in mega-bits per second... while many OS's will report in mega-Bytes per second.

    So folks expressing 8MBps (note the upper case 'B', the standard short form for bytes) are experiencing 64Mbps (note the lower case 'b', the standard short for for bits).

    Generally speaking (99% of the time these days) most systems consider a byte to be eight (8) bits of data. So 8MBps * 8(bits in a byte) = 64MBps... which is already higher than even the theoretical max throughput of 802.11g (54Mbps).

    One other thing to keep in mind as others have mentioned, is that the protocol speed on any shared medium (most LANs) interface such as ethernet (especially when in half duplex but also true to a lesser extent when in full duplex) and wireless is max theoretical and usually not attainable in practice. Conversely, most point to point network interfaces such as T1, OC3, etc can pass data at full link speed.

    Hope this helps,
  32. ladysman

    ladysman Network Guru Member

    I finally loaded the firmware and am now using it. Man is it fast. I'm beating on it right now as a matter of fact. :biggrin:

    I noticed better speed in speed tests using the ASUS.
    Here is one I just did. This is while downloading tons of updates to 6 macbooks all while doing this test.

    I have been playing around with the wireless settings as well. I noticed that when WMM is enabled and No ACK is set to enable, the iphones and 1 Windows 7 notebook (Intel 5100 AGN card) won't connect. So I changed it back. All I was doing was playing around with the settings.

    One question, what are you guys using as a channel? Auto or are you selecting it? Mine is on 1 since nobody around me is on it. My 2 repeaters are on 3 and 5 as well.

    Anyone think we need another thread just for Wireless N16 settings maybe? Just a thought because I see different things scattered all over this thread.

    All in all, I love that I can now have my printer connected and no longer need a PC running. My wife is more in love with that though.:wink:

    Glad I have this router now. Even more glad I have another one on the way. :)

    I might buy an external drive just to play with that too.

    Edit: Forgot to mention I streamed HD content all day via wireless on one of my Apple TV's and never had an issue.
  33. Edrikk

    Edrikk Network Guru Member

    I am jealously awaiting word from Teddy_Bear (or anyone who has tried) to see whether this works on Linksys WRT610Nv2. (The v2 is the same h/w as the RT-N16 as far as I know).

    I miss Tomato so much! :(
  34. cariyawa

    cariyawa Addicted to LI Member

    I just want to confirm(at least for me) that DD-WRT file transfer fails, only when using a wireless N-client. If G-client is used(or after set to G-only mode in DD-WRT, even with N-Clients), it worked flawlessly. So I think If we test tomato, we should focus specially on large file transfer using wireless N-clients in mixed mode. Hope this helps! :biggrin:
  35. kosiko

    kosiko Addicted to LI Member


    I like to have a tomato firmware with kernel 2.6. Will you add support to WL-500GP V2 or WRT54GL.

  36. Toastman

    Toastman Super Moderator Staff Member Member

    ladysman, remember that channel 1 overlaps adjacent channels. The next one that won't interfere with it is channel 6, then channel 11. You might find a lot of interference with 1,3, and 5, be careful of drawing any conclusions if you test speeds.

    Also, anyone testing the speed, please make sure that you are not too close to the router, or the receiver will overload and you may get poor throughput. Stick to at least 2 meters away.
  37. ladysman

    ladysman Network Guru Member

    OK, thanks on the channels. I'll mess with it more when I get home. So I should have them set to 1,6 and 11?
  38. Toastman

    Toastman Super Moderator Staff Member Member

  39. Engineer

    Engineer Network Guru Member

  40. greenythebeast

    greenythebeast LI Guru Member

  41. Troydm

    Troydm Addicted to LI Member

    i do have some disconnects to when transfering files from samba (watching hd quality movie using smb) using wireless-n (intel 5300) laptop. however it only happens when my link quality is below 70% (on Ubuntu) and I'm two walls far from the router. tests using iperf showed the same results. first few seconds transfer rate around 23 MBits/s and then disconnect from wireless. link quality is little bit lower than good e.g. 66-67%. however maybe this is just and linux intel 5300 wireless adapter issue. I also have DIR-655. and same distance same place iperf test showed transfer rate around 30-40 Mbits/s without disconnects so i little doubt the wireless adapter problem, maybe just compatibility between wireless devices i don't know.

    my wireless settings are standart 40 Mhz channel, WPA2-PSK AES, WMM Enabled (No ACK)
  42. teddy_bear

    teddy_bear Network Guru Member

    Is there anyone here who experiences the disconnects during wireless transfer (so far I was unable to reproduce this problem), and has a serial console and can get a console output when disconnects occur?

    There might be nothing interesting there, but maybe there's a kernel oops or something...
  43. soldier

    soldier LI Guru Member

    I have done some testing and here are the results:

    Settings which don't work for me:
    Wireless Network mode: Auto
    Wireless Channel: 13 (free after the scan)
    Channel Width: 40MHz
    Security: WPA/WPA2 Personal
    Encryption: TKIP/AES
    TX Power: 17
    WMM Enabled

    I got the connection but it was constantly dropping, internet was slow, and the connection speed was 150Mbps on Atheros AR9285 in my Asus notebook. If I disabled WMM the connection was good until next reboot. Notebook is N capable. I was changing the TX power to 20, 22, 25, 39 and 42mW with no big difference in signal strength. With auto mode my mobile phone couldn’t connect to network as well.
    Overall N connection or Auto is very unstable for my notebook.

    This setting works good:
    Wireless Network mode: B/G Mixed
    Wireless Channel: 4 (also free after the scan)
    Channel Width: 20 MHz
    Security: WPA Personal
    Encryption: TKIP
    TX Power: 39
    WMM Disabled

    With this setting it connects immediately, internet is fast enough, connection speed 54Mbps like it should be and streaming full HD video from LAN to WLAN goes smoothly. I didn’t test the speeds but in the future I will.

    I also noticed that changing TX power from 17-42 didn’t make any difference in signal strength.

    To be continued
  44. joew333

    joew333 LI Guru Member

    Reboot after changing settings

    I have observed that the actual transmit power does not always change after you update the advanced wireless settings.

    To check, go to Tools - System and enter "wl txpwr" and "wl txpwr1". This will confirm your power setting.

    If you do not see the correct settings, reboot the router OR clear NVRAM and load your configuration again (do a backup first).

    I am running at 40 Mw which is 16 db and I have great connectivity.
  45. ladysman

    ladysman Network Guru Member

    Mine is set to 35 and i've never rebooted the router. When i do the second command I get: TxPower is 127 qdbm, 31.75 dbm, 1496 mW Override is Off

    First command = 31.75 dBm = 1496 mw.

    So you may be right. I'll reboot in a minute.

    Edit, same even after a reboot.
  46. cariyawa

    cariyawa Addicted to LI Member

    I had the same issue..but unfortunately I can't remember what I did to solve that(I know that doesn't help)... So try to unplug the router and keep it unplug for 3-5 minutes.. Then plug and try again. May be that is what I did :)
  47. though

    though Network Guru Member

    i just transferred an 18gb file from my desktop to my laptop via wireless (N-only) while i had slingbox HD running on my laptop and had no problem. my N16 is absolutely rock solid with this firmware.

    im also running a WDS setup at another location with 2 N16's and 2 N12's and that setup is absolutely rock solid as well!

    Teddy Bear..... you rock! thanks again and keep up the great work
  48. rviteri

    rviteri Addicted to LI Member

    Please include OpenVPN with ebtables in the kernel!
  49. stallmen

    stallmen Addicted to LI Member

    Now that we have a Tomato capable router with a large amount of memory, has anyone tried modifying one of the ad block scripts to load a large blocklist? I'd love to use one of these lists at the router level to protect my whole network.
  50. gingernut

    gingernut LI Guru Member

    If your phone is from the USA it will not connect on channel 13, region restricted.
    Also remember that channel width @ 40MHz uses 2 wireless channels, main & extension, so could be interference.
  51. HKPolice

    HKPolice Network Guru Member

    I guess no one cares if this router's switch supports Jumbo frames or not? :(
  52. Toastman

    Toastman Super Moderator Staff Member Member

    Are we seeing N incompatibility problems?

    Just wanted to add my thoughts. Seems to me after reading all the posts that some of the problems people are having with connection are probably not down to the new Tomato beta. There are posts on this thread about some people connecting fine with one PC/wireless card while another has problems on the same router. Other forums which cover Draft "N" routers more heavily than this one show that there is a big, big problem with compatibility between various client wireless cards and routers by many different manufacturers. I suppose this will settle down in time as new driver upgrades correct things (hopefully).

    In the meantime, can people also post details of their wireless cards/adapters if they have problems, and also try to see if a problem occurs with all wireless cards? Maybe we will see a pattern.

    EDIT - The pattern I see is that INTEL cards, as usual, cause headaches.
  53. though

    though Network Guru Member

    in my WDS setup, i use 4 asus routers and have zero problems whatsoever. at another location i use a sony laptop a N16 on N-only and also have zero problems....

  54. cariyawa

    cariyawa Addicted to LI Member

    I transfer almost >1TB of data back and forth(wireless <->wired) and I couldn't reproduce any errors that I noticed earlier. So in that case, I may have to conclude that most problems noticed might be faults of my side.. not the firmware...

    Checking continuing...
  55. soldier

    soldier LI Guru Member

    Thanks everybody for your inputs and opinions.

    Phone is European, I will try changing channel

    I also suspect that there might be wireless card incompatibility issue

    I would really like to see from you guys, who have rock solid connections while transferring all kind of data wired and wireless, what are your settings. Please be so kind and put your settings here, just to compare and try them if they work for us (problems with N).

    I will keep testing
  56. teddy bear build capabilities

    Hello All. I'd like to congratulate Teddy on his amazing accomplishments. I am currently in the market to replace my gateway router, and this looks like a perfect candidate, especially using this firmware. I have scoured this thread and haven't yet found a post to confirm and answer my questions. Therefore I figured I'd post them. Can anyone confirm the following:

    1: Does this tomato build support USB external hard drive media serving to an Xbox 360?

    2: Does this build support bit torrent downloading?

    3: Does this build support game blaster QOS per IP, while running bit torrent.

    4: If yes to all questions above, have there been crashes or issues running QOS, SMB Xbox 360 media streaming, print serving, and bit torrent downloader all at once?

    I definately want to add this router to my cart, and start re-flashing next week. Thanks in advance for all the help that anyone can provide
  57. ladysman

    ladysman Network Guru Member

    I created a seperate thread so we can keep track of the wireless stuff on this Router.

    Hopefully others think it's a good idea.:)
  58. mstombs

    mstombs Network Guru Member

    Damn you teddy_bear, I had to spend my pocket money to join in the fun!

    Before I flash this mod - is there way to enable telnet/ssh on Asus firmware ( so I can have a poke around before dumping?

    One thing I am interested in is that it works out-of-the-box with my half-bridge pppoa adsl modem, normal Tomato or dd-wrt doesn't, needs a couple of firewall commands to fix routing.
  59. teddy_bear

    teddy_bear Network Guru Member

    Not sure if telnet is included into the standard Asus firmware, but you can access the hidden "System Command" page as
    There was also a modified version of Asus firmware with Telnet enabled by default floating around - I think you can find links on DD-WRT or Asus Oleg's forums.

    What kind of connection do you have - PPPoE, PPTP, L2TP? Asus now uses a lot of enhancements from Oleg's firmware - did you check if Oleg's firmware works out of the box with your modem as well (not on N16, since it's not ready for it yet - but maybe on another Asus)?

    (1) and (2) are not included, but can be easily installed as Optware packages. Especially a media server (ushare) - takes 2 mins to install and doesn't need any configuration (other than the shared folder). Although I'm considering to add both to the N16 firmware, it may never be done - they are pretty low in the priority list, and besides Optware packages may even be better option (give you more flexibility).
    (3) - not sure what "game blaster QOS per IP" is, but most probably you don't need any kind of IP-based QOS (unless it's a special case with monthly limit or very low bandwidth). The regular priority-based QOS in Tomato is very good - you can find several threads on this forum discussing it in details.

    Definitely try different channels. "Free" as shown by Wireless Survey doesn't necessarily mean "the best" channel - there could be other interference from different RF sources...

    The switch supports jumbo frames - yes. But I don't know if this support is "enabled", and if anything needs to be done on the software level to enable it.
  60. cariyawa

    cariyawa Addicted to LI Member

    I can't break this.. I tried so hard.. I gave up:boxing2:
  61. though

    though Network Guru Member

    break this?
  62. mstombs

    mstombs Network Guru Member

    Thanks already, that system command is good enough. The ASUS firmware has telnetd, and I can start it with "utelnetd" (and open up iptables port), but can't get it to work, maybe it needs passwd and shell defined somewhere, but I have now crashed the ASUS web gui...

    I have dhcp WAN but the gateway is not in the network defined by the WAN IP and netmask (its my script code generating this in the modem, to avoid 'spoofing'). Its easily fixed, infact there's an example further down in your rc/wan.c for l2tp "fixed routing problem in Israel by kanki", I'll be brave enough someday to attempt to commit a fix, because at present the code tries and fail 5 times to set the default route.

    And no, I don't have or need another ASUS... I could debug on my TM which has serial console+JTAG...

    Still haven't flashed your firmware, the ASUS GPL is taking forever to get here...
  63. cariyawa

    cariyawa Addicted to LI Member

    Yes...:biggrin: I mean.. RT-N16 with tomato works perfectly for me...even after hammering this thing using so many different ways, still it is rock solid!
  64. Maxwell

    Maxwell Addicted to LI Member


    I don't own one of these (yet) but the following should work as it does on Linux machines. Telnet into the router and run the following command. If jumbo frames are enabled the MTU value returned will be 9000.
    ifconfig vlan0 | grep MTU
    If that is not the case the following should enable jumbo frames on the LAN ports. I'm not sure how to restart the networking interfaces after the command is set or where this may be added so it is set before the networking interfaces start in the case of Tomato though.
    ifconfig vlan0 mtu 9000
  65. teddy_bear

    teddy_bear Network Guru Member

    Doesn't work here:
    ifconfig: SIOCSIFMTU: Numerical result out of range
    for any values higher than 1500.

    Some discussions on dd-wrt forum point out that the Broadcom et driver doesn't include support for jumbo frames.
  66. mstombs

    mstombs Network Guru Member

    Now got it and they have a very elegant solution to the WAN routes issue, and all routines clearly prepped for multiple WAN interfaces i.e. "add_wanx_routes"!
  67. Eambo

    Eambo Addicted to LI Member

    What's the best way to abuse the amount of connections on it? =-P I've been having issues for months with routers stopping working, sounds very much like a lack of connection handling, so I'm hoping this router (when it arrives next week) will be the answer to all my issues.

    If you could try to hammer the connections for me, or tell me how to do it, and tell me how long before it implodes, would be much appreciated =-)
  68. bigclaw

    bigclaw Network Guru Member

    What level of risk is it to swap among the stock firmware, dd-wrt, and Tomato on this router? Has anybody bricked the router yet?

    Would like to gauge the risk before purchasing one, considering that it's going to be heavily experimented with... :)
  69. cariyawa

    cariyawa Addicted to LI Member

    I have a local SSH/FTP Linux server setup and I transferred same 20GB file from the server using two SSH connection and one FTP connections to the same wireless N capable client.

    These are my observations.
    1. Using FTP, I could transfer without any problem
    2. First time, I used SSH to transfer 20GB file and router restarted.
    3. Just to make sure, I opened multiple connections(2-SSH and 1-FTP for the same file) and started the transfer. After a 10-15minutes, I closed one SSH sessions and the FTP sessions. Again router crashed and restarted.

    I am going to try another single SSH session and see what is going on
  70. cariyawa

    cariyawa Addicted to LI Member

    I think this router is very solid in switching firmwares. I swapped in between dd-wrt, stock and tomato more than 15:)biggrin:) times and I didn't have any problem.
  71. soldier

    soldier LI Guru Member

    @teddy bear
    I would also be very happy if you could put bittorrent downloading function.

    I have one noob question regarding QoS. I have 3 computers in the house. Is it possible to limit bandwidth using IP or MAC addresses? For example comp with IP (or MAC address) 100% bandwidth usage, IP 2 60% and IP 3 50%. I’m only interested if this is possible with Tomato, not with different software installed on the computer.
  72. cariyawa

    cariyawa Addicted to LI Member

    I was able to reproduce it. This is what I did.

    1. just to make sure I have a fresh start, I turn off router for about 5 minutes and restarted it.
    2. started SSH client(FileZilla) in my laptop which has Ubuntu 8.04LTS(Intel Wireless WiFi Link 4965AGN)
    3. My server is Ubuntu 8.04 LTS and it is connected to the router using 100Mbps .
    4. I used encryption WPA/AES and have 78-85% signal strength
    5. During the transfer, I have a putty terminal opened for router(with SSH) and top was running
    6. Router crashed/restarted after about 4.5GB transfer

    I'll try one more time...
  73. Troydm

    Troydm Addicted to LI Member

    I watch movies (hd quality) streaming from samba server connected by lan to wireless-n clients mac mini (n capable) and laptop (intel 5300 n capable), and from time to time router crashes and reboots, it happens like 2-3 times a day.
  74. Eambo

    Eambo Addicted to LI Member

    Gah, this is worrying. I've had similar issues on a lot of routers >.< Hope this isn't common on this one.
  75. though

    though Network Guru Member

    it's gotta have something to do with the wireless adapters (driver of the N16 or driver of the wireless client or clients connected to the N16) doesn't it? all my N12's and N16's are connected to each other wirelessly and get hammered by sling streaming, large web activity, ftp transfers, hulu, youtube, torrents, and they are SOLID!
  76. teronzhul

    teronzhul Addicted to LI Member

    I know that victek's Tomato mod has an IP/MAC bandwidth limiter within Tomato that I've used in the past. Since I have yet to acquire an RT-N16 I can't say whether it is included in teddy_bear's build, but I would assume it isn't based on the notes and changelog he has provided.
  77. cariyawa

    cariyawa Addicted to LI Member

    OK... it happened again. After crashing/restarting last time... I started a single SSH transfer(+putty shell open with top) and transfer occurred until about 35%... Seems like no crashing.. So I was impatient..:frown: Then issued halt command for the router.. wait at about 5 minutes and restarted it.. Then again I started the transfer with same conditions.. It crashed and restarted after 1.1GB transfer. So at least for me.. it is confirmed and I can reproduce it.
  78. soldier

    soldier LI Guru Member

    @teddy bear
    Can you provide any answer on that, please
  79. stallmen

    stallmen Addicted to LI Member

    I doubt adding BitTorrent is high on the list of things that need to be done to this build. From the sound of it there are much bigger issues that need to be worked out first. Take a look at DD-WRT if you really want BitTorrent support. There's an add-on that will install Transmission.
  80. teddy_bear

    teddy_bear Network Guru Member

    No, the IP limiter is not included.
    Search the main USBmod thread for "limiter", and you'll find more details and some workarounds.
    But first ask yourself whether or not you really need it. Unless you have a monthly bandwidth cap imposed by ISP, you most probably don't. For all other purposes regular properly configured Tomato QoS should work.

    As for the torrent client, you can install any of the available ones from Optware - transmission, ctorrent, rtorrent etc. It's really not very complex to learn how to install it (and will be even easier after Ray123 will publish his write-up :) ). This way you can choose which client you like better. For example, many think the rtorrent is the best one, but it doesn't work nice with FUSE in this kernel, so you can't use it if you want to download files to NTFS partition...
  81. protteus

    protteus Addicted to LI Member


    I can´t access and from Lisbon Netcabo with this router with Tomato. All the rest is fine.

    Can access with TMN Huawei and could access yesterday with Asus Wl500gp w/ Tomato Victek.
  82. mschulze

    mschulze Addicted to LI Member

    QoS using Src MAC address

    There might be a small problem with QoS. If I give my VOIP phone highest priority using Src MAC address, weird things happen: all connections become "Unclassified". After a while the internet connection stops working. Stopping QoS gets it back to normal.
    If I use Src IP address instead Src MAC address, everything seems to work fine. However the Src MAC address method was working with tomato on my WL520gU.

    So far no other problems. Many thanks to teddy_bear for this great job!!!
  83. teddy_bear

    teddy_bear Network Guru Member

    Please post the output of the following commands with MAC QoS configured:
    iptables -L -n
    cat /etc/qos
    cat /etc/iptables
    cat /etc/iptables.error
  84. protteus

    protteus Addicted to LI Member

    I have one WL500gp with tomato victek, one wrt54gl also with tomato victek and everything was doing fine.

    I went to buy a rt-n16 as soon as i knew that there was tomato firmware support for it.

    Loaded dd-wrt and next tomato, doing exactly like it was told in the forum.

    No complains, except that part of being impossible to get and reported those sites being active!!!

    those two sites ip are in the 62.xx.xx.xx area strangely!

    i could ping other ip but those not.

    Very strange indeed
  85. Toastman

    Toastman Super Moderator Staff Member Member

    soldier, the problem is that limiting people in the manner you suggest doesn't really help. I don't want to hijack the thread, so a brief comment:

    Assume you let a user use 30% of your upload bandwidth. Then he runs a P2P client, and requests three or four popular seeds. Within ten minutes, your incoming bandwidth will probably be taken up with P2P traffic, and nobody else can use the web.

    Just a simple illustration, but that is the difference between QOS and simple limiting. However, if simple limiting is what you want to do, then you can still do it with regular QOS.
  86. mschulze

    mschulze Addicted to LI Member

    Tomato v1.27.9042 RTN16-beta02 ND USB Ext

    BusyBox v1.14.4 (2010-01-06 13:23:33 EST) built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    root@router:/tmp/home/root# iptables -L -n
    Chain INPUT (policy DROP)
    target prot opt source destination
    DROP all --
    DROP all -- state INVALID
    ACCEPT all --
    ACCEPT all --

    Chain FORWARD (policy DROP)
    target prot opt source destination
    ACCEPT all --
    DROP all -- state INVALID
    TCPMSS tcp -- tcp flags:0x06/0x02 tcpmss match 1461:65535 TCPMSS set 1460
    wanin all --
    wanout all --
    ACCEPT all --
    upnp all --

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain upnp (1 references)
    target prot opt source destination

    Chain wanin (1 references)
    target prot opt source destination
    ACCEPT tcp -- tcp dpt:80
    ACCEPT tcp -- tcp dpt:22
    ACCEPT tcp -- tcp dpt:22

    Chain wanout (1 references)
    target prot opt source destination
    root@router:/tmp/home/root# cat /etc/qos
    TQA="tc qdisc add dev $I"
    TCA="tc class add dev $I"
    TFA="tc filter add dev $I"
    Q="sfq perturb 10"

    case "$1" in
    tc qdisc del dev $I root 2>/dev/null
    $TQA root handle 1: htb default 40
    $TCA parent 1: classid 1:1 htb rate 480kbit ceil 480kbit
    # egress 0: 80-100%
    $TCA parent 1:1 classid 1:10 htb rate 384kbit ceil 480kbit prio 1 quantum 1500
    $TQA parent 1:10 handle 10: $Q
    $TFA parent 1: prio 10 protocol ip handle 1 fw flowid 1:10
    # egress 1: 10-100%
    $TCA parent 1:1 classid 1:20 htb rate 48kbit ceil 480kbit prio 2 quantum 1500
    $TQA parent 1:20 handle 20: $Q
    $TFA parent 1: prio 20 protocol ip handle 2 fw flowid 1:20
    # egress 3: 3-100%
    $TCA parent 1:1 classid 1:40 htb rate 14kbit ceil 480kbit prio 4 quantum 1500
    $TQA parent 1:40 handle 40: $Q
    $TFA parent 1: prio 40 protocol ip handle 4 fw flowid 1:40
    # egress 4: 2-95%
    $TCA parent 1:1 classid 1:50 htb rate 9kbit ceil 456kbit prio 5 quantum 1500
    $TQA parent 1:50 handle 50: $Q
    $TFA parent 1: prio 50 protocol ip handle 5 fw flowid 1:50

    $TFA parent 1: prio 14 protocol ip u32 match ip protocol 6 0xff match u8 0x05 0x0f at 0 match u16 0x0000 0xffc0 at 2 match u8 0x10 0xff at 33 flowid 1:10
    tc qdisc del dev $I root 2>/dev/null
    tc qdisc del dev $I ingress 2>/dev/null
    tc -s -d qdisc ls dev $I
    tc -s -d class ls dev $I
    root@router:/tmp/home/root# cat /etc/iptables
    cat: can't open '/etc/iptables': No such file or directory
    root@router:/tmp/home/root# cat /etc/iptables.error
    :OUTPUT ACCEPT [0:0]
    :QOSO - [0:0]
    -A QOSO -j CONNMARK --restore-mark --mask 0xff
    -A QOSO -m connmark ! --mark 0/0xff00 -j RETURN
    -A QOSO -p udp -m mac --mac-source 00:21:04:0D:F0:12 -j CONNMARK --set-return 0x101/0xFF
    -A QOSO -p tcp -m mac --mac-source 00:21:04:0D:F0:12 -j CONNMARK --set-return 0x101/0xFF
    -A QOSO -p tcp -m mport --dports 80,443 -m bcount --range 0x0-0x7ffff -j CONNMARK --set-return 0x2/0xFF
    -A QOSO -p tcp -m mport --dports 80,443 -m bcount --range 0x80000 -j CONNMARK --set-return 0x4/0xFF
    -A QOSO -p udp --dport 53 -m bcount --range 0x0-0x7ff -j CONNMARK --set-return 0x1/0xFF
    -A QOSO -p tcp --dport 53 -m bcount --range 0x0-0x7ff -j CONNMARK --set-return 0x1/0xFF
    -A QOSO -p udp --dport 53 -m bcount --range 0x800 -j CONNMARK --set-return 0x5/0xFF
    -A QOSO -p tcp --dport 53 -m bcount --range 0x800 -j CONNMARK --set-return 0x5/0xFF
    -A QOSO -p udp --dport 1024:65535 -j CONNMARK --set-return 0x5/0xFF
    -A QOSO -p tcp --dport 1024:65535 -j CONNMARK --set-return 0x5/0xFF
    -A QOSO -j CONNMARK --set-return 0x4
    -A FORWARD -o vlan2 -j QOSO
    -A OUTPUT -o vlan2 -j QOSO
    :OUTPUT ACCEPT [0:0]
    -A PREROUTING -i vlan2 -d -j DROP
    -A PREROUTING -p icmp -d -j DNAT --to-destination
    -A PREROUTING -p tcp -d --dport 8080 -j DNAT --to-destination
    -A POSTROUTING -p tcp --dport 80 -s -d -j SNAT --to-source
    -A PREROUTING -p tcp -d --dport 2222 -j DNAT --to-destination
    -A POSTROUTING -p tcp --dport 22 -s -d -j SNAT --to-source
    -A PREROUTING -p tcp -d --dport 22 -j DNAT --to-destination
    -A POSTROUTING -p tcp --dport 22 -s -d -j SNAT --to-source
    :upnp - [0:0]
    -A PREROUTING -d -j upnp
    :INPUT DROP [0:0]
    :OUTPUT ACCEPT [0:0]
    -A INPUT -i br0 -d -j DROP
    -A INPUT -m state --state INVALID -j DROP
    -A INPUT -i br0 -j ACCEPT
    -A INPUT -i lo -j ACCEPT
    :FORWARD DROP [0:0]
    -A FORWARD -i br0 -o br0 -j ACCEPT
    -A FORWARD -m state --state INVALID -j DROP
    -A FORWARD -p tcp --tcp-flags SYN,RST SYN -m tcpmss --mss 1461: -j TCPMSS --set-mss 1460
    :wanin - [0:0]
    :wanout - [0:0]
    -A FORWARD -i vlan2 -j wanin
    -A FORWARD -o vlan2 -j wanout
    -A FORWARD -i br0 -j ACCEPT
    :upnp - [0:0]
    -A FORWARD -i vlan2 -j upnp
    -A wanin -p tcp -m tcp -d --dport 80 -j ACCEPT
    -A wanin -p tcp -m tcp -d --dport 22 -j ACCEPT
    -A wanin -p tcp -m tcp -d --dport 22 -j ACCEPT
  87. soldier

    soldier LI Guru Member

    @teddy bear
    Thanks for explanation; I will try to install some torrent client from Optware

    That’s what I want to do: my download speed from ISP is 20Mb. If I configure user with IP to 50% of the bandwidth he will get only 10Mb available. Did I understand you correctly?

    And some more testing results. As I wrote few post before that connection to N didn’t work for me. I managed to connect it thanks to teddy bear and somebody else by changing the channel. I changed to 4 and everything works good. But not perfect.
    Here are my new settings:
    Wireless Network mode: Auto
    Wireless Channel: 4 (free after the scan)
    Channel Width: 20MHz
    Security: WPA2 Personal
    Encryption: AES
    TX Power: 39
    WMM Enabled
    Connection speed of the WLAN card is 65Mbps, internet is fast.
    Transfering files with wireless notebook in both ways (WLAN to LAN and LAN to WLAN) around 5Mbps.
    If I change the Channel width to 40Mhz, wireless card connects to 150Mbps, but the internet is way too slow, pages are opening like I have 512/128 connection. File transferring around 130Kbps both ways.
    I’m seriously thinking that Atheros chip (WLAN card) is causing those problems.

    And one other thing. When transferring files to my HDX media player, from PC to player through router I can only get around 2,5Mbps speed, but before with old Linksys router I could get 7-10Mbps.
    PC connects to router with 1Gb but media player only have 100Mb connection. Should I change PC LAN adapter to 100Mb full duplex or is there something else.
    I ANSWERED ALREADY. Configured PC LAN adapter to 100Mb Full Duplex and transfer speed to media player is around 7.1 MB/s.
  88. Azuse

    Azuse LI Guru Member

    There is actually a tomato build with a micro torrent client built into it already. Although I'm not very familiar with it, what with me not speaking polish :p
  89. teddy_bear

    teddy_bear Network Guru Member

    Yay, finally a BUG :eek: ! Thanks for finding it!
    Should be easy to fix. In the meantime, do not use MAC match in QoS rules - it effectively disables all your QoS and filtering/forwarding rules as iptables fails to start.
  90. cariyawa

    cariyawa Addicted to LI Member

    max external hard dirve size?

    can somebody please tell me what is the maximum size of external USB hard drive that can be attached to RT-N16?
  91. blackmack

    blackmack LI Guru Member

    Im using Transmission now for torrent client and works fine. So +1 for a built in torrent client with interface on the main page. Would be cool since the router has 32MB of flash.
  92. adrman

    adrman Guest

    I registered just to say thanks for this build. I picked up two RT-N16s this week and have them configured as an AP and a Wireless Ethernet Bridge. Everything seems to be working perfectly.
  93. bigclaw

    bigclaw Network Guru Member a while back had a brief review on DD-WRT and Tomato:

    In this review Tomato seemed to have an abysmal figure (16) for max. simultaneous connections.

    Most newer routers reviewed by the site have max. simultaneous connections at 200, which I believe is the maximum value supported by their test tool.

    Any idea on how well Tomato performs in that department on the RT-N16?
  94. oldkuang

    oldkuang Addicted to LI Member

    Hi TB,
    I am going to install your mod to the newly arrived rt-n16. Where I can find a detail step by step installation guide just for this router? Thanks in advance.
  95. soldier

    soldier LI Guru Member

    All you need is on the first page. I did it through dd-wrt but you can do it with Asus Firmware Restoration Utility also. Still have doubts? Send me PM, will help you with a short tutorial if you want.
  96. soldier

    soldier LI Guru Member

    The same web page provides that data here
  97. The Doctor

    The Doctor LI Guru Member

    I am quite sure the results obtained by smallnetbuilder were accurate, but I doubt they were meaningful. The problem is, in their test the router is the limiting speed factor. This would not be the case in a normal network, the router should be able to handle the full speed of the connection.

    My personal experience has been running a WRT54G-TM on a FIOS 20/20 connection, which was later upgraded to 25/25. I am an extremely heavy P2P user, and typically have between 150 and 400 open TCP connections, as well as quite often over 1000 UDP connections being tracked. I run the connection at full capacity upstream at all times. I have never had any trouble with connections being dropped, or notice any bad effects except, of course, for rather high ping times due to the heavy connection load. And some packet loss if total up/down combined excedded about 40 Mb total, due to CPU overload.

    I am now running 35/35, still full speed ahead on the upstream, with my new Asus RT-N16 using the teddybear Tomato mod mentioned in this thread. Again, hundreds of continuous TCP connections, and well over 1000 connections total, and not a single sign of any problem. No packet loss whatsoever, even when pushing the connection right to its limits, which is not surprising as the CPU is still showing over 25% idle at this point.

    So, go ahead and install Tomato (or DD-WRT, if you prefer). So long as you're not pushing the router past its limits, I don't believe you will have any trouble.

    Good luck

    PS: Thank you once again, teddybear, for some truly excellent work!
  98. oldkuang

    oldkuang Addicted to LI Member

    Thank you so much Soldier. This will be my first time install tomato. I don't even know how to thoroughly erase nvram. DD-wrt said 20/20/20. Is this applied to rt-n16? Is is possible to find a step by step guide somewhere?
  99. bigclaw

    bigclaw Network Guru Member

    Yes, but unfortunately that's with the stock firmware, not Tomato.
  100. teddy_bear

    teddy_bear Network Guru Member

    That review (?) has no practical value because it's (a) almost 2 years old - for old versions of Tomato/DD-WRT, (b) for routers with default settings and no extra configuration performed, and (c) - as The Doctor pointed out - the router is the limiting speed factor in these tests.

    On this forum you can find a lot of genuine discussions and real-life examples of proper Tomato configuration. Here's for example one excellent post with the brief summary of the subject.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice