Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. occamsrazor

    occamsrazor Network Guru Member

  2. natel

    natel Networkin' Nut Member

    well that ... is whole question as you can see ....

    "Extras" as filename says ...
  3. gtj0

    gtj0 Networkin' Nut Member

    The "extras" are kernel modules, most of which are already in the "Extras" and "VPN" releases. If you run one of the smaller releases but need a module or 2 from the bigger releases, you can copy them from the archive to jffs or usb on the router and use insmod to load them.
  4. mstombs

    mstombs Network Guru Member

    loaded and running fine on my WRT54G-TM (yes no usb but I like the Extras!)
  5. natel

    natel Networkin' Nut Member

    thank you gtj0
    for example could not find chown/chgrp .. well these are in coreutils as turns out
    never mind ..
  6. Dashiell

    Dashiell Network Guru Member

    Formatting USB Drives in Tomato on RT-N16 (latest build)

    Sorry if this has been done to death, but I would like to mount a 4GB usb drive on my new RT-N16. I was thinking of using the ext3 filesystem, but I cannot figure out how to format it through the tomato interface. I suppose I could format it on my LinuxMint laptop, but if anyone can help with the commands within the router I'd prefer to do it that way... thanks in advance!
  7. cariyawa

    cariyawa Addicted to LI Member

    loaded my RT-N16 with beta18(upgraded from beta11). Works great. Thanks LOT T.B.
  8. natel

    natel Networkin' Nut Member

  9. sziggle

    sziggle Networkin' Nut Member


    I am running beta 11 which I flashed directly using the asus restore utility.

    now I want to upgrade to beta 18 and I have done some searching but couldn’t find a best practice for doing an upgrade and restoring settings. I have a bunch of port-forwards, static dhcp entries, VPN settings, and tweaks in there that I have gleaned from y’all over the past couple months and I would love to avoid having to go through every page of the admin and copying everything or making screenshots and then manually re-setting it all if possible.

    I know that with the stock tomato firmware you can just go into the admin -> upgrade and upload the new image and all the settings are kept. I hoped that would work with teddy’s builds too, but it didn’t work for me. I got a message that said “error reading file”. so does that mean that I need to use the asus restore utility again? and will that process overwrite all my settings?

    thanks in advance for any pointers.

    EDIT: acchhh! sorry, I am running on an RT-N16
  10. iloveramen

    iloveramen Networkin' Nut Member

    You should be able to just upgrade with no problems through tomato. Try unplugging the router and plug it back in. Then try to upgrade it through the GUI one more time. Also, what browser are you using? I usually use IE for all my FW upgrades.
  11. EricCartman

    EricCartman LI Guru Member

    Thank you Teddy :)

    Teedy for you :)

  12. Elanzer

    Elanzer Addicted to LI Member

    Has anyone tried OpenVPN and/or got it working correctly in the latest revision?

    I've been getting endless grief getting TAP working stable on either RT-N16s with K2.6 and WRT54GLs with SgtPepperKSU's K2.4 OpenVPN build. Both of them are unstable in similar way (periodical router freeze / drops all connections) but have different errors.

    I'm updating firmware remotely and because of the configuration, I can't easily just clear the nvram and reconfigure for the new update, otherwise I will lose my remote connection - anyone know if updating it will disable the broadcom "Fast NAT" module, or if an nvram wipe is required?
  13. madmalkav

    madmalkav Networkin' Nut Member

    I'm having some problems and I'm trying to test if it is fault of the router or the wireless card.

    Latest Tomato USB mod in WNR3500L, client pc running ubuntu x64 with atheros 928X card. In 20Mhz mode it works ok. In 40Mhz mode, lower control channel, it works ok but connection speed is half-N like if it was working in 20Mhz mode. In 40Mhz mode, upper control channel, the connection is unstable, it doesn't dissasociate from AP but if suffers of serious speed lost and unstability -SSH sessions getting lost continuosly, for example-.

    I'm awaiting for a new N card than I'm going to install in my girlfriend notebook and will also try this card in her computer to see if it is problem with the card or the AP. Meanwhile, if someone have similiar issues, or you are running a similar setup and everything is OK, it will be nice to know.

    Thanks for reading.
  14. sziggle

    sziggle Networkin' Nut Member

    hey, thanks for the coaching; power cycling the router and then flashing through the gui worked. I did it via safari 5 on the mac, fwiw. I’d have booted up a VM and tried IE if it hadn’t worked, but thankfully it did.

    thanks also to TB for this great project and all the effort that has gone into it and to supporting everyone using it.
  15. wycf

    wycf Network Guru Member

    Just flashed the new release -Tomato Firmware v1.28.9048 MIPSR2-beta18 K26 USB vpn3.6.

    The OpenVPN Client has trouble to start. The log shows:
    Jul 27 20:19:59 unknown daemon.notice openvpn[709]: OpenVPN 2.1.1 mipsel-unknown-linux-gnu [SSL] [LZO2] [EPOLL] built on Jul 25 2010
    Jul 27 20:19:59 unknown daemon.warn openvpn[709]: WARNING: No server certificate verification method has been enabled.  See for more info.
    Jul 27 20:19:59 unknown daemon.warn openvpn[709]: NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
    Jul 27 20:19:59 unknown daemon.notice openvpn[709]: LZO compression initialized
    Jul 27 20:19:59 unknown daemon.notice openvpn[709]: Control Channel MTU parms [ L:1542 D:138 EF:38 EB:0 ET:0 EL:0 ]
    Jul 27 20:19:59 unknown daemon.notice openvpn[709]: Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:135 ET:0 EL:0 AF:3/1 ]
    Jul 27 20:19:59 unknown daemon.notice openvpn[713]: Socket Buffers: R=[112640->131072] S=[112640->131072]
    Jul 27 20:19:59 unknown daemon.notice openvpn[713]: UDPv4 link local: [undef]
    Jul 27 20:19:59 unknown daemon.notice openvpn[713]: UDPv4 link remote:
    Jul 27 20:19:59 unknown daemon.notice openvpn[713]: TLS: Initial packet from, sid=6178b023 a846498b
    Jul 27 20:20:00 unknown daemon.notice openvpn[713]: VERIFY OK: depth=1, /C=CA/ST=BC/L=DELTA/O=COMPANY/CN=openvpn-gateway2/
    Jul 27 20:20:00 unknown daemon.notice openvpn[713]: VERIFY OK: depth=0, /C=CA/ST=BC/O=COMPANY/CN=openvpn-gateway2/
    With last version, vpn client get connected but can not pass http/ssh/samba traffic. This new release even not connected!

    Does anyone has success on this VPN version?
  16. tsanga

    tsanga LI Guru Member


    Build 48 bricked my WNR3500v2. Going back to the last one you sent me....

    Not sure why WNR3500v2 has such a tough time.
    beta 11 = brick
    beta 14 = ok, but upnp issue with wireless driver
    beta 16 = long time to boot
    beta 18 = brick
  17. ytsejam

    ytsejam Network Guru Member

    Build 48 seems to have broke Anonymous FTP access on my WNR3500L. Can anyone else confirm this?
  18. rhester72

    rhester72 Network Guru Member

    Not sure what's going on here - the code in libcrypto to handle X.509 certificate management isn't even compiled in anymore, so if the OpenVPN config was correct, it would die when trying to access the OpenSSL function (tested manually without launching from GUI).

    OpenVPN also now creates the tap adapter itself (rather than having it created/brought up before the tunnel is established), but doesn't bridge it to br0 - not sure why this change was made, because it's actually a more inflexible solution than the way it was before, even if certificates worked.

    Looks like there was some unfinished development work at play here.

  19. bhall7

    bhall7 LI Guru Member

    I'm having the same issue with the VPN not forwarding any traffic (v1.28.9048 MIPSR2-beta18 K26 USB vpn3.6). I've tried the option to "Direct clients to redirect Internet traffic," but it doesn't work. I've tried changing from TUN to TAP, and tried a myriad of ports, but no luck. Is there a VPN tutorial somewhere for Tomato USB?
  20. onehomelist

    onehomelist Addicted to LI Member

    I highly depend on QOS rules to share my 4 Mbp/s connection with more than 100 users. After I flashed my RT-N16 wth tomato beta18, the web pages load very slowly. It had never happened with any of the earlier beta versions. Earlier, even during peak hours, the web pages used to load without a glitch. When I did some tests, I found that the QOS rule, which slows down file downloads on ports 80, 443 if the transfer rate goes above 512KB, didn't work. By using darkstat I found out that just 2 users who were downloading via the http port hijacked my entire bandwidth.

    Is there any solution?
  21. teddy_bear

    teddy_bear Network Guru Member

    Guys, I apologize for the mess up with VPN in the latest build. The VPN build is a simple merge with SgtPepperKSU' mod, I'm not using OpenVPN myself, and only test if the server/client can be started. I will try to sort it out and post the fix soon though.
    Hmm... If any of the recent changes caused this, it was completely unintentional (looks like X.509 code is still there though, unless I'm looking at the wrong place)... Rodney, can you point to the git commits resulted in this behavior?
  22. reverson1

    reverson1 Networkin' Nut Member

    Hopefully someone can point me in the right direction with this.

    I ordered a NETGEAR WNDR3300 yesterday and I'm aware that ddwrt is supported on this router. However, I'd prefer to use tomato. Is this device supported and if so, is there a particular build that I need to use on this router?

    Thanks for the help
  23. ytsejam

    ytsejam Network Guru Member

    I don't believe the WNDR3300 is supported by Tomato. Teddy Bear's mod supports the routers listed here:
    And the full list of Tomato supported routers is listed here:
  24. reverson1

    reverson1 Networkin' Nut Member

    Thanks for the list of supported routers. I'll try my luck with ddwrt.

  25. though

    though Network Guru Member

    good luck there

  26. myersw

    myersw Network Guru Member

    I am running DD-WRT on a Asus RT-N16 currently. Have have no issues with it BUT I am not wanting to use the USB support on the router for file and printer support. DD-WRT does not provide the click and configure of Tomato for USB support. For just a very feature rich just works router I am very pleased with DD-WRT. I am using the latest build from Eko by the way. Was having some issues with Tomato that probably have been fixed now but have no reason to reinstall Tomato. DD-WRT does support USB but it take a little effort to make work.
    If you are not familiar with DD-WRT be sure to select the correct build and follow the install directions found on the Wlki.
  27. reverson1

    reverson1 Networkin' Nut Member

    I've been using ddwrt for a while now (mostly on wrt54g/gs). However, I also have an Asus RT-N16 and the overall experience with Tomato and samba was by far and away simpler to setup.

    Both have their strengths, I was really hoping to have more than one alternative to the factory firmware.

    Thanks for the reply
  28. MarcelE

    MarcelE Addicted to LI Member

    I have something similair.
    I use the latest Tomato USB mod with WNR3500L, also Ubuntu 64 bits on my notebook in the living room and a desktop PC with Ubuntu 32 bits in the attic.
    Downstairs I get a wonderful 80Mb/s (my internet speed) with wireless N (in 40MHz mode). Upstairs I have a USB wireless G card which of course has a lesser speed but I have to turn the speed back to 11M to have a stable connection.
    If I use the stock Netgear firmware (or another cheap wireless N router) I can turn it back to 54M and it's much faster (and stable). But with Teddy's Tomato it's stuck at 11M. Mind you, I have used the same channels, configuration (no afterburner etc).
    Reason I use Tomato is the Media Server which is working great with my PS3. If other firmwares has it I could use that but I haven't seen it.
    I could see if older tomato firmwares has a better coverage.
  29. cariyawa

    cariyawa Addicted to LI Member

    Yes...It seems like beta18 has a lesser coverage(at least for me). Also I noticed that once I try to reconnect to my wireless Ubuntu laptop, it takes longer time to reconnect it back compare to earlier version that I used(beta11).:)
  30. gingernut

    gingernut LI Guru Member

  31. karog

    karog Networkin' Nut Member

    TB, some time ago I asked for dropbear changes for openssh-sftp-server and default PATH for rsync and such.

    Just tried both in beta18 and both work great. Thanks.

    Also having VPN problems you responded to above. Happy to see you are on it.
  32. karog

    karog Networkin' Nut Member

    I was thinking about trying to write a little server to run on my RT-N16 with Optware. So I thought I would try a little example first, the std HelloWorld. I made a little HelloWorld.cpp file and built it using the toolchain from the tomatoUSB git in 32 bit Ubuntu. It built fine and I copied it to the RT-N16.

    When I try to run it I get: HelloWorld: can't load library ''

    That shared library exists in /opt/lib and in fact if I export LD_LIBRARY_PATH=/opt/lib, the program runs fine.

    Also /opt/lib is in /etc/ so I don't understand why it isn't found when the program tries to run. And ldconfig -p shows it in the list (ldconfig is in /opt/sbin).

    TB, can you or anyone else enlighten me? I am new at writing for this environment.


    I found mipsel-uclibc-ldd and see that there are built in incorrect paths for the shared libraries in the executable. Tried various switches but haven't figured it out yet.
  33. gtj0

    gtj0 Networkin' Nut Member

    You can try using the following compiler flags...

    LDFLAGS=' -s -Wl,--gc-sections,-rpath=/opt/lib:/opt/usr/lib'

    or you should be able to do an ldconfig once after opt is mounted to get the cache updated. Perhaps put it in /opt/.autorun
  34. karog

    karog Networkin' Nut Member

    Tried the LDFLAGS. Did not work. Had already tried the -Wl,-rpath though not the -s or --gc-sections. Thanks anyhow.

    As per previous message, ldconfig -p showed the library in the cache. I think it has to do with linking.

    I thought rather than use the toolchain from tb's git, I would just grab optware from its svn and build its toolchain and use their make templates. That's turning out to be a bit of a bitch too. Several broken links for which I managed to find alternatives but now some new make problem. Sigh.
  35. gtj0

    gtj0 Networkin' Nut Member

    Odd. Works For Me. :)

    When you say "it's in the cache" which cache are you looking at? I don't have an /etc/ until I do an ldconfig at least once and that fixes the problem. Could it be that the ldconfig from optware is looking at /opt/etc/ cache which isn't being read by the system?

    Grab ldconfig from /opt/brcm/K26/hndtools-mipsel-uclibc-4.2.4/target-utils and copy it to the router and see what IT says/does vs the one from optware.
  36. karog

    karog Networkin' Nut Member

    Well you have helped me make progress. Thanks.

    /usr/bin/which showed the ldconfig I was using was /opt/sbin/ldconfig. It apparently was showing /opt/etc/ Also curious is that /opt/etc/ was and is empty. I had tried putting /opt/lib in there and ldconfig told me to remove it.

    I copied ldconfig (and ldd) from where you said to a random dir and ran that ldconfig. It told me to remove /lib and /usr/lib from /etc/ - which I did not do. But that made my program work.

    But now recalling last night (it got rather late) with some of the link switches I tried the complaint about went away but replaced by a missing And that is odd since is in /opt/lib just like

    I am still a bit confused since all the Optware packages do not require the /etc/ nor does the firmware. So I would like to find a way to link correctly. For now I rm'd /etc/ but can always rebuild it.

    Again thanks.
  37. gtj0

    gtj0 Networkin' Nut Member

    Look at rhester72's utilities site if you haven't already...

    He compiles a lot of packages and his build scripts are easy to follow.
  38. karog

    karog Networkin' Nut Member

    I have not already. Thanks for the link.
  39. mstombs

    mstombs Network Guru Member

    Its mostly plain C in the Tomato and utility sources, I don't remember seeing any cpp, so there could be a bug in toolchain config?
  40. karog

    karog Networkin' Nut Member

    gtj0, here's the problem. Compiling with -Wl,-rpath=/opt/lib:/lib:/usr/lib yields an executable that no longer fails for but now for So this shows the rpath and why the problem goes away:

    $ readelf -a HelloWorld|grep lib
          [Requesting program interpreter: /lib/]
     0x00000001 (NEEDED)                     Shared library: []
     0x00000001 (NEEDED)                     Shared library: []
     0x00000001 (NEEDED)                     Shared library: []
     0x00000001 (NEEDED)                     Shared library: []
     0x0000000f (RPATH)                      Library rpath: [/opt/lib:/lib:/usr/lib]
        19: 00400ef0     0 FUNC    GLOBAL DEFAULT  UND __uClibc_main
        66: 00400ef0     0 FUNC    GLOBAL DEFAULT  UND __uClibc_main
      000000: Version: 1  File:  Cnt: 2
      0x0030: Version: 1  File:  Cnt: 1
      0041114c -32692(gp) 00400ef0 00400ef0 FUNC    UND __uClibc_main
    But this shows refers to and the rpath here is bogus:
    $ readelf -a /home/karog/ |grep lib
     0x00000001 (NEEDED)                     Shared library: []
     0x00000001 (NEEDED)                     Shared library: []
     0x00000001 (NEEDED)                     Shared library: []
     0x00000001 (NEEDED)                     Shared library: []
     0x00000001 (NEEDED)                     Shared library: []
     0x0000000e (SONAME)                     Library soname: []
     0x0000000f (RPATH)                      Library rpath: [/home/slug/optware/ddwrt/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/mipsel-linux-uclibc/lib]
      2152: 000b8550    56 FUNC    GLOBAL DEFAULT  UND _stdlib_mb_cur_max
      000000: Rev: 1  Flags: BASE   Index: 1  Cnt: 1  Name:
      000000: Version: 1  File:  Cnt: 3
      000e546c -27956(gp) 000b8550 000b8550 FUNC    UND _stdlib_mb_cur_max
      000e54fc -27812(gp) 000475e4 000475e4 FUNC     11 _ZNSt5ctypeIwEC1EP22__uclib
      000e5c18 -25992(gp) 00047fc8 00047fc8 FUNC     11 _ZNSt5ctypeIcEC1EP22__uclib
    So the ipkg installed was incorrectly built, or so it seems to me. Maybe no one writes c++ for ipkg so no one noticed. I am going to check other libs and wonder if there is a way to modify to correct its rpath.

    Edit: So I scanned all the libs in /opt/lib and is the only offender. How's that for a bullseye, the only lib my test program used?

    Edit: mstombs, good guess. I did not see your message as I was writing mine.
  41. gtj0

    gtj0 Networkin' Nut Member

    Yeah, it looks like the libstdc++ in the optware toolchain/distribution may be the issue. With the tomato toolchain and its libstdc++, I'm not seeing the problem with a simple HelloWorld cpp using the linker flags to control the library resolution.

    What's your goal? Is this for your own consumption or are you planning to redistribute what you're building?
  42. karog

    karog Networkin' Nut Member

    I have become enamored of the idea of using an RT-N16 as a home server for certain kinds of things. I am probably over-paranoid about cloud services but it seems to me a lot of little things like sync servers for various things could live on the always on low power router.

    So I thought I would play with the idea and I have a bit of a learning curve developing for this environment. But if something comes out of it I would be happy to contribute it as an ipkg.

    So for now I was just doing a few things to learn the environment and the first simple thing I do seems to run into a bug in the runtime environment. But I'm used to that, as frustrating as it is.

    As mentioned earlier, I am trying to build the optware toolchain and it blows out on trying to do doc. It said I did not have makeinfo and should maybe install texinfo. So I did install that and yet the make still complains that I don't have makeinfo despite the fact that in the same shell I can see it with which in /usr/bin and makeinfo --help and get instructions.
  43. gtj0

    gtj0 Networkin' Nut Member

    Gotcha. I'm going to try and build the optware toolchain myself. I'll let you know what I find out.
  44. karog

    karog Networkin' Nut Member

    As I edited into an earlier message, I scanned all the libs in /opt/lib that I currently have and libstdc++ is the only offender.

    Thanks for taking a stab at the optware toolchain. I found a few broken links:
    change the following paths to
    optware/make/ HEADERS_OLEG_SITE=
    optware/make/ HEADERS_DDWRT_SITE=
    optware/ddwrt/make/ HEADERS_OLEG_SITE=
    optware/ddwrt/make/ HEADERS_DDWRT_SITE=
    # only in 0.9.28 section for the next one
    optware/ddwrt/toolchain/buildroot/toolchain/uClibc/ UCLIBC_SOURCE=
  45. karog

    karog Networkin' Nut Member

    I repaired with chrpath and now all is well. I will now go inform the optware folks.

    BTW, is there any way to reset the auto-logout time for this forum site? I looked through all of the User CP settings but I may have missed it. It seems to time out rather quickly.
  46. gtj0

    gtj0 Networkin' Nut Member

    Glad you got it sorted out. BTW, the optware toolchain compiled fine for me (with the link fixes) and the resulting libstcc++ doesn't have the rpath problem.
  47. natel

    natel Networkin' Nut Member

    ok ... so anybody has fix for openvpn ????
    how about installing some ?? missing package from extras or maybe trying optware version ???
    would it work ?
  48. spykos

    spykos LI Guru Member

    hello people...

    Is anyone here using Asus RT-N16 with external USB HDD successfully ? What I mean by successfully is to upload big files to the HDD using ftp. All my transfers stop at around 50%. The HDD gets unmounted, seems like a usb driver crash or something. I tried 2 different drives, one 2.5" and one 3.5" with its own power supply. I am using latest TomatoUSB EXT build 48 (tried older version with no luck).

    Any clues on what could be wrong here ?
  49. natel

    natel Networkin' Nut Member

    spykos could it be ftp problem ?
    did you try these files over samba share ?
    how big files ?

    finally .. how about my suggestions on openvpn problem ? :)
  50. gtj0

    gtj0 Networkin' Nut Member

    The commit that caused this problem was 63a3, "Build: compile fixes for gcc 4.3.x", specifically openssl/Configure and openssl/ Reverting the changes to those 2 files in openssl results in a working openvpn.
  51. natel

    natel Networkin' Nut Member

    great found so what now ??
    more beer for bear ?? :)
  52. airbot

    airbot Networkin' Nut Member

    Just go back one or two versions for now. I'm sure that TB will fix OpenVPN in the next build. It'll be posted as soon as he has time to do so.

    Thanks for disabling fast NAT!
    While VPN was accidentally broken, I like beta 18. Disabling fast NAT has made so many things work better. Thanks, TB!

    A feature request (low priority).. but it would be nice to eventually have per IP bandwidth usage integrated into the GUI. This is easily done on the command line by way of a firewall script. And there are third party scripts, e.g. ipt-parse that do hang this on the GUI already.. but it'd be nice to look forward to this in the native GUI somewhere down the road.


    Attached Files:

  53. erikoss

    erikoss Addicted to LI Member

    For anybody's interest.
    my bandwidth per IP iptable scripts now work again in b18. YAAA!!!! :)

    I noticed, on a complete NVRAM wipe, in advanced wireless settings.
    country / signal strength set to USA and 17.
    I set back to Japan and 42 as is the normal default.
  54. though

    though Network Guru Member

    what's wrong with USA 17 ?
  55. airbot

    airbot Networkin' Nut Member

    Nothing if it works for you. 17mW is a weak signal though & won't reach the far end of my house. 28 mW will & that is what I use. Setting transmit to a higher figure will result in a dirtier signal, may run afoul of local regulations & may cause your router to over heat. So don't use a more power than you need.

  56. ladysman

    ladysman Network Guru Member

    For what it's worth, I get longer range and no disconnects with 17. Anything over that and it causes problems.
  57. FattysGoneWild

    FattysGoneWild LI Guru Member

    Weird. Because the U.S.A. version uses 28mW stock. Even Linksys has confirmed it.

  58. db3l

    db3l Networkin' Nut Member

    Well, many things aside from perhaps raw throughput...

    Judging from the reports in this thread, it seemed inevitable that it would get disabled in the main build, and I'm likely in the minority in missing it. But without it even my RT-N16 had a tough time keeping up with a 100Mbps WAN connection under full load, while with it enabled it can handle things smoothly.

    Not that I'm complaining, though I do suspect I'll have to do my own builds to re-enable it if I find a need to go beyond Beta-16. In that case I am definitely appreciative of the all the work done, and the repository provided, to make local building as accessible and straight forward as it is.

    -- David
  59. airbot

    airbot Networkin' Nut Member

    mmm.. I have a 100 Mbps line & my rt-n16 has no trouble keeping up with the disabled fast NAT in b18. I understand your point, but I don't think that fast NAT is the only way to achieve high throughput.

    What leads you to think that b18 can't sustain a 100 Mbps connection? What OS are we talking about? Perhaps your TCP stack needs tuning. Of course, as you suggest we can always compile a custom version to revert features that have been dropped from the main release.

  60. myersw

    myersw Network Guru Member

    Over on the DD-WRT forum they are saying that the RT-N16 has a weak wall wart and if you replace this with one that is 3 amps or greater the wireless signal works better and fixes dropouts that some folks complain about. Eko, one of the developers of DD-WRT, is the one who posted the info.
    Before someone say but you are supplying more power to the router and will this damage the router, the answer is no. The router will only take as much power as it requires.
    So it might be worth a try if you are having a router that reboots or wireless issues with your RT-N16. Can find cheap 12 volt 3 amp or greater on Ebay.
  61. ladysman

    ladysman Network Guru Member

    i'm curious on this. I'm at work so can you provide a link. :biggrin:
  62. groosh

    groosh Addicted to LI Member

    I see that beta19 was released with some VPN changes, has anyone else had a chance to load it yet?
    - can not test my VPN at the moment

    also see that some changes were posted to the git regarding the wnr3500, were these included in the beta19 drop?

    thanks TB
  63. gtj0

    gtj0 Networkin' Nut Member

    Can't speak to the wnr3500 but the openvpn problem is definitely fixed.
  64. madmalkav

    madmalkav Networkin' Nut Member

    Seems there is no modifications at all on the wifi one, so will skip this one.

    Anyway, thanks as always TB :smile:
  65. Dashiell

    Dashiell Network Guru Member

    FTP Server File Times

    I'm currently running beta18 (ext) on an Asus RT-N16. Everything seems to be working beautifully. One question I have on the FTP setup...

    I'm running an FTP with a 4GB flash drive. It's working really well, but I notice any/all files placed into the various directories automatically get a file time of four hours later than the actual time they are uploaded.

    I've learned to "think backward" and subtract four hours from each file's save time to get an accurate picture, but is there a way to adjust this so it is correct for my time zone?

    I'm an EST user, and the clock on the router is automatically set. It's perfectly accurate.

    Thanks in advance!
  66. myersw

    myersw Network Guru Member

  67. Elanzer

    Elanzer Addicted to LI Member

    Flashed up beta 19 and TAP VPN is still broken for me. After about 15 minutes of uptime where the VPN seems fine, the routers just starts dropping connections and refuses any new connections for about a minute.

    Oddly enough, it only seems to be dropping non-VPN connections now, my VNC and http download will get cut off, but a copy-paste transfer over the VPN doesn't get cut off - maybe it survives the timeout?

    Not seeing anything in the logs with this build on either side when it happens. The only thing I see is this:

  68. TexasFlood

    TexasFlood Network Guru Member

    Be interesting to see if there is anything to this beyond anecdotal evidence. I've never really had a problem, knock on wood. Maybe I'm lucky, or too dumb to notice, :wink:.
  69. myersw

    myersw Network Guru Member

    Power supply issue might explain not being able to increase wireless power on the RT-N16. Seems to become distorted with power increase so that things work better at lower power. I have to admit I have wondered about the power brick being an issue when I experienced this but since I was getting good coverage with the default I never did anything.
    Time will tell and I am sure that some power supplies are better then others and some routers are not as sensitive as others to power issues.
  70. db3l

    db3l Networkin' Nut Member

    All of Linux, OSX or Windows. But nothing really to do with the client - the PCs involved can transfer at hundreds of Mbps amongst themselves locally over the 1000bT wired network and have no problem saturating the link with beta-16. When I did have issues with other betas it was with the CPU load (more specifically time spent in sirq) on the RT-N16.

    See and

    To be fair, in my tests, hitting link saturation as a peak or for a short time is never a problem. The issue is that sustained transfers weren't surviving as well. This was typically with a single stream (single source/destination) of traffic.

    Perhaps b18 changed something else to get back some performance elsewhere, so I'll give it a shot when I have a moment, but given the changes amongst beta 14, 15 and then 16, the fast NAT code seemed very effective in my use case, and at least for now isn't impacting any features I need.

    -- David
  71. baker99

    baker99 Addicted to LI Member

    I have a Netgear WNR3500L/U/v2 and have installed the latest beta 18 firmware successfully, but I can't get any usb devices to show in the webgui, is usb not supported on this router, and if not will support be added? So far everything else seems to be working fine thanks TB.
  72. gingernut

    gingernut LI Guru Member

    So which Netgear model do you have the WNR3500L or the WNR3500v2/U? also what build did you load?
  73. rhester72

    rhester72 Network Guru Member

    Did a mtr run against the other end of my VPN overnight with (pre-?)beta 19 using a standard tap connection and had zero packet loss. Not sure what the issue is, but it doesn't look likely to be OpenVPN itself.

                                 My traceroute  [v0.80]
    cerberus (                                     Tue Aug  3 07:33:39 2010
    Keys:  Help   Display mode   Restart statistics   Order of fields   quit
                                           Packets               Pings
     Host                                Loss%   Snt   Last   Avg  Best  Wrst StDev
     1. 6pvl0c1.multics.local             0.0% 27060   57.0  20.0  18.8 3183.  31.7
  74. Elanzer

    Elanzer Addicted to LI Member

    Hmmm, it may be that some device on the network is causing it to break. I'm going to try a TUN VPN connection - maybe it'll filter out what possible junk is causing this to happen.

    If that doesn't help, then there's the joys of walking someone over the phone to disconnect devices for troubleshooting the network that's a 4 hour drive away.
  75. amsri

    amsri Networkin' Nut Member

    K26 No USB Standard version works with Linksys WRT54GS v4. I was able to load it successfully and things are going fine. K26 No USB VPN is too big for the 4mb flash on this router. Just reporting for information. I cannot use USB version as this router does not have USB port.

    By the way just being curious- if I attach an external usb drive to this router using a usb to lan converter will I be able to use the usb features of k24/k26 USB standard version.
  76. baker99

    baker99 Addicted to LI Member

    The tomato firmware reports Netgear WNR3500L/U/v2, and my receipt says WNR3500L-100UKS so I'm not sure, it definitely has a usb port which I have tried 2 flash drives and a usb harddrive in with no success. I'm using tomato-K26USB-1.28.9048MIPSR2-beta18-Ext, any help or advice would be appreciated, I bought this router to upgrade from my Buffalo mainly so I could attach a usb drive to it.
  77. baker99

    baker99 Addicted to LI Member

    Just checked the website I bought it from says it has 8MB flash so it is probably the version 1 as from what I have read v2 has only 4MB, also I assume tomato-K26USB-1.28.9048MIPSR2-beta18-Ext wouldn't fit on a v2 and it's working fine except for the usb.
  78. teddy_bear

    teddy_bear Network Guru Member

    Have you tried to reset the router to default settings ("thorough" nvram erase option)? If you did, and USB is still not working - what's the current value of "boardflags" nvram variable on your router?
  79. Prophet

    Prophet Networkin' Nut Member

    I created a dir that I want to stay, but it disappeared after a reboot. Can I save it by choosing 'Nvram commit' in the debug window?
  80. baker99

    baker99 Addicted to LI Member

    Here are the boardflags from nvram


    Looks like its v2, but I thought v2 only had 4MB and that v1.28.9048 MIPSR2-beta18 K26 USB Ext wouldn't fit, strange as it all seems to work and it didn't brick
  81. baker99

    baker99 Addicted to LI Member

    Ok it seems to work now, it turns out if I put my Verbatim memory stick in it messes up usb support on the router until I reboot it, the stick works fine in windows and I've tried formatting it as NTFS and FAT, but as soon as I put it in the router it messes usb up somehow and no other devices I plug in are seen until I reboot. Thanks for the help.
  82. rhester72

    rhester72 Network Guru Member

    Is the Verbatim stick flagged as FIXED_DEVICE or REMOVABLE_DEVICE?

  83. baker99

    baker99 Addicted to LI Member

    How can I check? I'm really a linux newbie, although using tomato is teaching me a lot.
  84. erikoss

    erikoss Addicted to LI Member

    >>I noticed, on a complete NVRAM wipe, in advanced wireless settings.
    country / signal strength set to USA and 17.
    >>I set back to Japan and 42 as is the normal default.

    Thanks for the advice guys.
    I set wireless back to USA and 28. Covers my house well.

    Now looking to get a 3amp power supply for my RT-N16.
    Its anoying the PS in the box does not have enough amp.
  85. though

    though Network Guru Member

    it 'may' or 'may not'. hard to tell for sure. i would like to get TB's official response regarding this!
  86. cariyawa

    cariyawa Addicted to LI Member

    My personal belief is that 1.25A power supply is enough. I may be wrong.... If RT-N16 draws lot of power under some circumstances , definitely power supply unit must generate reasonable amount of excessive heat which should make it "hot" instead of "warm". So people who have that setup may be able to compare(roughly) temperature of the power supply unit for the idle case.

    Just a thought...:biggrin:
  87. though

    though Network Guru Member

    i agree that 1.25A is 'probably' enought, BUT is that little thing really capable of delivering a constant 1.25A if needed? that's the question...
  88. micmanm

    micmanm Addicted to LI Member

    Hi people!
    Is ms-chap-v2 supported by tomato firmware?
    How to enable this protocol in /tmp/ppp/options file for PPTP WAN Connection?
  89. myersw

    myersw Network Guru Member

    The feeling by one of the DD-WRT developers is no it is not. I wonder how much having a power hungry USB device enters into it. Also wonder if this could be part of the reason some of us cannot increase the transmit power much higher then the default 17. Anyway here is a link to Eko's (DD-WRT Developer) thoughts on RT-N16 power wart. In his case he saw an improvement in the RT-N16.

  90. spookyneo

    spookyneo Networkin' Nut Member

    I just ordered a new power supply on ebay. 12V-3A. It was tested by another DD-WRT Guru to be top notch quality and it costed me only 11$ shipped to Canada :)
  91. peternm22

    peternm22 Networkin' Nut Member

    Any chance you have the E-bay link?

  92. amsri

    amsri Networkin' Nut Member

    Hi again..

    By the way just being curious- if I attach an external usb drive to this router's (WRT54 GSv4) ethernet port using a usb to lan converter will I be able to use the usb features of k24/k26 USB standard version.
  93. though

    though Network Guru Member

  94. rhester72

    rhester72 Network Guru Member

    It's not a Linux question. ;)

    If you put it in a Windows machine, does it say "Local Disk" or "Removable Disk" for Type under Properties?

    If it says "local disk", that might be part of the problem - Google for "Removable Media Bit" for more details.

  95. madmalkav

    madmalkav Networkin' Nut Member

    People, what is the best speed you are getting copying files from router samba share to a pc? In my case. Wifi N, pc really near, 20Mhz channel, both router and pc marks stable 117mbps but files are copying like at 1.9MBps. Any ideas?
  96. spookyneo

    spookyneo Networkin' Nut Member

  97. though

    though Network Guru Member

    does anyone have the capability to test the actual output capability of the stock psu?

    i could be wrong, but i highly doubt a new psu is needed unless someone is using usb devices that are not plugged into a powered usb hub, then **maybe**....
  98. cariyawa

    cariyawa Addicted to LI Member

    Yes.. that is exactly what I think too...
  99. TexasFlood

    TexasFlood Network Guru Member

    Eko has a long solid history so I trust his observations. On the other hand, I have the stock 12V 1.25A Asus power supply and have no problems. Perhaps there are hardware differences between his and mine, perhaps he stresses his more thereby pushing the power supply more. This seems to be more smoke than fire at this point. I'm not saying it's not true It doesn't seem to be in my case nor have I yet seen persuasive corroboration like a significant number of others reporting the same issues and resolution. But if I was having issues, buying one of those ebay 12V 3A power supplies would probably seem like a cheap & easy thing to try. Worst case it doesn't help and you're out $10 right? if enough folks were to do so with positive results then it would seem a lot more solid and perhaps something to take up with Asus.
  100. maurer

    maurer Network Guru Member

    i tried using my rt-n16 without usb attached hdd (it has its own ps) and no difference - disconnects every hour - marked as dhcp request in the log.
    i've also tried a 12v and 2A ps that i had to spare home - no difference - constant disconnects.
    I've searched the forum and i didn't found any complaints there.
    Could it be software related?
    What's also strange is that it started happening almost in the same period of time (last weeks) for people who bought units in the same period of time - i bought mine just before Christmas - a few weeks after eko received his and started development.
    is teddy having problems with his unit?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice