Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. cariyawa

    cariyawa Addicted to LI Member

    bad batch?:frown:
  2. riley0

    riley0 Addicted to LI Member


    Just a quick note to say I flashed with
    tomato-K26-1.28.9048MIPSR1-beta18-Std.trx and the QOS issues I reported previously (B16) are now gone. Everything seems to be working quite well. I also no longer classify by MAC as per your suggestion.

    Thank you for the continued development!
  3. myersw

    myersw Network Guru Member

    My RT-N16 had a build date on the box of December 2009. It has been rock solid as long as I do not run the Asus OEM firmware including Currently running DD-WRT Brainslayer build 14815 (latest). Have run TB Tomato as well with good results as well as Oleg. Just call me someone who likes to play with different firmware.
    BUT the router itself has always been rock solid with the exception of some wireless issues with one of Teddy_Bear's builds, don't remember which, but this is why I currently run DD-WRT.
  4. pfoomer

    pfoomer LI Guru Member

    Swapper Problem?


    any body else seeing this in their logs?, or any body know why this would happen?

    07-08-2010 09:39:33 warning user Aug 7 09:39:33 kernel: swapper: page allocation failure. order:3, mode:0x4020
    (followed by loads of other stuff)

    Tomato Firmware v1.28.9048 MIPSR1-beta18 K26 Std
    Linux kernel and Broadcom Wireless Driver updates,

    Based on Tomato Firmware v1.28

    Built on Sun, 25 Jul 2010 10:53:45 -0400
  5. ladysman

    ladysman Network Guru Member

    I switched to Beta 19 this morning and all is well for me!
  6. pfoomer

    pfoomer LI Guru Member

    STD version beta 19 not posted yet.
  7. TexasFlood

    TexasFlood Network Guru Member

    And probably won't be since as I understand it, this is just a fix for VPN.
  8. ladysman

    ladysman Network Guru Member

    Yep, VPN fix only.
  9. Dashiell

    Dashiell Network Guru Member

    Power Supply Discussion

    Just for the sake of it I ordered one of these power supplies via the Ebay link. 12v, 3A (actually it says 1A, 2A, 3A, 4A on the unit itself when you receive it). It appeared to be working fine, no 'radical' improvements in wireless. However, about fifteen minutes in the router rebooted itself for no apparent reason. (The cable modem and router are actually plugged into a battery backup unit as well.)

    I checked it out. Seemed okay after that. Six hours later there was another reboot. On the PS supplied with the RT-N16, I never experienced a single reboot.

    I'm using Teddy's 1.28 9048-Ext build. Have been since receiving this unit. It was up and running for a week with no issues before this. I have replaced the original power supply for now... we shall see if there's any more reboots.

    I felt I should state my case as it may turn out that switching the PS can CREATE a problem as well as fix one... unless anyone else has any ideas.
  10. iloveramen

    iloveramen Networkin' Nut Member

    I bought one of those power supplies for my RT-N16. I received it yesterday and so far, I haven't had any problems. I did erase my nvram before replacing the power supply. lol.
  11. HKPolice

    HKPolice Network Guru Member

    Everyone with reboot issues, your router is probably overheating. I opened mine up to replace the stock cooling and found that the heatsink was only making physical contact with maybe 10% of the chip, around the corners. Due to the convex surface of the heatsink, there was a huge gap in the middle.

    I put on a zalman northbridge cooler and overclocked to 533Mhz without any issues, been running solid for over a week now since the last reset with the stock AC adapter.

    I posted this long ago here:
  12. maurer

    maurer Network Guru Member

    I don't have any reboot issues.
    my wired lan connection is rock solid but the wireless has "hiccups" - constant disconnects although 100% signal strength.
    I've lowered the power down to 17 and it's not that frequent any more.
    i suspect that is has something to do with overheating chips - these weeks were very very hot here in Romania.
  13. airbot

    airbot Networkin' Nut Member

    Is there any place that I can find some documentation about the less common tomato features?

    For instance I want to set a samba option (no CIFS byte range locking)
    I can see where this can probably done in the tomato menu USB & NAS | File Sharing | Samba custom configuration menu
    But I can't find any built in help (man pages) or syntax documentation. I've also tried guessing without any success

    e.g. I've tried:
    mount -t cifs // /mnt/stats -o nobrl username=myusername,password=mypassword,rw

    nobrl = yes

    And the typical result is:
    nd daemon.err smbd[524]: Unknown parameter encountered: "nobrl"
    nd daemon.err smbd[524]: Ignoring unknown parameter "nobrl"


    Attached Files:

  14. gingernut

    gingernut LI Guru Member

    Just out of curiosity what cfe versions do you have on your RT-N16's

    I've had zero problems with mine, has a manufacturing date of Sept 2009 and a cfe (system bios) version of

    If your interested to find out your cfe version goto Tools -> System and type:

    nvram get pmon_ver
  15. myersw

    myersw Network Guru Member

    Guess Asus was happy with that version of cfe as my RT-N16 had a manufacturing date of December 2009 and has the same cfe version,
    My RT-N16 has been stable but I do not push it with increased transmit power and only an occasional bittorent. When I did load Oleg on it the default transmit power was higher, don't remember for sure but seems like it was 42, and my wireless range was reduced. When I changed it to 17 things were good again. Have not opened up the router to see how good the heat sinks are glued on. Some have reported that Asus did not do a very good job with getting the whole heat sink in contact with the respective chip.
    Running latest DD-WRT BrainSlayer 14896 big currently without issues. Why am I running DD-WRT you ask. I had issues with one of TB's Tomato builds with wireless and tried DD_WRT. It has worked for me and gives me what I want so have no driving need to reinstall Tomato.
  16. AeN0

    AeN0 Network Guru Member

    I didn't noticed until today but I got the exact same problem.

    After upgrading from WRT54GS Tomato vanilla to WRN3500L ND USB Mod K2.6 build 48

  17. ladysman

    ladysman Network Guru Member

    I guess I did notice something wrong this morning. Yesterday, I finally setup my VPN. Although I am not sure how much I'd use it, I just wanted to set it up. My problem was this. Every time i'd make a change to the router and save, it wouldn't come back and I couldn't connect to it for a long time. I assume this is the VPN server trying to get back up and running? I have selected the "WAN" check box so this is my only assumption.

    Is this normal?

    I completely redid my network yesterday so I was doing a lot of Pretty noticeable but now that i'm done, I think i'm good but wanted to check.
  18. airbot

    airbot Networkin' Nut Member

    This may not be related to your VPN configuration. I have the same problem everytime I flash a new version to the router. It takes a looooong time to connect, It's not obvious why & since it is fine on subsequent reboots & otherwise rock solid I really didn't worry about it. I haven't noticed this with simple configuration changes, just when flashing. A workaround that worked for me was to set a static IP on my PC.

    @gingernut. Also running CFE v. & stable
  19. rhdcheme

    rhdcheme Addicted to LI Member

    Mine was manufactured in China on March 2010 and has the same CFE version as yours.

    I also have had ZERO problems (of course, I don't overclock or subject it to ridiculous use either - it is a home router after all).

    It feels warm to the touch (like any other router) so I have a small fan blowing across it.

    It would be interesting to know when the units owned by those who have reported problems were manufactured and their cfe versions.
  20. ladysman

    ladysman Network Guru Member

    It only happened on certain changes or reboots (i reboot after doing scripts). Some simple changes it was fine i.e. wireless transmit power. This was a brand new RTN16 i've had for about a month and just never got around to reflashing it. I now use 2 of them. 1 is the main router and the other is a wireless repeater only.
    The first time it happened i thought I bricked it.:biggrin:

    Edit. Manuf Date of 4/2010 with same CFE. CFE
  21. airbot

    airbot Networkin' Nut Member

    Same here. At a guess, certain changes seem to cause a delay in passing out client IP's. It's fine after a wait. Or you can explicitly assign a static IP on both the router & PC to work around the delay.

  22. Dashiell

    Dashiell Network Guru Member

    Update for Teddy or others... (help!)

    Update to this post and the random reboot issue...

    It seems that the power supply doesn't have much to do with the issue. The random reboots seem to be related to the USB mounting. With both the included PS and the new one purchased off of Ebay, whenever I have a USB drive mounted within the RT-N16 it causes random reboots. They can be as soon as 20 minutes or as long as 9 hours after booting... but they always happen.

    Turned off all USB support and am now using the Ebay purchased power supply. 12v 3a. No reboots at all. 19 hours.

    One USB drive was a sandisk cruzer, 4gb and the other is a memorex 1gb. All were formatted with ext3 file systems.
  23. RavenII

    RavenII Networkin' Nut Member

    Guys, I'm sorry for not knowing as much as many of you, but I'm trying to learn...I've been trying to get HFS+ working for NAS purposes...I used insmod to load the hfsplus.ko, and checked it with 'lsmod'...but don't know how to get the actual drive mounted...

    I do...
    mount -t hfsplus -w /dev/sda1 /mnt/Little\ Lady/

    and get
    mount: mounting /dev/sda1 on /mnt/Little Lady/ failed: Invalid argument

    btw, it's GPT and it's HFS...(not journaled)...
  24. baker99

    baker99 Addicted to LI Member

    Thanks Rodney, I feel dumb now ;) I'll check tomorrow, for now I have a different usb stick connected and am having great fun trying out optware packages
  25. airbot

    airbot Networkin' Nut Member

    This may be the case but it's not universal. I always have a USB drive (cifs share) mounted & haven't had any unexpected rebooting at all. Currently using the latest beta 19 build & a 1GB SD card in an USB card reader. Ext3, required authentication for samba & FWIW, factory power supply.

    So if it's balking at your USB it must be a specific setting or perhaps the specific chipset in your usb drive(s). Try a different brand of drive? Or you can try the settings I am using & see if it makes any difference.


    Attached Files:

  26. Dashiell

    Dashiell Network Guru Member

    Your settings were almost identical to mine, with the exception of I had NTFS and FAT support checked, and I didn't have a CIFS mount. I will add both and try the result.

    I was using 2 different makes of usb drives.... we shall see.

    Thank you!

    UPDATE/EDIT: Rebooted within 22 minutes of changing these settings.
  27. baker99

    baker99 Addicted to LI Member

    I read earlier in the thread something about the media directory on a USB HDD being wiped when using miniDLNA, I have just experienced this too, after restarting miniDLNA all my files have been deleted, my drive is formatted as ext3, using a netgear WNR3500L-100 and Tomato Firmware v1.28.9048 MIPSR2-beta18 K26 USB Ext
  28. airbot

    airbot Networkin' Nut Member

    It was worth a try.. too bad it didn't help. It does seem to narrow it down to a conflict with the particular drives that you have tried so far. If you have an opportunity, try a different brand of drive or an USB card reader.

    edit: also have a look at post# 2221. another possibility is that your heatsink is loose and the router reboots when it overheats. so it may not be the usb mount, but just the increased load on the router that causes it to reboot.

  29. zmzmzm

    zmzmzm Addicted to LI Member

    I have a non-technical question.

    I am currently running the USB/VPN load in my Netgear 3500L, and don't have a problem with it being officially a beta. I would guess that some people will wait for there to be an "official" released version. Is there a path to get a first non beta load? I'm willing to help but don't know what issues there are which are preventing declaring a release as official.

    This firmware is great and think that there is very little preventing declaring beta19 as the first non-beta.
  30. ncfoster

    ncfoster Networkin' Nut Member

    Just to add a data point here, I just reverted to beta 16. I had been fine with beta 18 since it had been released, but today I started getting what I assume were the random reboots, as I was losing connection and was unable to get a working connection with IP without a long long delay.

    I don't use VPN, and I don't have any of the USB support enabled yet, so none of that is the issue for me. Hopefully, reverting like this will stabilize things, but since I just did it, I cannot say for sure. I will try to remember to report back after a while.
  31. amsri

    amsri Networkin' Nut Member

    It seems nobody has an answer to my question.
  32. spookyneo

    spookyneo Networkin' Nut Member

    Are the OpenVPN issues of 1.28 fixed now ? I know there is a build49 which is supposed to have fixed it, but I didn't see that much posts about people trying the new build and OpenVPN.

    I'm currently running on 1.27 and the OpenVPN issue is the only thing that is stopping me from upgrading to 1.28.

    Thank you.
  33. gtj0

    gtj0 Networkin' Nut Member

    Yes, build 49 fixed the openvpn issue (the cause was actually an openssl compile issue). I'm using the server now with no problems.
  34. spookyneo

    spookyneo Networkin' Nut Member

    Great ! Thanks for replying so quickly :)
  35. airbot

    airbot Networkin' Nut Member

    It may well be that no one has tried this. If it is important to you, you can be the first to try. It seems unlikely to work as the USB LAN adapters are usually configured to work in the opposite direction and require a driver. I don't see how bus traffic will be properly routed with the (possibly supported) USB chipset in the adapter on the far side of the ethernet port.
  36. airbot

    airbot Networkin' Nut Member

    I would imagine that when TB (the author of this tomato fork) is satisfied that the firmware is stable and has no significant bugs remaining that he will remove the beta tag. I doubt that there is a time line, schedule or anything else for this. It will be done whenever it gets to that point. Just check back periodically to see what the current version is if this is an issue.

    Having said that, TB has done a superb job and the firmware is already quite stable. But that is not to say that there aren't some minor bugs still hanging around.
  37. gagruk

    gagruk Networkin' Nut Member

    I thought I would take a moment to thank Teddy Bear for the great Mod he made. I recently put the Beta 19 on my Asus RT-N16. It is running flawlessly!

    I am a complete noob so I was glad that everything was so simple and any questions I had there was always a simple walkthrough that I could find. In less than an hour I cloned a mac address, had a USB hdd set up, and had my QOS settings tweaked for my VoIP service.

    I finally have the set up that I have been dreaming of for months (for a fraction of the cost I expected) and it is all thanks to Teddy Bear, the creators of Tomato, and those in this community. Thanks for all the hard work it is greatly appreciated.
  38. Dashiell

    Dashiell Network Guru Member

    I have thought of that as well... I'm thinking of re-seating it if it becomes obvious that is the issue. One other thing happened today:

    8 pcs connected, 2 of them wireless. No activity to speak of going on, the connection count was only a total of 16, QOS showed nothing going on. This is the cpu load report:

    Name xxxxxxxx
    Model Asus RT-N16

    Time Tue, 10 Aug 2010 12:26:21 -0400
    Uptime 0 days, 07:26:36
    CPU Load (1 / 5 / 15 mins) 1.00 / 1.00 / 0.92
    Total / Free Memory 124.29 MB / 115.56 MB (92.97%)

    Am I wrong or does this not seem a big HIGH for a machine with only 16 connections going on? Also, all usb sticks have been removed as well as the usb core support shut down.
  39. amsri

    amsri Networkin' Nut Member

    You are right it does not work. Anyway thanks a lot for your reply. If it worked it would have been a great way of using usb hdd on a router without usb port.
  40. airbot

    airbot Networkin' Nut Member

    That is odd, those are high loads.. I don't think that I've ever seen my rt-n16 go above 0.2, even when I have a lot more activity than you are describing. I am seeing loads of 0.00 - 0.15 with a dozen clients on a 100 Mbps line, two dozen QOS rules, CIFS share, FTP server, running scripts/SQLite dbase for traffic stats, using dnsmasq for ad blocking, etc.

    If you see this loading again, try enabling verbose logging (admin/logging) for a while and/or verbose console logging (admin/debugging) & see if there if there are any clues in the log. You might also try briefly disabling entire sections e.g. QOS or individual clients (access restriction), watching for large swings in the loading. Very high loads without an obvious cause would suggest to me an active conflict, crash or overheating. Did you do a thorough NVRAM wipe after flashing your router? Try having a desk fan blow directly at the top of the router for a while & see if it makes a difference.
  41. Dashiell

    Dashiell Network Guru Member

    Thank you for your help. I was going to check what process was doing this but it rebooted before I got the chance. Something's definitely wrong.

    I've got a replacement unit headed my way already should be here tomorrow. We shall see. And yes, I ALWAYS thorough NVRAM wipe after flashing. In this case it was twice, actually.
  42. airbot

    airbot Networkin' Nut Member

    You may know this already, but log into the router and type "top" without the quotes at the command line to view the detailed process information, cpu utilization, memory use, etc. Use the "q" key to exit

  43. Dashiell

    Dashiell Network Guru Member

    Yes, I did know that... I was trying to launch telnet when it rebooted. Thank you for all the help and if anything occurs to you I'd appreciate it. I'll update soon after I have the replacement unit running...
  44. vinhdizzo

    vinhdizzo Networkin' Nut Member


    After loading Tomato on my Asus RT-N16 primary router, I've decided to try tomato on my wireless bridge Linksys WRT160Nv3. I followed the directions here to set up a wireless bridge. I can connect to the internet fine when connected to the bridge. However, from the bridge, I cannot connect to computers connected to the primary router, eg, my NAS. Is this a Tomato issue or something else? In the mean time I've gone back to DD-WRT on the bridge.

    I apologize if this is not the proper place for this inquiry. Please refer me to appropriate place, thanks.
  45. rhester72

    rhester72 Network Guru Member

    Not sure if anyone is tracking this, but the last several checkins won't compile, even from clean checkout. Last bits of "make r2e":

    make -C libusb10
    make[5]: Entering directory `/home/rhester/tomato/release/src/router/libusb10'
    CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash /home/rhester/tomato/release/src/router/libusb10/missing --run aclocal-1.11 -I m4
    aclocal-1.11: couldn't open directory `m4': No such file or directory
    make[5]: *** [aclocal.m4] Error 1
    make[5]: Leaving directory `/home/rhester/tomato/release/src/router/libusb10'
    make[4]: *** [libusb10] Error 2
    make[4]: Leaving directory `/home/rhester/tomato/release/src/router'
    make[3]: *** [all] Error 2
    make[3]: Leaving directory `/home/rhester/tomato/release/src-rt'
    make[2]: *** [bin] Error 2
    make[2]: Leaving directory `/home/rhester/tomato/release/src-rt'
    make[1]: *** [e] Error 2
    make[1]: Leaving directory `/home/rhester/tomato/release/src-rt'
    make: *** [r2e] Error 2
  46. gingernut

    gingernut LI Guru Member

    Same problem here using latest git checkout.
  47. gtj0

    gtj0 Networkin' Nut Member

    This morning I did a git pull to update my local tree then a clean build and didn't have any problems. Just now I did fresh clone/checkout/build of tomato-RT and didn't have any problems either. This is on my trusty Fedora 11 x64 system.
  48. teddy_bear

    teddy_bear Network Guru Member

    gingernut & rhester72,
    Still builds fine on my Ubuntu box. Can you guys determine when it started? Could you still compile build 48 / beta 18?
  49. gingernut

    gingernut LI Guru Member


    I can't check much at the moment as I'm at work but the latest git tree that I used that compiled without errors was from 11 days ago, commit e7b562c8a2734824b9c831b902dd9dc8019ea868.

    Could be just an error I made but usually it builds without errors.
  50. teddy_bear

    teddy_bear Network Guru Member

    That might be the new binary toolchain - could not find anything else in the recent commits that could possibly affect the build:
    However, is doesn't cause any issues here...

    EDIT: Also, I just remembered that Toastman had exactly the same error trying to compile the git sources more than 2 months ago! Not sure if and how he was able to resolve it. Weird...

    EDIT2: Never mind - try the attached patch on top of the clean git checkout.

    Attached Files:

  51. rhester72

    rhester72 Network Guru Member

    Successful - thanks!

  52. jnappert

    jnappert LI Guru Member

    Git dated 2010-08-13 compiles fine in extended version. But WDS-Links WPA/WPA2 (AES) seem to be broken again although in cant see any changes in git concerning brcm drivers...
  53. rhester72

    rhester72 Network Guru Member


    Somewhere vaguely around beta 18 (I know, I know... :), the passwd.custom and group.custom appending seems to have stopped working on boot.

  54. teddy_bear

    teddy_bear Network Guru Member

  55. olaughlj

    olaughlj Networkin' Nut Member

    Issues with USB NAS

    I have SMB set up for an external USB drive hooked up and am seeing horrible performance but only through SMB. If I use FTP to transfer data off the drive it is as fast as I would expect it to be. Below is a link to my older thread that shows the transfer speeds in both configurations.

  56. jnappert

    jnappert LI Guru Member

    Hello TB. Beta 18 was working flawlessly. I did a compile in between (with labeled QOS classes) which was also fully functional but I can't remember the date. As i looked into the changes i also think that the mentioned commit did the break...
  57. rhester72

    rhester72 Network Guru Member

    In the Init script:

    [check to make sure /opt is mounted from USB drive]
    ln -s /opt/etc/passwd.custom /etc/passwd.custom
    ln -s /opt/etc/group.custom /etc/group.custom

    Maybe it is some sort of race condition? It used to be quite reliable, and I've hacked around it by doing:

    cat /opt/etc/passwd.custom >> /etc/passwd
    cat /opt/etc/group.custom >> /etc/group

    immediately before I try to create the softlinks (but after I validate that /opt is available) and it seems to be stable, so I'm not quite so sure it's a race situation after all.

  58. teddy_bear

    teddy_bear Network Guru Member

    You should not rely on the /opt mount being completed before other services are started (including telnet/ssh, and that's when passwd/group/etc files are getting created).

    The better options would be:
    1. Save your /etc/*.custom files to nvram using "nvram setfile2nvram" command. They are restored very early in the boot up process - it's guaranteed that the files are there by the time other services are getting started.
    2. If you prefer to store your actual files on /opt, you can use .autorun script in the root of your optware partition - "/opt/.autorun". Create your symlinks in that script, and then add "service admin restart" command at the end. The script will be automatically executed after /opt is mounted, and restarting the "admin" service will make sure that the passwd etc files are re-created.
    Unfortunately, I can't put these changes back... The newer nas/eapd from the latest Broadcom SDK - even though it apparently helps with WDS setup - is conflicting with the wi-fi driver version used in the firmware, and sometimes causes crashes/disconnects during wireless transfers - that's why I removed it.

    We can experiment with a few different available versions of nas/eapd/bcmcrypto binaries to see if there's a better combination - but I wouldn't keep my hopes too high. If you'd like, I'll make a few test builds and send them to you to try.
  59. rhester72

    rhester72 Network Guru Member

    Understood - I think I was getting lucky in the past, because the (faulty) approach was very reliable. I feel like the setfile2nvram approach is a bit cleaner than the .autorun/admin bounce, which is working well - thanks!

  60. rhdcheme

    rhdcheme Addicted to LI Member

    Low signal strength for wnr3500L

    After testing out Netgear's latest firmware for WNR3500L, I have reason to believe that the tomato signal strength default of 42 is significantly lower than the stock firmware strength. All my clients are connected at excellent signals and speeds using the stock firmware, but unfortunately not with the latest tomato 9048 ext build.

    Also, I discovered that the tomato transmit power really does not do much even when the power is increased substantially (e.g., 71) or, for that matter, lowered below 42. The speeds are very slow for distant clients (I have wireless set to Ch 1, Auto, 40 Mhz).

    Finally, is the signal strength information on the tomato "device" page correct? Again, I have reason to believe that the information is not accurate (before or after hitting the "Measure" button).

    Anyone with any insights?
  61. jnappert

    jnappert LI Guru Member

    @TB: As WPA/WPA2 is very important for me, i will certainly check test builds ;-)
  62. teddy_bear

    teddy_bear Network Guru Member

    Try building from tomato-RT-dev branch.
  63. jnappert

    jnappert LI Guru Member

    @TB: I compiled from tomato-RT-dev branch, merged labeled QoS classes and - sucess!

    WPA/WPA2(AES) connects immediately. Nice work.
  64. airbot

    airbot Networkin' Nut Member

    I'd like to start compiling my own images, rather than using the prebuilt ones. This would be a great way to learn more about linux in general. My first try using Ubuntu (dash shell) had a number of errors and it looks like I should have been using a bash shell instead?

    I've started searching through this thread looking for some tips or a guide (for someone who hasn't compiled before). I'm sure that I will figure it out in time.. but it is a large thread. If anyone happens to have a bookmark handy or any tips on where to start that would be appreciated.
  65. gingernut

    gingernut LI Guru Member

  66. airbot

    airbot Networkin' Nut Member

    Thanks for that. I will use that as a starting point.

    edit: Great instructions for a simple, straight forward compile. It took me a little searching to find the right source branch for what I wanted, but great instructions that saved me a lot of work. Much appreciated.

  67. rhester72

    rhester72 Network Guru Member

    Feature/change request - Perhaps /dev/null should have default permissions of 666 versus 644, for applications that drop permissions at startup but still need the ability to write to /dev/null (e.g. tor, transmission)? I don't see any real security risks here.

  68. Tu13es

    Tu13es Networkin' Nut Member

    I just picked up a WNR3500L and am hoping to load this on there. I read through some of the recent posts and am a little confused. Will I be okay with using beta19?
  69. airbot

    airbot Networkin' Nut Member

    Wouldn't /dev/null normally be 666? Is it possible that some root owned process (web browser?) is changing it to 644? Or is there some reason that I'm missing that it was set to 644 in tomato?

  70. ytsejam

    ytsejam Network Guru Member

    I'm running beta19 on my WNR3500L with no problems.
  71. rhester72

    rhester72 Network Guru Member

    Tomato seems to make a lot of assumptions that all processes will run as root - legacy holdovers from its Linksys/HyperWRT days, I'd guess.

  72. airbot

    airbot Networkin' Nut Member


    edit: deleted some spurious questions because I was using winrar which doesn't properly display all of the files inside the tomato source tarball. Everything works properly once I switch tools e.g. 7-zip or tar, instead of winrar.

    But I don't quite understand the git repository layout. I found the Tomato-RT branch & everything is complete in the tree. But when I look inside the source snapshot tarball it's incomplete. There is at least one complete directory missing. e.g. /release/src/router/www/ is in the tree, but not the tarball. But I see that this directory is fully populated in some other branch tarballs, so WTF?

  73. mstombs

    mstombs Network Guru Member

    There are 106 files in that folder - what tool are you using to view the tarball contents? Note that the source files are common to both versions, the same "router" folder is symlinked into the src-rt version.
  74. airbot

    airbot Networkin' Nut Member

    Thank you. I did notice the symlink in the tree, but as I am just getting my feet wet with linux I was still using windows GUI tools. Winrar appears to open the archive but in fact it does not properly parse the tarball. Weird that it didn't throw any errors, just shows an incomplete directory listing. I suppose that winrar probably doesn't know what to do with the symlink and can't parse the path to the www folder.

    I just tried 7-zip and tar and of course they both show the expected listing. I was starting to doubt my sanity, so thanks for deducing that I was using the wrong tool.

  75. mstombs

    mstombs Network Guru Member

    Historically windoze tools have never been able to properly open even Linksys GPL releases - some folders had filenames in both upper and lower case which windoze didn't understand - as well as symlink issues.
  76. Dashiell

    Dashiell Network Guru Member


    Hello, all!

    I'm running an ad blocking script in the wanup, and a custom theme script in the init. I notice that sometimes when rebooting the router rt-n16, in the logs there will show errors coming from nmbd [982] stating that "this request must come from a wins server."

    When startup is finished, sometimes it defaults to "WORKGROUP" instead of my named workgroup and nothing can be found on the attached USB drive.

    I've noticed this… most of the time if I run "service smbd stop" and "service nmbd stop" in telnet or the sytem tab BEFORE rebooting, I don't get the problem on startup. It shows the proper workgroup name and ip of the router (acting also as wins server).

    I've tried various "sleep" settings for the init and wan up scripts, sometimes it works and sometimes not. I was thinking the scripts had thrown off the timing of the boot operations and were causing the issue, but I think this may be happening regardless.

    My questions are these:

    1) Should I be stopping these services before a reboot? The fact that it seems to solve the issue may just be coincidence or…. ?
    2) I notice when restarting SMBD, it also restarts aspects of dnsmasq, thus ruining my wan up script for ad blocking. If I didn't want to reboot again, would executing "service smbd restart," "service nmbd restart" and then renewing the wan ip (to re-fire the wan up script) also be a viable option? I ask this because…
    3) I notice when running top it shows 2 of smbd and nmbd running. My concern is that if I restart the services manually, will it affect the way something else acts? I know the startup timing can be crucial.

    Sorry I'm a bit of a linux newb.

    Thank you!
  77. airbot

    airbot Networkin' Nut Member

    Having limited linux experience myself, I will defer to others with more experience. I'd think though that a detailed description of the configuration settings & script(s) that you are using would make trouble shooting easier and get you better informed answers.

    There are a lot of different ways to implement ad blocking. FWIW, the following approach works well for me. In short I keep the a list of hosts that I want to block on my cifs share (USB drive). A start up script copies this file to /etc, then restarts the dnsmasq service so that the blocking list is applied.

    [permanent location of ad block file]

    [Dnsmasq configuration]
    Advanced | DHCP/DNS: Dnsmasq custom configuration: conf-file=/etc/adblock.conf

    cd /cifs1
    cp /cifs1/adblock.conf /tmp/etc/
    sleep 3
    service dnsmasq restart

  78. ollobollo

    ollobollo LI Guru Member

    Running beta 18 ext. on an Asus RT-N16, I got this rstats error on the bandwidth monitor page:

    It started about a week ago. Today, its uptime was 16 days. My PS3, which I've prioritized in QOS, had terrible wireless performance. All computers, however, seemed to work well, both wired and wireless. I just rebooted the router, and it seems to have solved the problems. That's all I can say.

    Thanks again for tirelessly improving this firmware.
  79. ladysman

    ladysman Network Guru Member

    I've used beta19 for a couple of weeks now and its been flawless (this includes VPN usage). There is however 1 problem that occasionally happens and the weird part is not all devices at once.

    The appleTV (Wireless) and my iphone 4 will ocassionaly (happened twice each so once a week) will not remember the password on the wireless. THus I have to retype them in. The devices immediately see the network, I just have to reenter the password. On my phone, it's not an issue really, as I just type it in.

    However on the AppleTV, it won't sync then since it can't connect to the network. I have at least 8-10 devices that are all fine except those two. This includes my wife's 3GS iphone.

    I looked at the log but really see nothing out of the ordinary. Plus, its only got today's activity. I haven't set anything to create a log as i've never had the need.

    And yes, both of these devices are Wireless N if that helps.

  80. airbot

    airbot Networkin' Nut Member

    This just means that the rstats process is busy or perhaps crashed. If it was just a one time glitch and works fine after a reboot, don't worry about it. I didn't see that problem when I was using beta 18 (I'm now using beta 19 - VPN build).

  81. airbot

    airbot Networkin' Nut Member

    Have you tried resetting the iPhone network settings via settings/general/reset?
    Resetting tends to resolve most network-related issues.

  82. ladysman

    ladysman Network Guru Member

    That doesn't solve the AppleTV that i'm most concerned about though.
  83. airbot

    airbot Networkin' Nut Member

    Why not? Did you try resetting the Apple TV configuration to see if it resolved the problem?

  84. ladysman

    ladysman Network Guru Member

    Restore the software and reload? no way, it will take hours to set it all back up and move the content over. I just did it to my phone so we'll see if it fixes it.
  85. airbot

    airbot Networkin' Nut Member

    I don't have an Apple TV, so double check this information, but can't you reset just the networking configuration by pressing & holding the menu and - keys on the remote for about six seconds? In any event, I think that the problem originates with Apple & not Tomato.

  86. groosh

    groosh Addicted to LI Member

    build problem

    having a build problem, hoping that someone that does builds will be able to assist.

    I am running Ubuntu 10.04, I believe that I have everything installed correctly...

    I am executing: sudo make r2e (have also tried sudo make V1=0000 V2=0000 r2e) (have also tried using r2m with the two commands also)

    Each of the four produce the same problem:

    make[5]: Entering directory `/home/user/code/tomato/release/src/lzma-loader'
    mipsel-uclibc-gcc -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 -mno-abicalls -fno-pic -ffunction-sections -pipe -Wa,--trap -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -DLOADADDR=0x80001000 -D_LZMA_IN_CB -I/home/user/code/tomato/release/src-rt/include -I/home/user/code/tomato/release/src-rt/lzma/C/Compress/Lzma -D__ASSEMBLY__ -DBZ_TEXT_START=0x80500000   -c -o head.o head.S
    make[5]: mipsel-uclibc-gcc: Command not found
    make[5]: *** [head.o] Error 127
    make[5]: Leaving directory `/home/user/code/tomato/release/src/lzma-loader'
    make[4]: *** [lzma-loader] Error 2
    make[4]: Leaving directory `/home/user/code/tomato/release/src/router'
    make[3]: *** [all] Error 2
    make[3]: Leaving directory `/home/user/code/tomato/release/src-rt'
    make[2]: *** [bin] Error 2
    make[2]: Leaving directory `/home/user/code/tomato/release/src-rt'
    make[1]: *** [e] Error 2
    make[1]: Leaving directory `/home/user/code/tomato/release/src-rt'
    make: *** [r2e] Error 2
    user@ubuntu:~/code/tomato/release/src-rt$ echo $PATH
    The command mipsel-uclibc-gcc is in my path but for some reason it will not work, any ideas?


    p.s. if I do not use sudo the make errors out much earlier in the process with a permissions problem.
  87. ladysman

    ladysman Network Guru Member

    Not sure if the AppleTV has it. I'll check when i get home and report back.
  88. mstombs

    mstombs Network Guru Member

    You do not have to use sudo

    I use this little script on Ubuntu 10.04 to compile from git

    cd ~/tomato.git/release/src-rt
    sudo rm /opt/brcm
    sudo ln -s ~/tomato/tools/brcm /opt/brcm
    export PATH
    LOG=~/log$(date '+%Y%m%d%H%M%S').txt
    #time make V1=mst15 V2="NDUSBExt" s $@ | tee $LOG
    time make V1=0000 V2=0000 r2e $@
    with result just now

    Creating TRX: image/tomato-K26USB-1.28.0000MIPSR20000-VPN.trx
    TRX Image:
     Total Size .... : 7864320 (7680.0 KB) (7.5 MB)
       Images ...... : 7860996 (0x0077f304)
       Padding ..... : 3296
     Avail for jffs. : 0 EBs + 0
     CRC-32 ........ : DFAADF46
     128K Blocks ... : 60 (0x0000003C)
      64K Blocks ... : 120 (0x00000078)
       0: 0x0000001C  lzma-loader/loader.gz
       1: 0x00000A8C  tomato.git/release/src-rt/linux/linux-2.6/arch/mips/brcm-boards/b
       2: 0x000D9C00  router/mipsel-uclibc/target.image
    1.28.0000 MIPSR20000 K26 USB VPN  ready
    The time output didn't work properly, but what may be important is

    $ $ uname -a
    Linux i6600quad 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:38:40 UTC 2010 x86_64 GNU/Linux
    $ ls -laF /bin/sh
    lrwxrwxrwx 1 root root 4 2010-04-02 10:57 /bin/sh -> dash*
  89. groosh

    groosh Addicted to LI Member

    thanks mstombs with a few minor modifications to match my file structure the script worked great!

    One more question if I may, how do you update your repository on your hard drive from the git repository without having to download the entire tar each time?
  90. ladysman

    ladysman Network Guru Member

    The sequence above only reboots the apple TV. you can't just reset network settings either.

    However, I thought of something last night. I redid my network completely when i flashed with beta 19. I used to not use encryption. I do now. however, I kept the same SSID. I wonder if this is causing the problem. Hmm...thoughts?
  91. karog

    karog Networkin' Nut Member


    In your first PATH line you have /usr/bin twice. Did you mean the last one to be /usr/sbin?
  92. gingernut

    gingernut LI Guru Member

    git fetch command from the git directory.
  93. airbot

    airbot Networkin' Nut Member

    Seems like your best shot, so why not try changing the SSID? It's plausible that your Apple TV is still expecting the previous unencrypted setting. With a SSID change, a completely new profile may be created that will stick.

  94. greenythebeast

    greenythebeast LI Guru Member

    Is anyone aware of integrating HFS and HFS+ drivers into Tomato? I found the driver here: but have no clue as to how I would make it work with TomatoUSB :( I need HFS so very bad, please help!
  95. spookyneo

    spookyneo Networkin' Nut Member

    I had a weird issue tonight, maybe someone can help me out.

    I currently use OpenVPN with static key on VPN Server 1.

    I'm trying to setup a VPN Server 2 using TLS and SSL certificates. Everything was working fine, until I put the VPN Subnet/netmask to my LAN subnet.

    The default VPN Subnet in Tomato is When I did my tests to make sure that my SSL certificates were working, I forgot to change the VPN Subnet. My OpenVPN GUI on my computer could connect succesfully and gave me an IP of So far, so good.

    My LAN is So I therefore decided to change my VPN Subnet to Saved the settings in Tomato and then hit the start button to start the VPN Server. My router just stopped responding. Could not connect to SSH, HTTP, or anything. I did a hard reboot on the router, but I never came back. Possibly because I checked the Start with WAN option in VPN Server 2. I had to reset the settings to default of Tomato and restore my config file.

    Can I put my LAN subnet in the VPN subnet ? Am I doing something wrong ? My DHCP settings are from to only. Could it be related ? I guess the VPN use the DHCP server to address IPs.

    My router is an RT-N16 with TomatoUSB 1.28 build 49 (VPN fix).

    Thanks for any help !
  96. maurer

    maurer Network Guru Member

    I currently don't have the resources to build the tomato firmware from source.
    Can any of you build me k24 tomato-NDUSB-Ext to test with wl-500g Deluxe - i noticed support in the git for it.
    you can pm me the link.
  97. mstombs

    mstombs Network Guru Member


    I used SGTPepperSKU's instructions at some time use the "git" command to clone the repository into my PC.

    I then do not store the build script inside the tomato.git directory - because it may get reset/ flagged as addition. Then you can update using "git pull". I have this bookmarked

    because sometimes things don't compile, so I delete the folders and checkout a fresh clean copy - this usually works!


    I'm sure I did, but clearly not important. I do remember having to explicitly set the PATH inside the script, so it is not dependent on other apps changing the default PATH - I attempted to "capture" an old one that worked, after having that issue! The export command allows all called programs to use the new path, but it is forgotten when the script ends.

    I play around with compiling many different versions/ architectures hence the explicit patch to /opt so the correct toolchain is used - similar folders used by stock tomato etc.


    time -f "%E real, %U user, %S sys" make ...
    gives a better formatted time output.
  98. karog

    karog Networkin' Nut Member

    So to answer your question, that would be a no.

    What are you trying to do? Will your VPN client be another network or just a single machine? If the latter, is it that you want that machine when connected to the VPN to be as if it were on the LAN having an IP address from the LAN? If so, then you want to use TAP rather than TUN. TUN is routed access and TAP is bridged access. TUN is more efficient but TAP is more featured.

    So to answer your direct question, no, you cannot make the VPN and the LAN share the same subnet. But the larger question is why do you want to? What are you really trying to accomplish? You are more likely to get a useful answer if you specify that.

    Too many times people ask a narrow technical question in service of an ill advised strategy when what they really need help with is the strategy.
  99. spookyneo

    spookyneo Networkin' Nut Member

    Very good explanation, thank you.

    I guess I mismatched TAP and TUN. What I am trying to do is use my laptop anywhere in the world to connect on my OpenVPN Server on the router. From what I'm reading, I should use TAP instead. And looking at TAP, I just noticed that a DHCP checkbox appeared.

    Then, should I use TUN only for VPN Tunnels ? A site-to-site permanent tunnel for example.

    To sum it up, what I want to do, is connect laptops from the internet, to my router.
  100. karog

    karog Networkin' Nut Member

    Yes, TUN is probably the better choice for connecting two sites together

    I use TAP for this and it works great. Your laptop will get an IP address from the LAN and will thus act just as if it WERE on the LAN. You can do anything you could do if the laptop were wired into the router directly. No ports to forward in the router for this because your laptop is already inside on the LAN.

    If you check "Direct clients to redirect Internet traffic" on the VPN server and the VPN client supports it or if you add redirect-gateway to the client config on the laptop, then all internet traffic on the laptop will go through the VPN and out the router to the internet which is much safer in public venues.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice