Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. jubei_nj

    jubei_nj Addicted to LI Member

    I've got fiber - 30mbps down/15mbps up. Not doing large transfers....the signal just isn't getting to the living room where it had no issue with my other 2 routers.
  2. though

    though Network Guru Member


    also, just to confirm im not missing anything, when i set up the wireless ethernet bridge, i just enter in an ip address on the network, use the same network mask, enter the router's ip as the gateway and first entry of static dns, along with the correct security and that's it? any other changes or settings need to be changed/entered?

  3. karog

    karog Networkin' Nut Member

    If you don't mind my asking, which tomato build exactly are you running on the WHR-HP-G54?

    I am hoping to install a VPN version but the router is 3K miles away and will have to await my next visit. No remote flashing for me.
  4. jubei_nj

    jubei_nj Addicted to LI Member

    I'm using a stock 1.28 not the Tomato USB mod.
  5. Spyros

    Spyros LI Guru Member

    Thanks for taking notice to this and answering:)

    I think that the rule responsible for TVU not working is this


    but unfortunately can't test anymore because i

    succesfully converted my WRT320N to an E2000

    and now have the advantage of 60K NVRAM instead of 32K and all the bugs of the WRT320N CFE resolved, like reset button working and the ability to do a 30/30/30 reset.

    Hope that there will be a Tomato release for routers with 60K NVRAM like E2000 soon in order to retest and be a happy member of Tomato community.
  6. teddy_bear

    teddy_bear Network Guru Member

  7. Spyros

    Spyros LI Guru Member

  8. gwww

    gwww Addicted to LI Member

  9. though

    though Network Guru Member

  10. gingernut

    gingernut LI Guru Member

    One thing you forgot is to change the routing mode from gateway to router.

    Goto Advanced --> Routing --> Miscellaneous --> Mode
  11. greenythebeast

    greenythebeast LI Guru Member

    I never really thought about this until recently, but when it says 3.73 under CPU Load, does that mean 3.73% of the CPU is being used or something else?
  12. though

    though Network Guru Member

    made absolutely zero difference in speed. i would assume this setting is not needed, maybe teddy can confirm??
  13. cariyawa

    cariyawa Addicted to LI Member

    This might help.
  14. rhester72

    rhester72 Network Guru Member

    Perfect. Any voodoo I need to do for PPPoE? Supposedly Earthlink supports it, but there was a lot of hokeyness about being a part of a beta program, etc., etc. - about three years ago. If anyone has successfully gotten an IPv6 IP over PPPoE without having to do anything (other than the above), I'll know it's an Earthlink problem and back off. ;)

    For what it's worth, I am able to do IPv6 name resolution via Google's servers (over IPv4, of course).

  15. Guitar1969

    Guitar1969 Networkin' Nut Member

    Wireless Super G supported ?

    Just got set up running the latest 1.28 beta on an Asus RT-N16 - So much easier to set up usb storage compared to DD-WRt(Which I could not get running). Is USB disk spindown something I need to address with Tomato(which is a problem with DD-WRT)

    Working well, but the only question i have is if it supports Super G MIMO type wireless technology(which gets a max of 108Mbps). I am running 40mhz(For my N adapter) in Tomato. but I also have a Netgear Rangemax G adapter on my other computer and was getting 108Mbps(not real world obviously but max capability as reported on the installed PC)) on DD-WRT and my older G router, but now speed is only at 54Mps on my RT-16N and Tomato so its running in single channel mode(if that's the correct terminology for MIMO). Is there something Im missing or is it not supported.

    I will most likely upgrade to N on this PC as well, but would like to get max speed if possible with current hardware.

    Thanks for your help, and all the great work you do.
  16. though

    though Network Guru Member

    well, well, well.... if i switch to "Client Mode" instead of "Bridge" on the N12, all speeds are blazing fast and stability is rock solid, couldn't be happier.

    QUESTION: how do you log into a tomato router that is on the same network but different subnet? i can't figure out for the life of me!!


    should speeds/connectivity be crippled on a unit that is running "Wireless Ethernet Bridge" mode as opposed to "Wireless Client"?
  17. Hexxer

    Hexxer Networkin' Nut Member


    just a little Feedback: On my LS WRT160N Tomato (build 50) works good.
    Im new on tomato.

  18. bagu

    bagu Network Guru Member

    Since broadcom drivers are open source, maybe the kernel limitation will disapear ? (great new if so)
  19. bripab007

    bripab007 Network Guru Member

    Might not necessarily make a difference to speed, but it might make a difference on whether or not you have excessive packet collisions or other networking problems.
  20. though

    though Network Guru Member

    is it supposed to be set to 'gateway' only if it's being used as the main router gateway? and to 'router' if it's being used as a bridge, client, AP, and a secondary WDS?
  21. though

    though Network Guru Member

    how do you disable the firewall when in 'wireless client' mode? with this on i can't access the tomato interfaces when on different subnets???
  22. gingernut

    gingernut LI Guru Member

    It should be set to router mode if it's being used as anything but your main gateway.
    I'm not 100% certain but changing it to router mode you turn off the firewall and some other unused services.
  23. though

    though Network Guru Member

    im pretty sure the firewall is still enabled in router mode :(
  24. teddy_bear

    teddy_bear Network Guru Member

    pppoecd needs to be started with "-6" parameter to enable IPv6. Search for posts by Polaris75 on this forum - he actually submitted a patch to implement IPv6 support in pppoecd.
    Thanks for being insistent on this, and for the "lsmod" output!.. That helped me to find a very old (was there since the 1st K26 beta) and very obscure bug (argh - thanks to Asus for including invalid ancient headers into their kernel tree :mad:). Would you be willing to flash a new test build to verify if PPTP conntrack now works for you?
    bagu, could you too try the above test build? It may fix the RTSP helper as well...
  25. spookyneo

    spookyneo Networkin' Nut Member

    I've been running on build50 all day and so far so good. My wireless doesn't seem to drop anymore (my clients were getting disconnected after few hours on build49 and I had to reset the wireless in Tomato).

    I had to rebuild miniDLNA database due to the new "format". However, it seems to be scanning faster the file in build50.

    I've come accross a weird bug in Samba File Sharing. Let's say that I wanna share the directory "/mnt/Media/Downloads", well I can't give a Share Name of "Downloads", because I won't be able to access it. Accessing the share from Windows will give my a location not found when I click on Downloads. However, if I name the share "Downloads Folder" or anything else other than "Downloads", it will work. Anyway is having this issue ?

    As always, thanks TB for the build :)
  26. RavenII

    RavenII Networkin' Nut Member

    HFS or GPT or MBR? To journal or not to journal?...I'm trying to figure this many others are too...
  27. karog

    karog Networkin' Nut Member

    Are you trying to run OS X on your router? Good luck with that.

    Otherwise, what is the context of your question? Linux ain't all that hip to HFS+. Its gparted is rather ignorant of HFS+.

    If you are just talking about USB attached storage, you are probably better off going with ext3.
  28. bagu

    bagu Network Guru Member

    No problem (this test build ?)

    EDIT : rtsp contrack still don't work unfortunately.
  29. occamsrazor

    occamsrazor Network Guru Member

    Just to report back... I moved my WL-500GPv2 from tomato-K26USB-1.28.9049MIPSR1-beta19-vpn3.6.rar, to the latest tomato-K26USB-1.28.9050MIPSR1-beta20-vpn3.6 last night and had some fairly major probems, namely that the wireless didn't work.

    No, I didn't erase the NVRAM.... as all previous upgrades had worked fine without doing so.

    Unfortunately I don't have much time to troubleshoot at the moment, but the problem seemed to be that wireless clients either weren't connecting, or they were connecting and getting no DHCP address. Wired clients worked fine.

    One thing I did notice was that in the Wireless settings after upgrading, the "Beacon interval" field was empty. I manually changed it to the default of 100, but that didn't help. No idea if that was related to the problem or not.

    I then reflashed back to build 49, that didn't work either, so reflashed build 49 again, erased all NVRAM, and restored configuration using a known-working previously saved configuration, and it's working fine again.

    Like I say, I don't really have much time to troubleshoot now, so I will stick with build 49 for the foreseeable future, but thought best to mention it.

    On another note, does anyone know a way to automatically save a copy of the configuration e.g. once a day, on a USB or CIFS share? Preferable with a filename based on date so that today's won't overwrite yesterday's....
  30. teddy_bear

    teddy_bear Network Guru Member

    That is the clear indication of nvram corruption, and why erasing the nvram is recommended in case of any weird issues. The most probable reason for this is nvram getting full - the way nvram driver is implemented it is not complaining about that - it just starts cutting off the data that doesn't fit anymore...

    No need to flash and reflash firmware in this case. What you need is to erase nvram and reconfigure manually, keeping close eye on the used nvram space (run "nvram show" from time to time, and check out the size user and size free at the end of the output). What this also helps to do is to get rid of all old and no longer used nvram variables that were left over from previous versions...

    VPN version is prone for nvram overflow since it keeps pretty large SSL certificates in nvram. I believe SgtPepperKSU has posted once how you can move the certificates from nvram to external files on JFFS or USB partition - search the VPN Mod thread for these directions.
  31. greenythebeast

    greenythebeast LI Guru Member

    You'll have to load the hfsplus module using insmod. GPT and MBR both work. No journaling.
  32. RavenII

    RavenII Networkin' Nut Member

    Thank you!

    Sorry if the question was worded in a really ignorant matter, but I've posted before without a response, as have many others.

    I will try this again, I've had it formatted HFS (GPT) (not HFSPlus or Journaled)...and couldn't get it to mount, but I'm going to try fiddling with it again.

    Thanks again for the response, I will post progress for those who want to do this. There are more and more people running OSX, I'm sure there are a ton of people that would love to do this, I'm personally sick of having it connected to my Mac Mini and using it as a NAS...
  33. greenythebeast

    greenythebeast LI Guru Member

    HFS+ works fine.
  34. RavenII

    RavenII Networkin' Nut Member

    I wonder if my enclosure has something to do with it...hmm...damn it, time to reformat it.
  35. occamsrazor

    occamsrazor Network Guru Member

    Thanks, that does make sense now.

    Yes I know you are right... but it's SO MUCH hassle having to redo everything. I've read the various ways to save settings e.g. a saved web page that you then submit, but have never been able to get it to work properly. I have over 30 static DHCP entries, 20-30 port forwarding rules, and about 20 QoS rules..... it takes forever to re-enter them all by hand.

    I'll have a look for that, I didn't actually realise there were problems of NVRAM running out through large settings files. It's true I have 2 x VPN servers and 1x VPN client settings/certificates, however they were all running fine before the upgrade.

    One thing that occurred to me though - where does the info from the new "Web Monitoring (domains and searches)" get stored - in NVRAM? After I flashed to the latest firmware this was set to 300 entries each, and I then upped it to 1000, just to see what it was like. If that info is being stored in NVRAM, then it seems to me that it's a likely suspect in filling up the NVRAM....
  36. karog

    karog Networkin' Nut Member

    You can dump those rules with the nvram command to a file in a textual format. Then after clearing NVRAM, you can load them back in. You still have to watch for running out of NVRAM space.

    Look into: nvram export --set
  37. madmalkav

    madmalkav Networkin' Nut Member

    What compile-time optimizations are being used when building? I have read on the WNR3500L forum of some guy getting some interesting improvements both in network throughput and USB file sharing speed using compile-time optimizations when building DD-WRT and I'm curious if those are being used. If not, I will probably try to compile myself and compare as soon as I get my main PC back.
  38. oldoks

    oldoks Networkin' Nut Member

    Adduser to login Tomato Web-UI with "view" mode?

    I'm using Asus RT-N16 with tomato-K26USB-1.28.9050MIPSR2-beta20-vpn3.6.
    Only root or admin account can login Tomato WebUI(
    How to Adduser to login Tomato Web-UI with "view" mode?
  39. RavenII

    RavenII Networkin' Nut Member

    Ok, regarding my trying to mount HFS+

    I do...
    mount -t hfsplus -w /dev/sda1 /mnt/Little\ Lady/

    and get
    mount: mounting /dev/sda1 on /mnt/Little Lady/ failed: Invalid argument

    Am I doing something wrong?
  40. greenythebeast

    greenythebeast LI Guru Member

    Try sda2
  41. RavenII

    RavenII Networkin' Nut Member

    I only have sda and sda1...
  42. greenythebeast

    greenythebeast LI Guru Member

    Do you have a GPT partition table?
  43. RavenII

    RavenII Networkin' Nut Member

    Yep, I'm almost 100% it's GPT...
  44. greenythebeast

    greenythebeast LI Guru Member

    Using the latest build? If you aren't using the latest build the GPT is causing the problem and we can fix it with a little effort. If you're on the latest build and you've loaded the hfsplus module using insmod I'm not sure what is wrong. teddy_bear might be able to help.
  45. RavenII

    RavenII Networkin' Nut Member download mine from

    Tomato Firmware v1.28.9048 MIPSR2-beta18 K26 USB Ext...
  46. though

    though Network Guru Member

    beta 20 is the latest...
  47. RavenII

    RavenII Networkin' Nut Member

    Son of works. Slower than using my Mac Mini as Nas (7-8 MBps avg for both AFP and SMB...) as opposed to the 4 I get with the router...but it definitely works....thanks guys.
  48. Guest

    wireless Transmit Power on asus rt-n12 does not work, the settings are saved, as can be seen via wl txpwr1, wl txpwr, as well as nvram show, but it has no effect in signal strength seen on netstumbler(also tested with dd wrt, which does change signal strength to confirm netstumbler works). also did reboots to double check.

    settings used:
    access point

    tested firmware:
  49. silverchariot

    silverchariot LI Guru Member

    I think I have a similar issue with my RT-N12, running beta20.

    Country = Japan.
    Wireless Mode = Auto.
    Channel Width = 40MHz.
  50. teddy_bear

    teddy_bear Network Guru Member

    The kernel (the only critical component for networking throughput) in Tomato K26 has always been compiled with -O2. There's definitely a room to speed it up more - but by backporting various kernel improvements from the upstream rather than by optimization flags.

    Looks like the latest beta 20 gives the same or better throughput as optimized kong's dd-wrt mod (and much better than the mainstream K26 dd-wrt).
    As for Samba, in my tests I saw no noticeable difference in speed between -Os, -O2 and -O3 builds (while anything other than -Os significantly increases the size of the binaries).

    Of course, you can always experiment if you'd like - go through the various Makefile's in the Tomato source tree, and try different compile options. If you do - please post your results here, or on the Tomato USB forum.
    Pay attention to what GUI says: "actual max depends on Country selected". Search the forum for more details - it has been discussed many times before.
  51. madmalkav

    madmalkav Networkin' Nut Member

    Thanks for the info :)
  52. Guest

    re: asus rt-n12 tx power

    i did try with US, and a few other countries including zimbabwe, austria, taiwan, uk.
    tested power settings: 1mw, 17mw, 42mw, 71mw, 250mw, all with no difference in signal
  53. ladysman

    ladysman Network Guru Member

    I've been using beta 20 since this note you sent which was 9 days ago. not 1 dropout so I can confirm this has been fixed for me! :)
  54. HanzF

    HanzF Addicted to LI Member

    Beta 20 running great here on RT-N16 since it came out......thank you!
  55. cariyawa

    cariyawa Addicted to LI Member

    Once in a while, I had that with beta20, zero dropouts. :biggrin:
  56. chriswieringa

    chriswieringa Addicted to LI Member

    Still the same results as beta20 with the test build. Let me know if you need anything else that would help figure out what's going on. (Sorry about the delay getting back to you!)


    PPTP/GRE Conntrack on, Doesn't work.

    root@cronus:/tmp/home/root# lsmod
    Module                  Size  Used by    Tainted: P
    nf_nat_pptp             2592  0
    nf_conntrack_pptp       6000  1 nf_nat_pptp
    nf_nat_proto_gre        2128  1 nf_nat_pptp
    nf_conntrack_proto_gre     4160  1 nf_conntrack_pptp
    ipt_webmon             20576  1
    cifs                  280160  1
    nf_nat_ftp              2816  0
    nf_conntrack_ftp        8160  1 nf_nat_ftp
    nf_nat_sip              4416  0
    nf_conntrack_sip        9024  1 nf_nat_sip
    wl                   2051584  0
    igs                    17904  1 wl
    emf                    22656  2 wl,igs
    et                     59040  0

    PPTP/GRE Conntrack off, works fine.

    root@cronus:/tmp/home/root# lsmod
    Module                  Size  Used by    Tainted: P
    ipt_webmon             20576  1
    cifs                  280160  1
    nf_nat_ftp              2816  0
    nf_conntrack_ftp        8160  1 nf_nat_ftp
    nf_nat_sip              4416  0
    nf_conntrack_sip        9024  1 nf_nat_sip
    wl                   2051584  0
    igs                    17904  1 wl
    emf                    22656  2 wl,igs
    et                     59040  0
  57. teddy_bear

    teddy_bear Network Guru Member

    Then I don't know...
    With previous builds, including beta 20, I finally was able to reproduce the problem by unloading xt_layer7 module - that was the "right" combination that kicked it off for me. But after I found and fixed that old bug, I could not break it anymore no matter what I try... Are you using QoS? What's your WAN connection type?

    If you don't mind, I'd like you to backup your settings in Tomato, and PM me your config file - maybe I'll be able to get the same results with your exact configuration...
  58. Aaron

    Aaron Networkin' Nut Member

    I'm having trouble getting 3 APs to work in Access Point + WDS mode.

    I have an N16 and 2 N12s. I would like to WDS them like this:

    The internet comes through the N16 and is set up to link with each of the N12s. Each N12 is set to link with the N16. In WPA Personal with AES I can get the N16 and one N12 to work, but trying to get the 2nd N12 to play nice is near impossible. I can sometimes get both N12s onboard, but I am unable to access anything on the 1st N12(if connected to N12#1, I'm unable to ping anything on N12#2, and vice-versa.) I ONCE was able to get everything to work perfectly in WPA Personal with AES, but once I rebooted 1 AP the entire chain broke. I have not been able to reproduce that scenario where all 3 AP work again.

    BUT, if I run all 3 APs in WEP mode, everything works flawlessly. I would really like to get it to work with WPA security. Am I missing a setting? I followed the Tomato FAQ here:
  59. Toastman

    Toastman Super Moderator Staff Member Member

    He's dead Jim ...

    After compiling stuff from git successfully using Linux Mint for some months, I'm puzzled. Today for no apparent reason the same code that worked fine suddenly failed to compile five minutes later, and I have the dreaded radvd error message. This time it's refusing to correct itself. A new pull from git is the same. I'm going to try Ubuntu 8.04 after pulling out what little hair I have left - but this is crazy!

  60. mstombs

    mstombs Network Guru Member

    @Toastman - simplest workaround is to disable IPV6 if you don't need that. As I pointed out earlier the ancient version of radvd is the problem.

    Rodney has also compiled the latest version of radvd - apparently without even the need to avoid the -lfl function that the both the current tomato and OpenWRT versions patch out. Just needs someone to check any Tomato specific configuration integration required.
  61. rhester72

    rhester72 Network Guru Member

    There doesn't appear to be anything Tomato-specific required for the radvd build - it "just works". aiccu, on the other hand... *laughs* Suffice it to say that for tunneling you're probably better off with someone other than sixxs.

  62. teddy_bear

    teddy_bear Network Guru Member

    Upgrade to the latest build 50 / beta 20 if you didn't do that yet.

    If you still can't make it to work, try to contact jnappert for some advises, who seemed to have the similar configuration, and similar problems - but reportedly they have been resolved in the last build.
    I checked in updated radvd to git - hope it will resolve compile problems some people experienced.
  63. rhester72

    rhester72 Network Guru Member

    New radvd seems fine, drop-in replacement for my build.

    One question, though - why disable privsep?

  64. mstombs

    mstombs Network Guru Member

    Thanks tb, you have been busy over 25 meg git download, needed a distclean to get samba3 to compile but it all does now on my 64-bit Ubuntu

    make V1=0000 V2=0000 r2e
    Creating TRX: image/tomato-K26USB-1.28.0000MIPSR20000-VPN.trx
    TRX Image:
     Total Size .... : 7020544 (6856.0 KB) (6.7 MB)
       Images ...... : 7018896 (0x006b1990)
       Padding ..... : 1620
     Avail for jffs. : 0 EBs + 0
     CRC-32 ........ : 6672C19F
     128K Blocks ... : 54 (0x00000036)
      64K Blocks ... : 108 (0x0000006C)
       0: 0x0000001C  lzma-loader/loader.gz
       1: 0x00000A8C  /home/user/tomato.git/release/src-rt/linux/linux-2.6/arch/mips/brcm-boards/b
       2: 0x000ED800  router/mipsel-uclibc/target.image
    1.28.0000 MIPSR20000 K26 USB VPN  ready
  65. Toastman

    Toastman Super Moderator Staff Member Member

    Great news re radvd - thanks everyone ! K26 Compiles fine again now. I have a problem with K24 - new toolchain ... maybe... or is it me?

    EDIT - the symlinks in /opt/brcm still pointing to old directories which aren't there any longer. Changed with:

    ln -s K24/hndtools-mipsel-uclibc-4.2.4 hndtools-mipsel-uclibc
    ln -s K24/hndtools-mipsel-uclibc-4.2.4 hndtools-mipsel-linux
  66. LanceMoreland

    LanceMoreland Network Guru Member

    I just replaced a few WRT54G routers with a couple of Netgear WNR3500L Routers and have Teddy Bear's latest (Extra) build running on them. I wanted gigabyte connections and N wireless. Everything is working. The one thing that is very noticeable is that wireless signal quality is at least half of what it was with the WRT54G units and I can't get the full download speed of my internet connection on the G wireless machines like I could with the WRT54G units.. What am I missing here.
  67. x-demon

    x-demon Addicted to LI Member

    Just wondering - dual-band for Asus RT-N16 has software or hardware lock?

    Also, what about IPv6 tunnels support?
  68. occamsrazor

    occamsrazor Network Guru Member

    Isn't the RT-N16 2.4Ghz single-band only? Or am I misunderstanding your question...

    I'm very interested in a dual-band router that is supported by Tomato, but I'd thought the only one so far was the WRT320N which is dual-band, single radio only i.e. not simultaneous dual-band.
  69. x-demon

    x-demon Addicted to LI Member

    Wireless module support dualband.
  70. x-demon

    x-demon Addicted to LI Member

  71. Toastman

    Toastman Super Moderator Staff Member Member

    It's not that they disabled it. They didn't add the extra support components for the 5GHz band to the router in the first place! So it can't just be "enabled".
  72. gingernut

    gingernut LI Guru Member

    What about a broadcom based 5GHz wireless dongle attached via usb for simultaneous dual band support?
  73. LanceMoreland

    LanceMoreland Network Guru Member

    Further to this: While researching the low signal quality issue, I read that the WNR3500L uses multiple antennas to gather signals simultaneously. Is it possible that this is firmware driven and Tomato is not taking advantage of that hardware feature? I thinking about going to the stock firmware to see if there is a difference. Thoughts?
  74. karog

    karog Networkin' Nut Member

    This is a case of a little knowledge is a dangerous thing, especially when it is derived from the InterTubes.

    To quote: Wireless-N uses multiple technologies such as MIMO (Multiple Input, Multiple Output), which utilizes multiple radios [and antennas] to transmit and receive at the same time to maximize wireless networking performance.

    This is not unique to the WNR3500L. Tomato is not taking advantage of this? Have fun trying to find that difference between Tomato and stock firmware. Just be aware that you will never get that wasted time back.
  75. LanceMoreland

    LanceMoreland Network Guru Member

    This is on a WNR3500L, I set the transmit power to "0" for hardware default and it now reports:

    Tomato v1.28.9050 MIPSR2-beta20 K26 USB Ext
    root@Tomato-2:/tmp/home/root# wl txpwr1
    TxPower is 127 qdbm, 31.75 dbm, 1496 mW Override is Off

    I was expecting 42 mW or so. 1496 mW can't be correct.
  76. TexasFlood

    TexasFlood Network Guru Member

    When I got my RT-N16, right out of the box running the "as shipped" firmware v1.0.0.6, I ran "wl txpwr" from the Main_AdmStatus_Content.asp page and got "31.75 dBm = 1496 mw". While obviously this didn't sound right and I've always wondered about it, it seemed to be the factory default for the RT-N16.
  77. LanceMoreland

    LanceMoreland Network Guru Member

    Well that offers some comfort. I was beginning to wonder it the thing was going to burst into flames. Thanks.
  78. TexasFlood

    TexasFlood Network Guru Member

    I felt the same way after seeing it. I still would like to understand it. At the time I assumed no matter what the setting was, it would in reality peak out at whatever the legal limit in the wireless driver would allow. But that's just me guessing, I really don't know and would like to if anyone can enlighten me.
  79. maurer

    maurer Network Guru Member

    how expensive is that :) ?

    how expensive is that :) ?
  80. mstombs

    mstombs Network Guru Member

    Are there any Broadcom wireless N usb dongles with Linux PC support? Ralink chipset is pretty popular! The recent Broadcom driver release is work-in-progress and will be in future Linux kernels, so the chances of back-porting to Tomato would be slim - even if the Routers had the CPU power to cope, which is a big if!
  81. LanceMoreland

    LanceMoreland Network Guru Member

    I am runing two WNR3500L's, one is serving as a main router and the other is wired in serving as an Access Point only. I have had a similar setup for years and everything seems to be working fine but I keep getting this in the log files of both units>

    Sep 22 17:39:55 Tomato-1 user.warn kernel: eth1: received packet with own address as source address

    Anyone know what is causing this?
  82. myersw

    myersw Network Guru Member

  83. LanceMoreland

    LanceMoreland Network Guru Member

    I think I have narrowed down what is causing this message. It seems that as devices move from one access point to another this message is generated. Is there anyway to keep the routers from logging this event?
  84. though

    though Network Guru Member

    ****rt-n12 or rt-n16 in Ethernet BRIDGE mode****


    if im not mistaken, you mentioned that you use a RT-N12 in ethernet bridge mode. is this correct? if you do, what do you have connected to it? if you're not using a windows machine, can you **OR ANYONE ELSE** plug one in and try downloading something? i get total sh!t download speeds on both the N12 and N16 on a WinXP machine and Win7 machine, however on my ubuntu notebook, i get full speeds. this is driving me NUTS!

    couple download links below to test speeds:
  85. LanceMoreland

    LanceMoreland Network Guru Member

    Anyone know what this means? I get it on a fairly regular basis in my logs:

    Sep 25 11:23:15 Tomato-2 user.debug ddns-update[11939]: Breaking /var/lock/ddns.lock
  86. x-demon

    x-demon Addicted to LI Member

    Does Wireless Ethernet Bridge working? For me, after i choose that mode in wireless settings, wifi indicator starts blinking for infinity time after reboot.

    But i can use LAN ports and see in my router that wired networks works okay, as well as internet.

    Asus RT-N16, details in sig :)
  87. 3lackhawk

    3lackhawk Addicted to LI Member

    Earlier, I had tried K2.6 but my Asus WL500W router bricked with it and I got back the K2.4 version.Today, I flashed the latest K2.6 beta (tomato-K26USB-1.28.9050MIPSR1-beta20-Ext).I was surprised because it was seems to be working as long as I didn't enabled the usb support.After that it made continuous reboot.Unfortunately I don't have serial console that's why I can't see what cause the reboots.I flashed back to K2.4 again which is working with usb support.I think something wrong about the usb support in the K2.6 build.
    Is somebody tried K2.6 on similar asus router?
  88. acollado

    acollado LI Guru Member

    I have a similar problem with my WL500W. Turning off the USB 1.1 drivers seems to fix it.
  89. though

    though Network Guru Member

    ya Ethernet Bridge definitely works. it's just ***TERRIBLY SLOW*** with windows machines...
  90. teddy_bear

    teddy_bear Network Guru Member

    Well, normally I only had Linux-based clients connected to my RT-N12 running in Wireless Ethernet Bridge mode. But tonight I took time to connect my Win7 laptop to it and test the connection. Oh well... I don't know what's causing your problems, but for me it works as if I was connected directly to the main router - no slow downs at all. While I was downloading some large files from the internet maxing out my WAN connection, I kept pinging the main router - and the ping times never went above 4 ms:
    I really hoped to be able to reproduce the issue (there was another report about the similar issue with WET mode) - but since it doesn't happen here, I have no idea what to "fix", if anything. It would help if you (or anyone else) can come up with a good reproducible test case...
  91. x-demon

    x-demon Addicted to LI Member

    well i can reproduce it (just enable...) but does not see _anything_ related in the logs.
  92. d2globalinc

    d2globalinc Addicted to LI Member

    I've done the same test in WinXP behind an N12 and have the same slow down issues reported. However with a newer HP TM2 Tablet running Ubuntu Lucid 64bit I do not have the issue. What type of network card we're you using in the machine for the Win7 test? I'll reformat the notebook I tested with XP to Ubuntu and see if the same issue exists, and then try Win7 on the TM2 and see if it comes up there..


    - D2G
  93. teddy_bear

    teddy_bear Network Guru Member

    Broadcom NetLink Gigabit Ethernet.
    I'll test it later with an older XP laptop as well.
  94. 3lackhawk

    3lackhawk Addicted to LI Member

    I realised that,unfortunately I can't use K2.6 in this way because I need USB 1.1 for my webcam.

    Is there any possibility to fix this problem in the future?
  95. teddy_bear

    teddy_bear Network Guru Member

    What driver does WL500W use - OHCI or UHCI?

    Are you sure your webcam really needs the USB 1.1 driver? Even if it's 1.1 device, it still should work with USB 2.0 driver as it's backward-compatible with USB 1.1 standard.. Of course, there're exceptions - but have you tried it?

    Unfortunately, without the console output I can't do much about it - I don't have this router, and WL520GU works just fine with K26 MIPSR1 build and USB 1.1 driver (OHCI). What if you disable both - UHCI and OHCI - in the GUI, and manually try to insmod the corresponding module ("insmod uhci-hcd" and/or "insmod ohci-hcd" in telnet/SSH session)? Does loading the module manually cause the router to reboot immediately?
  96. 3lackhawk

    3lackhawk Addicted to LI Member

    Yes I'm sure that the USB 1.1 driver necessary if I turn off the router can't recognize my cam.I tested only in K2.4 builds but I'm not tested separate OHCI and UHCI turn off or on.

    You give a good idea I'll try to enable manualy with instmod and let's see what happen.If I can I prepare serial console and I can see the output.....

    If I have done these, I'll give a report.Thanks the idea!
  97. siaokia_leong

    siaokia_leong Addicted to LI Member

    hmmm..may i know asus n10 should use the build for MIPSR1 or MIPSR2 ?
  98. teddy_bear

    teddy_bear Network Guru Member


    However, make sure you know how to restore your router in case it doesn't work (with Asus routers it's usually easy using Asus Firmware Restoration Utility).

    If you try it, please report your results here. I believe this firmware (no-USB Std build) should work on RT-N10, but I have not heard from anyone yet who actually tried it.
  99. maurer

    maurer Network Guru Member

    this is my serial log with the wl-500gP (almost identical to wl-500w) trying to boot after i enabled usb 1.1 support

    Attached Files:

    • log.txt
      File size:
      10.1 KB
  100. teddy_bear

    teddy_bear Network Guru Member

    Ok, thanks! Was it with both - UHCI and OHCI - enabled in the GUI? Doesn't show much unfortunately... Did the router get into the reboot cycle, or just stopped after the "No change was necessary" message in the console?

    Could you also try what I asked 3lackhawk, and boot up with USB 1.1 disabled, and then try loading the modules manually, and catch the output if any?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice