Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. SoKoOLz

    SoKoOLz Networkin' Nut Member

    OMG!!, I'm so sad. I was trying to upgrade my WRT54GL device from the Original Tomato one to Teddy's one. And flashed by the wrong firmware. And is now bricked...... I guess I will have to buy a new router. Any recommendation? I wanna get the Gigabit one with Wireless-N. Hurrr this is very sad, it was perfectly fine until I ruin it myself T_T.
  2. mstombs

    mstombs Network Guru Member

  3. though

    though Network Guru Member

    **Ethernet Bridge Problem -- Reason found, need solution***

    ok teddy i figured out what's causing the problem after a TON of troubleshooting, hopefully you can come up with a fix. On the computers that have the ping/speed problems, they are either connected to the Homegroup network and/or "network discovery" & "file and print sharing" is turned on in the windows network sharing settings. as soon as i disconnect from the homegroup and/or turn off "network discovery" & "file and print sharing" BAM speeds and pings are 100% normal again. sometimes i need to restart the laptop for the changes to really stick, but this IS what is causing mine and i bet many others problems. this was confirmed on 3 different latops, both 32 bit & 64 bit win7 on different NIC's.

    when it's all disabled, download speeds are 3MB/sec (my isp max), pings are low in the single digits (to main router)

    with it all enabled, download speeds are around 400KB/sec but vary bigtime, pings are all over the map (to main router)

    this behavior is present with Ethernet Bridge mode on both the N12 and N16. I didn't try any other routers.

    if you need any more info from me, please ask!

  4. madmalkav

    madmalkav Networkin' Nut Member

    I start to like this idea. When I bought my WNR3500L some months ago there were plenty of free channels on the 2.4GHz band on my zone. In the last days it is starting to crowd hard.
  5. SoKoOLz

    SoKoOLz Networkin' Nut Member

    WOW Thanks for that. Ive already asked the shop I bought, They said I can claim it, but will need to wait. And I already bought the new one, However these tips u gave me are awesome, I'll try that if I cannot claim my device.

    Thank u so much
  6. teddy_bear

    teddy_bear Network Guru Member

    When I read this, I thought - wow, that must be it! Indeed, in my previous testing I used 2 Windows laptops (Win 7 and XP) - both are members of another domain, and not in the same workgroup as the rest of my LAN computers. So I did another test - this time with a Vista laptop which is a member of homegroup with network discovery and file sharing turned on, connected to RT-N12 in WET mode. And... again no problems :confused: :
    • 2 large simultaneous downloads maxing out my WAN downstream, pings are in the range of 1-34 ms, average 1 ms (1000+ packets, 0 lost).
    • 6 large simultaneous downloads, WAN bandwidth maxed out, pings are in the range of 1-26 ms, average 2 ms (1000+ packets, 0 lost).
    Maybe my WAN connection is too slow (12 Mbps) to see the problem?? Other than that I don't know what else could be so different between our environments. Just to verify one more time - on your WET router you have the routing mode set to "Router", internal DNS turned off, default gateway and static DNS set to your primary router's IP, QoS disabled (and I believe we already went through the wireless settings once before)?

    I can also send you a test build which includes some tweaks if you're willing to test them - of course I don't know if they help since I apparently can't get the problem to occur here...
  7. EricCartman

    EricCartman LI Guru Member

    Hi all i was doing my exams and haven't been reading post is there any new beta or version of teddy bears version of tomato ?
  8. teddy_bear

    teddy_bear Network Guru Member

    Or wait a few days - hopefully I'll release the next build very soon.
  9. erikoss

    erikoss Addicted to LI Member

    WOW new build soon.
    Look forward to it.
    All your new builds have been great steps foward. :)
  10. kgart2222

    kgart2222 Networkin' Nut Member

    I ve changed to Tomato USB firmware on my Asus Rt-N16 router due to unstability.....In the original asus firware it was pretty easy to set up an ftp site but in Tomato I m kinda lost...Is there anybody that could assist me in this matter...I ve enabled FTP server...But what should I type in Allowed Remote Address etc....I want to access my home USB hdd from my woking computer... Please help :)
  11. elitenoobboy

    elitenoobboy Networkin' Nut Member

    Next build is out:

    Access Restrictions criteria: allow to specify Src/Dst Address, expand list
    of available protocols.

    Allow to specify hostnames in addition to IP addresses for iptables rules
    (port forwarding, access restrictions, QoS).

    Allow to specify hostname in addition to IP address for remote logging.

    Replaced old Tomato's bcount match by standard connbytes match.

    Added "Interference Mitigation" setting to Advanced->Wireless.

    L2TP client daemon replaced with xl2tpd 1.2.7 (should provide better

    Execute *.autorun scripts loaded from nvram.

    Web Usage: added GUI option to clear web usage logs.

    Added additional timing options for syslog marker output.

    Display nvram usage on Administration->Configuration page.

    PPTP/L2TP WAN connections: fixed routing and firewall rules for internal
    ISP network (MAN), allow to specify static routes for MAN interface, added
    support for MPPE/MPPC encryption/compression, added custom options to GUI.

    Added support for ZTE ZXV10 H618B, Linksys WRT310N v1 and v2 routers.

    Fixed support for D-Link DIR-320, Asus WL-500G Deluxe.

    Fixed bugs in signal processing and restarting service applications.

    Fixed support for DHCP classless static routes broken in build 50.

    Fixed wireless channel selection in GUI when switching between B/G/N modes.

    Disabled loading USB 1.1 module (ohci or uhci) for non-existing controllers
    on Asus routers.

    Include additional iptables matches: quota, hl (K26 only).

    Software updates: Linux kernel, MiniUPnPd 1.4 20100921, pppd (fixes
    from upstream), ntfs-3g (in Extras builds) 2010.10.2.

    Code clean-up, minor bug fixes, cosmetics.

    * Kernel 2.4-based builds only:

    Toolchain: switch kernel 2.4 builds to use gcc 4.2.4 for userspace apps,
    binutils 2.20.1, updated binary 32-bit toolchain.

    * Kernel 2.6-based builds only (beta22):

    Fixed bugs in conntrack modules forward-ported from kernel 2.4.

    GUI cosmetics: display a message on "Media Server" page when directory scan
    is in progress.

    Restored JFFS in K26 Std builds (was disabled in build 50).

    Write checksum to the end of mtd block during firmware flash on Netgear
    routers: this should fix flashing back to the OEM firmware.

    Various kernel bug fixes and performance-related patches backported from
    upstream 2.6 kernel.

    Expanded set of available extra kernel modules - included modules for HID,
    sound and webcam (UVC) support.

    Software updates: MiniDLNA (cvs 2010-09-28), radvd 1.6, Samba
    3.0.37 (latest in 3.0 series) with security fixes from
    (CVE 2010-2063, CVE 2010-3069).
  12. teddy_bear

    teddy_bear Network Guru Member

    I just uploaded it literally minutes ago :biggrin:! Have not yet posted an announcement on TomatoUSB yet ;)...
  13. oldkuang

    oldkuang Addicted to LI Member


    Thank you so much, TB. A small token has just been sent to you, though it is far less than my appreciations.
  14. though

    though Network Guru Member

    Will put on now.... thank you very much teddy!
  15. spookyneo

    spookyneo Networkin' Nut Member

    Didn't you say few weeks ago that you were gonna take it slow teddy ? ;) I'm not complaining, just an observation !

    I'll install this tonight !
  16. though

    though Network Guru Member

    he said that just to throw off the dd-wrt fools!
  17. LanceMoreland

    LanceMoreland Network Guru Member

  18. teddy_bear

    teddy_bear Network Guru Member

    That should be fixed in build 51.

    In previous builds, disable OHCI, and only enable UHCI on WL500W, WL500GPv1 (these models don't have OHCI controller anyway).
  19. HanzF

    HanzF Addicted to LI Member

    RT-N16..........possibly one of the all-time best supported products..........Teddy Bear for president!
  20. teddy_bear

    teddy_bear Network Guru Member

    Guzel, when you get a chance, I'd like to hear your feedback on the last beta22 as well - do you notice any improvement or regression in WAN-LAN throughput?
  21. Guzel

    Guzel Network Guru Member

    Hi Teddy
    I whill testet this week :),
    Thanks for the new beta22
  22. Spyros

    Spyros LI Guru Member

    Any chance of getting 60k NVRAM builds for E2000/E3000?
  23. spookyneo

    spookyneo Networkin' Nut Member

    Don't know if I found a bug, but I can't log back in into my router after the flash. The username "admin" won't work with either my previous password or the default password.

    I flashed and then cleared NVRAM. Restored a previous config file from build50. Everything seems to be working, except I can't log back in into the admin page. Putty works fine however.

    Is there a way I can change/reset the admin password in putty to allow me to log back into the admin page ? I tried to reflash again, without success :(

    I'm using port 8080 for the admin page, if this could matter.

    Thanks !
  24. LanceMoreland

    LanceMoreland Network Guru Member

    User Name: root
    Password: admin

    Edit: Do a 30/30/30 reset and use the above user name and password and start from scratch rather than reloading a config file.
  25. teddy_bear

    teddy_bear Network Guru Member

    That's exactly the same as not clearing the nvram at all... What the point in erasing it, if you just reload it all back??

    Anyway, both usernames - "root" and "admin" - should work. However, garbage in nvram can cause "admin" name not to work anymore (if there's anything else in http_username nvram settings), as well as it can disable both logins (if http_password contains some garbage).
  26. Prophet

    Prophet Networkin' Nut Member

    Hm, updates been going on for 10 mins now. &#¤"#¤.
  27. Prophet

    Prophet Networkin' Nut Member

    Well first time it went for ~15 mins until it had some sort of timeout and it didn´t update. Since I love living dangerous I ofc had to try once more and this time it went for 20 mins until i interrupted it and this time the upgrade worked.
  28. MelechRic

    MelechRic LI Guru Member

    VPN Not Starting After Reboot

    First off, thanks. Really nice work on this firmware, teddy_bear.

    I have a couple of questions/issues I'm wondering about:

    1. I just loaded the "1.28.9050 MIPSR2-beta20 K26 USB vpn3.6" build on my RT-N16 and then manually re-entered all the previous setting (where applicable) from my old WRT54GL setup that was running tomato. Everything is working with one exception: When I reboot the router the VPN doesn't start when WAN starts. I manually have to log into the router (either with the web interface or via ssh and start the VPN). I'm curious if anyone else has seen this issue on the RT-N16. If not I'll try doing a complete reset of the nvram to see if that fixes it.

    2. I noticed that build51 just became available. I'd like to upgrade to this build and just want to be sure that I can upload the firmware through the web interface instead of having to use the ASUS firmware utility.

    Thanks again for this wonderful firmware and for all your effort and dedication.
  29. Catalin

    Catalin Addicted to LI Member

    2. You can safely use the web interface to update the firmware to the latest build.
  30. MelechRic

    MelechRic LI Guru Member

    Excellent! Thank you.


    I just fixed the start VPN on WAN up issue. Under Advanced >> Miscellaneous there is a "Boot Wait Time" pull down. My setting was 5 seconds. I changed this to 20 seconds and now my VPN is being started. I'm thinking that maybe there is a race condition and the kernel isn't finished bringing up all the interfaces before the VPN start script is run. Waiting a little bit allows the interfaces to come up which lets the VPN start script succeed.
  31. teddy_bear

    teddy_bear Network Guru Member

    Uhm... I can make a build for you - but will you be willing to risk your router to test it :)? There's no guarantee that it won't brick it...

    That is very strange... "Boot Wait Time" only affects the time bootloader waits before loading the kernel. I doubt changing that setting actually helped. Maybe you did something else too?..
    To verify, try to reduce it back to 5 secs, save and reboot, and see if it disables your VPN on WAN-Up again...
  32. MelechRic

    MelechRic LI Guru Member

    You're right. I moved it back to 5 seconds and my VPN is still coming up. I must have done something else and just thought this was it. If it happens again I'll be sure and leave the machine in that state for debugging purposes.
  33. EricCartman

    EricCartman LI Guru Member

    teddy bear where can I download Build 51 - 10/06/2010
    for Asus RT-n16
  34. 56kb

    56kb LI Guru Member

  35. EricCartman

    EricCartman LI Guru Member

    I went to that link and guess i can only download beta 22 not 51
  36. Catalin

    Catalin Addicted to LI Member

    Build 51 is Beta 22.
  37. deboyz1014

    deboyz1014 Addicted to LI Member

  38. HanzF

    HanzF Addicted to LI Member

    I am back to beta 18. I have had trouble with Beta 20 and 22.

    Last night with 22 loaded, my laptop with an Intel 5100 N card abruptly dropped offline with the RT-N16 not showing up at all to re-connect. Then it would appear for a moment and then dis-appear. Multiple reboots of the laptop did not solve the problem. At the same time I was streaming radio to a Squeezebox and the connection was solid through the entire laptop episode. I've never experienced that before.

    with all Tomato versions use:

    Mixed G and N
    40 MHz

    Also with 20 and 22, I have one heck of a time pulling a WAN IP if I manually change the WAN port MAC address. I keep going back to Beta 18 and have no noticeable problems with it. The laptop has a solid connection and the WAN port problem is much easier to deal with.

    Overall, very happy with Tomato, just don't understand this stuff well enough to know what is going on with the newer builds.
  39. Toastman

    Toastman Super Moderator Staff Member Member

    I've seen episodes like this here with several laptops using Intel 5100N. The owners are mostly university students and they tell me this happens a lot at their unis, coffee shops, libraries, etc. and with many different brands of router. Unfortunately with N there are so many variables that identifying what might be wrong is probably not going to be easy.
  40. HanzF

    HanzF Addicted to LI Member

    Aye....thanks for that info Toastman. The 5100 has been rock been solid with the RT-N16 on beta 18, just the newer builds (20 and 22) giving me a problem especially with the WAN IP.

    I have the RT-N16 and cable modem plugged into a wall socket that is controlled by a light switch, so both of them boot up at the same time. Could I have a timing issue causing the problem, in other words, should there be a delay between one or the other when starting?

    If 18 was the last fw ever produced for the RT-N16, I could live with that just fine. All works well, wireless performance, USB printing, etc.. Still miles above most of the craptacular routers out there.
  41. Toastman

    Toastman Super Moderator Staff Member Member

    Something seems to have changed, but I always find it curious that other makes of wireless seem somehow to still work - but the real PITA here is always Intel's crap wireless connectivity. I wouldn't worry about the two devices on a switch, both devices coming on at the same time is normal. But, your router would appear to be working normally if your Squeezebox streaming is uninterrupted.
  42. teddy_bear

    teddy_bear Network Guru Member

    I wonder if you tried any of the older builds - specifically beta 11 or older - and if that worked as good for you as beta 18.
  43. andy

    andy Addicted to LI Member

    K26 R1 EXT, build 51


    Anything changed in the iptables ?
    WANIP=$(nvram get wan_ipaddr)
    SSH_PORT=$(nvram get sshd_port)
    sleep 5
    modprobe xt_recent
    # Open VPN port with brust-force attack prevention
    iptables -t nat -A PREROUTING -p udp -d $WANIP --dport $VPN_PORT -j DNAT --to
    iptables -A INPUT -d -p udp --dport 1194 -m state --state NEW -m recent --set --name VPN_LIMIT --rsource
    iptables -A INPUT -d -p udp --dport 1194 -m state --state NEW -m recent --update --seconds 60 --hitcount 4 --name VPN_LIMIT --rsource -j DROP
    iptables -A INPUT -d -p udp --dport 1194 -j ACCEPT
    # Open SSH port with brust-force attack prevention
    # Do not enable Remote Access in Menu, this script will do it
    iptables -t nat -A PREROUTING -p tcp -d $WANIP --dport 54321 -j DNAT --to$SSH_PORT
    iptables -A INPUT -d -p tcp --dport $SSH_PORT -m state --state NEW -m recent --set --name SSH_LIMIT --rsource
    iptables -A INPUT -d -p tcp --dport $SSH_PORT -m state --state NEW -m recent --update --seconds 90 --hitcount 4 --name SSH_LIMIT --rsource -j DROP
    iptables -A INPUT -d -p tcp --dport $SSH_PORT -j ACCEPT
    The above code was working in the previous build (up to build 50), but it seems not working in build 51.

    I just found that the "Wan Up" script is not executed, if I put the script in a file and run it manually, it works.

    Why the "Wan Up" script is not executed ? anything wrong ?
  44. Guzel

    Guzel Network Guru Member

    hi teddy
    Hir is the WAN-LAN speed whit beta22 83/116 Mbit/s, in beta20 98/132 Mbit/s
  45. teddy_bear

    teddy_bear Network Guru Member

    Yep, there's a potential problem with WAN-Up script in build 51 - check out the other "Tomato USB Mod" thread.

    But your commands should go to Firewall script actually - that's an exact place intended for creating custom iptables rules, and it's called every time firewall is reconfigured (which may happen more often than WAN initialization).
  46. elitenoobboy

    elitenoobboy Networkin' Nut Member

    I usually check the sourceforge page about once every 2-3 weeks, so I guess I just got lucky with the timing this time... I figured it had just been released, as the old builds were still up on the page, but not that close.
  47. HanzF

    HanzF Addicted to LI Member

    My old brain doesn't even remember what happened yesterday :tongue:

    I just recently upgraded my laptop to that intel 5100 (cheap) for N capability. Beta 18 has been the best of the last three for my setup. I could try the old betas, but 18 seems to work well enough. I am not power using the router, my needs are gig ethernet, good wireless performance, and USB printing and 18 does all of that well for me. Next trick for me is to learn QoS when I have some time to do that. I am just a firmware freak and like to keep updated. Your efforts are much appreciated!
  48. Slimey

    Slimey Network Guru Member

    still any chance this can be ported to work on WRT350Nv1?
  49. bagu

    bagu Network Guru Member

    I also notice that b22 is really slower than b20 and b21 (the test build).
    To see HD videos without lags, i revert back to b21 for the moment.
  50. andy

    andy Addicted to LI Member

    When using the previous builds, "modprobe xt_recent" was the first command in "Init", and the others were in "Firewall" script. I moved this to "Wan Up" script when using build 51 because :
    1. "modprobe xt_recent" not loaded successfully (too early to load ?)
    2. I am worrying "WANIP=$(nvram get wan_ipaddr)" will fail to get the correct WANIP before Wan Up.

    I also start the openvpn (optware) in the WanUp script. If the WanUp has problem, where should I start it ?
  51. teddy_bear

    teddy_bear Network Guru Member

    You should do both - load the needed iptables modules, and create rules - in the Firewall script. The reason xt_recent was not loaded successfully in the Init script is because it's getting later unloaded by the firewall initialization code after all standard rules are initialized (if it's not used by any of them) and before your Firewall script is called. WAN IP is also already known in the firewall script.

    WAN Up script will be fixed in the next build. For the time being, you can use a workaround from this post (note that instead of /jffs/etc/config directory you can also use /opt/etc/config).
  52. andy

    andy Addicted to LI Member

    Thanks, I put them all in the Firewall script and it is working now.
  53. Trym

    Trym Networkin' Nut Member

    OpenVPN errors in log and other questions.

    I recently started experimenting with VPN on Tomato. (currently loaded: tomato-K26USB-1.28.9051MIPSR2-beta22-vpn3.6. I need both JFFS and VPN, the no-usb-VPN does not have JFFS, and the no-usb-std does not have VPN.)

    I'm up and running, of sorts, I'm connected via VPN, and I get approx. 800kbit/s down speed, 60% of what my line is capable of. (When using win7's VPN-client I get full speed, the infrastructure is fast enough.) I guess this is normal for a WRT320N, but if I can do anything to get better speed I will.

    First, there's a bunch of these in the log:

    Tomato daemon.err openvpn[780]: write UDPv4 []: No buffer space available (code=132)

    ...about 25 a second for 2 or 3 seconds, and they seem to appear alongside speed-dips, or perhaps just randomly.

    The overview page shows I have 8MB+ RAM free, with "Count cache memory and buffers as free memory" UNchecked in debug, so the 8MB should be readily available.

    Then, more seriously, I will lose connection completely, and unlike pressing "Stop VPN" in Tomato GUI, this will not reconfigure the iptables to allow "normal" internet-access. Internet will be dead until I restart the router. The log shows:

    Tomato daemon.notice openvpn[780]: TLS: soft reset sec=0 bytes=1750086075/0 pkts=2057287/0
    Tomato daemon.err openvpn[780]: ERROR: could not read Auth username from stdin
    Tomato daemon.notice openvpn[780]: Exiting

    I use the "auth-user-pass" option in custom-configuration, with a filename argument /tmp/something which get's written in the init-script. It works when starting VPN, but obviously not after this soft-reset, whatever that is.

    A third thing I'm unsure about is whether UPnP and NAT-PNP should be disabled when using bittorrent over VPN. Will not the bittorrent-client instruct peers to contact the router directly, bypassing the vpn? Or will tomato reject anything coming in which is not from the VPN, regardless of open ports?

    Does anybody have any insights?

  54. imago54

    imago54 Networkin' Nut Member


    What happened to the iptables in the latest build?

    iptables -t mangle -I PREROUTING -i `nvram get wan_iface` -j TTL --ttl-set 128
    iptables -t mangle -I POSTROUTING -o `nvram get wan_iface` -j TTL --ttl-set 128
    The above Firewall script was working in the previous version (up to build 50), but it seems not working in build 51.

    Moreover if I try to run it from the command line

    root# iptables -t mangle -I PREROUTING -i `nvram get wan_iface` -j TTL --ttl-set 128
    i get

    iptables: No chain/target/match by that name
    Please help!

  55. teddy_bear

    teddy_bear Network Guru Member

    Use "insmod xt_HL" (instead of "ipt_TTL").
  56. imago54

    imago54 Networkin' Nut Member

    Thank you very much - works like a charm!
    BTW: Could you consider adding an option to the GUI to allow the user set the TTL value for all incoming/outgoing packets to 128 (value by default used by Windows) or 64 (value by default used by Linux)? Only these values are valid for example with my ISP.
    Incrementation of the TTL doesn't solve all the issues. For example in my case all SYN ACK packets have the TTL set to 1, but at the same time all DNS responses has TTLs set to 255.
  57. nordberg

    nordberg Guest

    Love this... so much better than DDWRT, my printer and router just WORK with this. Now if I could only have a PPTP server on this it would be awesome! (only thing I did like about the one DDWRT I used earlier).

    Any chance of a PPTP server interface? OpenVPN is just too much overkill for me!
  58. lavenderyew

    lavenderyew Networkin' Nut Member

    Need help with Victek RAF

    I have tried upgrade it to my WRT160nV3

    but the error message appears File is too big to fit in MTD

    any advise? I am running Tomato Firmware v1.28.9051 MIPSR2-beta22 K26 Std
  59. gingernut

    gingernut LI Guru Member

    Build 52 (beta 23 for kernel 2.6-based builds) is available for download

    Build 52 - 10/15/2010

    Changes common for kernel 2.4 and kernel 2.6 based builds:

    •Fixed WAN Up script not being executed (was broken in build 51).
    •Fixed obtaining DHCP lease from Corbina Beeline and possibly other ISPs (was broken in build 51).
    •Fixed DHCP renewal processing to not replace the default gateway and DNS servers for PPTP/L2TP connections.
    •Fixed errors in routing for PPTP/L2TP connections.
    •Added "Use Default Gateway on Remote Network" option for PPTP/L2TP connection types (turned on by default). Turn it off to use gateway obtained via DHCP for internet routing, and only use PPTP/L2TP gateway for VPN subnet (custom routing may be required in case if VPN network contains multiple subnets).
    •Resolve sporadic PPPoE disconnect issues with some ISPs.
    •Allow to configure custom TTL values in the Web GUI.
    •Make sure PPTP/L2TP is gracefully disconnected after firmware upgrades and after restoring configuration to prevent connection problems after reboot.
    •Size optimization of some large applications.
    •Software updates: PPTP kernel driver 0.8.5, Busybox 1.17.3.

    Kernel 2.6-based builds only (beta23):

    •Fixed Mini build for Netgear routers with 4MB flash (WNR2000v2, WNR3500v2), removed RIPv1/v2 routing from Mini build due to Netgear size restrictions, added JFFS to Mini build to make use of some otherwise wasted flash space.
    •Fixed flashing all supported Netgear routers back to OEM firmware.
    •Media server: removed some rare and obsolete demuxers to reduce size, reduced MiniDLNA memory usage.
    •Minor backports from upstream 2.6 kernel.

    Have fun :smile:
  60. Guzel

    Guzel Network Guru Member

    Hi teddy
    Nice work whit PPTP VPN
    WAN-Lan 80/101Mbit/s beta23
    Now ther is a problem whit openVPN client, it dosint get DNS adress from the server :)
  61. teddy_bear

    teddy_bear Network Guru Member

    I didn't touch OpenVPN in this build, and probably nothing that could affect it. In what build did it work for you last time?
  62. Guzel

    Guzel Network Guru Member

    Sorry Teddy
    It works, :) l have had the wrong setings for the openvpn sorry
  63. trevorw

    trevorw LI Guru Member

    It seems the speed keeps getting lower with every new build. I'm not sure whether it's a test problem (micro-benchmark) or something more to it.
    Guzel, would you mind sharing your bandwidth test with the rest of us?
    Also, I assume you are talking about the wifi speed (and not the wired one)?

    TeddyBear, do you have any idea why might cause this speed delay? I haven't noticed any driver updates as of late in the changelog.

  64. teddy_bear

    teddy_bear Network Guru Member

    Don't get confused by the different test results. I believe these measurement are for (as the post says) PPTP WAN connection, and have nothing to do with wireless. PPTP will be obviously a lot slower than plain DHCP or static IP. Besides, any test with actual WAN connection involves too many variables to be very accurate...

    If you want an independent (not mine :wink:) lab test results, you can do it yourself (one option is Optware iperf) and compare different builds, or ask this guy who seems to have the environment set up and ready for testing, and already tested betas 16-20...
  65. trevorw

    trevorw LI Guru Member

    Thanks for the clarification teddy! I'm using PPoE and thinking of changing the ISP and getting a pure DHCP connection which should improve things in general. I wasn't too concerned about the speed but after reading on the various tests I started to think I had missed something.

    I'll post back if I find something relevant.

  66. trevorw

    trevorw LI Guru Member

  67. teddy_bear

    teddy_bear Network Guru Member

    The mentioned iptables rule was always in Tomato.

    As for the /proc/sys/net/ipv4 parameters, it's questionable whether or not the values recommended in that post will benefit everyone. As always, you gain something and you loose something. It's better to have marginally slower connection speed than face some weird and irregular problems (here's one example). In Tomato these parameters are left at their defaults (although there's a whole bunch of others that are changed). You can google them, and experiment with the values if you'd like - all you need to do is to add those commands to your "Init" or "Firewall" script.
  68. Guzel

    Guzel Network Guru Member

    Dhcp speed Wan-Lan 80/101 Mbit/s
    And pptp VPN speed is 18/25 Mbit/s
  69. AeN0

    AeN0 Network Guru Member

    Since the latest betas, I'm trying to setup the native IPv6 connection I got from my ISP.

    I read a lot and came to the conclusion that an only-IPv6 bridge between WAN<=>LAN is the way to make IPv6 and IPv4 NAT working simultaneously.

    By joining WAN and LAN on bridge (brctrl addif br0 vlan2) and applying an ebtables rule to allow only IPv6 traversal (ebtables -t broute -A BROUTING -i vlan2 -p ! 0x86DD -j DROP), I was able to get IPv6 working on my computers. :)

    Now I got a very weird problem that I don't understand (and how it's related): each DCHP request/renew in my LAN network disables Internet IPv4 connectivity for 1 or 2 minutes on all computers! :eek: IPv6 still works.

    I have the done the following test :

    - Apply ebtables rule to allow only IPv6 transversal on the bridge
    - Bridge WAN and LAN
    - Computers get IPv6 connectivity and IPv4 NAT is still working

    1. Powering on a computer : all devices on the LAN network lost ipv4 Internet (no ping)
    2. Renew a DHCP lease : same
    3. Connect a wifi device : same
    4. Plug-in an ethernet cable of a computer : same

    I really need help on this one.

    Thank you !
  70. teddy_bear

    teddy_bear Network Guru Member

    Heh... Must've been too late at night :biggrin: - for a moment I thought you're talking about PPTP speed here (although the numbers do seem to be out of order for VPN connection ;) )...
    As for the WAN-LAN speed changes in the last betas:
    20 -> 22: lots of kernel changes that potentially can affect the speed in either way, but not much.
    22 -> 23: no kernel changes that could possibly affect connection speed, any difference is probably a fluctuation or measurement inaccuracy.
    Interesting. I can't help you with this now - haven't played with IPv6 enough yet. Maybe Rodney can shed a light on what might be going on?..
  71. dareino

    dareino Network Guru Member

    there goes 63 days of uptime out the window :)
    Thxs Teddy!
  72. HanzF

    HanzF Addicted to LI Member

    I'm on the new far so good, thanks Teddy Bear!
  73. nordberg

    nordberg Guest

    me too... 22 hours and counting. Thanks!! :biggrin:
  74. vinuneuro

    vinuneuro Networkin' Nut Member

    In the last couple weeks my RT-N12 has started dropping wireless connections several times a day with increasing frequency. It's usually out for a min or so. I'm usually on channel 6, but the same thing happens with others. Is it possible 42mw (tomato default) is damaging to this model, or could this just be unrelated to that and just a general h/w failure?

    Either way, I probably need to get the router rma'd? Do I need to (is there a way) to load the factory f/w before sending it in?
  75. Catalin

    Catalin Addicted to LI Member

    Tomato default transmit power is 17mW AFAIK.
  76. vinuneuro

    vinuneuro Networkin' Nut Member

    It's definitely 42mw.

    Attached Files:

  77. Catalin

    Catalin Addicted to LI Member

    What firmware are you using now?

    The latest Teddy Bear build looks different...

    Any way, you can flash the original firmware straight from the tomato GUI, without any problems.

    Attached Files:

  78. vinuneuro

    vinuneuro Networkin' Nut Member

    Using beta11 at the moment. Haven't used the latest yet, but everything between beta11 and the one previous to the current gave me problems with voip and QoS.
  79. ladysman

    ladysman Network Guru Member

    Is this because it's a 2.4 Kernel? The 2.6 for sure defaults to 17mw at least on the RTN16
  80. vinuneuro

    vinuneuro Networkin' Nut Member

    beta11 was 2.6, pretty sure they all have been for the N12 and N16. teddy_bear must have changed the default at some point.
  81. ladysman

    ladysman Network Guru Member

    You are right and i just realized you used beta 11. Beta 11 it was 42. Later on he changed it to 17. :)
  82. Isildur

    Isildur Addicted to LI Member

    Set it to 0 and you'll get hardware default value (like in original firmware).
  83. Toastman

    Toastman Super Moderator Staff Member Member

  84. imago54

    imago54 Networkin' Nut Member

    Thank you very much for adding the new option to the Web GUI allowing to configure custom TTL values. Finally I could get rid of the custom firewall script. I hope it will help other users to overcome some stupid ISP TTL tricks. Works like a charm!

  85. HanzF

    HanzF Addicted to LI Member

    Great, useful stuff Toastman! thanks.....

    Beta 23 has been a rock for my network, best fw I've used so far on RT-N16. Everything is working the way I want it to, all issues I had with prior betas are gone......thanks again TB.
  86. siaokia_leong

    siaokia_leong Addicted to LI Member

    thx TB for making tomato firmware work on asus rt n10 (black color looking)..
    after some reading from here and ddwrt forum..i decided to buy myself a asus rt n10 (Broadcom BCM5356@300 based) for less than usd30 and l believe this is the cheapest router available on the market that is able to run tomato firmware:razz::razz:..

    p/s : note that there is another version known as asus rt n10+ (a white color looking router) which is a atheros based router and i believe it will not support by tomatousb, please take note people!

    oh ya..i flashed the Kernel 2.6 MIPSR2 (build 52) on my asus rt n10 but not MIPSR1..


    hope this will help ^^

    extra :

    asus rt-n10

    asus rt-n10+
  87. shadow2k6

    shadow2k6 LI Guru Member

    Possible NVRAM issue (for me)

    I wanted to pass on when I flashed from VPN beta22 to VPN beta23 on my RT-N16, I was unable to go out to the internet. I reverted back to beta22 and was fine again. Although I have not cleared my NVRAM in awhile (and I know I should), I suspect that this is my issue. I will upgrade again later when the family is not waiting to use the internet. I have a PPPoE connection and my router stated it was connected and received an outside IP address and an outside gateway address. Once again, I do not suspect that this is a problem with the new build but my nvram. I just wanted to let others know if they also encounter this. Thanks for all your great work Fedor!

    * Resolved: Dnsmask Custom Configuration issue. Read next 2 entries...
  88. teddy_bear

    teddy_bear Network Guru Member

    It could be an NVRAM issue (first thing to check is the nvram usage on the Administration->Configuration page), but it also could be related to some changes in dnsmasq config. Check out the notes here for details.
  89. shadow2k6

    shadow2k6 LI Guru Member

    Thanks, that was right on the money. I had the following lines in my Dnsmask Custom Configuration section which I remarked out to resolve the problem:

  90. shadow2k6

    shadow2k6 LI Guru Member

    From another thread awhile back, I had been using all these entries:

    # OpenDNS
    # UltraDNS
    # DNSResolvers
    # Google
    # BT

    I don't want to hijack this thread, but are the rest of the non-commented items still sound?
  91. shibby20

    shibby20 Network Guru Member

    @teddy my friend, can you add again "ftpget" to busybox in new build? Many users from Poland will be glad :)
  92. mstombs

    mstombs Network Guru Member

  93. shadow2k6

    shadow2k6 LI Guru Member


    Thanks, I modified accordingly (getting rid of last 2 of 4 opendns servers and getting rid of BT servers since I'm not in the UK)
  94. EricCartman

    EricCartman LI Guru Member

    Hi teddy bear I just flashed Tomato Firmware v1.28.9052 MIPSR2-beta23 K26 USB vpn3.6
    an i love it.

    Is there any way you could add SFTP ???

    Thank you again for your hard work and dedication :)

    You made networking so easy with tomato :)
  95. uncola

    uncola Networkin' Nut Member

    Hi, I just flashed tomato for the first time.. I just got an asus rt-n16 and it's a big upgrade for me.. my first gigabit router. I have a couple questions about tomato settings.. for Wifi I notice it has a B+G mode but no G+N mode. does it make a big improvement vs mixed mode? also, should I use 20Mhz wide or 40Mhz wide? is 40MHz wide the thing that enables 300Mbps wifi w/ mimo clients? if I enable it, will it mess up non MIMO wifi clients? also I do a lot of usenet nzb downloading and only minimal torrenting.. would enabling QOS improve my speeds? should I use the defaults or are there better settings I could use?
  96. onehomelist

    onehomelist Addicted to LI Member

    In build 50 or before I was using the following code to do MAC based access restriction

    iptables -A rdev01 -m mac --mac-source 00:37:69:1A:BE:E2 -j RETURN 
    In build 52 when I run the code I get this
    iptables: No chain/target/match by that name
    I have a script having about 400 entries and for each entry I get the same error.
  97. karog

    karog Networkin' Nut Member

    sftp-server is available via optware.
  98. teddy_bear

    teddy_bear Network Guru Member

    There's no "G+N only" mode (it's not supported by the wifi driver) - just use "Auto" (which allows all B/G/N clients to connect).
    You need to make sure "rdev01" chain (which may or may not be created by Tomato automatically - depending on your Access Restrictions settings) exists - are you creating it also? Did you verify it's created? Other than that your rule looks ok and should work.
  99. mattel

    mattel Networkin' Nut Member

    no intent to step on Master toes but :confused: doesn't "other" firmware offer NG-only ?
    Tomato has drifferent drivers ?
  100. Catalin

    Catalin Addicted to LI Member

    Why do you really need only G/N? What Wireless B devices do you use?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice