Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. teddy_bear

    teddy_bear Network Guru Member

    If you mean dd-wrt, then yes - they do have different driver. They have the sources from Broadcom now, and they can do whatever they want with them.

    Not that I see any good point in introducing "NG-only" mode though - are there many B-devices left?.. And if you have one, would not you want it to be able to connect occasionally (when needed) without resetting the router?

    P.S. I believe the pointless "NG-only" mode added by DD-WRT is the reason for countless questions about where is "NG" in Tomato;( ... Argh...
  2. LanceMoreland

    LanceMoreland Network Guru Member

    When NG only mode is selected in dd-wrt, B devices will still connect, so it is no different than Tomato's Auto mode.
  3. onehomelist

    onehomelist Addicted to LI Member

    Yes, you are right Teddy. I had ticked off access restriction believing that If I am using a script there is no need to have it on in GUI. But "rdev01" chain only works if access restriction is enabled. It's my own mistake. Thanks :) I have more than 400 entries in the script and it works absolutely fine. Thanks once again.
  4. mattel

    mattel Networkin' Nut Member

    just being curious .... are you saying you cannot get, use these sources ?
  5. Toastman

    Toastman Super Moderator Staff Member Member

    That's exactly what he is saying. Broadcom's wireless drivers are released as a compiled module and no source code is available. That has always put developers at a disadvantage. It seems that DD-WRT have actually done work for Broadcom and have been allowed access to the source code for at least one driver. That would be covered by a non-disclosure agreement, of course. No access.
  6. gwww

    gwww Addicted to LI Member

  7. Toastman

    Toastman Super Moderator Staff Member Member

    No. That driver is under development. Broadcom did not release the source code for their current drivers. That "news" was a non-item. Read though it and you'll see what I mean.
  8. SolidCactus

    SolidCactus Networkin' Nut Member

    Xbox Live Connection Difficulties in beta 22/23

    Hi all,

    I was hoping for some help in troubleshooting a problem I'm having with connecting to Xbox Live since upgrading to Tomato ND USB Mod with kernel 2.6 beta 22/23 on my Linksys WRT610N v2.

    I currently have two Xbox 360's that connect via ethernet using uPnP. They could both connect and work fine until I recently upgraded to beta 22/23. When I upgraded I cleared the NVRAM before and after upgrading and entered my settings back in manually.

    The Xbox's have been assigned IPs via Static DHCP and the Xbox's get their IP via DHCP.

    I'm now seeing some strange behavior and was looking for help on troubleshooting this. I can connect to Xbox Live for a while after first powering on the router. I can see the correct ports being opened in the UPnP section.

    Then after a undetermined period of time I'm no longer able to connect to Xbox Live and I'm wondering where to look to find out why? Then if I reboot the router then I'm able to connect to Xbox Live without issue.

    Just doing some further troubleshooting on this and I'm now seeing the following in the logs when I drop off Xbox Live:

    tomatorouter daemon.warn miniupnpd[640]: HTTP Connection from closed unexpectedly

    Another update!

    Deleting all UPnP rules will allow me to connect again. Is it not clearing the old rules effectively?

    Any ideas on where to look on why it's no longer able to connect?

    Any help/ideas would be much appreciated!

  9. EricCartman

    EricCartman LI Guru Member

    Hello All.

    I have a question for teddy bear.
    Is it possible do make Virtual Wla, or at least guest wireless network?

    Thank you
  10. nyonya

    nyonya Addicted to LI Member

    What's the likelihood the Netgear WNDR3400 is supported anytime soon? Looks like it has the same internals as the WNR3500L, same CPU and same flash and RAM amounts. I'd love to be able to use a 5Ghz router to get around some of the interference in my apartment building.

    Thanks for all the hard work Teddy!
  11. lavenderyew

    lavenderyew Networkin' Nut Member

    kinda wonder when victek bandwidth limiter will be out.

    Kinda desperate for it lol
  12. Toastman

    Toastman Super Moderator Staff Member Member

    What do you mean? It's been available for some time.
  13. mstombs

    mstombs Network Guru Member

    RE:Xbox Live Connection Difficulties in beta 22/23


    Can you give more details on what ports are used/needed by dual Xbox. I'm still not sure - maybe it depends on the game/app in use?

    Some more discussion in a thread I started re miniupnpd - I don't think this is a Tomato specific issue

    I don't think the miniupnpd error message directly related, due to mispelling the usual message from miniupnpd can be seen to crop up all over the place "Connection closed inexpectedly"
  14. nyonya

    nyonya Addicted to LI Member

    Hey guys, so weird issue I'm having. Finally decided to format my external drive as ext3 to improve transfer speeds (had been using NTFS). Formatted it once through the gparted boot CD on my laptop, and once through the tools included in the extras build. Both times, same issue - if I try to transfer more than about 7MB of data, it hangs, and eventually I get a message that the folder can't be accessed. Then generally the hard drive disappears from the USB page in the browser GUI, and eventually comes back - or restarting the drive works. I've searched but haven't seen mention of this issue.

    Using a WNR3500L, running the latest Toastman build, Windows 7 64-bit on the laptop. Didn't have issues when it was formatted as NTFS, just went slowly. Any ideas?
  15. nyonya

    nyonya Addicted to LI Member

    Nevermind, installed Beta 52 and all works well. Thanks for the awesome job Teddy!
  16. SolidCactus

    SolidCactus Networkin' Nut Member

    RE:Xbox Live Connection Difficulties in beta 22/23


    I don't really pay much attention to the ports required as I have it all managed by UPnP/NAT-PMP. I think the main ones that need to be opened if doing this manually are UDP ports 88 and 3074 as well as TCP port 3074.

    I remember reading the thread you created previously but it didn't seem to really help me out as I already had the setup.

    Thanks for your ideas/help!
  17. TexasFlood

    TexasFlood Network Guru Member

    Working well for me now as well. I didn't read the notes on DNS options before upgrading so ended up with dnsmasq failing as a result and had to sort that out but all is well now.
  18. teddy_bear

    teddy_bear Network Guru Member

    Do you guys remember the attempt to use newer wireless driver in betas 14 and 15?

    If you're reading this, willing to do some tests, and actually experienced problems with UPnP in betas 14-15, please PM me - I need help from someone who could reproduce the issue...
  19. hrvy

    hrvy Addicted to LI Member

    I guess Linksys WRT610N v1 will never be supported right?
  20. trevorw

    trevorw LI Guru Member


    I know this was an old discussion but I've finally managed to put my RT-N16 (running beta 23) at work at I managed on a 100mbps connection to get wan-lan max 11.1 MB/s (in torrents) in a real environment. Prolly with the actual protocol overhead it's around 90 mbps or so which is not bad. The CPU load was around ~0.6/0.4/0.3.

    From my speed tests, there's still seems to be some bandwidth untapped that could be used but I'm not sure whether it's the router, the other side or the cable itself.
  21. Catalin

    Catalin Addicted to LI Member

    Running Build 53 (first official non-beta version). :) So far so good.
  22. though

    though Network Guru Member

    installing 53 now... thanks teddy!
  23. bagu

    bagu Network Guru Member

    A small problem with build 53 ext :
    I have set remote access in https with a custom port 9192.
    I can't log in with (i get "La connexion a été réinitialisée" )

    Where with 52 version i can.
    I've try an erase custom data then try again, but no change.
  24. bogderpirat

    bogderpirat Network Guru Member

    build 53 seems to have broken classless static routes in busybox' udhcpc once again. i'm reverting to 52 for the time being.
  25. Papka__

    Papka__ LI Guru Member

    2 problems found with last build

    1. Unable to connect with ddns name from outside (
    With IP https://my_IP:port - all is ok. Try to renew DDNS - renewed ok, but result the same.

    2. Setting wireless security to WPA/WPA2 Personal and Encryption TKIP/AES - get error "The field "wl_wpa_gtk_rekey" is invalid. Please report this problem.". Same is with AES encryption.
  26. Catalin

    Catalin Addicted to LI Member

    Everything works ok for me with the latest Build. I get a far better wireless signal over a wider area than before. :)

    Thanks TB!
  27. buggage

    buggage Network Guru Member

    WPA2/AES doesn't seem to be connecting here either in 53. Rolled back to 52 and working fine again.

    I should add this is with the 2.4 kernel tomato-ND-1.28.8753-Std build on a WRT54GL. The other wireless clients can see the connection fine, just don't appear to be authenticating.
  28. teddy_bear

    teddy_bear Network Guru Member

    There were no changes in that part of the code (other than minor change in the busybox upstream that should not affect it this way)...
    Please post the output of "nvram find wan_routes" command from both builds - 52 and 53 - after connecting to the ISP.
    Seem to be the same problem as bagu reported above. Will check this out...
    EDIT: Tested. All works fine for me with Firefox in the non-VPN build. Need more details - the browser, router model and the exact build you're using.
    Figured this one our - will fix in the next update.
    Need more details. I have it set to WPA2-PSK/AES, and 8 different clients connecting with no problems, including one Asus WL-520GU running a K24 build in a client bridge mode - so your issue must be either with a specific client, or possibly corrupted nvram.
  29. buggage

    buggage Network Guru Member

    Not sure what else I can provide WPA2-PSK/AES was set with the normal key, yet the other wireless devices in the house were not connecting...actually I don't believe they were even showing in the device list. Tried restarting and clearing NVRAM and reapplying the settings and no help.

    Went back to 52 and entered all the same info and everything was working again.

    I will test again though to see if I have the same results or not.
  30. though

    though Network Guru Member

    WPA2 AES works perfectly here...
  31. teddy_bear

    teddy_bear Network Guru Member

    Did you say that this is on K24 build? If so, you posted it in the wrong thread ;).
    Regardless - have you tied other security settings? Did you see my post on with the known problems of build 52 (may or may not have something to do with your issue)?
  32. buggage

    buggage Network Guru Member

    Yes I did post in the wrong thread, sorry...but I tried again and everything works now. I have no idea what happened originally, as I said I cleared the NVRAM, etc, but couldn't get the other devices to connnect. Reloaded v53 and now the same settings are working fine, and no further issues. Sorry about that.
  33. ddox

    ddox LI Guru Member

    I have flashed my asus rt-n16 with tomatousb v53 and I can`t get access to web admin when I changed to https, it`s no problem with v52 but hast to be something wrong with v53. It`s the same story with tomato RAF 8652. Can somebody check this on RT-N16
  34. teddy_bear

    teddy_bear Network Guru Member

    Well, the SSL implementation for this build has been completely re-done :).
    I see multiple reports for the same problem - but can't reproduce it - https access works fine for me in the latest build from WAN and LAN.

    I need more details to do any further troubleshooting - anything that will help me to reproduce it, starting with browser, the exact build you're using, detailed settings from the Administration -> Admin Access, and possibly more...

    What you can also try in the meantime is to regenerate the certificate.
  35. bagu

    bagu Network Guru Member

    After a day + many reboot + certificate regenerate + certificate deletion in browser : it work...
    I get "Invalid certificate" but it work.

    I use EXT 53 version + RT-N16 and the problem occured with firefox 3.6.12 and iexplore 8.
    Maybe i'm wrong but i think it's "certificate regenerate + certificate deletion in browser" witch make the stuff working according to the new SSL system.
  36. teddy_bear

    teddy_bear Network Guru Member

    Out of all this, probably the certificate regeneration is what helped :). I wonder if this affects only non-VPN, or all builds (because the SSL implementation is different). Can't validate it myself as I don't have any old certs generated by previous builds anymore ;)...

    "Invalid certificate" was always the case with self-signed certs in IE - you just need to ignore it. Or obtain the properly signed cert, and install it using this guide.
  37. ddox

    ddox LI Guru Member

    Thanks teddy_bear I done that regenerate the certificate and its help.
  38. HanzF

    HanzF Addicted to LI Member

    Beta 23, build 52 was flawless for me on RT-N16, everything worked perfectly.

    Just flashed to the new 53 and after a few hours, so far so good. No issues at all with WPA2/AES.

    I always do an NVRAM clear before and after flashing.

    Thanks again TB!
  39. ginson

    ginson Addicted to LI Member


    Thanks for all the hard work to make this unit work rock solid. This post is the reason why I purchase the N16. I didnt even bother looking atthe stock firmware. Jumped right into flashing it with Tomato the minute I plugged it. Been runing now for the past two days without any reboots or restarts :)

    However, I have a question about the stock antennae. I was hoping to share my network with my neighbours and to do that, I would have to use a different antenna. I would like to know if I can change the stock antennae with this one:

    Also, do I need to purchase three of these or will one be enough?

  40. HanzF

    HanzF Addicted to LI Member

    3 of these work great:


    sorry, I couldn't resist :biggrin:
  41. Papka__

    Papka__ LI Guru Member

    So router ASUS RT-N16, build - Ext, build 53. Reinstall Chrome - seems ddns connection is now working. Strange. Will test later again.
  42. trevorw

    trevorw LI Guru Member

    Hi guys,

    Is there any way to check whether the ports (in particular the WAN one) is set to full or half duplex? I find that my torrents are going strong only one way - up or down but never both ways at the same time.
    I'm using an Asus RT-N16 with beta 23(52) but I can't find any information through ifconfig.

  43. though

    though Network Guru Member


    i noticed this in the changelog:

    * Updated Broadcom wireless driver and SDK to version (experimental, 2nd attempt).

    i have a N16 access point with build 51 on it and about every day for 5-30 minutes, the AP would disappear so no wireless clients can connect to it (2 dell laptops, sony laptop, and 2 different android phones), while a N12 in bridge modes stays connected to it just fine as well as wired clients. this "problem" has baffled me for a long time and has been doing it on several different builds that i have tried, as well as different hardware..... N12, WRT54GL, WHR-G54S.

    my question... do you have any idea what is causing this problem and a possible remedy? will that wireless driver update in build 53 possibly cure this?

  44. teddy_bear

    teddy_bear Network Guru Member

    No idea, since such things simply don't happen to my equipment :) - that includes sudden disconnects, high pings in wireless bridge mode and other weird stuff some other users reported - for whatever reason I could not reproduce any of these no matter what I tried... Except that I never was able to get WDS to work reliably until I upgraded the driver. This is the main reason why I keep trying to move to this version.

    You may play with different wireless settings to see if anything helps - but it's hard to give any specific advice - there are too many factors including your exact configuration and environment (i.e. other interference sources, clients etc). It very well may be a single wireless client on your network that kills your wi-fi from time to time. Or anything else...

    The newer driver may or may not solve your problem - you need to try it yourself. If you didn't install build 53 yet, I suggest you wait for 54 which will include several critical fixes. For sure, I'd like to know if it makes any difference for you.
  45. though

    though Network Guru Member

    i'll put 54 on it when it's released... thanks
  46. ladysman

    ladysman Network Guru Member

    Its out.
  47. though

    though Network Guru Member

    that teddy is FAST
  48. adlerfra

    adlerfra LI Guru Member

    I flashed my new RT-N16 yesterday with Build 53. I was unable to obtain a WAN IP from Comcast. I replaced it with my WRT54GL and was able to obtain a WAN IP without any problem. I see in the changelog that the new Build 54 includes a fix for this issue. I wonder if that is why I couldn't get an IP with the RT?
  49. Catalin

    Catalin Addicted to LI Member

    There is only one way to know for sure: flash it with Build 54.
  50. adlerfra

    adlerfra LI Guru Member

    For sure. I was just wondering if anyone else ran into the same issue. I'll try it when I get home from work tonight.
  51. fubdap

    fubdap LI Guru Member

    from - For build 53.

    •After erasing NVRAM, your router may not be able to receive the WAN IP address via DHCP. To solve the issue, go to "Administration -> Debugging" page, click on the "NVRAM commit" link, and reboot the router.
  52. Hexxer

    Hexxer Networkin' Nut Member

    Thx for B54. Will try it.

    Flashed on sunday with B53 on a linksys WRT160N
    Yesterday i took (after work) a very slow connection (if got 32mbit). Downloads are running with 40kb/s. sneaking suspicion was my ISP - but after a reboot of the router everything looks fine. Today my wife is caling me that everything is extremly slow. Once again power off/on from the router.

    Hope that will be gone with B54. B52 was very stable without any problem for me.

  53. adlerfra

    adlerfra LI Guru Member

    fubdap. Thanks for that! I'll try the fix.
  54. milky

    milky Networkin' Nut Member

    Asus rt-n16 as a DLNA to PS3

    Hi folks total noob here, there's no denying it. Wow what a thread. I'm interested in purchasing the Asus rt-n16 router, putting tomato usb kernal 2.6 mipsr2 VPN on it, and streaming media to my PS3 via a WD 1tb ac powered hard drive utilizing one of the usb ports. So, is this something that's reasonable with this setup? Also, I read different versions for installing the firmware. I would like to follow the instructions listed here Is that the write way to go? I've read lots of stuff about the 30-30-30 hard reset, but this instruction does not mention it. Any help to get this setup up and running would be greatly appreciated.
    Regards, MIlky
  55. Hexxer

    Hexxer Networkin' Nut Member

    Ok, have to go back to B52. B54 brings me also some massive slowdowns (down to 0.5Mbit) after 10 miuntes standby of my computer.
    Tryed to renw the wifi connection, but that doesnt help. Only a reboot bring back my 32mbit.

    Im note sure that thi sis right. Is tomato-K26-1.28.9052MIPSR2-beta23-Std that build what came before B53 ? Im on a newer WRT160N
  56. Catalin

    Catalin Addicted to LI Member

    tomato-K26-1.28.9052MIPSR2-beta23-Std is Build 52.
  57. Hexxer

    Hexxer Networkin' Nut Member


    Thx. Im not sure for that. I did not wrote down due to no reason. with b52 i can confirm that there are no slowdowns after a while. My computer was 60 min in standby and everything is OK. B53/b54 did not do that.
  58. shibby20

    shibby20 Network Guru Member

    Teddy i have now Asus RT-N10 for testing.

    Tomato beta18, 20 and 22 works fine but the newest tomato brick router. Rollback to beta22 and again router work correct.
  59. teddy_bear

    teddy_bear Network Guru Member

    Yes, see the "Build Types": "only build 52 and earlier" for RT-N10. Which one have you tested - 53 or 54?

    If you have a serial console, we can try to figure out what's going on...
  60. tmr250z

    tmr250z Network Guru Member

    Wireless Channel Scan Error in Firefox & Safari on Mac

    I receive "error:unknown" errors when using the wireless channel scan in Basic->Network in both Firefox and Safari on Mac, doesn't happen on Google Chrome.



    Asus RT-N16
    1.28.9054 MIPSR2-beta K26 USB Ext
    Wireless Mode: Access Point
    Wireless Network Mode: Auto
    Channel: 11
    Channel Width: 40 MHz
    Control Sideband: Upper
    Security: WPA2 Personal (PSK) + AES

    Firefox 3.6.12
    Safari 5.0.3
  61. though

    though Network Guru Member

    channel scan works perfectly for me (build 54 nousb std) using firefox...
  62. teddy_bear

    teddy_bear Network Guru Member

    Works here with both - FF and Safari, so it may have something to do with actual SSIDs it picks up... Check the list of SSIDs it shows on the Wireless Survey results (if that works of course, and refresh it a few times to let it pick up more APs), and the list of SSIDs picked up by the channel scan on Chrome. Do you see anything unusual?
  63. tmr250z

    tmr250z Network Guru Member

    Ok, the error came up in Chrome this time too. I just happened once, can't get it to show up again.

    Here's the channel scan from Chrome:


    And here's the Wireless Survey:

    I see two w/ their SSIDs hidden, a SSID I've never seen before w/ a exclamation point in it and the rest are the SSIDs I usually see.
  64. shibby20

    shibby20 Network Guru Member

    oo fu**. i didnt read this :) My CA-42 i have at home (now i am at work), well later i will send you boot log.
  65. teddy_bear

    teddy_bear Network Guru Member

    Nothing obvious on your screenshots (assuming you cleared out BSSID column before posting, and it was not really empty)... No idea what might be causing this issue for you :(.
  66. shibby20

    shibby20 Network Guru Member

    Teddy_bear this is bootlog from RT-N10 with beta22

    and this is log from Tomato build54
    ifconfig and vlan configuration
    eth1 driver is our problem
  67. bagu

    bagu Network Guru Member

    Teddy, can you explain how to activate ipv6 ?
    Because i've put :

    echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
    echo 0 > /proc/sys/net/ipv6/conf/default/disable_ipv6
    echo 1 > /proc/sys/net/ipv6/conf/default/forwarding

    on init script, but i can't get an address (My internet provider give ipv6 address and it work if i put my computer directly after my modem)

  68. tmr250z

    tmr250z Network Guru Member

    Yeah, I cleared out the BSSIDs.

    Well, I going to try erasing the NVRAM and reconfiguring everything manually again. If that doesn't help, I'll try a new FF profile. If all else fails, I'm going to go back to build 52 for now because I don't recall this happening with that build.
  69. greenythebeast

    greenythebeast LI Guru Member

    I'll admit from the get go that I know nothing about noise floor. Therefore, I'd like to ask you all a question. I have two sets of antennas for my RT-N16. One produces a noise floor of around -99 dBm while the other produces a noise floor of -74 dBm. Which one should I use? Is a higher negative number in regard to noise floor better or worse? Thanks.
  70. Toastman

    Toastman Super Moderator Staff Member Member

    The noise floor is supposedly a measure of stuff on that channel that cannot be identified as a valid transmission, such as interference from many sources, off channel data transmissions, wireless TV cameras, baby alarms, microwaves, radar, all sorts of random noise.

    The most important figure is known as the signal-to-noise ratio, which Tomato calls "Quality". This shows how much stronger the wanted signal is than the noise on the channel.

    In Tomato, you'll notice that the signal strength of the wanted signal is the RSSI figure (Radio Signal Strength Indicator). The difference between the "Noise Floor" and the RSSI gives the "Quality" figure (Signal-to-noise-ratio).

    You need to choose the antennas that give the highest signal to noise ratios.

    Incidentally, there's something quite weird about a change of antenna producing such a horrific noise reading. I don't believe it.
  71. Prophet

    Prophet Networkin' Nut Member

    Hm, I saw in the changelog that tcp vegas has been removed from the gui. How do I enable tcp vegas now? I searched this thread pretty thoroughly but didn´t find anything even though Im guessing I´m not the only one who wants to reenable it.
  72. BeHappy

    BeHappy Network Guru Member

    Something like that disable/enable
    echo 0 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid
    echo 0 > /proc/sys/net/ipv4/tcp_vegas_alpha
    echo 0 > /proc/sys/net/ipv4/tcp_vegas_beta
    echo 0 > /proc/sys/net/ipv4/tcp_vegas_gamma
  73. teddy_bear

    teddy_bear Network Guru Member

    The NVRAM keys controlling TCP Vegas are still there - you can use them to enable/disable it:
    Enable TCP Vegas: ne_vegas
    Alpha: ne_valpha
    Beta: ne_vbeta
    Gamma: ne_vgamma
    The Netgears are PITA to work with because of the proprietary checksum verification technique they are using, but unless they did something particularly tricky with this model, it should not be too difficult to get Tomato running on it after 3500L is already supported, and I'm done with simultaneous dual-band support.

    Do you have one of these and a serial console for debugging/debricking, and confident you can debrick it? If so, we can certainly try to put Tomato on it and go from there...
  74. achoi

    achoi Networkin' Nut Member

    just a dumb question. Will my Asus RT-N16 support dual band after I flash Beta54 into it? alex
  75. Catalin

    Catalin Addicted to LI Member

    Asus RT-N16 is not a dual band router. It does not have the hardware parts for that.
  76. nyonya

    nyonya Addicted to LI Member

    Unfortunately no, I wasn't going to buy one until it was supported - I don't think I can go back to a non-Tomato router :) I'll keep the WNR3500L I just got, dual-band would be nice but it's working like a beast. Thanks for all you do Teddy!
  77. shibby20

    shibby20 Network Guru Member

    Teddy when is possible to support again rt-n10 in newest build?
  78. teddy_bear

    teddy_bear Network Guru Member

    Maybe never :(. Based on your log, it indeed looks like the support for BCM5356 chipset has been dropped from the newer version of the driver. I have one more thing to try (will PM you a build to test) - but if it won't work then build 52 will be the last one with RT-N10 support (unless I roll back the driver again, LOL).
  79. Edrikk

    Edrikk Network Guru Member

    Let's not fall into the same trap as dd-wrt in terms of support of "Legacy" hardware... At a certain point, the "hit" on everyone in terms of stability and performance is not worth supporting old hardware...
  80. oldkuang

    oldkuang Addicted to LI Member

    Can someone teach me how to use /etc/syslogd.cfg to log inbound connection and use USB drive for storing the log files?
  81. shibby20

    shibby20 Network Guru Member

    its bad news. ok, please send me soft to test on PM.

    one more question: if i will merge b54 with older drivers, only i need to replace driver`s files or maybe this is more complicated :)
  82. Ezrem

    Ezrem LI Guru Member

    I upgraded from an old 1.27 build to the latest yesterday...didn't reset defaults or anything, did I need to?

    I wanted to check TCP Vegas so I tried this:
    Tomato v1.28.9054 MIPSR2-beta K26 USB vpn3.6
    root@tomato:/tmp/home/root# nvram get ne_vegas
    root@tomato:/tmp/home/root# nvram get ne_valpha
    root@tomato:/tmp/home/root# nvram get ne_vbeta
    root@tomato:/tmp/home/root# nvram get ne_vgamma
    This output would indicate that TCP Vegas is enabled with what used to be the default settings, correct?

    If I wanted to disable I'd just do:
    nvram set ne_vegas0=0
    One other thing, is there any way to disable some (or all) of the LEDs on the ASUS RT-N16?
  83. though

    though Network Guru Member

    Yes, do a thorough NVRAM erase after upgrade.

    Oh, and electrical tape works wonders :)
  84. TerminatorHTK

    TerminatorHTK LI Guru Member

    If I wanted to use TCP Vegas, would the init script be the proper place to put the set commands for it?

    nvram set ne_vegas=1
    nvram set ne_valpha=x
    nvram set ne_vbeta=y
    nvram set ne_vgamma=z
  85. Toastman

    Toastman Super Moderator Staff Member Member

    you could run it in the system box, or command line, and then nvram commit, after that - no more need.
  86. bigclaw

    bigclaw Network Guru Member

    Does anybody have wifi password problems between the Asus RT-N16 and apple devices? All of a sudden I'm having a lot of "incorrect wifi password" errors on my iPhone 4, iPod touch, and iPad. My laptops (MBP and Windows laptops) never have such a problem. Re-entering the 64-character password on these things gets old pretty quickly.

    I'm using an RT-N16 with v1.27.9044 MIPSR2-beta05u-vpn3.6. I know it's a big long in the teeth and will upgrade shortly. It's just that only apple devices are having problems...
  87. though

    though Network Guru Member

    apple = headache
  88. ehmjay1

    ehmjay1 Networkin' Nut Member

    Hopefully somebody can help. I've flashed tomato on the Asus Rt n-16, and my wireless speeds are capped at 11 mbps. I can sit right next to the router and the speeds are the same as when I am on the outer limits of my network. I have looked everywhere, and can't find a solution to this. It seems as if it won't get past wireless "b" speeds. My old G router, i would get a connection of at 54 when i was right next to the router..can't figure it out.

    ANY HELP would be welcome!!!
  89. deboyz1014

    deboyz1014 Addicted to LI Member

    1. Do a thorough nvram reset
    2. Check what is the wireless mode the router is set at
    3. Is there any activity when you were checking speed or was it during idle?
  90. rmccask

    rmccask Network Guru Member

    Which builds types have IPv6

    Which builds types have IPv6 support enough to forward IPv6 packets if I use it as an access point? I am currently running on an Asus WL520GU so I might need to buy a new router for this if it needs a larger build type than it can support.

  91. mecha50

    mecha50 Network Guru Member

  92. tmr250z

    tmr250z Network Guru Member

    From instructions here and here:

    1. Go to Administration-> Bandwidth Montoring and manually backup your bandwidth stats to your computer.
    2. Copy and paste the "Shutdown Script" to Administration-> Scripts-> Shutdown on your router and click Save.
    3. Copy and paste the "Wan Up Script" to Administration-> Scripts-> Wan Up.
    4. Edit the "Wan Up Script" replacing the values of USER, PASS, and SERVER with your real FTP username, password, and server URL and click Save.
    5. Create a dummy "rstats.tar" file on your FTP in the remote path specified in the Wan Up Script. The default path is the root directory indicated by RPATH="/rstats.tar". You can change it to a different path if desired, but make sure you move the dummy "rstats.tar" file to that path. I've changed mine to RPATH="/bandwidth/rstats.tar".
    6. Reboot the router to verify that it picked up the dummy rstats.tar file you created. There should be an "RStats Data Restored" entry in the router log.
    7. Go back to Administration -> Bandwidth Montoring and manually restore your bandwidth monitoring stats from your computer. This should be the last time you have to do that.
    8. Reboot the router again. (Use the webpage to reboot the router... Don't just kill the power). This will cause the backup to occur before the reboot and your bandwidth stats will overwrite the dummy rstats.tar file.
    9. Your bandwidth stats should restore automatically this time. Verify by checking your stats in Bandwidth-> Daily, Weekly and Monthly.

    Here's a blank rstats.tar file for you to use if you want:
  93. dareino

    dareino Network Guru Member

    I seem to have a similar problem. Just upgraded from 52 to 54. Running Asus RT-N16 with an N USB nic. I did run nvram and then rebooted and all seemed fine. Streaming a movie to my laptop and was getting a 300/150 speed. Messing around I checked the Noise Floor measurement tool and bam, Im back to 54mbs. Rebooted router and back to 300mbs. Within 30 seconds, it dropped back to 54mbs?
    Running the iwconfig wlan1 command and it shows bit rate=144.5 MB/s where previously it showed 300....then ran the iwconfig wlan1 rate 300 command but it still reports back as 144.
    Any suggestions?
  94. rmccask

    rmccask Network Guru Member

    IPv6 problem solved

    I think my problem wasn't that the router wasn't supporting IPv6. My problem was is radvd kept dying. For now I put in a cron job to restart it if it is down and that got things working. Then I broke it again trying to upgrade the IPv6 firewall and getting that fixed took me a while.

  95. shibby20

    shibby20 Network Guru Member

    teddy my friend, im still waiting for build to test :biggrin:
  96. Toastman

    Toastman Super Moderator Staff Member Member

    dareino, I was looking on the web for information on another problem, but I found several people with the same problem you have, all using Intel wireless chipsets. Is yours Intel by any chance?
  97. dareino

    dareino Network Guru Member

    I am currently running an Azio USB N adpater.......
    running the lspci command I see:

    darco@darco--karmic:~$ lspci
    00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
    00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
    00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
    00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
    00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
    00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
    00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
    00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
    00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
    00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
    00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
    00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
    00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
    00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
    00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
    00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
    05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    07:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
    07:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
    07:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
    07:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller
    07:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (re

    not sure why I dont see the adapter

  98. Toastman

    Toastman Super Moderator Staff Member Member

    That's a Ralink USB adapter. Usually those are fine.

    So what was this ?

    Intel strikes again .....
  99. dareino

    dareino Network Guru Member

    It keeps disconnecting after maybe 30 mins or less...Ill probably revert back to 52
  100. shibby20

    shibby20 Network Guru Member

    @Teddy - one more thing... I translated tomato to polish language. It was lot of work and time ;)

    Maybe its time to thing about locale in tomato? :) What do you thing? ;)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice