Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. Catalin

    Catalin Addicted to LI Member

    On the serial header there is only 3.3 V.
  2. xtacydima

    xtacydima LI Guru Member


    Most strange, I will double check tonight but I used a multimeter and it fluctuated of course but went over 3.3v, my 5v fan runs on it just fine.

    Let me double check it when I am home later though, will confirm for sure tonight.
  3. Catalin

    Catalin Addicted to LI Member

    You can even triple check, there's only 3.3 V there, according to my multimeter...
  4. Catalin

    Catalin Addicted to LI Member

    daemon.err smbd[766]: read_socket_data: recv failure for 4. Error = No route to host
    daemon.err smbd[1139]: read_socket_data: recv failure for 4. Error = Connection timed out
  5. teddy_bear

    teddy_bear Network Guru Member

    Don't worry about occasional Samba errors in log, unless you experience problems - usually they are harmless.
    But if you do have problems connecting to Samba shares - please provide the details.
  6. call_151

    call_151 Addicted to LI Member

    Am making some progress as make starts to run but does not complete and have encountered another error as it complains lzma is not a directory.

    Running ls on src-rt
    ls -la /home/mld/tomato/tomato/release/src-rt/
    total 124
    drwxr-xr-x 13 mld mld  4096 2010-02-03 02:18 .
    drwxr-xr-x  6 mld mld  4096 2010-02-02 14:30 ..
    drwxr-xr-x  4 mld mld  4096 2010-02-02 14:30 bcm57xx
    drwxr-xr-x  3 mld mld  4096 2010-02-02 14:30 bcmcrypto
    lrwxrwxrwx  1 mld mld    84 2010-02-03 02:16 btools -> ../src/btools
    lrwxrwxrwx  1 mld mld   104 2010-02-03 02:16 cy_conf.h -> ../src/cy_conf.h
    lrwxrwxrwx  1 mld mld   104 2010-02-03 02:16 cy_conf.mak -> ../src/cy_conf.mak
    drwxr-xr-x  6 mld mld  4096 2010-02-02 14:30 emf
    drwxr-xr-x  4 mld mld  4096 2010-02-02 14:30 et
    drwxr-xr-x  2 mld mld  4096 2010-02-03 02:18 image
    drwxr-xr-x  6 mld mld 16384 2010-02-02 14:30 include
    drwxr-xr-x  3 mld mld  4096 2010-02-02 14:30 linux
    [COLOR="Blue"]----------  1 mld mld     0 2010-02-03 02:16 lzma[/COLOR]
    lrwxrwxrwx  1 mld mld   104 2010-02-03 02:16 lzma-loader -> ../src/lzma-loader
    lrwxrwxrwx  1 mld mld    84 2010-02-03 02:16 Makefile -> ../src/Makefile
    lrwxrwxrwx  1 mld mld    84 2010-02-03 02:16 router -> ../src/router
    drwxr-xr-x  3 mld mld  4096 2010-02-02 14:30 rts
    drwxr-xr-x  3 mld mld  4096 2010-02-02 14:30 shared
    -rw-r--r--  1 mld mld   224 2010-02-02 14:30 target.mak
    -rw-r--r--  1 mld mld   233 2010-02-03 02:22 tomato_profile.mak
    drwxr-xr-x  5 mld mld  4096 2010-02-02 14:30 wl
    drwxr-xr-x  2 mld mld  4096 2010-02-02 14:30 wlconf
    It appears that the snapshot tarball is not picking the lzma directory? What would the best way to pick this up?

    Thanks for the patience and help. Would really like to get this to compile.
  7. n3IVI0

    n3IVI0 Addicted to LI Member

    Samba2 is not compatible with Windows 7. I ran into this problem on DD-WRT. I can see the Samba share, and connect to it, but about 30 seconds after I begin transferring a file to the share, my samba connection tanks, and it throws up some message about being write-protected. I think, at least for us Windows 7 and Vista users, we're going to need Samba3 in a future build.
  8. xtacydima

    xtacydima LI Guru Member

    Hey, just got home and opened it up, checked with multimeter, and yes its a 3.3v as it turns out my fan is a 3.3v don't know why I thought it was 5... it's been a long week for me I guess, very little sleep, long work hours, and a newborn... don't ask :eek:

    So anyway, just wondering....

    1. Are there future plans to add the IP/MAC BW Limiter to this build (I know right now most concentration is set aside on working out bugs)?

    2.. What according to everyone's experience is best rate for transmission power (42mw) or other?
  9. cariyawa

    cariyawa Addicted to LI Member


    Today I gave little stress test to my RT-N16... I mean.. it is not too much but, eventually I had a really slow wireless connection(20-30kbps) in my N connection and but router never got stuck or restarted. Even though the connection is slow, wireless clients could connect.. but it took more time to get a DHCP address. After that I stopped all the testing and tried to put it in a regular load.. but it didn't come for the real speed/life for a while. Initially I thought I just burnt the sucker.. but after a hard reset + cooling is working fine(at least right now!)

    Here are the things that I did:

    1. Create a infinite loop with some math calculations using python and start 10 process using telnet
    2. start 2 3GB WAN->LAN download using wireless N and G client in two diffent computers
    3. Using N-client I uploaded 20GB file as well as simultaneously download 20GB file from LAN
    4. During these period CIFS is enbaled and connected to my Ubuntu server share. I telnet to router and start creating a tar.gz backup of the whole root partition of the router..(I know it is crazy, but I just needed to give it more work)
    5. also I browse web.. etc

    CPU load went high as 6-8.

    What happened:
    1. Of course CPU was REALLY hot..
    2. Switch chip is really hot.. I really don't think it can hold it without a heatsink
    3. Memory is getting little warm.. but I really don't think it is something that should be concerned..
    4. RF shield becomes warm... but again.... I don't think we need to add anything extra to that.. as long as we keep TX power reasonably low.

    My suggestions:
    * CPU heat sink is not enough, if we are going to use optware and do all other crazy things. For regular use, It may be sufficient...probably RT-N16 will survive with Asus stock without any problem, because with it, we don't have a way to increase CPU load by executing custom stuff...
    * I really believe switch chip need a heat sink.. It may not last with that temperature
  10. n3IVI0

    n3IVI0 Addicted to LI Member

    Tried these wireless settings:

    Wireless Mode: AP
    Wireless Network Mode: Auto
    Channel: 1 (Auto should work too, I just use 1)
    Security: WPA2 Personal
    Encryption: TKIP/AES


    Country/Region: Japan
    Bluetooth Coexistence: Enable
    Transmit Power: 39
    WMM: Enable

    So far so good. Good speeds, no random disconnects like I was getting. When transfers to Samba occur, for the 30 seconds they last, I'm getting 5.5 MB/s or so. Looking good. New build (with Samba3) in conjunction with Animal's forthcoming new and improved ORW script for Tomato, and this thing's gonna be a beast!
  11. teddy_bear

    teddy_bear Network Guru Member

  12. baarak

    baarak Guest

    I'm using Windows 7 with this build, and while it does let me read/write to the share with no authentication, for some strange reason it will not let me execute any programs from the share. The executables are not corrupt - if they are copied locally and then run, they work fine. This only occurs with Windows 7 - Vista and XP don't show this problem at all, and it only occurs with samba 2. Any ideas? The drive is formatted as ext2.
  13. n3IVI0

    n3IVI0 Addicted to LI Member

    No, they're ext3. I can see the shares, and I can access them easily enough, but 30 seconds into a transfer, it crashes. If it's not the O/S, what else could be the problem? Also, Samba3 gave me none of these problems...

    For example, with Samba3, I only had to include these lines in my smb.conf:

    ntlm auth = YES
    lanman auth = YES
    client ntlmv2 auth = YES

    And I never had any problems. Samba2 doesn't recognize those commands.
  14. n3IVI0

    n3IVI0 Addicted to LI Member

    However, when I had trouble before, it wouldn't even connect at all, so possibly it is something else. I will keep digging.
  15. KyleChen

    KyleChen Addicted to LI Member

    just compiled and installed from latest source code( 02/02/2010) on my n16, the storage flag update really helped. (i have a seagate freeagent go, some ppl should no abt it). what a amazing work teddy bear!

    I upload it to , if you have trouble compiling by yourself, you can download it. but Hi, its teddy bear's code but its unreleased compiling, kind of nightly update, you should know that.

    and i changed a little bit about the upnp, now upnp device in win7's network(upnp can't hide from win7's detection) will show "Upnp" instead of "Tomato router". Because expose the firmware name "tomato" to all users is considered as a security leak.
  16. KyleChen

    KyleChen Addicted to LI Member

    e2fsck your disk. write-protected sounds like the kernel is protecting your file system from further damage.

    I used win7 x64, the samba running all right with 2 ntfs partitions, 1 fat32 and 1 ext partition (i change it between ext2 and ext3 often), transmission downloading blue-ray movies into NTFS, which usually between 10-20GB per file. i copy super big files here and there, copy them between partitions, did so many things with the build-in samba, never had a problem.

    oh sorry, not never, the samba do have a problem, is delete folder with stuffs, it will deny. i have to empty the folder first b4 i delete it. anybody encounted the same probs?

    ----------==============fancy shining line============-------------
    I do think teddy bear will build a samba3 in the firmware, just a matter of time lol

    hope there will be a stable version come out asap, dont need any unreal functions, just basic functions(ftp samba upnp etc) without any bugs. then we can do anything we want without looking for upgrade time to time, and teddy bear can go retire lol hahahaha
  17. gingernut

    gingernut LI Guru Member

    Thanks a bunch.

    Just installed with no hiccups.
  18. soldier

    soldier LI Guru Member

    Yes, I’m experiencing the same issue. For now I use ftp but this is not the solution. With ftp running, you can delete everything, it doesn’t matter if the folder is empty or not. Hope this helps.
  19. Catalin

    Catalin Addicted to LI Member

    A little update on he cooling side... Since on the first try, the 40mm fan mounted on the cpu heatsink was a little bit noisy at night (the router is placed in a bedroom) because the fan was very close to the top cover of the case, I decided to cut a hole in it, changed the fan to a bigger one (50mm) and also reduced the rpm by using two 10 Ohm 3W resistors. In addition, I've covered all the top and side air holes, so now there is a good air flow on both top and bottom sides of the board.
  20. n3IVI0

    n3IVI0 Addicted to LI Member

    I did. Took awhile. Didn't eliminate the problem (copies for a bit, then fails with the message that the disk is write protected). Curious...
  21. n3IVI0

    n3IVI0 Addicted to LI Member

    Tried it in XP and Mac OS X, and I'm getting the same result. It sees the share, accesses it, and will allow me to copy about 400MB, then it stops and tells me the volume is locked/write protected. I've examined /etc/smb.conf, and it looks legit. Drives are mounted rw. What is the problem with my Tomato setup that is causing this behavior, when it works for others? I ran e2fsck on all drives by the way, and they are clean, so it's not that. The aggravating thing is that the builtin Samba is very fast. If it worked all the way, it would be great. I'm planning on sticking with Tomato from here on out, so I have to solve this problem in order to continue accessing my NAS.
  22. cherepochek

    cherepochek Addicted to LI Member

    Teddy_bear whether in the future, your firmware for the RT-N16, to support Russian Dual PPTP?
    Thank you!
  23. KyleChen

    KyleChen Addicted to LI Member

    sth wrong with your usb disc, or your router soft/hardware. I am sure the 400MB problem is not generated by the tomato firmware.

    suggest you to do: more disc test, surface test. reflash router, clean nvram. keep it cool. then tell me how is going.
  24. n3IVI0

    n3IVI0 Addicted to LI Member

    I'll try a fresh install of Tomato, because, you know, fresh Tomatoes are the tastiest... :biggrin:
  25. n3IVI0

    n3IVI0 Addicted to LI Member

    Fresh install does nothing. I can copy FROM the NAS, but not TO the NAS.
  26. teddy_bear

    teddy_bear Network Guru Member

    Replied to you guys here.
  27. stallmen

    stallmen Addicted to LI Member

    I just bought this router and had to return it because the wireless was hardly working. It appears the hardware in these is crap juding by the posts in this thread (cooling, crashes, etc). I'm seriously thinking about just getting a refund.
  28. cariyawa

    cariyawa Addicted to LI Member

    Hardware spec is the only good thing in this router.. Stock firmware is the crap. It has some heating issues... but lot of people are working with it as it is without any significant modifications such as fans and heat sinks(but.. of course with Tomato :)).
  29. KyleChen

    KyleChen Addicted to LI Member

    if i were you, i ll change another friend's different usb disc and try the copy.
  30. n3IVI0

    n3IVI0 Addicted to LI Member

    I tried different discs and same thing keeps happening. Here's what the log reveals:

    Feb 3 23:29:54 USER hotplug[1382]: USB partition unmounted from /opt
    Feb 3 23:29:54 USER daemon.err nmbd[1449]: ===============================================================
    Feb 3 23:29:54 USER daemon.err nmbd[1449]: INTERNAL ERROR: Signal 11 in pid 1449 (2.0.10-security-rollup)
    Feb 3 23:29:54 USER daemon.err nmbd[1449]: Please read the file BUGS.txt in the distribution
    Feb 3 23:29:54 USER daemon.err nmbd[1449]: ===============================================================
    Feb 3 23:29:54 USER daemon.err nmbd[1449]: PANIC: internal error
    Feb 3 23:29:54 USER daemon.err nmbd[1449]:

    That make any sense to anyone?
  31. KyleChen

    KyleChen Addicted to LI Member

    If new disk pass test
    then forced check your old disk/partitons
     if old disc pass the e2fsck forced check
     then surface test, or low level format it.
      if get error in surface test or low level format,
      then buy your self a new disc, job done!
      else, format the disk, test it.
       if still fail
       then try flash the latest firmware i compiled in my post
       report your disk model so i wont buy it
        if still not work, then buy a new disk(may be power issue),job done!
        else, job done!
        end if
       else, job done!
       end if
      end if
     else, fix your file system, or backup-format-restore, job done!
     end if
    else full erase nvram then test new disc again.
     if new disc still fail, flash back to asus original firmware and test.
      if asus firmware pass copy test
      then you are so f**ked. report your chip model and everything.
      wait for firmware update or change to another rt-n16, job done!
      else, send back your rt-n16 to shop for warranty replace, job done!
      end if
     else, job done. your old drive will work too.
     end if
    end if
  32. n3IVI0

    n3IVI0 Addicted to LI Member

    It's not the drives. Both drives are exhibiting the same behavior. They both passed e2fsck forced checks. I can see one drive having a physical error, but both? It's not likely. They're Western Digitals, which have always been good in my experience. I will attempt the stock firmware and see if it will let me write to the share.
  33. Toastman

    Toastman Super Moderator Staff Member Member

    I got my RT-N16 four days ago! I wanted to post some of my observations. Router RT-N16 90-IG0D002E01 - 01P0Z was manufactured in Dec 2009 serial no. 9C1EAC070768. The box bears a red sticker (meaning unknown) next to the label. It is clocked at 480Mhz.

    I am testing only the normal router functions, none of the USB mods are used.

    1) We recently upgraded to 16Mbps/1Mbps ADSL via PPPOE connection. The existing WRT54GL's could handle this OK, but started to become noticeably sluggish, with CPU Load often around 0.5 or higher. Nobody noticed the lag, but it annoyed the hell out of me. The RT has cured this. The best ping time from my ISP gateway is a little faster than the WRT54GL.

    2) I set long conntrack timeouts and then set up uTorrent with a few hundred files and let it rip. This was with about 35 other users online doing their own things. My upload speed was 700Kbps, download 15Mbps. QOS was on. Web pages were still fast, ping times varied between 14mS and 40mS. At the same time I opened as many IPTV and Shoutcast TV sessions as I could. All fine. I still could not reach 10,000 connections. The most I managed to get up to was 7000 odd connections but the router handled it fine, and it has performed without a glitch over the past 3 days with varying load levels.

    3) While under the highest load, I looked at the inside of the router. Processor and ethernet switch were hot, however, I could keep my finger on the heatsink indefinitely, though this was very uncomfortable. Based on past experience of many years in burning fingers on heatsinks, I estimate a temperature of 55-60 degrees C. Ambient temperature here is 34 degrees, so a rise over ambient of 20 to 25 degrees C is probably what we are seeing.


    I should point out that I am an engineer, I've worked with electronic components and microprocessors for 45 years. And I want to write something from that viewpoint because of all of the nonsense that I am seeing here in this forum about the RT-N16 hardware.

    I had previously asked a friend who works in an RF certification lab (one of my old employers) to do some quick tests on the RT if he had time. He did manage to do a few quick and dirty tests. Basically, he says the one they have runs quite cool, measured at 45 degrees C with IR thermal imager. Ambient temperature in the lab was 22 deg C - consistent with my "guess" - this was a rise of 23 degrees.

    Please notice his choice of words - "QUITE COOL" - meaning that for this type of application it would not be considered to be unusually hot.

    He also quickly took the processor up to 85 degrees C when it began to fail. After that he put the whole router in their environmental test chamber where it ran happily at 50 degrees ambient most of the weekend along with several customer's hardware on test. He also checked the wireless' PA compartment. He does not see any slowdowns or disconnections on LAN/B/G or N wireless transfers. He stated that there is no heat problem with the sample of router that he has. It runs quite hot but well within acceptable limits.

    On the heat "Problem"... I want to caution forum readers. This thread is fast becoming a "RT-N16 Overheating" thread!!


    As an engineer I want to ask readers to please calm down. Don't see or create problems where none exist. It only takes one post and now we have people making statements that they won't buy this router. We will soon be getting to the same point as the old WRT54GL - when many became covered with huge fans, lights, and potentiometers for no reason whatsoever.

    After reading through the various posts on this forum and others such as the ASUS forums, I don't think there has been even a single processor or switch failure. Only vague "slowdown" or "disconnection". I wouldn't see this as a sign of overheating. Processors do not generally "slow down" - they fail. (The exception being those which have internal temperature monitoring, which switch the processor to lower clock speeds when high temperatures are detected - such as Intel computer CPU's).

    I believe people are getting totally paranoid about overheating.
  34. cariyawa

    cariyawa Addicted to LI Member

    Failing of electrical components such as rectifiers, transistors, etc is not a zero or one thing. They do partially die. Rectifier which is commonly used in AC-DC converters is a simple example. Even ICs die partially. So this is common to any semiconductor including microprocessors. Specially with high thermal settings, this can be happened more often.

    After certain temperature threshold, processors performance slows down.. may be also with erratic behavior.

    Simple empirical study done for P4 processor:
  35. gingernut

    gingernut LI Guru Member

    But does the BCM4718 cpu have a thermal sensor or any kind of heat sensor inside the Asus? If not then it would be impossible for the cpu to slow down due to heat.
  36. gingernut

    gingernut LI Guru Member

    I use windows 7 and have zero problems transfering files using samba, I've tried with various types and sizes upto 4GB and they transfer fine.
  37. Catalin

    Catalin Addicted to LI Member


    Works OK with Win7 for me, using a NTFS USB PenDrive. Previously I had problems because the stick was formatted as FAT32.
  38. Toastman

    Toastman Super Moderator Staff Member Member

    caryawa, yes. It is quite true that some electronic components can change value, or otherwise fail "partially". But here we are talking about microprocessors.

    In general, microprocessors do not "slow down" due to overheating.

    The link you posted is not relevant. It deals only with the Intel P4 computer processor, which in common with other (expensive) Intel CPU's has an internal temperature measurement device which lowers the clock frequency by dropping clock cycles in the event of high temperatures being detected. It is necessary in these larger processors because they have to be protected in the event of fan failure. [Incidentally, the threshold for this to happen is of the order of 90 to 100 degrees C].

    The cheap and quite feeble consumer IC's used in routers have no such internal protection mechanism and thus the above statement does not apply.

    The experiment performed in the test lab that showed the processor failing at an external case temperature of 85 degrees clearly shows that the BCM4718 processor has no internal protection mechanism. So, I will stand by my statement that unless proved otherwise, any problems are almost certainly not due to the processor overheating.

    By the way, even the Intel processors are supposed to run at temperatures from 90 to 100 degress C !
  39. KyleChen

    KyleChen Addicted to LI Member

    as i said, if another disk fails too, erase nvram totally (base on a good firmware flash), run the router clean and test. if still fail, flash back to asus stock firmware and test. if all your usb disks fail under asus stock firmware, you can bring the router back to shop.

    and Toastman!!!!!!!! great infomation!!!!!!! you saved my day!
    if only 25C heat up, i dont need to worry abt open the router and put a extra heatsink.
    any of your friends tried overclock it?
  40. Toastman

    Toastman Super Moderator Staff Member Member

    I am going to try to clock it at the designed 533MHz now, just for the sake of interest. It appears some will do 533, some won't , it appears that this frequency is quite unstable. I posted the serial number etc. above in case anyone wants to do any tracking of manufacturing dates.

    NB - the data sheet has recently been changed, it now covers Broadcom's ass by stating the clock frequency as "300-533MHz" :biggrin: So the data sheet reproduced in this post is no longer current. Even later versions have changed the specification to 480MHz and all references to 533 have gone.

    EDIT: It did work at 532 MHz - for a short time - but reboots quite unpredictably. That's what Teddy found happened with his.

    The failure is most definitely NOT caused by overheating. It doesn't matter if the thing is cooled or hot. It still fails. Neither is it caused by the power supply, in case anyone is wondering about that too.

    So stick to 480MHz or 500MHz!
  41. n3IVI0

    n3IVI0 Addicted to LI Member

    Blast it. It's the router. I tried hooking back up to my WRT610Nv2, and it transfers to the drives with no issues. I suspect something with the USB chip is the problem, because it would get into the transfer, and then the log would indicate I/O errors, dead devices, and the mount would tank, then you can see it attempting to recover. It was the router all along. Well. I'm glad I held on to the other router. Back to Newegg it goes (that's why I always buy from those guys - very lenient return policies)...
  42. ruslan

    ruslan Guest

    So, what about this mod of Tomato on NetGear WNR3500L? It works OK? Any nuances?
  43. hutschnur83

    hutschnur83 Addicted to LI Member

    No probs so far i will make today some tests for teddy_bear , but basics qos routing wireless modes i use bridge mode no probs, no disconnections stable transferrates no reboots or freezes till yet.
  44. TexasFlood

    TexasFlood Network Guru Member

    All I've done to my RT-N16 is load DD-WRT then Tomato, nothing from a hardware perspective. The RT-N16 signal is stronger than the router it replaced. I might add some heatsiinks and/or a fan to improve cooling when I get around to it but don't consider it a pressing issue. I've not had any noticable issues with mine but haven't run a lot of tests either.
  45. Lost_Animal

    Lost_Animal Addicted to LI Member

    I have RT-N16 2 weeks now.
    If i Overclock it at 532,266 its ok for normal use but NOT for Heavy torrent download via Transmission.

    At Stock 480Mhz never crashed even i was download about 60GB of Torrent using Transmission. :biggrin:

    Yes it hot but not BURN....:biggrin:

    If you want a stable 533 MHz operation then cooling is a MUST.

    Wifi is strong with good throughput and never crashed.
    Tomato is fine with RT-N16 and internal SAMBA is Great....
    QOS working fine also and now i try to Load all Optware i can to reach the max "power" of this Very Good Product...:hug::flowers:
  46. stallmen

    stallmen Addicted to LI Member

    It's a brand new router, I shouldn't have to chop it up and add fans, heatsinks etc and lose the warranty at the same time. I think I'll just wait for Tomato to be ported to one of the newer Linksys routers. I had a bad feeling about Asus from the start and it turns out that feeling was right.
  47. Lost_Animal

    Lost_Animal Addicted to LI Member

    Well i think all depends....

    If you want a heavy duty router with many QOS - VPN - Torrent Connection - Quality and Stability (Professional Use) then your Road ENDS on CISCO side with cost raise.

    ASUS RT-N16 with dd-wrt or Tomato Firmware, is a fine Low Cost Router with High CPU power and huge RAM / ROM, and i believe since now its my BEST BUY.:biggrin:

    Every Product in the market has some PROS(+) and COS(-).
    RT-N16 is no exception, so take your time and search was fit to your needs and your pocket.

    BTW i will also do sometime a cooling mod to ensure 100% 532+Mhz Stability... :biggrin:
  48. TexasFlood

    TexasFlood Network Guru Member

    So you've already returned one and trying to decide whether to get a replacement or refund? Could you be more specific about how "the wireless was hardly working"? Perhaps it's something that could be tweaked to work. Was this with the stock firmware or teddy_bear's Tomato build?

    If I felt that I HAD to add heatsinks and/or fans to use my RT-N16 then I might question keeping it but mine is working fine, for my needs, without any hardware modifications.

    I'm considering improving the cooling at some point but consider it an optional improvement, not a requirement. Note that I'm running the stock 480MHz clock speed. I did overclock it to 532MHz just to see if it would work but went back to stock after. It's a small gain and not work the risk of overheating so I won't overclock without some sort of supplemental cooling.

    I can only speak of my experience but I'm happy so far.
  49. oldkuang

    oldkuang Addicted to LI Member

    I post here as well, hope someone can help me.

    I don't know what exactly I did. Define the symbols rc_start or echo to the fstab. Now I got this

    nvram show
    sh: nvram: Permission denied
    sh: sort: Permission
    deniedSegmentation fault

    Do I have to reload firmware to correct this? Thanks a lot for help.
  50. Toastman

    Toastman Super Moderator Staff Member Member

    Another myth is beginning to take hold...

    Stallmen, the results of our measurements are very clear. No additional cooling has been found to be necessary. Until someone proves, and I mean PROVES, otherwise, I will stand by that statement. Some people may like to do it anyway, even though it has not been shown to be "necessary". There's no harm in that at all.

    Unless someone has a very high ambient temperature because they are (a) in a hot climate such as where I live, in the tropics and (b) the router is an an enclosure - I don't see the need for a fan or extra heatsinks. Neither did my friend the certification engineer in the UK lab.

    If the ambient temperature is very high, (and mine sometimes reaches 40 degrees plus), then a fan could be considered useful for insurance, although I'm not in the least bothered. To repeat once again, one sample has been running at 50 degrees ambient for two days without problems. And the processor when tested did not fail until it reached 85 degrees C. I'm sure your house doesn't get this hot?

    It is concerning me greatly that a myth is beginning to grow in much the same way as the one built around the WRT54GL. To repeat, at the moment, nobody has shown that lack of cooling has been responsible for any failures whatsoever. All is pure conjecture so far.

    For those who want nevertheless to fit some extra cooling, I'll post some information shortly on the best way to do it without wrecking your router. For those who have no technical skills, or lack the inclination to do it, just stop worrying about it, because it isn't necessary! I'd even like to go further and reassure you, that this router really flies !!!
  51. Catalin

    Catalin Addicted to LI Member

    The benefits of extra cooling might be shown on the long run, as it is well known and proven that higher the core temperatures, less reliable the chips get... Then you'll say it has warranty... Yes, it does, but unfortunately warranty applies differently in different parts of the world, a problem can be fixed in a few days or it could take months... Everybody should choose the solution that fits him best... In my case I prefer buying another router than waiting for RMA, and also I bought this unit to use it 24/7, not sit around and wait for Asus Service to fix it...

    It really needs extra cooling? Since there are no information about failed units, apparently not...
    Is cooling bad for it? For sure it can't be bad, as long as it is done well, and if a fan is fitted, is connected to a safe point on the PCB board.
  52. teddy_bear

    teddy_bear Network Guru Member


    Do not overclock it. The manufacturers - both Asus and Netgear - had a reason to clock this CPU to 480 MHz. According to Oleg from Asus forums, the author of popular alternative firmware for Asus routers who does some work directly for Asus now, the BCM4718 CPU is unstable at 533 MHz.

    Although some of these units appear to work just fine at this frequency, the router can still suddenly hang or reboot for no apparent reason, especially if you use USB port. My N16 starts up just fine at 533 MHz, but then reboots itself every several minutes - and it's definitely NOT an overheating issue. I tested it with the case open and the fan blowing on it - and it barely gets warm, but still reboots. At the same time I have no issues whatsoever with my router when it runs at 480 MHz - no problems with N-speed wireless transfers, no hang-ups or sudden restarts.

    You may be lucky, and your router might run for days at 533. The point is that the 480 MHz is the only safe bet, and that better cooling - although won't harm - won't help much with overclocking either.
  53. Catalin

    Catalin Addicted to LI Member

    I never overclocked mine, and I will never do it untill I see some comparison tests because I don't think it's worth it. :)
  54. Toastman

    Toastman Super Moderator Staff Member Member

    I concur with Teddy Bear's statement above. DO NOT CLOCK THIS ROUTER AT 532MHz. No amount of cooling makes any difference to the instability at 532 MHz. If it seems stable, that is probably because you haven't actually used it much.

    My router does accept this clock, but runs for a short time ONLY, then it reboots quite unpredictably. It does so even if placed in the freezer. It is most definitely not a cooling issue, it's probably a RAM timing issue or something weird which will become clear in time. Some models of the WRT54 were clocked by Linksys at 216 MHz by for this very reason, if my memory serves me correctly.
  55. Lost_Animal

    Lost_Animal Addicted to LI Member

    I had this router working at 532 MHz for days without any crash issues.
    All was fine - fast and barely warm.
    This changed since i installed Transmission optware.
    I changed the limit of max peers connections and Started download Torrent Files about 60 GB total size.

    Cpu was 100% load all the time and i had random disconections at Transmission.
    The timing was totally random (30 mins - 2,5 Hours - 1 hour e.t.c)

    Since then i never went back to 532MHz for heavy Download until do some cooling mods.:biggrin:
  56. stallmen

    stallmen Addicted to LI Member

    The RT-N16 I had bought had packet loss issues on the wireless interface. This is with the stock firmware. The only thing I could do to minimize the packet loss was to turn the router on it's side. I understand that the extra cooling is not required, but it seems that Asus has some quality control issues with these units.
  57. TexasFlood

    TexasFlood Network Guru Member

    I did basically nothing with the stock firmware before loading DD-WRT then Tomato, so can't speak to how well it works or doesn't work. There was some decent reviews of the stock firmware though. And as for quality control issues, I have read rumors of issues with at least the very early ones. My only personal experience is with mine which has been fine, luckily for me.
  58. mstombs

    mstombs Network Guru Member

    The title of this thread is wrong, there's already a report that it works with the Netgear - I can also report that the non-usb version I compiled for my wrt54g-tm also works.

    I again had problem with getting wan port to work, but power cycling the modem fixed it this time, so I will have to blame someone else for that!

    Dec 31 16:00:12 unknown init[1]: Tomato 1.27.0000 2std ND
    Dec 31 16:00:12 unknown init[1]: Linksys WRT54G/GS/GL
    # uname -a 
    Linux unknown #1 Tue Feb 2 00:24:11 GMT 2010 mips GNU/Linux
    All seems to work fine (including route to gateway through modem)
  59. mstombs

    mstombs Network Guru Member

    Re Asus RT-N16,

    Mine is cool to the touch from outside, but I have been running it standing on its side - it does have wall mounting hooks - maybe better air convection when on edge?

    I haven't opened it up yet, so do not know if I even have heat sinks - do you have to remove the rubber feet? I will do it sometime to fit a serial console adaptor, but the back panel is pretty full!

    I do have a couple of ADSL routers that feel hot through the case, this is not same league!. I would be very surprised if this technology router cpu gets hot depending on throughput, heat primarily a function of clockrate - and Gigabit switches will be hot. Wireless may be a an exception some bits could get hot when 'shouting loud'.
  60. TexasFlood

    TexasFlood Network Guru Member

    You know, I wasn't thinking about it, but I've been running mine on it's side also. I had the WL500GPv2 on its side at the edge of my desk where it meets a bookshelf because it took up minimal space there and gave good coverage through the rest of the house. When I swapped it out for the RT-N16, I just put it in the same place cause it was easy and I'm lazy. It's virtually identical in size except for the additional antennas which wasn't an issue.

    I haven't opened my case either but looked through the top holes with a flashlight and could see that it has a single heatsink on the CPU. I was advised by someone who has opened the case that it's "not a big deal" (FYI, not my words as I haven't done it yet), just pull off the small rubber pads on the bottom to access the 4 screws. And there is reportedly no "warranty seal" to break.
  61. cariyawa

    cariyawa Addicted to LI Member

    I opened mine... No warranty seals, locks.. nothing.. Just removed the 4 rubber pads and then 4 screws. Then top can be lifted off without any tools...
  62. pharma

    pharma Network Guru Member

    @ mstombs
    Interesting comment .... I saw this on the NetGear website for the WNR3500L router:

    Open-Source Router, Community and Development Partner program
    • Open-source Wireless-N router with Gigabit wired ports for Linux developers and open-source enthusiasts.
    • Open-source community website and development Partner program with downloadable applications, user guide, forums, blogs and downloads at
    • High Performance Broadcom 480 MHz MIPS® 74K CPU, 8 MB Flash and 64 MB RAM to even run business-class applications
    • Popular Linux Firmware-DD-WRT, Open-WRT and Tomato available on Open-source community website

    Based on this the Official Tomato firmware and all other mods should be able to work with the NetGear WNR3500L router.

  63. Catalin

    Catalin Addicted to LI Member

    Mine stays also mounted on the wall... Because of that, the heat goes upwards.. You can feel it if you remove a USB cable or connector from the socket after a few hours on functioning, and also, on the back cover of the case, on the opposite side of where the ethernet chip is located.
  64. mstombs

    mstombs Network Guru Member

    Just to be clear - when they posted this they had patched the Linksys WRT54GL distro, downloaded from Victek's web site and just about managed to get Tomato to run with the 2.4 kernel - but wireless didn't work so it was not usable. Seemingly they had no help from Netgear/Broadcom in getting new drivers for the 2.6 kernel.

    Teddy_bear has constructed a complete new src and toolchain tree, freely available from the Git repository, which I can confirm compiles first time without any modification on my system. The resulting firmware is still heavily dependent on Broadcom binary drivers, which is to be expected as the routers have large integrated Broadcom chips that do all the clever bits!

    That Teddy_bear's firmware works on other routers is not an accident - it is a result of careful consideration of the Broadcom chips identifying board_flags and the fact that the routers have custom CFE's that do board specific setup.

    We now have a router platform with Tomato and 2.6 kernel and hardware with enough CPU speed/ram/hard-disk to fully utilize the rest of the GNU/Linux OpenSource world - REJOICE!

    Thanks again teddy_bear
  65. Troydm

    Troydm Addicted to LI Member

    can anyone confirm that wireless-n issues with large file transfers (reboot issues) go away after you do a cooling mod (like add a case cooler inside this router)

    EDIT - NO THEY DO NOT !!! -admin
  66. stallmen

    stallmen Addicted to LI Member

  67. KyleChen

    KyleChen Addicted to LI Member

    please read the post in last 2 pages. there is no over-heat issue for the router, unless you room ambient temperature reach 60+ C degree which is impossible in most places of the world.

    reboot issues can be caused by over-clock, and it is a chip interior problem with overclock, not the heat. the cooler/heatsink/fans wont help.

    many thanks to teddy bear and toastman.
  68. cariyawa

    cariyawa Addicted to LI Member

    I am not promoting/ demoting anyone to do hardware modifications for RT-N16. Personally I really don't care about the warranty for this one. As most of the above posts mentioned, I could have put a fan, but I already have 24/7 server running with lot of noise in my room. So I prefer to have a passive heat sink. Of course this will void my warranty and since I used thermal epoxy, I'll never ever be able to see the top of the CPU and switch again :biggrin:

    Attached Files:

  69. HanzF

    HanzF Addicted to LI Member

    Mine did have the warranty seal on one bolt. I bought this router open box from Newegg so I don't know if it took a trip back to Asus or not, however, it has performed like a rock so far with Tomato.
  70. cariyawa

    cariyawa Addicted to LI Member

    Probably Asus people knows that more and more people are using 3rd party firmware on this router instead of their stock firmware. So they might have started adding warranty seals for new batches.... One way to get out of honoring warranty saying "you broke the seal"...
  71. Credo

    Credo Addicted to LI Member

    cat /proc/cpuinfo
    system type		: Broadcom BCM4716 chip rev 1
    processor		: 0
    cpu model		: MIPS 74K V4.0
    BogoMIPS		: [COLOR="Red"]238.59[/COLOR]
    wait instruction	             : no
    microsecond timers	             : yes
    tlb_entries		: 64
    extra interrupt vector	: no
    hardware watchpoint	: yes
    ASEs implemented	: mips16 dsp
    VCED exceptions		: not available
    VCEI exceptions		: not available
    unaligned_instructions	: 9
    dcache hits		: 2147483648
    dcache misses		: 3077528935
    icache hits		: 2147483648
    icache misses		: 3752034285
    instructions		: 2147483648
    Feature of the firmware or not properly installed?
    It is necessary to install 480MHz hand-teams?
  72. shibby20

    shibby20 Network Guru Member

    @Credo - this is not frequency of CPU. Check dmesg after run your router and you will see "CPU: BCM4716 rev 1 at 480 MHz"
  73. bogderpirat

    bogderpirat Network Guru Member

    hey there!
    in anticipation of my wnr3500l arriving soon, i got the source off the git repository (.tar.gz link here) and wanted to try and compile the thing. i set up a fresh debian inside a vm and installed those packages from debian that are necessary for compilation (build-essential, bison, flex, autoconf, a couple more).
    now when i try to run with edited paths to conform to my extraction dir, it configures the kernel, then compiles for a while and after some time, aborts.
    here's a log of the process; the first few lines are the (evidently successful, despite being full of warnings) compilation of iptables, after that when he changes to the rc directory, it errors out on everything, because some files are missing.
    this is probably an error of mine, but i can't figure it out - do i need extra stuff besides the toolchain that is already included in the tomato-RT branch?
  74. mstombs

    mstombs Network Guru Member

    Hi - been there and had same errors - you are building the wrong src directory, start in "src-rt" for the Linux kernel 2.6 version you want, and you don't want to use that, don't know what thats doing there - see instructions earlier in this thread!
  75. bogderpirat

    bogderpirat Network Guru Member

    crap on a cracker!
    thanks, i must have skipped that (albeit being an avid follower of this thread).
    BTW, if anyone needs a wnr3500l person to test this firmware, feel free to harass me about it. i'm planning to do throughput tests as soon as i have it.
  76. though

    though Network Guru Member

    RT-N16 Thread

    Please start a wnr3500l thread. this thread is for the RT-N16 and teddybear's tomato firmware release for it.

  77. teddy_bear

    teddy_bear Network Guru Member

    Actually, this mod is not only for N16 - more models will be supported, and are already if you compile sources from git yourself, like bogderpirat is doing.

    There's no need for a new thread yet. However, after I release the next build, I will either rename this thread to remove RT-N16 from the title, or start a new one...
  78. Catalin

    Catalin Addicted to LI Member

    When will that be?:flowers:
  79. though

    though Network Guru Member

    thanks for the clarification teddy. where's the N12 build :)
  80. mstombs

    mstombs Network Guru Member

    I also saw this, other Broadcom mips processors do tend to report bogomips = cpu clock rate, but this ratio does change between processor families. I hope it is just the R2 mips in the bcm4718 that do twice as much per cycle for some operations - just not for the simple delay loop used to calibrate the system on boot-up.
  81. dtruax

    dtruax Guest

    dual DHCP load balancing

    Thanks very much for this awesome firmware Teddy Bear! Both wireless N and the print server function flawlessly; those are the main features I found lacking in the Asus firmware.

    I have a question though, is it possible to configure this firmware to create 2 DHCP connections to one modem using a single wan port, and then load balance it? I guess what I want to do is similar to the mlppp mod, except that I need to use DHCP.
  82. blackmack

    blackmack LI Guru Member

    I tried to overclock the router but it crashes at 532MHz while copying files over USB. I tried to lover frequecy, but the next lovest acceptet was 500 and 250 for ram. If i set 510 and 255 for ram it goes back to 532,266. I assume it's set by internal frequency table. How to get this table, to see which frequencies are supported to find the stable maximum? Or how can i set frequencies between 500 and 532?
  83. mstombs

    mstombs Network Guru Member

  84. blackmack

    blackmack LI Guru Member

    Thanks. So i have to stay with 500/250. Is anyones router stable at USB copying with 532/266? I installed a bigger heatsink but it doest help. I have also read that router gets more stable with a 5A power supply. Can anyone test this?
  85. i have a question, how can i get PPTP VPN (pass-trough) server to work on my ASUS RT-N16 with "Tomato Firmware v1.27.9042 RTN16-beta02 ND USB Ext."
    I have a Asus WL-500W with "Tomato ND 1.25 Thor MOD - SDHC | SNMP | VPN | USB "and with this router it works very wel.
    i use /8 as LAN address space. my gateway is and my PPTP VPN server is
    I forward TCP 1723 to
    The WL500W is working perfectly.
    The RT-N16 is giving me "Error 721: Remote PPP peer is not responding"
    With the Asus firmware (for the RT-N16) it is working but that is just about the only thing that is working....
    when i disconnect the RT-N16 and connect the WL-500W it works.....
    (i never use both the gateways at the same time becase they have the same IP)
    Can somebody help me ?
  86. TexasFlood

    TexasFlood Network Guru Member

    Is 500,250 stable? I tried 532,266 but went back to 480,240,120 because it's stable, and seems plenty fast so don't feel I -have- to overclock it.
  87. KyleChen

    KyleChen Addicted to LI Member

  88. blackmack

    blackmack LI Guru Member

    Yes it's stable. I overclock it becouse i get faster usb speeds.
  89. Catalin

    Catalin Addicted to LI Member

    How much faster compared to the standard freq (480,240) ? I get about 7 MB/s read and 3 MB/s write on a flash usb pendrive on standard freq.

    My figures for this Tomato USB firmware so far:
    Router's uptime: 5 days
    PPPoE conn uptime: 4 days 3 hours
    Data transfer through WAN since last reboot: 296 GB

    No problems whatsoever. I only get random erorrs in the syslog about samba, but despite that, everything works, including samba.
  90. Toastman

    Toastman Super Moderator Staff Member Member

    500/480=1.042 - it is 4% faster but may be unstable - but that depends on your particular hardware. Mine seems OK.
  91. KyleChen

    KyleChen Addicted to LI Member

    It no transfer speed change after O/C. and I just tried, OC 533 the router became paranormal. even OC 500 the router not stable (lost wifi connections after 5 mins and usb disk become read-only after few MB data transfered)

    the stock 480M Hz
    On ext3 partition, it is about 7M/S write, 15M/S read.
    On ntfs partiton, it is 1.6M/s write(very slow...) and 6M/s read.

    Seagate free agent go 2.5 disk and windows 7 x64 system, under SAMBA.

    My experience is, bad usb storage quality and vista system are main killers of the transfer rate.

    If I format disk into bigger size block, killall background bittorrent program and transfer files under FTP, this number should be rocked again. I am pretty happy with it except NTFS write. I can't use fat32 coz i download blue ray movies usually larger than 4G, I can't use ext3 coz I am a windows user. I dont like the speed of NTFS but i have to use it, things never be perfect in life you know.
  92. Catalin

    Catalin Addicted to LI Member

    Hm, my values are for a NTFS file system... It's strage you got such high values for ext3... Or at least I've never read about someone having such high transfer speeds..
  93. Rasky

    Rasky Addicted to LI Member

    I suggest you format the disk with ext2 (which is even faster than ext3) and then use a ext2 driver for Windows such as:
  94. Rasky

    Rasky Addicted to LI Member

    teddy_bear: i've got troubles with the tomato firmware on my brand new rt-16. It looks like the wireless network "dies" at some point and the only way to fix it is to reboot.

    I'll try to give you more details of what happens while it is "dead". The SSID is still broadcasted. When I try to associated a client to the AP, i get timeouts; this is the dmesg from my Linux client:

    [ 4612.028234] ath0: direct probe to AP 90:e6:ba:92:ad:15 (try 1)
    [ 4612.221172] ath0: direct probe to AP 90:e6:ba:92:ad:15 (try 2)
    [ 4612.421460] ath0: direct probe to AP 90:e6:ba:92:ad:15 (try 3)
    [ 4612.620631] ath0: direct probe to AP 90:e6:ba:92:ad:15 timed out

    Even if I restart the wireless subsystem (service wireless restart, or tweaking wireless parameters in web interface and then saving), it still does not work.

    I activated full logging, but there is absolutely nothing being printed to either dmesg or /var/log/messages, so I have no clue how to debug this.

    This is the dmesg following a wireless restart:

    vlan2: dev_set_allmulti(master, -1)
    vlan2: del 01:00:5e:00:00:01 mcast address from vlan interface
    vlan2: del 01:00:5e:00:00:01 mcast address from master interface
    br0: port 2(eth1) entering disabled state
    br0: port 1(vlan1) entering disabled state
    vlan1: dev_set_promiscuity(master, 1)
    vlan1: del 01:00:5e:00:00:01 mcast address from vlan interface
    vlan1: del 01:00:5e:00:00:01 mcast address from master interface
    device vlan1 left promiscuous mode
    br0: port 1(vlan1) entering disabled state
    device eth1 left promiscuous mode
    br0: port 2(eth1) entering disabled state
    EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
    EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
    br0: starting userspace STP failed, staring kernel STP
    vlan1: add 01:00:5e:00:00:01 mcast address to master interface
    device eth1 entered promiscuous mode
    br0: port 2(eth1) entering listening state
    br0: port 1(vlan1) entering listening state
    br0: port 2(eth1) entering learning state
    br0: port 1(vlan1) entering learning state
    br0: topology change detected, propagating
    br0: port 2(eth1) entering forwarding state
    br0: topology change detected, propagating
    br0: port 1(vlan1) entering forwarding state
    vlan2: Setting MAC address to 90 e6 ba 92 ad 14.
    vlan2: add 01:00:5e:00:00:01 mcast address to master interface
    vlan2: dev_set_allmulti(master, 1)

    How should I debug this?
  95. blackmack

    blackmack LI Guru Member

    With 480 around 7MB/s write, 6 read. 500 aroud 7,5 write 6,9 read and with 532 8,4 write and 7,5 read.
  96. Catalin

    Catalin Addicted to LI Member

    What file system? How can you get higher write than read speeds?
  97. Rasky

    Rasky Addicted to LI Member

    I further investigated it: it is not a "die" state. The issue is that the signal is really disturbed.

    My wl500gp has a really stable signal. I bumped the transmission power to 70mW because I live in a noisy block, but other than that I can get good signal in my whole flat. If I walk around with a laptop with a ping on the screen, I get super-table 1ms pings within the whole apartment.

    When I switch to rt-16, things are much worse. I get 1ms pings only if I stand in front of the router. As soon as I walk away 2-3 meters and get behind a wall, I get a very irregular ping, packet drops, and so on. I replicated the same configuration of the wl500g; I'm using the same wifi channel (channel 1), with the same transmission power (70mw), with the same wifi config (G-only), the same encryption (WPA1/2-AES), and so on. I can't spot a single difference in the web screens.

    If I look at the output of iwconfig from a connected client, I get approximately the same results from the same position:
    Tx-Power=27 dBm Link Quality=56/70 Signal level=-54 dBm

    Any idea? Maybe a broken unit?

    I remember when I first got my Asus router I had similar problems; I had to open it to find out that the external antenna was disconnected from the PCB. Then googled and find out that it was a common factory defect. Might be something similar?
  98. simploid

    simploid Guest

  99. Catalin

    Catalin Addicted to LI Member

    Use a DDWRT mini firmware compatible with your unit, and after that flash the Tomato firmware from DDWRT GUI.
  100. shibby20

    shibby20 Network Guru Member

    @simploid - dont install this firmware to netgear. This firmware doeasnt support nergear fully. You have to wait for new release.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice