Tomato ND USB Mod with kernel 2.6 (Tomato-RT)

Discussion in 'Tomato Firmware' started by teddy_bear, Jan 8, 2010.

  1. belliash

    belliash Addicted to LI Member

    @teddy_bear: Two features missing in my opinion:

    1) Mixed G/N wifi mode would be nice (it is possible to check G/N mixed in DD-WRT)
    2) IP/MAC BW Limiter like in Tomato RAF mod - it's very usefull and meny ppl uses that blessing feature ;)

    And one more thing... i have connected WRT54GL LAN <=> RT-N16 WAN.
    Asus stock firmware and DD-WRT were obtaining IP from DHCP (WAN in DHCP mode), but tomato does not - had to choose static ip...

    Anyway great software and good luck!
    Looking forward for missing features ;)
  2. bagu

    bagu Network Guru Member

    I have RT-N16 with wan in DHCP mode and everything work fine

    But : UPNP don't work...
  3. though

    though Network Guru Member

    2 questions:

    1) when you change from 1 beta to another... 05 to 07 for example, do you need to do a thorough reset and re-input your figures to be safe or not?

    2) is there a changelog with these releases?

  4. Exeqtor

    Exeqtor Guest

    Thx teddy_bear for new beta07

    I found one issue with WLAN:

    I'm using old pda with Windows Mobile 2003 SE (FS Loox 420) on my WRT54GL (Tomato v1.23, security: WPA Personal-TKIP). WPA2 isn't supported.
    I turned on the same security on RT-N16 beta07 but my pda doesn't connect with router.
    I've tried different modes: including B/G Mixed and Auto.
    After changing security on WEP it connects and working.

    I dont' know: maybe problem is only with my pda.
  5. teddy_bear

    teddy_bear Network Guru Member

    Actually, there're more than 2 features that can be added/implemented :)... The only question is a free time to do it all...

    1) You mean - G/N without B? Can be useful for some, but probably not for many. I'll take a look - maybe it's something that can be added quickly and easily.

    2) I bet half of IP/MAC limiter users use it because they don't know how to setup service-based QoS properly. That said, there's definitely a usage for it for people with monthly bandwidth limit. And yes - it's on my list ;).

    What I'm gonna do soon is starting a poll here for new features to be included in future versions of this mod, and then get to them based on the actual demand.

    As for obtaining the WAN address from the ISP - you just may have to reboot or power-cycle the router one more time. If you look through this thread, you'll find a few complains about similar problem - all were resolved either by power-cycling, or by some "magic" sequence of saving some settings - like enabling and then disabling again the Jumbo frame support... What version do you use? I hope the issue is fixed in beta07, but I'm not sure since I can't reproduce it myself.

    Correction - UPNP in general works - I have no problems with it. If you're talking about RTSP (which I know you have problems with), that's totally different thing... In any case, please do not post blind statements like this - always clarify what exactly is not working for you and how, and what you expect.

    WPA+TKIP should be disabled in beta07 in "Auto" and "N-only" modes - unless I forgot to disable it ;) - because it's officialy an invalid combination now in the final "N" standard.
    It should still work in "B/G" or "G-only" mode though. Try different channels, and make sure to update wi-fi driver for your PDA to the latest. You can also play with advanced wireless settings on the router. But of course there's still a chance that some older clients may not be compatible with it...
  6. hapahopi

    hapahopi LI Guru Member

    upgraded my wl-500gpv2 to beta07. usb working already with optware transmission. thanks a lot TB!
  7. bagu

    bagu Network Guru Member

    Sorry teddy, but this time, it's an other problem.

    Emule can't open port...I will try to re-update, erase all nvram and re-enter datas.
    Maybe it come from a change wich need an nvram erasing.
    I will re-post when more tests done.
  8. mstombs

    mstombs Network Guru Member

    There are known issues with miniupnpd (used for some time in all versions of tomato for upnpd) and emule, there are emule mods that fix this - search the forums..
  9. bagu

    bagu Network Guru Member

    Already done, eveything work fine with beta5 after many other tests, it work with beta7 too...

    As i said just before your post, i suspect it need clear nvram + manually enter config + reboot to make it work 100% of the time.

    May be it will be usefull to say it in first post to make tests more accurate ?
  10. bigclaw

    bigclaw Network Guru Member

    I may be a bit slow... where can I find the release notes for beta07? I'm trying to decide whether to upgrade.

  11. Brandonc

    Brandonc Addicted to LI Member

    This may be addressed in other releases of Tomato but on this particular fork if I were to connect a multiple USB adapter to the router and plug in both a HD and a printer and enable both would it work?
  12. myersw

    myersw Network Guru Member

    Upgraded the beta07 ext on RT-N16. Everything looks fine. USB share mounted without incident.
    Thanks for the hard work teddy_bear. Asus should give you some money for this. I am sure there are others like myself that bought the RT-N16 because of the Tomato support with USB, etc. The RT-N16 is a work horse for me and just keeps running.
  13. bub181

    bub181 Addicted to LI Member

    That's a great idea. I'll put a vote in for optware integration. Thanks teddy_bear!
  14. ACE 256

    ACE 256 Addicted to LI Member

    I don't know if this has been brought up before or if its just a problem with my setup but channels 1 and 2 don't seem to work in 40Mhz N mode. Channel 3 seems to get the best signal of the ones I have tested (I have only tested a few). Also is there a way to donate to you personally?
  15. voipj

    voipj Addicted to LI Member

    hp 1018 printer

    Does anybody has success running hp 1018 with hot plug script on RT-N16? I tried to run it but printer is still not working. I tried all the remedies as per original USB tread but no success. I'm running windows 7 on my system. Printer work fine attached directly to system but not on router. Router is able to detect printer but can't print. Pl. help
  16. teddy_bear

    teddy_bear Network Guru Member

    ACE 256,
    All channels work differently in different conditions. This depends on your clients, neighboring wi-fi networks, interference with electronic devices etc. For example, I never get a good speed on any channel below 6. So it might be your setup, your environment, or anything else. I wouldn't worry too much if there are still channels that work good for you.

    By "all the remedies" do you mean loading firmware into HP1018 from the router using hotplug script?
  17. Rasky

    Rasky Addicted to LI Member

    What is the memory usage of 2.6 compare to 2.4? I'm worried that on 32Mb routers like WL500gP 2.6 would eat too much RAM.
  18. though

    though Network Guru Member

    my N16 is using up about 10MB of ram most of the time...
  19. belliash

    belliash Addicted to LI Member

    Yes, i meant that ;)

    No... I connected RT-N16 WAN to WRT54GL LAN ;) And it cannot obtain IP from DHCP. I have PPPoE connected to WRT54GL WAN port and RT-N16 connected to WRT54GL LAN.

    There is Tomato 1.27 RAF installed on Linksys and static dhcp set by MAC address... And RT-N16 with Tomato 1.27beta07 that cant obtain IP from linksys. Already tried clearing nvram (from gui - thorought and pressing WPS while powering on). Will try to play with Jumbo Frame support when get home as i'm at university right now.

    I also think You might connect Ext with VPN version. RT-N16 has a lot space for both VPN and additional stuff. You may also consider adding iperf in beta08, so ppl (at least me) would not have to use optware for that ;)
  20. sysdemon

    sysdemon Addicted to LI Member

    teddy_bear, thank you for L2TP kernel acceleration, it works! CPU usage at 10 megabits decreased from 100% to 30%!
    I wish to report about some strange problem when using L2TP - it is impossible to upload big files via FTP fo fileshare services. It hungs at 92 megs with "dropped from server side" message (tested more then 10 times with different files/services). Changing firmware to non-Tomato fix the problem.
  21. crack

    crack Addicted to LI Member

    Somehow, I find the WLAN signal strength curious on my WNR3500L (using it as a wireless ethernet bridge at the moment):

    With beta06u.04, signal quality is between 35 and 40, RSSI is ~ -40 dBm and Noise is 76 dBm.

    With beta07 (and the earlier betas) signal quality is between 20 and 25, RSSI is ~ -72 dBm, Noise is -96 dBm.

    Also, changing the transmit power doesn't seem to have any effect. Anyone experienced anything similar?
  22. ACE 256

    ACE 256 Addicted to LI Member

    There is no signal at all using channels 1 or 2. Even feet from the router. :confused:
  23. voipj

    voipj Addicted to LI Member

    Yes, It shows loaded, the printer is in the attached USB devices. Only no check mark or any comment in Mounted? column.
  24. contrary

    contrary Addicted to LI Member

    Hi and Thanks for all this work!
    I loaded MIPS1beta07 onto my WL-500gPv2 last night and have noted a small problem.
    After thorough nvram erase and reconfiguring by hand using the gui, I could START my vpn client fine, and STOP it once, but once I did that the "Stop Now" button never updates. In other words the vpn stops ok, but the button doesn't change from StopNow to StartNow. A workaround is to reboot (from the gui menu) which resets the StartNow button. I will try MIPS2beta07 on my N16 this weekend and can provide more info if you tell me what detail you need, and if the problem repeats on the N16 version.
  25. jnappert

    jnappert LI Guru Member

    Hello teddy_bear.

    I compiled squid to use epoll. As squid tries to startup it states: "error function call epoll not available"...
  26. teddy_bear

    teddy_bear Network Guru Member

    Interesting... Curious if that's caused by MAC adress of WAN port not being updated until you do something "special". Do you allow DHCP on WRT54GL at all? Do you see the N16 on the list of attached devices on GL (I believe you should see it there even if it can't obtain an IP)? If so - what MAC does it show - is it the same as you expect and configured?
    I'm aware of this problem - the other testers who tried it with L2TP reported the same issue. I'm still trying to figure it out - that's why there were no announcement yet for an updated L2TP driver ;). I was also told the behaviour was the same in the previous builds (beta02 and beta05) which didn't include any L2TP-related changes at all. Can you confirm that? Also - could you please check if it loads routes from the ISP correctly now?
    I wonder what signal strength you're measuring - the router doesn't transmit in wireless ethernet bridge mode ;)... Besides, the most notable change between beta06u.04 and beta07 is the version number - nothing that could affect wireless.
    Just tested it, and it works here with beta07 on these channels and 40MHz bandwidth. So it must be your specific environment, client or setup.
    Where does it show as "loaded"?? Please describe step by step what you're trying to do to make it work - the vague statement about "all remedies" leaves it all to guess.
    Did it work in USB mod build 44 (kernel 2.4-based)? What is in the process list ("ps" command output) after you stop the client from GUI?
    Well, I guess that means "CONFIG_EPOLL=y" in 2.6.22 is not enough for what squid wants...
    From after compiling the kernel:
    800b3e10 T sys_epoll_wait
    800b430c T sys_epoll_pwait
    800b4450 T sys_epoll_ctl
    800b4918 t ep_ptable_queue_proc
    800b49d8 T sys_epoll_create
    800b4ac4 t ep_eventpoll_poll
    800b4b38 t ep_poll_callback
    Any idea why it may not be enough?
  27. belliash

    belliash Addicted to LI Member

    MAC is written on the label at the bottom of router. I have typed it in static DHCP, and PASTED into ARP binding in IP/MAC BW Limiter. I repeat - I COPIED & PASTED IT.

    Two facts:
    1) Static IP works
    2) RT-N16 cannot obtain IP from WRT54GL using DHCP.

    MAC has to be good. Otherwise there won't be communication due to selected "Limit unlisted machines" option in ARP binding page. I checked Jumbo Frames, as You said - didnt help.

    P.S. have You got my PW?
  28. mstombs

    mstombs Network Guru Member

    Time to get a hub and wireshark between routers. Strange MAC changes also explain my inability to sometimes get WAN connections - may have to wait 5 mins for connected arp tables to timeout, but if dhcp the old IP likely reserved. I saw this type of problem years ago with tomato when experimenting with dual-wan, the dhcp broadcasts can come from a different default MAC than subsequent requests.
  29. teddy_bear

    teddy_bear Network Guru Member

    The MAC on the bottom is the router's LAN MAC. Tomato sets the WAN MAC to be a [LAN MAC]+1, and the WLAN MAC to [LAN MAC]+2.
    Looks like something with MAC setting is not working with this switch, or with kernel 2.6, the same way as it used to - and that's what seems to cause some people these weird connectivity issues. Doesn't happen to everybody though - I can't reproduce the problem here.
    Ok, so with the static IP assigned based on the router's supposedly-LAN MAC address, it connects just fine? That probably means that the WAN port still has the same MAC as the LAN port, and has not been changed - and that, in turn, may cause some weird behavior... We're getting closer ;)...
    Can you post your "ifconfig" output? If it has the correct MAC on the WAN iface (i.e. [LAN MAC]+1, as it should be) - then maybe all you need to do is to specify it on your GL for ARP binding.
    Yep. Are you going to submit a patch to enable booting from USB drive, or wait for me to implement it ;)?
  30. sysdemon

    sysdemon Addicted to LI Member

    Yes, same was for beta05, and yes, it loads routes from ISP as expected! :) Interesting is that when upload hungs, you can browse the FTP server directories, but even after some time when I try to resume upload (some FTP servers support this feature) even one bit cannot be uploaded. After reconnecting to the same server, resume works (so 90 megs, hung, reconnect, 410 megs more without problems). Maybe you need to see it by your eyes? I can share with you my desktop if it can help.

    Another small issue - ISPs use vpn servers with DNS round robbin for load balancing, so name of VPN server resolves to several IPs. Right now entering of vpn server names don't work, so I have to use IPs only. Is it hard to fix it?
  31. belliash

    belliash Addicted to LI Member

    @teddy_bear: i will describe in points:

    1) MAC from bottom (from label) is: XX:XX:XX:XX:XX:8B
    2) Tomato shows XX:XX:XX:XX:XX:8C as WAN port MAC address
    4) Tomato shows XX:XX:XX:XX:XX:8D as WLAN MAC address
    5) When was still on asus stock firmware i have written XX:XX:XX:XX:XX:8B (from label) in static dhcp on wrt54gl (tomato), hen copied and pasted to ARP Binding :)
    6) On stock software it obtained IP via DHCP
    7) Upgraded to dd-wrt, and it also obtained IP via DHCP
    8) Upgraded to tomato - DHCP does not work

    So i noticed something weird... Routers are connected together WRT54GL LAN <=> RT-N16 WAN. Both stock and DD-WRT have obtained IP from DHCP (mac still set to 8B - from label). Tomato does not, as WAN port MAC address is not 8B, but 8C - OK... but i have also binded ARP... so if MAC is wrong the RT-N16 should have no internet access...

    But ok, let's see 8C is WAN MAC address.. so i updated configuration in WRT54GL (both static dhcp and arp binding). It obtained IP - wow! But it's not accessible from WRT54GL LAN. I had to connect notebook to RT-N16 LAN port to access it.

    So i set static IP to 8C and ARP binding to 8B and seems to work ok...
    And now please tell me what the hell? 2 MACs for WAN port? :| That's strange and weird :| I still cannot believe that.

    i think it would be faster if you could implement it, as im rather more familiar with openwrt. tomato is afaik missing init scripts - the easiest way to do that. and btw i also consider it as usefull feature for ppl with routers that have less free flash space.

    teddy_bear, if You use jabber, then maybe we could discuss some things
  32. teddy_bear

    teddy_bear Network Guru Member

    Ok, so there's no problem then - it all was your fault - and the correct config of the main router solves the issue. I have no idea how ARP binding is implemented in the RAF mod and what exactly it does - maybe it only affects DHCP? Also remember that to access N16 from your GL LAN, you need to allow WAN admin access on N16, and get to it by the address assigned to it by GL.

    As for features you're asking for - sure, I'll implement all of them - and more - as soon as I can stretch a day up to 48 hrs ...
  33. belliash

    belliash Addicted to LI Member

    But thats weird...
    and it cannot affect DHCP only. Let's see situation:
    YY:YY:YY:YY:YY:YY has binded ip, when change IP to any other, then machine has limited network access. It's more complicated.

    And if that was my fault - why both stock & DD-WRT obtained IP?
    Thats very strange and could be adopted by X-Files :D
  34. teddy_bear

    teddy_bear Network Guru Member

    Probably because they don't change the default WAN MAC address, unlike Tomato, if you don't explicitly change it yourself in the GUI.
  35. Catalin

    Catalin Addicted to LI Member

    That's exactly right. :) I don't see it as a firmware problem at all. It's just a beginner's mistake in setting the correct MAC for static DHCP, and making wrong assumptions.
  36. belliash

    belliash Addicted to LI Member

    first of all i'm not begginer ;)
    second, it's still not clear why it works correctly only when specify 2 different MAC addresses on main router. As i already said before i had specified MAC address that was WAN MAC on both stock and dd-wrt. teddy_bear wrote that tomate changes mac address... i would say it swapped LAN and WAN macs... but when i entered new wan mac then i got no connectivity due to limitation of unlisted machines in arp binded table.

    So if i specify one, and the same mac, for both options: static dhcp and arp binding, then it should all work w/o any problems, OR don't acquire IP AND limit connectivity when static ip specified.

    And described situation is definitely a bug - just not sure if it is a bug in Tomato ND USB with kernel 2.6, or Tomato RAF...but i suppose Victek's mod failed here. And i'm going to ping him and let he know about that situation.
  37. teddy_bear

    teddy_bear Network Guru Member

    Yes, I believe that's how it should work. Well, there're no misteries - there should be an explanation.

    As this is not possible to have 2 different MAC addresses on one interface, it probably means that either
    • ARP binding is not working properly - I really doubt so, because Victek' usually thorougly tests features he includes, and this particular functionality has not been changed for a while - surely somebody would notice if something's wrong there.
    • You misunderstand what it does and what it doesn't do - I can't help here because I never looked into its implementation.
    • Maybe there's some discrepancy in how the settings are getting applied when ARP binding is changed - have you tried to reboot (just in case) both routers after saving the correct settings (i.e. specify the same correct N16 WAN MAC for static dhcp and arp binding on GL, and then save and reboot)?
  38. ACE 256

    ACE 256 Addicted to LI Member

    I'm running beta05 maybe this has been fixed in beta07. Do you accept donations? I would like to help with your work. :)

    Edit: Beta07 fixed the problem
  39. teddy_bear

    teddy_bear Network Guru Member

    Hmm... Doubt so - but it's worth to try - in any case there were several (unrelated to wireless) bugs fixed in b07.
    Sure, why not ;)? The link is in the 1st post. And thank you - and everyone else who donated - for your support!
  40. voipj

    voipj Addicted to LI Member

    HP 1018 Printer on RT-N16

    Teddy bear

    Steps I did, in beta07 built
    1) under Administration ---> JFFS---> Enable---> enable when mounted
    wget -O /jffs/sihp1018.dl
    ---> Format
    When loaded, it shows loaded and total free size changes.

    2) under USB & NAS ---> hotplug script added
    if [ $PRODUCT = "3f0/4117/100" ]
    if [ $ACTION = "add" ]
    sleep 5
    cat /jffs/sihp1018.dl > /dev/usb/lp0

    3)I can see the printer in attached devices with all the fields like Type, Host etc. filled, except for mounted? which is blank.

    4) Set up printer on windows 7 machine, added as described in USB thread

    When I tried to print any page. pc shows status as printing and then 0 documents pending for printing but the printer doesn't print anything or neither shows any sign of receiving data.
  41. teddy_bear

    teddy_bear Network Guru Member

    Ok, so that's what "loaded" meant... Well, it's loaded from the internet into the router - not into the printer yet.
    Now, once you have the file in /jffs, run the following commands manually in telnet or ssh session with printer connected and visible in the GUI:
    ls -lFA /jffs/sihp1018.dl
    This is just to make sure file is there, and is the correct size. You should see an output similar to this:
    -rwxr--r--    1 root     root       129143 Mar  5 23:19 /jffs/sihp1018.dl*
    where the 129143 is the size of the firmware file. It should be the same.

    Then try to load firmware to the printer (assuming you have only one printer connected to the router):
    cat /jffs/sihp1018.dl > /dev/usb/lp0
    I don't know if printer will provide any indication of firmware being loaded or not - but at least you should see no errors messages after this command. If you check the file size of /dev/usb/lp0 file, it still should show up as 0 after that.

    Now you should be able to configure your printer in Windows, and print to it. If not, it means something is wrong - either corrupted firmware file, or printer is not functioning properly, or you're not configuring it correctly in Win7.

    If it works now, then probably something's wrong with the hotplug script. Verify the product ID (you can see it in system log when you plug in the printer), and try to increase the delay.
    That all looks normal.
  42. Catalin

    Catalin Addicted to LI Member

    There is a big difference between "a beginner's mistake" and "a beginner". Nevermind, the point is that, unless you fiddle with it, the default WAN MAC for all the firmwares (Tomato / DDWRT / Oleg / Asus) is the same. And, using the other router, you can always check very easy what MAC every device connected to it has... Also, it's worth checking in Advanced/Routing/Miscellaneous what Mode is set (Gateway / Router).
  43. belliash

    belliash Addicted to LI Member

    @Catalin: I described above how do the static dhcp and arp binding work...
    If port MAC address is different than specified in ARP binding, then the machine (RT-N16 in this case) has no connectivity. The situation was different - RT-N16 has connectivity! Just could not obtain IP from DHCP Server.

    But ok - i specified wrong IP you said - so i changed configuration (both static dhcp, and arp). And what? RT-N16 obtained IP from DHCP, but no conenctivity (different MAC in ARP than port mac).

    So... If port can have ONLY ONE mac address, why i need to specify different at static dhcp card, and different in arp binding?! Thats sick! I hope You understand that, because its definitely a bug!

    Why i report that weird situation here? Because it has not happened on stock firmware and on DD-WRT (on RT-N16 ofc). On wrt54gl i use Tomato RAF all the time, with idem configuration.
    I hope You, guys, understand now...

    So Catalin, please dont talk about being a beginner and/or doing a beginner's mistakes, if You do not understand me correctly. Maybe the screenshot will tell You more than my descriptions:

    As You see i put 2 different MAC addresses for which is RT-N16 WAN.
    When i specify :8B in both then internet works but could not get IP from DHCP.
    When specify :8C in both, then obtains IP, but no connectivity (only RT-N16's lan works).
    Have to specify 2 different macs for 1 port, what is weird and abnormal.
  44. Catalin

    Catalin Addicted to LI Member

    I cannot reproduce your issue here... I've connected my old router (DI-524) to the ISP cable and the WAN port of the RT-N16 to a LAN port on the DI-524. I've set the static DCHP using the WAN MAC reported by Tomato GUI for RT-N16. Guess what? Everything works as it should, RT-N16 gets it's IP, and the internet works...
  45. belliash

    belliash Addicted to LI Member

    DI-524 does not allow You to bind ARP table - begin with that, so thats different situation.
  46. myersw

    myersw Network Guru Member

    teddy_bear. Just hit the donation button, had never noticed before, and sent some help your way.
    FOLKS, you use teddy_bear's mod. Give him some support. Send a donation. You would not be having the nice experience of Tomato on RT-N16, etc with USB if not for him.
  47. WrtFan

    WrtFan Addicted to LI Member

    RT-N16: Problems with 2GB files over Samba and MAC changes on VPN server start

    First of all I want to say hello to the users of this forum and apologize for my bad English.
    I changed from DD-WRT to tomato, because DD-WRT was not stable on my router.

    I like many features of Tomato ND USB an say thank you to teddy_bear for his famous work and all users who supports the community.

    Unfortunately i have two main problems:

    1) I can't access files which are greater than 2GB over Samba. The file system on the disk is ext3, with telnet i see the right size an can copy the file, in Windows the size is cut on 2GB and also only 2GB will be copied.

    2) On every start of the VPN Server the LAN-MAC of the router changes to a randomly value. So Vista and Win7 clients detects a new network location.
    I searched for the reason and found this:
    On creation the vpn adapter tap21 gets this randomly MAC, when it is added to the bridge br0, then the bridge gets this MAC.

    This seems to be a problem with Kernel 2.6, also in DD-WRT, where i started the vpn server over a script.
    There i have fixed this in the script, with setting the MAC of tap21 before adding it to the bridge.

    I have installed the vpn version of beta07.

    Any suggestions? Thanks.
  48. voipj

    voipj Addicted to LI Member

    HP1018 Printer on RT-N16

    Thank you Teddy bear. Checked from all wireless laptops. Worked like charm.
  49. teddy_bear

    teddy_bear Network Guru Member

    Thanks for reporting this! Yep, unfortunately some large files support defines got lost :frown:. I'll fix it in the next update.
    Is it really kernel 2.6-specific behavior? Looking at the TUN/TAP driver sources in kernel 2.4, it should also generate random MAC values...
    Anyway, you better consult regarding this with SgtPepperKSU - the author of VPN mod/integration - ask this question on VPN mod thread, or - better yet - start another thread. I'm not familiar with OpenVPN and TUN driver, but if you guys tell me what I can do in my code - if anything - to remedy the issue, I'll do it.
  50. TexasFlood

    TexasFlood Network Guru Member

    I don't use the ARP binding so I'm not 100 sure how it works. However based on what I do know, the RT-N16 WAN MAC is really the MAC of the device and gets the DHCP assignment. What I am not sure of is. We know the LAN MAC represents the default gateway from the RT-N16 LAN perspective. As you have the "Limit untrusted machines" box ticked on you WRT54GL, anything not on that list by definition won't be routed to the Internet so perhaps the LAN MAC has to be there for that reason.
  51. ACE 256

    ACE 256 Addicted to LI Member

    My RT-N16 to laptop wireless signal is very strong, but laptop to RT-N16 is rather weak. The majority of my bandwidth usage is RT-N16 to laptop and not from.

    1) Would it be possible to force a transmit only rate and leave the laptop transmit rate at auto?

    2) Can upstream and downstream wireless rates run asynchronous in 802.11n?

    3) If so how would you go about setting the transmission speeds above the 54max in the web interface?
  52. jnappert

    jnappert LI Guru Member

    I did some verbose logging to this:
    "FATAL: comm_select_init: epoll_create(): (89) Function not implemented"

    Seems that epoll_create is the problem - but i dont know if there are further dependencies...
  53. teddy_bear

    teddy_bear Network Guru Member

    ACE 256,
    I am not sure what you're talking about. Are you saying that the transfer speed is much slower going from your laptop to the wired clients than from the wired clients to the laptop?
    Also, the "Transmission Rate" on the Advanced->Wireless page is only for G-mode, and there are no separate transmit/receive rate settings.

    The libc shared libraries in Tomato are getting stripped out of all symbols not used by included applications to reduce the size. No other built-in software is using epoll functions, so these calles are getting removed from the library. And of course, there could be other dependencies - not only on epoll but other functions as well.

    The only way to make sure that all used functions are included, is to build the application into the firmware.
  54. WrtFan

    WrtFan Addicted to LI Member

    MAC changes on VPN server start

    I have tested it with Kernel 2.4. On adding the tap-adapter to the bridge with brtctl, to old MAC remains, with Kernel 2.6 it changes.
    I have also found an workaround for that problem:
    Before i start the service vpnserver1 i create the tap adapter tap21, change its MAC adress (ifconfig tap21 hw ether xx:xx:xx:xx:xx:xx) and then add it to the bridge. So i have always the same MAC, because i start the vpn on startup of the router.

    It would be nice, if this functionality would be added in the firmware.

  55. 01520717

    01520717 Guest

    newer TLS ciphers

    teddy_bear, thanks for all of your efforts on the firmware. It's definitely the best one out there for the RT-N16.

    Is there any chance you would consider updating the version of OpenSSL that's used? I believe gawd0nes found a way to use OpenSSL 1.0.0 with Tomato (see It seems to support a lot more ciphers for the sake of both compatibility and security.
  56. Elanzer

    Elanzer Addicted to LI Member

    Has anyone else noticed a flakiness with the RT-N16's wireless with this firmware, and knows of a solution?

    After about 1 day of uptime, none of my devices can connect wirelessly anymore until the wireless is reset.

    I flashed to dd-wrt, then beta05 with a thorough nvram erase, and then beta07 without an nvram reset.
  57. though

    though Network Guru Member

    maybe try a thorough nvram erase then put back in your parameters??

  58. myersw

    myersw Network Guru Member

    I have been up for over 4 days on a RT-N16 with beta07 without any wireless issues. Wireless is used all day and eve. As suggested, perhaps a nvram reset then re-input your parms?
  59. mschulze

    mschulze Addicted to LI Member

    With beta07 I am sill experiencing wireless disconnects (as I reported for the earlier betas). Now I found a way to get the wireless working again w/o rebooting the router: When I click the WAN release button, wireless comes back to life again (in the same moment I click that button), and WLAN clients can reconnect.
    Since I have switched from WPA/WPA2-TKIP/AES to WPA2-AES, the disconnects have become less frequent: about twice per week instead of once per day.
  60. though

    though Network Guru Member

    definitely go for WPA2 AES. i have 3 N16's in different locations and they are all rock solid (with the help of teddy bear of course!)
  61. teddy_bear

    teddy_bear Network Guru Member

    Sounds like a setting for VPN Server - an ability to specify custom MAC address for TAP adapter - which won't hurt kernel 2.4-based builds if implemented there as well. Talk to SgtPepperKSU, the author of OpenVPN integration, regarding implementing this feature - I'd like to avoid making changes in VPN code while he's still actively working on his mod.

    There's no real need to update OpenSSL - in regular builds it's only used to generate X.509 certificates, while actual secure connections are provided via MatrixSSL library.
    OpenSSL is used in VPN builds, but in these builds it already includes AES cipher backported and optimized by fyellin, and I also applied a few security patches applicable to the OpenSSL version used in Tomato.
  62. teddy_bear

    teddy_bear Network Guru Member

    What are your other wireless settings - network mode, channel, channel width? Have you changed any of the settings on the Advanced->Wireless page? What wireless clients do you have? Was it happening with any other firmwares if you tried any of them (Asus original, DD-WRT etc)?
  63. maurer

    maurer Network Guru Member

    kernel error

    i had this morning an interesting behavior from my rt-n16:
    the power led was off but i had wired connection to the internet
    when i tried to access through the ssh - the session died after login -> it showed me a blank screen with no prompt.
    Also i tried to reset the router through the web interface and it did not reset.
    I just used it as a transmission torrent seeder device - no other /opt daemons
    Before power cycle it and everything was back the way it was i saved the log.
    here it is the last erroneous part:
  64. weiyu99

    weiyu99 Addicted to LI Member


    Does anyone know if the no-usb VPN version (tomato-1.27-ND-9044MIPSR1-beta07-vpn3.6.rar) will work on Asus WL-520GU (4mb flash,16mb sram)?

  65. Catalin

    Catalin Addicted to LI Member

    Read the first post of this thread.
  66. mschulze

    mschulze Addicted to LI Member

    wireless settings:

    advanced settings (non-default):

    wireless clients:
    macbook (MB061LL/B)
    lenovo X300 (intel 4965)

    I haven't tried any other firmwares.

  67. Catalin

    Catalin Addicted to LI Member

    Teddy Bear, just a information that might be somehow usefull: Asus placed yesterday on their ftp site a new firmware for RT-N16, version 9010 ( ). Would be interesting to know if it brings some newer drivers...:)
  68. mstombs

    mstombs Network Guru Member

    Good find, and the GPL sourcecode downloaded and extracted first time, which is a good sign.

    The Broadcom release notes suggest its a much newer Broadcom reference set (5.22.65) than the previous Asus firmware (5.20.23) and wireless driver
    to version 5.10.119 from
  69. prito

    prito Addicted to LI Member

    Couple questions here.

    How does one use the extras file listed with the firmware on download site? What's in it?

    Second, is there anything lacking or different between the regular USB build and the VPN build aside from the VPN features? I've been using the VPN build, but I don't plan on implementing a VPN right now. Am I sacrificing or missing anything by using the VPN build?
  70. though

    though Network Guru Member

    i wonder if the updated driver set will offer better range or better compatibility with wireless devices???
  71. WilsonB

    WilsonB Addicted to LI Member

    Can someone fill me in one precisely what a 'thorough NVRAM reset' looks like for the N16? I've spent a good while looking into that, and it remains hazy.

    When I activate the 'restore' process via the button and a power-cycle, does that also reset any parameters to their factory values? Do I need to upload a new flash file to trigger it? Is there a way to perform this process from a running Tomato install?

    I've been running beta7 since March 5th and I'm still having difficulty getting non-N clients to connect reliably; wondering if there is a fuller reset I can perform.
  72. Posh

    Posh Addicted to LI Member

    If you are using 40Mhz Channel Width have you tried turning CTS Protection Mode to AUTO in the Advanced Wireless section? I believe and I could be wrong but in Mixed environments this is important to turn on when using 40Mhz Channel Width.
  73. cariyawa

    cariyawa Addicted to LI Member

    You mean.. Do you want to see a nvram dump of a different RT-16 to compare with yours?

    I believe YES.

    I don't think you need to upload a firmware to trigger it. Actually even if you upload, it won't be triggered automatically.

    Go to Administration->Configuration->Restore Default Configuration

    From that choose:Erase all data in NVRAM memory(thorough)

    People have different experience on this. But definitely thorough NVRAM erase will not harm you. If you have read the first post by T.B., it clearly says you must do a thorough NVRAM erase after flashing :biggrin:
  74. WilsonB

    WilsonB Addicted to LI Member

    Nah, though that would be fun.

    Totally; that's why I am making sure I have performed the steps teddy_bear is thinking of when he uses that phrase. Heh.

    I hadn't seen that NVRAM erase option under the admin menu. Thanks; that is what I was looking for. *facepalm*
  75. teddy_bear

    teddy_bear Network Guru Member

    Actually it's even newer - (the firmware is marked as "Beta" on the Asus web site though). The release notes mention a lot of fixes - hopefully this will resolve at least some of the weird problems people experienced.

    But it comes with a price - Broadcom built in the proprietary closed source conntrack module - another binary that we have no control over, and don't know what it's doing. Unfortunately the new driver requires it, so it can't be turned off. It might be ok though - but as with the wi-fi driver itself, it is impossible to address any issues without sources. The compiled firmware image comes out a bit smaller with the new driver, but it eats about 1MB+ extra RAM memory right after boot - not a concern for N16 with 128MB RAM but could be an issue if anyone runs it on 16MB, or even on 32MB routers. Some of the changes from this Broadcom reference set are already in this mod since beta05, but in beta07 I rolled back the other set of changes from the same SDK since it seemed to cause LAN-to-LAN speed to drop a bit...

    Anyway, I'll probably release the next update with this driver to see if it helps with anything. If not, I can always roll it back and wait for another version.
    If you don't know what it's for, you don't need it.
  76. bogderpirat

    bogderpirat Network Guru Member

    so i've done a bit of configuring and have my wnr3500l running tomato productively now.
    as the nat throughput (pppoe over a vlan-tagged interface over a VDSL modem) isn't the best (at around 5.2MByte/s, load is barely below 1.00, webif and ssh are sluggish), i've overclocked the box from 453mhz to first 532mhz (wouldn't boot, hard-reset fixed things) and now to 480mhz (running fine at the moment). with barely 50MBit/s of net speed over pppoe'd nat, those 480mhz don't look that strong compared to my old wrt54gl's 250mhz, which achieved almost the same speed.
    it seems like the performance has suffered a lot under the 2.6 kernel. has anyone else done nat speed tests with the wnr3500l?
  77. Elanzer

    Elanzer Addicted to LI Member

    Thorough NVRAM clear didn't help, same issue.

    I narrowed it down to using 40mhz channel width instead of 20mhz for wireless.

    I think I can chalk it up to an environment issue. My WRT54GL would do the same thing when using channel 1 or 11, only channel 6 would let all devices work correctly. With 6 and 40mhz width it must be straying into those frequencies that simply don't work for me.
  78. WilsonB

    WilsonB Addicted to LI Member

    This completely fixed it for me. Thank you!
  79. azdps

    azdps LI Guru Member

    if this actually fixes wireless problems some people are having maybe CTS Protection Mode should automatically be set to AUTO when 40mhz Channel Width is set.
  80. though

    though Network Guru Member

    what exactly is CTS Protection Mode in dumb people terms?
  81. Toastman

    Toastman Super Moderator Staff Member Member

    T/B - ref. this new wireless driver with built-in connection tracking module. Do we still have individual control of the conntrack expiry timing if this driver is used?
  82. mstombs

    mstombs Network Guru Member

    Is this related to the CONFIG_BCM_NAT flag? I don't currently see the closed source binary but I don't understand how anyone can make a change to the heart of netfilter without making it GPL. Binary blobs that are for specific proprietary hardware built as kernel modules is quite different

    BUT - do Broadcom see real performance limiting issues in the mainstream Linux 2.6 kernel that they feel the need to workaround? I've also come across this with Ti wireless drivers and Linux 2.4 kernel, they streamline the kernel code with a FAST_PATH flag and things like tcpdump no longer work, but the biggest issue is that the kernel version becomes locked.
  83. HKPolice

    HKPolice Network Guru Member

    Has anyone done speed tests with the RT-N16? What's the point of having such a fast CPU if the new kernel slows everything back down again? :(
  84. KyleChen

    KyleChen Addicted to LI Member

    1, Did you see him saying cpu only 1.00? my heavy test always push the cpu to about 7.00. His test didn't use much cpu, something else is slowing him down.

    2, Some early test showing overclock to 480MHz or anyother frequency will slow the router down. Only the stock settings can give it maximum shot. Related to some chips synchronize problem which is unknow so far.
  85. jnappert

    jnappert LI Guru Member

    I tried the MIPS32 R1 Release within my WDS-Cloud using WRT54GLs and WPA(AES)-encryption. The routers start fine and establish WDS-Links - but only with one other AP at one time.

    The APs that stands in the middle between two other WDS-APs, cant connect to second WDS-AP when its already connected to the first. So i can use the mod only with end-nodes.
  86. shibby20

    shibby20 Network Guru Member

    quick question:
    I have tplink router with openwrt and samba3

    now, how can i mount this share to tomato? (tplink-, tomato-
  87. shibby20

    shibby20 Network Guru Member

    i found :)
    solution: mount -t cifs \\\\\\dane /cifs1 -o username=root
  88. bogderpirat

    bogderpirat Network Guru Member

    i can't confirm these findings. i've never seen a cpu load above ~1.30 on any of the tomato routers i've worked with and the increase from 453 to 480 mhz hasn't but at best increased performance. using top, sirq load is up in the high 90%s. the router is definitely at its maximum.
  89. Catalin

    Catalin Addicted to LI Member

    What sort of internet bandwidth do you have? On a 100Mbps bandwidth form my ISP I get CPU loads higher than 2 on p2p transfers at ~9 MB/s both upload and download at the same time...
  90. WilsonB

    WilsonB Addicted to LI Member

    802.11 lets strong or badly-behaved clients starve everything else of their chance to talk to the access point. Here is my understanding of how CTS ('clear to send') works:
    With CTS enabled, before attempting to talk to the access point, clients send an RTS ('request to send') message. The access point chooses one to respond to with a CTS message. That client then gets to talk to the access point until it is done, at which point the AP picks up the next 'RTS' message and goes through the process again.

    My guess is that high-speed 802.11n traffic looks a whole lot like "badly behaved" to an 802.11g/b client talking to the same access point.
    The drawback of CTS is the overhead it introduces into the process; no idea how much it slows down networks in actual practice. Hugely reduces error rates due to simultaneous requests though.
  91. teddy_bear

    teddy_bear Network Guru Member

    Well, Broadcom can... It's related to CONFIG_BCM_CTF kernel configuration setting, the binary module src-rt/ctf/linux/ctf.o (it's now required by the wireless driver), and the HNDCTF defines throughout the kernel sources. And yes, the new bcm_nat module is there as well - but at least that one is distributed with sources.
    Exactly :mad: ! It actually was a problem already - that's why we're not upgrading from 2.6.22 to a newer kernel so far. The wifi driver is relying on some base kernel structures (like skbuff etc) that have been changed masively in later kernel versions. Although it might be possible to patch the new kernels to be backward compatible with what the driver expects, it's a very complex task, and it could cause hard to solve, or even impossible to solve conflicts. Of course, the introduction of another binary module in the netfilter doesn't help with this...
  92. mschulze

    mschulze Addicted to LI Member

    I cleared nvram and reconfigured, but still there are wireless disconnects, now at least once per day. I checked the logs and found a funny error message right when the disconnect started:

    Mar 11 10:30:43 router cron.err crond[402]: time disparity of 21138750 minutes detected
  93. bogderpirat

    bogderpirat Network Guru Member

    i'm on a 50mbit/10mbit vdsl connection. this requires outgoing vlan tagging as well as a pppoe connection. i assume those two eat up a bit of cpu time. at least i try to explain it to myself like that, as i can't explain why a dhcp connection (which i assume is what you have) is that much faster at four times the network load.

    i'm not annoyed as much by the fact that i don't get stable speeds at low load, but rather at the fact that even the 5 year old wrt54gl could do better (again: it was also maxed, but had a much more responsive webif as compared to the wnr).
  94. teddy_bear

    teddy_bear Network Guru Member

    That doesn't look right - it means something else is going on... The router time gets reset to "zero date" and then resynchronized again with ntp server. But the only time the date should be "zero" is at startup - you only should see this message in the log once, right after reboot. As far as I know the date should never get back to "zero" again during the normal opearation.
  95. though

    though Network Guru Member

    this was with cts enabled also????
  96. mschulze

    mschulze Addicted to LI Member

    it was disabled, but I just enabled it to see what happens. anything else I could try?
  97. though

    though Network Guru Member

    just that for the time being... do you have mixed clients that connect to it?? B/G/etc....
  98. ACE 256

    ACE 256 Addicted to LI Member

    I think you answered my question. I was wondering if its possible to transmit at 270~300 and receive at a slower rate. I have seen it done in 802.11g but I'm not sure how.
  99. maurer

    maurer Network Guru Member

    new TB build - no 40 Mhz link


    I've just installed latest TB's build tomato-K26USB-1.27.9044MIPSR2-beta08-TEST.trx and I've noticed that my AR5008 client cannot connect anymore with a 40 Mhz channel.
    I mention that I've used only default settings on router and client.
    I've also tried setting CTS to auto with no result.
    What are you suggesting next ?
  100. maurer

    maurer Network Guru Member

    new build and 40 Mhz channel

    Got it!!!
    Had to switch from Japan to Europe.
    now i have 40 Mhz Channel and 300 Mbps link.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice