Tomato ND USB Mod

Discussion in 'Tomato Firmware' started by teddy_bear, Dec 17, 2008.

  1. pharma

    pharma Network Guru Member


    I'm currently testing the Lite Build44 of your excellent mod. I have a question regarding the miniupnd cleanup option.

    Should Cleaning Threshold be set to 0 if we want unused, useless rules to be removed quickly and efficiently? The threshold number we choose has to be reached before any useless rules are removed. Is this correct? With the default setting of 20 I tend to see rules left over from the previous days sessions.

    Thanks again for your very nice Tomato mods.

  2. ray123

    ray123 LI Guru Member

    You shouldn't really be doing disk configurationing on the router. This really needs to be done on a real Linux system. If you don't have such readily available, you can download and boot any of the Linux live CDs---Knoppix, Ubuntu, etc.
    Or, if you have an optware package set up on your router, you could install the opt disk utilities into opt and then use those.

    The fact that things like mkfs, fdisk, etc. work on the router at all is an interesting tidbit-----but I'd never trust them. As Teddy Bear said, they are old old kludge version build into Busybox.
  3. noabody

    noabody Addicted to LI Member

    I searched this forum for PS2, 445, 139 as I was looking to see about streaming games across the network with wl-520gu attached NAS, Latest ND USB STD, a connected Playstation 2 Slim, and Maxtor 500Gig self powered HD.

    From my posts on the PS2 forums for OpenPS2Loader or OPL, I found that program expects Server Message Block (SMB) on port 445. I noticed that Tomato shares on Samba ports 137, 138, and 139 (session service) but can connect to a Windows CIFS.

    I was curious if there is a way to configure smbd/nmbd daemon with SMB over port 445 rather than the Samba standard 137, 138, 139. Does Samba 2.0.10 have that support? I can see the NAS from properly configured Windows and Linux clients on port 139. The PS2 has a media program SMS that also supports Samba which I have yet to test. I can telnet into the PS2 so it's network configuration is good. The wl-520gu is setup in client-bridge mode which really has no effect on this issue but I thought it was worth mentioning.

    This appears to be a client software access issue but I thought I check this forum for suggestions.
  4. phdeez

    phdeez Addicted to LI Member

    root@520gu:/tmp/home/root# smbd -?
    Usage: smbd [-DaoPh?V] [-d debuglevel] [-l log basename] [-p port]
           [-O socket options] [-s services file]
            -D                    Become a daemon
            -a                    Append to log file (default)
            -o                    Overwrite log file, don't append
            -P                    Passive only
            -h                    Print usage
            -?                    Print usage
            -V                    Print version
            -d debuglevel         Set the debuglevel
            -l log basename.      Basename for log/debug files
            -p port               Listen on the specified port
            -O socket options     Socket options
            -s services file.     Filename of services file
    looks like smbd -D -p 445 will do it. Good luck!

    You can probably throw -p 445 into the "Samba Custom Configuration" box under "File Sharing"
  5. Rasky

    Rasky Addicted to LI Member

    What is the correct way to upgrade a router within a ssh session? I've reverse-engineeered the following, but I would like a confirmation:

    service upgrade-start
    mtd-write -i fwimage.trx -d linux

    Is this correct?
  6. teddy_bear

    teddy_bear Network Guru Member

    Almost, except no dash in "service" command:
    service upgrade start
    mtd-write -i fwimage.trx -d linux
  7. alexlau

    alexlau LI Guru Member

    oh, BTW, does this mod has the IP/MAC bandwidth limitation setting as of Victek's mod? It's kind of useful when sharing network with a group of people...
  8. noabody

    noabody Addicted to LI Member

    Thanks for the reply phdeez. Now I have another question. I checked the forums extensively but oddly didn't find the answer to this. I can edit /etc/smb.conf /etc/passwd but those changes aren't persistent. It looks like I can use "nvram setfile2nvram <filename>" but I don't think that is meant for system files. It may be as simple as "nvram commit". Flashfs save/commit/enable doesn't appear to be applicable.

    So how do I make edits to system files persistent in Tomato firmware?
  9. ray123

    ray123 LI Guru Member

    No, it's exactly meant for system files. Didn't you find any of the posts where I said I use this for my /etc/fstab?
  10. noabody

    noabody Addicted to LI Member

    Thanks ray123. I guess it's all in the way you search. I was using keywords like save, edit, /etc, system, persistent. I got "nvram setfile2nvram <filename>", "nvram commit" from somewhere but I also got the impression that "nvram show |grep -i /etc" would show a list of system files stored in this manner.

    Since changes to /etc/smb.conf can be accomplished through the GUI, I expected to find reference to it with "nvram show". It made me think there was another method for making the changes persistent. Maybe I over-thought the issue.

    Believe me, I hate to waste people's time especially when a good thoughtful search usually provides the expected information.

    So for my situation, after making edits to /etc/smb.conf and /etc/passwd:
    nvram setfile2nvram /etc/passwd
    nvram setfile2nvram /etc/smb.conf
    nvram commit

    Thanks again.
  11. teddy_bear

    teddy_bear Network Guru Member

    Some system files - and that includes smb.conf and passwd - will be overwritted by the firmware every time corresponding services are restarted, so even if you save them to nvram, your changes will be lost. That's why for samba config the box is provided in the GUI where you can specify your extra settings.

    If that's not enough, and you want to completely change the config file by your own version, you'll have to disable Samba in GUI, and manually start it. When Samba is disabled in GUI, it won't overwrite the config files. Of course, in that case you'll loose all the nice build-in features, like auto-sharing of USB partitions, and will have to do it all yourself. By the way, this is exactly the same with the Oleg's firmware you're used to (based on the references to flashfs) - the files like smb.conf are recreated on samba restarts, and the only way to preserve them in flashfs is to handle the corresponding services manually.

    The similar situation is with passwd. Except there's nothing you can "disable" in the GUI to perevent it from overwriting this file - it will be recreated every time the LAN is started. To make - and preserve - the changes to this file, you'll have to modify file in the script - possibly WanUp script, as it runs after LAN and WAN are started.
  12. beatnitup

    beatnitup Addicted to LI Member

    NAS + USB xfer speeds.

    I've searched this thread numerous times in search of an answer to what seems to be a popular question.

    "How Do I speed up the USB throughput?"

    I've enabled WAN port for LAN...I'm only getting 850KB/s over LAN via SAMBA and thats with the latest Tomato Teddy bear NAS+VPN mod. USB 2.0 is enabled and i'm using a external powered NTFS formated USB 2.0 Hard drive

    The router is being utilized strictly as NAS. The AP radio's have been turned off, as well as the majority of the default services. This transfer rate is acceptable for Divx/Xvid etc but way too slow for Blu-Ray.

    Am I overlooking something?
    Any advice would be most appreciated.
  13. Rasky

    Rasky Addicted to LI Member

    NTFS implementation is really slow (and it's the only available for Linux). You should try using ext3 or even ext2 for higher speeds.
  14. beatnitup

    beatnitup Addicted to LI Member

    Rasky: Thanks for the quick response, which file system would yield a higher transfer rate ext3 or ext2? Any recommendations on the fastest way of doing this?
  15. uf20wop

    uf20wop Addicted to LI Member

    has anyone been able to use the scanner function of a multi function printer with this tomato mod?

    i'm trying to figure it out but i can't find a tutorial anywhere

    edit: just searched, seems like its possible, i guess i found my answer
  16. ray123

    ray123 LI Guru Member

    Theoretically, for reading, ext3 & 2 should be the same. Ext3 is just ext2 with journalling. Writing ext3 will be slower due to the extra writes, but journalling doesn't come into play for reading.
    Are you using a USB hub? Be aware that some hubs are USB1.1---especially old ones and cheap China ones (even some that claim to be USB2). That'll really be slow.

    I did some measurements on my system, using dd and hdparm. Disk to router only. USB 2.0 devices read speed was 4.5 MB/s to 7.6 MB/s. A usb 1.1 device was only 740 kB/s.

    Going over the LAN will be slower. I don't know how much of a bottleneck that is.

    Just ran a test, reading a 370MB file, FAT, using dd. Asus WL-520GU
    On the router itself, 6.5 MB/s
    On a Windows machine across the lan, 1.6 MB/s
    On the Windows machine itself, 23.4 MB/s
    On the router across the lan from the Windows machine, 1.4 MB/s

    On a windows machine from another windows machine, 1GB lan, 2.1 MB/s.

    So, serving a file from the router on a 100MB lan is almost as fast as serving it from a Windows box on a 1GB lan.
  17. beatnitup

    beatnitup Addicted to LI Member

    Thanks Ray123 for taking the time to run some benchmarks and answering my questions. I'm not using a USB Hub.

    What options/parameters did you use with dd and hdparm?
    I tried hdparm -T /dev/hda via webgui and received: /tmp/.wxVQ1EtC: line 5: hdparm: not found"
    I fear that my hard drive is only negotiating connecting usb 1.1 rather than 2.0. Any ways I can verify this from shell? I plan on converting to ext2 once i finish backing up the data. Thanks again for all the assistance.
  18. ray123

    ray123 LI Guru Member

    I have optware installed on my router and use the "dd" from it. The built-in dd doesn't compute the bps speed. I just did "dd if=/mnt/whatever of=/dev/null bs=16k"

    If you HD is USB2, it will use USB2 unless it's broken.

    It's easy to check. On the router, Use dd or somthing to read a file (50MB or more) from the drive and time it. Then unload the usb2 driver. "rmmod ehci-hcd". This will unmount & remount the drives. And use USB1.1 only. Repeat the dd. You should see it be much slower. Then "insmod ehci-hcd".

    USB1.1 devices will be about 740 kb/s. USB 2 will be about 5 MB/s

    cat /proc/uptime ; dd if=whatever .... ; cat /proc/uptime. The 1st number is the uptime in seconds. Obviously, the diffrence between these will be the elapsed time.
  19. Oreo1982

    Oreo1982 Addicted to LI Member

    Teddy Bear, your new build 44 is fantastic! Seems to have better memory usage too. Keep up the good work. :D
  20. Labrat407

    Labrat407 Addicted to LI Member

    WL-520GU newly flashed

    Hello, I am new on here and just wanted to check in. I just flashed my WL-520Gu using the ASUS Flash utility and the and trick mentioned in the comment section of the Easy Guide, it worked like a charm as I had some trouble connecting to the router when I tried the router first flashed to dd-wrt.

  21. cadteach

    cadteach Addicted to LI Member

    Trying to install Optware. After I telnet into the router, which is set to wireless ethernet bridge mode, I get this when I try to ping.

    ping: bad port spec ''

    I can connect to the internet from my PC hooked up to the router. Possible that I have a firewall on the original modem/router from SBC that could be causing the problem (I know it has a firewall on it, and I'm not sure how to disable it, it only lets me adjust some settings.

    Edit: Nevermind, I didn't have the gateway specified.
  22. Labrat407

    Labrat407 Addicted to LI Member

    Got my printer Working

    This build is great, just installed my printer and shared it on 2 PC's.
  23. melcug

    melcug Addicted to LI Member

    clock problem on Asus WL-520GU

    The latest build (44) is running without problems, but I am still confused about cpu speed. The output for the command "cat /proc/cpuinfo" used in Tools/System is:

    system type		: Broadcom BCM5354 chip rev 3 pkg 0 
    processor		: 0 
    cpu model		: BCM3302 V2.9 
    BogoMIPS		: 197.83 
    wait instruction	: no 
    microsecond timers	: yes 
    tlb_entries		: 32 
    extra interrupt vector	: no 
    hardware watchpoint	: no 
    ASEs implemented	: mips16 
    VCED exceptions		: not available 
    VCEI exceptions		: not available 
    unaligned_instructions	: 9 
    dcache hits		: 0 
    dcache misses		: 0 
    icache hits		: 0 
    icache misses		: 0 
    instructions		: 0 
    I expected to see a value close to 240 on Bogomips, in accordance with the above statement from ChangeLog.
  24. glenb1

    glenb1 Network Guru Member

    same router, same issue here. other than that firmware performs great.
  25. phdeez

    phdeez Addicted to LI Member

    This is a well documented problem on the 520gu and any third party firmware.
  26. glenb1

    glenb1 Network Guru Member

    the nvram variable has the correct speed; would it make sense to set that variable to overclock by 40mhz more, to try to arrive at the correct speed ?. on one of my old wrt54g routers, overclocking it causes the router to seize and it takes some doing to reflash it to recover, so i have been hesitant to try that on this unit. any ideas ?
  27. teddy_bear

    teddy_bear Network Guru Member

    Guys, stop speculating. As phdeez mentioned, this is well documented - and it's not a "problem". Learn how to use search, and read.
  28. quackdealer

    quackdealer Addicted to LI Member

    "Sent to Printer" but Not Printing

    I just got my Asus WL-520GU set up with with the standard mod and it's working great. However, I'm having trouble with my printer. It's a Dell AIO 926. I was able to use the directions in the first post of the thread about setting up the printer in windows, without any issues. And I see that Tomato is recognizing the printer (under "USB Support" under "USB and NAS") as an attached device.

    The problem is that when I try to print, everything looks normal on the windows end, but the printer never receives any data. When I pull up the queue for the printer, it lists the status of the documents as "Sent to Printer".

    I've heard some not so great things about Dell printers in the past (especially with Linux) but wasn't sure if that would be the cause, or if I'm just missing something. Thanks for any help you can give, and sorry if I missed the answer to this question elsewhere in the thread.
  29. llllllllllll

    llllllllllll Addicted to LI Member

    Hi, Guys,

    I used the easy method to flash the firmware to tomato-1.27-NDUSB-8744-Std.rar, it went successfully, then I went to erase all settings in nvram. Everything seemed to have worked just fine, however my router don't seem to get an IP address from my cable modem, in the status page, it always shows as "renewing". I was able to restore back to the firmware and router was able to get an IP address from my cable modem. What did I do wrong? can anybody point me to the right direction? Any help would be greatly appreciated!

    1. Go to ASUS website & download firmware version (WL520gu_2.0.0.8_EN.trx.
    2. Download Tomato with USB support (ver 1.25 with USB). You will most likely need to get/use a RAR unzip program to open the file. After decompressing go to File Manager and rename the uncompressed Tomato file to: WL520gu_2.0.0.9_EN.trx.
    3. Plug in the router's A/C adapter and an ethernet wire from port 1 of the router to your computer. If using a laptop or wireless pc turn off the wireless before doing this.
    4. Start IE and go Login and passwords are admin.
    5. Once you are in the ASUS firmware click on ADMIN, FIRMWARE UPGRADE, BROWSE and then browse to where you downloaded and uncompressed the file in step 1. Then click on UPGRADE FIRMWARE. (Yes, you are going back in time firmware wise but it’s only for 6 mins.
  30. teddy_bear

    teddy_bear Network Guru Member

    Power-cycle the cable modem after erasing nvram in Tomato.
  31. Rasky

    Rasky Addicted to LI Member

    RAM upgrade

    Hi, I'm going to try upgrade RAM of my WL500GP to 128Mb, using this guide:

    I would like to double-check that if the commands specified in that guide (NVRAM sdram configuration) will work correctly also for Tomato USB. Teddy_Bear, can you confirm that they should work?

    What if I upgraded the firmware to the 2.6-based beta before (or after) the memory upgrade? Would those configurations still work?

  32. Cool_Zero

    Cool_Zero Addicted to LI Member

    Network Shares

    When I use the Automount feature in USB Support page on Webgui, all of my directories in /dev/discs/disc0/part3 which is mounted on /tmp/mnt showed
    in my Network Shares of Windows system when I try to access the router thru
    windows explorer (My Network Places).

    But when I use the Hotplug script feature in USB Support page on Webgui,
    the only that I configured in Samba File Sharing on Network Shares List
    are only directories showed.

    any idea? that's why I stick on Hotplug script.

    Tomato Firmware v1.27.8744 ND USB Ext
    WL520GU with USB Hardisk
    /dev/discs/disc0/part1 on /opt
    /dev/discs/disc0/part2 on swap
    /dev/discs/disc0/part3 on /tmp/mnt
  33. llllllllllll

    llllllllllll Addicted to LI Member

    Hi, Thank you very much for your reply! I brought my router to work today and re-flashed it, it shows the same "Renewing...." message, then I power-cycled it, still shows "renewing...", then I power it off, waited for more than 2 minutes, power it back on, still shows "renewing...". what else can I try? Thanks!

  34. teddy_bear

    teddy_bear Network Guru Member

    I suppose the sdram settings are the same between these firmwares, including the kernel 2.6 builds. But I can't test myself as I don't have wl500gp.
    Did you read what I said? Power-cycle the modem, not the router!
  35. Rasky

    Rasky Addicted to LI Member

    What should I do to test that the sdram settings are the same between tomato and oleg's firmware, before doing the RAM upgrade?
  36. teddy_bear

    teddy_bear Network Guru Member

    Can't help you with that - they should be the same but I am not taking responsibility for saying they are ;).
    I do know though that people use this mod with routers upgraded to 128 MB - you can probably find some reports regarding it on this thread.
  37. llllllllllll

    llllllllllll Addicted to LI Member

    Sorry, I didn't say it clear. I didn't bring the modem to work, I just plugged the router directly into one of the network jack on the wall. Just for testing purpose to make sure my router doesn't have any problem, I flashed it to dd-wrt.v24_mini_asus.trx and it picked up an ip from the network jack on the wall and worked. But I do want to flashed it to your modified tomato, I have tried it multiple times with no success and ran out of ideas. I am still puzzled what I did wrong coz it worked for other people. Any other suggestions? Thanks for your time!

    Did you read what I said? Power-cycle the modem, not the router![/QUOTE]
  38. uscallesen

    uscallesen Addicted to LI Member

    Just wanted to to make a short reply - to thank teddy_bear for this awesome firmware. I really hope you'll continue with the development. I flashed my Netgear WNR3500L with the 1.27 ND STD Beta7 release today and I'm loooving it !
  39. myersw

    myersw Network Guru Member

    Click on the donation button and really show him how much you like it. Link is on first page. --bill
  40. CsBubo

    CsBubo Addicted to LI Member

    Hi, You can use the mentioned variables, They just work fine.
    I'm using Teddy Bear's mod with a modded wl-500gp V1 for more then a year now.
    I used the mentioned page as reference.

    when You restarted the router and You see 128mb, You can also do
    nvram set sdram_ncdl=0
    which will make the router finetune the settings on the next reboot.

    Hope this helps.
  41. Rasky

    Rasky Addicted to LI Member

    Thanks! Out of curiosity, what memory modules are you using? I have several PC memory sticks around but obviously none of them match the four reported in that page (I suppose there are hundreds of them, so the odds are against me).

    What you mean "finetune the settings"?
  42. teddy_bear

    teddy_bear Network Guru Member

    Have you solved the issue? Normally all you need to do after flashing Tomato is reset settings to defaults (do "thorough" NVRAM erase via GUI, or push and hold the "Restore" button on the back - not the EZ Setup button - for longer than 3 secs), and then, after Tomato restarts, power cycle the modem.

    If you still can't get WAN IP after that, you can try to modify the "Reduce packet size" setting on the "Advanced - DHCP/DNS" page (assuming you have DHCP connection).
  43. Tim2k

    Tim2k Addicted to LI Member

    I want to make my WRT54GS (no USB) act as a masterbrowser ( speeds up networksharelisting a lot) with samba, i flashed the tomato-ND-8744.trx (NoUSB) but i can't find Samba anywhere.

    root@safehouse:/# find -name *smb*
    root@safehouse:/# find -name *samba*
    I guess Samba is not included in the NoUSB-version, right? I tried to flash tomato-NDUSB-8744-Std.trx (Standard) and tomato-NDUSB-8744-vpn3.6.trx (VPN), but that doesn't work, after choosing the trx the flash-counter counts down to about 5 or 6 and then the webinterface changes to a white page.

    Any way to get Samba to run on my router? :)
  44. teddy_bear

    teddy_bear Network Guru Member

    If your router can run standard non-USB ND firmware, it should be able to run any other editions. Try flashing it again - I see no reason for it not to work. Erase nvram if you keep having problems flashing.
  45. Tim2k

    Tim2k Addicted to LI Member

    Thank you teddy_bear, erasing nvram made it possible to flash the standard-version! :thumbup:
    My WRT54GS is now the masterbrowser in our network, hooray! :)
  46. Papka__

    Papka__ LI Guru Member


    Yesterday install tomato-1.27-NDUSB-9044MIPSR2-beta07-vpn3.6.rar on my new RT-N16. Overall all works, but my torrent client on DUNE do not upload at all. Download - ok. Ports on router is forwarded (checked). Previously with WRT54G and Tomato with the same ports all was working fine. Any ideas?

    Magic words CLEAR NVRAM can help?
  47. Rasky

    Rasky Addicted to LI Member

    Make sure you tick both "Master Browser" and "WINS Server" in the "File sharing" page, and leave the manual WINS configuration empty ("") in the Basic Network page.

    This way, not only tomato will act as masterbrowser, but it will also be assigned as the WINS server by DHCP (you can check this by running ipconfig /all on the client machines after you connect/disconnect them; they should display something like "WINS:").
  48. nitr8

    nitr8 Network Guru Member

    Hi All,

    I am wandering if someone can shed some light here.

    Clean Router - WNR3500L
    I installed DD-WRT for WNR3500L v24 K2.6 Mini 13972 BETA (CHK) reset defaults

    Clean NVRAM

    Now this was working great, but had issues with n to I wanted to see if DD-WRT had the same issues. USB working 100%

    Flashed this as tomato wanted a bin,
    DD-WRT for WNR3500L v24 K2.6 BIG 13972 BETA (BIN)
    30/30/30 reset

    I did not try USB, just testing wifi. I did not like the clunkyness of DD-WRT, which I was used to before I had found tomato ;) so I decided best thing was go back to tomato.

    Clean NVRAM

    But now everything is working 100% besides picking up the USB stick. When I insert a new stick, tried 5 different ones, including the one that was working but it does not detect the disk. dmesg shows nothing when i insert the disk. Could any one shed some light here please?
  49. CsBubo

    CsBubo Addicted to LI Member

    I've used Samsung chips mentioned on the page, and Elpida as well. All from notebook 512MB modules. As it is stated there, the chips should be organized 32Mx16. This is the important part. I was looking at several candidates of desktop ram modules, hardly found a few to meet this criteria. None of them were available.
    If You have several, You'll have to look up all the related datasheets for the chips and compare.
    For the parameter, it is said, the memory controller will be forced to check and store the best internal timings to be used together with Your newly installed chips. So once You set it to 0, during next reboot, the value will receive the "tuned" setting.
    Hope this helps!
  50. llllllllllll

    llllllllllll Addicted to LI Member

    not yet. I am going to try "reduce packet size" tonight when I get home. BTW, my router is the Asus WL-520GU. Anyone has this same router and not having any issue with flashing to tomato?

    Thanks for all your help!

  51. teddy_bear

    teddy_bear Network Guru Member

    Port forwarding works fine for me. How exactly did you check it? Post the output of the following commands:
    iptables -L -n
    cat /etc/iptables
    You didn't cleat the NVRAM after flashing?? If you didn't, then of course - do this first, before trying anything else.
  52. teddy_bear

    teddy_bear Network Guru Member

    How did you clear the NVRAM? Try it again - via GUI - Administration->Configuration->Restore Default Configuration, choose "Erase all data in NVRAM memory (thorough)". And possibly power-cycle the router if USB still not working after that...
    WNR3500L requires certain boardflags to be set correctly to control USB power - maybe something is getting messed up there - but thorough nvram erase should get it fixed.
  53. nitr8

    nitr8 Network Guru Member

    teddy_bear, top man thanks. I had cleared NVRAM loads of times via the UI, just did it again nothing, but the power-cycle did the trick.... now im back in action. dam I love your work, thanks for all the effort :)
  54. genjuro

    genjuro Addicted to LI Member

    CPU Load

    Hi all :)

    I just i have some questions, i regularly watch the CPU load of my WL500GP, because i OC it to 300/150 Mhz and it started to heat a lot, i solved the problem by adding some heatsinks and a fan, and i see this:

    CPU Load (1 / 5 / 15 mins) 0.18 / 0.20 / 0.73

    I understand the part of the 1 / 5 / 15 mins, the thing that i don't understand is the metric of the CPU usage, 0.18 is 18% of the CPU? or 0,18% of the CPU? or the scale is different, since sometimes it gets up to 3.77 of usage when it's checking the torrent files...

    Thank you all in advance... :)
  55. quackdealer

    quackdealer Addicted to LI Member

    Any ideas with this? Thanks!

  56. Papka__

    Papka__ LI Guru Member

    Thanks for reply. About port forwarding - after 12-15 hours of no upload all start working normally. Without router/torrent client reboot. Weird.
    Will try to clear NVRAM today. Just forget to do that after flashing. :)
    Yesterday in the evening (~24 hour router was up) it was not possible to use wireless connection. My laptop wireless show connected for 1 minute and then disconnects. Try to change some settings (fixed channel, only G mode) - nothing. Result the same. Only router restart resolve problem. Wireless connection have no encryption and use only mac filter. May be NVRAM clearing will resole this issue? Will try.
  57. jinx

    jinx Addicted to LI Member

    IIRC you can think of the decimal portion of the CPU load as percentage, so in the case of a CPU load of "0.18" your overall CPU load is 18% with no single process allocating 100% of the CPU. However, in the case of a CPU load of "3.77", that means that there are three processes attempting to use 100% of the CPU with a remainder of 0.77 (or 77%) CPU load allocation in the system.
  58. genjuro

    genjuro Addicted to LI Member

    Thanks jinx for your answer :), now i get it! :thumbup:
  59. genjuro

    genjuro Addicted to LI Member

    Transmission high memory usage!

    It's me again!! With another noob question :)

    I use Optware and transmission (web GUI), i read a lot in the web that it has a "small memory footprint", but every time i start transmission it uses all the available RAM (12-14 Mb), is that normal? Is there a way to limit the memory usage or to force transmission to swap?

    Here is my ps output:

    1 root 1024 S /sbin/init noinitrd
    2 root 0 SW [keventd]
    3 root 0 RWN [ksoftirqd_CPU0]
    4 root 0 SW [kswapd]
    5 root 0 SW [bdflush]
    6 root 0 SW [kupdated]
    7 root 0 SW [mtdblockd]
    26 root 984 S buttons
    28 root 1448 S syslogd -L -s 50
    30 root 1444 S klogd
    42 root 0 SW [khubd]
    91 root 1016 S nas /etc/nas.conf /var/run/ lan
    93 root 928 S dropbear -p 22
    99 root 1468 S crond -l 9
    103 root 768 S rstats
    107 root 0 SW [usb-storage-0]
    109 root 0 SW [scsi_eh_0]
    110 root 1088 S httpd -s
    126 root 1528 S nmbd -D
    128 root 1488 S nmbd -D
    134 root 1756 S smbd -D
    143 root 0 SW [usb-storage-1]
    144 root 0 SW [scsi_eh_1]
    168 root 0 SW [kjournald]
    322 root 1460 S udhcpc -i vlan1 -s dhcpc-event -H TSRT01 -m -S
    402 root 0 SW [kjournald]
    522 nobody 2568 S dnsmasq --conf-file=/tmp/gen
    1034 root 14184 S N /opt/bin/transmission-daemon -g /opt/share/transmissi
    1035 root 14184 S N /opt/bin/transmission-daemon -g /opt/share/transmissi
    1036 root 14184 R N /opt/bin/transmission-daemon -g /opt/share/transmissi
    3608 root 1108 S httpd -s
    3609 root 1452 S sh -c /tmp/.wxgOCnul >/tmp/.wobtgTOT 2>&1
    3610 root 1456 S /bin/sh /tmp/.wxgOCnul
    3614 root 1452 R ps


    total used free shared buffers
    Mem: 30644 29900 744 0 2260
    Swap: 95656 1116 94540
    Total: 126300 31016 95284

  60. ray123

    ray123 LI Guru Member

    Transmission will swap along with everything else----accordng to how the kernel feels like doing the swapping. Rememeber, you've only got 16MB of real memory. That's not a whole lot---just barely enough to run Linux.

    Being able to run an application of these routers is a bonus. They are like a dancing bear: The wonder is not that it dances so well; the wonder is that it dances at all.

    I've found that I need to kill and restart transmission once a day in order to keep it from locking up. I just set up my script to do this. Someday I'll get around to posting it. ;-(
  61. Rasky

    Rasky Addicted to LI Member

    Out of socket memory

    Hi, my router shows this message lots of times in the dmesg:

    Out of socket memory

    Do you know what it is? Is it a problem or should I ignore it?

    root@tomato:/tmp/mnt# free
                  total         used         free       shared      buffers
      Mem:        30644        30056          588            0         1040
     Swap:       104420        40304        64116
    Total:       135064        70360        64704
  62. ray123

    ray123 LI Guru Member

    At a guess......I/O buffers must be in RAM. Obviously--you can't do I/O from memory that's swapped out to disk.

    It looks like you have 32MB of RAM and a 100+(?)MB of swap. And you're using 40+MB of total memory--32 RAM and another 10 swapped out. I would say you're overcommitted on RAM. What else do you have running and consuming memory?
  63. llllllllllll

    llllllllllll Addicted to LI Member

    This issue is now resolved. I checked "Reduce packet size" and some other settings, then saved it. then powered off my cable modem, waited for over 3 minutes, powered it back on, then powered router on, my router finally got an IP from my modem. I then unchecked "reduce packet size" and rebooted my router, it got the same IP again. so I don't know what suddenly made it to work :) Thank you Teddy_bear! Now any guide for setting up a print server on the usb port?

  64. melcug

    melcug Addicted to LI Member

    My PPPoE connection is unstable on latest version (44). Torrents, Rapidshare or similar services make my router WL520GU to close the connection. I returned to version 42, with the same configuration and the problem disappeared.
  65. teddy_bear

    teddy_bear Network Guru Member

    Yep, the build 44 includes some experimental port of PPPoE "improvement" from newer Linksys GPL code. Apparently, it's causing issues to some people, so I reverted it, and it won't be in the next build.
  66. EricCartman

    EricCartman LI Guru Member

    teddy are you going to build next build for ASUS RT-N16 ???
  67. viniciusferrao

    viniciusferrao Addicted to LI Member

    Teddy, I'm trying to install your version of Tomato in my DIR-320 but I haven't find any documentation about installing Tomato in DIR-320.

    I'm already running DD-WRT v24sp2 latest build and tried to update to Tomato through web interface. But I got: "Upgrade failed".

    Don't know what to do. I've downloaded the VPN Edition. Any ideias of what's is happening here?
  68. teddy_bear

    teddy_bear Network Guru Member

    Uhmm... Didn't I do already :rolleyes:??
    Have you extracted the Tomato .trx from the rar-archive, and then renamed it to *.bin before flashing?
  69. viniciusferrao

    viniciusferrao Addicted to LI Member

    Yes of course!

    Extracted into ChangeLog.txt and the firmware .trx

    Renamed to .bin and failed. Tried with .trx and failed too!
  70. teddy_bear

    teddy_bear Network Guru Member

    Then I don't know why the dd-wrt upgrader fails. Maybe someone with DIR-320 who already flashed this mod can shed some light onto how they did it.
  71. gmc888

    gmc888 Addicted to LI Member

    I can not install tomato-8744.

    after lace trim dir320 does not answer
  72. gmc888

    gmc888 Addicted to LI Member

    where take tomato 8742?
  73. gmc888

    gmc888 Addicted to LI Member

    has not found the references where take tomato 8742.
  74. llllllllllll

    llllllllllll Addicted to LI Member

    not printing

    Hi, I tried to setup my printer on the USB port. Here is what I did:

    inside tomato, under "USB Support", I checked every box, saved the changes, then connected my printer to the usb port, and tomato showed my HP laserjet p1005 printer under "Attached Devices". Then on my xp laptop, I added a printer according to this page:

    Everything seemed to go through just fine. However, when I tried to print the test page, nothing printed out, in print queue, the status shows "Error - Printing". anything I missed? Any suggestion to fix this? TIA!
  75. viniciusferrao

    viniciusferrao Addicted to LI Member

    I haven't understood your posting. Do you have a DIR-320 too and cannot install it in your router?

  76. llllllllllll

    llllllllllll Addicted to LI Member

    It's very odd, sometimes after I power off then power on the printer, I can print successfully, then sometimes after I power off then power on the printer again, it stops to print, even though /var/log/meesgages shows it finished the print job, as follows:

    Mar 14 21:59:03 unknown kernel: hub.c: new USB device 00:03.1-1, assigned address 8
    Mar 14 21:59:04 unknown kernel: printer.c: usblp0: USB Bidirectional printer dev 8 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3D17
    Mar 14 21:59:04 unknown kernel: printer.c: usblp0 Device ID string [86]='MFG:Hewlett-Packard;MDL:HP LaserJet P1005;CMD:ACL;CLS:pRINTER;DES:HP LaserJet P1005;'
    Mar 14 21:59:04 unknown user.debug hotplug[588]: Attached USB device /proc/bus/usb/001/008 [INTERFACE=7/1/2 PRODUCT=3f0/3d17/100]
    Mar 14 21:59:14 unknown lpr.notice p9100d[412]: Connection from port 1054 accepted
    Mar 14 21:59:16 unknown lpr.notice p9100d[412]: Finished job: 755 bytes received
    Mar 14 22:00:01 unknown root: -- MARK --

    Teddy, can you shed some light? :) Thanks!

  77. teddy_bear

    teddy_bear Network Guru Member

    Ran across a few guides about flashing DIR-320 with dd-wrt using TFTP method. They should work for Tomato as well:
    And there's a home-made utility for D-Link similar to Asus' firmware restoration tool (but this page and the tool itself is in Russian...) :

    HP P1005 needs a special firmware file, like HP 1018/1020. Look for instructions for these models - there are links in the 1st post of this thread. The specific firmware file for your model can be found here:
    (BTW - took me ~5 mins to google your model, and find out what it needs. Is it so hard to use google ;)?)
  78. Papka__

    Papka__ LI Guru Member

    Hi. Is it possible to use cifs as vsftps root?
  79. genjuro

    genjuro Addicted to LI Member

    I have no issues with transmission ray123... it never crashed, and I'm using it for over one month, 24/7 :)... i just never imagined that transmission was so greedy in using RAM...I'm tempted to try the RAM upgrade to 128 MB, but I'm not sure i can accomplish that exploit... i will have to find someone to help me :confused:

  80. llllllllllll

    llllllllllll Addicted to LI Member

    Guess I am pretty dumb :-(

    Now I have copied the firmware file for my P1005 to /jffs, and put the hotplug script in place, but still not printing... Here is the hotplug script:

    if [ $PRODUCT = "3f0/3d17/100" ] then
    if [ $ACTION = "add" ] then
    sleep 5
    cat /jffs/sihpP1005.dl > /dev/usb/lp0

    Here are the logs:

    Mar 15 22:04:28 unknown kernel: usb.c: USB disconnect on device 00:03.1-1 address 3
    Mar 15 22:04:29 unknown kernel: hub.c: new USB device 00:03.1-1, assigned address 4
    Mar 15 22:04:29 unknown kernel: printer.c: usblp0: USB Bidirectional printer dev 4 if 0 alt 0 proto 2 vid 0x03F0 pid 0x3D17
    Mar 15 22:04:29 unknown kernel: printer.c: usblp0 Device ID string [86]='MFG:Hewlett-Packard;MDL:HP LaserJet P1005;CMD:ACL;CLS:pRINTER;DES:HP LaserJet P1005;'
    Mar 15 22:04:29 unknown user.debug hotplug[365]: Attached USB device /proc/bus/usb/001/004 [INTERFACE=7/1/2 PRODUCT=3f0/3d17/100]
    Mar 15 22:06:54 unknown lpr.notice p9100d[61]: Connection from port 1928 accepted
    Mar 15 22:06:56 unknown lpr.notice p9100d[61]: Finished job: 5388 bytes received

    in above log: I noticed every time when the printer was powered off then powered on, it gets a new address, ie, it was assigned address 3 before powered off, then assigned address 4 after powered back on. is this normal? Thanks!

    HP P1005 needs a special firmware file, like HP 1018/1020. Look for instructions for these models - there are links in the 1st post of this thread. The specific firmware file for your model can be found here:
    (BTW - took me ~5 mins to google your model, and find out what it needs. Is it so hard to use google ;)?)[/QUOTE]
  81. teddy_bear

    teddy_bear Network Guru Member

  82. llllllllllll

    llllllllllll Addicted to LI Member

    finally it's working! the issue was the script probably had some special characters in it so it didn't execute that "cat /jffs/sihpP1005.dl > /dev/usb/lp0" line. I manually ran this line and it fixed the issue. I went back and re-copied the script and saved it and now it worked like a charm! Thanks Teddy!

  83. Papka__

    Papka__ LI Guru Member

    Can't mount network shared folder:
    mount -t cifs "//192.168.1.XXX/my_share" "/mnt/folder_for_mounting" -o username=tomato,password=tomato,rw,iocharset=utf8,file_mode=0777,dir_mode=0777

    If I try to mount via GUI to cifs1, and then mount cifs1 with bind option to /mnt/folder_for_mounting - all is ok. Any ideas?
  84. dennys

    dennys Addicted to LI Member

    I'm using Tomato Teddy Bear v44 + Asus 500gp v1 + Huawei E169 for 3G network, the following is my steps

    1. Install extras.tar.gz
    2. Use insmod to load driver (usbserial.o and option.o)
    3. Use usb_modeswitch to switch E169 to modem mode
    4. Kill the process of pppd and use pppd to dial manually
    5. The 3G network is ok, but the problem is, after pppd dial, I'll see lots of log like the following.
    The volume is very huge and keventd uses more than 90% CPU.

    user.err kernel: usb-uhci.c: ENXIO c0010400, flags 0, urb 8360dee0, burb 8360d3e0 
    user.err kernel: usb-uhci.c: ENXIO c0010400, flags 0, urb 8360d9e0, burb 8360d3e0 
    user.err kernel: usb-uhci.c: ENXIO c0010400, flags 0, urb 8360df60, burb 8360d3e0 
    user.err kernel: usb-uhci.c: ENXIO c0010400, flags 0, urb 8360dee0, burb 8360d3e0 
    user.err kernel: usb-uhci.c: ENXIO c0010400, flags 0, urb 8360d9e0, burb 8360d3e0 
    user.err kernel: usb-uhci.c: ENXIO c0010400, flags 0, urb 8360df60, burb 8360d3e0
    But when I stop the 3G modem, the log is stopped and CPU loading is normal. If need more log of above command, please let me know.

    And I also tested dualwan (, it has the same problem. But I didn't see this problem in CDMA@wifi (
    RobRedbeard likes this.
  85. teddy_bear

    teddy_bear Network Guru Member

    At least you got 3G working :).
    Not sure what's going on with UHCI logging - have you tried to disable USB 1.1 support, and only use USB 2.0? You will need to reboot the router after making this change.
    If using USB 2.0 doesn't help, and if you have no other problems with this modem, maybe all we need to do is to disable logging of this message - that should bring the CPU usage down.
  86. quackdealer

    quackdealer Addicted to LI Member

    Obviously I'm doing something wrong here, as I haven't gotten a response to my question, and obviously I don't know what that thing is, since I keep asking it the same way. Any help you can give on my problem or on what I'm doing wrong would be greatly appreciated.
  87. teddy_bear

    teddy_bear Network Guru Member

    No, it only means that nobody can give you the definite answer. If you use search, you'll find several generic posts regarding printing support that are applicable to your case as well - nothing new can be added. For example, check my post on this thread.
  88. tarataqa

    tarataqa Guest

    Looking for USB 2.0 for newbies

    My Tomato-WRT54G recently died so I got an Asus WL-502GU to try out a USB 2.0 NAS using Teddy's famous Tomato mod.

    I want to copy files to it from Win7 via Samba and then use the NAS to stream MKV files to my Popcornhour so I picked firmwares <=4MB with USB and Samba.

    I tried two USB2.0 drives, one at a time. Both formatted as EXT3 on latest Ubuntu. One, a Seagate 1TB in Vantec case. Other, a 1TB Calvary.

    So far the firmware is functioning great in most areas, but my problem is I cannot get the NAS to transfer at USB 2.0 speeds.

    No Samba; FTP speed was 12Mbps

    Samba speed was 12Mbps

    Samba speed was 15-17Mbps

    I'm sure there are other WL-520GU users that have gotten USB 2.0 to work. I've tried clearing nvram, and the log doesn't show anything bad. Please tell me what I'm doing wrong or how I can track down the problem.

  89. freddyspam

    freddyspam Addicted to LI Member

    You are not going to get full USB 2.0 speeds because of the limitations of this router. The speeds you are reporting are normal for the 520GU and this firmware (this has been asked a few times here, even once by me :biggrin:). If you want faster speeds, look into getting a dedicated NAS. In short, you're not doing anything wrong.
  90. ghostknife

    ghostknife Addicted to LI Member

    Sometimes I have this problem with my Canon 810 if it's been unplugged/off or hasn't been used for a while the print jobs seem to go nowhere, usually I reboot the router with the printer attached and turned on and then it's fine. Otherwise try turning bi-directional support in tomato and in the printer driver on/off depending on what setting you already have. Also only use USB 2, here are my settings:

    Core USB Support [on]
    USB 2.0 Support [on]
    USB 1.1 Support [off]

    USB Printer Support [on]
    Bidirectional copying [on]
  91. toolbox

    toolbox LI Guru Member

    I have a similar problem with my Caon iP2600 on VPN version of build 44. If my printer have not been used for a while, the printer will stuck after half page is printed and it won't restart until I reboot the router. I have tried cancel the print job and re-print but the printer won't resume until the router is rebooted.
  92. imakowski

    imakowski Guest

    NFS support


    can you please include nfs support for this mod? As you know nfs better for this routers than smb. I'm using linux client for shares so this will increase speed a lot...
  93. ray123

    ray123 LI Guru Member

    But...there doesn't seem to be any free NFS client for Windows. That would make NFS on the router useless for 99% of people. Anyway, I doubt that NFS would be any faster than Samba---you're limited by the speed of the network and the slow & overloaded CPU in the router.
    IMHO, it has to work out-of-the-box with Windows machines, without requiring a Windows user to install additional software. Samba fulfills this, NFS doesn't.

    Not that I like Samba. Configuring Samba shares on my Linux box is worse work than shoveling our a barn.
  94. teddy_bear

    teddy_bear Network Guru Member

    Ray explained it very good why Samba is chosen as a file sharing solution for these routers. I'm considering to add NFS server to the kernel 2.6-based builds for routers with 8MB+ flash, but there's simply no space for it in 4MB builds.
  95. DaeMonS

    DaeMonS Addicted to LI Member

    oh, very good idea my friend :D
    we will preciate very much with devices like RT-N16....but better u do this soon,then late :D
  96. viralmind

    viralmind Addicted to LI Member

    tomato teddy bear mode is support the linksys wrt160nl? is it possible?
  97. endiz

    endiz Network Guru Member

    Is there any possible way to add a user to the shell? I want to be able to give tunneling privileges to other people using the remote access feature, nothing else.

    Thanks guys.
  98. dennys

    dennys Addicted to LI Member

    Sorry for late reply. If I enable USB 2.0 only, the modem is not detected (use cannot see it). I need to enable UHCI of USB 1.1 at least. Yes, everything is ok except log and CPU loading.
    Load average: 0.61 0.26 0.08 2/30 3221
        2     1 root     RW       0   0%  64% [keventd]
     3025     1 root     R     1444   2%  15% klogd 
     3023     1 root     S     1448   2%   8% syslogd -L -s 50 
     3216  2869 root     R     1456   2%   1% top 
    But how to disable the log? I didn't find the option, maybe I miss it?
    RobRedbeard likes this.
  99. Catalin

    Catalin Addicted to LI Member

  100. teddy_bear

    teddy_bear Network Guru Member

    No, it's not Broadcom.
    Sure, there's a way - it's a Linux box. But there're no built-in tools for that in the firmware - you'll have to dig them up from the net (i.e. optware' adduser), and figure out how to use them with Tomato.
    Catalin & dennys,
    No, I didn't mean to disable all logging completely... What I'll probably do is I'll comment out that particular message in kernel sources for the next build.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice