Tomato ND USB Mod

Discussion in 'Tomato Firmware' started by teddy_bear, Dec 17, 2008.

  1. chuckwhite8

    chuckwhite8 Networkin' Nut Member

    Hello -- I am trying to get my HP LJ M1319f MFP to work with SANE backend.

    I have installed the following: libusb, libtiff, libjpeg, libpng, libieee1284, xinetd, sane-backends, and made the required changes in /opt/etc/sane.d/saned.conf (so that all clients can access) and for the service in /opt/etc/xinetd.d/saned.

    Output of sane-find-scanner is:
    found USB scanner (vendor=0x03f0, product=0x5817) at libusb:001:002

    Output of scanimage -L is: No scanners were identified.

    In /opt/etc/sane.d/hp.conf, I added
    # HP LaserJet M1319f MFP
    usb 0x03f0 0x5817
    and ran xinetd.reload. That does not help.

    As I was browsing around, I found the following page:
    which points to HPLIP ( and shows several HP scanners as being supported.

    Any help around which HPLIP distribution to use, and how to go about installing it would be very appreciated. Thanks.
  2. CBC888

    CBC888 Networkin' Nut Member

    Oh... I thought that I would see the automatic shares listed with the other two shares (root$ and share) under the "Network Shares List" in Tomato. Is this not the case, or would it (the automatic share) be visible/evident only from my Windows clients? :confused:
  3. jed_99

    jed_99 LI Guru Member

    I have a WRT54GL that I've used various firmwares in over the years. Tried Teddy Bear mod in some WL-520gu's and RT-N12's, and love the wireless connectivity plus the # of connections in this one.

    Then, I put tomato-K26-1.27.9045MIPSR1-beta11-Std, on, and so far, so good. Figured I would play around with the vpn version, and I get "mtd will not fit", error when I try to load it via the gui upgrade interface. Router is not adversely affected. 4mb memory limit, I assume.

    Is there an opportunity to have a Teddy Bear vpn version fit my WRT54GL (like tomato-K26-1.27.9045MIPSR1-beta11-vpn3.6)? Or am I missing something in my reading.
  4. chuckwhite8

    chuckwhite8 Networkin' Nut Member

    Thanks for your response. Here's the output of blkid:
    /dev/sda2: UUID="94e2599e-429e-40a9-8ee0-30b267ef00d2"
    /dev/sda1: LABEL="My Book" UUID="08A2-AD16"
    /dev/sda4: LABEL="disk" UUID="a7813d01-f223-4cc5-999e-44a5a0447273"
    /dev/sda3: LABEL="ftp" UUID="65599531-0a41-4bf8-80d6-84070a548411"

    After seeing your response, I have removed the mkdir /mnt/... commands in the init script. I have also removed two lines from /etc/fstab which corresponded to disk and ftp. All partitions still mount correctly and I can access from Windows.

    1. Is there a utility which only sets the label of a partition? I ended up re-running mke2fs with -L option.
    2. How do I set the label for the swap partition? I used mkswap -L swap /dev/sda1 but that does not seem to set the label.
  5. rhester72

    rhester72 Network Guru Member

    You can use tune2fs, a precompiled version of which is on my utilities web site. -L is also used to set the volume label, and does not require the media to be dismounted.

    What is the output from "tune2fs -l /dev/sda1"?

  6. teddy_bear

    teddy_bear Network Guru Member

    That's strange because I was able to flash Asus wl-520gu (which also has 4MB flash) with tomato-K26-1.27.9045MIPSR1-beta11-vpn3.6.trx. Not sure why it doesn't fit onto WRT54GL...

    1. As Rodney suggested, you can use a separate tune2fs utility. It's not included in the firmware because of the size.
    2. Actually, "mkswap -L" works correctly. The problem turns out to be that the Busybox' functions to read the label from a swap partition don't work correctly if that partition was previously formatted as FAT. Tomato GUI uses Busybox' functions too - that's why you see the old label in blkid output as well as in the GUI. I'll fix it in the next build. In the meantime, as a workaround you can reformat your swap partition as Ext2/Etx3, and then convert it to swap again using "mkswap -L <LBL>". That should fix it.
  7. chuckwhite8

    chuckwhite8 Networkin' Nut Member

    Thanks rhester72. I downloaded tune2fs from your website and could set the label on opt without unmounting the media.

    Thanks teddy_bear. formatting using mke2fs and then mkswap -L worked perfectly. Here's the current output of blkid.
    /dev/sda4: LABEL="disk" UUID="a7813d01-f223-4cc5-999e-44a5a0447273"
    /dev/sda3: LABEL="ftp" UUID="65599531-0a41-4bf8-80d6-84070a548411"
    /dev/sda2: LABEL="opt" UUID="94e2599e-429e-40a9-8ee0-30b267ef00d2"
    /dev/sda1: LABEL="swap"
  8. playdude

    playdude Addicted to LI Member

    cat /proc/mtd on my wrt54gl shows the size of the firmware partition to be 3b0000 in hex which is 3866624 bytes. The size of that K26 image is 3907584 bytes which is larger than the firmware partition. So I guess that's why it wouldn't fit. I had a similar issue trying to flash the K26 Light USB version on my dir320 too. After taking out the binaries I didn't need like pppd and pppoecd using the Firmware Modification Kit I managed to make it fit though.
  9. trueman

    trueman Addicted to LI Member

    I have WRT54GL with Tomato 1.27 installed. I have never played around with Tomato mods and this one seems to be a good fit with good reviews. I do not need USB since my router doesn't have one, but interested in the Speedmod.

    Will I be able to install this mod on top of Tomato 1.27 and retails all my settings? Just curious if this would be treated as an upgrade or new install where the nvram has to be cleared.

    Can you please confirm that tomato-ND-1.27.8745-Std.rar has SPeedmod and all features mentioned in the first post? I dont need USB, VPN or extra.

  10. parkhaus

    parkhaus Addicted to LI Member

    I would just like to know: what is the maximum transfer rate you get with the USB memory access? I have a ASUS WL-500gP V2 and a HDD via USB connected. Maximum rate via Samba is 2.5MB/s. not bad, but I would like to reach at least 7 or 8. Any advise?
    Edit: just read it could be due to the NTFS format. FAT32 should give higher rates.
  11. kimy

    kimy Networkin' Nut Member

    I have the 1.27 build of Tomato (Teddy Bear Mod [Lite]) installed on my Asus 520 GU. Everything is working great, except....I have a Lexmark printer (6100 series) that I cannot get to play nice with this configuration. I see the printer listed in the Tomato UI, but printing fails.

    When I connect a different printer (Canon), all is fine.

    Are there printers that are incompatible with this setup? I searched, but haven't come up with anything.

    Thanks for any advice.
  12. playdude

    playdude Addicted to LI Member

    I've got a 500gpv2 too. 4MB/s is the maximum speed the CPU can deliver. If you want 7 or 8MB/s, get an Asus rtn16.
  13. teddy_bear

    teddy_bear Network Guru Member

    Sure, there are... The firmware only includes generic printer driver (which most printers work with) but - but some printers require special drivers to work on Linux. I don't know specifically about Lexmark 6100 though...

    You should be able to retain your settings from vanilla Tomato 1.27. However, in case of any issues the first troubleshooting step will still be clearing the nvram and manual reconfiguration.
  14. kimy

    kimy Networkin' Nut Member

    Thanks for the info teddy_bear!
  15. trueman

    trueman Addicted to LI Member

    Thank You!

    I did end up reconfiguring which I think is the better way in this case - for eg, when I retained the original settings, and max number of connections was still at 4096. Everything is good now. I noticed that the webpages open up faster than before. I am using the "no usb" firmware.
  16. HiJacK

    HiJacK Guest

    Ext3 partition sharing issue

    I've been using the Teddy Bear mod (latest firmware) on my Asus 520gu for quite some time. Last night I decided to reformat my HDD from Fat32 to (Ext3 & NTFS). My partitions are as follows:

    Seagate 1tb external usb drive
    /dev/sdb1 ext3 /media/movies movies 930 gib
    /dev/sdb2 ntfs /media/windows windows 1.85 gib
    /dev/sdb3 linux-swap 102 mib

    I am able to mount the partitions in tomato. I can access the files in the ntfs partition, but NOT the ext3 partition. I can access the ext3 partition on my Ubuntu machine with the following command:

    sudo chown -R username:username /media/movies

    If I mount the HDD on the Asus router and try to access the ext3 partiton from the Ubuntu machine, it says I don't have permission to access the file. I'm assuming I need a script in
    but can't find a script that will allow me to access my ext3 partition. Do I need "optware" or any other plugin in order for me to access my ext3 partition?

    I tried chown on tomato, but it doesn't recognize it. I've see some people use chmod. I read some threads on the Ubuntu forums and someone suggested opening up a terminal and typing gksu nautilus, then right click on the movies folder and click on the "permissions" tab and change the permission on user and group, but that didn't work.

    I've done a lot of reading and research on this forum & google, but can't find the answer. Can someone please help me get on the right track. Any help is much appreciated.
  17. IcepickSU

    IcepickSU Guest

    Hi everyone,

    I was trying to install an OpenVPN version of Tomato on my WRT54-GL. As far as I can tell, Teddy Bears mod seems to be the best out there, but the VPN edition is overkill for my router (has no USB). I wouldn't care, except that upgrading from the "no usb" edition complains that the VPN firmware is too big to flash.

    Anyone else experience this and possibly have a solution?

  18. CBC888

    CBC888 Networkin' Nut Member

    daemon.err smbd[3092]

    Several times a day, the following error shows up in the log file:

    daemon.err smbd[3092]: smb_pwd_check_ntlmv1: incorrect password length (74)

    Is this something that I need to be concerned with? Everything seems to be working fine...
  19. teddy_bear

    teddy_bear Network Guru Member

    Are you using the "No Authentication" mode for Samba file sharing? If everything works, I wouldn't worry about it for now - but I probably know why it's happening... There's some minor incompatibility of Samba "share" mode with NTLM implementation in Vista and Win7 - the default authentication method fails, and Samba fails over to another one which then succeeds. Not a problem besides some annoying log messages. But there's a workaround (not using the "share" mode even for no-password access) - I may try it in the next update.
  20. CBC888

    CBC888 Networkin' Nut Member

    Yes, I am using the Shared-No Authentication mode. Okay, good to know - as long as everything works.
  21. Rasky

    Rasky Addicted to LI Member

    Teddy_bear, I am trying to auto-configure a proxy in my network. I saw that there are symlinks in /www:

    lrwxrwxrwx 1 root root 18 Apr 26 21:06 /www/wpad.dat -> /www/ext/proxy.pac@
    lrwxrwxrwx 1 root root 18 Apr 26 21:06 /www/proxy.pac -> /www/ext/proxy.pac@

    but it looks like there is something wrong going on: even if you create a file called proxy.pac in the /www/ext directory, it is not being served when you visit You can try by yourself. Either the webserver does not follow symlinks, or it does not serve files by default (maybe it only serves images?).
  22. teddy_bear

    teddy_bear Network Guru Member

    Probably missing the proper MIME handler. I'll add it to the next build which should be out shortly.
  23. teddy_bear

    teddy_bear Network Guru Member

    Update - build 46

    Changes common for kernel 2.4 and kernel 2.6 based builds:
    • Fixed upnp bug when NAT-PMP redirections were expired prematurely.
    • D-Link DIR-320 support: the router should retain its original MAC address after flashing with Tomato (untested).
    • Software updates: Busybox updated to the latest ver. 1.16.1 with additional patches from trunk, miniupnpd 1.4 (20100511), ntfs-3g (in Extras builds) 2010-05-16, usb_modeswitch (in Extras builds) is updated to ver. 1.1.2 (with included new-style configuration files), libusb 1.0.8 (some of these updates were already present in K26 beta11 builds).
    • Fixed bug in Samba configuration allowing Linux clients to bypass authentication even when authentication is set to "required" in the GUI.
    • Slightly improved Samba compatibility with Windows clients (do not use "share" mode).
    • Fixed obtaining label/uuid from swap partitions.
    • Added Wireless Interference Level to Status -> Overview GUI page (for APs in 40Mhz wireless-N mode).
    • Do not restart FTP/Samba on every USB partition unmount - do it only if the partition can't be unmounted otherwise.
    • Modified USB after-mount and before-unmount scripts. Now they are always called for every partition getting mounted or unmounted, and they get one parameter - the mountpoint (can be examined in addition to the environment variables). Previously the after-mount script was called for every partition in K26 builds and once per device in K24 builds, the before-unmount script was called once per device.
    • Added minimalistic tune2fs Busybox applet to the Extras build - only supports the "label" (-L <lbl>) option.
    • Improve automatic reconnect for PPTP/L2TP WAN connections.
    • Fixed DHCP lease renewal with some broken ISPs (should eliminate a need for workaround iptables rule).
    • Fixed minor memory leak in iptables2.
    • Fixed domain name corruption in Dnsmasq.
    • Added MIME handler to Tomato http server for proxy autodiscovery files.
    • Removed "Reduce packet size" option from the GUI DHCP settings - this is always enabled now.
    • Added option to erase NVRAM after flashing the new firmware image - useful when flashing to other firmwares (this was already in K26 beta11 builds).
    • Fixed display of some password fields (FTP users and Samba passwords) in GUI to use dots when editor doesn't have focus (this was already in K26 beta11 builds).
    • Modified the build system to allow more flexible firmware configurations.
    • Cosmetics and code cleanup.

    Kernel 2.4-based builds only:
    • Additional USB 2.0 driver updates/fixes backported from kernel 2.6.
    • Some fixes and updates backported from kernel 2.6 tree in network support modules.
    • Allow mounting of USB discs with no partitions (that was already working in K26 builds).
    • Extra utilities (e2fsck, mke2fs) are removed from VPN build to reduce the size and to make it fit into 4MB flash.

    Changes specific for kernel 2.6-based builds (beta 14):
    • Updated Broadcom wireless driver and SDK to version (experimental).
    • Added Media Server (MiniDLNA 1.0.17) to Extras and VPN builds.
    • Fixed bug causing error in the GUI trying to save negative numeric values (i.e. the default "-1" value for "TLS Renegotiation Time" in VPN builds).
    • Updates for USB kernel drivers backported from newer kernel 2.6 tree.
    • Various kernel fixes and updates backported from kernel 2.6 tree in networking support modules, MIPS CPU support, ext3/fat fs support.
    • Fixed regression in beta11 that decreased USB transfer speed for some devices.
    • Included ebtables 2.0.9-2 into Extras and VPN builds.
    • Added maxSize parameter for usb_serial module to specify USB endpoint size.
    • ftdi_sio.ko and pl2301.ko modules are now included into Extras builds.
    • CIFS module updated to ver 1.52: backported from kernel 2.6.24.
    • In Extras and USB builds the standard uClibc libraries are not getting stripped out of unused symbols to make it easier to use additional custom compiled software.
    • Added preliminary support for Linksys WRT320N (thanks to dbt78 for the router id patch) and Netgear WNR2000v2 (untested).
    • Fixed flashing with Netgear .chk images from Web GUI (untested).

    Links to the firmware binaries and the git repository with sources are in the 1st post.
  24. liubebo

    liubebo Guest

  25. teddy_bear

    teddy_bear Network Guru Member

    Yes. And - if you read the 1st post of this thread carefully - you'll find the link to the same solution ;).
  26. meazz1

    meazz1 LI Guru Member

    what is the best way to upgrade to this version. I am using an Asus RT-N16 with TB older version.
    Do I need to do 30/30/30 process and update firmware thru admin screen and do a nvram clear than restore back up?
  27. Rasky

    Rasky Addicted to LI Member

    Thanks! Now the only issue left is that the file is being served only under authentication, while it should not require it. It's a matter of flipping the last field in the mime table from 1 to 0.
  28. tmpid

    tmpid Networkin' Nut Member

    "Allow mounting of USB discs with no partitions".

    I have an all-in-one card reader connected to the USB port. The "USB and NAS" menu now needs to wait half a minute before it will show up. The system log shows that the router is trying to read all the empty slots and assume they are raw partitions till the reading times out/gets the IO error. The one inserted card does work fine though.

    Hopefully this will get fixed in the next release. Thanks for the great work.
  29. teddy_bear

    teddy_bear Network Guru Member

    Hmm, you're right... Kernel 2.4 creates partitions for empty card readers, and that causes these attempts to read and mount them... In kernel 2.6 it works fine because no partitions are created when the slot is empty, and that allows to support the non-partitioned drives. Well, I'll take a look to see if it can be backported from kernel 2.6, and if not - I guess I'll just have to roll it back...
  30. Pay87

    Pay87 Addicted to LI Member

    I updated from build 45 to build 46.
    Do I have to reset the config files?
    Just flashed it in admin menu.. :)
  31. tmpid

    tmpid Networkin' Nut Member

    Or maybe you can add an option to enable/disable it if mounting raw partitions is useful for some people.
  32. Sopmod

    Sopmod Network Guru Member

    Anyone else having an issue with Dynamic DNS?

    I use DynDNS - Dynamic

    And after the upgrade to v46 I'm getting:

    Thursday, 3 June 2010 15:03:21:
    Unknown error (502).
    (1/3: Automatically retrying in 16 minutes)

    Never has happened before so hence why I ask.
  33. teddy_bear

    teddy_bear Network Guru Member

    Maybe a temp glitch with your DynDNS account?
    I tested it with build 46 (both - 2.4 and 2.6-kernel based), and it worked with DynDNS (http & https) as well as with Dns-o-matic and No-IP.
  34. Sopmod

    Sopmod Network Guru Member

    Yes it seems so. All good now. Sorry to waste you time TB.

    I have a wl-500gv2 ASUS. Is there a benefit for me to use the 2.6 firmware?

    Most importantly, thank you so much for your efforts with the your firmware.
  35. maurer

    maurer Network Guru Member

    hello all.
    I just found this:,6629.msg111149.html#msg111149
    it's a tomato ND-usb with 3G wan option.
    DANtes has a long history of versions for 3G dongles mainly for DIR-320 under x-wrt and it seems he ported his code to tomato.
    If you manage to convince him to upload his code on TB's repo it will be a great feature addition for tomato and TB's mod.
  36. Rasky

    Rasky Addicted to LI Member

    Very nice! It would be nicer if it was integrated it with the builtin list of APNs/ISPs/Countries already available in modern distros.
  37. malystc

    malystc Networkin' Nut Member

  38. Rasky

    Rasky Addicted to LI Member

    You need to activate JFFS (Administration >> JFFS), and format it. Or, if you have a USB disk/pendrive attached, you can save the file to it instead of JFFS.
  39. malystc

    malystc Networkin' Nut Member

    Thank you very much for your help Rasky. The printer works perfectly now!
  40. nguyen

    nguyen Addicted to LI Member

    nvram vlan1ports

    After reboot, vlan1ports always reset to vlan1ports="0 5". Teddy_bear, could you please check this? I only test tomato-NDUSB-1.27.8746-Ext.rar firmware. All the previous versions are working fine.

    Can any one tell where I can get tomato-NDUSB-1.27.8745-Ext.rar?
  41. Engineer

    Engineer Network Guru Member

  42. kastytis75

    kastytis75 Addicted to LI Member

    I have noticed one problem... sometimes FTP server shows "could not connect" like there is no ftp server when I'm trying connect...but after unmount/mount of usb flash or after remove it and insert back FTP works again...I am using ext file system
  43. BeHappy

    BeHappy Network Guru Member

    I have noticed one problem... fresh installation editing wireless setup getting error wl_nmode_protection is invalid on WHR-HP-G54, however if upgrading from elder build no error message as above.
  44. Trigunflame

    Trigunflame Networkin' Nut Member

    I believe I reported it a while back. I was just about to upgrade and test that -__-
    I really don't want to flash it and then find out it still doesn't work; then have to revert back to my current.. lol
  45. teddy_bear

    teddy_bear Network Guru Member

    Confirmed, there's such error in a few last builds on Buffalo routers only. Just figured it all out today - will be fixed in the next update.
  46. cxu123

    cxu123 Networkin' Nut Member

    "USB Core USB Support" can not be saved after reboot

    I am using WL-520GU. I have a problem with the latest "K24 build 8738 ND USB Lite" . After I enabled the "USB Core USB Support" and saved it. Next time after router reboot, the "USB Core USB Support" will become disabled again.
  47. teddy_bear

    teddy_bear Network Guru Member

    Uh? 8738 was "the latest" last November ;).

    In any case, did you erase the nvram after installing Tomato?
  48. cxu123

    cxu123 Networkin' Nut Member

    Yes, you are right. I accidently upgrade old firmware during a recovery process. That explains why the settings can not be saved properly. It works now, thanks.
  49. DisturbedCrok

    DisturbedCrok Networkin' Nut Member

    I'd first like to start by thanking TeddyBear and all of those who have made this wonderful firmware. Also, the installation guide was a breeze compared to my older Buffalo router.

    But now, I am trying to use my RT-N16 and the USB features and I just can't seem to figure it out! I am having problems with trying to read it. It shows mounted in the USB Support section, but I cannot seem to access the drive.
  50. cxu123

    cxu123 Networkin' Nut Member

    The problem happens again. I am using "v1.27.8746 ND USB Lite". Only the "Core USB Support" enabled selection can not be saved. Other USB settings selection can be saved.

    I had put "rmmod ext3" and "killall -9 buttons" in the [Administration] - [Scripts] -[ Init], after that, this problem came out. I had restored default and clean NVRAM and there was no help.

    I don't know the exact way to reproduce it. It randomly happened to me.
  51. jed_99

    jed_99 LI Guru Member

    What about a 30/30/30 and then a reflash, and another 30/30/30? I have a WL-520GU with the latest Lite firmware, working fine with USB printers.
  52. cxu123

    cxu123 Networkin' Nut Member

    USB printer works fine for me. Just the selection of "Core USB Support" option can not be saved or lost after reboot. I have to enable it again from Web to use USB printer. It seems to be random happened, sometimes it was just fine.
  53. kdf37

    kdf37 Networkin' Nut Member

    First off, thank you teddy_bear for this great piece of work!

    Regarding, v1.27.9046 MIPSR1-beta14 K26 USB vpn3.6:
    My wl 500gp V2's clock seems to be running slow. I noticed that there have been some release notes (Build 1) relating to the clock speed and some fixes for the 500gu - seems like 83% (200/240). Could this issue have been re-introduced in the above release?
  54. ray123

    ray123 LI Guru Member

    Despite TB's fix/enhancement to ntpsync a while back, the clock on these routers will drift horrendously and erratically. The clock is a little slow when there's not much traffic, and very slow when you do heavy downloads or start doing torrents.

    Ntpsync (on the router) itself is kinda brain-dead, because it truncates off the fractional seconds, and adjusts the time by one huge step once a day (or per your configuration) whenever it has drifted by "too much".

    The whole thing has offended my sensibilities as a professional programmer, so I've been tinkering with this off-and-on for a while now. I haven't submitted anything yet because I'm still not happy with the reliablility that I can get without implememnting the whole-hog ntpd. Ntpd is just too too big to be a reasonable solution on a 16MB/4MB router. And then we went on a couple of long cruises and I forgot about it. :redface:

    Now that I've rememberer, and that I've finished some other projects, I guess I'll get back on it.
    Yes, yes, this is only a router and doesn't need to keep accurate time, but still.....
  55. teddy_bear

    teddy_bear Network Guru Member

    What are you talking about? That was a problem with original Tomato kernel 2.4.20 - back then the clock could easily drift a second or 2 per hour, even with light load. After upgrading the kernel, the normal time drift om my routers is within 1 sec per day (I have it set up to sync the time every 24 hours now), and in case of very heavy torrenting it sometimes can go up to 3-5 seconds per day, which is totally acceptable IMO. Never seen it to drift more than that on newer kernels...

    The original problem on 520GU caused the clock to be 20% slower than normal, losing 10 mins per hour. Is your clock that slow now? Was it working properly in previous builds? If so, it might be another side effect of updating the wireless driver in K26 betas 14 and 15. The new driver had too many other problems though, and I reverted it back in beta 16 (not yet announced but already available for download). Hopefully it will fix it. But let me know if your clock is still slow after you update to beta 16 (and if so - exactly how much slow).

    What you experience is definitely not normal. You are not reloading your settings from the stored config file after clearing the nvram, are you? If not - then something else is screwed up. Hard to say what it could be without the actual faulty router on hands...
  56. cxu123

    cxu123 Networkin' Nut Member

    I did reloading my settings from the stored config file after clearing the nvram. Will this screw up something?

    Strangly only enable "Core USB Support" can not be saved correctly (it always became disabled after reboot router). Chnage to all other settings can be saved correctly.
  57. teddy_bear

    teddy_bear Network Guru Member

    That completely negates erasing the nvram. You have to manually re-enter your settings.
  58. ray123

    ray123 LI Guru Member

    Teddy Bear, if you do the time update only once every 24 hours you don't see all the clock wander that's going on.

    To give you an example----I had mine updating at one hour intervals when we were out of town, when NOTHING was going on since all the computers were powered down and only the router was alive.
    Looking at the log for Feb 7 to Feb 8 for 24 hours, the time updated +1s four times, and updated -1s three times, and "no change" 17 times, for an overall 1 sec correction per 24 hours. In the 20 days we were gone, there were 214 "no change", 59 +1s, and 47 -1s.

    Unless you run something like ntpd or chronyd you won't see how much the clock drift is. You can't see it with Tomato's ntpc---it is just too coarse a tool. So maybe the overall drift is 1 second a day. But that's because sometimes it runs a little slow and sometimes it runs a lot slow. Ntpc is nowhere near precise. It discards fractional seconds, so if it compares 14.99 to 15.01 it thinks that it is one second off. And if it compares 15.01 to 15.99 it thinks that it is spot on. And (if you have it configured to use the xx.pool.ntp servers) it uses a different time server each time. (The pool rotates to a different set of servers every hour.) This introduces another error.

    Now, you could make a pretty good argument that this is good enough. After all, it's only a router and who the heck cares if the clock is inaccurate. For sure, we don't want to take up a lot of the 4mb RAM just to make the clock accurate.

    It just kinda irks me. Linux has a bunch of code to maintain clock accuracy---all it needs is to be fed the right parameters. On my WL-520GU the raw clock drift is terrible: -130 ppm at idle. When I ran the full-boat ntpd, the freq swings from -193 to +176 (a swing of 370 ppm) when the traffic goes from idle to heavy.

    In summary, ntpc does a crappy job, and does both too much and too little. Too much: the way it gets run there is no reason to do all the fancy stuff---we should just do ntpsync periodically. Probably once an hour.
    Too little: 1) the algorithm it uses and the implementation are brain-dead. 2) it does not give the kernel the adjtime parameters that the kernel needs to keep the clock accurate.

    Anyway, I'm gonna keep playing with this, to see if I can come up with something that keeps a reasonably accurate clock without a whole lot of code.
  59. teddy_bear

    teddy_bear Network Guru Member

    That's exactly the point! I agree with you that the ntpc in Tomato is a way too simple... But however brain-dead the implementation is, it is small and does what it needs to do - keeps the router's clock within the reasonable accuracy even with only one sync per day. Yes, it discards fractional seconds - so what?

    I don't see a real need to improve it, but if you'd like to work on it, and will make it dead accurate without adding much code - sure, why not :)?
  60. teddy_bear

    teddy_bear Network Guru Member

    Update - build 47

    Changes common for kernel 2.4 and kernel 2.6 based builds:
    • Added Busybox sendmail applet to Extras and no-USB Std builds.
    • Added basename command to all builds except Lite.
    • Fixed proxy autodiscovery mime handler to not require authorization.
    • Software updates: ntfs-3g release 2010.5.22 (in Extras build), Dnsmasq 2.55.
    • Added "nvram erase" command.
    • Fixed issue with overriding vlan ports configuration on every reboot.
    • Fixed error saving settings on "Advanced->Wireless" page for Buffalo routers.
    • Allowed to append custom content to /etc/[passwd|group|shadow|gshadow] files.
    • Changed dropbear config to simplify using Optware openssh-sftp-server.
    • Cosmetics.
    Kernel 2.4-based builds only:
    • Fixed nasty regression introduced in previous build 46 when empty USB cardreaders caused the USB GUI page to hang for a long time.
    Changes specific for kernel 2.6-based builds (beta 15 and 16):
    • Reverted Broadcom wireless driver binaries back to version since the new driver ( caused intermittent problems with port forwarding and UPnP. Included some updates extracted from the new Broadcom SDK ("fast NAT" module, wifi security binaries (nas/eapd), minor patches for wlconf utility).
    • Software update: MiniDLNA 1.0.18 (cvs 2010-06-09, in Extras builds).
    • Removed JFFSv1 support from Non-USB Std build since JFFSv1 for kernel 2.6 causes various problems and needs more work (while JFFS2 in K26 is too big to be useful on 4MB flash).
    • Fixed detection of some non-standard or invalid partition table entries.
    • Fixed VLAN initialization for Asus RT-N10.
    • Completed support for Netgear WNR2000v2 (thanks to gingernut for extensive testing).
    Links to the firmware binaries and the git repository with sources are in the 1st post.
  61. kdf37

    kdf37 Networkin' Nut Member

    Thanks for the insight. Yes, I am losing about 10 minutes per hour with beta 14. I just bought the router so I have no experience with previous releases - it just sounded remarkably similar to the reports in the DD-WRT forums - i.e. 20% slower. I'll let you know the results of the upgrade.
  62. ghostknife

    ghostknife Addicted to LI Member

    Hi, haven't been here in a while but just wanted to ask if there's been any changes to the print server (or anything that it relies on?) recently because I'm having an issue since upgrading from [1.27-NDUSB-8742-Ext] to [NDUSB-1.27.8745.01-Ext] a while back. I couldn't see anything in the release notes but could have missed it.
    It's quite possibly my printer gone screwy (Canon MP810) but whats happening is that when I select to print greyscale it's printing in a sort of Sepia tone instead but XP printer test pages are ok so I don't get it.
    Haven't tried rolling back to 42 yet but if theres nothing changed I'll try a full reset or rollback or something, just don't want to do that if theres no point, Thanks.


    WL-500GPv2 , I only have Core USB Support + USB 2.0 Support enabled and it's always been like that, no HDD, other usb or hubs currently attached
  63. DisturbedCrok

    DisturbedCrok Networkin' Nut Member

    Can anyone advise? I've done lots of googling and couldn't find anything.
  64. gingernut

    gingernut LI Guru Member

    To be able to access the drive you need to also enable file sharing on the file sharing page.
  65. teddy_bear

    teddy_bear Network Guru Member

    Are you sure it's not the cartridges gone bad ;)?
    First of all, you can verify whether or not it's the printer problem by connecting it directly to your PC, and testing the same print jobs. Or try downgrading to the version you didn't have problems with.

    If indeed you track it down to the firmware issue, then you'll need to find out exactly what build was the first one with the problem - there were too many changes between 42 and 45, and it would be much easier to troubleshoot if we get down to one build.
  66. Pay87

    Pay87 Addicted to LI Member

    Thanks for the update!
    Just wonder (like everytime when there is a update), if I have to format NVRAM and restore to default settings..

    Could you please add a info when this is necessary?
    I just updated without formatting the NVRAM and all seems to be okay! :thumbup:
  67. DisturbedCrok

    DisturbedCrok Networkin' Nut Member

    Thanks, it was enabled it already, it was on Yes, no authentication. =( Anything else I might be missing?
  68. teddy_bear

    teddy_bear Network Guru Member

    Did you configure your shares, or have "Auto-share" enabled?
    How exactly are you trying to access the shared drive?
  69. DisturbedCrok

    DisturbedCrok Networkin' Nut Member

    I have it on Read/Write.

    I am trying to access it from any computer on the network, or I would love for it to be able to be read from any computer, even not connect to the network. I am lead to believe that is possible.
  70. Rasky

    Rasky Addicted to LI Member

    teddy_bear, any specific reason why "dns proxy = false" in smb.conf?

    On Windows, if you try to resolve "", the DNS is used. But if you try "foobar" (no dots), it only uses netbios/wins. At that point, if "dns proxy = false", nmbd will report that the name does not exist (unless there is a computer with that name in the domain). On the other hand, if you use "dns proxy = true", nmbd will fall back to DNS resolution. This way, you can add virtual names to your LAN simply through dnsmasq (address=foobar,

    On Linux, DNS is always used (obviously), and this is why tomato adds LAN computer names to /etc/hosts.dnsmasq.
  71. ray123

    ray123 LI Guru Member

    Removed JFFSv1 support from Non-USB Std build since JFFSv1 for kernel 2.6 causes various problems and needs more work (while JFFS2 in K26 is too big to be useful on 4MB flash).

    Is this my JFFS v1 that's now in Tomato's 2.4 kernel? That you perhaps up-ported to 2.6?? 'cause I thought that they removed jffs[v1] from the official 2.6 kernels and now have only jffs2.

    I can develop/debug stuff on either kernel, so let me know and I'll take a look at it. What are the problems? AFAIK, everything in my version should work ok and is not kernel-specific.

    I'd kinda like to get a working version of jffs[v1] back into the kernel, since I think they were a bit hasty on dumping it---and none of them wanted to futz around with the original code or algorithms.
  72. kdf37

    kdf37 Networkin' Nut Member

    I just upgraded to beta 16 and the clock remains slow on my 500GP V2 (10 minutes per hour).
  73. ray123

    ray123 LI Guru Member

    FWIW, for anybody that cares, here's a chart showing how the time offset (delta from the time server) drifts on my WL-520GU. Intervals of about 36 seconds for about 40 hours. Ntpc runs (to adjust the time) once an hour. Positive offset means the router's time is behind the server.

    This chart shows 2 things.
    1) The slope shows that the router's clock runs significantly slow.
    2) The adjustments in time that ntpc makes are haphazard. Sometimes it makes an adjustment when the offset is small. Sometimes it makes an adjustment and then reverses it an hour later. These are due to the fact that it ignores fractional seconds.
    This is yet another example of multiple bugs/flaws in a chunk of code cancelling each other out. The design intent was to adjust the time only when the offset is more than one second. What should be happening is the offset would drift upwards to 1 and then jump down to -1.

    Attached Files:

  74. RonWessels

    RonWessels Network Guru Member

    Actually, what that shows is that the time adjustment algorithm has an integral component as well as a direct offset component in the decision to adjust the time. What that means is that the average offset gets zeroed. In other words, on average, the time is accurate.

    This works very well when there are random variations in the clock offset - they will tend to get smoothed out. However, in this case where the random variations are significantly smaller than the adjustment precision, you wind up with a "dithering" solution.
  75. teddy_bear

    teddy_bear Network Guru Member

    Yes, it's your JFFSv1 that I ported to 2.6. Mostly unchanged - I just had to make a few changes to make it compile (hopefully didn't screw it up along the way). It would be nice if you can look into it. It seems to work. But I just recently noticed that if jffs module has been loaded at least once - even if it's unloaded now - the router will reboot when network services are restarted. That doesn't happen with jffs2. I didn't have time yet to investigate further or get a console dump...

    Very strange, I never heard about this problem on WL500GPv2. Could you please PM me the "sysinfo" output from your router? Also try to flash it with kernel 2.4-based build - would be interesting to see if the same problem exists on your box with older kernel.

    Did you set the workgroup name on the router to match the workgroup of computers on your network? Your Samba shares should be visible in Windows just as any other network shares. Can you share the folder on one of your computers, and make it visible for others?
    The name of the "computer" for the Samba shares will be the hostname you specified on the Identification page in the Tomato GUI. You should also be able to access the shares by typing in "\\your_router_host_name" in the Windows Explorer address bar.

    No real reason. I guess I just copied it over from some other implementation I was looking at, or maybe I had some thoughts about saving resources by not allowing nmbd to start another instance... I'll remove that restriction.
  76. BeHappy

    BeHappy Network Guru Member

    Do I misunderstand something about usb mounting? Mount a printer and usb-pen impossible! Mouting an usb printer must be attached directly on usb port of the router ???
    Mounting a couple of usb-pens w/o printer no probl.. Please enlight me.
  77. teddy_bear

    teddy_bear Network Guru Member

    Enlighting - it's possible...
  78. Rasky

    Rasky Addicted to LI Member

    Try this guide:
  79. BeHappy

    BeHappy Network Guru Member

    My setup
    - usb hub w. 4 ports w/o external power supplier connected a printer, usb-pen

    When connect a printer to hub invisible on the usb list
    Only usb-pens visible w. all the mounted devices

    USB Support
    Core USB Support
    USB 2.0 Support yes
    USB 1.1 Support no OHCI no UHCI no
    USB Printer Support yes
    Bidirectional copying no

    USB Storage Support yes
    File Systems Support Ext2 / Ext3 yes FAT yes

    Do I need some usb scripts? The printer product "3f0/210/100"
  80. teddy_bear

    teddy_bear Network Guru Member

    So the bottom line is - your printer works without the hub, but doesn't work when connected through the hub?
    It should work in most cases... But here's what you can try:
    1. Update to the latest build 47 - it has some minor changes in the USB driver that may help with this particular issue.
    2. Activate USB 1.1 support (you can check both - only one will be activated depending on the controller in your router).
    3. Try different hub.
  81. BeHappy

    BeHappy Network Guru Member

    Thanks for your reply.
    - already updated to build .47
    - already trying two different hubs w/o better result; one straight hub, another octopus aliked
    - all ports are valid, no dead port
    I tear my hair off ???
  82. teddy_bear

    teddy_bear Network Guru Member

    Your sig still says "41". Was it the same with 41?
    You didn't confirm if it works without the hub.
    You didn't say whether or not you tried to activate USB 1.1.

    Also, you may try to activate only 1.1. and disable USB 2.0 (after that you'll need to reboot the router once) - some USB 1.1 printers just don't work via USB 2.0 hub - period - when USB 2.0 driver is enabled.
  83. ray123

    ray123 LI Guru Member

    The thing to try would be to unplug everything and then watch syslog while one-at-a-time plugging in the hub then the problem device(s). You'll see various messages as the USB subsystem detects & activates each device. My first guess would be that you don't have USB1.1 enabled.

    Non-Linux-guru method to watch syslog: Open the router's web page, then go to Status/Logs/view last XX lines. Make sure logging is enabled.
  84. BeHappy

    BeHappy Network Guru Member

    Thanks for your replies. My sig. isn't updated yet, but the router is updated w. build .47
    Unplug from internet, reset/restore all to default
    Here is a part of syslog

    .. only the printer hocked up
    Dec 31 16:00:08 unknown kernel: printer.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 3 vid 0x03F0 pid 0x0211
    Dec 31 16:00:08 unknown user.debug hotplug[87]: Attached USB device /proc/bus/usb/002/002 [INTERFACE=7/1/3 PRODUCT=3f0/211/100]

    .. only usb-pens (last 25 lines)
    Dec 31 16:00:10 unknown user.warn kernel: Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
    Dec 31 16:00:10 unknown user.warn kernel: sda: Waiting for disc 0 to settle.
    Dec 31 16:00:11 unknown user.warn kernel: SCSI device sda: 7936000 512-byte hdwr sectors (4063 MB)
    Dec 31 16:00:11 unknown user.warn kernel: sda: Write Protect is off
    Dec 31 16:00:11 unknown kernel: Partition check:
    Dec 31 16:00:11 unknown kernel: /dev/scsi/host0/bus0/target0/lun0: p1
    Dec 31 16:00:11 unknown user.debug kernel: WARNING: USB Mass Storage data integrity not assured, unmount it before unplugging
    Dec 31 16:00:11 unknown user.debug kernel: USB Mass Storage device found at 3. Host: 0
    Dec 31 16:00:11 unknown user.debug hotplug[120]: Attached USB device /proc/bus/usb/002/003 [INTERFACE=8/6/80 PRODUCT=930/6545/100]
    Dec 31 16:00:11 unknown user.warn kernel: MSDOS FS: IO charset utf8
    Dec 31 16:00:11 unknown hotplug[120]: USB vfat fs at /dev/discs/disc0/part1 mounted on /tmp/mnt/USB_XP_710
    Dec 31 16:00:11 unknown kernel: hub.c: new USB device 00:03.0-1.3, assigned address 4
    Dec 31 16:00:12 unknown kernel: scsi1 : SCSI emulation for USB Mass Storage devices
    Dec 31 16:00:12 unknown user.warn kernel: Vendor: CBM Model: USB 2.0 Rev: 2.50
    Dec 31 16:00:12 unknown user.warn kernel: Type: Direct-Access ANSI SCSI revision: 02
    Dec 31 16:00:12 unknown user.warn kernel: Attached scsi removable disk sdb at scsi1, channel 0, id 0, lun 0
    Dec 31 16:00:12 unknown user.warn kernel: sdb: Waiting for disc 1 to settle.
    Dec 31 16:00:13 unknown user.warn kernel: SCSI device sdb: 4110336 512-byte hdwr sectors (2104 MB)
    Dec 31 16:00:13 unknown user.warn kernel: sdb: Write Protect is off
    Dec 31 16:00:13 unknown kernel: /dev/scsi/host1/bus0/target0/lun0: unknown partition table
    Dec 31 16:00:13 unknown user.debug kernel: WARNING: USB Mass Storage data integrity not assured, unmount it before unplugging
    Dec 31 16:00:13 unknown user.debug kernel: USB Mass Storage device found at 4. Host: 1
    Dec 31 16:00:13 unknown user.debug hotplug[127]: Attached USB device /proc/bus/usb/002/004 [INTERFACE=8/6/80 PRODUCT=1221/3234/0]
    Dec 31 16:00:13 unknown user.warn kernel: MSDOS FS: IO charset utf8
    Dec 31 16:00:13 unknown hotplug[127]: USB vfat fs at /dev/discs/disc1/disc mounted on /tmp/mnt/disc1

    .. both the printer and usb pens
    Dec 31 16:01:06 unknown kernel: hub.c: new USB device 00:03.0-1.4, assigned address 5
    Dec 31 16:01:06 unknown user.err kernel: usb.c: USB device not accepting new address=5 (error=-145)
    Dec 31 16:01:06 unknown kernel: hub.c: new USB device 00:03.0-1.4, assigned address 6
    Dec 31 16:01:06 unknown user.err kernel: usb.c: USB device not accepting new address=6 (error=-145)
  85. Pay87

    Pay87 Addicted to LI Member

  86. BeHappy

    BeHappy Network Guru Member

    Found the solution after some reading for Linux USB FAQ and the usb cable is the sin, using cable from usb hdd works perfectly.

    Q: Why doesn't USB work at all? I get "device not accepting address".

    A: This can be one of several problems:

    * High speed devices sometimes have problems with cables used to connect them. They're more sensitive to signal quality issues than older usb 1.1 full or low speed devices. If the device works OK at full speed on the same system, after you "rmmod ehci-hcd", this is likely the problem you're seeing. There are a lot of things you can do to change signal quality.
    o Use a different cable. Some are even marketed specifically for use with high speed devices. Most USB 1.1 cables work just fine at high speed, but the one you're using might be an exception (maybe it's been damaged).
    o Switch to a different USB connector on your computer. Back panel connectors are often right on the motherboard, with much care taken to preserve signal quality. A front panel connector probably doesn't use cabling designed with USB in mind; and its cable could be damaged by bending, baking or something else even when it's not routed through the power supply.
    o Use an external high speed hub. Those hubs have signal conditioning circuitry that may cover up certain flaws.
    o Make sure your device is using its own external power supply, or that its battery is fully charged.
    You might be able to get the same device to work at high speed on a different machine.
  87. ray123

    ray123 LI Guru Member

    From what you said, jffs1 seems to work properly, but after it has been loaded restarting network triggers a reboot. Right? I'll look into it.

    [update:] Which build? I only have a 520GU, so can only load the LITE build---but that one has jffs1 turned off. I can fix that easily, but want to mimic your setup as closely as possible to duplicate the problem. How many EBs in the jffs?

    [update]: Can't duplicate the bug. Here's what I did.
    Tweaked LITE build to load jffsv1 and trim out a couple other fs's to get 3 EBs. Flashed that.
    WEB-GUI -- ENable jffs w/format.
    cp /bin/rstats /jffs
    service net restart

    then various combinations of service jffs2 stop & service net restart & service net start
    No problems.
  88. CBC888

    CBC888 Networkin' Nut Member

    I just realized that FTP no longer works on build 47. I keep getting the following error:

    230 Login successful.
    ftp> dir
    200 PORT command successful. Consider using PASV.
    150 Here comes the directory listing.
    426 Failure writing network stream.

    I do not recall if I tried FTP during the brief lifetime of build 46, but I do know that it was working perfectly on build 45 with the exact same hardware and settings... :confused:
  89. teddy_bear

    teddy_bear Network Guru Member

    There were no changes between 45 and 47 that could affect FTP connections, and it still works here - from LAN and WAN - with no problem.
    So it's either a new issue or configuration change on your end, or - very likely - you're just trying to connect from your LAN using external WAN address...

    Instead of "service net restart", try to save settings on the Basic->Network or Advanced->Wireless page - it does more than just restarting the "net" service, and that's how I ran into the issue for the first time. I only tested it on the Asus RT-N12 with Std build (to compile Std with JFFSv1 replace "NO_JFFS=y" by "JFFFv1=y" in the Makefile).
    If you won't be able to reproduce the issue, I'll experiment with it more and get a console output when I get a bit more time - probably next weekend...
  90. weizhengphotography

    weizhengphotography Networkin' Nut Member

    ASUS RT-N16 and cable modem frequent rebooting


    Just got this modem and installed DD-WRT on it. I can't say it is DD-WRT's fault, but the combination of this router, DD-WRT and the cable modem (Motoroal Surfboard SB6120) are just not working out.

    First, it is pretty slow for new connections. Every new web page took several seconds to open. This is most likely DD-WRT's problem as after I switched to Tomato Teddy Bear, this problem is completely gone.

    Second, after initial connection (I mean, reboot modem, reboot router), things are working for a while, then all of a sudden, the modem will reboot (I think it is rebooting based on its indicators) very often, as often as every 5 or 10 minutes, most likely to happen when I open a new web page. Same with Teddy Bear Tomato. This never happens before with my old router (Linksys WRT54GL). WRT54GL has been rock solid and the modem may fail less than once a week (maybe some are real connection failure due to external issue).

    I am a programmer myself and I know that the modem shouldn't just reboot just because it recives some bad packets from router. However, I really don't want to waste $ on modem and this modem has decent review on Amazon. The experience with the other router tells me that if the router behaves itself, things should work fine.

    Has anyone experienced similar problem? Anyone has any kind of clue what is going on here, or how I can inspect some logs/packets or what ever to pin point the culprit? or this router and the modem just don't come together?

    And I managed to find a little more information about the modem from its log:

    Ranging Request Retries exhausted;CM-MAC=00:21:1e:d9:6f:15;CMTS-MAC=00:1d:45:70:6c:b8;CM-QOS=1.1;CM-VER=3.0;

    Unicast Maintenance Ranging attempted - No response - Retries exhausted;CM-MAC=00:21:1e:d9:6f:15;CMTS-MAC=00:1d:45:70:6c:b8;CM-QOS=1.1;CM-VER=3.0;

    No Ranging Response received - T3 time-out;CM-MAC=00:21:1e:d9:6f:15;CMTS-MAC=00:1d:45:70:6c:b8;CM-QOS=1.1;CM-VER=3.0;

    Cable Modem Reboot due to T4 timeout ;CM-MAC=00:21:1e:d9:6f:15;CMTS-MAC=00:00:00:00:00:00;CM-QOS=1.1;CM-VER=3.0;

    No Ranging Response received - T3 time-out;CM-MAC=00:21:1e:d9:6f:15;CMTS-MAC=00:1d:45:70:6c:b8;CM-QOS=1.1;CM-VER=3.0;

    T6 Timeout and retries exceeded;CM-MAC=00:21:1e:d9:6f:15;CMTS-MAC=00:1d:45:70:6c:b8;CM-QOS=1.1;CM-VER=3.0;

    REG RSP not received;CM-MAC=00:21:1e:d9:6f:15;CMTS-MAC=00:1d:45:70:6c:b8;CM-QOS=1.1;CM-VER=3.0;

    I checked this website:
    It gives the definitions of the T2, T3, T4 and T6 timeout. However, since the modem almost never had any problem with WRT56GL, I am wondering if anyone has any clue what configuration I can change to avoid the problem?

  91. CBC888

    CBC888 Networkin' Nut Member

    I am connecting the same way that I always have, which worked in the past until 47 beta 16.

    I tried clearing the NVRAM, flashing with 47 beta 15 and setting up only the FTP - it worked!
    I tried clearing the NVRAM, flashing with 47 beta 16 and setting up only the FTP - it does NOT work - same error as in my previous post!?! (Login works and I can hear the USB drive spinning up, but I cannot even do a simple dir listing let alone transfer files.)

    I think that it is a new issue, although I do not understand why it works for you... :confused:

    Anyhow, I am back on build 47 beta 15 for now, since FTP is something that I use quite frequently...
  92. JayP146

    JayP146 Guest

    Pretty simple question:

    I'm running v1.23.8625 ND USB Std. Router in question is an ASUS WL-520gU.

    I'd like to mount an NTFS formatted USB-connected external hard drive (FAT mounted 16GB flash drives work just fine). Tried it already and got a "Failed to mount. Verify the device is plugged in, and try again" message.

    Do I just need to upgrade to the newest version of Tomato? Or is the newest build of the ND USB better?

    Please forgive my n00bishness. Thanks in advance!
  93. Polaris75

    Polaris75 Networkin' Nut Member

    Sorry if this has already been asked or answered ... I tried to read the entire thread but I got about 2 hours and 25% of the way into it :)wink:) and gave up ...

    I know how to build Tomato and have built working images before - this question is about Tomato USB specifically, and 2.6 more specifically - should I be building in src or src-RT? And what Machine Selection and CPU Selection should I be selecting in the Kernel config for MIPSR1? Specifically, a WRT54GL. I'm really interested in playing around and building custom so I can dump the stuff I don't need (and play around with v6 if it's in so much as a partially working state), but I'm REALLY afraid of bricking my router beyond a simple TFTP restore if I build for the wrong CPU. I know what the right options for a WRT54GL are in the 2.4 config, but things appear to be different for 2.6.

    Thanks! :)
  94. teddy_bear

    teddy_bear Network Guru Member

    To build K26 image, make sure you download sources from tomato-RT branch, and run make in srt-rt directory.
    Run "make help" for the list of pre-configured targets. You don't need to configure the kernel - it will be configured by make depending on target selected.

    For WRT54GL you need to choose one of the MIPSR1 targets. For example, "s" to build "Std no-USB" image.
  95. Polaris75

    Polaris75 Networkin' Nut Member

    Awesome! Thanks so much!! :)
  96. Polaris75

    Polaris75 Networkin' Nut Member

    D'oh ... I ran off and started building so quick that I missed a pretty important part of this until I re-read it while waiting for the build to finish -

    Does that mean if I go into the router directory, do a 'make menuconfig' and enabled/disable stuff (IPv6 for example), that those changes will be overwritten when I do a `cd ..; make s`? That would defeat the purpose of me building a custom image :frown:

    Edit - nm, I think I figured it out after picking through the Makefile :) - I'm doing `make bin` with all the S options and then my changes, i.e. IPV6SUPP=y, NO_ZEBRA=y, etc. ...
  97. Polaris75

    Polaris75 Networkin' Nut Member

    lol! I bricked it. TFTP doesn't even seem to be working ... I'll play with it more tomorrow ...
  98. nguyen

    nguyen Addicted to LI Member

    I have nslookup problems. Firmware: Tomato Firmware v1.27.8747 ND USB Ext. OS: Windows 7 32-bit. I set "Domain Name" to When I try to run:


    Non-authoritative answer:

    Is this a normal way to show host name?
  99. harman

    harman Networkin' Nut Member

    fresh install

    Hi guys, this is my first post, and firts of all thanks for the great job. i have a wl500gp v2 and i have installed the teddy bear tomato firmware. it's great. my question is: i have an external usb drive with 3 partitions. 1 swap, 1 ext3 and 1 jffs. what i don't know is what should i do next? when i connect it to the router with option automount enabled, i see that all the partitions are /mnt like "folders". should i put any script so that the router recognises each partition as it is or is there anything else i should do?

    thank you for the answers. keep up the great job!
  100. ray123

    ray123 LI Guru Member

    Just make sure there is a label on each partition, and then it'll be automounted at "/mnt/LABEL".

    The swap won't get automatically activated unless you put it in /etc/fstab. But then you've got to save that to nvram.

    -OR- (best)

    Create this file called "00-start-swap.autorun" in the root directory of your ext3 partition. Obviously, change the SWAPNAME line to be the actual label of your swap partition.
    # This is 00-start-swap.autorun
    # The 1st parameter is the path to here.
    # The label of the swap partition.
    # If no parameter, complain and quit.
    [[ xx == x$1x ]] && (logger No pathname parameter [$0] ; exit)
    # Edit fstab to put the swap partition label there.
    sed -i "/^LABEL=$SWAPNAME /d" /etc/fstab
    echo "LABEL=$SWAPNAME swap swap" >>/etc/fstab
    # Then turn it on
    swapon -a
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice