Tomato ND USB Mod

Discussion in 'Tomato Firmware' started by teddy_bear, Dec 17, 2008.

  1. Victek

    Victek Network Guru Member

    But life continues and we (all) have to follow with Tomato.
  2. hrts

    hrts LI Guru Member

    I do encounter a DDNS problem: OpenDNS does not work anymore after I've upgraded my WRT54GL v1.1 with Tomato 1.28 ND USB VPN.
    Previously I've used Tomato 1.19 and OpenDNS worked flawlesly.
    As soon as I've upgraded to Tomato 1.28 ND USB VPN (image from site) I get the follwing error:

    Last Results: and time .......: Unknown error (404). (1/3: Automatically retrying in 16 minutes)

    I didn't change anything from 1.19 cfg: I have the same user, same password and same LABEL (Network) for OpenDNS. I am using OpenDNS for a single network (very simple setup).

    Technical details:
    WRT54GL v1.1, Tomato 1.28 ND USB VPN (, PPoE, No-IP (working), OpenDNS, OpenVN (working)
    I am using 2 DDNS services: no-ip (working) and OpenDNS.
    Open DNS is the first DDNS service defined.
    Use as DNS is checked: Current DNS:,
    I've put to DNSMASQ since Tomato 1.19 the following parameter: strict-order. I've checked without it but no positive results.
    Last Results: and time ...... : Unknown error (404). (1/3: Automatically retrying in 16 minutes)
    Force next update does not change the status. Neither leaving a trace in the logs :( (the loging is setup to be verbose - "at maximum")
    OpenDNS has a single Label (network) defined. The label is entered in Tomato DDN interface (along with the user and password)

    OpenDNS client worked in the past 2 years over 1.19 and I would like to get some help to make it run again in 1.28.

    Thank you!

    By using nvram set debug_ddns=1
    I gotOpenDNS log file at /tmp/mdu-opendns.txt log:

    GET /account/ddns.php?hostname=YGH&myip= HTTP/1.0
    User-Agent: MDU - Tomato Firmware 1.28
    Authorization: Basic aHJ0c2dvZ3U6X1lvMyxjY3A=

    HTTP/1.1 404 Not Found
    Date: Wed, 19 Oct 2011 16:17:46 GMT
    Server: Apache
    X-Powered-By: PHP/5.3.6-12
    Set-Cookie: OPENDNS_ACCOUNT=760345787c2070476d8a13eaa87d7304; expires=Fri, 18-Nov-2011 16:17:46 GMT; path=/;
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Vary: Accept-Encoding
    Content-Length: 7477
    Connection: close
    Content-Type: text/html

    Update 2: reading a post on openDNS forum I've noticed that the update URL has changed from "/account/ddns.php?hostname=" with "/nic/update?hostname=".

    I've moved back to Tomato 1.19 and my ddns log uses "/account/ddns.php?hostname="

    Could it be this the reason ( /account/ddns.php?hostname=) why my Tomato firmware does not work?

    How cand I change "/account/ddns.php?hostname=" with "/nic/update?hostname=" in the OpenDNS setup from a Tomato Firmware?

    Temporary workarround applied:

    I've used Custom URL:
    https://[my Username]:[my Password][my OpenDNS Network Label] &myIP=@IP
    It works!
    So Tomato firmware has a wrong URL?

    Update on 8th May 2012
    I revert my setting to standard settings for OpenDNS (no more custom URL) and it works!
    What in the happening with OpenDNS? It accepts again /account/ddns.php?hostname= requests? I'll keep an eye on it!
  3. Nick

    Nick Networkin' Nut Member

  4. hrts

    hrts LI Guru Member

    Go to the Basic/DDNS meniu on your Tomato.
    Please select as DDNS provider "Custom URL" (instead openDNS that is now selected).
    You will get a space to enter a custom URL like this:

    1.Please replace above my_openDNS_Username with your username (account) used to logon on OpenDNS website
    2.Please replace above my_openDNS_Password with your password associated with above username (account) used to logon on OpenDNS website.
    3. From OpenDNS website, Settings area ( please find your OpenDNS LABEL (is the name you gave to your network!). Use this Label instead of my_OpenDNS_Network_Label above.

    Last but not least :
    Also, on the Tomato DDNS setup page, the first setting named "I will use IP Address:" should be "Use WAN IP a.b.c.d (recommended)" option. This is needed to work the last part of the custom URL string: to pass to OpenDNS server your IP as it is known by the router TCP/IP stack.

    Somebody on OpenDNS Forum ( ) suggested that I can get rid off last part of the custom URL string (erase "@myIP=@IP") but to do that I have to use "Use external IP Checker" on the field "I will use IP Address:". Didn't tried this combination:)
  5. Nick

    Nick Networkin' Nut Member

    Thanks For your response, i used the custom URL and it work fine for me, i did entered it without the @myIP=@IP and it stil workes fine for me.

    thanks for your help.
  6. Toastman

    Toastman Super Moderator Staff Member Member

  7. andy

    andy Addicted to LI Member


    I have a problem in using tomato-NDUSB-1.28.7628.1-Toastman-Ext.trx :
    I have WL-520gU routers with VPN (optware, not VPN build). I have been using T-B's mod (2.4 & 2.6) so far no problem. However after I upgraded the VPN client router to tomato-NDUSB-1.28.7628.1-Toastman-Ext.trx, the PCs behind the client router cannot ping the VPN server router, while the VPN client router can. It seems that this command "iptables -t nat -A POSTROUTING -s -o tun1 -j MASQUERADE" does not function in this build.

    If I install tomato-K26USB-1.28.7821MIPSR1-Toastman-ND-Lite.trx to the VPN client router, this problem disappeared. PCs behind the VPN client can reach the VPN Server side.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    OK, noted. I'll probably make a new K24 build soon, and hope the problem goes away. As you probably noted from the readme files, I don't use the older routers any more and the K2.4 firmware is pretty much untested and WYSIWYG. However, since it's based on the same code it theoretically ought to work ... but sometimes bits of it doesn't. :(
  9. andy

    andy Addicted to LI Member


    Thanks for your quick response, and thanks for your work.

    One more bug (maybe), the firewall script runs twice in both tomato-NDUSB-1.28.7628.1-Toastman-Ext.trx (K24) and tomato-K26USB-1.28.7821MIPSR1-Toastman-ND-Lite.trx (K26).

    I have to do it this way :
    line=`iptables -L INPUT | grep "udp dpt:1194"`
    if [ -z "$line" ]; then
    iptables -t nat -A PREROUTING -p udp -d $WANIP --dport $VPN_PORT -j DNAT --to $LANIP:1194
    iptables -A INPUT -d $LANIP -p udp --dport 1194 -j ACCEPT

    I have WL-520gU x 6 and WL-500gpV2 x 1 working in different locations, so I should use these old routers for some period of time.
  10. x7007

    x7007 Networkin' Nut Member

    Hi, if i have E3000 and i want to get the TomatoUSB TeddyBear mod newest there is, that works without bugs and stuff, and has support for IPV6, which one should i download ? ( i saw that TeddyBear Mod has more connections , support for IPV6 (-How to enable ? ) and many more tweaks.

    *Currently i have 1.28Beta installed - tomato-E3000USB-1.28.9054MIPSR2-beta-vpn3.6 from Tomato Main site.
  11. hrts

    hrts LI Guru Member

    After fixing OpenDNS today I've discovered that No-IP DDNS service is telling me that my host will expire:

    Your free host, will expire in 7 days due to account inactivity. was last updated on 2011-10-20 16:12:48. Free Dynamic DNS hosts must be updated via our website or dynamic update client every 30 days to prevent them from being removed from our system

    I've checked my Tomato router and there the last update was 6 days ago. I also did forced a new update, it worked fine but the website continues to tell me that last update was on 2011-10-20.

    The only way to have the No-IP host updated on the website was to reboot the router. As soon as i rebooted it the website took in consideration the host update from my router.

    What is wrong? Tomato says "DDNS No-IP update ok" and says "will expire soon". And in fact the update works only at startup (rebooting the router)
    Any solutions?
  12. andy

    andy Addicted to LI Member

    I just bought a Belkin F7D4301 with Gigabyte network, installed Tomato Firmware v1.28.7487 MIPSR2-Toastman-RT K26 USB VPN-NOCAT, everything works fine.

    The NIC of my computers are 100M, so I'd like to know if I can config the router's Gigabyte network to work at 100M (by command or optware) to reduce power consumption.
  13. Catalin

    Catalin Addicted to LI Member

    Want to save 1 watt?
  14. Toastman

    Toastman Super Moderator Staff Member Member

    The router already auto-negotiated to suit your LAN speed ...
  15. andy

    andy Addicted to LI Member

    Yes :
    1. Environment friendly
    2. The 1 watt will finally become heat. The BCM4718 is quite hot now, I am worrying its stability during summer.
  16. andy

    andy Addicted to LI Member

    I found the RT-N16 (with the same SOC BCM4718) has a "Link down mode", is there a way to activate it ?

  17. Toastman

    Toastman Super Moderator Staff Member Member

    Andy, forget about it and enjoy ... this router operates well in countries where 45 degrees + is normal. No fan needed.
  18. andy

    andy Addicted to LI Member


    Thanks. Yes, I think I should forget it.
  19. andy

    andy Addicted to LI Member


    "tomato-K26USB-NVRAM60K-1.28.7487MIPSR2-Toastman-RT-VPN-NOCAT.trx" overclock does not work, while "tomato-K26USB-1.28.7487MIPSR2-Toastman-RT-VPN-NOCAT.trx" works without problem on the same router :

    I set the CPU freq to 500250, after reboot :

    Name toast
    Model Belkin Play Max / N600 HD (F7D4301/F7D8301) v1
    Chipset Broadcom BCM4716 chip rev 1 pkg 10
    CPU Freq 453MHz
    Flash RAM Size 8MB

    The CPU freq is still 453MHz, but the Advance->Miscellaneous still showing "CPU frequency : 500250".
    Can I set it by command line, then "nvram commit" ?
  20. Toastman

    Toastman Super Moderator Staff Member Member

    I don't know these routers. Does it even have 60K of NVRAM?

    Yes, you can always set by command line.
  21. andy

    andy Addicted to LI Member


    Tried setting by command line, also not work.

    Administration-->Configuration, I have :

    Total / Free NVRAM: 60.00 KB / 31.87 KB (53.12%)

    Also, "nvram show | grep freq" will get :
    Does it mean that the router has 60K of NVRAM ?
    Actually, I don't have a clear concept about the NVRAM, is it just part of the 8MB flash memory ?

    The reason why I want more NVRAM is :
    Using TB's VPN builds and your VPN builds (in WL-520gU, WL-500gpV2 etc), if I setup the VPN by inputting certs/keys etc. to the GUI. After saving, it always losses somethings such as some certs/keys or VPN port/subnet/netmask etc. I think this may be due to not enough NVRAM ?
  22. Toastman

    Toastman Super Moderator Staff Member Member

    Andy, your router doesn't have 60K of NVRAM, so essentially your are using the wrong build. Anything written to the NVRAM that doesn't exist will be lost. You should change build to a normal one, set up again from scratch.
  23. andy

    andy Addicted to LI Member


    Thanks for your reply.
    I have reverted to tomato-K26USB-1.28.7487MIPSR2-Toastman-RT-VPN-NOCAT.trx, everything is working fine now.
  24. hrts

    hrts LI Guru Member

    I do need your advice on DDNS (again aparently). This this is about NO-IP: the No-Ip website does not recognize the update from Tomato unless is done at reboot or reconnect.

    Tomato does the update as instructed in "Auto refresh every: 5 days" field: I see in the field "Last results: UPDATE Successful with the date and the IP passed to no-ip website.
    But the No-IP site displays the date from last reboot/last reconnect instead of the date displayed in the field "Last results".
    Because of this, at each 30 days, my No-IP registration expires and I have to manually reboot the rooter or Disconect/Conect the PPOE in order to have the IP registered.

    Technical details:
    WRT54GL v1.1, Tomato 1.28 ND USB VPN (, PPoE, No-IP (update recoqnized by No-IP site only at rooter reboot, subsequently updates are ignored by the site), OpenDNS (working - manual configuration), OpenVN (working)

    Any ideas?
    Update: I've setup a Schedule to RECONNECT the PPOE every night until I figure out what is wrong with the DDNS update for NO-IP
  25. sarmour

    sarmour Networkin' Nut Member

    I've got a head scratcher. My router is the same as the post above (WRT54GL v1.1), with Tomato 1.28 running, PPoE, OpenDNS. I am located in Natal, RN, Brazil and have NEVER been unable to get OpenDNS to run from here. I've tried every combination I can think of, tried every forum trick, including using the custom URL for my Dynamic DNS (https://[my Username]:[my Password][my OpenDNS Network Label] &myIP=@IP) .

    Nothing seems to activate OpenDNS on our small network (6-8 systems, mix of hardwired, wireless), yet Tomato shows the OpenDNS addresses (only) under Status>Overview>WAN>DNS. I've even tried the different various OpenDNS addresses but to no avail.

    I'd love to use OpenDNS with my Tomato-equipped Linksys for many reasons, but something somewhere is overriding my OpenDNS settings, so no Stats, no OpenDNS.

    Settings under Dynamic DNS are: IP address (Use WAN IP Address (recommended), and updates show as "successful". Under DHCP/DNS Server I tried ever setting, to no avail, including "Intercept DNS port (UDP 53)".

    Tomato LOG shows:
    Dec 9 11:59:27 unknown dnsmasq[7191]: using nameserver Dec 9 11:59:27 unknown dnsmasq[7191]: using nameserver

    (another DNS from OpenDNS I was trying), so it seems it is correctly configured, yet...OpenDNS apparently does not see me or register my accesses.

  26. ntest7

    ntest7 Network Guru Member

    Your ISP may be hijacking your DNS requests.
  27. arunfriends93

    arunfriends93 Networkin' Nut Member

    Can anyone give a download link tomato USB teddy bear mod?
  28. andy

    andy Addicted to LI Member

  29. arunfriends93

    arunfriends93 Networkin' Nut Member

    Thank you for you prompt reply andy. Can u pls tell me which build to select?
  30. andy

    andy Addicted to LI Member

  31. Planiwa

    Planiwa Network Guru Member

    When No-IP says "updated" they mean "changed".
    When Tomato says "auto refresh" it means "say that it has not changed".

    When the IP address changes, No-IP thinks that the host is still active.
    When the IP address does not change, No-IP thinks it is no longer in use.

    You may find the following useful -- a workaround by nobugme:
  32. Daijoubu

    Daijoubu Serious Server Member

    Or use dyndns instead? I've setup a CNAME on my domain to point to the dyndns one so it looks better lol
  33. Pete7874

    Pete7874 Network Guru Member

    I am running Tomato Shibby build and I just noticed that in my case DDNS 2 update was executed first, before DDNS 1. Strange...
  34. hrts

    hrts LI Guru Member

    Thank you for the workarround!
    Unfortunatelly I use one DDNS for No-IP and the othe one for OpenDNS

    I've set up my router to do a disconnect/connect every 7 days and this solved my No-IP issue: at each disconnect/connect my ISP allocates me a new IP (as No-IP wants in order to consider me ALIVE).

    Note: I saw that the post was from 2008. Until 2011 No-IP worked for me even my IP was changed 2-3 times per year (I had same IP for long periods: 2-3 months). Strange to see the same problem in 2008 while for me worked until 2011
  35. ayk11

    ayk11 Serious Server Member

    where do i find the download link for
    Tomato ND USB Mod

    thanx alot
  36. ayk11

    ayk11 Serious Server Member

    how do i install tomato usb on an asus wl520gu? whenever i try is says failed?
    thanx alot
  37. miamijones

    miamijones Reformed Router Member

    Where is the download link?
  38. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Top of forum has Tomato links. Toastman, Victek, and Shibby all have updated ND mods, and there's also a link to the original TomatoUSB.
  39. timjordan

    timjordan Connected Client Member

    I have a spare Dlink DIR 615 E3 and after looking around it looks like the teddy bear mod of tomato will work on this little router. I tracked down this version tomato-K26USB-1.28.9054MIPSR2-beta-Ext.trx and tried to install it from the upgrade firmware page of the DIR-615. However it would not take it.
    Having a little experience with tomato I thought the problem was because the firmware was not in .BIN form. Does anyone know where a BIN format might be found? I have looked around for one but can not seem to find it. Thanks if you have anything to say about any of this. :)
    Last edited: Jan 2, 2016
  40. Alex Kulbachuk

    Alex Kulbachuk New Member Member

    Could you please help me with advice.
    First, i have never before worked with linux, couse i am standart "windows" user
    I have old DIR-320 A.1 version router with "tomatousb" software v1.27.8745 ND USB Ext. I specialy updated it for "home server" goals.
    So i shared "Samba" and it is working with flash drive 4 Gb good
    But when i tried to connect my "toshiba canvio desk" 5tb i got a problem - disk haven't been mounted
    HDD connected to router through hub 2.0
    I formated my HDD to next partition:
    1.swap ~ 50Mb;
    2.ext3 ~ 1Gb for opt;
    3.ext3 ~ 1Gb for data;
    4.ntfs ~ 970gb for data;
    5.fat32 ~ 970gb for data;
    6.ntfs ~ 950gb for data;
    7.ntfs ~ 880gb for data;
    8.ntfs ~ 880gb for data.
    I have read in web about this problem with solution for others routers model, but have not found solution specifically for DIR-320.
    As far as I understand all very depending from software version for model and router model core
    Please give me some note, how to fix it if it possible, or give link's to same problem with this router

    P.S. Sorry for my English
    Last edited: Feb 18, 2017
  41. pomidor1

    pomidor1 Networkin' Nut Member

  42. pomidor1

    pomidor1 Networkin' Nut Member

    hub must be an active, self-powered

    type something like this in the Administration / Scripts / Init and save

    if [! s / var / run / FIRSTRUN]; then
    echo "FIRSTRUN" >> / var / run / FIRSTRUN
    echo "LABEL = opt /opt ext4 defaults 0 1" >> / etc / fstab
    echo "LABEL = nas /nas ext4 defaults 0 1" >> / etc / fstab

    dark color singled out those things that you need to change the disk to their

    label can be arbitrary but must mount the existing directories in toamto (not allowed under mnt) have a lot of Partition ;-) but can you find so much hehe directories in toamto
    because the drives must be installed
    I tried not ntfs installed so I do not know whether you will succeed
    search for news on the subject by making the translation itself
    What you can discern the tab
    USB and NAS / USB Suport
    To use the these drives have to make them available in new tabs below or ftp, samba,
    actually even Torrent client you can with entware / opetware INSTALL
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice