Tomato not saving dynamic dns settings

Discussion in 'Tomato Firmware' started by charincol, Apr 10, 2010.

  1. charincol

    charincol Networkin' Nut Member

    I just started using Tomato on a WRT54GS V3.0 and it's great. However, when I try to put in my account settings for my DynDNS account
    and then save it, nothing happens.

    I get the please wait message for about 10 - 15 seconds and then it goes back to the DDNS settings page and shows this:

    I have tried this with both the regular Tomato 1.27 and with teddy bears' mod release 45 and neither version will save the settings.

    I also tried setting up a DNS-O-Matic account and it wouldn't save those account settings.

    Is there something I need to enable with a script or something?
  2. rhester72

    rhester72 Network Guru Member

    Very bizarre - have you tried doing a thorough NVRAM reset?

  3. charincol

    charincol Networkin' Nut Member

    Tried to erase the nvram from both the gui and from telnet using 'mtd-erase -d nvram' and it still isn't saving the DDNS setting.

    The same thing is happening with the SpeedBoost mod.

    So, plain Tomato 1.27 (latest stable), teddy bear mod (latest ND stable), and SpeedMod (120 beta release) are all not saving DDNS settigs.
  4. pharma

    pharma Network Guru Member

    Edit: Just re-read and saw you tried DNS-O-MATIC with same results. I'm currently using DNS-O-NATIC with no problem. Before this used DYNDNS and OPENDNS with no problem on a WRT54Gv4.

    Have you tried loading default Linksys firmware?
  5. charincol

    charincol Networkin' Nut Member

    Won't be able to really try that until this weekend.

    I only saw the Linksys firmware admin page long enough to erase it.
  6. charincol

    charincol Networkin' Nut Member

    Won't accept password

    I finally figured out why Tomato isn't saving my settings.

    It's not accepting my password.

    Currently I use the Passwordmaker extension on Firefox for most of my online passwords. It hashes passwords on the fly using a master password that I've chosen and the web url of the site I'm trying to log into.

    It's real handy because 1) I don't have a common website password, 2) No passwords are stored anywhere, and 3) I don't have to remember anything except a master password.

    So, the password that it comes up with for a particular website (like would be something similar to 's&>ho:De#.' and Tomato apparently isn't accepting it as a password. Same thing happened when I created a DNS-O-Matic account - the password had characters that tomato apparently doesn't like.

    When I change the password to something like 'P@ssw0rd1', then Tomato saves all the settings and it works.

    Can anybody tell me why the hell an open source project like Tomato would have character restrictions on ANY passwords it saves (particularly English ones)? This makes no F***ing sense.

    Any program, website, etc. that doesn't let you use the whole alphanumeric character set for passwords is pretty retarded in that aspect of security.
  7. teddy_bear

    teddy_bear Network Guru Member

    Tomato doesn't like '<' and '>' symbols in some fields - ddns settings included. It uses these cheracters as separators.

    It should have warned you about using invalid character though, and not let you to save it. The validation is probably missing on that page...
  8. charincol

    charincol Networkin' Nut Member

    Thanks for the answer! Yeah, it definitely did not give a warning about invalid characters.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice