Tomato on ASUS WL-500g?

Discussion in 'Tomato Firmware' started by mikester, Nov 4, 2007.

  1. mikester

    mikester Network Guru Member

    Has anybody tried this router with Tomato yet?

    I am interested in using the USB ports - if anybody has one or tried this let me know of your pros/cons with this router.

  2. roadkill

    roadkill Super Moderator Staff Member Member

    you need to compile from source and enable TOMATO_SL=1
  3. mikester

    mikester Network Guru Member

    Thanks roadkill. What does that switch enable?

    I am interested in attaching a webcam and OWFS. I am debating to butcher one of my WRT54GL's or just buying the Asus w/2 USB ports already added. Would make a cool weather station!
  4. roadkill

    roadkill Super Moderator Staff Member Member

    my guess is thats the switch for WRTSL54GS and I think it even includes NAS usb support.
    I don't think you can do much more without a proper software interface there is some project dealing with accessing USB ports via network that you can integrate...
    check functionality before killing your old ones.
  5. FRiC

    FRiC LI Guru Member

    I'm currently testing Tomato on WRT54GL's. I'm wondering if using it on an ASUS WL-500g Premium or something similar with faster CPU and more RAM will improve performance? I don't really have any speed issues with the WRT54GL right now, but I have a lot of users and have a relatively complex access restrictions list.
  6. roadkill

    roadkill Super Moderator Staff Member Member

    as long as you don't use L7/IPP2P rules/classifications you should have no problems
  7. FRiC

    FRiC LI Guru Member

    Actually, I do plan to use L7/IPP2P rules. Does using those slow down things a lot?

    Guess I would find out since I've already bought the ASUS and will be getting them later this week.
  8. FRiC

    FRiC LI Guru Member

    Hmm, I did get the WL-500g Premiums, but I'm getting an error: 'The field "http_wanport" is invalid. Please report this problem.' when I try to save the config in the Admin Access screen. Any ideas?

    (Edit) Figured it out. Apparently must specify a remote port even if remote access is disabled. Didn't remember having to do this on the Linksys. I now have 2xWL-500gP and 3xWRT54GL...
  9. elale

    elale LI Guru Member

    any progress on the support to ASUS wl-500g?

    I've tried it a bit recently, flashing Tomato to my wl500g router, and it seemed that everything was OK except for the Ethernet port. Some articles on web said it may be due to the mismatch of the switch/bridge port number.

    I'm wondering whether TOMATO_SL=1 option could solve this problem. Is there anybody trying it? If not, I'll try to set up a building environment and build from source.

  10. mstombs

    mstombs Network Guru Member

  11. FRiC

    FRiC LI Guru Member

    What's the problem?

    I've been using my two WL-500gP since November (see above post). They're running 1.11+VPN, 30+ users on either side, a lot of Internet traffic and VPN traffic.
    No problems, but I'm not really doing anything special.
  12. elale

    elale LI Guru Member

    no, what I used is not wl-500gP, but wl-500g, there's some difference between these two.

    when I flashed Tomato to wl-500g, everything runs OK, except for the Ethernet port. I can telnet to the wl-500g router via wireless link, and perform various tasks normally.

    WL-500g and WL-500B are very popular here in China, and they share almost the same hardware except the wi-fi card (one is 802.11G, and the other is 802.11b).

  13. elale

    elale LI Guru Member

  14. FRiC

    FRiC LI Guru Member

    Oops, didn't notice you don't have the WL-500gP, since the WL-500g is not officially supported. Anyway, if Ethernet is the only noticeable problem, you should porbably let Jon know (email on the Tomato FAQ page) so he can fix it, and put the WL-500g on the official support list.
  15. elale

    elale LI Guru Member

    Here's what I've got so far.

    I followed the links suggested by MSTOMBS, basically those posts mainly focused on the VLAN part. I then checked the corresponding part on my ASUS WL-500g. For comparison, I use two wl-500g routers, one equipped with oleg's customized firmware (, the other with Tomato.

    0) After flashed Tomato to wl-500g, all ethernet ports don't work, while the wireless port works. I then connect to it throught wi-fi connection. Both telnet and web go well. Thus I can conduct some experiments using telnet.

    1) Interfaces
    The result of "ifconfig" of both firmwares are almost the same, same ifname (br0, eth0, eth1, eth2, lo0), IRQ number and other flags, only one difference: oleg's firmware supports IPv6, while by default tomato does not.

    2) VLAN.
    After cmd "
    nvram show |grep vlan
    ", I got nothing.

    3) Bridges
    For cmd "brctl showbr br0", I got "br0 STP disabled", while for oleg's firmware, it's enabled by default. I'm not familiar with STP at all, but anyway, I enabled it by setting "nvram set lan_stp=1", "nvram set manual_boot_nv=1" and "nvram commit", then rebooting it. After that, the results for brctl are same with oleg's firmware, including two interfaces, namely "eth0" (switch) and "eth2" (wireless). However, after this change, the ethernet port still cannot work.

    4) Syslog
    I checked the syslog (as attched), most of them seemed OK except for some warnings, such as
    Dec 31 16:00:06 unknown user.notice kernel: 0x00000000-0x00040000 : "pmon"
    Dec 31 16:00:06 unknown user.notice kernel: 0x00040000-0x003f0000 : "linux"
    Dec 31 16:00:06 unknown user.notice kernel: 0x000e0f20-0x002f0000 : "rootfs"
    Dec 31 16:00:06 unknown user.notice kernel: 0x002f0000-0x003f0000 : "jffs2"
    Dec 31 16:00:06 unknown user.notice kernel: 0x003f0000-0x00400000 : "nvram"
    Dec 31 16:00:06 unknown user.err kernel: sflash: chipcommon not found
    Dec 31 16:00:08 unknown dnsmasq[77]: started, version 2.40 cachesize 150
    Dec 31 16:00:08 unknown dnsmasq[77]: compile time options: no-IPv6 GNU-getopt no-RTC no-ISC-leasefile no-DBus no-I18N no-TFTP
    Dec 31 16:00:08 unknown dnsmasq[77]: DHCP, IP range --, lease time 1d
    Dec 31 16:00:08 unknown daemon.warn dnsmasq[77]: failed to access /etc/resolv.dnsmasq: No such file or directory
    But those seemed not to make the ethernet interfaces stop working.

    5) Network monitor
    I then connected my laptop to the ethernet switch of ASUS wl500g, and monitored the network link using tcpdump. To my surprise, I found that I can receive the packets from the router. The packets were from two MAC addresses, one is eth0, whose packets were SSDP packets coming from upnp daemon, and the other is from eth1(WAN port), whoe packets were DHCP DISCOVERY packets since DHCP client is enabled at WAN port.

    So maybe the driver and ethernet itself are all right, but I just cannot find how to proceed to make my ASUS wl-500g work. I'v written to Jon to ask for help, and he politely told me that he did not own any wl-500g router and someone else tried this before but failed. Considering Jon would be overloaded by other high priority tasks, and wl-500g is not the mainstream product so far, thus I stop bothering him again.

    Thanks for your help.


    Attached Files:

  16. mstombs

    mstombs Network Guru Member

    If you check the Openwrt tableofhardware it seems the 500g is a mix of WRT54G v1 and newer. Maybe Tomato thinks there is an ADM6996L switch and fails to configure it? As you get both WAN and LAN traffic from the switch it does suggest it is just the vlans are not configured, but whether this can be fixed by script rather than kernel/app recompile I haven't a clue - I'm pretty sure the vlan tagging and switch operation is done at pretty low hardware/device driver level.
  17. elale

    elale LI Guru Member

    I wish it would be VLAN configuration problem, yet I cannot verify it.
    As showed above, there's no vlan related variables in nvram, probably vlan is not enabled. How can we setup VLAN and config it accordingly?

  18. tournet

    tournet LI Guru Member

    bellow is from OPENWRT:
    the link is here:
    "Note that the internal switch can not be configured through OpenWRT yet because its internally accessed using a GPIO interface instead of MII (Source). As a workaround, if you don't actually need VLANs but just want to put LAN and WAN ports in the same "VLAN", just use Linux's bridge capability, eg. in Kamikaze put in /etc/config/network :"

    Is this useful?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice