Tomato + pppoe/dns server problem

Discussion in 'Tomato Firmware' started by redcow, Dec 10, 2006.

  1. redcow

    redcow LI Guru Member


    I have a strange problem, i upgraded to tomato 1.0 and everything worked great, then since two days my internet connection acts strange it disconnected often and at the end dns resolution no longer works. I tried to downgrade to tomato 0.9 but no change, then i tried thibor15c and my connection works again.

    so my question is whats going on ? Why is the connection working with thibor and not with tomato and this only since a few days?

    In my logfiles are a lot of pppoe authentication failures and after a few minutes it connects and i get a ip adress from the server etc but the dns resolution doesnt work. If i connect direct, with the modem via windows ethernet/pppoe or thibor it works without problems :confused:


    I know i can resolve this issue entering manually a other dns server, but why this "dns server retrieving" problem ? maybe tomato gets only one dns server and thibor two, and maybe one of the two dns server is broken so dns resolution doesnt work for tomato in this case?
  2. digitalgeek

    digitalgeek Network Guru Member

    curious as I didn't even reset my nvram when I upgraded, and my pppoe works no problem...

    did you clear nvram when you upgraded... cause sometimes that helps when there are problems
  3. nsumner

    nsumner LI Guru Member

    I had a very similar (maybe identical problem). I normally get 2 DNS servers and Tomato was only getting one. I emailed the author and about 2 days later he sent me an updated copy to try which completely solved the problem.

    I don't know if I can give you the link so I would suggest you contact that author and ask him about it. I presume he will be happy to help you out and send you the link as well.
  4. katsyonak

    katsyonak Network Guru Member

    I also had the same problem and eventually I had to revert back to Thibor because of that :(
    Would love to have Tomato again when this issue is resolved.
  5. der_Kief

    der_Kief Super Moderator Staff Member Member


    try to put those two DNS server in manually in the basic configuration. Then disable "Use Internal Caching DNS Forwarder" in the advanced configuration. Had the same issue and this solved it. Maybe this helps.

  6. katsyonak

    katsyonak Network Guru Member

    I got a test version from the author. I will try it first and if it doesn't work i'll try to add them manualy and diable "Use Internal Caching DNS Forwarder".

    Thank you :)
  7. redcow

    redcow LI Guru Member

    Thanks for the suggestions, for now i use the manualy/"Use Internal Caching DNS Forwarder" way to solve the problem and wrote to the author to send me the testing firmware hoping it resolves the problem :) .

    I got the new testing firmware and now everything works great :)
  8. katsyonak

    katsyonak Network Guru Member

    Yes, the test version seem to be working fine here too :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice