Tomato Problems

Discussion in 'Tomato Firmware' started by ssss25, Oct 18, 2009.

  1. ssss25

    ssss25 Addicted to LI Member

    Hi Everyone!

    HELP! :)

    I am an owner of a WRT54GL 1.1. I was running DD-WRT without any problems. However, I switched to Tomato due to QOS on Tomato which is a lot better, and after testing it proved to work much better than DD-WRT.

    However, I have 2 HUUGE problems with Tomato!

    1- Every 2 - 4 days, it just DIES! I look at LEDS on the front and they seem ok, but not flashing as much. I then see that I have no internet at all! I cannot login or ping the router at all! I enabled syslog to see if I can see what happened but I don't see anything strange or error before it dies! The way out is to re-cycle power! That by far the biggest problem, I can shedule it to restart daily, but I am trying to avoid that so far, not sure if that will fix it either. What I tried to resolve:

    a- I had 1.25 at first, I upgraded to 1.26 latest beta, still same poblem.
    b- I did the 30-30-30 reset.
    c- re-flashed!

    All same result! one might think it's my router, but it was working without any problems of this sort with DD-WRT.

    2- My second problem, is that I have an asterisk server in my LAN. Sometimes, or after the Tomato Reset, I notice that it never connects to the voip provider. I did a lot of trouble shooting and I found out through TCP dump that Asterisk is actually trying to register, and sending out registration messages, no reply.

    I then found the following:

    Today I did a lot to find out what happaned. I found out that my VOIP server was sending registration messages from my internal IP ( to some public IP, let's say x.x.x.x.

    I sniffed on my VOIP server, and I can see the packet leaving to x.x.x.x, but no response. I contacted my voip provider they told me that they are not seeing ANY voip packets from me.

    so I went to Tomato and Installed TCPDUMP, I then sniffed ppp0, (tcpdump -i ppp0)..

    I saw that the packet that is supposed to be sent to x.x.x.x is being sent from! At first I thought that is normal, although I Expected at the PPP0 level to see my public IP and not my private IP.

    I then reset the router, and all started working again! So now that things are working, I did a TCPDUMP again on PPP0 and now I see the source to be my public IP, and not 192168.1.45!

    I now know now that for some reason the router was not translating my voip traffic out!

    Is this any knows issue, anything I can do to get you more details if this is new to you?

    Just for your information, this is a capture from TCPdump when it worked: ( is my puclic IP, is my internet destination

    # tcpdump -i ppp0 -A -n -s 1500 udp port 5060
    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on ppp0, link-type LINUX_SLL (Linux cooked), capture size 1500 bytes
    13:18:49.457443 IP > SIP, length: 563
    E`.O.A..?...B3.bC.J......;.2REGISTER REST OF SIP PACKET

    when it doesn't work, was replaced with

    The only was to fix this is to stop my server from trying to register (it tries every 1 - 2 seconds) and then after 30 or 60 seconds start it again. Then it works. I think that is when the session clears, and then I start a new one then translation works.

    Thanks a lot for any help/ or debugging I can do.

    I can simply go back to DD-WRT but the QOS sucks there! I really would like to stay with Tomato!

  2. pharma

    pharma Network Guru Member

    Try a forum search on "asterisk server". I think you will a few threads that offer suggestions.

    Which beta are you using? I believe there have been about 3 or 4 beta releases. Also use the non-ND firmware version first, and if issues persist try the ND version. I'm using the ND version and it's been rock solid!

    The latest can be found below:

    New Beta Available ...

    * Update to miniupnpd-20091010. Fixes leak.

    October 12, 2009
  3. Toastman

    Toastman Super Moderator Staff Member Member

    The following is something that has happened to me and may, or may not, be something to do with the problem you experienced. I set up a lot of port based QOS rules. One of them contained a large number of ports. It worked fine. One day I added another range of ports, and apparently broke some limit. Sudddenly several things happened. Port forwards failed or sometimes forwarded to the wrong port or even client. The remote access port on the web server disappeared. Instead of port 8080 facing the outside world, port 80 was. Also internal telnet access on port 23 also switched to the WAN. ssh access on the WAN disappeared.

    First step in recovery was to switch off QOS then everything returned to normal allowing everything to be changed back. I am just wondering if you have also inadvertantly exceeded some internal limit, maybe on rules, hostnames, whatever, as your problem is also with strange WAN behavior. Something to check out!

    Good luck!
  4. ssss25

    ssss25 Addicted to LI Member

    Thanks for your reply guys.

    I am using Tomato Firmware v1.26.1780, the latest one. Unfortunatly, after 4 days it still failed. following the instructions, I used the non ND version. The instructions says to use non ND for WRT54GL. What is ND anyways? I am afraid if I use it I would brick my device.

    As for the other suggestions, I can try that. But I am really not using much! I have IP based QOS saying that any traffic from my asterisk server are to be prioritized as highest! That is all, so I really only added 3 - 4 more QOS rules. But it's worth trying for a few days for sure.

    I check the connections count and it's usually about a 100, nothing close to the 4096 limit.

    Thanks for your thoughts.
  5. Engineer

    Engineer Network Guru Member

    ND = New Driver (IIRC).
  6. TexasFlood

    TexasFlood Network Guru Member

    You might also consider going to Tomato v1.25. Heck I'm still running v1.23 on some of my routers, just because I've run it for so long without significant issues that I trust it. My understanding is that v1.26 is a beta so -could- (I'm not saying does just that it could) have some issues not yet shaken out.

    * Update - sorry I missed in your earlier post where you said you'd tried 1.25
  7. inaninck

    inaninck Addicted to LI Member

    For your #1 problem, this is not going to help you but I just want to let you know that I have the same version but I run the 1.25 Tomato without any problem.
    Why do you use beta stuff???
  8. ssss25

    ssss25 Addicted to LI Member

    Thanks for the replies...

    I use beta because I all the problems I described happened on 1.25. Then I though maybe 1.26 fixed something specific to me. But the same issues. So I did try 1.25 and the beta...

    The most problem to me now is that the router just dies! I just cannout ping it, login to it! Just dies and I have to power reset!

    I think I might just go buy a new WRT54GL, mine is 1.1, maybe the new ones are a lot better.

  9. ssss25

    ssss25 Addicted to LI Member

    btw, how can I get this issue to the developers so they can tell me how I can debug this better, maybe more advanced logging or something? I didn't find a forum for tomato that is from the developers? Isn't this a problem they may want to know for the new version to fix if I am hitting something strange?

  10. ljohnson15

    ljohnson15 LI Guru Member

  11. landa

    landa LI Guru Member

    Have you tried 1.23 version. In my point of view, 1.23 is the most reliable version.
  12. ssss25

    ssss25 Addicted to LI Member

    Thanks for the tips. I will try the assured and noreplied timeouts changes.

    I will also give 1.23 a try... I have not tried it anything before 1.25.

  13. ssss25

    ssss25 Addicted to LI Member

    not sure if this will help anyone identify the problem... (prob #1 where the router just dies and only a power reset gets it back).

    I have a torrent client in my network that is always uploading abotu 20k during the day, and 40 at night, and at sometimes downloads. I notice that that if I don't do a lot of downloading, then the number of days that the router stays up is longer.

    the connections never reach the max, so not sure what else could be causing this.

  14. Planiwa

    Planiwa Network Guru Member


    I now have a minimalist probe that runs continually and keeps a nonvolatile log of the last 24h in /jffs (4 probes a minute):

    Connections, Free RAM, Load, Wifi users, Processes

    When the crash happens, just examine the recent log.

    You sound like you could benefit from that. Interested?

    BTW, you say "connections never reach max". How do you know?
    How do you know that connections don't shoot up by a few 1000 in a few seconds while you're not watching? :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice