Tomato RAF Releases

Discussion in 'Tomato Firmware' started by Victek, Dec 28, 2012.

  1. Victek

    Victek Network Guru Member

    Hi all,
    After some months off due to my 'real job' I had some holidays during last week and ... Tomato RAF 1.28.9013 will be ready on January 1st, 2013. Bugs like Nocat malfunction have been solved and other features have been added. So, Enjoy it .. and remember, I do it for fun and it's my hobby, don't start conquest about who's the best, simply enjoy, send me e.mail if something is wrong and wait for the next release.

    Thanks to all Tomato RAF fellows. The release will be active January 1st, 2013...
  2. mito

    mito Network Guru Member

    Hi Vicente!
    Great, al fin!
    salu2, best regards! And happy New 2013 to all!
  3. eahm

    eahm LI Guru Member

    Thanks, enjoy your holidays!
  4. Toastman

    Toastman Super Moderator Staff Member Member

    Happy New Year Vic!
  5. pzlmg

    pzlmg Network Guru Member

    Thanks Vic, and Happy New Year!
  6. myersw

    myersw Network Guru Member

    You are the best.
    Looking forward to your update.
    Happy New Year!!
  7. free2share

    free2share Addicted to LI Member

    This should be the caption line for the sticky at the top of the forum!

    I wanted to take a moment to thank people like Victek, Toastman, Shibby, and many others for their continued development, support and contribution the the community.

    Have a happy and great 2013 everyone!
  8. awesome news mate. Been visiting your site every couple of weeks hoping id see an update since August :p
  9. wizzy

    wizzy Addicted to LI Member

  10. Python46

    Python46 Networkin' Nut Member

    I am running 9013 on an E3000 now. I have not seen any gotchas yet. I plan to run it long enough to see if there are any problems.
  11. kthaddock

    kthaddock Network Guru Member

    Can you test and se what wifi-driver that build use ?
  12. Python46

    Python46 Networkin' Nut Member

    5.100 RC138.20
    wl0: May 29 2012 08:48:50 version
    jondlou and kthaddock like this.
  13. zorkmta

    zorkmta Network Guru Member

    Are there any build for rt_n66u?

    Enviado desde mi ASUS Transformer Pad TF300T usando Tapatalk 2
  14. Victek

    Victek Network Guru Member

    I don't have RT-N66U yet... and I read many strange bugs about Tomato running in this model... so, I did not release it. In few days I'll own an IPv6 net line, then I'll try to test issues about. All my builds are stable and this is my target, solid rock.

    BTW, Source code available in my site and pushing to git. To all other contributors to Tomato, share your knowledge and keep GPL rules please.
  15. shibby20

    shibby20 Network Guru Member

    Hi Vic. I was on tomato`s git page and i didn`t see any of changes in yours branches. Are you sure did you push commits to remote git?

    Best Regards and have new year :)
  16. Victek

    Victek Network Guru Member

    Hehe,, shibby, pushing, pushing ... if I can get my cert again.. in the meantime you can suck source code in my site, no problem boy, btw, did you pushed last changes ?.
    uci and siproxd from roadkill are not in the code yet .. you have to wait ;) .. be patient.
  17. adlerfra

    adlerfra LI Guru Member

    Upgraded my RT-N16 to 9013 from previous Tomato firmware using the GUI and checking the box to erase all data in NVRAM memory. After reboot, I made changes to various settings and after changing and saving the time settings, I could no longer connect to the GUI even though I still had Internet connectivity. I power-cycled the unit, and after that, the router has been purring along very nicely. Thanks, Victek!
  18. Victek

    Victek Network Guru Member

    Thanks adlerfra, I suspect some of the changes committed a WAN boot (and your PC forgot the Gateway) and you lost LAN connectivity for a while. I suggest you to clear cookies in your browser since some cache data differs from previous or other Tomato releases. Thanks to you and your comment.
  19. adlerfra

    adlerfra LI Guru Member

    Yes. I probably should have cleared cookies in my browser. I use Google Chrome.
  20. DarkFnh

    DarkFnh Networkin' Nut Member

    Great new build Victek its been running on my RT-n16 for a couple of hours and its solid so far ..
    I've been using Tomato for a couple of years now and since its 2013 ... I just want to say thanks to the tomato community for the renewed support ...
  21. Engineer

    Engineer Network Guru Member

    First, thanks and welcome back to Victek! :D

    Happy New Year also! :D

    On your download page, you have
    Tomato RAF 1.29.9013.

    instead of 1.28.9013 ;)

    Also, I don't remember much but were there versions for general routers (i.e. generic) instead of the specific routers you have listed? Sorry but I just don't remember.

    Again, thanks (to all of you)!:D
  22. Victek

    Victek Network Guru Member

    Thanks, fixed typo, 1.28-9013 is built for the listed models, can we compatible with other .. but I don't know, just tested in these routers I got temporaly from Cisco and Asus.
    Other models, please look at Language TAB on top, you will access to other models and previous releases.


    DAVIZINHO Addicted to LI Member

    Hi victek
    thanks for this great job!
    i use it on a E4200 and a FTTH line and work PERFECT!
    In this new version i can configure de virtual wireless and this is very good for me :)

    thanks for all again!
  24. fubdap

    fubdap LI Guru Member

    Victek - thanks for the new release. I have not installed it yet. I am trying to read up on it. You mentioned on your homepage that "Several important changes and new features are included." I cannot find any information on that. What are the important changes and new features? Thanks again for your hard work.
  25. shibby20

    shibby20 Network Guru Member

    Vic i always push changes to git before i release new version :) i see ysources on your website, thanks, but git i better to look what kind if changes did you make and if some of them will be intersting i would like to cherrypick them to mine branch :) im glad you come back!
  26. Victek

    Victek Network Guru Member

    *// davizinho, thanks for the info, I'll own a FTTH line 100/10 next month, it's a very and useful info for me.
    *// fubdap, main changes are inside (Busybox 1.20.2, warnings clean during compilation, nocat libexec fixed, rc/init.c and services.c rebuilt..). It will make lower CPU load and a more fluid internet navigation. I'm not using all the features in this version and I will apreciate any feedback about your experience with this release as davizinho reported.
    *//shibby, swap complete busybox, I upgraded to 1.20.2, compare dir; dns, nocat, src/makefile changes in glib to permit clean nocat function, with your version, I'm not following your branch, so, be careful with the changes. I'm handling now uci and siproxd for poweful routers in my next release. I saw you created a Polish translation, hard job!!, so, I restarted multilanguage support, do you think it will be better to include-use a dictionary file?... it will be compatible for other languages.
  27. ilkevinli

    ilkevinli Network Guru Member

    Thanks Vic for your work !!! Happy New Year !!
  28. shibby20

    shibby20 Network Guru Member

    @Vic i continued our job (remember ours thread on email) and i made full/working multilanguage version many months ago (Aug of 2011).

    My release of 075 was ML - multilanguage version:

    But only one person want to make dict of chinesse language. No volunteer to make french, german, italian, spain etc dictionary. Thread od multilanguage version hadn`t a followers, well i decided to leave multilang project and make only Polish branch. It`s not to really hard using "merge" command in git :)

    If you want re-open multilang project you have my vote and i want to help. Working branch you can find here:

    More changes (dicts updates) are in my tomato-shibby branch.

    Best Regards :)
  29. Victek

    Victek Network Guru Member

    *//shibby, I'll take a look and let's communicate via e.mail out of this thread, at least no problem for the Catalan, French or Spanish branch J:

    Thanks to others posting in this thread, It's very important to have feedback for all of us, I win and you too.
  30. zapoqx

    zapoqx Networkin' Nut Member

    I suppose I feel the need to ask...
    Does it have the multi-wifi SSID thing?
    If so, I'm all for it. I love your build and to me, it gets the job done (not a whose better war, but for me that doesn't have to research as much to make things work). That multi SSID is what I'm looking for to be honest.
  31. Victek

    Victek Network Guru Member

    Yes, it's build and compiled.. but TBH I did not tested.. would you test and feedback your findings?, Thanks.
  32. alexlau

    alexlau LI Guru Member

    wow wow! Finally!:D:cool:

    Thank you Vic! Definitely a wonderful New Year present~

    BTW, how to do the translation? I know nuts about programming, only know how to translate the words ( I guess Google Translate can do the same). Is there anything that I can help?
  33. Victek

    Victek Network Guru Member


    DAVIZINHO Addicted to LI Member

    Hello victek.

    I see a Little bug with a virtual wifi ssid.

    I have a e4200 with two wifi (one In 2,4ghz And other In 5ghz), this wifi conect with the br0 (lan principal 192.168.1.x)

    I have 2 others virtual wifi that conect with br1 (lan 192.168.2.x)

    All my machines are in static dhcp with ips In their ranges.

    If i what no see what machines are conected i can see In "device list" And i can see In WOL because a machine that is ON In WOL apears with status "active In arp"

    Ok, after this, the problem is when i conect a machine to the virtual wifi i can see it on the "device list" but not with the "active In arp" check In he WOL



    Sent from my Windows 8 device using Board Express
  35. shibby20

    shibby20 Network Guru Member

  36. Edrikk

    Edrikk Network Guru Member

    Hi Vic,

    Welcome back! Happy New Year!

    Any chance for an update to miniupnpd?

    Thanks and again, happy new year!
  37. valerima

    valerima LI Guru Member

    Victek, this is revelation of the year that you came back.
    More than happy!!!
  38. Victek

    Victek Network Guru Member

    I have been working in a new miniupnpd first quarter of last year, roadkill sent me some sources.. let me check, I don't know the status of miniupnd, something wrong?

  39. Victek

    Victek Network Guru Member

    Hehe, you wrote it in your whishes for the new year? Voila!

  40. Victek

    Victek Network Guru Member

    Understood .. I have to recreate this scenario, never tried before .... so, arping is not applied to machines connected to VSSID, right?.. Silly question but important for me to avoid caching flies, what version are you using?
  41. VirtualLarry

    VirtualLarry Serious Server Member

    Wow, thank you Tomato developers and Victek!
  42. mstombs

    mstombs Network Guru Member

    Welcome back Vic!
  43. Victek

    Victek Network Guru Member

    Thanks, just to leave first release of 2013... and I hope not the last :J
  44. mito

    mito Network Guru Member

    Vic i never saw you post so much all toghether!
    Gracias for being back, we all hope you'll keep on posting in 2013:) !
  45. valerima

    valerima LI Guru Member

    Dears, as I use Asus RT-N66u currently and wanna go to last Victek's build for this device, which firmware upgrade/flashing way would be advised: Shadowandy's or just simple via GUI upgrade function?
    While with RT - N16 last one was working perfect.

    DAVIZINHO Addicted to LI Member

    HI Vic,

    I use the versión 1.28.9013 with a e4200, if you want more info i can email you and tell you more details (In spanish because my english is poor )

    Sent from my Windows 8 device using Board Express
  47. Victek

    Victek Network Guru Member

    Please do it, I would like to go in deep about it. Thanks

    DAVIZINHO Addicted to LI Member

    Ok Vic, to be continued ;-)

    Sent from my Windows 8 device using Board Express
  49. shibby20

    shibby20 Network Guru Member

    Vic i`m trying download your sources but i have only 5KB/s speed ( i have 50mbps simetric optical cable network) :/ It will takes ~12hours :(
  50. kthaddock

    kthaddock Network Guru Member

    I have download it. I can upload to you ?
  51. Victek

    Victek Network Guru Member

    Well .. since all posts from January 4 till yesterday are gone .. I ping again this thread, please test 9013 release 1.0 version and write your thoughts, thanks.
  52. bimmerm3m5

    bimmerm3m5 Network Guru Member

    CPU usage is less on R1.0 on my e4200, and speed seems good. And yes, 0 cpu usage would mean it's off ;)

    Thanks Vic
  53. were55

    were55 Addicted to LI Member

    Hi Vic,

    so far is 9013r1.0 is working great, I installed transmission from Shibby rep (thanks Shibby) and not issues discovered yet, thanks both for great job.

  54. Victek

    Victek Network Guru Member

    Happy to read it, but ... you might have to update soon to the next release ... ;) it's in beta test now.. two weeks and 9013.R1.1 will be available .. with VoIP NAT (Siproxd) and 'another' surprise ... all my releases uses the router as it's .. a network manager, sorry if excluding other useful applications like torrent but it's not the service I expect from one router...
  55. tstrike2000

    tstrike2000 Network Guru Member

    Updated from an older version of Shibby to 9013.R1 on my E3000. It's be working very well since I flashed it yesterday. If this one is stable, I'll probably just stick with this one for a while since I don't really need too many goodies, just USB and VPN mainly. Thanks again Vicente on all the time you've put into it.
  56. alexlau

    alexlau LI Guru Member

    :cool: Cool Vic! 2013 is really an exciting year from you, :D

    Now with the active releases from Toastman, Victek and Shibby, may I safe to say
    Toastman is focused on stability;
    Victek is focused on network services/functions (and stability of course);
    Shibby is focused on more functions, lots of, all kinds of functions :D

    of course, all are great releases. I seriously think Cisco/Asus should hire you guys as consultant and have Tomato built into all routers before it's released to the market.

    BTW, anyone heard from Jonathan Zarate recently? Hope he has a great start for the year as well.
  57. zapoqx

    zapoqx Networkin' Nut Member

    I just wanted to chime in that I finally got the chance to sit down and upgrade the router... to my surprise, you had the release 1.0 (which was a good thing I did check). So I loaded it. So far, everything is working properly on my Linksys E3000.
  58. Victek

    Victek Network Guru Member

    Question to the topic follower's. I have to include one library (some of you will know soon what library is...) and I thought for the same tip I can include lighttpd (WebServer), just for routers with USB. Do you think it will be useful?, at least in my case yes but ...

    kardzzz likes this.
  59. kthaddock

    kthaddock Network Guru Member

    :) That would be nice.
  60. kthaddock

    kthaddock Network Guru Member

  61. kthaddock

    kthaddock Network Guru Member

  62. vlads

    vlads Networkin' Nut Member


    Any plans to continue support for MIPS2 based routers with 4MB flash such as the WRT310Nv2 or the M10v1? These models run great with Tomato Firmware RAF1.28.9006 MIPSR2_RAF K26 VPN-NOCAT but I could really use the new and upcoming OpenSSL/OpenVPN and TC-ATM DSL QoS enhancements.

  63. Cyrixx

    Cyrixx Serious Server Member

    I have tried the new version on my asus rt-n16 and still has the problem high sirq, bad ssh respons when downloading at 70 mb/s. The router can't reach the maximum download speed (80 mb/s). The latest good version was tomato-K26USB-1.28.9006
  64. Victek

    Victek Network Guru Member

    Yes, it will exists a build for these models in next release. ;)
  65. Victek

    Victek Network Guru Member

    Strange ... I tested with my FTTH line now .. 100mb/s down and 10mb/s upload sustained for 5 minutes, no problem. I tested in my RT-N16 also. Any change in Miscelaneous or firewall section?. Please send me log if some warning appeared.

    btw .. When you installed release 9013 .. which version? Did you configured from scratch after nvram erase?
  66. Bhope

    Bhope Serious Server Member

    Hi Victek, when will you be releasing the next build for RTn66u?
  67. Victek

    Victek Network Guru Member

    Targeted for Friday next week .. it depends on test doing now by betatester colleagues (15 worst environments... one of the sites it's a Business Center with RT-N16 and 320 users 24/24). I don't know a better way to test firmware .. ;)
    Till today 15 tickets... mainly in wireless authentication (iPhone) and UPnP....
  68. Bhope

    Bhope Serious Server Member

    Hi Victek, OK thanks, look forward to it!
  69. Cyrixx

    Cyrixx Serious Server Member

    Thanks for your reply. I have tried this version TOMATO RAF 1.28.9013 Release 1.0 ASUS - RT-N16 VPN-NOCAT

    Erased nvram, with default settings. Please try this when you download more than 70 mb/s check ssh response (for example top command) and admin page response and what is your sirq that time?

    I'm using PPPoE, I know that PPPoE is more cpu hungry than others, but what is the difference between the old and the new release? Is it possible to create a new build with the old PPPoE client?

    Thanks in advance.
  70. Victek

    Victek Network Guru Member

    Main difference ... many .. some of these differences are related with PPPoE, Networks drivers, DNSmasq ... a lot of differences. I'm using PPPoE also..., strange. Are you sure that no upload traffic exists?... the explanation you gave me is more oriented in a bottleneck upload than a download congestion. Would you adjust QoS to give a breath to ssh port 22?
  71. thursdaychild

    thursdaychild Serious Server Member

    The firmware version "Tomato-Netgear-3500Lv2-K26USB-1.28.9013-R1.0--RAF-VPN.chk" can not be flashed. I get the error message "File is too big to fit in MTD". Two weeks ago I also sticked with version "Tomato-K26USB-1.28.9013MIPSR2--RAF-VLAN-VPN-NOCA.trx". - Result: Same error. But I must admit, at the moment I don't know which version of the "Netgear 3500L" I have (v1 or v2). Anyway I think the error message would appear in both versions, 'cause the flash memory is simply slightly too small for this firmware.
  72. kthaddock

    kthaddock Network Guru Member

    You can identify which version you have here:
  73. thursdaychild

    thursdaychild Serious Server Member

    Okay, following to this it are WNR3500Lv1. I have 2 of them. One serves as a master-router, the other one as a repeater. Because I live in a bigger house, where only one router couldn't cover the whole area with the WiFi-signal. What a shame, that these WiFi-standards were designed so weak.
  74. Victek

    Victek Network Guru Member

    Thanks kthaddock ;), thursdaychildyou must be careful before manipulating any device, search the information and then proceed. Thanks to Tomato code we avoid to brick your router by your intrepid upgrade ...

  75. thursdaychild

    thursdaychild Serious Server Member

    Don't worry... If any of my routers bricks, I just buy a new one over eBay. They are not that expensive anymore. From 25 to 35 € you already can get one.
    But back to topic: I successfully flashed
    "tomato-K26USB-1.28.9011MIPSR2-RAF-NOCAT-NCC-VLAN-VPN-NOCAT (22-07-2012).trx" with a size of 7.540.736 bytes.
    While the firmwares
    "tomato-K26USB-1.28.9013MIPSR2--RAF-VLAN-VPN-NOCAT (01-01-2013).trx" with 7.987.200 bytes
    "tomato-Netgear-3500Lv2-K26USB-1.28.9013-R1.0--RAF-VPN.chk" with 7.766.074 bytes
    were both too big to flash. So if you would shorten the last one (for Netgear 3500Lv2) just about 200 k I guess it would fit in my MTD. And as long as the firmware is MIPS-R2 the router won't brick. It just won't work maybe not as it should, right?
  76. thursdaychild

    thursdaychild Serious Server Member

    For those who want to flash the new Vicktek-firmware (Build 9013) on a Netgear WNR3500L (checked for v1, but also for v2 I think), I tried two of the latest firmware-versions:

    Flashable is:
    "Tomato-K26USB-1.28.9013MIPSR2-R1.0--RAF-VPN-NOCAT (13-01-2013).trx" (7.659.520 bytes = 7.480 kB)

    Not fitting (too big for MTD):
    "Tomato-K26USB-1.28.9013MIPSR2-R1.0--RAF-VLAN-VPN-NOCAT (13-01-2013).trx (7.684.096 bytes = 7.504 kB)

    So the exact border for being able to flash firmware on 8 MB flash-memory routers seems to be (set by the programmer Jonathan Zarate) at 7.500 kB.
  77. Victek

    Victek Network Guru Member

    :D ... I hope you're kidding .. or send to the developpers the bricked routers.. Ok, I'll fix the compilation version size for WNR3500L

    Unfortunately some new features will be out for these routers.

  78. kthaddock

    kthaddock Network Guru Member

    That is only for WNR3500L not L2 with 128k, right ?
  79. Victek

    Victek Network Guru Member

    Sure, the restriction is just for WNR3500L v1 .. v2 is not affected, thanks for the topic.
  80. thursdaychild

    thursdaychild Serious Server Member

    THX! - Probably I will donate some money in the next time, because I really use your firmwares now for quite a long time and always was lucky with it.

    Hard, but unavoidable....
  81. zong

    zong Serious Server Member

    running 1.28.9013MIPSR2-R1.0--RAF-VLAN-VPN-NOCAT om N16 from the first day :) and still very stable and good performance. However I like more the toastman way of QOS and changed this via NVRAM commit.
    (Classification & Class). I better now, however I think it is more the rates-setting in the class which is different , not so much the classification (minor changes).
    Here is my current settings- however no longer have the "original toastman" -or "origina lRAF" basic settings.
    Can you pls show me those settings if unchanged :))

    nvram set qos_orates="5-20,5-60,5-40,5-70,20-100,5-80,5-50,5-90,5-50,0-0"

    Outbound Rates / Limits

    Service 92 - 370 kbit/s
    VOIP/Game 92 - 1110 kbit/s
    Media 92 - 740 kbit/s
    Remote 92 - 1295 kbit/s
    WWW 370 - 1850 kbit/s
    Mail 92 - 1480 kbit/s
    Messenger 92 - 925 kbit/s
    Download 92 - 1665 kbit/s
    P2P/Bulk 92 - 925 kbit/s
    nvram set qos_irates="10-100,60-100,40-100,40-100,0-100,40-100,30-100,40-90,10-40,2-10"

    Inbound Rates / Limits

    Service 2,850 - 28500 kbit/s
    VOIP/Game 17,100 - 28500 kbit/s
    Media 11,400 - 28500 kbit/s
    Remote 11,400 - 28500 kbit/s
    Mail 11,400 - 28500 kbit/s
    Messenger 8,550 - 28500 kbit/s
    Download 11,400 - 25650 kbit/s
    P2P/Bulk 2,850 - 11400 kbit/s
    Crawl 570 - 2850 kbit/s
  82. zapoqx

    zapoqx Networkin' Nut Member

    So after a while of trying release of 1.0, so far, I haven't had any complaints (THANK YOU!), but I have noticed on odd times that the internet seems to lose connection. When I look at my IM's, I see almost all of them go out and then start coming back on within 30 seconds after. At the same time, my network hesitates for a brief moment. This seemed to happen on IPv6 tunnel enable so I tried taking that off (By this point, it was Thursday). It seems fine after that, but late at night when I'm not awake, sometimes I wake up with 2 or 3 IMs being off due to time outs according to its status windows. The only time I have the router reboot is on Sunday mornings so I'm a bit confused at to would even lose connection unless its the modem, but I'm just mentioning because it just started to happen.
    It is possible about connection load as well (as I'm technically still new to networking in comparison to many of the helpful people here) as I have a network switch in my room that has a Wireless G Buffalo router connected to the switch for wireless G only connections and the switch is also connected to the Linksys E3000 that is the main handling of everything. Again, it could be just me so I guess we'll see on your projected next version.
  83. Victek

    Victek Network Guru Member

    Well, Thanks zapoqx, I'm also confused by your explanation 'cause I can determine clear evidence .. but please set debug level to 3 in your router and pass me the log. I also noticed that base source code we (all coders and variations of Tomato) are using has been modified (middle last year) and 'somebody' installed ignore switch to avoid crash errors during compilation. :confused: then... I can wait random glitches from some modules .... are you working via PPPoE ?.

    Roadkill and myself we're working on it. Thanks.
  84. AmyGrrl

    AmyGrrl Network Guru Member

    Thanks! I just flashed Tomato Firmware v1.28.9013 MIPSR2-R1.0--RAF K26 USB VLAN-VPN-NOCAT to my Asus RT-N16. All appears to be working with no issues. I was having an issue with IP Traffic and UPnP not working at first. So I reflashed the firmware. Cleared the NVRAM again and this time held down the reset button. All appears to be working after doing this. Thank You!
  85. Victek

    Victek Network Guru Member

    AmyGrrl ... thanks for testing the firmware, I would say .. it's a 'health exercise' to clear nvram always, specially if you're swapping releases from different coders .... just erase nvram through the option in Administration/Configuration it's enough if you missed it during the update/upgrade. Longlife for the Flash RAM.
    BTW .. to the coders .. beware with lots of 'nvram commit' found in the source code... it's needed? I'm concern what I'm finding boys....:( pfff...

    Thank you all for the comments!
  86. zapoqx

    zapoqx Networkin' Nut Member

    @Victek: So far its been behaving itself actually. No random disconnection which leads me to believe it was either a ISP connection issue or a server issue (The former being more possible due to how they had a recent hour long service interruption). No, I'm actually in DHCP mode. In fact, I've never come across PPPoE ever in my lifetime of using broadband networking. I just set it and I'll see if I can get a download going.
  87. zong

    zong Serious Server Member

    hai guys,
    no longer happy with my defined QoS limits. Can somebody give me the original /default settings for
    qos_orates and qos_irates. Or screenshoot of basic settings with assigned limits. THX
  88. shibby20

    shibby20 Network Guru Member

    can you explain Vic?
  89. Victek

    Victek Network Guru Member

    No, it's not the place .. open PM.
  90. philess

    philess Networkin' Nut Member

    Hi everyone, i am new here and new to TomatoUSB.

    I am running a E4200v1 with v1.28.9013 MIPSR2-R1.0--RAF K26 USB VLAN-VPN-NOCAT
    Victek Mod. Just want to take this opportunity to say THANK YOU VICTEK! :)
    Everything is working great so far, i had the 9013 on it early January, now updated
    to the R1.0, with NVRAM reset etc.

    I just noticed one tiny bug in the webinterface i guess.
    The BW Limiter seems to ignore if you have multiple LAN bridges set up and complains
    about the IP being out of range.

    I have 2 LAN bridges set up (one for my own network, second to use VLAN/Guest-WLAN).

    br0 with DHCP range (thats my personal LAN).
    br1 with DHCP range 192.168.40-60 (for Guest WLAN).

    Now if i want to limit all clients in my Guest WLAN, i would enter 192.168.1-254 as
    a range to be limited, but i get that warning that its out of range... I can still click
    save tho. Last time i did that crashed the router and it rebooted with default fw config.
    Might have been a coincidence tho, crashing at that time.

    Edit: Oh and i tried to find a away to disable/enable the virtual wireless interfaces through
    a script (assigned to AOSS button etc), but i couldnt really get it to work. Either i would
    toggle the whole radio (wl_radio) or i would disable a vif, but it would still be broadcasting
    its SSID. How can i achieve toggling the VWLAN´s in a script in the same way that the
    web GUI does it?
  91. Victek

    Victek Network Guru Member

    Hi philes, thanks for the comments, my answers:
    _ Yes, BW limiter was conducted to run one interface.. we have to extend it to others subnets. I'm working on it.
    _ Yes, this behaviour (crash and reboot) it's known (I read some complaints in another versions), RT-N16 it's more resistant due to bigger RAM but it crash also. The code was patched and some bugs have left, these bugs are related with buffer overflow when manipulating nvram values without type of descriptor.. we have to patch again. -pedantic option was deleted in package build to ignore these errors... and you suffer the consequences.
    _ Second issue, it's known, unfortunately when you 'play' many VLAN you can't go back and need to perform a factory default and start again. Another ticket pending to solve.

  92. kthaddock

    kthaddock Network Guru Member

    You can delete VLAN jya fixed that a while ago.
  93. philess

    philess Networkin' Nut Member

    Thank you Victek for the quick and helpful reply.

    I will keep on trying to get to disable my guest WLAN through a script,
    it has to be possbile somehow :)
  94. kthaddock

    kthaddock Network Guru Member

  95. Victek

    Victek Network Guru Member

    Do you think so? .... it's not solved depending on router model... ;)
  96. valerima

    valerima LI Guru Member

    Dear Victek, I see as promised: new build today at your site.
    ...But still no for Asus RT-n66U?
  97. Victek

    Victek Network Guru Member

    I would like to test in one RT-N66 before release... or to buy one used unit... ;) do you own the RT-N66?
  98. M0g13r

    M0g13r LI Guru Member

    hi Victek

    have an rt-n 66u, i can test 4 u if u want
  99. valerima

    valerima LI Guru Member

    sure, I can participate in testing...
  100. kardzzz

    kardzzz Addicted to LI Member

    I can't wait to see lighttpd included in the next release. I'm running 1.28.9006 on a E3000 and was looking at adding a webserver via optware. If your release makes life easier to configure a webserver i'll wait because my knowledge of unix/linux is very basic.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice