Tomato RAF Releases

Discussion in 'Tomato Firmware' started by Victek, Dec 28, 2012.

  1. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    the wireless seems to indicate 2.4ghz has 300 mbps

    and the 5ghz has 108 mbps

    o-o; hm... under overview
  2. guyee

    guyee Reformed Router Member

    Okay, I was right. When pinging from the SRX with VLAN tag 3, this is what happens:

    root@unknown:/tmp/home/root# ./tcpdump -i vlan3 -n
    tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    listening on vlan3, link-type EN10MB (Ethernet), capture size 68 bytes
    19:58:35.864431 arp who-has tell
    19:58:36.464423 arp who-has tell
    19:58:37.364836 arp who-has tell
    19:58:38.472767 arp who-has tell
    4 packets captured
    8 packets received by filter
    0 packets dropped by kernel
    arp requests with no replies... even though vlan3's IP address IS

    root@unknown:/tmp/home/root# ifconfig vlan3
    vlan3      Link encap:Ethernet  HWaddr 94:44:52:AF:91:7D
              inet addr:  Bcast:  Mask:
              RX packets:2430 errors:0 dropped:0 overruns:0 frame:0
              TX packets:394 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:113922 (111.2 KiB)  TX bytes:18124 (17.6 KiB)
    now what?... :D
  3. szpunk

    szpunk LI Guru Member

    @Victek, tomato-RT-AC66U-1.28.9013-RAF-V1.2ra.trx broke openssh-sftp-server function? I use sftp manager route files always, today i upgrade to 1.2ra, i can not connect route with sftp, scp is ok.

    I install openssh-sftp-server for sftp connection, after i installed, it will "takeover" dropbear automatic when i use ssh connect to route's console, use ps command i can see some sftp-server process running. But i lost this "function" after i upgrade to 1.2ra.

    I downgrade to 1.2n, is fine~~
  4. Victek

    Victek Network Guru Member

    I checked new dropbear only with ssh .. may be you're right ... I'll test with sftp now but nevertheless previous version have big security issues as you can read in the changelog. Yes 1.2n is using old dropbear. May be openssh needs also to be updated to live with this new version? .. or dropbear should be patched again with sftp module...

    Edit: OK,I found the issue.. new dropbear hardcoded to another path to run sftp-server .. Thanks for the bug reporting.

    @szpunk you have one new version for RT-AC66U now with path to /opt .. test and report problem solved or not, thanks
    Last edited: Oct 24, 2013
    Elfew likes this.
  5. RonV

    RonV Network Guru Member

    Hey Victek,

    Have to stay on version "q" for the rest of the week. Need to keep the network running so I can pay my bills ie. "Do my day job". Anyway I will be around this weekend for more testing. I am sure you will be beyond "r" by then.
  6. szpunk

    szpunk LI Guru Member

    @Victek , 1.2rb is ok!
  7. CowMix

    CowMix Addicted to LI Member

    Hey Victek,

    Did you ever get a chance to look at the QOS bug I reported a while ago? I discovered this morning that if the router reboots while I have QOS enable the router will fail to start as well. I had upgraded to n recently so I can't remember if this happened on older versions because I never tried rebooting the router with QOS enabled.

    Thanks :)

    EDIT: You did fix it, it turns out the issue was IPv6 not working with QOS. I'll leave IPv6 disabled for now.
    Last edited: Oct 24, 2013
  8. MrJman

    MrJman Serious Server Member

    Jumbo Frames work on the E3000 with Tomato RAF Version 1.28.9013 release 1.2. I reported earlier that it did not but continued to investigate. System problems were forcing the MTU to 1500 bytes so I never really tested JFs. Comodo CIS Firewall is the culprit and removing it allowed passing of 9000 byte JFs between my DT and LT. Thanks and enjoy, John.
  9. guyee

    guyee Reformed Router Member

    Hi Victek,

    I think I managed to get somewhere... and found a bug. :) the MAC address of vlan3 is the same as vlan1. Maybe this is what causes my issues. I tried to change that manually, I was able to get to a point where arp replies were seen in tcpdump on the router, but the packages never left the router, the connected device didn't receive anything.

    But it may be my fault, maybe I haven't changed the mac address everywhere.

    I wanted to set the MAC address in the nvram so that the interfaces get the right address on boot, and set the lan1_hwaddr variable.

    root@unknown:/tmp/home/root# nvram show | grep lan1_
    My issue is that both vlan3 and br1 has their original MAC address:
    root@unknown:/tmp/home/root# ifconfig | grep HWaddr
    br0        Link encap:Ethernet  HWaddr 94:44:52:AF:91:7D
    br1        Link encap:Ethernet  HWaddr 94:44:52:AF:91:7D
    eth0      Link encap:Ethernet  HWaddr 94:44:52:AF:91:7D
    eth1      Link encap:Ethernet  HWaddr 94:44:52:AF:91:7F
    eth2      Link encap:Ethernet  HWaddr 94:44:52:AF:91:80
    vlan1      Link encap:Ethernet  HWaddr 94:44:52:AF:91:7D
    vlan2      Link encap:Ethernet  HWaddr 94:44:52:AF:91:7E
    vlan3      Link encap:Ethernet  HWaddr 94:44:52:AF:91:7D
    What should I do to assign a static MAC to lan1?

  10. MatteoV

    MatteoV Networkin' Nut Member

    Sorry for the delay! Yes, that's written that way in the changelog:

    Inviato dal mio Nexus 4 utilizzando Tapatalk
  11. Victek

    Victek Network Guru Member

    No, I didn't fix the QoS .. cause I don't use QoS... it's a pending job for tomato.... @Toastman is the person who handled QoS since long time ago, address him.

    I'll not upgrade, too many jobs for one person only, let's hope the job of other devel's ... ;) you can ask @shibby20 for plans to upgrade.

    You can set another MAC ... we talk about virtual interfaces. You can communicate with the author of VLAN for tomato for more investigations about it @teaman

    You can try to change vlan3 value ... simply create same MAC as vlan2 have (WAN) ..
    vlan2 Link encap:Ethernet HWaddr 94:44:52:AF:91:7E
    vlan3 Link encap:Ethernet HWaddr 94:44:52:AF:91:7D

    nvram set vlan3_hwaddr=94:44:52:AF:91:7E
    Last edited: Oct 24, 2013
  12. MatteoV

    MatteoV Networkin' Nut Member

    Don't worry.
    If you want...there's a working binary somewhere on the internet, I sent the link last time. It's actually fueling my e4200 so it's really working and tested!

    Thank you

    Inviato dal mio Nexus 4 utilizzando Tapatalk
  13. Victek

    Victek Network Guru Member

    The binary is not the solution, one of the good things for the GPL is to build the module in order to control and enhance firmware features. Tomato is using few built modules. If you can use another version and it works then wonderful, use it !
    MatteoV likes this.
  14. Victek

    Victek Network Guru Member

    Release RAF v1.2s in Beta area for listed routers:

    -E800,E900,E1200v1, E1200v2, E2000, E3000, E4200, RT-AC66U, RT-N16, RT-N53, RT-N66, Netgear ....

    -SFTP bug corrected.
    -dnsmasq updated to V2.67 + patches.
    -dnscrypto strict-order disabled for faster dns resolution.
    -toolchains: Fix lookup with DNS search domains when res_init() is used in multi-threaded application.
    -kernel ipv6 patches.

    -* stable version.
    riley0, Edrikk, szpunk and 2 others like this.
  15. shibby20

    shibby20 Network Guru Member

    done. I compiled new version successful. Will push sources to git after few tests.
    MatteoV and Elfew like this.
  16. Elfew

    Elfew Network Guru Member

    You should cooperate more... maybe this is the first step?

    Mainly with modules and its updates... it would be nice!

    Thank you
    nurofen likes this.
  17. Ric

    Ric Network Guru Member

    E4200v1 using 6rd Relay here. Not able to enter 6rd Prefix Length 28. Get error "The field "ipv6_6rd_prefix_length" is invalid. Please report this problem."
    Victek likes this.
  18. Victek

    Victek Network Guru Member

    Ric, I understand the configuration was working in previous version? (r or ra) right? please confirm to start seeking what changed in dnsmasq or in the gui, I use static6in4 .. it works.
    Last edited: Oct 26, 2013
  19. Ric

    Ric Network Guru Member

    It was working in r. Didn't get a chance to try the ra.
  20. Victek

    Victek Network Guru Member

    I think it never worked with /28 in any tomato version cause it's a bug in the code (I checked r version and the bug exists since year 2011) ... enter all other parameters leaving /32 prefix, then, enter via telnet in the router and write:

    root@unknown:/tmp/home/root# nvram set ipv6_6rd_prefix_length="28"
    root@unknown:/tmp/home/root# nvram commit
    Commit... done.
    root@unknown:/tmp/home/root# reboot

    It's a temporal solution while I patch code, thanks ;) .. I'll code one version for you in few minutes!!!! ...

    Edit: @Ric new version for E4200 (sa) to test allowing 6rd /28 prefix lenght, please test and comment your findings.
    Last edited: Oct 26, 2013
  21. Ric

    Ric Network Guru Member

    Thanks Vic. Downloading now.

    Downloaded. When updating via the GUI I get the following message:

    JFFS2 is currently in use. Since an upgrade may overwrite the JFFS2 partition, please backup the contents, disable JFFS2, then reboot the router

    I don't have JFFS enabled at all.
    Last edited: Oct 26, 2013
  22. RonV

    RonV Network Guru Member

    Trying to download "s" this morning and getting 404 file not found. Looked in the directory for the 1.3 builds and there are no "s" versions there....
  23. Victek

    Victek Network Guru Member

    Sorry, I uploaded the version to release t for two reasons, There is one bug when including code for rt-ac56u affecting jffs2 partition as Ric mentioned. The solution for it is to replace the actual firmware using ftp tool for linksys, uploading with version t.
    The next change I patched 6rd to accept /28 prefix length, @Ric I figure you entered the prefix in one previous version I patched and since then you updated for each version without problem, I forgot to include the patch again and it could be the reason for warning with s version.

    New versions (t) are uploading now ...

    Edit: If it helps here is the link and instructions how to recover from a bad version:
    Last edited: Oct 26, 2013
    nurofen likes this.
  24. Bhope

    Bhope Serious Server Member

    Hi Victek,

    Upgraded to version t and only got 32k NVram??

    Rtn66 file
  25. Victek

    Victek Network Guru Member

    What version did you used? ... there are two versions distinguished by the 32K or 64K figure in the file name. What model do you have?

    Edit, Ok, I saw you edited .. let me check again if I built it correctly ...
    Edit 2: I checked the 64K file for RT-N66U in another router and the unit shows the correct nvram (64K). It's your first upgrade to tomato or just one update?
    Last edited: Oct 26, 2013
  26. The Master

    The Master Network Guru Member


    Have the same Problem as Ric:

    JFFS2 is currently in use. Since an upgrade may overwrite the JFFS2 partition, please backup the contents, disable JFFS2, then reboot the router
  27. Victek

    Victek Network Guru Member

    If you upgraded version s then yes, flash the new version using the ftp tool and instructions how to in the link I answered to @Ric. If you have ASUS router you can use also the restoration firmware tool.. as you like. I always use the Linksys tfptp tool for any router.
  28. The Master

    The Master Network Guru Member

    Ah Sorry dont see the edit of the Post :( my bad.

    But i have one Question. How could i check if "FAST NAT" is enable???
    I have sometimes 100% Load @Asus N-16 @100/10Mbit. Thanks.

    "_ Fast NAT auto enabled when QoS is disabled."
  29. Victek

    Victek Network Guru Member

    ctf is only enabled in Speedtest version, not in RT-N branch.
  30. Elfew

    Elfew Network Guru Member

    It is not enable in normal version? Because I have better throughput... and it is not placebo effect because I make notes for every build which I flash on my unit...

    Is possible to auto enable fast nat when QoS is disabled? Because I dont use QoS and it could be really useful
  31. The Master

    The Master Network Guru Member

    Then this is a typo?

    Hopefully i could Update my N-16 from the S Version :(

    Last edited: Oct 26, 2013
  32. Bhope

    Bhope Serious Server Member

    I just upgraded from stable V1.2
  33. Victek

    Victek Network Guru Member

    My mistake ... I built for another model ... (hopefully it did not break anything) ... I'll upload revised version in few minutes (ta release for your model), sorry for inconveniences.
  34. Bhope

    Bhope Serious Server Member

    No problem thanks
  35. RonV

    RonV Network Guru Member

    Darn, I just got done flashing and configuring my RT-N66U with "t"...seems to be working...haven't turned on IPv6 yet. Do you think I could just flash "ta" without setting NVRAM?
  36. Victek

    Victek Network Guru Member

    Yes, you can.. no problem, I expect your scripts didn't fill nvram completely .. or might be you lost some of the scripts, curious to know...
  37. Ric

    Ric Network Guru Member

    Well, have tried the tftp numerous time, no joy. Gets a little over half way and the no response from server. Any ideas?
  38. RonV

    RonV Network Guru Member

    Nope NVRAM didn't fill up....thanks...

    NVRAM Size / Free 32.00 KB / 3960 (12.08% 
  39. Victek

    Victek Network Guru Member

    Sorry Ric, wich tftp.. the one I linked from Linksys?

    Release 1.28.9013.V1.2ta for rt-n66u ready. Again I'm very sorry for inconveniences.
  40. Ric

    Ric Network Guru Member

    Yes, the one you linked above.
  41. Victek

    Victek Network Guru Member

    OK, the the procedure is easier if you follow the description in the text file, the safest method is to use the original firmware from linksys for this model and rename the file to code.bin , then set your network card to static IP , gateway and netmask (to do it you must reset your router to default settings or erase nvram), once it's done start tftp program (if you use windows remember to disable any antivirus and firewall) as administrator, set address and set retries to 255, load file code.bin (the renamed one with the original linksys firmware) and press start. Switch OFF the router, switch ON again with the RESET button pressed and network cable connected to any LAN port, release reset button, wait for the progress bar in the tftp program to begin downloading, if 20 seconds passed without success switch OFF router and retry the same procedure. Usually it runs casually.
    Once the progress bar reached 100% wait 10 minutes without doing anything, then switch OFF router, switch ON again and restore your network card settings.
  42. Elfew

    Elfew Network Guru Member

    @Victek - could you please confirmed your answer related to QoS and fast NAT?
  43. Victek

    Victek Network Guru Member

    As it's known the activation of QoS and other features in Tomato (iptraffic, access restriction, ethernet port monitor....) provokes a bottleneck in the router BW increasing the sirq value in the CPU (software interrupt request) and herewith restricts the packet inspection and filtering.
    In the RT-N versions I build the attainable download speed is something better in tests done by some users and posted in this forum versus other versions. In order to clarify the difference and translated to human language I have to say ... 'don't use the QoS and other extended features in tomato if you want to maintain a feasible Bandwidth speed'.

    If your connection have a download speed higher than 200Mbps I recommend you to download Speedtest version. ;)

    This is what I tried to say in few words.... but now I hope it's more extended.
    koitsu likes this.
  44. RonV

    RonV Network Guru Member

    Hey Vicktek,

    No go on "ta" for my RT-N66u. I have tried 3 times to configure and each time I turn on IPv6 I ended up with a un-responsive router or the router went into reboot loops. I did my normal configuration of IPv4 stuff first, everything configured by MAC address:

    • Basic network settings
    • Static DHCP
    • QOS
    • Web Server
    • Administration
    • DNS
    • Access Restriction Rules
    After those setting I would verify IPv4 and ever thing checked out, on the to IPv6 settings:
    • Disabled QOS
    • Disable Access Restriction Rules
    • Enabled IPv6 Prefix Delegation with IPv6 DNS addresses from OpenDNS
    With say 30 seconds on saving the IPv6 the internet would be un-reachable but the router pingable. Then it went into a reboot loop where the router was only pingable for about 15 seconds before the reboot happened again.

    After the 3 tries I have now back to running your 1.2 release version. I couldn't find a way to capture any information from the router due to the short reboot cycle. :(
    Last edited: Oct 27, 2013
  45. khris972

    khris972 Networkin' Nut Member

    Same Here
  46. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    whats new in T o_o; ?
  47. Victek

    Victek Network Guru Member

    Thanks, yes ... latest merge of dnsmasq and code for new models provoked conflicts, I'm now reverting to a stable dnsmasq version as I had for 1.2r, seems it gives overall best results.

    Correct bugs, nothing special for your case.

    @Ric have you been able to recover your e4200? If not send me a PM and I'll send you specific tools to do it.
    Last edited: Oct 27, 2013
  48. Ric

    Ric Network Guru Member

    Still not recovered. PM sent.
  49. Victek

    Victek Network Guru Member

    Answered with instructions.

    Release 1.2u ready to install ... as usual only for few models, others upon request. Enjoy!
    Last edited: Oct 27, 2013
    Moogle Stiltzkin and nurofen like this.
  50. nurofen

    nurofen Serious Server Member

    I correctly Upgrade your Firmware?
    Current Version: 1.28.9013 MIPSR2-RAF-V1.2s K26 USB>>>>> 1.28.9013MIPSR2-64K-RAF-V1.2u :)
    Or better through the restoration firmware tool?

    Edit: Upgrade through restoration firmware tool! :)

    Why did you come back to the old version PPOE?
    RP-PPPoE plugin version 3.10 compiled against pppd 2.4.5

    Thanks for the answer.
    Last edited: Oct 27, 2013
  51. Seal

    Seal Network Guru Member

    Same problem here as Ric...E4200 wont take any kind of reflashing
  52. khris972

    khris972 Networkin' Nut Member

    Thanks you Vic , Release 1.2u works fine :) great work ... FIXED
  53. Victek

    Victek Network Guru Member

  54. RonV

    RonV Network Guru Member

    Up and running...all settings working under IPv6 except for QOS which we all know by now...needs work. Thanks for getting this out....
  55. Victek

    Victek Network Guru Member

    Yes .. I'm learning nftables, I'm confident this is the way to work with networking, many recognized voices assumed already.
  56. alexn

    alexn Reformed Router Member

    Hi Vick. I installed the 1.28s for the e2000.. got a nice handy brick.. my light is flashing blue.. I tried to recover with previous version of 1.2a.. and tried official from linksys.. but still cant revert.. is there a fix for this? I have tried tftp and putty with the instructions above given.. with no luck. Any help would be great. Thank you.
  57. Seal

    Seal Network Guru Member

    All read and tried...closest i got to what looked like a reflash was a "System is busy" message in telnet.
    Plainly i admit im out of my water here regarding telnet flashing and what i might be doing wrong...any idea towards a script/chain of commands that will accomplish the reflash?
    PS:The 3500l script linked in tools for reprogramming only accepts the wget part on my E4200 it seems.
  58. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    I don't particularly use QOS, because i usually run my internet things to the max. Something about throttling my torrent speed just doesn't sit right with me :p lol.

    Anyway, if Toastman is doing a nice job with qos, why not migrate his QOS implementation into yours ? I think he does that from other authors if i'm not mistaken. Saves you time from this, so you can focus on other parts :] just a thought.

    You're probably bored of this question, but whats new in the 1.2u ? Or simply put, is it to do with ipv6 ? Because my area will get it sometime around Dec, so i'm interested to know your progress with the firmware in regards to ipv6 implementation :]

    Atm i'm using Tomato RAF Firmware v1.28.9013 MIPSR2-RAF-V1.2t K26 USB which to me seems very stable. So before i move onto 1.2u, i think i'll stay on 1.2t for a while to see how it goes :X
  59. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    I just read up on the nftables history. Pretty interesting read. Lots of promise, but seeing as it's new i wonder how it will perform :X
  60. Victek

    Victek Network Guru Member

    I upgraded my E4200 doing the following (do it at your risk).


    mini version of dd-wrt for E4200.
    and patience ....

    enter in your e4200 v1 by telnet
    mtd-erase -d nvram
    mtd-erase -d linux
    now your firmware is gone... then you can do two things ... upload the dd-wrt mini version to any internet file service and then download into the router using wget command... and then
    mtd-write -i name of the firmware file -d linux
    then ... once finished ... patience ... wait no rush ....

    Once rebooted choice the new firmware to upgrade ...
    Last edited: Oct 27, 2013
  61. Victek

    Victek Network Guru Member

    @Moogle Stiltzkin 'u' version is one update of ipv6 portions and tests, not easy to be done when I have no access to all different implementations of ipv6. It's the way of improving and testing the firmware what helps next step. It contains also code for coming models....

    About nftables, it's more than promises... hours to study, test and fail ... it's life, some people live life in the beach, some learning ....
  62. Ric

    Ric Network Guru Member

    enter in your e4200 v1 by telnet
    mtd-erase -d nvram
    mtd-erase -d linux

    Must set IP address to for tftp on boot. Connected right up and loaded "Tomato RAF Firmware v1.28.9013 MIPSR2-RAF-V1.2u K26 USB" with no problem at all. Following the reboot, reset NVRAM via Admin/Config and reconfigured all from scratch. All is back online and running smooth so far.

    Thanks for the help with the recovery Victek.
  63. Seal

    Seal Network Guru Member

    E4200 revived and operational again.Thanks a bunch Victek and Ric
  64. Elfew

    Elfew Network Guru Member

    I will get IPv6 in 3 days so I have a small question - which features are compatible with IPv6?
    - BW limiter, BW monitor, IP traffic, QoS, Access restriction

    Thank you
  65. Victek

    Victek Network Guru Member

    All except QoS, BW limiter and Access restriction fix by MAC address.
    Elfew likes this.
  66. Elfew

    Elfew Network Guru Member

    Ok thank you. ;)
  67. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    Is your ipv6 implementation taking this into account ? I take it that once ipv6 is enabled in the router firmware, it will do the appropriate firewall settings for IPv6 ?

    just trying to understand how this works :X
  68. Victek

    Victek Network Guru Member

    Tomato code for ipv6 firewall is implemented, you can see the code in ... from where did you copied this comment (wKkaY) not registered in this forum ?...
  69. Victek

    Victek Network Guru Member

    Sorry for delay, I saw your post after reading all page comments, please follow Ric's procedure in this post.
  70. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    different forum. they're doing ipv6 migration for our isp, so there is an ongoing discussion about it.

    Sadly it seems most of the users use the crappy default dlink 615 router, or with dd-wrt :/ no tomato users other than me sadly lulz... 320
  71. Victek

    Victek Network Guru Member

    Ok, as far you posted in PM tomato works for you after the unstable connection/disconnecting problems but your ISP admitted that there is no ipv6 in your area yet... so, no rush ..

    By the way.. ipv6 firewall test in Tomato RAF... you can see my answer in their topic .. I think there is a lack of knowledge in some post opinions...

    Last edited: Oct 30, 2013
  72. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    Found the issue.

    plugged in a ethernet into a wrong port thus creating a loop :/ that was causing the disconnection.

    But my issue was the microtik port 2, was plugged back into the btu port 2.... which was wrong :p

    Anyway i can do the ipv6 test sometime december so till then :}
  73. Edrikk

    Edrikk Network Guru Member

    Hi Vic,

    I saw someone else post this before as well...
    Just tried to upgrade from "s" to "u" on an E3000, and got the following error message:
    "JFFS2 is currently in use. Since an upgrade may overwrite the JFFS2 partition, please backup the contents, disable JFFS2, then reboot the router "

    I don't use JFFS.

    So I went into the JFFS page, *enabled* it, 'formatted', went back, 'disabled', saved, rebooted. Tried flashing again... same message...

    Any idea as to how I can flash? Seems I'm blocked.

    [Edit] found your tftp instructions and will try that [/edit]

    [edit 2]Ok, took a long while but back up and running... tftp scared the crap out of me because it seemed not to work, until one time it went 50% and died... I assumed 50% meant it had erased but not written... :/
    Anyways, mtd_write to the linux partition was the only way to get out of that situation.
    [/edit 2]
    Last edited: Nov 1, 2013
  74. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    i'm using U now on e4200v1. Works fine :X i use cifs though...
  75. Victek

    Victek Network Guru Member
  76. danyxp

    danyxp Reformed Router Member

    Victek, thanks for the raf versions, they worked magic for my old e4200v1. Got me from 90 to 240 mbps on pppoe.
    I'm looking around for a tomato version for d'link 868 L, the official firmware can't do more than 385 mbps on a 1000 pppoe connection. I bought it hoping the hardware will sustain gigabit, I was expecting 900+ but nope...
    Seeing that other routers with similar hardware have a tomato alternative, do you think it's doable for this router ?
  77. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    i'm currently doing some tests for my NAS which has a UPNP auto setup so the router would have these ports forwarded (upnp ez mode).

    i tested this before on the NAS to the router using the firmware before and it worked. But this time around it didn't.

    Either it's the nas new firmware, or the router's which is making the upnp not forward all the services :/ (so far it's partially working, but it's not forwarding all the services ports that was specified).

    Any ideas where i should checked in my configuration ?
  78. Victek

    Victek Network Guru Member

    I think D-Link is working on it, afaik the first firmware versions had problems with dual core CPU, I think you know it uses also an ARM device, so, did you upgrade firmware? ... on latest reviews I saw this unit breaking 800Mbps iperf ...
    The architecture for this router is known and not so different as rt-ac56/68 from ASUS so I expect if we success porting tomato to ARM then 868L can be a candidate also.
    Are you able to reach 900-1000Mbps in your LAN? if yes then may be problem is in the router but first you must test your LAN hardware and settings.
  79. Victek

    Victek Network Guru Member

    UPnP it's a great advantage but also a headhache, I don't have problems with Tomato since longtime ago for normal services in my NAS services, ftp,http,torrent,ssh,... but I suggest you to use a more secure Portforward and one static IP for your NAS. Tomato it's very reliable and one of the firmware better value features.
  80. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    yeah i setup static dhcp ips for my devices :X

    i tried clearing the upnp saved port forwards, and save. i then re-ran the upnp savings, but it doesn't commit.

    Very weird :/
  81. Ric

    Ric Network Guru Member


    Just got back in town. Have a new error to look into. Seeing the following in the log file:

    user.warn kernel: wlc_print_ampdu_txstatus: txstatus 0xf163
    user.warn kernel: wlc_print_ampdu_txstatus: txstatus 0xf161
    user.warn kernel: wlc_print_ampdu_txstatus: txstatus 0x0761

    These errors result in limited internet access. Reboot of router seems to have temporarily cleared the problem. Still looking here to see what else I can find.

    - Ric
  82. danyxp

    danyxp Reformed Router Member

    Yes, I testet with fw 1.01b05 and 1.04, no difference. In lan I get transfer speeds around 100 MB/s (file copy from pc to NAS), and i think I'm limited by the hard drive (no ssd in NAS).
    I'm looking forward for an custom fw, the official is buggy, and the support from d'link is nonexistent.
    Thanks for your input.
  83. Victek

    Victek Network Guru Member

    These errors come from wireless, so, are you connected by wireless? ... set a fixed channel in the router... but in any case I can't do so much about it .. read...
  84. Ric

    Ric Network Guru Member

    Thanks Viteck. Just found that post this morning. Already changed to fixed channel and waiting to see if any other problems pop up. Also going to toy with the ipv6 again here in a bit on the 6rd connection and see how things are working.
  85. Victek

    Victek Network Guru Member

    Ok, Thanks, nevertheless I found this issue time ago and it's fixed when you set a fix channel, interested also to know your ipv6 experience ;).
  86. Ric

    Ric Network Guru Member

    Well, with AT&T 6rd implementation, results are not promising. I can pass the IPV6 test without problem (10/10), but in actual use connections appear to time-out or load very slowly. Facebook for example fails to load the full page consistently, and graphic links don't load properly. Wife not happy (lol). Not certain if the problem has to do with DNS (using OpenDNS ipv6 servers) or just the return routing. I see some dropped return packets, but haven't had a chance to trace them down yet to see if that's where the problem is.
  87. RonV

    RonV Network Guru Member

    I believe the problem is on AT&T's or Facebook's end. I was testing my U-verse for pure IPv6 by having my N66U just act as a access point and connecting native to the NVG589 RG. I then configured my DNS on my PC to be only the OpenDNS IPv6 servers. I had 10/10 with IPV6 and was able to connect to most known IPv6 sites with no issues. Facebook was the exception. It would load but none of the graphics loaded properly. At one point all my YouTube video's would start to play and just stall out but then they just started working again.

    When I went back to the IPv4 DNS in conjunction with the IPv6 DNS on my computer the graphics would paint but very slowly. Then my last test was with only the IPv4 DNS and everything seemed to be fine.

    So my conclusion is that AT&T has some type of routing issue with their IPv6 implementation and I am not going to debug it for them.

    You may want to explore some of the other folks findings on AT&T IPv6 on both the AT&T user forums and For right now I am back to using the U version of Victek with IPv6 disabled.

    The question I have is why aren't you using prefix delegation in your configuration instead of 6rd? I guess I am assuming that your AT&T device supports IPv6 natively below you can see that since the RG is a router is already delegates so the Tomato router should continue the delegation to the LAN.

    Global IPv6 Address: 2602:306:bdae:6b20::1/64 
    Link-local IPv6 Address: fe80::b277:acff:fecf:a30
    Router Advertisement Prefix: 2602:306:bdae:6b20::/64
    IPV6 Delegated LAN Prefix: 2602:306:bdae:6b20::, 2602:306:bdae:6b28:: 
    Last edited: Nov 2, 2013
  88. Victek

    Victek Network Guru Member

    Well , facebook fails for most of testers using ipv6 with RAF version, youtube videos are working better every day in my case, at the beginning stream was staled but now I have few problems.

    If you got 10/10 then it sounds promising and if tests on recommended ipv6 test sites runs fine then you're in the good way. Only 8% of worldwide sites are ipv6 at the moment ...

    Release 1.2u runs very stable .. I'll leave some days if no urgent bugs appear, then I can release 1.3 with RT-AC56U included...
    Elfew likes this.
  89. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    This router ?
  90. Ric

    Ric Network Guru Member

    Same thing I'm seeing here Ron.

    Concur 100%. Exactly what I've experienced here.

    That's where I'm at here as well. Gotta keep the wife happy. ;)

    Not on UVERSE here. Only ADSL with PPPoE. I thought the 6rd was my only option since I don't have a static IP to work with.

  91. Ric

    Ric Network Guru Member

    I'm with you Victek. Version 1.2u has been very stable with IPV4. No problems at all unless I enable IPV6, and that's when things get a little flakey. Otherwise the router has been extremely stable with the current firmware.

    nurofen likes this.
  92. Moogle Stiltzkin

    Moogle Stiltzkin Networkin' Nut Member

    what you mean flakey ? explain >:{
  93. Ric

    Ric Network Guru Member

  94. RonV

    RonV Network Guru Member

    Yes 6rd if your IPv6 address is based on IPv4. In the U-verse world even though our IPv4 address is dynamic it never changes, going on 4 years and it was the same for me until AT&T replaced my old residential gateway with the NVG. The delegation prefix has remained the same for 3 months and if it did change using prefix delegation on Tomato would have picked it up and propagated it to my home network.

    You have to do what works in each situation. This is what is causing most of the headaches for the router companies and Tomato. There are so many variables to making IPv6 work due the implementations by the ISP's.
  95. ArtemR

    ArtemR Reformed Router Member

    Hi Victek,
    Trying to find FW with siproxd, and I can't understand which FW I should download to test it?

    I have WNR3500L, WNR3500Lv2, RT-N66U, WNDR4500.

    Last edited: Nov 4, 2013
  96. Victek

    Victek Network Guru Member

    @ArtemR unfortunately I included SIPROXD in previous releases with no feedback from anybody, No problem for me to add the package (a very good feature developed by roadkill ) in next builds.
    Elfew likes this.
  97. ArtemR

    ArtemR Reformed Router Member

    Many thanks! Looking forward to next releases.
  98. hacker3000

    hacker3000 Serious Server Member

    Hi victek!

    I got a E4200v1 with your v1.2t firmware set to 533MHz clock. Works perfectly stable since 2 weeks now.

    I read on your website that WAN-LAN max is 193 MBit/s, but I only get ~160 MBit/s (with 480MHz it's ~140) on Cable-Internet (DHCP, 200/10). I already disabled all things like BW Limiter/Monitoring, IP-Traffic Monitoring, QoS, Port Monitor, ...

    What's the actual status on max WAN-LAN throughput? Should I get more?

  99. Victek

    Victek Network Guru Member

    Yes, you must get higher speeds, disable the following features if you enabled, webmonitor, iptraffic monitor, ethernet port status, access restrictions, QoS and test again with stock clock. Added features increase CPU sirq and cut performance. You can update also to 1.2u version in:

    From today it's the only download page in the web, all other options has been merged into this page.

    Also you can try this version for E4200, it's built for >250Mbps speeds ..

  100. hawkmat

    hawkmat LI Guru Member

    Hi Victek! I have an odd problem. One of my AP's will not get the date and time.
    I'm using 1.2U
    All units are RT-N66U, Router and access points.
    One AP will not get the date and time.
    I have done a hardware reset and a configuration reset and no luck.
    I have reinstalled the firmware and typed in all settings by hand and no luck.
    Time is set up the same on all six units.
    What could be causing this?

    ModelAsus RT-N66U
    ChipsetBroadcom BCM5300 chip rev 1 pkg 0
    CPU Clock600 MHz
    CPU Load0.99%
    CPU Load (1 / 5 / 15 mins)0.00 / 0.00 / 0.00
    Date & TimeNot Available
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice