Tomato RAF Releases

Discussion in 'Tomato Firmware' started by Victek, Dec 28, 2012.

  1. mpegmaster

    mpegmaster Addicted to LI Member

    Welcome to the 'AZG' Apple Zombie Generation... :cool:
  2. Victek

    Victek Network Guru Member

    The results I'm getting are confused, some routers are working fine, other have some issues with known bugs (miniupnpd, QoS, I think the first users didn't use these modules or did not noticed the malfunction yet..) and others like KGB-7 have serious problems as he describe.

    RMerlin, we are working in team (shibby and me with sporadic help from roadkill due to lack of time .. as almost all of us) with same code, different model but same platform and very slight differences, all my code is in the git.

    The begining for each new model and in this case for new platform is difficult, what's confuse me are the disparity of the feedback, so, I'll stop releasing public betas and if someone is interested to test the firmware please PM with the model you have and I'll answer with the link to download. At least I can follow who's using RAF ARM release because now I don't know what release do you use, the model you own and the problem you have.

    I have both routers (RT-AC56U sent by Asus and RT-AC68U bought from my pocket because the donations don't allow me to buy one router ...), both units are working since two weeks now and I flashed from Ausus original firmware with Asus restoration utility, my configuration is PPPoE+IPv6 tunnel (one unit) and DHCP (other unit). I cleared nvram using the tomato gui menu to do so, that's all.... and it works.

    I appreciate the feedback, but let's organize a little bit to see clear water in this disparity of opinions and behavior.


    Edit: I'm not asking you for donations if you understood in my post, the beta version has been loaded by 185 users... and I got two donations ... ;) .. I do because it's my hobby and I learn also. So, few problems I read compared with the downloads ... so, I'll restrict and ask for feedback from now on.

    The other people asking for EA6700, EA6900, R7000 ... If I have one router we can try, without it it's a big risk for you to try Tomato.
    Last edited: Apr 1, 2014
    ilkevinli and Elfew like this.
  3. lilstone87

    lilstone87 Serious Server Member

    Well I understand the work and such you guys put in for tomato, so I appreciate it all, and have run tomato on multiple routers I have owned. I currently have a R7000, and want to run tomato on it as much as anyone. One of the main reason I like tomato, is it's QoS, and I understand that's something that is currently not possible. As it does need some time, and effort put in first.

    Also I understand the donations are not active enough for you guy's to support certain router's currently. So some people just don't understand this, or don't want to understand it, which I find sad. At this point, just seeing the work you guy's are putting in with ARM makes me happy. As I know there is a good chance sometime in the future there will be support for router's like my R7000.

    Also I find it smart on your part, not to try building firmwares for router's you don't have one to test on properly. As we all know early build's will have many problem's, that will require a unit to use to figure out. Plus no need in taking the chance on bricking more router's over not being able to test like needed. An as we all know the netgear routers aren't like the newer Asus routers, in which are pretty hard to totally brick.
  4. pena1348

    pena1348 Networkin' Nut Member

    It's a v1
    Where can I send the CFE so that the whole world will not see it ?
  5. Victek

    Victek Network Guru Member

    Send me a PM with the link where you uploaded the file, enough.
  6. roadkill

    roadkill Super Moderator Staff Member Member

    First of all I would like to explain that adding another CPU arch for an existing project is in most cases harder than building from scratch as the guys who are using the beta already noticed we maintained the Tomato look and feel but it became much snappier, Hopefully we'll be able to release a stable version soon as this becomes more stable by fixing issues we come across on a daily basis.

    Secondly this is all done as volunteers and none of us is a professional developer we also make mistakes so bare with us as we have more exciting plans for Tomato as this is my own favorite platform and I personally have invested a lot of time into it and I don't see myself quitting anytime soon.

    Third those issues some of you are experiencing could be due to variations in the hardware as we are still unaware of exactly how many models exists for each router and we are limited in models that we can get our hands on but I'm confident we'll get to stable build eventually one bug at a time as both Victek and I are pushing towards it as we can.

    If any of you have the developing skills required and is willing to contribute from their time please contact us there is much to be done in order to achieve our plans for Tomato.

    Sent from my iPhone using Tapatalk
  7. The Master

    The Master Network Guru Member

  8. Mohnish

    Mohnish Networkin' Nut Member

    First of all, thanks to the team for bringing Tomato to these routers. Effort much appreciated (donated to Shibby in the past; shall be donating to Victek this time as a token of appreciation).

    Ok now, I have got TomatoRAF on AC56U. Working well except that I cannot issue the following command anymore while setting up optware:

    ... nvram setfile2nvram /etc/fstab ...
    It gives "... usage: nvram [get name] [set name=value] ..." error as if the command is incorrect!

    What changed? Is there some other way to commit file to nvram now? Any other alternative to commit modified fstab?
  9. Victek

    Victek Network Guru Member

    command is not implemented yet, you can use winscp meanwhile, fstab is accessible.
    Last edited: Apr 3, 2014
  10. noyp

    noyp Network Guru Member

    finally got my usb to serial ttl, firt order of business after gettng into the CFE prompt is checking http_passwd and this is the encoded passwd "$1$X/Vc3hCN$vSbO4zSKp.CbKj167.RCA1", was able to login in gui and reset nvram.
  11. Victek

    Victek Network Guru Member

    ;) congrats, let's follow then..
  12. godraab

    godraab Networkin' Nut Member

    Any new RAF version coming for RT-AC68U based on the new source code? I want to test if possible.
    Last edited: Apr 3, 2014
  13. desiromeo

    desiromeo Addicted to LI Member

  14. Victek

    Victek Network Guru Member

    @godraab I'm looking sources, in my poor opinion they fixed a temporary patch (not a solution) for one issue (CTF+PPP+IPv6) connection, I didn't see noticeable changes. I'm looking in another direction with better improvements over the source code we're handling and kernel 3.xx.x ..
    Marcel Tunks likes this.
  15. kIssGlaY

    kIssGlaY Networkin' Nut Member

    CTF+PPP+IPv6 still in ASUS latest beta, no fix at all. Maybe the source you are looking at is slightly newer than the binary.
  16. Victek

    Victek Network Guru Member

    That's why I wrote 'temporary patch (not a solution)' ... when the third variable is not gathered then it crash.. about time stamp of sources and binary.. don't know, but as I wrote and you confirm (I was waiting your experience on it ;) ), it looks not fixed yet ..
    Last edited: Apr 3, 2014
  17. godraab

    godraab Networkin' Nut Member

    So if I disable IPv6, my connection will be more stable?
    Now I have constant disconnects/freezes/reboots.
  18. kIssGlaY

    kIssGlaY Networkin' Nut Member

    Disable CTF or disable IPv6 tunnel, just FYI. Maybe this is not the cause of your freeze/disconnects.

    BTW, Vik, just saw a new FW airing, gotta try that and then report back.

    ASUS RT-AC68U Firmware version
    Security related issues:
    1. Fixed remote command execution vulnerability
    2. Fixed cross site scripting vulnerability

    1. Added universal beamforming to enhance the wireless speed for non 802.11ac devices
    2. Fixed IPTV related issues.
  19. Victek

    Victek Network Guru Member

    Nice, they are working hard to solve it, please test and feedback.
  20. Victek

    Victek Network Guru Member

    What IPv6 connection mode do you own? .. I have HE tunnelbroker and works stable.
  21. kIssGlaY

    kIssGlaY Networkin' Nut Member

    Problem persist.:(

    BTW, you don't have such problem? PPPoE + HE V6in4 tunnel + CFE works stably for you?
  22. godraab

    godraab Networkin' Nut Member

    My ISP uses 6rd Relay, but disabling IPv6 did not help, the connection still went down. It stayed up only one hour before it froze. I had to switch back to my older RT-N66U router.
    How do I disable CTF?
  23. Victek

    Victek Network Guru Member

    I have it disabled.... yes.. I have the same problem as you.

    Advanced/miscellaneous and click off CTF box. Do you own heavy traffic or special configuration scripts?
  24. godraab

    godraab Networkin' Nut Member

    No, not much heavy traffic, and no scripts. But I have a lot of connected devices. And one thing, that makes the router crash is my iphone5, as soon as it leaves the WiFi-coverage, the router goes down, and when I get home from work, and the iphone5 goes into WiFi-reach, the router goes down again.
  25. Victek

    Victek Network Guru Member

    Makes sense the issue with Iphone5, I got the same problem. A kernel panic event is generated in the router OS pointing to wireless section. I'm investigating it .. good info, Thanks!
  26. RMerlin

    RMerlin Network Guru Member

    Symptoms matches the random reboot issue reported with 4561 - many users were triggering it with their iDevice. 4887 resolved this issue.
  27. Guzel

    Guzel Network Guru Member

    Ac56 tomato same small problems
    PPTP vpn= speedtest 62/62 nice speed, but when I download file get 3MB/s max
    5Ghz=80Mhz dosent work, have trade to reset nvram and change to different country
    iphone/ipad = drops connection when I youse FaceTime after 1 h and I can't connect back to Wifi
  28. Victek

    Victek Network Guru Member

    Don't worry about vpn / pptp ... we (roadkill is leading it) are working in another solution.
    5GHz... solved, thanks for the information.
    idevices.. patched and testing ... since the problem occurs after some period of time I'm testing it since 12 hours... let's see.
    roadkill and desiromeo like this.
  29. Victek

    Victek Network Guru Member

    Will release Tomato RAF ARM 9014-v1.3b for ARM routers (RT-AC68U/R, RT-AC56U today, changes:

    - Phy patched to RGMII (Reduced Gigabit Media Interface), improvements in WAN-LAN, sirq dropped -50% (23% CPU Load for 100Mbps) please test with 1Gbps, I'm very interested to know the stability.
    - Exploit vulnerability Port 445 patched.
    - Wireless iDevices reboot the unit. Have been tested for 24 hour and no reboots. Please test.
    - Users EA6900, I need the nvram dump since the CFE.bin don't have nvram contents, please PM with the link to download, thanks.

    Elfew and kIssGlaY like this.
  30. godraab

    godraab Networkin' Nut Member

    Installing now
  31. Elfew

    Elfew Network Guru Member

    I am looking forward! Thank you and others devs who make Tomato better for your work! Keep it!
  32. teh_g

    teh_g Networkin' Nut Member

    Does this have the UPnP changes in it?
  33. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    do u have an R7000 Victek?
  34. alexlau

    alexlau LI Guru Member

    I remembered Victek mentioned that his unit is a ASUS RT-AC56U.

    Not to worry, what Victek is doing now is digging through a tunnel to the new ARM world. Once it's done, endless opportunities will be made available...;)

    Aplausos, Vic!
  35. Victek

    Victek Network Guru Member

    No, I'm waiting shibby's push in the git after users feedback.

    No .... I do not, but would like to have it ;)

    @alexlau, thanks, with the new router and 128MB Flash I wonder what to include, except Photoshop ;)
  36. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    me too lol, and a wrt-1900ac . i think u should email linksys and tell them if they want good open source for it they should send you one ;) netgear might also send you one, have you tried asking? i tweeted at linksys for you.
  37. Victek

    Victek Network Guru Member

    I think they know if they visit the forum ... and I know they do ;)
  38. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    so there giving you one? if so thats awesome, might be able to sell off my rt-ac66u to get one when tomato works on it
  39. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    I never expected CTF support to be again in the hands of Tomato devs, maybe we will get proper support in the MIPS branch also. I know the CTF check box still exists in some builds but at least the builds I've tried didn't load anything when checkbox was checked.
    I mainly used Toastman and Shibby tough... :(
  40. godraab

    godraab Networkin' Nut Member

    tomato-RAF-ARM_9014v.1.3b, froze before an hour was gone. Restarted froze again, this version is unusable for me. It even took down my IPTV, which comes straight form the modem??
  41. Victek

    Victek Network Guru Member

    Ok, I send you a PM with one small change let's see...
  42. Guzel

    Guzel Network Guru Member

    AC56 tomato 1.3b M Air 2013

    5GHz=80MHz dosent work

    E. CTF
    5Ghz/40Mhz,WPA2=280/310 after 6h 242/301
    Wan-Lan 879/790

    D. CTF
    Wan-Lan= 315/326
  43. Victek

    Victek Network Guru Member

    Thanks, What wireless adapter do you own? I have USB-AC53 and 80MHz works.. weird.
  44. Guzel

    Guzel Network Guru Member

    I have the macbook Air 2013 AC, think is brodcom.
    AC56- it dosent show in the menu Overview 80mhz it shows 40mhz only
  45. Victek

    Victek Network Guru Member

    Screenshot from 2014-04-07 23:15:11.png ? ..

    Please try to set parameters in basic menu... should work. For a better test don't associate any device and look that 80MHz is shown, then connect your laptop.. if it drops to 40MHz then your wireless device is not supporting 80MHz or distance, obstacles don't allow to reach top synchronization.
    Last edited: Apr 7, 2014
  46. Archmage

    Archmage Reformed Router Member

    I will post this here just in case somebody else had the same problem I had: What ever you do DO NOT flash Tomato directly from DD-WRT using the in-built DD-WRT firmware upgrade. It took me 3 hours to fix it.. you will have a login that shows up saying DD-WRT and no known login/password will work. Asus Firmware Restoration Utility will not work and would fail after 79% was reached.

    Its some sort of conflict with the with the double NVRAM.. to fix it you need to:
    1)Unplug power, push and hold in the reset button and plug the power back in. Hold until the power light on front blinks off. Then wait a minute or two.

    2)Unplug power again, push in WPS button on the side of the router, plug the power back in while holding the button. Continue holding the button in for a minute or two.

    3)Unplug power again and then plug it back in. Wait for router to reboot.. once rebooted try accessing it normally. A login screen should appear saying "TomatoRAF". Login/Password is the standard admin/admin.
  47. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Many of us have done the same thing. It's buried in the FAQ. You need to retrieve the http password from dd-wrt before flashing Tomato because of the different way it is stored. I believe the command is nvram get http_passwd or you could just set it using nvram set http_passwd
  48. Victek

    Victek Network Guru Member

    The problem is you can't access cli mode neither cause it request you the login and password stored in dd-wrt format...., pushing WPS button while Power ON and wait till Power LED flash seem the best solution before you use serial tag to clean nvram...
  49. noyp

    noyp Network Guru Member

    exactly what happened to mine, i use serial tag just to get the encoded http_passwd in CFE when all other methods didnt work
  50. Guzel

    Guzel Network Guru Member

  51. Victek

    Victek Network Guru Member

  52. Guzel

    Guzel Network Guru Member

    It dosent work
    in channel it shows auto only, when I select 80Mhz
  53. Victek

    Victek Network Guru Member

    Weird.. what's your model name? ..

    Screenshot from 2014-04-08 11:30:55.png
    Screenshot from 2014-04-08 11:31:25.png
  54. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    That's why I said it should be done before flashing Tomato.
    How to use WPS on power on to clear NVRAM has come up every few days since the newer routers have come out. Perhaps that should be in the FAQ as well?
  55. The Master

    The Master Network Guru Member

    Hi Victek,

    i bought a R7000 today(Not yet at home). What do you need for a beta FW test?! Or do you want to finish on the other Routers and THEN migrade?!?

    In 2-3 Days i could test all FW you want @ the Hardware.

    Have a nice Day.
  56. Guzel

    Guzel Network Guru Member

    I have the ac56u tomato 1.3b
    80Mhz dosent work
    In wireless settings do you have EU are USA
  57. Victek

    Victek Network Guru Member

    Good new ;), after I heard problems with R7000 and other firmware to revert back to original Netgear firmware I prefer to test by myself if donations allow to buy it. Good router as I'm reading, congrats!

    My settings (default) are USA. Ah! and I see what you mention now... ok, set to USA.
  58. The Master

    The Master Network Guru Member

    I NEVER want to go back :D... But ok.

    And DONATE :D
  59. Victek

    Victek Network Guru Member

    Thanks! ... ;) ... it's planned to buy it .. patience.
    The Master likes this.
  60. Elfew

    Elfew Network Guru Member

    wistlo likes this.
  61. Victek

    Victek Network Guru Member

    Heartbeat was disabled since v1.2n version... it's already implemented in miniupnpd after this version.
    Elfew likes this.
  62. wistlo

    wistlo LI Guru Member

    Victek - I tested my router by accessing Remote Admin via https at port 443 (usually off, but must open when testing and updating OpenVPN) at, and the remote web site was able to write and read back from router memory. (!)

    The version is newer than 1.2n:

    Tomato RAF Firmware v1.28.9013 MIPSR2-RAF-V1.2v K26 USB

    Apparently the OpenSSL vulnerability exists in Tomato even if heart beat is disabled.
  63. Guzel

    Guzel Network Guru Member

    Sorry it dosent work. When I select US 5ghz disappears
  64. FattysGoneWild

    FattysGoneWild LI Guru Member

    Some say yes some say no? Heartbleed. Does the vulnerability exist in the latest beta version of RAF?
  65. koitsu

    koitsu Network Guru Member

    Run openssl version from the command-line and find out for yourself. Per official statements:
    • OpenSSL 1.0.1 through 1.0.1f (inclusive) are vulnerable
    • OpenSSL 1.0.1g is NOT vulnerable
    • OpenSSL 1.0.0 branch is NOT vulnerable
    • OpenSSL 0.9.8 branch is NOT vulnerable
    eviltone and shibby20 like this.
  66. leshan

    leshan Network Guru Member

    Hi Victek,
    Would you give us a example of make command to compile a firmware for F7D4301 from your source code?
  67. MrJman

    MrJman Serious Server Member

    I am still running Tomato RAF Version 1.28.9013 release 1.2 on my E3000. Does this have the HeartBleed vulnerability? Thanks and enjoy, John.
  68. Retronite

    Retronite Networkin' Nut Member

    I second that! :)
  69. FattysGoneWild

    FattysGoneWild LI Guru Member

    Can you please tell me how to do that? Is it with in Tomato? I never used command line before or know where its at. Sorry.
  70. FattysGoneWild

    FattysGoneWild LI Guru Member

    I looked in Victek's release log.

    Up to Version 1.1k

    OpenSSl release 1.0.1c

    Looks like it follows all the way up to 1.2 final.

    Version 1.2g

    OpenSSL updated to 1.0.1e release

    Follows to 1.2x as well with latest beta version.

    Will this be patched up soon Victek?
    wistlo likes this.
  71. lancethepants

    lancethepants Network Guru Member

    1.0.1g can be used.
  72. koitsu

    koitsu Network Guru Member

    telnet into the router, or via the GUI use Tools / System.
  73. FattysGoneWild

    FattysGoneWild LI Guru Member

    I went into the GUI Tools/System and put in openssl version in the empty box. But it says invalid command. Feeling really stupid atm. :(
  74. koitsu

    koitsu Network Guru Member

    Dunno what to say; works fine for me on Toastman. I'd rather not speculate.
  75. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Some builds omitted version from openssl to save space. I think Shibby mentioned it a couple of days ago.
  76. Elfew

    Elfew Network Guru Member

    So what about Heartbleed problem? I am a little bit confused - is it in tomato raf or not? If yes, could you release new version for ARM and MISP routers? Thanks for your time and answer :)
  77. shibby20

    shibby20 Network Guru Member

    all openssl version 1.0.1 to 1.0.1f (include) has heartbleed issue.
    version 1.0.1g was released 7 April

    If you want to check it yourself then just go to page and run test (remember to check advanced mode button)

    Please be patience and please give us a time. I`m already compiling tomato with latest openssl version. After that i will push changes to git for Victek and others devs.
    Elfew and The Master like this.
  78. shibby20

    shibby20 Network Guru Member

    toastman mod hasn`t build-in "version" command for openssl. You propably has installed openssl package from optware/entware. Then openssl version will return version of installed openssl package. Build-in openvpn, https etc services are using build-in openssl binary. Just try run
    and you will see invalid command.
    The Master likes this.
  79. koitsu

    koitsu Network Guru Member

    That may have been the case some time ago, but isn't true today. Firmware in question is tomato-K26USB-1.28.0503.7MIPSR2Toastman-RT-N-Ext.trx --

    $ telnet gw
    Connected to gw.home.lan.
    Escape character is '^]'.
    gw login: root
    Tomato v1.28.0503 MIPSR2Toastman-RT-N K26 USB Ext
    root@gw:/tmp/home/root# which openssl
    root@gw:/tmp/home/root# /usr/sbin/openssl version
    OpenSSL 1.0.1c 10 May 2012
    root@gw:/tmp/home/root# ls -l /usr/sbin/openssl
    -r-x------    1 root     root        133296 Feb 21 17:06 /usr/sbin/openssl
    root@gw:/tmp/home/root# df -k
    Filesystem           1K-blocks      Used Available Use% Mounted on
    /dev/root                 6464      6464         0 100% /
    tmpfs                    63492       216     63276   0% /tmp
    devfs                    63492         0     63492   0% /dev
    /dev/sda1             15599232    181144  14625684   1% /tmp/mnt/usbflash
    /dev/sda1             15599232    181144  14625684   1% /opt
  80. alexlau

    alexlau LI Guru Member

    How about Vic's v1.2v for the linksys series? Currently using it on a E3000.

    Any further update after 1.28.9013 v1.2v / v1.2x? I guess Vic is too busy for the ARM works.
  81. jerrm

    jerrm Network Guru Member

    Toastman applied Shibby's commits which included 1.0.1c with version and speed March of last year. He has not (yet) applied the subsequent Shibby commit that removed version and speed. So it depends on which release. Recent releases have version, older than one year or so do not.
  82. nurofen

    nurofen Serious Server Member

    Hi! Vic :) When will the new version for RT-N66U ?

    thank you
  83. shibby20

    shibby20 Network Guru Member

    Vic is in trip. Patience

    Wysłane z mojego S-line przy użyciu Tapatalka
    The Master likes this.
  84. FattysGoneWild

    FattysGoneWild LI Guru Member

    PM sent to you shibby in case you did not see it.
  85. Victek

    Victek Network Guru Member

    Back with regular Internet access... I'm reading all the alarm about Openssl..ok, will patch and release a new mipsel version, makes sense.
    Elfew likes this.
  86. Elfew

    Elfew Network Guru Member

    Upnp fix and new version of dnsmasq will be inluded too? Thanks
  87. FattysGoneWild

    FattysGoneWild LI Guru Member

    I know 1.3 stable is in coming....
  88. Victek

    Victek Network Guru Member

    Yes, is in test ;), with several changes (and openssl upgraded) ... one of the most significant changes is...

    Apr 22 03:27:33 router daemon.notice miniupnpd[1016]: version 1.8 (20140401) started.
    Apr 22 03:27:33 router daemon.notice miniupnpd[1016]: HTTP listening on port 11808
    Apr 22 03:27:33 router daemon.notice miniupnpd[1016]: Listening for NAT-PMP/PCP traffic on port 5351

    Read about PCP entering the term 'pcp miniupnpd' in google.. ;) or here for complete information and the reason why I consider it's a good feature for one router.
    Last edited: Apr 22, 2014
    Elfew likes this.
  89. zorkmta

    zorkmta Network Guru Member

    Victek, any big difference between these 2 models in wifi perfomance and stability? cuz making a decision to buy one expensive or save some money.
  90. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    to answer that question accurately u must honestly tell us the clients and the exact specs of there wifi chips.
  91. Victek

    Victek Network Guru Member

    If you plan to use wireless extensive then RT-AC68U, for average wifi then RT-AC56U. But remember that AC wireless implementation requires additional expenses on receivers, the cost can be twice the price you paid for your router. It's the only main difference between both units when you flash tomato.
    zorkmta and koitsu like this.
  92. Elfew

    Elfew Network Guru Member

    one of my mikrotik access point has better cover with internal antennas than my ac56u... i know it is only 2,4GHz but it is really interesting. Mikrotik has 2xmimo antennas inside (I am talking about rb951g-2HnD) with total output 1000mW. So it doenst matter how many antenans do you have or if they are inside or outsite of the box.
  93. Victek

    Victek Network Guru Member

    Then.. your Mikrotik is out of regulatory standards fixing a max output of 110mW ERP (20dBm) ... ;)
  94. Elfew

    Elfew Network Guru Member

    Who cares :D it is not in town, alone farm in countryside :D

    EDIT: I checked setting for wifi - everything is set to default value, country Singapoure. Same range, same signal on the same place. So I dont know if it is wrong :) and yes, I updated to the newest version of fw
    Last edited: Apr 22, 2014
  95. Victek

    Victek Network Guru Member

    First Y2014 version for MIPS routers, many updates from ARM modules has been cloned (with no easy modifications to mips platform).
    Release 9014 v.1.3c (yes, prior beta 'a-b' versions have been tested until this public release)


    Release 9014-v1.3c

    _ Dnsmasq updates and DNSSEC consolidation (2.69 test version) read more Test from your PC with .. dig TXT after you modified dnsmasq custom window with proxy-dnssec.
    _ New version for RT-AC56U and RT-AC68U also. Beta, please report functions.
    _ Busybox 1.22 .. Read changelog in
    _ BCMcrypto (Assorted Cryptographic Algorithms) updated Y2012 and common with new AC routers and ARM platform models.
    _ BCM57xx (Network driver) updated to Y2012 version and common for AC and ARM platform models.
    _ eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller (Asus driver 13July2013)
    _ eth1: Broadcom BCM4329 802.11 Wireless Controller (b/g/n)
    _ eth2: Broadcom BCM4331 802.11 Wireless Controller (b/g/n)
    _ NGINX updated to release 1.5.11
    _ PHP updated to release 5.5.10
    _ miniupnpd updated to release 1.8
    _ zlib patched and updated to version 1.2.8
    _ Openssl updated to version 1.0.1g

    Links for download will be updated in next 24 hours. As usual, please report any bug you may find. I come back to ARM build.... :)
    You may notice that build size have decreased a lot (-20%) ... nothing wrong, just learn how to reduce builds without speed performance drop.

    Last edited: Apr 22, 2014
    szpunk, Elfew, eahm and 2 others like this.
  96. The Master

    The Master Network Guru Member

    ModelAsus RT-N16

    Date & TimeWed, 23 Apr 2014 00:56:18 +0200
    Uptime 61 days, 01:00:52

    Now Test the new 1.3c :D hopefully same Uptime!!!
    If there is no Sign from me all is OK!!!
  97. Victek

    Victek Network Guru Member

    Test wireless performance please... I got better figures.. thanks!
  98. FattysGoneWild

    FattysGoneWild LI Guru Member

    Is this a solid release? :) Or will we be seeing another rather quickly? Few days to few weeks? I remember you mentioning the next release would be marked as 1.3 stable. So, thinking this version potentially has some bugs needing to be reported? Or stable just not quite ready yet as thought previously? Either way. Thank you for the release! :D
    Last edited: Apr 23, 2014
  99. The Master

    The Master Network Guru Member

    WTF.... i dont need a R7000 around 40-50mbit down and 10 up @ipad 4 with N16..

    with old FW only around 25-30mbit /10up...

    +10-15Mbit more @Mobilephone

    @PC iam STUCK @85 like a Wall but i dont know if it is a Problem with the FW or the ISP. Test it again tomorrow (Time for bed now 2 O Clock)

    All Test@ ISP 100/10


    Edit: All Tests with Channel 1 and 20Mhz
    @40mhz i only got MAX 30mbit @Ipad.


    CPU: 0% usr 0% sys 0% nic 0% idle 0% io 0% irq 99% sirq
    @85Mbit :(

    Next test Tomorow
    Last edited: Apr 23, 2014
  100. Victek

    Victek Network Guru Member

    It's a production release.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice