Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. aztech

    aztech Serious Server Member

    @dc361 Thanks, I really don't know how I got into downloading that other build.
    Confirmed 5GHz @ v116!
  2. cjason

    cjason Networkin' Nut Member

    How can I relocate minidlna log to a mounted partition (external HDD)?

    I tried to edit minidlna.conf using sed via init script but is not working.
    Code is functional but somehow useless.
    sed -i 's/^log_dir=\/var\/log/log_dir=\/opt\/var\/log/' /etc/minidlna.conf
  3. shibby20

    shibby20 Network Guru Member

    the easiest way is make a symlink from /opt/var/log/minidlna.log to /var/log/minidlna.log:
    ln -s /opt/var/log/minidlna.log /var/log/minidlna.log

    After that restart minidlna service.
    I will make Custom log file location in next release.
  4. reimer

    reimer Addicted to LI Member

    I guess this means the October driver wasn't ready for v116 release. I'm only wondering because I noticed Merlins builds are using a driver from December for N66 and maybe users seem to be finding range is near equal or equal to SDK5 drivers.
  5. JoeDirte

    JoeDirte Networkin' Nut Member

    Just upgraded to tomato-K26USB-1.28.RT-N5x-MIPSR2-116-AIO-64K. Everything looks good so far...
  6. GhaladReam

    GhaladReam Network Guru Member

    That is exactly why I'm eager for shibby to sort out the kernel panics with the december SDK6 driver :)
  7. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

  8. scorpeeon

    scorpeeon Addicted to LI Member

    Just updated to version 116 on my E4200, and i can definitely see a significant speed improvement.
    I have 120 mbps net and with last version i used (around version 110 i think) i could only achieve about 105-110 mbps. Now i can easily go over 130, reaching close to 140 mbps, so now i'm probably only limited by my internet provider.
    Also wireless speed looks better.
    This new Broadcom driver seems to be superb :)
    Thanks for this great software.
  9. jerrm

    jerrm Network Guru Member

    Belkin 3301/3302/4302/7301/7302/8302 require the .bin image for the first flash, after that you can use any generic RT build under 8MB. RT-N builds worked prior to 114. RT-N 114 & 115 were broken for this Belkin series. I haven't tried 116.

    Last time I tried a Shibby .bin image, the Belkin would not accept it, but it's been a while. We just keep an old set of Toastman .bins around for initial flash, and then immediately move on to Shibby's .trx builds.

    The Belkin 4301/8301 does NOT need an initial .bin image, you can flash to your desired .trx directly from the standard Belkin GUI. Shibby 114/115 RT-N builds work OK on the 4301 as well.
    Last edited: Jan 21, 2014
  10. kthaddock

    kthaddock Network Guru Member

    I'm running 116-aio on rt-n16 24h and working very good haven't seen any problem so far.
    Did a test with openvpn and I reach ~1,35MB/s (udp) on a 10/10 fiber.

    I also did a speed test with samba over wifi to usb drive ext2 and get:
    Thank you Shibby !!!
  11. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    @jerrm I know how to flash Belkin Play or Max, I have both of them, tried the mini in V116, DD-WRT-Mini then 116 (Mini and full), still no go on the RT-N branch.
    Last Usable version is V112. Thank you, you are a champ as always!
    I only asked because I've seen those minis in V116 folder and was really excited to try them out!
    P.S.: The 4302 doesn't work just to be clear on that...
    Last edited: Jan 23, 2014
  12. Igorek

    Igorek Networkin' Nut Member

    I don't know why, but 116 firmware very often disconnects L2TP connection on AC66U :(
    L2TP goes through AC68U router, AC68 has dd-wrt, so ac66u can't connect via pptp, via openvpn speed is very bad. VPN Passthrough in Enabled in dd-wrt ac68u
    Now I roll back to 115 firmware, and will look if it disconnect or not.
    Anybody has the same problem?
    Last edited: Jan 22, 2014
  13. sa411022

    sa411022 Reformed Router Member

    I flashed tomato-K26USB-1.28.RT-N5x-MIPSR2-116-AIO-64K.trx to my N66U.
    It seems that the 5G wireless has some problem.
    If the distance between N66U and client is about 2m or shorter,
    the client cannot connect with N66U via 5G wireless (2.4G is OK).
    115 and previous versions do not have this problem.
  14. kthaddock

    kthaddock Network Guru Member

    Delete your 5Ghz and connect again, if distance is to close to router it can saturate rx receiver.
    Did you upgrade without nvram reset and reconfigure by hand ?
  15. sa411022

    sa411022 Reformed Router Member

    My upgrade procedure is:
    clean nvram -> flash new firmware -> clean nvram -> reboot -> manually key in all settings
    I have tried to reset wireless settings in client, but nothing worked.
    With the same location and settings, 2.4G works fine in all versions, and 5G works find in 115 and previous versions.
  16. JugsteR

    JugsteR Addicted to LI Member

    If you have the time, the next time you upgrade, could you provide a diff between how the nvram looks before and after the second nvram clean.

    It would be interesting to see how many bytes you save there, if any.

    Signature? Signature!
  17. kthaddock

    kthaddock Network Guru Member

    Okey have you seen this ?
  18. krum09

    krum09 Networkin' Nut Member

    If you have configured, turn off wireless, Via Button or Time, the 5g will revert to 20mhz or what erver the 2.4g is set at. I noticed this also with 116.
    just make the changes in the basic wireless sections and save, after that it will come back to 40mhz or what you had before.
  19. PGalati

    PGalati Network Guru Member

    Just sending out a little love for the WRT54GL. Since Shibby removed SNMP from version 116 of the K24 builds, the SD build that includes DNSCrypt now fits in the 4MB flash.

    Thank you Shibby.
  20. Igorek

    Igorek Networkin' Nut Member

    From my last post I have no disconnects via L2TP on 115 firmware.
    I have disconnects but not so often, about one disconnect for 6-8 hours, on 116 firmware some disconnects for one hour.
    Last edited: Jan 23, 2014
  21. sa411022

    sa411022 Reformed Router Member

    Thanks for your suggestions.
    But my problem is not about 20/40mhz, I can make connection with 5G/40mhz when the distance is longer (> 3m).
    Now I have rolled back to 115 and no problem exists.
    Maybe the new wireless driver has some problems in 5G?
  22. Malitiacurt

    Malitiacurt Networkin' Nut Member

    Sounds like saturation/signal clipping. Try turning down the transmit power on the 5Ghz radio.
  23. braindedd

    braindedd Addicted to LI Member

    116 running OK here. Still having some issues with the administration HTTP server occasionally not responding to me. Worked around by switching to HTTPS. RT-AC builds still do not register > 20mhz channels on my RT-N66U.
  24. jodur

    jodur Networkin' Nut Member

    tomato-RT-N66U_RT-AC6x--116-AIO-64K running well on my RT-N66U
    I upgraded from V115, did not do a NVRAM erease!!
    No extra functions are added so I think a NVRAM erease is not needed? Could you confirm Shibby?

    5GHZ is running as before with no problems!

    Only 2,4GHZ has still bad connection with 40 MHz channel width!! This was also the case with V114 and V115 so no improvement on that.

    Uptime V116 for 4 days now with no problems!
  25. windozer

    windozer LI Guru Member

    Hi shibby. will you add mtime to busybox?

    It will be great to "trim" (delete) my IP camera files, to prevent full disk.
  26. _NemO_

    _NemO_ Networkin' Nut Member

    RT-N66U, MIPSR2-116 K26AC USB AIO-64K, Wireless Driver (r341183)
  27. kthaddock

    kthaddock Network Guru Member

    Well uptime is ONLY ~1minute just wait and se, 24h and what do you read then ?
  28. GhaladReam

    GhaladReam Network Guru Member

    Yeah this has been present ever since the beginning of the SDK6 builds. I've been wondering about it too. Might be a side effect of the driver itself.. It doesn't seem to affect anything connectivity-wise, but it is annoying nonetheless.
  29. RMerlin

    RMerlin Network Guru Member

    I was using 5.100, not 5.110 on the RT-N66U SDK5 builds (which are from the sdk5100 branch BTW, not from master). 5.110 was badly broken on the 5 GHz band, and Centrino devices have major issues connecting to it. I think Asus/Broadcom managed to resolve some of these, but a few manufacturers still had issues connecting to it, so Asus gave up and upgraded the RT-N66U to SDK6, with the range loss that came with it.

    EDIT: sorry for the very delayed reply, that thread was gone from my subscriptions so I hadn't been keeping track of it lately.
    Last edited: Jan 25, 2014
  30. leandroong

    leandroong LI Guru Member

    Does anyone know how to re-start "file-sharing" command. My NFS client not display on startup and I needed to re-saved file-sharing to have it display on network neighborhood.
    BTW, if your curious, I enable my NFS client via init-script that goes like this:
    mkdir /mnt/downloads
    mount -t nfs -o nolock,intr,hard,timeo=14,sync,rsize=32768,wsize=32768 /mnt/downloads
    sleep 1
  31. leandroong

    leandroong LI Guru Member

    Self-answer: service smbd restart
  32. shibby20

    shibby20 Network Guru Member

    sdk5100 branch :) Now it`s ok. I have downloaded your master branch and there is 5.110.
  33. RMerlin

    RMerlin Network Guru Member

    Yes, master has 5.110 since only the RT-N16U uses SDK5 in my project (and since it doesn't have a 5 GHz band it works fine with 5.110). The RT-N66U was a special case, so it was on a separate branch.

    That branch will most likely disappear in the near future however, since the latest SDK6 resolved most range issues that were introduced in the previous SDK6 driver.

    Also, all SDK5-based builds (both RT-N16 and RT-N66U) are currently broken in HEAD after the latest SDK6 merges, so you might need to checkout an older tag (such as 374.36-Beta1) to regain a working SDK5 tree. Still waiting for Asus to release newer GPL code with the required fixes.
  34. teh_g

    teh_g Networkin' Nut Member

    shibby, word on the street is that you may need help testing a Tomato build for the RT-AC68U, is the word true?! If it is semi-stable (I can connect to the internet and things won't explode), I would love to test.
  35. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    @shibby20 and @RMerlin
    Intel 4965AGN plays very good with Belkin Play Max on 5Ghz band 40 Mhz wide. Actually it's the first time when I can use other channels than 36 (maybe 40?!) in Tomato (the network was invisible if I changed it).
    I don't know if it was a driver problem or a misconfiguration in NVRAM, or if v116 fixed it or a previous version, if it's specific to the Belkins or other brands... What is certain is that neither routers f7d4301 or f7d4302 allowed other channels.
    The f7D4302 (V112 - is paired with ASUS PCE-N53 Ralink RT5592 and if I remember correctly it exhibits the same behaviour (It's at a location that I visit less often so can't really test it out now).

    To confirm or infirm the Centrino incompatibility someone uses this wireless card? how is it working for them on 5GHz?

    P.S.: From last post, We should expect driver version regression to 5.100 or an advancement to SDK6?
    Last edited: Jan 28, 2014
  36. sa411022

    sa411022 Reformed Router Member

    My NB ASUS F9E has a Intel 4965AGN wireless card.
    After I flashed my RT-N66U to RT-N v116, which uses 5.110 wireless driver, my NB cannot make connections to N66U with 5Ghz wireless when the distance between them is shorter than 3m.
    The 5Ghz signal can be seen in my NB, but there is an error when I try to make connections.
    So I tried earlier versions such as RT-N v115, which uses 5.100 wireless driver, connections are successfully created.
    I also tried RT-AC versions, which uses SDK6, and no problem exists.
    It can be concluded that the 5.110 wireless driver has some problems in 5Ghz wireless as RMerlin mentioned in #2729.
    I think that it will be better to roll back the wireless driver to 5.100 in future N66U builds, but please keep 5.110 in other devices which has no 5Ghz wireless such as RT-N12, since 5.110 has fixed the FTP transmission problem as I stated in
  37. kthaddock

    kthaddock Network Guru Member

    After every swith to new build to test new driver, delete your wifi client and reconnect again.
  38. sa411022

    sa411022 Reformed Router Member

    Yes I do reconfigurations and reconnections every time I try a new version.
    The result is that the connection issue only exists in RT-N v116.
  39. RMerlin

    RMerlin Network Guru Member

    Asus resolved the Centrino issue in the last 5.110 release sometime last spring or last summer. I was one of those who had the issue and was following up with them on it back at the time.
  40. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    @sa411022 I took the laptop 10 cm next to the router, it connected and I browsed a few pages without any problem... wow 300 mbps ;) The problem you are having must be specifically to RT-N66U or a bad setting in antenna power... I'm using 0 - Auto.
    Why don't you try upgrading to 116 without erasing NVRAM, maybe something is not initialised properly... If still won't work then you know for sure it's the new driver! (I've done this in the past just to bypass some buggy settings between builds or simply lack of spare time, not recommended).
    Last edited: Jan 28, 2014
  41. theirongiant

    theirongiant Networkin' Nut Member

    Since upgrading from 115 to 116, L2TP is not being passed through. I even have firewall rules for UDP ports 500, 1701, and 4500.

    My VPN server, a Mac Mini, is not on the DMZ. When I put it in the DMZ, VPN L2TP works again.

    Also, in the "Conntrack" section, the NAT Helpers are enabled. There is no option for L2TP (ESP), just GRE/PPTP.

    Shibby, did you forget to enable passthrough of "ESP" (Protocol 50) ?
  42. Malakai

    Malakai Networkin' Nut Member


    I am using Tomato Firmware 1.28.0000 MIPSR2-112 K26 USB AIO by Shibby, and I am trying to limit the access from my guest lan (br1) to the Internet and only allow http, https and ping and reject everything else. For that I have put in the Firewall tab in Administration > Scripts:

    iptables -I FORWARD 1 -i br1 -o ppp0 -p tcp -m multiport --dport 80,443 -j ACCEPT
    iptables -I FORWARD 2 -i br1 -o ppp0 -m state --state ESTABLISHED,RELATED -j ACCEPT
    iptables -I FORWARD 3 -i br1 -o ppp0 -p icmp --icmp-type 8 -j ACCEPT
    iptables -I FORWARD 4 -i br1 -o ppp0 -j REJECT
    Everything is blocked, ping works with no problem, but when I try to go on a website (http, https) it loads forever (except google pages that load quickly - weird), and I can't really access the websites. I have some things activated on the router (RT-N16), like ftp, vpn etc., the only thing that could create a problem being Bandwidth Limiter, but even when I disable it the loading of websites problem persists. The same problem appears with Captive Portal being activated but this time only if Bandwidth Limiter is also activated (if I have only one of these two activated then there is no problem).

    How can I achieve what I want to do: limit the access from my guest lan (br1) to the Internet and only allow http, https and ping and reject everything else, and eventually use Bandwidth Limiter and Captive Portal too.
  43. aztech

    aztech Serious Server Member

    I recently got a used E4200v1 and the first thing I did was to install shibby's 115 on it.
    Before I really had the time to set it up, 116 got out so I flashed it with this release.

    I'm having trouble with setting up vlan tagging on vid's higher than 16, but I stumbled upon <this thread> and saw that there is a bugreport on that the sourcecode for non standard vlans is gone.

    I'm not sure that this affect my particular router, but maybe someone can tell me if it does, so I can realax and stop loosing my mind trying get it work?

    <This> is my own thread about me trying to set up vlan tagging on the wan port for IPTV.
  44. _NemO_

    _NemO_ Networkin' Nut Member

    Bandwidth Limiter doesn't work for upload on br1.

    Tomato Firmware 1.28.0000 MIPSR2-116 K26AC USB AIO-64K
    Asus RT-N66U
  45. justinbeaird

    justinbeaird Networkin' Nut Member

    Last edited: Jun 10, 2015
  46. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    Tomato RT branch v115 -116 tested ...
    When Using Wireless Ethernet Bridge Virtual Lans are visible but can not connect on 2.4 Ghz Band (and possibly other modes for 2.4 Ghz like WDS, basic Wireless Access Point mode works).
    5Ghz works ok as access point, as expected on Belkin Play F7d4302 (Same behaviour tested later on F7D4301).
    RT-N branch works in all modes(V112 on this router).
    Last edited: Feb 1, 2014
  47. occamsrazor

    occamsrazor Network Guru Member

    Not sure, but I use these, which were tweaked a while back after having issues with SIP connections:

    Attached Files:

  48. Kisch

    Kisch LI Guru Member

    Hi Shibby. Thank you for your time and effort to improve Tomato. I am happy with it for years (Asus WL520GC, WL500gp, RT-N16), using Victek and yours builds.

    Now I have Asus RT-N66U and I changed Victek version K26USB-1.28.9013MIPSR2-64K-RAF-V1.2v to Shibby K26RT-AC 116 and it seems working good except two things:

    1) I cant set 40Mhz channel width for 2,4 and 5Ghz wifi. When I set 40 Mhz and save it, in Status/Overview is still shown 20 Mhz. I have not 5Ghz device, so I dont know if problem is setting, or just status showing. In Victek version it works well. What can I try? Mean different settings (country, manual channel set etc.)?

    2) For br0 DLCeil woks, but ULCeil is not. Upload speed rises to QOS upload limit. And when I save settings on BW Limiter page, outboud graph on QOS page turns grey and I have to do this: disable QOS - save - enable QOS - save, to return it back. But ULCeil limit is still not working.

    I did NVRAM reset before and after instalation of new version.
  49. Kisch

    Kisch LI Guru Member

    So I did some more wifi testing to manage 20/40Mhz settings work. Now it seems I got 40 Mhz working. But I have to choose wifi channel manually. Doesn´t matter if lowest or highest. After saving Overview page shows 40Mhz. If now I set channel to Auto and save it, Overview page still shows 40 Mhz. But after restart with channel set to Auto is again shown only 20Mhz. When I restart router with manually chosen channel, after boot is still 40Mhz. So now it seems the only problem is Auto channel setting. Both 2,4 and 5Ghz wifi have same behaviour.

    PS.: Apologize for my English, it is not my language.
  50. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    The wireless driver cannot be relied upon to choose an appropriate non-overlapping channel. Though it is a bug, it is unlikely to be fixed as channels should be manually chosen anyway.

    Your English is fine. :)
  51. shibby20

    shibby20 Network Guru Member

    You cannot use BW Limiter and QoS in the same time!
  52. Kisch

    Kisch LI Guru Member

    Hi Shibby, thx for answer.
    I tried it before even with QOS off. But I tried it again (without QOS) and it is working, but sometimes I had to restart router to get BW rules into live. Especially if i set QOS to off, then set BW rules and after it played with TCP Vegas. I had to restart router, or just press save button in BW limiter again.
  53. Malakai

    Malakai Networkin' Nut Member

    So, no one knows??
  54. stillsober

    stillsober Reformed Router Member

    Hi, I was wondering what the the Tor-VPN tomato does when my current firmware can run Tor just the same?
    Tomato Firmware 1.28.0000 MIPSR2-115 K26 USB BT-VPN
  55. shibby20

    shibby20 Network Guru Member

    please forgive me. I don`t have time answer on each post because i am very busy. I`m working really hard on this...


    Best Regards ;)
    Elfew, rZnth4r, sa411022 and 3 others like this.
  56. Kisch

    Kisch LI Guru Member

    Oh my god! Great news! Don´t answer us and work. :)
  57. justinbeaird

    justinbeaird Networkin' Nut Member

    Last edited: Jun 10, 2015
  58. shibby20

    shibby20 Network Guru Member

    "we" make little steps forward and there is very long road ahead to make fully working tomato-arm :)
  59. Mindaugas

    Mindaugas Reformed Router Member

    I have the same issue with SDK6 v115 and v116 with 2,4 GHZ wifi. After ~8 h up time i have connection with WiFi, but can't access to router and internet, or have bad connection.
    With 20 MHz no problems !

  60. Mindaugas

    Mindaugas Reformed Router Member

    I have the same issue with SDK6 v115 and v116 with 2,4 GHZ wifi. After ~8 h up time i have connection with WiFi, but can't access to router and internet, or have bad connection.
    With 20 MHz no problems !
  61. quinezhu

    quinezhu Addicted to LI Member

    I tried tomato-K26-1.28.RT-MIPSR2-116-MiniVPN (3,864KB) (which includes OpenVPN and vlan/guest ssid), but it is a little bit bigger for M20's 4M flash. Would it be possible to remove PPTP function to reduce the size of this firmware size under nearly 3,748KB ? THX in adv.


    ps. I've got tomato-K26-1.28.RT-MIPSR2-107-MiniVPN.trx (3748KB) flashed into M20 and it works. :) THX a lot
    Last edited: Jun 4, 2014
  62. Mangix

    Mangix Networkin' Nut Member

    any plans to make wndr3400v1 builds or do the current builds work? I'm still on the test build.
  63. tomatosoup

    tomatosoup Networkin' Nut Member

    Can confirm that on my E4200 - 2,4 GHz stops working after some time, while 5 GHz is still usable.
  64. pfonseca

    pfonseca Reformed Router Member

    Hi guys,

    I use Tomato from Shibby for a while now, but I have a problem.I have a Asus RT-N66U working nice until yesterday when I change ISP +TV+VOIP provider.

    They've installed a router tha have Internet+VOIP+IPTV. I put a switch connected to the ONT and connect their router an my router to that switch. To have Internet on mine I have to configure a tagged VLAN. The only way I was able to do thar was to use Asus Merlin firmware and configure the WAN connection with VLAN tag of VID=100 and PRIO=1. With this kind of configuration, LAN3 is for IPTV and LAN4 to VOIP or vice-versa, I'm not sure now. I don't want to have IPTV or VOIP on my router so I have to set switch_stb_x=0 whatever that means. For me it's working as I expect.

    I've Googled a lot trying to understand how to do that with Tomato, bur I wasn't able to make the right configuration. Everybody talk a lot about VLANs, tagging and whatever more, but no one give a simple and direct solution comparable to what Asus Merlin provides.

    I consider Tomato from Shibby a better solution then the one I have now, for instance. Does anyone understand what I mean and what I need? I would appreciate:)


  65. shibby20

    shibby20 Network Guru Member

    SUCCESS!! Today i made a working firmware for AC68U!

    Router works, WAN works, WIFI works (BOTH), USB works, nvram set/get works, restore to defaults works.
    TODO: upgrade firmware via GUI ;)

    Best Regards!
    Fredrik, M_ars, sa411022 and 5 others like this.
  66. aztech

    aztech Serious Server Member

    Shibby, you added vlan multiplier in build 95.
    For some reason it's not working any more and some say the code for thus is missing in later builds. There are reports of it on your bugtracker.

    There are a few of us who need this for iptv to work, so can you please look into it pretty soon please?

    Skickas från min iPhone via Tapatalk
  67. shibby20

    shibby20 Network Guru Member

    vlan multiplier works correct. Please show me screenshoots and result of:
    ifconfig | grep vlan
  68. aztech

    aztech Serious Server Member

    Can't do it right now because I resetted the router earlier this morning.

    But ..
    vlan (1) 832 - internet (untagged on WAN port)
    vlan (2) 833 - LAN br0
    vlan (13) 845 - iptv (tagged on WAN port)
    base vlan - 832

    Internet is working just fine and I get a dhcp lease for that, but not on vlan845 for IPTV.
    Using a switch before the router (on wan port) I can see everything in Wireshark, but operations on vlan845 doesn't leave the WAN port at all because I can't see anything when monitoring that.

    The idéa is to set up 2 vlan interfaces on the wan port and to proxy the iptv traffic on vlan845 to the LAN via br0.

    Trying to get a lease using: udhcpc -i vlan845 -V IPTV_RGW_PRIV

    This is done using a Linksys E4200 v1.

    Edit ..
    I managed to set the config up @shibby20

    vlan 1.JPG
    root@unknown:/tmp/home/root# nvram show |grep vlan
    lan_ifnames=vlan1 eth1 eth2
    landevs=vlan1 wl0 wl1
    vlan13ports=4t 8
    vlan1ports=0 1 2 3 8*
    vlan2ports=4 8
    Last edited: Feb 17, 2014
  69. teh_g

    teh_g Networkin' Nut Member

    Words can't describe how pumped I am!
  70. shibby20

    shibby20 Network Guru Member

  71. kthaddock

    kthaddock Network Guru Member

  72. FireWire

    FireWire Serious Server Member

    I previously have been using Shibbys version of Tomato, but sadly had to abandon this great firmware about a year ago due to the new speed from my ISP. With Tomato I wasn't able to utilise the full speed from my ISP. So I had to go over and use the original firmware. I ended up with Merlins great custom firmware. But I miss a lot of features that Shibbys firmware provided. So my question is, have anything evolved in this firmware regarding WAN speeds? My ISP speed is 250Mbit/100Mbit.

    Best regards,
  73. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Router model? Which Tomato features do you miss that aren't in the Merlin firmware? (affects speed)
  74. shibby20

    shibby20 Network Guru Member

  75. kthaddock

    kthaddock Network Guru Member

    No havn't :( not yet.
  76. shibby20

    shibby20 Network Guru Member

  77. FireWire

    FireWire Serious Server Member

    I have Asus RT-N66U.
    Mainly I need the Parental Control that Shibbys version provides that is far more usable then Asus totally crappy Parental Control features. And there are a couple more features that I would like to have, but isn't a "must have", but would be nice to have. But Parental Control is the main reason. And I must say, I love Shibbys Tomato GUI over Asus GUI. But that is just a matter of opinion and not the main reason.

  78. shibby20

    shibby20 Network Guru Member

  79. _NemO_

    _NemO_ Networkin' Nut Member

    Found some bug in 116 AIO AC for RT-N66U
    pinging any host from router leads to reboot :confused:
    I have this in firewall scripts:
    iptables -I INPUT -i br1 -m state --state NEW -j DROP
    iptables -I INPUT -i br1 -p udp -m multiport --dports 53,67 -j ACCEPT
    iptables -I INPUT -i br1 -p tcp -m multiport --dports 5280,9040,9050,9053 -j ACCEPT
    and have configured wl0.1 briged to br1 with Captive Portal enabled.
  80. FireWire

    FireWire Serious Server Member

    Thanks Shibby for the link. Is it possible to use this AND use Parental Control? I don't need QOS, so thats not an issue, but Parental Control is important to me.
    If I understand correctly, I need to send the command ""modprobe bcm_nat" every time the router reboots. Is it possible to add this somewhere in the gui, to initiate that command each reboot? I am a total noob regarding linux/telnet and so on. Or is there some other way to enable this command to be sent on each reboot?

  81. jerrm

    jerrm Network Guru Member

    What are you equating to parental control? Access Restrictions? And if so, what kind of rules?
  82. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    I think you should be able to use access restrictions.

    Administration > Scripts in the GUI, could probably put it under "Firewall" section or earlier (not in "WAN up") since you don't need the script to run repeatedly.
  83. FireWire

    FireWire Serious Server Member

    It was a while sins I used Tomato, so don't remember what "parental controls" was in the GUI, but you maybe right, that it's access restriction a need to use in Tomato.
    What I need is to disable certain devices from accessing WAN/Internet, some for specific periods of time and some always. BUT they should always have access to the LAN. The issue with Asus worthless Parental control is, if you restrict a device in that function, then the device have no network access at all. With Asus firmware, you can use something called Network Filter instead to block access to WAN, the problem with that is, that you cannot set individual times for each device. With Tomato I know I could achieve just what I need, to only problem earlier was, like I said in op, the speed.

    @Marcel Tunks
    Big thanks for this. I think I am going to have a nice time changing firmware. Have been eager to go back to Tomato.

    So with given demands above, do you think I can use this type of restrictions and use bcm_nat?

    I really appreciate everyone's help, you are rock solid when it comes to helping us noobs out =).
  84. jerrm

    jerrm Network Guru Member

    I don't use bcm_nat, but since you're not really probing the packet and only allowing/disallowing based on IP or MAC, there is good chance you'll be OK.

    If you wanted to use the layer 7 or http request filters, I'd be doubtful.
  85. FireWire

    FireWire Serious Server Member

    Ok, thanks for this.
    I am about to download Shibbys firmware. I see there is 2 firmwares to chose from for ASUS RT-N66U: K26RT-N and K26RT-AC.
    What is the difference between those two and which one should I chose?
  86. jerrm

    jerrm Network Guru Member

    Either should be OK. The RT-AC branch uses the same wireless drivers and source tree as the AC series routers, so it is slightly more experimental at this point, but still pretty stable. It also includes a better ntfs driver if you have any ntfs formatted drives attached to the router.

    I use the RT-N branch.

    Probably worth experimenting with both and seeing which gives better wireless performance for your environment and mix of clients.
  87. Gitsum

    Gitsum LI Guru Member

    Which version of the RTN66U firmware can you use the "bcm_nat" module??
  88. shibby20

    shibby20 Network Guru Member

    K26RT-AC support bcm_nat, new paragon NTFS driver and newer wireless driver (SDK6). K26RT-N doesn`t support bcm_nat, has regular NTFS-3G driver and older wireless driver (SDK5).
  89. jerrm

    jerrm Network Guru Member

    114 Release notes indicate bcm_nat is in RT/RT-N. I don't see anything since then. Has this changed?
    Gitsum likes this.
  90. Gitsum

    Gitsum LI Guru Member

    I am using 116-K26 USB VPN-64K on my ASUS RTN66U and have confirmed that bcm_nat is "INIT"

    Be nice if Shibby could incorporate a check box i the GUI to enable and disable this..
  91. shibby20

    shibby20 Network Guru Member

    my fault, bcm_nat is supported by RT-N, not RT-AC. sorry.
  92. shibby20

    shibby20 Network Guru Member

    [Breaking news]

    RT-AC68U with tomato and with enabled CTF = 700Mbps from WAN -> LAN :D
    jerrm and Gitsum like this.
  93. leandroong

    leandroong LI Guru Member

    I wonder whiat is the original FW speed.
  94. RMerlin

    RMerlin Network Guru Member

    Pretty similar. Last time I tested it on an RT-AC56U, using iperf, and FW 374.36 Beta 1:

    With CTF:
    [ ID] Interval  Transfer  Bandwidth
    [152]  0.0-30.0 sec  2.70 GBytes  774 Mbits/sec
    Without CTF:
    [ ID] Interval  Transfer  Bandwidth
    [152]  0.0-30.0 sec  1.30 GBytes  373 Mbits/sec
    EDIT: Now I see in my notes that this was with the CPU overclocked at 1 GHz tho. At stock clock without CTF I was at 330 Mbits. I didn't note the performance with CTF however, but itf iit's the same performance ratio (about 10% gain), then it should also be very close to 700 Mbits.
  95. ceckin

    ceckin LI Guru Member

    On E4200 v116, even after NVRAM Erase (thorough) 2.4 and 5Ghz can't co-exist. The only way i can get 2.4 to work is to disable eth1 and force eth2 to work on 5Ghz. Does anyone have any idea if both interfaces can work with different setting on 2.4/5 bands?
  96. jerrm

    jerrm Network Guru Member

    Just a note on iperf -- be wary of the stats if running under Cygwin on Windows. In some testing I did just this weekend, when Cygwin iperf was the "server" the stats were very comparable to Linux. When Cygwin iperf was the "client" stats were about 25-33% of the Linux numbers. Running iperf inside a Linux VM on the same Windows PC gave stats comparable to the native Linux box.

    I know this is not an issue with the your tests, but thought I might give a heads up to others from my (very) recent experience.
  97. FireWire

    FireWire Serious Server Member

  98. jerrm

    jerrm Network Guru Member

    Only the RT-N firmware. The RTN66 is the only unit supported under both versions, but only the RT-N firmware supports bcm_nat.
    shibby20 likes this.
  99. FireWire

    FireWire Serious Server Member

    Ok, thanks for clarifying. Lucky I haven't had time to change firmware yet. I was about to install the RT-AC firmware, lucky I didn't do that =).
  100. shibby20

    shibby20 Network Guru Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice