Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. kamaaina

    kamaaina Serious Server Member

    This is the drop down from v. 119 (it shows it in the editing preview, how can I make it appear)

    Last edited: Jun 9, 2014
  2. kamaaina

    kamaaina Serious Server Member

    Genius. Thanks much. I guess we file this under user error.
    /tmp/home/root# cat /proc/dmu/temperature
    CPU temperature : 67?C
    Not too bad for running at 1400 Mhz for 6 days now.
    Fredrik likes this.
  3. kamaaina

    kamaaina Serious Server Member

    You could try to go through the Tomato ANON list and see if you could filter by uptime.

    The problem is that most people with newer routers might also have upgraded the fw after heart bleed etc.
    The fastest would probably be the R7000 and then the 25+ devices running the 800Mhz dual-cores, at least the ones that can handle Tomato. Look under general SoC the two at the bottom. My old E3000 was really stable, but that thing is slow compared to todays routers.

    I am not sure about the pure networking/switching speed, but for running an OpenVPN client in Tomato with PIA, for example, which requires CPU power, my average range when tested for download speed was about this:
    E3000: 7-8 Mbit/s (532 Mhz)
    N66U: 13-15 Mbit/s (600 Mhz)
    AC56U/AC68U: 23-25 Mbit/s (at stock speed 800Mhz)
    AC56U/AC68U: 28-30 Mbit/s (OC at 1000Mhz)
    R7000: 30-35 Mbit/s (stock 1000 Mhz)
    R7000: 40-45 Mbit/s (OC at 1400Mhz)
    That's on a 55 Mbit/s broadband connection.

    Most problems with the current fast ARM routers seem to come from the wireless driver which seem shitty coming from the vendors and then Tomato/DD-WRT etc. need to deal with what's there. The routers otherwise seem stable, whether Merlin, DD-WRT, or Tomato. That said, for the R7000, this has just been two Tomato releases, I would give it a bit more time before I put this is a company setting, for example. Dropouts at home are annoying, in a company that can cost the job. Maybe get a router than has Tomato support now but run it with other fw for the next 3-6 months and then be ready to switch. I don't see anything faster than the R7000 coming shortly. The AC87U seems to have the same chip, and if you over clock the R7000 to 1200 you are running the same CPU clock speed as the WRT1900AC.
    wistlo and TyShawn like this.
  4. wit100

    wit100 Networkin' Nut Member

    Very interesting and great insight. Thank you!
  5. Fredrik

    Fredrik Networkin' Nut Member

    Is there a guide on how to OC and get temperature readings? :)
  6. shibby20

    shibby20 Network Guru Member

    OC R7000 to 1400
    nvram set clkfreq="1400,800"
    nvram commit

    read CPU temp:
    cat /proc/dmu/temperature

    and this is how it look
    Last edited: Jun 6, 2014
    Fredrik likes this.
  7. The Master

    The Master Network Guru Member

    @Just for Info
    Running my R7000 with Shibby 119 AIO Build and OC @(clkfreq="1400,800") with Temp @Idle 64° and Load 65°... No OC Problems so far..
  8. shibby20

    shibby20 Network Guru Member

    R7000 (O/C 1400,800) + tomato-ARM v120 + openssl 1.0.1h

    The Master likes this.
  9. kthaddock

    kthaddock Network Guru Member

    I'm using sunset mode "stealthMode sun 906493" and when run I get up/down time.
    Does this update get new times or do I need to do it maually eg every moths or so to get new sunrise and sunset times?
  10. The Master

    The Master Network Guru Member


    Nice very nice!

    is there a aproximate Release Date for the new Version! 1-2 Months?!

    Thx for the HARD WORK.
  11. Bird333

    Bird333 Network Guru Member

    For some reason the image doesn't show up until I quoted your post to respond. :) Are these the tls-ciphers? They don't look the same as the one I posted. BTW, I am not using the gui to run openvpn.
  12. shibby20

    shibby20 Network Guru Member

    propably 2-3 days.
    wistlo, szpunk, kthaddock and 3 others like this.
  13. qashi

    qashi Reformed Router Member

    idk if its normal, but i get really strange pings if i ping my new r7000 running v119 (idle)

    edit: fixed, just unplug the power cable for a few seconds.
    Last edited: Jun 6, 2014
  14. kthaddock

    kthaddock Network Guru Member

    I does get new sunrise / sunset time, seem update automatically.
  15. lepa71

    lepa71 Networkin' Nut Member

    Is there a build for R6250?
  16. Lamoboy

    Lamoboy Serious Server Member

    I can't save settings on "DHCP / DNS Server (LAN)" page (advanced-dhcpdns.asp). When I press "Save" button nothing is happening.

    P.S. Is there a bug-tracking system for Shibby's firmware or all concerns just go to this one thread?
  17. kthaddock

    kthaddock Network Guru Member

    Use Explorer in compatibility mode.
    Last edited: Jun 8, 2014
  18. Lamoboy

    Lamoboy Serious Server Member

    The same problem. "Save" button on all other pages works as it should, but on advanced-dhcpdns.asp page it just don't work.
  19. abubin

    abubin Addicted to LI Member

    i have been using shibby's mod for a long time. Since the wrt54GL days until recently, I upgraded to linksys e2500v1. I just did a setup on guest login (and bandwidth limit). I would like to turn on QoS now for the rest of my network however, I read that QoS and Bandwidth Limit does not work together. So I just want to politely ask Shibby if fixing this problem is in the pipeline or not?

  20. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Known issue in this version, several posts about this in multiple threads in past week. Shibby will almost certainly have it fixed in the next version.
  21. Lamoboy

    Lamoboy Serious Server Member

    To avoid this, Shibby should setup a good bug tracking system on his website.
  22. vite0150

    vite0150 Reformed Router Member

    I have a belkin f7d4302/8302 installed the 115 k26usb big vpn... enabled usb and bittorrent, but i can't access to the gui... is this feature supported on this version
    Last edited: Jun 8, 2014
  23. wit100

    wit100 Networkin' Nut Member

    Got myself a R7000 yesterday. For me, the most important thing is wired routing performance (WAN<-->LAN, both directions) with over 100 wired clients. Is the latest (v119 as of now) stable enough for this purpose?

    Extra background info:
    - I will have some port access restriction rules based on MAC and IP addresses.
    - Doesn't matter if wireless is stable or not for my purpose (but wired must be absolutely solid).
    - DHCP must work reliably.

    If anyone who has tried R7000 v119 could please chime in, it would be appreciated! Thank you!
  24. Mercjoe

    Mercjoe Network Guru Member

    Honestly, the firmware for the ARM routers should be considered a beta at this time. I would not use it in any kind of production environment.

    Will it be capable of what you are asking? Of that I am sure. But right now things are still being worked on/fixed.

    For the record, I have a R7000 with w /119 on it. I am using it as a AP at the moment till the QOS and IP traffic issues are fixed. Will it route traffic, oh yes. It does that VERY well. It is the lack of QOS and bandwidth monitoring that is keeping me from moving it to the main position.
  25. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Here it is:

    Bug trackers lose the advantage of the community. If suggestion for improvement is posted here, other people may have contributions and fixes for that issue and can help the developer. If you just use the bug tracker, you are essentially asking one individual to do all the work. Shibby and the others do this for free and for fun. It's more fun if we all help!
    Lamoboy and NokHook like this.
  26. abubin

    abubin Addicted to LI Member

    I went to look at that bug tracker and there are tons and tons of bugs being posted there. I am sure some of them are not bugs but shibby really need someone to help sort them out. Too bad I am swamped with work and family or else I would have offered to help. I love tomato firmware and would love to see it over-take dd-wrt or open-wrt as the best thirdparty firmware for routers. I can see why shibby wanted to do the tomatoanon project. It really helps him to prioritize on fixing bugs on routers that are being used the most. Wait..I think will donate once I solve my own financial problem.
  27. wit100

    wit100 Networkin' Nut Member

    My primary tomato is rt-ac66u.

    Playing somewhat with R7000 (v119). Ping time seems fine so far on wired. I have wireless turned off. Looking forward to the next version! Hope it will be production ready soon!

    I can totally see R7000 Tomato becomes the next rt-n16 as Tomato for R7000 matures. The hardware is awesome.
    Last edited: Jun 9, 2014
  28. Fredrik

    Fredrik Networkin' Nut Member

    Thanks again for the awesome work that you do! You make my router worth more than twice what I paid for it.

    I made a donation for €50 to your PayPal, I hope you have something fun to spend it on!

    I can also report that I overclocked the R7000 according to your instructions and my OpenVPN client speed went from ~42mbit to ~58mbit with 100mbit Internet over wlan. Absolutely amazing!
  29. kamaaina

    kamaaina Serious Server Member

    I think so too. It's a great box with enormous potential. To your other questions: I have about 10-15 clients connected at any given time, so nowhere near the 100 you are talking about. It's a mix of DHCP and Static DHCP (printers, network receiver for airplay, HTPC) based on MAC addresses. Seems to run fine. I was fine with 118 and it's been fine now with 119. Three weeks so far and I rebooted twice. One time because I changed setting and another when upgrading to 119. Throwing this in production with 100 users is a different beast though, probably worth waiting a few more releases.

    Last edited: Jun 9, 2014
  30. Ole Juul

    Ole Juul Networkin' Nut Member

    I haven't been paying attention for a while, and am still running Shibby 1.28.0000 MIPSR2-105 K26 USB AIO on my Netgear WNR3500L v2. Has much happened since? Would I gain much by getting the latest version?
  31. kamaaina

    kamaaina Serious Server Member

    v105? Probably plenty of bug fixes, performance tweaks, give it a few days/weeks until v120 comes out and then update with the rest of us.
  32. PartisanEntity

    PartisanEntity Networkin' Nut Member

    Hi there, sorry if this has been answered or is obvious, but will v119 be available for users of K24? (WRT54GL in my case).
    Last edited: Jun 9, 2014
  33. wit100

    wit100 Networkin' Nut Member

    i seem to recall the answer is "no" but there will be with v120. having said that, i am not 100% - not like i know what i am talking about...
  34. toolbox

    toolbox LI Guru Member

    I installed tomato-K26USB-1.28.RT-MIPSR2-119-VPN.trx to my Belkin F7D4301 V1 router. Everything seems to work except I don't see the option for 5GHz anymore. Before 119, I think 5GHZ was available for build 116. Any idea why?
  35. wit100

    wit100 Networkin' Nut Member

    1. Clear NVRAM first - the router will reboot.
    2. Reboot (just a simple reboot)

    That should fix it. Did it for me on a different model.
  36. kIssGlaY

    kIssGlaY Networkin' Nut Member

    This problem seems still there in 119 ARM.
    Adding virtual wireless to 2.4G(wl0.x) would mess up several pages -- Basic|Network, Advance|Virtual Wireless.
    The content of "Basic|Network|Wireless(5GHz/eth2)" is missing thus can't set anything belonging to that part, and "Save" button in "Advance|Virtual Wireless" is useless(having no effect).
    Donno if it's just a cosmetic glitch or what.

    Attached Files:

    Last edited: Jun 10, 2014
    JameZUK likes this.
  37. toolbox

    toolbox LI Guru Member

    Never mind.
    Last edited: Jun 10, 2014
  38. shibby20

    shibby20 Network Guru Member

    [RELEASE] v120 is now available.

    Please read changelog first.

    Best Regards.
  39. callous

    callous Network Guru Member

    Thank you
  40. leandroong

    leandroong LI Guru Member

    ZTE ZXV10 H618B, Tomato Firmware 1.28.0000 MIPSR1-120 K26 USB AIO

    Very nice dnscrypt-proxy drop down menu. Thanks again ....
  41. wit100

    wit100 Networkin' Nut Member

    This is a stupid question, but I searched and can't find the answer.

    There are two versions of R7000 Shibby Releases: AIO vs. VPN.

    AIO is obviously All-In-One so it has everything.

    I am not clear what is in AIO that is NOT in VPN... Anyone?
  42. JoeDirte

    JoeDirte Networkin' Nut Member

    There used to be a builds.png file in each of the version folders, but it seems like it is no longer included. Perhaps it is no longer accurate, but here is the builds.png from the v101 folder:

  43. lolento

    lolento Serious Server Member


    On AC66U with v120, I cannot change channels for 5GHz 80mHz Ch width. The drop down is no longer available...had to revert back to v190.

    Although in v120, the status page show that I am using 80mHz Ch
  44. eduncan911

    eduncan911 Reformed Router Member

    E4200v1 - TomatoUSB Shibby v120

    Long time Tomato v1.25 (and earlier versions) user on my WRT54Gv3 for many many many years (and DDWRT before that)... Just loaded Shibby's TomatoUSB on an E4200 I just inherited to replace the WRT54g on my Verizon FiOS pipe.

    Question: How do I change the LAN MAC? I can change the WAN and WL0 and WL1, but not the LAN.

    I tried nvram with:

    nvram set et0macaddr=XX:XX:XX:XX:XX:XX
    nvram commit

    But it doesn't stick - either via a soft reboot, or a power cycle. Always reverts back to the "Default" setting.

    I have quite a few virtual machines running on several host servers. They are all configured for "Private" networking (Windows), which FYI is all tied to a LAN MAC address it designates as a "network."

    Needless to say, if the MAC address of the gateway changes, it's a PITA to go in and reset all the firewalls and networks for each and every VM. I've had to do it once or twice with the Verizon FiOS router and WRT54G swaps, etc.

    I was able to set the LAN MAC in Tomato.
  45. eduncan911

    eduncan911 Reformed Router Member

    Oh, and FYI, I WILL INVEST into a stable R7000 build. If you, Shibby, is up to the task I'll throw a few C-bills your way.

    Since I am running a phat pipe (150/65), I've never been able to see that bandwidth with my WRT54G v3.0. I accounted it to the slow CPU after years of research. Using the default Verizon FiOS router, I get the speed.

    I have 3 WRT610N v2s that I got cheap used for wifi routers throughout the house... They were not able to do much better than the WRT54g w/DD-WRT loaded on them as the FiOS gateway.

    I'm aware the E4200 v1 isn't that much faster than the WRT610N v2.0 (same hardware). But, I have never tried TomatoUSB. This will be my experiment to see if it can handle the phat pipe I got by enabling CTF (IPv4 only).

    If not, the Netgear R7000 will be my next purchase.

    Any other tips for big bandwidth on TomatoUSB builds, please let me know.
    Last edited: Jun 11, 2014
  46. conquer22

    conquer22 Network Newbie Member

    Quick question as I use R7000 only for AP with no special features(VPN nor SSL nor etc).
    Can anyone please tell me would there be any performance advantage on tomato(OC 1400,800) VS stock (latest FW)
  47. ksergey2012

    ksergey2012 Serious Server Member

    Dear Shibby! I updated the firmware for the router AC - 66U for v.120 (VPN), identified the following challenges:
    1. Within the range of 5 GHz - there is no choice of channel width = 80, although in the "status" indicates that the channel width is set - 80.
    2. When selecting a particular channel number in the "status" indicates that you select the smallest channel.
    Return back to the firmware v.119.:(Screenshots:

    Attached Files:

    Last edited: Jun 11, 2014
    lolento likes this.
  48. mstombs

    mstombs Network Guru Member

    Thanks for the update shibby.

    One observation after reviewing the start-up log - not new its been happening for years - is that the firewall script still gets run 3 times in quick succession around the time of wan connection (dhcp):- (I currently have a simple logger "firewall script") in there, but this has caused me script problems in past with long slow scripts

    Jan 1 00:01:11 rtn66u user.notice root: firewall script
    Jun 11 09:04:43 rtn66u user.notice root: firewall script
    Jun 11 09:04:43 rtn66u user.notice root: firewall script
    Jun 11 09:04:44 rtn66u daemon.notice miniupnpd[1049]: version 1.8 started
    Jun 11 09:04:44 rtn66u daemon.notice miniupnpd[1049]: HTTP listening on port 50376
    Jun 11 09:04:44 rtn66u daemon.notice miniupnpd[1049]: Listening for NAT-PMP/PCP traffic on port 5351
    Jun 11 09:04:44 rtn66u user.notice root: wan-up script
    Clearly the WAN is connected enough for time to update after the first run of the firewall, but why does it need to run twice more?
  49. Anzial

    Anzial Addicted to LI Member

    Same crap on n66u, only 20mhz channel on 5ghz band, even though settings are set to 40mhz. Confirmed by Inssider, the 5ghz is at 20mhz width instead of 40 in the settings
    Last edited: Jun 11, 2014
  50. kthaddock

    kthaddock Network Guru Member

    Thanks Shibby for new build! :D

    I have discoverd one little quirk in Interference Mitigation mode, get error when try to use that.
    Only in mode 4 "WLAN auto with Noise Refuction" all other, 1-3 seems to working.
    If I check with: #wl -i eth1 interference" I get :
    Is some choice not used anymore?
    Tested all, all seems to work but GUI doesn't like that. (mode 4)

    Only 1h uptime, RT-N16 120-aio


    Attached Files:

    Last edited: Jun 11, 2014
  51. Justio

    Justio Networkin' Nut Member

    Thanks for the update shibby20.

    Is there also an update v120 for K24 builds?
    There are still some users like me that use the K24ND (VPN) version on the old WRT54GL and this would be much appreciated!!
    At least the openssl update to 1.0.1h :)?

    Thanks in advance and keep up the good work.
  52. qashi

    qashi Reformed Router Member

    is it possible to disable all led with the button on the back on ac68u? like in ofw/merlin.
  53. PartisanEntity

    PartisanEntity Networkin' Nut Member

    Same here. Would really appreciate any updates for wrt54gl users.
  54. kamaaina

    kamaaina Serious Server Member

    Thanks for the release, everything seems fine at first glance. On R7000 120 AIO, uptime 5 min.
  55. redsandvb

    redsandvb Network Guru Member

    If you clear nvram and let it reboot and then reboot a second time, does that fix anything?
  56. redsandvb

    redsandvb Network Guru Member

    The changelog says for v116:
    "!! Attention: Builds BT-VPN and TOR-VPN are now too big for WNR3500Lv1 and all routers supported by K26RT-N with 8MB flash (like RT-N10U)."

    Is that still the case? I noticed for v116 there is a separate 116-BT (in addition to BT-VPN) build for K26RT-N, did not notice for later builds.
  57. FrancoisC

    FrancoisC Network Guru Member

    IPV6 (6rd option 212) used to work with my ISP (Videotron) but since version 109 it does not anymore. I found a guide with a script that fix it (Link at the bottom of this post) but I was wondering if it was possible to include the fix directly in the firmware? Thanks!
  58. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    Alright, I've downloaded V120 RT-N Big-VPN this time I've erased NVRAM (thourough) and started configuring everything by hand (only by GUI, without nvram set or restoring a binary backup).

    The error is still there, please don't mock me again, I've lost 8 hours already trying to figure out what NVRAM setting is causing it, my inevitable conclusion is that the WEB MODULE is just MISSING or it's not loaded from the proper path in builds dedicated to 8Mb routers!
    v119-120 NoCat version are the same.

    @kthaddock said he doesn't exhibit the error, and I think he's an advanced user, so he knows what he's talking about, but, probably he uses AIO.

    To get the error I just need to enable PPOE for WAN, the access restriction and that's it... as always blocking all internet access dismisses the error!
    error 2.jpg
    Last edited: Jun 12, 2014
  59. kthaddock

    kthaddock Network Guru Member

    Yes I'm using 120-AIO build and DHCP.
  60. Mihai Olimpiu-Cristian

    Mihai Olimpiu-Cristian Networkin' Nut Member

    You might be on to something, as WAN is configured for DHCP initially and no error shows up, when I'll go home I'll test and post results here!

    Later edit:
    @kthaddock: yes, you are right, if I set WAN to DHCP (not connected), the error disappears! My ISP uses PPOE tough :(

    The error is also purely cosmetic, it does block the domain, I didn't wanted or dared to test on the device itself for reasons I would rather not say here.

    So, in conclusion the error only appears only when PPOE is used, tough cosmetic it's pretty annoying as it appears also in IPv6 page...
    Last edited: Jun 12, 2014
  61. wit100

    wit100 Networkin' Nut Member

    For R7000, I can confirm erratic ping times for both:
    - within LAN (PC to router)
    - from PC to outside servers (

    I am comparing these ping times with v117 on RT-AC66U. The difference is extremely significant.

    See screenshots for comparisons of these two routers (attached)

    Note these erratic times are also reflected when loading websites.

    Attached Files:

    Last edited: Jun 12, 2014
    The Master likes this.
  62. eduncan911

    eduncan911 Reformed Router Member

    Just a question...

    Others in this thread, around the last page and this one, say there was huge pings as well.

    A power-cycle resolved the ping issues with V119 from what many others reported.

    Did you try to power it off, and back on?
  63. The Master

    The Master Network Guru Member

    Here to with Vitek and shibby FW... was gone for a while... but came back :( ... there is no problem @N-16 Same fw.
  64. wit100

    wit100 Networkin' Nut Member

    - Powered off
    - Powered on
    - Erase NVRM (thorough) and reboot
    - Reboot (through Administration this time) so that the wireless features appear
    - The router sits there idle, not actively used (it's not my primary one) with a laptop connected through Ethernet.

    Oh, by the way, the CPU temp is about 57C.

    After 24 or 48 hours (not sure how long), I took the screenshots above.
  65. eduncan911

    eduncan911 Reformed Router Member

    Coo Coo... Just trying to help. :)
  66. shibby20

    shibby20 Network Guru Member

    @mihai indeed, web module for ip6tables is missing (also in v119). I will fix it in next release. Temporary you can try disable ipv6. Then access restriction should works.

    Wysłane z mojego IQ4410 przy użyciu Tapatalka
  67. lolento

    lolento Serious Server Member

    No it doesn't tried this many times.

    There is no 80mhz channel option in v120.
  68. xtacydima

    xtacydima LI Guru Member

    Are any Android phones with tether capability supported by USB?
    I tried mine but won't even get detected :(

    Any way to get them to work?
  69. eris23

    eris23 Networkin' Nut Member

  70. vincom

    vincom LI Guru Member

    5ghz led does not shutoff when disabling radio, script for stealth shuts off all led's except for the 5ghz radio led.
  71. redsandvb

    redsandvb Network Guru Member

    Oh, OK.

    Sorry, I dont have an AC66U but the other poster I quoted said they had a similar problem with 40MHz width on an N66U, which I do have.
    After installing RT-AC6x--120-AIO-64K on my N66U, I had it clear nvram and then I rebooted a second time following that. I have my 5GHz set at 40MHz width and so far my 5GHz devices (only have 2 in use) are connected with 40MHz width. If it matters, I am using Country=Singapore and Transmit Power=0 in the Advanced-->Wireless settings.
  72. HKPolice

    HKPolice Network Guru Member

    Been like this since the first AC firmware... no hint of fix ever coming.
  73. kthaddock

    kthaddock Network Guru Member

  74. HKPolice

    HKPolice Network Guru Member

    Another bug with AC66U v120: cannot change the wifi channels. The pull down menu works and pressing save is normal as well, but in the overview page no changes were made. Verified with wifi clients that channel is the same as before. Tried resetting nvram but same thing occurs and changing the country doesn't fix it either.

    Went back to v119 and everything is working normally.
  75. kthaddock

    kthaddock Network Guru Member

    Did you reset "forget" your client and reconect when testing?
  76. HKPolice

    HKPolice Network Guru Member

    Not required, changing wifi channels automatically resets the connection with all clients and forces them to reconnect on the new channel. Worked this way with all previous versions, and wifi clients never remember the channel they were previously using, only the AP name & password.

    This is clearly a bug with the coding.
  77. joecop67

    joecop67 Networkin' Nut Member

    I am not sure where to ask. Will there be a build for the netgear6250?
    The netgear firmware disables 1 of the cpu cores ans uses half the ram.
    dd-wrt isn't working well for me.
  78. Justio

    Justio Networkin' Nut Member

    [RELEASE] 087

    - propably this is the last release of K24

    @Shibby -> is there any way to make you change your mind? and maybe update only openssl for K24 builds?:)

  79. wit100

    wit100 Networkin' Nut Member

    I would think it is difficult to support several platforms (just speculating here). I think in general, it is easier to have a "defining router" kind of thing for Tomato as hardware changes.

    For example...
    1st Defining Router of Tomato: WRT54G
    2nd Defining Router of Tomato: RT-N16

    There are other routers with similar hardware that got supported along the way, which makes perfect sense since they are only slightly different from those two.

    Looking at all the routers on the market, it seems to me the next logical one is Netgear R7000.

    At some point, it is necessary to discontinue support for older hardware for a variety of reasons. It just makes more sense to choose a router based on Tomato support instead of buying a router and hoping that Tomato will support it eventually.
  80. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    for my the third defining router of tomato would be the RT-AC66U. however it is my first tomato router :)

    and i love it.

    personally im just waiting for a MU-MIMO router with tomato support

    that will be the next big step IMO
  81. kamaaina

    kamaaina Serious Server Member

    Yep, maybe something like this.
    For example...
    1st Defining Router of Tomato: WRT54G
    2nd Defining Router of Tomato: RT-N16
    3rd Defining Router of Tomato: N66U/R AC66U/R
    4th Defining Router of Tomato: AC56U/AC68U
    5th Defining Router of Tomato: R7000

    I think this can help as a buying guide. E.g. Kong stated in a post that he will focus on the dual-core ARM due to work-focus so that means DD-WRT support for these routers as well. For me this is always a buying criteria. Strong router (HW) with great firmware options.
  82. Connor McCaffrey

    Connor McCaffrey Networkin' Nut Member

    for me r7000 is the 4th and the 56/68 don't matter ;)
  83. Justio

    Justio Networkin' Nut Member

    Returning to the main ideea => the fact is that K26 -R1 miniVPN build is (a bit) too large for WRT54GL :(... so that's why I have asked if possible to update only openssl for K24 VPN order to stay secure :eek: on old hardware also.

    Best regards.
    Last edited: Jun 15, 2014
  84. esoterik

    esoterik Network Newbie Member

    I just bought an RT-N66U. Looking at Shibbys firmwares for this device I see K26RT-N and K26RT-AC both listed for the RT-N66U. Which one should I choose? And why?
  85. Powerkraut

    Powerkraut Reformed Router Member

    Same here: I cannot change channels, channel width/sideband or wireless mode in neither network (2,4 or 5 GHz).
  86. MaX PL

    MaX PL Networkin' Nut Member

    well your router doesn't have AC so I would go with K26RT-N.
  87. DallasFlier

    DallasFlier Network Guru Member

    And for others, the RT-AC68U is the 4th and the R7000 doesn't matter. Your point?
  88. wit100

    wit100 Networkin' Nut Member

    Well, everyone, let's all take it easy. :) I think we all like RT-AC68U/AC56U, and all of us are eagerly awating to see R7000 mature.
  89. Anzial

    Anzial Addicted to LI Member

    I chose the latter for my n66u simply because it has updated broadcom wifi drivers. Works fine, imho.
  90. Maivorbim

    Maivorbim Serious Server Member

    Hello and first of all thank you Shibby for this wonderful firmware. I have just come from DD-WRT and i feel Tomato works better and with fewer headaches :)
    I have installed the latest v120 firmware on a R7000 router, all works fine and i even managed to install optware. However, i have an issue with iperf. Even if it installed sucessfully, it complains about a missing library, Any idea how ican fix this? Best regards

    root@R7000:/opt# ipkg install iperf
    Installing iperf (2.0.4-1) to /opt/...
    Configuring iperf
    Successfully terminated.
    root@R7000:/opt# iperf
    iperf: can't load library ''
  91. The Master

    The Master Network Guru Member

    Maivorbim likes this.
  92. shibby20

    shibby20 Network Guru Member


    Maivorbim likes this.
  93. Maivorbim

    Maivorbim Serious Server Member

    Thank you :) i assumed that ipkg already downloaded all the necessary dependencies.
  94. JTD121

    JTD121 Addicted to LI Member

    I like the updates to the dnscrypt-proxy system in 120, Shibby! Using okturtles for the moment, due to geographical location (in the US), unless there is someplace else I should be using?
    lancethepants likes this.
  95. Bozo29

    Bozo29 Networkin' Nut Member

    Toastman explained how to restore the configuration from a router to another or on the same router that runs Tomato.

    So far I have used this way to restore settings after every update.

    I recently changed the router "RT-N66U" with one "RT-AC68U" and I did upgrade to "tomato-RT-AC68U-ARM-120-AIO-64K"
    I was surprised to see that the command "nvram export --set" does not work.
    Instead, I found that there is the command "nvram show".

    For example, for:
    nvram export --set | grep dhcpd_static
    now is:
    nvram show | grep dhcpd_static
    And has the same result.

    My question is:
    This change is only for TomatoARM?
  96. xiaobb

    xiaobb Network Guru Member

    Have you tried killing the process blink_5g?
  97. vincom

    vincom LI Guru Member

    i would try but went back to merlin for now as wifi for me was too, um how to say this in a nice way.....a bit flaky.
    ive been using shibbys builds on my wrt54gtm and wrt54gl forever, took awhile to get used to another gui but merlins firmware is pretty good and wifi is more stable for my devices, i'll wait for 121 to test again.

    question, the ac66u is not listed in shibbys supported router page but he has firmware posted for it, does this mean that its considered beta
  98. IcyTexx

    IcyTexx Networkin' Nut Member

    Is the transmit power option working?
    I've been changing the values on E7000 but the signal stays the same?

    Also, is beamforming in the works?
  99. nmalinoski

    nmalinoski Networkin' Nut Member

    I'm having an issue with DNS resolution on Shibby 120, particularly with OpenVPN.

    I have the OpenVPN configured site-to-site, with Server Address on the client end (Where I'm having the problem) configured as a domain rather than an IP address, because the external IP on the server end is assigned via DHCP (Home connection). Unfortunately, when the router comes up fresh (Or periodically, for whatever reason), OpenVPN fails to connect with the following error:
    daemon.err openvpn[8002]: RESOLVE: Cannot resolve host address: <domain>: Name or service not known
    I have no idea what causes this resolution failure. If I do an nslookup with my router as the DNS server, lookups time out. If I use my ISP's DNS servers, which are configured under Static DNS on the Basic>Network page, the resolution is fast. The only thing I've found to work is if I ping the target domain from my desktop (Windows box); once that resolves the IP, the router's like "OH!" and connects just fine. I suppose that cached record eventually expires, and then eventually causes my VPN connection to disconnect.

    Any help or insight would be appreciated.
  100. Daryl Martin

    Daryl Martin Serious Server Member

    I upgraded my Linksys E2500v1 from a TVLZ beta build to Shibby 120en. I don't have any 5ghz cards, so I turned the radio off. Since that point, the 5ghz settings stopped showing. This isn't a big deal, since I don't use it. But it was more reassuring when I could see the settings & know it was off. I erased the NVRAM, and the 5ghz reappeared. I reloaded the settings manually, and it went away again. Just an FYI.....

    Edit: Tvlz answered this issue in another thread. The 5ghz is also dependent on the USB Core support module. I had disabled the usb, since my 2500 didn't have it. As soon as I re-enabled it, the 5ghz reappeared. Thanks Tvlz.
    Last edited: Jun 23, 2014
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice