Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. thecodemonk

    thecodemonk Connected Client Member

    From my hard wired PC to the router, pinging the router. The ping time should be consistently less than 1 millisecond. When this issue is occurring, it is NEVER less than 1 millisecond, but all over the place including over 200-300 milliseconds at time. It does affect latency outside of the network and also the latency between other devices on my lan. I also tested on the WIFI and the same problem exists there, although I realize you will never get a less than 1 millisecond response time. Ping over wifi also wasn't consistent within reason. Doing it from my phone sitting right next to the router and it was also all over the place, from anywhere between 10ms and 500ms. When the issue is resolved, it's less than 10ms no matter when I am in the house.
  2. koitsu

    koitsu Network Guru Member

    Thanks @mkozlowski and @thecodemonk. If I remember right, I thought that was a bug in an old version of Shibby's firmware which got addressed. (I'm going off of memory here, I just remember there being a large discussion about it and he figured out what the issue was). Maybe something was accidentally reverted? Best to wait for him to respond I think.
  3. jd_hupp

    jd_hupp Network Newbie Member

    I have been studying alternative firmware choices for a Linksys E1200 v2 for several days. We have one PC that is only supposed to be used for email and light web browsing. For security, I want to place it on its own subnet (VLAN will do this?) And then to enforce its proper use I want to limit its available download speed.

    It looks like Shibby's Tomato is the best choice. I have downloaded tomato-E1200v2-NVRAM64K-1.28.RT-N5x-MIPSR2-121-Max.bin. But I have never installed a non-stock router firmware and have not been able to find a how-to for the Linksys E-Series.

    Can I just use the stock firmware GUI to install the Tomato image? Then reset the NVRAM and reboot (or reboot and then reset the NVRAM).

    I read in one or two places about a Tomato option to reinstall the stock firmware. If the installation succeeds but I don't like it, can I indeed do this?

    If the upgrade to Shibby goes badly and I brick the router, what is the de-brick procedure?
  4. squingynaut

    squingynaut Network Newbie Member

    I apologize in advance if this is a dumb post as I honestly don't know anything about ASP, building Tomato from source, or even Git. I recently upgraded my Shibby firmware to the latest release (v121) and was having a terrible time getting my router (AC66U) to switch to an 80 MHz channel width. I had worked around some quirks with this on previous versions but the ways around it I used before weren't working. I don't speak any of the relevant languages but I looked into the code and found a commit from May 28th that I thought might have something to do with the problems I ran into (link). Again, this code is all very foreign to me but it looks like all references to the 80 MHz channels and 802.11ac support were overwritten with this commit, making the settings inaccessible on the basic settings page. Since I don't know the first thing about building Tomato, I just rolled back to the last Shibby version before the commit was made (v119) and I was easily able to get all of my 80 MHz channel width problems resolved. Can someone who knows more about this tell me if I'm way off track here or if there is something else I should have been doing after flashing the newer version?

  5. christophocles

    christophocles Network Newbie Member

    I just installed Shibby firmware on my WRT54G-TM. I am using this image:

    I was using Toastman firmware before. All in all, the feature set is great. Big improvement over Toastman. But I am having some major issues with load. When I start some moderate bittorrent usage, everything slows completely to a crawl. The web interface is slow and unresponsive, the wifi stops responding, dns stops working, I basically can't do anything until I turn the torrents back off. Even SSH screen updating is delayed by several seconds. Memory usage is OK (60%+ free), so all signs point to high CPU load.

    When this is going on, I log into SSH and run the 'top' command, and the load average reads 8.0+ and the CPU usage for [ksoftirqd] is 60%+. The connection count under Conntrack/Netfilter is around 500.

    I have tried a few things to try to minimize the load on the router CPU:

    -Disable 'Inbound Layer 7'
    -Disable Web Monitoring and IP Traffic Monitoring
    -Disable logging to external server (syslogd)
    -Disable VLANs and Virtual Wireless APs
    -Disable QoS
    -Disable dnscrypt

    QoS and dnscrypt seem to have made a significant difference, I assume they are pretty CPU-intensive. But even with all of these features disabled, it's still not what I'd call 'normal'. The web interface is still more laggy than I am used to. I've looked through the menus for Shibby to try to find other default-enabled features that are resource hogs and I haven't found much else. It's bare bones right now with all of this stuff disabled.

    Perhaps I should use Kernel 2.4? Would that make a huge difference? I used K2.6 for IPv6 support in the future when my ISP enables it, but I'm not using it right now so I probably don't have any other reason for K2.6.

    I used to be able to run this router with many more features enabled on the Toastman firmware and I never had a problem with load like this. I had lots of QoS rules, OpenVPN, Web Monitoring, just about every nice feature was enabled and I could run torrents with hundreds of connections without a hiccup. If anyone has any ideas I'd appreciate your input.
  6. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    Are you running the torrent client on the router or on a wired or wireless device on your network?

    That's an old router with a CPU that will get bogged down with anything more than routing packets at the modern speeds offered by ISPs. The torrent would cause least CPU overhead on a wired device/PC on your network, a tiny bit more for wireless.
  7. boghea

    boghea Reformed Router Member

    Hi all,
    I have installed OwnCloud 7 on shibby's TomatoUSB v122 and I am wondering if there is a way to enable nginx (web server) to use https instead of http. I don't want to use OwnCloud without https.
  8. jd_hupp

    jd_hupp Network Newbie Member

    Answering my own questions:

    I found out that yes, I can install Shibby as above, and that it supports reinstalling the stock firmware.

    I also found out that the unbrick/debrick procedures are widely enough detailed -- they are not at all particular to Shibby.
    Last edited: Sep 3, 2014
  9. Image This

    Image This Reformed Router Member

    Well 80mHz Channel-Width isn't displayed for me in the 5G-Config with the latest build on both the AC56U as well as the AC66U (Non-ARM CPU). However resetting the NVRAM once puts it to 80mHz, which you can see in the overview mode so it 's at least working at that width right now.

    However the channel-width list shows 40mHz as maximum for my AC66U with AC1750 5G and setting it to any value, saving and rebooting - even doing complete a NVRAM wipe + reflash + NVRAM wipe cycle simple changes - nothing.

    So I guess it 's a general bug not only related to the ARM build.
  10. christophocles

    christophocles Network Newbie Member

    The torrent client is running on a PC. I would definitely _not_ attempt to run the torrents on the router itself, it's painfully obvious that would never work. It couldn't even handle the NoCat portal, I experimented with it but I had to turn it back off immediately as it could hardly even load the gateway page. But like I said, I was able to do a lot more with this hardware (without noticeable slowdowns) on the Toastman firmware for some reason. I really think K2.6 might have something to do with it. I will try K2.4 build.

    And I will solder a JTAG onto my bricked E3000 router to attempt to bring it back from the dead. I'd really like to be able to take advantage of all this Shibby firmware has to offer, and the WRT54 just isn't going to cut it.
  11. Marcel Tunks

    Marcel Tunks Networkin' Nut Member

    K2.4 is definitely faster on that hardware. You only need K2.6 if you are using IPv6.
  12. cavemandaveman

    cavemandaveman Reformed Router Member

    I would like to know this too. I tried to enable https admin access on the router gui in hopes that would solve it, but I can't even access the admin page on https for some reason, only http : (

    I am also getting a second security warning with owncloud saying "the .htaccess file is not working". Anyone know how to get rid of it?
  13. Quad5Ny

    Quad5Ny Networkin' Nut Member

  14. John Galt

    John Galt Network Newbie Member

    Any chance of getting true multi-link PPPoE going? Given how slow DSL is, this is a must and I'd rather use a router to do this than a server or expensive cisco box or something like that. Looks like part of the code from the fixppp stuff is already in. Would be great if the rest was in and working. (up to 4 would be awesome, then you could have one port that goes to a switch and 4 that are PPPoE)

    (I'd be willing to donate to this effort.)

  15. MrDoh

    MrDoh Addicted to LI Member

    I have Comcast, and DHCP6-PD works perfectly for me on v122. I have the following 2 commands in my firewall script:

    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding
    ip6tables -A PREROUTING -t mangle -p icmpv6 --icmpv6-type neighbor-solicitation -i vlan2 -d ff02::1:ff00:0/104 -j DROP

    The second line is because I get lots and lots of "neighbour table overflow" messages overnight from Comcast, and this command sends them to the cornfield instead of causing log entries. The other night I got over 50,000 of these packets courtesy of Comcast.

    But IPv6 works great here.
  16. Quad5Ny

    Quad5Ny Networkin' Nut Member

    Nope that didn't work either. All my settings are exactly the same as on Toastman's build but IPv6 is not working.

    I can't even ping google from the web console (the address resolves but it seems any data ends up in a black hole):
    ping -6 -c 4 -W 1 -w 5
    PING (2607:f8b0:4004:809::1004): 56 data bytes
    ping: sendto: Network is unreachable

    Also when I try to turn on Access Restrictions with IPv6 I get ip6tables-restore: failed at line 72.

    Hold on… I messed around with a bunch of different settings and now IPv6 is working. I'll post back with what fixed it.
    Last edited: Sep 5, 2014
  17. Quad5Ny

    Quad5Ny Networkin' Nut Member

    Here are some facts I've found out so far:
    • R7000 v122 VPN and R7000 v122 AIO both have the same problem
    • IPv6 Worked perfectly with Toastman's latest build for the 66U (rebooting and all).
    • Erasing NVRAM and starting from scratch does not help
    • AAAA DNS records work fine (ie. Resolving to a IPv6 address)
    • I can successfully ping the routers Local IPv6 address as soon as it boots.
    • IPv6 WAN addresses take about 5 minutes of router uptime and I need to have "echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding" in my firewall script.
    • If i try to ping a external IPv6 address just before it comes online I get a whole shitload of duplicates:
      --- ping6 statistics ---
      4 packets transmitted, 4 packets received, [B]+276 duplicates[/B], 0.0% packet loss
      round-trip min/avg/max/std-dev = 27.595/43.186/61.148/11.080 ms
    • If I have any Access Restrictions enabled External (WAN) IPv6 never works and I get "ip6tables-restore: line ## failed" on the Access Restrictions page.
    • If I enable Access Restrictions AFTER IPv6 is up and working, external WAN addresses go down for another 5 minutes and I also get the ip6tables-restore error. More Details:
      Access Restrictions Error: "ip6tables-restore: line 64 failed"
      Syslog Error: unknown user.crit preinit[1]: Error while loading rules. See /etc/ip6tables.error file.
      :OUTPUT ACCEPT [0:0] 
      :INPUT DROP [0:0] 
      :OUTPUT ACCEPT [0:0] 
      -A INPUT -m rt --rt-type 0 -j DROP 
      -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT 
      -A INPUT -p ipv6-nonxt -m length --length 40 -j ACCEPT 
      -N shlimit 
      -A shlimit -m recent --set --name shlimit 
      -A shlimit -m recent --update --hitcount 4 --seconds 60 --name shlimit -j DROP 
      -A INPUT -i br0 -p tcp --dport 22 -m state --state NEW -j shlimit 
      -A INPUT -i br0 -j ACCEPT 
      -A INPUT -i lo -j ACCEPT 
      -A INPUT -p udp --dport 546 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 1 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 2 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 3 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 4 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 128 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 129 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 130 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 131 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 132 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 133 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 134 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 135 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 136 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 141 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 142 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 143 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 148 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 149 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 151 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 152 -j ACCEPT 
      -A INPUT -p ipv6-icmp --icmpv6-type 153 -j ACCEPT 
      -A OUTPUT -m rt --rt-type 0 -j DROP 
      :FORWARD DROP [0:0] 
      -A FORWARD -m rt --rt-type 0 -j DROP 
      -A FORWARD -i br0 -o br0 -j ACCEPT 
      -A FORWARD -m state --state INVALID -j DROP 
      :restrict - [0:0] 
      -A FORWARD -o vlan2 -j restrict 
      -I INPUT 1 ! -i lo -p udp --dport 53 -j restrict 
      :rres00 - [0:0] 
      -A rres00 -p tcp -m web --hore "" -j REJECT --reject-with tcp-reset 
      :wanin - [0:0] 
      :wanout - [0:0] 
      -A FORWARD -m state --state RELATED,ESTABLISHED -j ACCEPT 
      -A FORWARD -o vlan2 -i vlan2 -j DROP 
      -A FORWARD -p ipv6-nonxt -m length --length 40 -j ACCEPT 
      -A FORWARD -p ipv6-icmp --icmpv6-type 1 -j ACCEPT 
      -A FORWARD -p ipv6-icmp --icmpv6-type 2 -j ACCEPT 
      -A FORWARD -p ipv6-icmp --icmpv6-type 3 -j ACCEPT 
      -A FORWARD -p ipv6-icmp --icmpv6-type 4 -j ACCEPT 
      -A FORWARD -p ipv6-icmp --icmpv6-type 128 -j ACCEPT 
      -A FORWARD -p ipv6-icmp --icmpv6-type 129 -j ACCEPT 
      -A FORWARD -i vlan2 -j wanin 
      -A FORWARD -o vlan2 -j wanout 
      -A FORWARD -i br0 -j ACCEPT 
      -A FORWARD -i br0 -o vlan2 -j ACCEPT 
    P.S My ISP is TWC NYC (Road Runner).

    P.P.S I have a USB to TTL Serial debug cable so if someone is absolutely sure it will help, I'd be happy to log diagnostic messages.
    Last edited: Sep 5, 2014
  18. Energon

    Energon Network Newbie Member

    I have an Asus RT-N53 router with the latest (121) Tomato by Shibby, that is working as an AP.
    It works great, when it works...

    The problem is when I'm connected to 5 Ghz, If I download something big for 2-3 minutes, the connection freeze.
    In the same time, the 2.4 Ghz has no problem; I can connect, have IP, make traffic etc.

    If I try to reconnect to 5 Ghz, it connects, but it does not take an IP...

    Only a reboot fixes the problem. Any idea?

    Thank you!
    Last edited: Sep 5, 2014
  19. Mirko Baila

    Mirko Baila Networkin' Nut Member

    Version 122 for rt-N66U where you downloaded?
  20. kthaddock

    kthaddock Network Guru Member

    Not relesed yet!
  21. Quad5Ny

    Quad5Ny Networkin' Nut Member

    Ok so while I'm waiting the 5 minutes for IPv6 connectivity the Routing Table page (advanced-routing.asp) shows no default IPv6 Route.

    Also I confirmed it with "ip -f inet6 route show default dev vlan2", which shows nothing until the route is established.

    Is this and having to run "echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding" normal for Shibby's builds or am I doing something wrong?
    Last edited: Sep 5, 2014
  22. Bozo29

    Bozo29 Networkin' Nut Member


    Router: RT-AC56U.
    Firmware: Shibby 122 AIO.

    Problem: Besides the power LED, all other LEDs (USB x2, Wirelesss x2) are off.
    The USB ports are working and wireless are working, but no LED on.

    Any ideas?
  23. ierwin

    ierwin Networkin' Nut Member

    Shibby, I notice you have update the router list on your website.
    There's some mistakes.
    Tenda N6 has a BCM5358 running at 530MHz, not 300MHz. (I am sure on this because I own this device)
    Fiboom HG320 has only 64M RAM. (Most websites and forums in China confirm this, RAM: MIRA P3R12E4JFF 64MB, FLASH: MXIC MX25L12845EWI-10G 16MB, see below)

    Last edited: Sep 6, 2014
  24. NoobWRT

    NoobWRT Serious Server Member

    Anyone else experiencing DLNA problems?

    Also, still can't use JFFS on R7000 so I can put my DLNA database on that. :/
    Using v122 once again because lower ping is a must for me gaming. v121 was causing extreme lag spikes.
  25. zorkmta

    zorkmta Network Guru Member

    Is the ping lagging gone in ver 122 or better time ms than 121?

    Enviado desde mi LG-D802 mediante Tapatalk
  26. NoobWRT

    NoobWRT Serious Server Member

    ping is always 1ms.
    it's gone
  27. MrDoh

    MrDoh Addicted to LI Member

    Depends on what kind of router you have. If you have an Asus, no problem I hear. If you have a Netgear R7000, then nothing has changed in the ping time department. I can stabilize the ping times after a whole bunch of reboots until I have a reason to reboot. Then it starts all over again. No fun.
  28. Energon

    Energon Network Newbie Member

    A little update: I've tried also victek firmware and I have the same problem...

    Now I'm back to Asus FW...
  29. BinaryTB

    BinaryTB Network Guru Member

    I've either lucked out or everybody with ping time spikes have some unique configurations set up.

    I'm running an Asus RT-N66U with v121 (tomato-RT-N66U_RT-AC6x--121-VPN-64K) for a little more than a week (v115 before that) and no ping time issue here. They're always "<1ms" for me when pinging the router ( Ping is running continuously until canceled and no spikes. Uptime is currently 11 days.

    I probably have the usual setup as the "average" user. QoS rules, port forwarding, some static DHCP, DDNS, NTP, 15+ devices connected via wired, ethernet switch, wireless extender, 2.4GHz wireless, and 5GHz wireless; CIFS mounts (bandwidth and IP logs are stored there), USB Core disabled, etc.
  30. wit100

    wit100 Networkin' Nut Member

    I think the ping time issue occurs only in ARM builds (such as the R7000 everyone hopes to run Tomato on). If I am mistaken, someone please correct me.
  31. volgera

    volgera Networkin' Nut Member

    What is this ping problem? I have a R7000 with shibby 121 VPN and every time I ping -t my router its always <1ms.

    I also play games online and I'm not having any lag issues.

    I'm only using Port Forwarding (NAT-PMP off) and DDNS. 25+ connected devices. CTF is also off
  32. MrDoh

    MrDoh Addicted to LI Member

    You're lucky *smile*. The issue for me is that when I get the firmware completely configured, and ping the router, the ping times are pretty random. From <1 ms to hundreds of ms., just plain random. If I try to ignore this, it shows up as lag when I'm using the internet. I can reboot the router a bunch of times, and the ping times will eventually stabilize to "<1ms". Until I need to reboot the router for some reason, then they're random again, and need to do a bunch more reboots to get the ping time back to where it should be.

    That's about the only reason why I'm currently using stock Netgear firmware, since I'd much rather be using tomato. I've spent way too much time waiting for the router to reboot. Hope springs eternal though, I try each new release faithfully *smile*.
  33. Energon

    Energon Network Newbie Member

    So... there seems to be a driver issue or I have a lemon RT-N53!?

    Tomato Shibby and Victek - both same problem - 5Ghz Freeze
    Asus Stock FW - the 5Ghz SSID is gone.

    Only a restart fixes the problem...

    Syslog is pretty empty

    Jan 1 02:00:12 syslogd started: BusyBox v1.17.4
    Jan 1 02:00:12 kernel: klogd started: BusyBox v1.17.4 (2014-02-21 16:26:06 CST)
    Jan 1 02:00:12 kernel: start_kernel
    Jan 1 02:00:12 kernel: Linux version (root@asus) (gcc version 4.2.4) #1 Fri Feb 21 16:29:10 CST 2014
    Jan 1 02:00:12 kernel: CPU revision is: 00019749
    Jan 1 02:00:12 kernel: Found an ST compatible serial flash with 128 64KB blocks; total size 8MB
    Jan 1 02:00:12 kernel: wombo_reset set to gpio 22
    Jan 1 02:00:12 kernel: Determined physical RAM map:
    Jan 1 02:00:12 kernel: memory: 02000000 @ 00000000 (usable)
    Jan 1 02:00:12 kernel: Built 1 zonelists. Total pages: 8128
    Jan 1 02:00:12 kernel: Kernel command line: root=/dev/mtdblock2 noinitrd console=ttyS0,115200
    Jan 1 02:00:12 kernel: Primary instruction cache 32kB, physically tagged, 4-way, linesize 32 bytes.
    Jan 1 02:00:12 kernel: Primary data cache 32kB, 4-way, linesize 32 bytes.
    Jan 1 02:00:12 kernel: PID hash table entries: 128 (order: 7, 512 bytes)
    Jan 1 02:00:12 kernel: CPU: BCM5357 rev 2 pkg 8 at 500 MHz
    Jan 1 02:00:12 kernel: Using 250.000 MHz high precision timer.
    Jan 1 02:00:12 kernel: Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
    Jan 1 02:00:12 kernel: Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
    Jan 1 02:00:12 kernel: Mount-cache hash table entries: 512
    Jan 1 02:00:12 kernel: PCI: no core
    Jan 1 02:00:12 kernel: PCI: no core
    Jan 1 02:00:12 kernel: PCI: Fixing up bus 0
    Jan 1 02:00:12 kernel: IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
    Jan 1 02:00:12 kernel: TCP established hash table entries: 1024 (order: 1, 8192 bytes)
    Jan 1 02:00:12 kernel: TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
    Jan 1 02:00:12 kernel: pflash: found no supported devices
    Jan 1 02:00:12 kernel: Creating 5 MTD partitions on "sflash":
    Jan 1 02:00:12 kernel: 0x00000000-0x00020000 : "pmon"
    Jan 1 02:00:12 kernel: 0x00020000-0x007f0000 : "linux"
    Jan 1 02:00:12 kernel: 0x00149844-0x00710000 : "rootfs"
    Jan 1 02:00:12 kernel: 0x007f0000-0x00800000 : "nvram"
    Jan 1 02:00:12 kernel: 0x00770000-0x007f0000 : "jffs2"
    Jan 1 02:00:12 kernel: dev_nvram_init: _nvram_init
    Jan 1 02:00:12 kernel: _nvram_init: allocat header: 2151612416, size= 32768
    Jan 1 02:00:12 kernel: u32 classifier
    Jan 1 02:00:12 kernel: OLD policer on
    Jan 1 02:00:12 kernel: Netfilter messages via NETLINK v0.30.
    Jan 1 02:00:12 kernel: nf_conntrack version 0.5.0 (512 buckets, 4096 max)
    Jan 1 02:00:12 kernel: ipt_time loading
    Jan 1 02:00:12 kernel: ip_tables: (C) 2000-2006 Netfilter Core Team
    Jan 1 02:00:12 kernel: net/ipv4/netfilter/tomato_ct.c [Feb 21 2014 16:28:32]
    Jan 1 02:00:12 kernel: ip6_tables: (C) 2000-2006 Netfilter Core Team
    Jan 1 02:00:12 kernel: VFS: Mounted root (squashfs filesystem) readonly.
    Jan 1 02:00:12 kernel: Warning: unable to open an initial console.
    Jan 1 02:00:12 kernel: ctf: module license 'Proprietary' taints kernel.
    Jan 1 02:00:12 kernel: et_module_init: passivemode set to 0x1
    Jan 1 02:00:12 kernel: eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller
    Jan 1 02:00:12 kernel: wl_module_init: passivemode set to 0x1
    Jan 1 02:00:12 kernel: eth1: Broadcom BCM4329 802.11 Wireless Controller
    Jan 1 02:00:13 kernel: Symbol usb_deregister is being used by a non-GPL module, which will not be allowed in the future
    Jan 1 02:00:13 kernel: Please see the file Documentation/feature-removal-schedule.txt in the kernel source tree for more details.
    Jan 1 02:00:13 kernel: bcm_rpc_up: waiting to be connected
    Jan 1 02:00:13 kernel: bcm_rpc_buf_recv_mgn_high: Reason: 0 Dongle Version: 0x5648a89
    Jan 1 02:00:13 kernel: bcm_rpc_buf_recv_mgn_high: Connected!
    Jan 1 02:00:13 kernel: eth2: Broadcom BCMa8e4 802.11 Wireless Controller
    Jan 1 02:00:13 kernel: Algorithmics/MIPS FPU Emulator v1.5
    Sep 9 08:59:14 RT-N53: start httpd
    Sep 9 08:59:20 kernel: eth1: received packet with own address as source address
    Sep 9 08:59:43 kernel: eth1: received packet with own address as source address
  34. _NemO_

    _NemO_ Networkin' Nut Member

    Is there any way to add password login (only one pass) into Captive Portal?
  35. Stormdrain

    Stormdrain Network Newbie Member

    :( No v122 for Tenda
    :cool: No problem liquor kicking in
    :) Probably forget what I was looking for in a few minutes
  36. wit100

    wit100 Networkin' Nut Member

    Do you have your CTF turned on or off?
  37. MrDoh

    MrDoh Addicted to LI Member

    I'm able to stabilize the ping times without turning on CTF on the last couple of versions, while I seemed to need CTF on the first couple. Since my download speed is 28.8Mbps, it really shouldn't affect me *smile*. The direct answer is that I have CTF turned off.
  38. leandroong

    leandroong LI Guru Member

    @shibby20, I would like to see header version change from "Version 1.28 by shibby" to be

    "Shibby Tomato Firmware 1.28.0000 MIPSR1-121 K26 USB AIO"
  39. Bloudemane

    Bloudemane Network Newbie Member

    I have a silly question. If I upgrade from 117 to 121, will all my QoS settings (and router settings in general) be erased ?
  40. NoobWRT

    NoobWRT Serious Server Member

    you should reset it either way.
  41. Siff

    Siff Serious Server Member

    No, but since the settings are not migrated to the new version, there is always a risk that they will not work properly with the new firmware, so it is always recommended to erase the NVRAM before and after you flash the router. You can check here and here for some of the ways to save and recreate the settings after changing the firmware.
  42. thecodemonk

    thecodemonk Connected Client Member

    I think you can resolve the ping issue in only one reboot. Another user and I were able to fix ours by powering down, unplugging the power cable, turning the power switch on, which will effectively drain all the capacitors in the router, and then plugging power back in. I had the same issue and reboots were not fixing it at all (I tried more than a dozen times). As soon as I did this, it went down to <1ms ping times.
  43. thecodemonk

    thecodemonk Connected Client Member

    I have an R7000 on Comcast, so this may not apply to you in any way, but I AM on Shibby 122. However, I have IPv6 working on my router, phones, and PCs on the network just fine. However, I had to add a few scripts to make it happen.

    Wan Up Script:
    # Workaround for TomatoUSB bug where a spurious default IPv6 route is
    # added for no justified reason, resulting in packets getting forwarded
    # effectively to /dev/null.
    # 1. Temporarily disable accepting IPv6 RAs on the WAN interface. This
    # will stop the kernel from automatically adding a default IPv6 route
    # when such an RA is received via the WAN.
    # 2. Delete ALL default IPv6 routes. In effect this deletes the spurious
    # IPv6 default route, as well as any default IPv6 routes received via RA.
    # Sadly the "ip" command does not give you a way to differentiate between
    # the two, since the one we truly want to delete lacks "proto kernel".
    # 3. Restore honouring IPv6 RAs via the WAN. Within 60-120 seconds (often
    # within seconds on Comcast) a default IPv6 route should be added by the
    # kernel. You can use "ip -6 route show default dev `nvram get wan_iface`"
    # to verify; you should have only one route ("default via fe80::xxx ...").
    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/accept_ra
    ip -6 route flush default dev `nvram get wan_iface`
    echo 2 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/accept_ra
    Firewall Script:
    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding
    I have no idea if this will apply to you or help in any way. Hope it does...
    beatnik likes this.
  44. MrDoh

    MrDoh Addicted to LI Member

    I tried this after first reading about it here. Did not work for me. Thanks for trying, though! Any workaround for this problem would be much appreciated.
  45. MrDoh

    MrDoh Addicted to LI Member

    Also have Comcast and R7000 here, and IPv6 works great for me using only the firewall part of the scripts above. Just thought that I should mention that.
    Last edited: Sep 11, 2014
  46. Quad5Ny

    Quad5Ny Networkin' Nut Member

    Since I don't feel like waiting 5 minutes for the router to establish a default (IPv6) route all the time I'm using this in the Firewall script:

    echo 0 > /proc/sys/net/ipv6/conf/'nvram get wan_iface'/forwarding
    *Wait 5 minutes*
    Check the 'default' IPv6 route:
    ip -f inet6 route
    Finally I take the IP, replace "Paste-IP-Here" and then paste it-
    -into Scripts>Firewall as the very top line:
    ip -f inet6 route replace default via Paste-IP-Here dev `nvram get wan_iface` hoplimit 64 proto kernel
    Side note- Don't use access restrictions on the R7000 running v121 or v122, it will completely break the ip6tables (Well at least HTTP Request matching does).
    Last edited: Sep 11, 2014
  47. Quad5Ny

    Quad5Ny Networkin' Nut Member

    How to turn off every LED on the R7000:
    Note: The power LED will still glow amber ever so slightly. I'm assuming its a hardware bug or the resistor is too small because they never intended for the LED to be completely off.

    Paste this into the init script:
    for i in 3 8 9 12 13 17 18;do gpio enable $i;done
    for i in 14 15;do gpio disable $i;done
    et robowr 0x0 0x18 0x1ff
    et robowr 0x0 0x18 0x0
    et robowr 0x0 0x1a 0x0
    Paste this into the bottom of the Firewall script:
    sleep 5
    gpio enable 2
    Fredrik, szpunk and volgera like this.
  48. Quad5Ny

    Quad5Ny Networkin' Nut Member

    Shibby: In my testing on the R7000, "Virgin Islands, U.S." has the highest TX power for 2.4GHz. In the past Tomato was set to SG as that had the best TX power but it seems like that is no longer the case for the R7000.

    Also on your R7000 setup video you suggest resetting the MAC Address for eth3 to default. On my router I end up with a bogus MAC address that doesn't seem to be tied to any company (E6:F4:C6:##:##:## - It might be best to leave eth3 alone.

    I'll be posting a chart later on of the TX power for all the Country's.
    Last edited: Sep 11, 2014
  49. MrDoh

    MrDoh Addicted to LI Member

    I just looked at the video again, and as I recalled, there's a big "SKIP THIS STEP, if you change eth3 MAC address WPA/WPA2 doesn't work" note on the screen during the MAC adjustments part. So you can just skip that step, and don't touch the MAC addresses *smile*.

    By the way, looking forward to the tx power versus locale chart that you mentioned. That would be great!
  50. defcon

    defcon Networkin' Nut Member

    I just tried TOR and created a public hotspot by creating a virtual interface, I stumbled across these firewall rules that you might want to add to the Tor features for security:

    iptables -t nat -A PREROUTING -i br1 -p tcp ! -d -j DNAT --to-destination
    iptables -t nat -A PREROUTING -i br1 -p udp --dport 53 -j DNAT --to-destination
    iptables -t nat -A PREROUTING -i br1 -p tcp --dport 80 -d -j DROP
    iptables -t nat -A PREROUTING -i br1 -p tcp --dport 443 -d -j DROP
    iptables -t nat -A PREROUTING -i br1 -p tcp --dport 22 -d -j DROP
    iptables -t nat -A PREROUTING -i br1 -p tcp --dport 23 -d -j DROP
    What this does is denies access to the router and forces all connections over TOR on the br1 interface. Tor is really nice to be able to share your wireless connection and not worry about what people view/do since its all anonymized. What I did was spoofed the mac address as well. Maybe in the TOR interface you could create a premade profile to enable a "anon wifi" virtual ssid with spoofed mac with this firewall ruleset. As Tor is setup now, people could log on to your wifi, not all connections are forced over Tor, and someone can reveal who you are.

    This might seem like too much work but if you can do it, I'll contact EFF/Tor Project and have them write about your firmware. Since they just launched the OpenWireless Initiative this would bypass any ISP restrictions on free wireless and protect router owners. I shared my wifi now without worry and also limited the bandwidth to 300/300kbps, maybe you could add that as well. I hope im not asking for too much, but making all that happen with 1-2 clicks would be badass.
  51. defcon

    defcon Networkin' Nut Member

    @shibby20 if you can, can you add temps to each interface? This cmd line works well for every device:
    echo eth1=$((`wl -i eth1 phy_tempsense|awk {' print $1 '}`/2+20))C
    These temps are important for modifying tx power, Also cpu temp would be handy too.
  52. Quad5Ny

    Quad5Ny Networkin' Nut Member

  53. koitsu

    koitsu Network Guru Member

    Not all routers have thermistors to provide any of this information. I'm not sure why you blindly assumed that CPU temperature is available. What made you think that?
    defcon likes this.
  54. defcon

    defcon Networkin' Nut Member

    the ones that do have these temps available, why not take advantage of it?
  55. npumcrisz

    npumcrisz Network Newbie Member

    Tomato Firmware 1.28.0000 -122 K26ARM USB AIO-64K
    • This firmware doesn't have support for 802.11ac only 802.11 a,b,g and n right or I'm missing something?
    • Could I use ipv6 as my vpn subnet/netmask or local/remote endpoint address?
  56. MrDoh

    MrDoh Addicted to LI Member

    Wireless-ac works here on R7000 on v122. Using it as we speak *smile*. You should see a channel width choice of 80MHz. on 5GHz. band, that's wireless-ac. You can leave "Wireless Network Mode" on "Auto".
    Last edited: Sep 13, 2014
    npumcrisz likes this.
  57. npumcrisz

    npumcrisz Network Newbie Member

    Thanks would change to auto or the 80MHz. I'm using rt-ac68u and its strange l didn't see it but would double check.

    Sent from my C6916 using Tapatalk
  58. _NemO_

    _NemO_ Networkin' Nut Member

    There is a problem with nginx + php (from WebUI): php-cgi is runing from nobody user and shell_exec doesn't work. There is "Segmentation fault" error.
    When I run php-cgi manually as root all works fine.

    RT-N66U, 1.28.0000 MIPSR2-121 K26AC USB AIO-64K

    And I can't run nginx manually adding nginx into WAN up script.
    I tried:
    /opt/etc/init.d/S80nginx start

    Nothing! There is no problem with lighttpd.
    What do I do wrong?
    Last edited: Sep 13, 2014
  59. Quad5Ny

    Quad5Ny Networkin' Nut Member

    Is your 5GHz Country/Region still on Singapore? I've noticed that with Tomato 80MHz support is very dependant on the region selected.

    If there are enough available channels available for 80MHz for the selected region, you should see one or more channel numbers in the 'Channel' drop down box (NOT just Auto) when it's set to 80MHz. -- Don't quote me on this though. =p
    npumcrisz likes this.
  60. Quad5Ny

    Quad5Ny Networkin' Nut Member

    Finished the TX Power vs Region Graph for 2.4GHz:

    Last edited: Sep 28, 2018
  61. npumcrisz

    npumcrisz Network Newbie Member

    No my country/region is united state and if auto isn't selected l have only 2 channel options
  62. Grumpy Woofy

    Grumpy Woofy Network Newbie Member

    I don't use VLAN Offset so I don't know, but VLAN VID mapping is not working on K26RT-AC build 121. The same also for Viktek K26RT-AC build. 121 fixed the VLAN VID mapping for K26RT-N. The bcmrobo.c in src-rt-6.x don't have the modifications for the VLAN VID mapping.
  63. AndreDVJ

    AndreDVJ LI Guru Member

    I have a suggestion. Is it possible to add external log file location for Transmission on the Tomato GUI?
    root@WNR3500L:/tmp/mnt/storage/logs# transmission-daemon --help | grep logfile
     -e  --logfile  <filename>  Dump the log messages to this filename
    I edited /tmp/ and it worked fine, Transmission logs are logged in another file... However opon reboot changes will be lost, so it would be nice to have that added on the Tomato GUI.
    [EMAIL]root@WNR3500L:/tmp/home/root[/EMAIL]# cat /tmp/
    sleep 10
    if [ ! -d "/mnt/storage/Downloads/.incomplete" ]; then
    mkdir /mnt/storage/Downloads/.incomplete
    if [ ! -d "/mnt/storage/Downloads/.settings" ]; then
    mkdir /mnt/storage/Downloads/.settings
    mv /tmp/settings.json /mnt/storage/Downloads/.settings
    rm /mnt/storage/Downloads/.settings/blocklists/*
    /usr/bin/transmission-daemon -g /mnt/storage/Downloads/.settings -e /mnt/storage/logs/transmission.log
    logger "Transmission daemon successfully started"
    sleep 2
    /usr/bin/btcheck addcru[code]
  64. defcon

    defcon Networkin' Nut Member

    if I change region to japan or another country living in the states will I get better signal? Also would it be compatible with most devices? And would the fcc be knocking on my door?
  65. spektor56

    spektor56 Network Newbie Member

    Yea, my WAN port is showing up as Lan port #1 in the port states with the latest AC build. It's showing properly with the N build on my N66U.
  66. Mysteron

    Mysteron Networkin' Nut Member

    Need some help with ipv6 and Shibby 121 (122 is not available for me, yet) I've had ipv6 working in the past, but I cannot get it working now. I also noticed the DDNS entry for HE seems not to be working correctly, in that it keeps failing and reporting authorisation errors, when there are none.

    I read the posts above regarding waiting for five minutes and setting

    echo 0 > /proc/sys/net/ipv6/conf/`nvram get wan_iface`/forwarding
    But nothing seems to help...
  67. dc361

    dc361 Network Guru Member

    Do you have a new tunnel at HE? If so, you need to use the "Update Key" found on the advanced tab of the tunnelbroker site instead of your login password when you configure Tomato.

    Good luck!
    pzlmg likes this.
  68. alawadhi3000

    alawadhi3000 Addicted to LI Member

    Hello guys,

    I have a weird issue with the RT-AC68U, I have the latest version installed, I'm running it as a router with a bridged DSL modem, the AC68U connects fine to the internet (using PPPoE) and I can even ping websites within the Tomato GUI, however I any device connected whether through a LAN cable or wireless doesn't get internet connection, can anyone help me with this? Thanks a lot.
  69. npumcrisz

    npumcrisz Network Newbie Member

    Change the settings to gateway it should work because mine works. Why did you set it as router in the first place?

    Sent from my C6916 using Tapatalk
  70. alawadhi3000

    alawadhi3000 Addicted to LI Member

    You mean the option to set it as a gateway or router? I didn't change it, it was on gateway, anyway I cleared the NVRAM and the issue is solved now, I'll configure the device again to see if some of my configuration is actually causing the issue.
  71. Quad5Ny

    Quad5Ny Networkin' Nut Member

    The only compatibility issues you would run into is if you use a channel that's not supported by your devices (you'll know because the devices will refuse to connect), or if under Advanced>Wireless>2.4GHz you have 'Regulatory Mode' set to anything other than 'Disabled'.

    Remember to either set 'Transmit Power' (Advanced>Wireless>2.4GHz) to '0' (0 is Max TX Pwr for the selected Region) or something higher than 42 or you won't see any benefit.

    Try not to use Japan, it and Korea had some really weird issues; Japan's Tx power would jump up/down and Korea didn't transmit at all.

    Note: On the graph the higher up the stronger the Transmit Power, so Anguilla would be the strongest and Afghanistan would be the weakest.

    No one is going to be knocking on your door... but if you increase TX power and live very close your neighbors be nice and set:
    [Under Basic>Network]
    Wireless Network Mode: Auto
    Channel Width: 20Mhz
    Channel: 1, 6 or 11 for Regions that have 11 Channels || 1, 5, 9 or 13 in Regions that have 13 Channels
    [Under Advanced>Wireless>2.4GHz]
    Afterburner: Off
    CTS Protection Mode: Auto
    Frameburst: Disabled
    802.11n Preamble: Mixed Mode
    Last edited: Sep 17, 2014
  72. callous

    callous Network Guru Member

    What's the difference between selecting the country with s trongest signal and just changing it under Advanced>wireless transmit strength?
  73. krism75

    krism75 Serious Server Member

    I saw in the changelog ( that v122 of shibby is avaible, but looking at the download page for RT-N66 there is no 122 . Where can I find it?
  74. Quad5Ny

    Quad5Ny Networkin' Nut Member

    The selected Country/Region limits the transmit strength to max specified by the Locales local Laws/Regulations.

    For example (and I'm making these numbers up) if the wireless amp is spec'd to 500mW but your country is set to Canada which has a hardcoded limit of a maximum of 240mW… well your only going to get 240mW even if you set the value manually to 500mW.

    Your changing the Region to bypass hardcoded limits in the Broadcom driver. After which you can set the Transmit Power to '0' (which would be the MAX for that Region) or set it manually to a value that is equal to or lower than the limit for that Region.
  75. callous

    callous Network Guru Member

    ok I get it thanks
  76. npumcrisz

    npumcrisz Network Newbie Member

    by any chance can you post a link as to how to configure with shibby's firmware. I'm seriously trying to figure it out. I've search this forum in vain for a simple straight forward manner. I even posted [ ] but no reply as of date.
  77. PBandJ

    PBandJ Addicted to LI Member

    Adding just a smidgen of info, besides limiting bandwidth it also (not sure if perfectly) limits certain channels.
    For example, if you set country to Japan you can crank it (=channel) up to 14!

    Full details here:
  78. _NemO_

    _NemO_ Networkin' Nut Member

    You can simply get supported channels in country:
     wl -a eth1 channels_in_country SG b
    wl -a eth2 channels_in_country SG a
    and power:
     wl -a eth2 curpower
    for selected country by:
    wl -a eth2 country SG
  79. ierwin

    ierwin Networkin' Nut Member

    Asus RT-N12 B1
    shibby 121 k26 rt-n max
    when disable wireless, wireless led still lights up
  80. callous

    callous Network Guru Member

    odd, still don't see 122 for e3200
  81. The Doctor

    The Doctor LI Guru Member

    Shibby, is bandwidth monitor and IP traffic likely to be working on the RT-AC68 anytime soon? I am wanting to put my RT-AC68 into service, and due to my ISP getting upset if I exceed 10 TB in a month, I really need the bandwidth monitor.
  82. Gustav Gans

    Gustav Gans Network Newbie Member

    Is the default value for DNSMASQ DNS cache size 150 in Shibby's Tomato? I'm just wondering because I noticed that new queries occur multiple times a day for the same websites. I set cache-size to 10,000 now (in the box in Advanced Settings - DNS), but I'm wondering what the default value in this Tomato mod is. I apologize for my lack of knowledge which prevents me from going into the router and look up the information myself, which now is probably too late after all since I changed the cache size.
  83. koitsu

    koitsu Network Guru Member

    The default value is 150, as per stock dnsmasq; see CACHESIZ:

    Be aware that a value of 10000 is quite large -- it'll be your responsibility to make sure the dnsmasq process doesn't grow to an extremely large size + potentially exhaust RAM on your router.

    This is outside the subject/topic matter because it's dnsmasq-specific and is better-suited for their mailing list, but reviewing cache.c function cache_init() and other code (hard to explain) indicates that the amount of RAM used per cache entry is cachesize*{size of crec struct}, and that structure looks like it could be fairly big given all the structs it includes. If I had to take a wild guess (on the high end), I'd estimate about 512 bytes per cache entry, possibly more if you recursively consider all the pointers to other structs which need to be allocated as well (this is what makes it hard to calculate a literal value just by looking at the code). So with 10K entries, that'd turn out to be about 5MBytes. That might sound small but you have to consider all the rest of the system RAM use by the kernel and all the other subsystems, drivers, and userland daemons. I'm not saying don't do it, I'm just saying keep an eye on it.
  84. jerrm

    jerrm Network Guru Member

    Shibby starts dnsmasq with a "-c 1500" parameter, increasing the cache to 1500, I think other mods do the same, but am not sure.

    1500 should be more than adequate for a small network. Realize dnsmasq is only going to cache as long as the record's ttl specifies. If the client is requesting the record, then chances are the ttl has expired.
    Last edited: Sep 21, 2014
    koitsu likes this.
  85. koitsu

    koitsu Network Guru Member

    Thanks @jerrm -- I didn't even consider the possibility of a command-line flag. Don't know why that didn't occur to me, but it didn't. And you're right -- -c 1500 is what the firmware (including Toastman) uses by default (thus overriding the compile-time default of 150).

    I'd have to look at the dnsmasq code to see which gets read/honoured last -- the -c command-line flag or the config file cache-size directive.
  86. jerrm

    jerrm Network Guru Member

    I tested, and current versions (tested 2.71) will honor the config file.
  87. Gustav Gans

    Gustav Gans Network Newbie Member

    Thank both of you for clarifying, that really helped.
    However, you mentioned Shibby starts pixelserv. Does that mean pixelserv is already installed?
  88. jerrm

    jerrm Network Guru Member

    Sorry, no - I meant dnsmasq. This was a drive-by reply between adblock responses, and the fingers got confused.
  89. wit100

    wit100 Networkin' Nut Member

    I am still a bit confused - so does ping issue still exists with v122 on R7000? Mine seems okay in a simple setup but if I put it in production, it is completely different volume of traffic and many more restriction rules.

    If anyone could please shed some light on it, it would be appreciated.
  90. Malakai

    Malakai Networkin' Nut Member

    I tried to block the hosts of the guest network from seeing each other with this command :

    iptables -I FORWARD -i br1 -o br1 -j DROP

    and deleting the command that let's them communicate (iptables -I FORWARD -i br1 -o br1 -j ACCEPT), but it doesn't work...

    I would like to know if something is missing in the command or how can I prevent them from communicating.

  91. rs232

    rs232 Network Guru Member

    Yes it is still thee. We still don't have a clear clue of what causes it. Mine doesn't seem to be load related as it appears towards the end of the boot procedure.
    When I experience it the best thing is to is to cold boot. Usually at the 2nd->5th time I get stable pings for few days... until it goes crazy again.

    Hopefully it will be resolved soon

  92. jerrm

    jerrm Network Guru Member

    In general iptables and Linux will never see traffic between two hosts on the same lan. Only exception is if they cross a software bridge, which generally would be wireless<->wired traffic, then you can use ebtables.

    ap isolation can be used for traffic between wireless clients, but doesn't work out of the box with tomato. See

    Not much you can do for traffic between two wired clients, unless you set each port on it's own vlan, use script to bridge them together, and then use ebtables. Even then, traffic will have to cross ports to be seen by ebtables.
    Malakai likes this.
  93. npumcrisz

    npumcrisz Network Newbie Member

    Issues I'm getting on Tomato Firmware 1.28.0000 -122 K26ARM USB AIO-64K using RT-AC68U
    • IP aliasing/virtual LAN especially wrt IPv6
    • Login with ssh
      • under ssh daemon all is enabled but the authorization key(s) is blank. Is that how it should be?
      • for some unknown reason my login username & password don't work when using Bitvise SSH Client.
    • Install arm-extras from the GUI.
      • Guess I need a how to manual which I haven't been able to locate.
    • Enable and format JFFS
  94. Malakai

    Malakai Networkin' Nut Member


    thanks for the info.
  95. wit100

    wit100 Networkin' Nut Member

    Thanks - I appreciate the insight!
  96. Mate Rigo

    Mate Rigo Networkin' Nut Member

    Hi there!

    I am facing the same, or at least a very similar problem.
    I have a Asus RT-N53 A1 router myself. I tried various tomato builds in the past ~year.

    To sum up my experience:
    Every now and then something causes the router to restart. After coming back online, the 5GHz adapter is missing. Eg. ifconfig does not show eth2, which would be the 5GHz interface. I have to do a manual restart, that eth2 comes up correctly.
    Win7 seems to be a little slow noticing that the 5GHz access point has gone missing, and will try to connect to it.

    I even wrote a script for doing the restart after the crash for me:
    FOUND=`grep "eth2" /proc/net/dev`
    sleep 10
    if  [ -n "$FOUND" ] ; then
    echo 5Ghz interface found!
    Which is inserted at the Administration/Scripts/Init

    The crashes did mostly occur, when there was some fairly heavy traffic on it.

    For the last 8 days, I switched off the 5GHz interface, and even disabled the USB driver. (At this router the 5GHz is actually a USB connected Wifi stick, or sort of.
    Note: I am using shibby 121 RT-N53 right now.

    And since then it runs rock solid.
    So my guess would be that there is some problem with the USB interface of the router.

    This blows the whole purpose of having bought this router in the first place, as living in a metro area, where the 2.4GHz band is fully bloated.
    Fredrik likes this.
  97. Energon

    Energon Network Newbie Member

    Mate Rigo, thank you for confirming the problem.

    Now I'm on stock FW and I cannot access the admin anymore, but 2.4 Ghz is working so I'll find the time to put Shibby build and use the script.
  98. Mate Rigo

    Mate Rigo Networkin' Nut Member

    To be perfectly honest the attached script is actually saved to the jffs section, and at the Administration/Scripts/Init section the '/jffs/' shell script is added.
  99. Energon

    Energon Network Newbie Member

    Mate Rigo, do you use an Apple device to connect to N53? (macbook, iMac etc?)
  100. Mate Rigo

    Mate Rigo Networkin' Nut Member

    Yes, in fact I have an ipad 2. Both 2.4 GHz and 5GHz radios connect without problems. So in terms of ipad compatibility the N53 is good.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice