Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. Tox0601

    Tox0601 Reformed Router Member

    Any idea why after updating to v134 (with "erase nvram after flashing") logs shows the following?

    Mar 20 11:33:06 router1 daemon.warn httpd[19067]: Invalid ID 'TIDef138826c0189d76' from for /js/status-data.jsx
    Mar 20 11:34:09 router1 daemon.warn httpd[19165]: Invalid ID 'TIDef138826c0189d76' from for /js/status-data.jsx
    Mar 20 11:35:13 router1 daemon.warn httpd[19231]: Invalid ID 'TIDef138826c0189d76' from for /js/status-data.jsx
    Mar 20 11:36:16 router1 daemon.warn httpd[19299]: Invalid ID 'TIDef138826c0189d76' from for /js/status-data.jsx
    ps: R7000, is reserved ip-address.
  2. MrDoh

    MrDoh Addicted to LI Member

    Tox0601, do you have set up as a static IP or reserved dhcp address for a particular device, and another device is using that IP address? Like maybe it got assigned to another device by dhcp, or another device has this address set in it? It kind of looks like that...
  3. Tox0601

    Tox0601 Reformed Router Member is a reserved dhcp address for my laptop. I've just checked, if I set up another address (e.g. 1.14) as a static IP for this computer, I can't ping 1.13...
    sorry for my bad English...
  4. callous

    callous Network Guru Member

    Build 1.35 multi-wan is out for all builds!

    I think my Linksys e3200 is missing though :(
  5. PetervdM

    PetervdM Network Guru Member

    just flashed tomato-RT-AC66U_RT-AC6x--135-AIO-64K and although not in the release notes, dnscrypt configuratiuon seems to be fixed. thx shibby!
  6. sac7000

    sac7000 Networkin' Nut Member

    Thank shibby, behind v.135. for tena w1800r,
    There are two versions of VPN and Mega-vpn,
    You could not tell what is the difference ?
  7. Thomas Begley

    Thomas Begley Serious Server Member

    Hi guys,

    Just updates from 1.34 to 1.35 and when going to Adminer it says the version is 4.2.1

    I am sure in 1.34 it was version 4.2.3

    Am i going mad?
  8. Gamby

    Gamby Networkin' Nut Member

    The problem with dhcp on vlan100 with v135 persist.
  9. phuklok1

    phuklok1 Network Guru Member

    Noticed in both 133 and 135 that if you setup the router for single WAN operation in "wireless client" mode, the option to bridge the unused WAN port to the primary LAN is no longer available under the basic network settings.
    This is minor, but it was quite useful to have that port be available on the LAN side.
  10. japoness

    japoness New Member Member

    Hello @shibby20, I upgraded my Linksys E900 from v133 to v135 and everything is working fine, except for the QOS bcause eeverytime I turn it on, my internet stop working. On the log file, I found this error:

    Mar 21 17:53:40 unknown user.crit init[1]: Error while loading rules. See /etc/iptables.error file.

    Do you know what's causing the problem? I rebooted my router, cleaned the NVRAM and made the 30/30/30 but the error persists.

  11. sac7000

    sac7000 Networkin' Nut Member

    Not connected with PPPoE router TENDA W1800R
    Do not get ip- address from the ISP , I use the one WAN port and iptv and internet ( tagged traffic from VLAN).
    This is usually happens if the broken support 802.1Q , VLAN does not work properly in the version of the 135 at Tenda w1800r.
    turning to the 132 version.
    Last edited: Mar 21, 2016
  12. ChefJoe

    ChefJoe Connected Client Member


    Difference would then be the inclusion of Nocat, BtClients, SNMP, UPS, TR_extras, Tor, IPsec, RAID, Dnssec, TINC, and Nano.
  13. JoeyJoeJoe

    JoeyJoeJoe Guest

    Is DHCP usually unchecked for PPPoE by default? For whatever reason it wouldn't grab DNS when enabled.
  14. sac7000

    sac7000 Networkin' Nut Member

    Thank you for the information , but unfortunately going back to v.132. No PPPoe connection , I suspect that disrupted with the vlan , and therefore do not get the ip- address from the ISP .
  15. trippleA

    trippleA New Member Member


    I'd like to make a Ip hash table, tried this command in telnet and ssh
    "ipset create listwan hash:ip" but both consoles seems to hang after that.
    Iam using Tomato v1.28.0000 -134 K26ARM USB AIO-64K on a r7000, what can be the problem?
  16. glehel

    glehel Reformed Router Member

    same here! My AC66U QOS iptables error QOS ON and not net! My WAN connection ok!
    QOS OFF net connected ok. My WAN connection ok!
  17. rs232

    rs232 Network Guru Member

    Is the:

    nvram export --set 
    not working any more? Tried it on v132 and gave me no output
  18. Weltherrscher

    Weltherrscher Reformed Router Member

    Anyone with a RT-AC68U experienced poor WiFi-Strength with v133 and up?

    As of v133, my 5.2 GHz Connection is very poor, through one wall only 3..4 MB/s.
    With v132 i had 15..20 MB/s.

    Ok, works somehow now.
    Set region to Singapore, all advanced options to default ans set the channels hard to 36 lower & 6 lower.
    No i got my 25 MB/s back. =)
    Last edited: Mar 22, 2016
  19. NoisyNinja

    NoisyNinja Reformed Router Member

    Reporting that an upgrade on the R6300v1 and RT-N16 works. Running into the same problem with QOS (the internet dies when QOS enabled) in v135 as others are describing earlier in the thread. Thanks for the hard work Shibby!
  20. eangulus

    eangulus Network Guru Member

    132 cannot access remotely on any port. Can't access my port forwards or my remote admin port.
  21. tommyv

    tommyv Addicted to LI Member

    Are you behind vpn ? I have the same situation, forwarded port via iptables, used to work in 128
  22. eangulus

    eangulus Network Guru Member

    Yeah, worked it out. My VPN config was wonky and I had all traffic over VPN.
  23. Pess0g

    Pess0g Networkin' Nut Member

    DDNS doesn't work in v135 after wan gets up and I have to update by myself and iptables gives error in MIPS version but could work in ARM.
    iptables -t nat -A PREROUTING -i br1 -s $source -d $dst -p udp --dport 53 -j REDIRECT --to-ports 54
    I ran in MIPS v135,it says "No chain/target/match by that name"

    Is there anyone else who encounters the same issue?
  24. koitsu

    koitsu Network Guru Member

    This is (another) example of netfilter/iptables giving an error message that's confusing, because it makes the person think "how is there no PREROUTING chain in table nat?".

    The problem is that there the target to jump to (-j argument) doesn't exist in netfilter/iptables. In other words: there is no REDIRECT target available. The kernel/netfilter needs to be built with REDIRECT support enabled for this to work. I believe this is controlled with CONFIG_IP_NF_TARGET_REDIRECT.

    Looking at the default options (this would be in release/src/linux/linux/config_base), it appears REDIRECT support is enabled as a module (CONFIG_IP_NF_TARGET_REDIRECT=m), which means it's dynamic.

    Try doing modprobe ipt_REDIRECT from the command-line, then afterward try your iptables command. I'd bet money you'll find it works. Proof:

    root@gw:/tmp/home/root# iptables -t nat -A PREROUTING -i br1 -s -d -p udp --dport 2222 -j REDIRECT --to-ports 9999
    iptables: No chain/target/match by that name
    root@gw:/tmp/home/root# modprobe ipt_REDIRECT
    root@gw:/tmp/home/root# iptables -t nat -A PREROUTING -i br1 -s -d -p udp --dport 2222 -j REDIRECT --to-ports 9999
    root@gw:/tmp/home/root# iptables -t nat -L PREROUTING -n --line-numbers | grep REDIRECT
    4    REDIRECT   udp  --                 udp dpt:2222 redir ports 9999
    root@gw:/tmp/home/root# iptables -t nat -D PREROUTING -i br1 -s -d -p udp --dport 2222 -j REDIRECT --to-ports 9999
    So: if you want this to work, just add modprobe ipt_REDIRECT to Scripts/Init and you should be fine going forward. (If ipt_redirect is already loaded, this command will essentially do nothing, so no harm).

    Pro-tip: Toastman MIPSR2 firmwares have REDIRECT enabled as a module, so this is not necessarily a "Shibby problem". If it's something specific to Shibby v135, then so be it, but I can't tell what's specific to v135 right now because there's no v135 tag, only some commits made to the repo 8 days ago.

    release/src/linux/linux/config_base for different branches (hint: as of this writing, all 3 branches use CONFIG_IP_NF_TARGET_REDIRECT=m. You can click on "blame" and see that this line hasn't changed in any of them for a very long time, so you should have been, ideally, experiencing this in other releases as well):

    Last edited: Mar 23, 2016
  25. BlackPhantom

    BlackPhantom New Member Member

    Upgrade 1.33 to 1.35 on Asus RT-N53. In WAN set static IP, and mask, but in Overview always But internet is work.
  26. Bobby J

    Bobby J Reformed Router Member

    Hi ChefJoe, Wow! How did you do this? I'm trying to figure out the minimal release (v135) / version (K26RT-N) that includes "dnscrypt". I downloaded the v135 Mini version, but it doesn't appear to have dnscrypt. At least it's not showing on the Basic page. Since the release matrix hasn't been updated since v99, I'd like to find another way to find out what components exist in each release/version.

    You seem to have found a way to do it by comparing the makefile. I don't even know what that is or where to find it. I'm a newbie, semi techie, but if you can point me in the right direction to how to find and compare the makefiles by version, I can try to figure it out myself.

    Thanks in advance.
  27. Mastec

    Mastec Network Guru Member

    I am curious if there is, or will be, a fix for the R6250 and its weak or dead 2.4GHz signal. I have 2 R6250 routers both were loaded with tomato-R6250-ARM--134-AIO-64K, one in front of the house and one in back. Netgear Genie is currently installed now. Reason being is with Tomato, the 2.4 signal completely died on the front router. It was as if it never existed. I could see with a wifi scan on my tablet that the back router was broadcasting its 2.4 signal. I did numerous resets and 2.4 would be up but by the time the router was reconfigured 2.4 was dead again. So I figured that 2.4 was dead in the water and prepared the front router by reinstalling Genie for an RMA since it was still under warranty. After getting Genie reinstalled my tablet signaled that there was an open network. I checked and it was the router I thought had the dead 2.4, which wasn't dead after all. Is there anything that can be done to fix this problem? I've seen posts from others with the same router with the same problem.
  28. Mate Rigo

    Mate Rigo Networkin' Nut Member

    The same happens on my Asus rt-n66u
    Last edited: Mar 24, 2016
  29. Lorenceo

    Lorenceo Networkin' Nut Member

    Is anyone else having trouble with QoS since the Multiwan versions? My router seems to be classifying the connections, but not actually doing anything differently with them. Everything just seems to be sent out on the default priority.
    See screenshot here:
    There were other classes of traffic moving on the line at the time the screenshot was taken. 50kb/s or so of what should be classed as "Games" upload traffic. Note that "Default" isn't actually the default on my setup. The P2P class is. When viewing the connection list, they are classed correctly.

    Edit: Just tested this by changing the "P2P" maximum upload to 20% of the previous limit. Running a speed test, the router is catching the speed test traffic it as "Browsing" (as it is set to do), but is treating the upload traffic from the speed test as "P2P" and making it fight with other actual P2P traffic. The "Browsing" traffic from the speed test running doesn't show up in the live graphs.
    Last edited: Mar 25, 2016
  30. Tony Arnold

    Tony Arnold Serious Server Member

    @Lorenceo yeah, I've tried each new update and keep ending up back on v132. So far, I've seen:

    • QoS is non-functional — it's mis-classifying things, and even when it does get the classification right, the limits seem to be a lot lower than what I've entered;
    • Playing media over the LAN causes the router (a Netgear R7000) to reboot all of it's services. Actually any kind of load seems to cause the router to fall over.

    v132 (pre multi-WAN) works perfectly in both of these circumstances. I'm not sure what to provide to @shibby20 to help diagnose the issues I'm having, and unfortunately I have to keep putting v132 back on to get work done, so I can't leave v135 on to troubleshoot more :(
  31. svjugs

    svjugs New Member Member

    Is there any way to get more than 25MB/sec over 5GHz? It's a lot slower than AsusWRT and stock.
  32. jerrm

    jerrm Network Guru Member

    I agree 135 is beta at best, more like alpha. I also had unexplainable issues for the short time I tried it out. Hopefully @shibby20 will work it out over the next few releases. Otherwise I may just maintain my own 132 based build.
  33. rickmav3

    rickmav3 Serious Server Member

    Is it possible to get and compile 132 source files with only some some fixes / changes from 133-135, like R7000 LED support from 133?
    hasafly likes this.
  34. hasafly

    hasafly Network Newbie Member

    I don't understand why not all supported routers by Tomato by Shibby, have LEDs working at 100 percent!!

    Mine RT-AC56U doesn't have any led working......

    Why this is not fixed for all supported routers?
  35. AndreDVJ

    AndreDVJ LI Guru Member

    It's not fixed for all supported routers because Tomato Firmware is an open-source firmware, not a commercial product.

    Open-source means that we need your help to get RT-AC56U LED's working.

    R7000 LED's are working because I found by myself how to fix them and shared the solution here.

    If you can spend some time figuring out gpio addresses, craft and test something similar to what I shared, and share your solution, I am sure your unit LED's can be supported with the next release.
    Edrikk likes this.
  36. Edrikk

    Edrikk Network Guru Member

    Because Devs develop what they want to, and Shibby20 wants this (because he is a part of that 1%).

    I do agree that a safer approach would have been to keep two branches for a while longer so that not everyone gets impacted by all the things that break with such a big change.

    I'm sure it'll all be resolved soon.. The key will be frequent releases at this point to stabilize...
  37. JoeyJoeJoe

    JoeyJoeJoe Guest

    For whatever reason a $RECYCLE.BIN directory is created on my Samba share. Is there any way I can stop it from being created or hide the folder from being shown on the media server folder list? The external drive is NTFS if that makes any difference.
  38. remlei

    remlei Networkin' Nut Member

    ^check for viruses or malware on that computer, normally windows will not create any kind of that in network share.
  39. JoeyJoeJoe

    JoeyJoeJoe Guest

    Will do.
  40. koitsu

    koitsu Network Guru Member

    Samba does have a feature to enable exactly what's described. The question is whether or not the version of firmware you're running (you didn't disclose this -- we need preferably the filename of the firmware you're running) has configured Samba to use vfs_recycle or not.

    In general though, no, this is not something you usually see. When deleting a file on a CIFS/SMB share, most environments delete the file (and it's gone forever). My gut feeling is that because you're using an external USB drive that's pre-formatted on a PC and there was probably something deleted on the drive (while in/connected to Windows directly) before it was made the drive for the CIFS/SMB share. But this is hearsay because I have no way of confirming/denying it. You'll need to do the sleuthing work yourself.

    I can't remember where the Samba configuration file is on Tomato. Possibly it's /etc/smb.conf but there are several places where it could be. Edit: smbd -b doesn't work on Tomato because it's too old. strings also turns up nothing. Might just have to find / -name "smb.conf" -ls and hope for the best.
    visceralpsyche likes this.
  41. JoeyJoeJoe

    JoeyJoeJoe Guest

    That find command didn't work for whatever reason, but I looked at the smb.conf and found no vfs_recycle entry, so I'm moving everything off the drive and formatting it while connected to the router and moving everything back over.

    Update: So far, so good. Fingers crossed.
    Last edited by a moderator: Mar 28, 2016
  42. NewAtair

    NewAtair Network Guru Member

    Small question because the search did't find it:

    In which Versions of the shippy firmare/relases jffs can be used?
    I use a WRT54GL (this router is used by my mother) with the version 1.28.0000 MIPSR1-135 K26 MiniIPv6 but jffs is not included (anymore)?

    I need jffs for the usage of the ad-blocker.
  43. koitsu

    koitsu Network Guru Member

    The find command didn't work because Busybox's find doesn't support the -ls argument (BSD and GNU find do). Sorry, I should have just left that off. find / -name "smb.conf" would have sufficed. My apologies.
    JoeyJoeJoe likes this.
  44. Robby

    Robby Reformed Router Member

    Yes, the E3200 firmware is missing for some reason, I'm also waiting for it.
  45. uneedus

    uneedus Networkin' Nut Member

    I have a pair of Asus RT-N16, one production, one spare. I have been running build 130 AIO, and decided to try loading build 135 AIO on my spare, and putting it into production. Too many things are broken for me, and I reverted back to my 130 router. These problems include:

    No V6 router advertisements are being made to the lan, and thus I have no V6 connectivity to the internet for dynamic clients.

    Even in the case of a static V6 assignment like my server, I still have no V6 connectivity.

    The GUI will not allow me to select channels 1-4 for wifi, and only displays "auto" and channels 5-11.

    My SNMP monitoring script is not working correctly. Before MIB5 was the place where I monitored the Wan link, and it seems to have moved to MIB7.

    I am using a WISP that gives me a static V6 assignment for my use, and I have the point-to-point link routing in my wan-up script.
    I re-entered the configuration by hand into the router, but the bits above do not work. I do not see any difference in the device names, the V6 address is on br0, and the Point to Point link for feeding my routed V6 address is still on vlan2

    Something has broken the V6 parts of the build between 130 and 135, at least for those of us who have a native connection to V6.
  46. chchia

    chchia Network Guru Member

    it seems that with the new introduction of multiwan, it introduced a new problem too, the WAN will never reconnect correctly if for some reason it is failed.

    the only solution is to reboot the router, restarting wan service will not work, nor manually click on the connect button.

    so i have to put this custom script in the scheduler, with 5 minutes interval

    /bin/ping -c 1 > /dev/null; if [[ $? != 0 ]]; then /bin/ping -c 1 > /dev/null; if [[ $? != 0 ]]; then "reboot"; logger "restarting"; fi;fi

    this script intent to ping google or yahoo, if failed it will reboot the router. (logging part seem useless, ya i knew)
  47. NeverMore

    NeverMore Reformed Router Member

    Can someone point me to a file (source, driver, etc) that might contain the code responsible for selecting country in Advanced > Wireless > Country/Region?

    I want to extract the true information by reverse engineering the file responsible for it and make a table for every FW version/brand.

    Example: Selecting Tunisia will disable "X" and "Y" feature and limit the max mW at 80 internally and disables "X" channel, etc etc.
  48. AndreDVJ

    AndreDVJ LI Guru Member

    I'm curious as well where all these countries come from, but I suspect the list comes straight from the driver (wl_apsta.o). Maybe @RMerlin can chime in something.
    Last edited: Mar 28, 2016
  49. RMerlin

    RMerlin Network Guru Member

    This is all done by the closed source wireless driver.
    AndreDVJ and koitsu like this.
  50. nmalinoski

    nmalinoski Networkin' Nut Member

    Just installed Shibby 135 on an Asus N10P. Blew away nvram on install. Configured for Wireless Ethernet Bridge, set routing mode to router. DNS doesn't resolve anything. Can't ping outside the local network, while other devices on the same network can ("network is unreachable").

    Edit: Default gateway isn't being added to the routing table. Bit of an oversight, no?

    Edit 2: Worked around default gateway by adding the route using the Firewall Up script, but then had to turn on Internal DNS to get DNS to work (/etc/resolv.conf wasn't being generated otherwise), and now I'm finding that HTTPS for admin access isn't working.
    Last edited: Mar 29, 2016
  51. koitsu

    koitsu Network Guru Member

    sac7000 likes this.
  52. sac7000

    sac7000 Networkin' Nut Member

  53. YeOldHinnerk

    YeOldHinnerk Serious Server Member

    Shibby: Let me first say thank you once more for your relentless and successfull effort to produce an excellent piece of software!

    I upgraded yesterday from 133 to 135 (tomato-RT-AC66U_RT-AC6x--135-AIO-64K) on my RT-AC66U. I noted a little bug: When I entered into dnsmasq configuration (via GUI) the line "cache-size=4096" Internet Connection would not work anymore. When I checked via command the actual dnsmasq configuration after removing the line again (and having a working Internet Connection once more), I noticed that this cache-size is in there by default. So, no need to add it, I was just surprised that it had a side-effect.
  54. AndreDVJ

    AndreDVJ LI Guru Member

    It's because dnsmasq wouldn't start. Please provide output of the following command:
    cat /etc/dnsmasq.conf | grep cache-size
    Probably you'll find it's been set up already. However I believe what we see listing the process:
    root@R7000:/tmp/home/root# ps | grep dnsmasq
    10751 nobody    4120 S    dnsmasq -c 1500 --log-async
    Is what's gonna be enforced.
    Last edited: Mar 29, 2016
  55. leandroong

    leandroong LI Guru Member

    I would do something like this, in init script (note correct path, i'm using different router)

    sed -i 's/cache-size=1024/cache-size=0/g' /etc/dnsmasq.conf
    killall dnsmasq
  56. jerrm

    jerrm Network Guru Member

    That won't do any good. dnsmasq.conf is rewritten with every service restart.
  57. jerrm

    jerrm Network Guru Member

    Remove your cache-size option. Dnsmasq will not start if two cache-size options are given, even if they are the same, and @shibby20 is now writing his own into the config. I think this is a regression from a change proposed earlier that was temporarily in the tree. Hopefully it will be fixed.
    visceralpsyche likes this.
  58. kanstin

    kanstin Addicted to LI Member

    I have the exact same issue. It also seems like random things are getting reset. I know I had set wifi security to WPA2 Personal, but after I rebooted it was open and had to turn it back on.
  59. NeverMore

    NeverMore Reformed Router Member

    Some reports about RT-N53 (135)

    1. Connected via PPPoE. Status stuck at: Renewing. Internet is working though.
    2. Unchecking "Core USB Support" results in disappearance of 5 GHz wireless/menu.
    3. Port Order/VLAN stuff after NV Ram reset


    Currently connected to WAN and Port #1



    Switch: enabled
    Port 0: DOWN enabled stp: none vlan: 2 mac: 00:00:00:00:00:00
    Port 1: DOWN enabled stp: none vlan: 2 mac: 00:00:00:00:00:00
    Port 2: DOWN enabled stp: none vlan: 2 mac: 00:00:00:00:00:00
    Port 3: 100FD enabled stp: none vlan: 2 mac: 00:00:00:00:00:00
    Port 4: 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
    Port 5: 100FD enabled stp: none vlan: 1 mac: 00:00:00:00:00:00
    VLANs: BCM5325/535x enabled mac_check mac_hash
    0: vlan0:
    1: vlan1: 4 5t
    2: vlan2: 0 1 2 3 5t
    3: vlan3:
    4: vlan4:
    5: vlan5:
    6: vlan6:
    7: vlan7:
    8: vlan8:
    9: vlan9:
    10: vlan10:
    11: vlan11:
    12: vlan12:
    13: vlan13:
    14: vlan14:
    15: vlan15:
  60. JoeyJoeJoe

    JoeyJoeJoe Guest

    I just noticed that I'm having the same issue and I've tried resetting the data with no change. R7000 as well.

    Edit: IP traffic works fine.
    Last edited by a moderator: Mar 29, 2016
  61. fonos

    fonos Serious Server Member

  62. chchia

    chchia Network Guru Member

    Hi Shibby,

    I own a Xiaomi R1D, but in the Overview Status page, i cannot see any Ethernet Port State.

    is there anything to do with code/router/others/ethstat

    MODEL=`nvram get model`
    if [ "$MODEL" == "R1D" ]; then
    sed -i '/Port 1/d' /tmp/ethernet.state1
    sed -i '/Port 3/d' /tmp/ethernet.state1
    sed -i '/Port 5/d' /tmp/ethernet.state1
    sed -i '/Port 8/d' /tmp/ethernet.state1
  63. Mate Rigo

    Mate Rigo Networkin' Nut Member

    Point 2: on that router, the 5ghz is connected over a usb channel to the main SOC, that is why this happens.
    NeverMore and koitsu like this.
  64. tvlz

    tvlz LI Guru Member

  65. NeverMore

    NeverMore Reformed Router Member

    Thanks, exactly my guess.

  66. NeverMore

    NeverMore Reformed Router Member

  67. onmyouza

    onmyouza Serious Server Member

    Hi all,

    I have a problem when using the Default Class feature in Bandwidth Limiter. The description says that non-included MAC will take the Default Rate. So I added my PC MAC address and give it higher DLCeil, and then enable the Default Class and set it to lower DLCeil.

    The problem is my PC is treated as Default Class, even though I've already added its MAC address. It is connected via wireless. My router is old WRT54GL, running tomato-ND-1.28.5x-124-VPN.

    Is this a bug? Can anyone help me to troubleshoot?


    I manage to make it work. The rule applied correctly only if I set my PC priority to 'Normal'. Previously I set it to 'Highest'.

    It seems there's a bug when the clients are set to priority other than 'Normal', it would be treated as Default Class.
    Last edited: Apr 1, 2016
  68. vincom

    vincom LI Guru Member

    maybe try a newer version
    more here
  69. Weltherrscher

    Weltherrscher Reformed Router Member

    In the same room as the router i get about 45 MB/s.
    The 25 MB/s are trough one (thick) wall with perfect alignment of my notebook. =)
    NB wifi is intel 7260.
  70. onmyouza

    onmyouza Serious Server Member

  71. vincom

    vincom LI Guru Member

    I have a tm so i thought the gl also had 8mb, my bad.
    toastman should have a build w/vpn <4mb
    onmyouza likes this.
  72. Ryogo

    Ryogo Connected Client Member

    Anyone tried to build Paragon NTFS driver for Tomato? Open NTFS-3g driver is painfully slow...
    P.S.: on the second thought - driver used for ac56u should work on EA6500v2/EA6700, I think.
    Last edited: Mar 31, 2016
  73. Mercjoe

    Mercjoe Network Guru Member

    What version of the firmware are you using?

    The ARM versions have the Paragon driver built in and is selectable in the USB and NAS tab -> USB support -> NTFS driver
  74. AndreDVJ

    AndreDVJ LI Guru Member


    Paragon and/or Tuxera drivers can't be distributed for all devices. It's a licensing issue, we cannot offend licensing terms and distribute binaries for unlicensed devices.
    – GUI: Allow users to decide which NTFS driver they want to use: Tuxera (AC56, AC68) or Paragon (N18, Netgears) or NTFS-3G (all routers).
  75. das.nauip

    das.nauip New Member Member

    Chiming in to say I just updated 132 -> 135 and cleared NVRAM (I don't usually). My final step is to cleanup & enable QoS. Everything worked perfect until that last step. I'll have to deal with No QoS until we get the fix.
  76. Porevo

    Porevo Connected Client Member

    you can unbind WAN port and bind it to LAN on VLAN setup page
  77. Ryogo

    Ryogo Connected Client Member

    btw, how come that drivers for AC56u and AC68u is distributed with tomato? Is it because binaries used in tomato is directly ported from official firmware e.g. not rebuilt from source?
    I'm asking because EA6500/EA6700 official firmware is also bundled with a Paragon NTFS binary so maybe it could be ported too.
  78. AndreDVJ

    AndreDVJ LI Guru Member

    They are binary blobs so not really a port. Tomato-ARM uses either Tuxera or Paragon binaries 'as is' from Asus, no matter if you build the firmware for Asus, Netgear, Linksys, Tenda, etc.
  79. nick ant0ny

    nick ant0ny Networkin' Nut Member

    Hi all,
    i would to ask, is there any chance we might see the shubby 1.30 builds (kernel with fq_codel) for routers like the E4200?

  80. bimmerm3m5

    bimmerm3m5 Network Guru Member

    I've noticed additional issues with dnsmasq...the "Use received DNS with user-entered DNS" option doesn't seem to work. Only my static DNS entries for OpenDNS appear. Also, any additional commands for dnsmasq don't seem to be allowed (such as strict-order)
  81. NightMonkey

    NightMonkey New Member Member

    Any chance of getting MTU on WAN to allow Jumbo Frames (i.e. > 1500 MTU)? I've got a cable modem with gigabit connected to my N66U, and gigabit devices on Ethernet, so I'd think that pushing the packet fragmentation upstream might take some load off of the N66U's switch. Thanks!
  82. koitsu

    koitsu Network Guru Member

    Are you certain your cable modem works with jumbo frames? Most cable modems I've used (including expensive present-day stuff like the SB6190) tend to only work with 1500 MTU. I would be very wary of using this feature, given the fact that the actual switch in most Tomato routers is 5-port -- the WAN connection is one of those ports, and the segregation is accomplished via a kind of vlanning (sort of), and as you know mixed-frame environments (ex. one device using a frame size of 9000, another using 1500) generally do not work.

    There was a talk given by Richard Steenbergen (NANOG member -- hint: most NANOG folks are professional network administrators) about the misuse and technical nightmares that are jumbo frames. I would suggest reading the slides (slowly and clearly) -- the concerns/points he makes are all 100% valid and not to be taken lightly. LSO is what generally helps on most NICs today, and doesn't require an increased MTU. Slides:
    Last edited: Apr 4, 2016
    Toastman and AndreDVJ like this.
  83. NightMonkey

    NightMonkey New Member Member

    Thank you, koitsu! I will check all that out. :) FWIW, I do not have anything but 1GigE on the router's switch. I have a smart gigabit switch downstream that also only has 1 GigE devices connected (and Jumbo Frames). But I am also curious about if the cable modem I have can handle a larger MTU - I'll investigate further, perhaps do some experiments with just a laptop directly connected.

    P.S. I heart NANOG. :)
  84. dadaniel

    dadaniel Network Guru Member

    Would it be possible to add a minimum rssi setting that kicks all wireless clients below this threshold? Or is this possible using scripts?
  85. rs232

    rs232 Network Guru Member

    Apologies, but what's the use for this?
  86. MrDoh

    MrDoh Addicted to LI Member

  87. rs232

    rs232 Network Guru Member

    In that case there no need for anything, the client picks up the strongest AP
  88. IcyTexx

    IcyTexx Networkin' Nut Member

    I had to revert to v132 because PPPoE connection with WAN set to VLAN 100 is not working... :(
    ChefJoe likes this.
  89. MrDoh

    MrDoh Addicted to LI Member

    Not always, sometimes that doesn't happen, depending on the client That's what "roaming assistant" does, kicks clients below a certain level off the weaker AP. Also speeds up the process.
    Techie007 likes this.
  90. shibby20

    shibby20 Network Guru Member

    mipsel or ARM?
  91. IcyTexx

    IcyTexx Networkin' Nut Member

    Oh, I'm sorry for not mentioning. R7000, ARM.
    Last edited: Apr 5, 2016
  92. tvlz

    tvlz LI Guru Member

    It's both MIPS and ARM
    This got commented out in 'wan.c'(around line 818) when Multi-Wan was added,
        f_write(wanconn_file, NULL, 0, 0, 0);
            if (!foreach_wif(1, &p, is_sta)) {
                p = nvram_safe_get("wan_ifnameX"); //"wan_ifnameX"
                if (sscanf(p, "vlan%d", &vid) == 1) {
                    vlan0tag = nvram_get_int("vlan0tag");
                    snprintf(buf, sizeof(buf), "vlan%dvid", vid);
                    vid_map = nvram_get_int(buf);
                    if ((vid_map < 1) || (vid_map > 4094)) vid_map = vlan0tag | vid;
                    snprintf(buf, sizeof(buf), "vlan%d", vid_map);
                    p = buf;
                //set_mac(p, "mac_wan", 1);
        // shibby fix wireless client
    shibby20 and ChefJoe like this.
  93. eVrajka

    eVrajka New Member Member

    Hi, I have a trouble with ipv6 jn Tomato by Shibby (Tomato Firmware 1.28.0000 MIPSR2-132 K26 USB AIO), my ISP get ipv6 by DHCP without prefix delegation, if i try to put some prefix after several minutes ipv6 address lost, in log I see:

    Apr  6 01:03:54 ROUTER daemoninfo dnsmasq-dhcp[11440]: router advertisement on ****:****:*:****::, old prefix for br0
    Apr  6 01:03:54 ROUTER daemoninfo dnsmasq-dhcp[11440]: RTR-ADVERT(br0) ***:****:*:****:: old prefix
    Apr  6 01:04:00 ROUTER daemoninfo dnsmasq-dhcp[11440]: RTR-ADVERT(br0) ***:****:*:****:: old prefix
    Apr  6 01:04:14 ROUTER daemoninfo dnsmasq-dhcp[11440]: RTR-ADVERT(br0) ***:****:*:****:: old prefix
    I hid my address
    Can you recommend something?
  94. shibby20

    shibby20 Network Guru Member

    @tvlz - indeed, i found this bug 2 days ago. Thanks.
  95. dadaniel

    dadaniel Network Guru Member

    Roaming, every "good" Accesspoint has this feature, as nearly all wireless clients don't roam on their own and always stick to the same accesspoint until the connection is lost at all.
    Techie007 likes this.
  96. Bobby J

    Bobby J Reformed Router Member

    Installed v135 Mini on Asus RT-N10P. Noticed a couple of issues similar to what is being reported here.

    1) In regular Access Point mode, ISP DNS server being appended even though I am using DDNS with OpenDNS and "Use received DNS with user-entered DNS" disabled.
    1.5) Also, no option to configure dnscrypt. Not sure if this is available in the Mini build or not.
    2) In Wireless Ethernet Bridge mode, router time not being set, shows no time available and logs show Jan 1 date.
    2.5) Also, Overview does not show WAN IP or DNS. In this mode I set the IP manually outside of the primary router DHCP pool, and set DNS to the primary router IP. These are note reflected on the Overview page.

    Still looking for help to figure out how to view the makefile in order to determine components of each release/version (see #6226 above)
  97. Maverick00420

    Maverick00420 Network Newbie Member

    Hello there

    133/135 WPA2-Enterprise is broken (Im using EAP-PEAP)

    RT-N16 on K26USB-RT-N5X-MIPSR2-132-AIO works but 133/135... freeradius logs show 'Error: discarding conflicting packet from client XXXXX port XXXX ID: 0 (or 1,2,3)'

    Been using alternative firmware for awhile now and keep learning more and more.... if you need me to check something in my setup I can do so... with some direction on how to do so of course. Im still a total newbie to Linux enviros

    Thank you for all your hard work shibby!
  98. shredthegnar

    shredthegnar Reformed Router Member

    Hi everyone

    I have an e3000 router and I would like to install tomato to use openvpn, after reading through this forum I am having a hard time determining which firmware version would be best. looking for a stable version that has openvpn capabilities. Any help or direction would be very appreciated.
  99. Drinyth

    Drinyth Reformed Router Member

    132 should be entirely stable. 133+ introduced MultiWAN features which seems to have created some issues for users (including myself - I cannot enable QoS with anything above 132), so unless you need to have MultiWAN I'd recommend staying with 132 until the dust settles.
  100. shredthegnar

    shredthegnar Reformed Router Member

    Thanks so much for the help. I have found a few guides for installing tomato on the E3000 but just wondering, do you have any guides you feel are best since you have done it before. Do you use VPN on 132? IF so does it work well?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice