Tomato Shibby's Releases

Discussion in 'Tomato Firmware' started by shibby20, Feb 26, 2011.

  1. redsandvb

    redsandvb Network Guru Member

    Jeez, just found out there's also E1 (been away for while)... Are they pretty much the same?
  2. pomidor1

    pomidor1 Networkin' Nut Member

    pl_shibby repo owner
    ok, so maybe i will say few words. I have a working tomato on revC (and probably newer). Working means that i am able to compile tomato`s image and flash it to the router, router booted correct BUT it works until erase nvram. After that wireless variables )wl0_, wl1_ wl0.1 etc) should automatically restore from default variables wl_, but it does not happen and here is the problem. Still fighting.
    Malakai likes this.
  3. Elfew

    Elfew Network Guru Member

    Still true?
  4. Yim Sonny

    Yim Sonny Serious Server Member

    Thank you very much for the work on the firmware. Don't worry too much about the wireless. Most people who use Tomato firmware leave the WiFi disabled anyway. Tomato is for routing.
  5. Edrikk

    Edrikk Network Guru Member

    That's too funny. Nice random generalization based on no facts, evidence, or reality.
  6. etyrnal

    etyrnal Networkin' Nut Member

    And the wireless represent a network, thus it can be routed to and from. People who assume that everybody thinks and do things the way that they do, are always a little scary to me. When they say things like "most people" but are actually referring to themselves. Sounds like something politicians would say. Imagine they speak for most people, but they don't know anything about most people.

    Sent from my XT1575 using Tapatalk
  7. mojolacerator

    mojolacerator Serious Server Member

    So I shut the wireless off. But none of the browsers work on our phones, tablets, TVs, and game consoles won't connect to online game servers. What gives?
  8. pomidor1

    pomidor1 Networkin' Nut Member

    I think Shibby should consider dropping tomato on ac68 C1, E1 in alpha version it is without working wifi because it is such a demand
  9. Elfew

    Elfew Network Guru Member

    OK, but is there any progress since august? I dont think so...
  10. yangcy

    yangcy New Member Member

  11. JustinChase

    JustinChase Networkin' Nut Member

    If we're wishing out loud, I would like to see the graphing fixed. I went back to toastmans version because of this issue.

    Sent from my phone, forgive any spelling errors
  12. pomidor1

    pomidor1 Networkin' Nut Member

    Last edited: Nov 7, 2017
  13. pomidor1

    pomidor1 Networkin' Nut Member

    if not he who?
    I do not know Shibby personally, but from what I've seen, it always ends up with what he started. Adaptation of the tomato to the new SDK is the key to this project. Without this the tomato will fall into a lethargy.
    Elfew and The Master like this.
  14. yangcy

    yangcy New Member Member

    I assume this has been an answer to my post. I'll try testing this image in coming days and will report back.
  15. crashnburn

    crashnburn Network Guru Member

    Would a move from Tomato Firmware 1.28.0000 MIPSR2-138 K26 USB AIO
    To 140 allow me to export / import a Config file? PS: Not the script one, just the default one?
  16. Elfew

    Elfew Network Guru Member

    Not recommended, better to set everything from scratch.
  17. Kobalt

    Kobalt Networkin' Nut Member

    You could do something like from within the shell...

    nvram export —set >config.txt

    Then cherry pick the most important settings you want from that list, and then paste those into the shell to set them.
    Most things won't change on firmware updates, but, it is possible some will, that is why I say to cherry pick the ones you really want.
  18. Kobalt

    Kobalt Networkin' Nut Member

    Lately, my 5GHz has been very unreliable.

    Anyone know what causes this? I tried a router reboot, and it is doing the same thing, any device that tries to connect to the 5GHz band keeps dropping then connecting then dropping.

    2.4GHz works fine though.

    Using the latest tomato firmware on my Asus N66U router.
  19. apreslin

    apreslin Connected Client Member

    I also experienced stability issues with 5GHz on both an Asus RT-AC68U and an Asus RT-AC3200 on the latest Shibby builds (even on fresh clearing NVRAM installs). Mine was mostly 5GHz dropping all connected devices for about a minute every couple of days, and some other quirky connectivity related issues in various devices. I never was able to identify a root cause or anyone else that had a fix/workaround after reading pretty much this entire thread. I switched over to the Toastman builds a couple of months ago and haven't had an issue with 5GHz since.

    So for stable 5GHz, you may want to try:

    1. Toastman build:
    2. kille72 build fork based on v132 Shibby build:
    3. Shibby v132 build (before MultiWAN was introduced):
    Last edited: Nov 9, 2017
  20. Yim Sonny

    Yim Sonny Serious Server Member

    It sounds like you forgot to add a functional WiFi access point to yer system.
  21. Heavy Thumper

    Heavy Thumper New Member Member

    Will a RT-N53 build be available for v140? I've tried the AdvancedTomato version, but it seems to be just a hair too big - I can't enable JFFS (get too few erase block message) - and therefore I can't setup VPN client. If there's a way to get a "mini" version that just enables JFFS, Dual-Band Wifi, and VPN that would be great.
  22. pomidor1

    pomidor1 Networkin' Nut Member

    Attached Files:

    Last edited: Nov 13, 2017
  23. candycrush

    candycrush Serious Server Member

    Hello will shibby be patching the two recent vulnerabilities that affect the firmware he builds, it has been a while and I haven't seen anything new. Specifically I'm referring to the KRACK vuln and dnsmasq vulns. KRACK looks like a harder problem but I think DD-WRT already took a stab at it. dnsmasq can probably be fixed just by upgrading. How are you guys dealing with this issue on your routers?
  24. pomidor1

    pomidor1 Networkin' Nut Member


    DAVIZINHO Addicted to LI Member

    I found yesterday a liknsys e4200 lost in a box :-P and i used it to install tomato by shibbys with a 3g usb modem.
    This works REALLY COOL!!!!

    but i have a little problem, the 3g dont conect automatically on boot, I must push the connect button in web interface. Its posible that connect automatically??

    thanks a lot!!
  26. pomidor1

    pomidor1 Networkin' Nut Member

    it will automatically run, it probably lack power, connect it via usb2 hub (do not use usb3 hub) with its own power supply separately
  27. Kobalt

    Kobalt Networkin' Nut Member

    It would be better to have the CLIENTS updated, since once you are out of your home WiFi, you remain vulnerable to KRACK.

    DAVIZINHO Addicted to LI Member

    power problem? but if I puss the connect button it works perfect.
    Can i run any automatic script to run de connect order after x seconds on boot?
    I cant use a power switch :-(
  29. pomidor1

    pomidor1 Networkin' Nut Member


    DAVIZINHO Addicted to LI Member

    i still dont understand you. Sorry.
    Im not have a problem disconecting, or a problem in a connection process.
    The problem is when the router power on not conect automatically the wan with the 3g device. I must push the button to connect. No more

    I think if was a power problem, when i push de connect button it fail or give me some problems, but this not ocurs.

    do you understand me? (sorry for my poor english)
  31. pomidor1

    pomidor1 Networkin' Nut Member

    try router+usb2 hub powered+modem lte/3g

    DAVIZINHO Addicted to LI Member

    i still dont understand, but i will try it
  33. Pavel cz

    Pavel cz New Member Member

    Hi, can I use tomato shibby for Netgear R6400v2 ? on Shibby web is router list a there is only R6400, there are no any version about this router. Thank you
  34. pomidor1

    pomidor1 Networkin' Nut Member

    no, only ddwrt
  35. Kobalt

    Kobalt Networkin' Nut Member

    Just an update to this.
    I couldn't solve what the issue was with Tomato Shibby, or, I tried Merlin's build, and haven't had any dropouts in either 2.4GHz or 5GHz.

    Unsure what the difference is between those firmwares, but, I assumed Shibby used the same source for the radios, so, anyone have any ideas on what the issue could have been?
  36. duren11

    duren11 Network Newbie Member

    If by latest tomato you mean v140 for the n66u, I'm currently running the same and I don't experience any dropouts on the 5ghz band. I do get an occasional blip on the 2.4 once every few months but that's it.

    For this reason, krack, and the general update situation of tomato, I'll likely be moving back to dd-wrt soon.
  37. Jau-Ling Chou

    Jau-Ling Chou Networkin' Nut Member

    Does the rt-n66u support minimum rssi setting in any firmware? I'm not sure if it's a limitation of 802.11n, or if it's tomato or I'm just blind?

    Edit: I found that ASUS calls it Roaming Assistant, but I guess its not a feature of tomato/shibby?
    Last edited: Dec 2, 2017
  38. Kobalt

    Kobalt Networkin' Nut Member

    Yes, was on v140, and I did try everything under the sun, from clearing NVRAM to nightly reboots, everything was left at default settings.
    Can't explain it, since the switch to Merlin's, there have been no dropouts at all on either 2.4 or 5.
  39. Suva

    Suva LI Guru Member

    I don't see any of Shibby's post for long time. Is he still here?

  40. Yim Sonny

    Yim Sonny Serious Server Member

    No. He got married a year ago. Spent the first 6 months chasing after his new wife. Spent the last 6 months running from her. Wait another 6 months and he should be single again and ready for some more Tomato.
    RogueScholar likes this.
  41. Techie007

    Techie007 Networkin' Nut Member

    Oh my. That's really unfortunate. A wife is a superlative—either really good or really bad. Thank you for the update, and I hope it goes well for him.
  42. Tomato warrior

    Tomato warrior Reformed Router Member

    While waiting, I have a suggestion, don't know how to officially convey it, but since privacy is a hot topic, and many do not want to hand over their contacts and calendar to google or other online providers, wouldn't it be great if Tomato could take over that task by integrating a calendar and contacts server? Tried installing radicale in python3-light, but there is no pip module.
  43. Yhazarus

    Yhazarus Network Newbie Member

    I put on my qos scheduler pfifo and on system tools doing tc -s qdisc ls dev br0 shows me several qdisc but no pfifo,is it normal?
    I have br0 on 192.1681.1 because router is only routing while modem it works aswell only as modem.Command shows me these results:

    qdisc htb 1: root r2q 10 default 0 direct_packets_stat 2880
    Sent 21986760 bytes 71105 pkt (dropped 0, overlimits 0 requeues 0)
    rate 0bit 0pps backlog 0b 0p requeues 0
    qdisc sfq 100: parent 1:100 limit 127p quantum 1514b perturb 10sec
    Sent 2992976 bytes 4642 pkt (dropped 0, overlimits 0 requeues 0)
    rate 0bit 0pps backlog 0b 0p requeues 0
    qdisc sfq 10: parent 1:10 limit 127p quantum 1514b perturb 10sec
    Sent 17406893 bytes 63489 pkt (dropped 0, overlimits 0 requeues 0)
    rate 0bit 0pps backlog 0b 0p requeues 0
    qdisc sfq 11: parent 1:11 limit 127p quantum 1514b perturb 10sec
    Sent 26883 bytes 94 pkt (dropped 0, overlimits 0 requeues 0)
    rate 0bit 0pps backlog 0b 0p requeues 0
    On qos I only have two ips and
    Version of firmware is MIPSR2-140 K26 USB AIO
  44. bhall7

    bhall7 LI Guru Member

    Just curious if the Shibby builds have stopped. I have an ASUS RT-AC66U, and haven't seen an update (140) since May 2017. I know there have been some security issues that have mostly been patched in the industry, but haven't seen an updated Shibby build. Considering switching to stock ASUS firmware for security, but would be super sad to let go of so many features in Tomato.

    What is everyone else doing? Is there a more updated Tomato build for the ASUS RT-AC66U?

    vex-box likes this.
  45. Xruptor

    Xruptor Serious Server Member

    The only active and remaining Tomato firmware build is Kille ARM builds for Shiby. It looks like any MIPS router developments are dead and folks have to look elsewhere. So if you have a router that can support ARM firmware then give Kille a try. Other then that it looks like Tomato future is in trouble. There are other firmwares available, DD-WRT, AsusWRT-Merlin, etc.. if anything else.
    pedro311 and kille72 like this.
  46. Justio

    Justio Addicted to LI Member

    @kille72, @pomidor1

    Hi guys, i know that you are (please forget my ignorance if not true) somehow in contact with @shibby20 following your posts either here or on openlinksys forum.

    Do you know by chance if he will make future updates to MIPS versions? or the has stopped his involvement in tomato firmware?

  47. Denarius

    Denarius New Member Member

    Really terrific firmware. Only trouble is I'm having a bit of an issue with Open VPN client on it, but I'm sure that's me, not you! :)
  48. Suva

    Suva LI Guru Member

    I am using RSync on Shibby tomato ver. 132. Suddenly it (RSync) stopped working. Can anyone guide me on how I should troubleshoot or fix this issue?

  49. bhall7

    bhall7 LI Guru Member

    Thanks for the reply. I suspected as much. Thinking of switching to Ubiquiti or re-flashing my Asus hardware with stock or AsusWRT-Merlin. Sad, because I sure loved Tomato!
  50. Tox0601

    Tox0601 Reformed Router Member

    Hi! Please give an advice on my problem.
    After flashing my R7000 with v140, there is no internet via wifi. Wifi is broadcasted, I can connect to both of networks, but my mobile devices can't connect to internet. Then I flashed v138, erased nvram and set eerything up from scratch, but devices can't reach network so far. Wired devices work perfectly.
    Sorry for my poor English.
  51. Tomato Mike

    Tomato Mike Connected Client Member

    Your English is great. Did you happen to enable/disable a guest network (set up a VLAN and a virtual wireless network) at any point?
  52. etyrnal

    etyrnal Networkin' Nut Member

    nnnnnnNNNNNOOOOOOOOOOoooooooo! Say it isn't so!

    Nothing compares!

    Sent from my XT1575 using Tapatalk
  53. callous

    callous Network Guru Member

    Did Shibby outright say there will be no more, or is this a guess?
  54. callous

    callous Network Guru Member

    Can WPA3 potentially be added to 3rd party firmware, or will that require new hardware? Talking about on router side, and on wireless adapters for computers
  55. maurer

    maurer Network Guru Member

    theoretically it can be added but as we can't even patch KRACK in wpa2 for tomato i don't see wpa3 here for tthe same reasons outline above - broadcom binary blobs.
    Openwart/lede can add this new standard very easily
  56. RMerlin

    RMerlin Network Guru Member

    Too early to tell, as we don't even know yet if the manufacturers can add it without a silicon revision...

    We won't be seeing WPA3 in production for many months.
  57. JustinChase

    JustinChase Networkin' Nut Member

    is there any updated firmware which shows a graph of traffic, instead of just numerical output? I tried Merlin, but it's only numbers, so no way to see trending (or just at a glance)

    Sent from my HTC6545LVW using Tapatalk
  58. RMerlin

    RMerlin Network Guru Member

    Looks graphical enough to me:

    RogueScholar and kthaddock like this.
  59. JustinChase

    JustinChase Networkin' Nut Member

    Sorry, I mean the real time, and 24 hour historical graphs of thru-put, not amount of data/day. Like Tomato offers. It's useful to see at a glance how my shitty satellite internet is performing.

    Attached Files:

    • data.jpg
      File size:
      254.6 KB
  60. cybrnook

    cybrnook Addicted to LI Member

    Yamon probably has this:

    YAMon2 On ASUSWRT-Merlin
    ruggerof likes this.
  61. etyrnal

    etyrnal Networkin' Nut Member

    What are the three most powerful router models that run tomato shibby that I could buy right now at the store or online, that run shibby mod without any gotchas or hang ups?

    Can I run shibby on a netgear R7000 Nighthawk?
    Can I run shibby on an Asus ac3200?

    What I'm asking, is beyond being able to get the Tomato shibby mod on to these devices and running, do they run without issues? Or are there weird problems?

    Sent from my XT1575 using Tapatalk
  62. Jose C

    Jose C Serious Server Member

    Yes, works good for me.
    etyrnal likes this.
  63. The Master

    The Master Network Guru Member

    Use this Router with Tomato works fine.
    etyrnal likes this.
  64. etyrnal

    etyrnal Networkin' Nut Member

    Do you have any particular hardware revision of this router?

    Sent from my XT1575 using Tapatalk
  65. pomidor1

    pomidor1 Networkin' Nut Member

    there is only one version for R7000 for today
    the other is labeled: R7000P
  66. DomDis

    DomDis Network Newbie Member

    I bricked mine and the serial cable did not work - I had a tech put it on an oscilloscope. The odd this was that the router would come up issue an ip via DHCP, was pingable for a short time and then it would crash. Sure wished that cable worked so I could see where it crashed.
  67. pomidor1

    pomidor1 Networkin' Nut Member

  68. DomDis

    DomDis Network Newbie Member

  69. pomidor1

    pomidor1 Networkin' Nut Member

    Last edited: Feb 2, 2018
  70. Maverick00420

    Maverick00420 Network Newbie Member

    So by the sounds of things some of the bugs that arrived in the multiwan versions will seemingly never be fixed? Sounds like Shibby is winding down.....

    WPA2-Enterprise is still broken in every version beyond 132 (client is sending mutitple packets too quickly)
    As well my OpenVPN server setup works fine on 132 but will not start on newer versions. (havent looked into why its failing as without Enterprise working theres no point)

    Without WPA2-Enterprise I guess Ill be stuck on 132 until I upgrade routers which have more recent support???
  71. gary201

    gary201 New Member Member

    Any version above 132 was unstable on my E4200. If Tomato is really becoming a dead project, I'm wondering whether I should just switch to something like pfSense and just use the e4200 as an access point and be done with it.
  72. Urashima Taro

    Urashima Taro New Member Member

    Hello gary201,

    Have you researched LEDE and/or DD-WRT to work with your E4200?
  73. jenom

    jenom LI Guru Member

    I have a E3200 and using latest VICTEC Tomato v1.28.9014 (made in 2014) which has a nice GUI menu for Webserver with NGINX.
    It has kernel, and I am thinking to get Shibby's "extras" and add ENTWARE.
    However, I need to match kernel version and so far all my effort failed to find out kernel versions of different Shibby's builds.
    Already read "LOGS" on his website, with no kernel version mentioned.
    Can somebody help to tell me which older Shibby's built uses kernel ?
  74. maurer

    maurer Network Guru Member

    any of the recent (v130+) shibby MIPS releases use kernel - its a wireless driver requirement
  75. jenom

    jenom LI Guru Member

    I will try to get "extras" from v132 (the latest non-multiwan/english)
    However, so far could not get NGINX working in Victec
    Does not give me any error message, but webpage (index.html) does not show up.
  76. oppsig

    oppsig New Member Member

    On the openvpn client, is it possible to load routing policy from a file like you can do for your ca.crt in custom configuration? If so how would the syntax look like? I have a bunch of ip's i want to route but don't want to fill nvram entirely. Thanks in advance.
    Last edited: Mar 15, 2018
  77. James Bond

    James Bond Reformed Router Member

    Being happy with MIPSR1 K26 140, I see DNSCrypt has been rewritten from scratch, so update would be appreciated.
    Elfew likes this.
  78. Elfew

    Elfew Network Guru Member

  79. AndreDVJ

    AndreDVJ LI Guru Member

    DNSCrypt was rewritten in Go language, so I don't think we have a compiler for that.
  80. koitsu

    koitsu Network Guru Member

  81. James Bond

    James Bond Reformed Router Member

    I thank @Elfew for the quick attention and @koitsu for the detailed report.
    There is less room for uncertainty now, so I guess we’ll continue to use DNSCrypt 1.x.

    Let me ask another DNS-related question. Some ISPs forbid using third-party DNS, i.e. they restrict connections on port 53. The obvious way to circumvent this limitation is to use DNSCrypt, but what about ordinary third-party DNS with non-standard port (e.g. At present I could manually set IP in Shibby’s settings, but there is no field to insert the port. Perhaps we should add one, or notation IP : PORT is possible here?

    Last edited: Mar 26, 2018
  82. AndreDVJ

    AndreDVJ LI Guru Member

    I guess this is possible via dnsmasq custom configuration box, by adding server=ipaddress#port. Please have a look at that discussion:
  83. James Bond

    James Bond Reformed Router Member

    Thank you for advice, @AndreDVJ.

    Indeed, this way works, but there is a drawback. Imagine, you need to switch on DNSCrypt, then you have to comment out server=ipaddress#port in dnsmasq.conf, otherwise this plain DNS server would be used along with encrypted DNSCrypt’s one (leak is visible via advanced test on If, however, DNS server is set via GUI, it will be automatically discarded after switching DNSCrypt, which is what I desire. One old thread here reveals 2014’s outlook of Shibby’s firmware with IP : PORT notation possible for setting DNS, let’s make it come back.

    Last edited: Mar 31, 2018
  84. pedro311

    pedro311 Addicted to LI Member

    Use IP:pORT in DNS1/DNS2 form, as always:

    Attached Files:

    • WAN.png
      File size:
      14.2 KB
  85. James Bond

    James Bond Reformed Router Member

    Sir, I would not create a request without carefully checking first. Firmware is 1.28.0000 MIPSR1-140 K26 Max, here I cannot insert as DNS1 or DNS2, simply put no more characters are allowed after .177 part.

  86. kille72

    kille72 LI Guru Member

  87. James Bond

    James Bond Reformed Router Member

    I can’t find something akin to 1.28.0000 MIPSR1-140 K26 Max among @kille72’s builds, can you?
    Router is ASUS WL-500gP V2. Oh, Shibby, where are you?
  88. pedro311

    pedro311 Addicted to LI Member

    Well it's only for ARM, I'll try to clone and compile shibby MIPS version with that fix.
    kille72 likes this.
  89. JustinChase

    JustinChase Networkin' Nut Member

    I believe that version has many fixes, could you port them all to a mips clone of that current full version?

    I've been hoping someone could/would do so for some time now.

    Sent from my HTC6545LVW using Tapatalk
  90. pedro311

    pedro311 Addicted to LI Member

    You can download now v140 with that fix, DL link in my signature.
    kille72 likes this.
  91. James Bond

    James Bond Reformed Router Member

    I’ve upgraded MIPSR1-140 K26 Max to MIPSR1-140 K26 Max Pedro Edition without erasing NVRAM values. And for some reason DNSCrypt resolvers list is empty now. @pedro311, have you changed anything here besides extending DNS fields? Or do you believe I should erase NVRAM values first?
  92. pedro311

    pedro311 Addicted to LI Member

    Ouch, I forgot to add fix with new url for resolvers list...
    Let you know (today) about it.

    To be honest, I need more time to make that mips branch more up to date, with all the fixes needed for proper building of images.
    Probably at the end of next week, I'll be ready to release version with updated (main) packages, etc.
    T-Dome and Elfew like this.
  93. James Bond

    James Bond Reformed Router Member

    @pedro311, thanks for your efforts and take your time, so far I’ve rolled back to Shibby’s edition.
  94. pedro311

    pedro311 Addicted to LI Member

    Just uploaded corrected version, enjoy.
  95. James Bond

    James Bond Reformed Router Member

    @pedro311, good news is that DNSCrypt resolvers list is back, but bad news is that initial issue about coexistence of DNS on alternate port with DNSCrypt is not solved yet. Thanks to your fix, DNS field now allows to insert longer values, for example, But this plain DNS is not discarded when DNSCrypt is switched on, so both plain and encrypted servers are used according to leak testing sites (see log). It’s weird, because if I insert DNS of my ISP, it gets discarded perfectly fine and DNSCrypt’s server is used exclusively (see log).
  96. kille72

    kille72 LI Guru Member

    Show us your configuration of WAN Settings/dnscrypt-proxy/dnsmasq/etc please...
  97. James Bond

    James Bond Reformed Router Member

    @kille72, see the screencast, please (link will expire in 3 days for privacy reasons).
    And, as a result, there is a DNS leak as follows.

    Last edited: Apr 4, 2018
  98. MongooseProXC

    MongooseProXC Connected Client Member

    Is Shibby ded?
    eahm likes this.
  99. Monk E. Boy

    Monk E. Boy Network Guru Member

    Shibby got married.

    Life has a way of changing your priorities.
    wistlo, Mercjoe, eahm and 5 others like this.
  100. NickJH

    NickJH Network Guru Member

    I have an old Buffalo WHR-G125 which was running the original 1.28ND release from polarcloud. Because of a Radius/WPA Enterprise issue I decided to try updating to Shibby. From I saw I could use the K26 build so I went for the tomato-K26-1.28.RT-MIPSR2-140-Mini build and flashed the router. Now it just works as a switch. I can't contact it and the radio is also off.

    Have I misunderstood which build I could use? Does anyone know of an easy recovery procedure? I've tried rebooting holding in the reset, releasing it then trying to tftp to it both on its last IP and the default but no dice. I can't get it to respond to pings.

    I've seen jtag instructions including a nice one with a raspberry pi but I'm hoping there may be an easier way - it will take me a while to get round to the pi solution.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice