Tomato: static DHCP hostnames, domain name, and DNS resolution question

Discussion in 'Tomato Firmware' started by scottlindner, Jul 26, 2011.

  1. scottlindner

    scottlindner Addicted to LI Member

    This is a bit complicated so I will start with the essence of this issue. I am having DNS resolution issues for some hosts in my LAN. Routing works fine. The hostnames are entered via Static DHCP which works most of the time but not in certain situations. That's the bottom line of the issue. More specific details follow.

    I have two Tomato routers one behind the other. I run a couple of servers and those are available to the Internet in the first LAN and I have VPN running on that external router as well. The second router is member to this LAN and creates a private network that my desktops and NAS are in. I don't know the name of this network architecture but I am doing it for security purposes. I use Static DHCP on both routers for all devices. If I put a PC on either network I can ping by the hostnames used in Static DHCP. However, if I try to ping by hostname used in the first external router but from within the second router it fails to resolve the hostname. Routing is working because I can ping and do everything else with the hosts.

    I am suspecting that however Tomato is designed to resolve these hostnames entered via Static DHCP it is not actually in the local DNS. I don't fully understand it so I am hoping you can help.

    Here are a few more details that might help the DNS minded understand what is gong on.
    1. The first router's LAN is 192.168.2/24. I am calling this the Red LAN and this the "redrouter" under Basic/Identification/Hostname. When on this LAN I can ping "redrouter" and it will resolve and work.
    2. The second router's LAN is 192.168.3/24. I am calling this the Green LAN and this the "greenrouter". Pinging "greenrouter" works when on this LAN.
    3. DNS resolution for Static DHCP hostname on either router does not work if a Basic/Identification/Domain Name is left blank
    4. I have been using a domain name that I have purchased that resolves to my external IP address as my domain name. e.g. I enter "" as the domain name in both routers and when I ping by hostname from either LAN it says I am pinging ""
    5. From within the LAN of either router I can ping any hostname entered in Static DHCP and it will resolve to ""
    6. If from within the second LAN (green LAN) I do a "ping -a" it will say "pinging" and work
    7. I tried adding both router IPs (, as my DNS servers in my IP settings rather than letting it be assigned via DHCP and pinging "redrouter" does not work
    8. Neither "redrouter" nor "" works
    I used to think I understood DNS until this problem.
    Thanks for the help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice