Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. Toastman

    Toastman Super Moderator Staff Member Member

    Why Toastman Firmware?

    I made this build because I couldn't find one that was stable enough for unattended operation over long periods of 24/7 operation.

    I concentrated on making this firmware for use in residential premises with a large number of users. The one overriding requirement is that it has to be close to 100% stable. Unfortunately, some residents can often download excessive loads of data, including P2P such as Torrents, which hogs bandwidth and upsets other residents. So, I had to develop a QOS system that worked to prevent those people from taking over the available bandwidth. The QOS should work reasonably well for you also, with a little tweaking.

    For my usage, my routers have to work 24/7. ANY downtime is unacceptable to residents. I avoid unnecessary bloat and useless functions to achieve that. I believe the job of a router is to route packets. So you won't find unnecessary bells and whistles or bloat, or "features" that hardly anyone ever uses. Don't ask me to ad them.

    For the same reason, when you use any firmware, please don't just enable every checkbox you see, thinking it must be good to have everything turned on. Many things will not work unless you configure the router correctly or use the "feature" in the correct way and with the correct online site.

    Also, be aware that many people have such badly set up PC's (especially Laptops) and routers that web pages take MINUTES to load!

    Lastly, my builds come with DHCP turned off. You need to set an IP (such as on your PC first to access the router. This is a deliberate safety feature to prevent failed routers from coming online issuing the wrong IP addresses. (If you don't know how to set an IP on your PC, then you shouldn't be trying to use Tomato.)

    Good Luck!

    December 18 2011 - 1.28.7493 and all variants

    December 22 2011 - Version 1.28.7630 K2.4 for MIPSR1 routers now posted.

    1) Reinstate dropbear 0.54 update

    2) Additional options to syslog (local file)
    • max size of file before rotation (default 50KB)
    • number of rotated message files to keep (default 1)
    3) Web UI/httpd: improved checking of WL ifaces operational state (up/down)
    • consider flag IFF_RUNNING when detecting the current/operational state of WL ifaces (in addition to IFF_UP)
    • cleanup afterwards (bugfix: close socket file descriptor)
    4) Web UI: Advanced/Firewall
    • enable selecting between SNAT and MASQUERADE targets for WAN on advanced-firewall.asp
    • reorganized firewall options in 3 groups: Firewall, NAT and Multicast settings
    5) Attempt to prevent cstats/rstats datafile corruption at service shutdown
    • cstats/rstats: allow more time between SIGTERMs at shutdown
    • cstats: delay sending additional SIGTERMs if a there's a gzip process running
    • cstats/rstats: wait for any gzip children to complete at shutdown
    • added syslog startup/shutdown messages for both services
    • wait for any helper processes complete at service shutdown
    6) Hostname completeness: partial revert (cosmetics: 'too noisy')

    7) VLAN-GUI: enforce config requirements for UPnP and IGMPproxy
    • UPnP and IGMPproxy services must be active in at least one LAN bridge to be enabled

    If you enjoy this mod, and would like to thank me for all the time I spent working on it, you can

  2. Toastman

    Toastman Super Moderator Staff Member Member

    What version to use?


    When you get to the download site:
    • First - decide what branch you want. This depends on your router.
    • If it's for the older MIPSR1 routers like WRT54 series, choose "ND"
    • If it's for newer MIPSR2 routers like RT-N16, WNR3500L, Linksys "E" series, then choose "RT"
    • Choose the RT-N branch for some recent MIPSR2 routers (e.g E4200, RT-N10U, RT-N12B1, WNR3500L v2).
    • The E4200 needs the newer "N" wireless driver to get support for the 5GHz radio. You can still use the RT version IF you don't need the 5GHz radio to work. But the other routers mentioned can't use the RT version.
    • Choose the "W/High" folder for routers whose second radio is based on USB E2500 etc
    • Chooses the RT-AC models for RT-AC66U WNDR4500 R6300 etc
    • Choose the ARM branch for latest ARM processor based routers R7000 etc
    • Choose ARM7 branch for R8000, AC3200 etc
    Once inside the correct folder, you will have another choice to make:
    • If your needs are simple, and you don't intend to set up a VLAN, then select "STD"
    • If you need the easy setup VLAN GUI, then choose the folder marked "VLAN"
    Now choose your build:
    • Mini - no USB, no CIFS, no Zebra
    • MiniIPV6 - no USB, no CIFS, no Zebra + IPv6
    • Std - normal build
    • Ext - normal + Extra utilities + NTFS
    • VPN - normal + Extras + NTFS + VPN
    • VPN-NOCAT - normal + Extras + NTFS + VPN + NOCAT portal
    If your router needs USB support, chose a version with "USB" in the title.
    There are "tailed" versions for named routers that have special needs.
    There's also a "generic" version for routers with 60K nvram. If there is a "tailed" (named) build, use that instead.

    You cannot flash the 60K NVRAM version on routers that have only 32K, you may brick your router. Yes, it will show that you have 60K but you don't.


    K2.4 and K2.6 refer to the version of Linux kernel used for a particular compile. Early routers always used K2.4 (which is smaller/faster/lighter). The newer routers use kernel 2.6 which is necessary to use the Broadcom wireless drivers. The IPv6 support is also more complete. While K2.6 builds can be made for, and do work on the earlier routers such as the WRT54 series, they take more memory and are slower in operation. For this reason you will rarely see them. From time to time developers have made such builds available to allow experimentation with IPv6 on those early routers. The real answer however is to upgrade to a better router.

  3. Mercjoe

    Mercjoe Network Guru Member

    Will the IPT pie chart graphs ever come back?

    I found it rather informative as far as connection and traffic distribution. It was far easier to read at a glance than the other graphs.
  4. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "IGMPproxy services must be active in at least one LAN bridge to be enabled"

    Where do we do this?
  5. Mercjoe

    Mercjoe Network Guru Member

    Advanced---> Firewall---> IGMPproxy
  6. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Its only in the VLAN verions. I just checked. So for non-vlan versions we don't need the additional assigning to a LAN information?
  7. Dr Strangelove

    Dr Strangelove LI Guru Member

    Thank you Toastman for the informative 'What version' post. I will have to Google NOCAT portal one day.

    I have upgraded my 'Special needs' ;) Linksys E4200v1 to the following firmware:

    Tomato Firmware v1.28.2493 MIPSR2-Toastman-VLAN-RT-N K26 USB VPN

    Have tested my OptWare add-on PPTP server and OpenVPN server and both work fine.

    2.4GHz and 5Ghz works fine with my Dell Wireless 1520 300Mbps 2.4Ghz/5Ghz mini-card. (two streams)
    2.4Ghz is set to mode 'auto' to accommodate my Android 802.11g phone which then sets the wireless connection rate indicator to 54Mbps, all good.

    At 15m my notebook gets a signal of -62dB on 2.4GHz with connection rate of 162Mbps and transfer rate of 80Mbps
    At 15m my notebook gets a signal of -70dB on 5GHz with connection rate of 81Mbps

    To test transfer rate I use Windows7 'DOS'/Command mode ftp in binary mode.

    My Alienware M11xR1 with Dell Wireless 1520 can be a bit of a pest, as one has to align the laptop with it's built-in antenna just right to get the -62dB signal at 15m otherwise it can drop down to -70dB and only return a 64Mbps transfer rate. That's a loss of 15Mbps if the laptop(client) is not positioned just so for optimal transmission.

    So just check, it's not always the routers fault.

    For me and my Linksys E4200 the signal strength and transmission rates have not changed (better/worse) that I have noticed on 2.4GHz over all the Toastman firmware versions I have used. +-5Mbps

    So in summary, happy camper on firmware v1.28.2493

    Edit - Clarified OptWare add-on PPTP server.
  8. Toastman

    Toastman Super Moderator Staff Member Member

    Thank you for the info, much appreciated :D

    Jim, #7 - correct, not needed except for VLAN builds.
  9. Toastman

    Toastman Super Moderator Staff Member Member

    Mercjoe - yes, perhaps the ipt pie chart will come back in some form, I'm sure. Just at the moment unless your network has less than 11 users, the graph doesn't help us much here (with 100+ users) and is very confusing to my admin staff, so I've put it on hold.

    This isn't because of any speed issues, or anything like that. Augusto and I both agreed that it's superfluous, what is the point of having something that only works for a few people and not every circumstance. Whatever I put in my builds must work.


    In fact, a grand total of 3 people wanted to see it. For my application, it is completely useless, because it obviously is impractical to use with 100+ users.

    It's dead Jim....
  10. Jacques

    Jacques LI Guru Member

    i'm not for ipt pie chart
    CPU will be busy with no important tasks...
  11. kthaddock

    kthaddock Network Guru Member

    I ON with that, Using on one RT-N16 shibby 083V-AIO and it's working, no issue cpu load.
  12. Beast

    Beast Network Guru Member

    Im using the 4493 build (ON RT-N16), and I noticed that this version/build does not contain a preset for turning on and off the wireless radio in the sheduler. It is present in the build im using on my WRTSL54GS. I really like that option, any chance of putting this into the 44?? builds.
  13. Toastman

    Toastman Super Moderator Staff Member Member

    Scheduler shows Reboot/Reconnect/Custom 1,2,3 as usual here.

    You can turn off wireless in Access Restriction menu (Disable Wireless).
  14. mraneri

    mraneri Network Guru Member

    Didn't know PPTP server was included? Or is it??
    Is this PPTP server built into the Toastman firmware, or was it some other OptWare add-on?

    Toastman, if you've built this in, can you tell us which ones include it? I'd like to play with it, (preferably on a MIPS1 2.4 kernel firmware)


    - Mike
  15. Toastman

    Toastman Super Moderator Staff Member Member

    It's a PPTP VPN Client, and it's in VPN Builds

    EDIT - the PPTP server was also added in March 2012 - thanks to Teaman
  16. mraneri

    mraneri Network Guru Member

    Ah. I knew about the PPTP client. Was hoping for an integrated server. Thanks, though.
  17. lancethepants

    lancethepants Network Guru Member

    Dr. Strangelove set up a PPTP server using Optware. That's what he's referring too.
  18. Dr Strangelove

    Dr Strangelove LI Guru Member

    Ah yes, there is a built in PPTP client in Toastman firmware.

    BUT, I installed OptWare PPTP Server add-on on a Linksys E4200v1 as my non-rooted Android can only support PPTP and I 'needed' access to my NAS. [Works very well by the way]

    +1 vote for IPSec server in Tomato firmware. [Tongue in cheek]

    Fingers crossed future releases of Tomato firmware will be kind to this PPTP server add-on installation.

    Read from the bottom up it's less painful, ;) but second post in the thread has links to install info.

    As this is a firmware release thread, PPTP server installation should be discussed elsewhere is my guess, but just thought I'd clarify.

    Edit - Ah, didn't see Lancethepants posted a reply. Thanks to Lancethepants for all his help.
  19. brueggma

    brueggma Networkin' Nut Member


    The following version seems to be crashing on me once a morning: Tomato Firmware v1.28.7493 MIPSR2-Toastman-RT K26 USB Ext. I have a feeling my hardware is starting to go bad, but I'm just posting here to see if anyone else is having similar issues.

    The previous version was 7492.4 and the upgrade didn't go well. I got a mtd failure to write and had to use tftp to reinstall. Again, I think this is hardware related.

    Router: wrt320n converted to a e2000
  20. Toastman

    Toastman Super Moderator Staff Member Member

    Try reducing CPU clock frequency if you think the hardware may be dodgy, it can help.
  21. Toink

    Toink Network Guru Member

    I'm wondering why you flashed your converted WRT320N -> E2000 with that firmware, instead of the Tomato-E2000USB-NVRAM60K-1.28.7493MIPSR2-Toastman- RT-Ext.bin ?

    If it helps, reflash with the OEM firmware. Then try to do a manual reset - use the reset button at the back of the router and flash with the correct Tomato build. It worked for me when one of my E3000's failed to completely flash using one of Toastman's older builds...
  22. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Dr. Strangelove. Pretty amazing stuff you've pushed your equipment to accomplish. Nice work.
  23. brueggma

    brueggma Networkin' Nut Member


    I did use the 60K NVRAM firmware.. I just copied/pasted the version mentioned in the "About" page. Let me try to under clock the CPU as Toastman recommended..

    tomato-K26USB-NVRAM60K-1.28.7493MIPSR2-Toastman-RT-Ext.trx. I use this on both my converted 320n (which I'm having problems with) and my wrt610n (e3000 convert). It's working fine on the e3000.
  24. bucher

    bucher Networkin' Nut Member

    Yeah, I'm surprised it's working with that firmware. I have a WRT320n converted to e2000 as well. You should use the firmware for E2000. tomato-E2000-NVRAM60K-1.28.7493MIPSR2-Toastman-RT- Std.bin
  25. pharma

    pharma Network Guru Member

    Toastman ... When WMM is set to "Auto" in the router and after "saving the setting", a trip to the Device List page did indeed indicate the wireless devices were connecting at speeds higher than 54mbps. However when I went back to Advanced settings in the router, the WMM setting had changed from "Auto" to "Enabled".
    Not sure if router settings are supposed to "change" after being saved, but seems to be happening here.

  26. hakowy

    hakowy Networkin' Nut Member

    FFS, my router can't connect to internet, i set modem as always into bridge, and in router i set pppoe username and password and, router can't establish internet connection, whats wrong with it?????
  27. hakowy

    hakowy Networkin' Nut Member

    Router has ip, and modem is connected to 'internet' port on router as bridge), i have also set in router "route modem ip", and still doesnt work. It is strange because when i reboot router in routing it has for a while modem ip, but after few seconds it dissapears, what is wrong i have never any problems in earlier versions.
  28. Toastman

    Toastman Super Moderator Staff Member Member

    pharma, yes, mine does that too, so did the older versions & K2.4 builds I've just tried.
    Set to Off = Off
    Set to On = On
    Set to Auto* = immediately switches to Enable.

    I seem to remember Teddy Bear answering a post about this a long time ago. Maybe we should try to locate it :)
  29. gutsman7

    gutsman7 Networkin' Nut Member

    Hey Toastman just wanna tell you that ive been running your latest build tomato-K26-1.28.7493MIPSR2-Toastman-RT-Mini. And I am very happy with it, its performing very well on my wrt310n v2 and im using your default QOS properties. Thanks alot for the time you commit to this wonderful firmware and Merry X-mas.:)
  30. JTD121

    JTD121 Addicted to LI Member


    So, it says, for the MIPS-R1 ND K2.4 builds, that Version 1.28.7630 is listed as beta. Why is it beta? Also, why the additional IPT....naming convention/suffix?

    Want to upgrade a bit, but am not sure if this is really a beta or a naming mismatch or what.

    Merry Christmas to those who celebrate!

    EDIT: Actually reading the Readme now.....Still wanna know if this build is beta or not
  31. EpsilonX

    EpsilonX Network Guru Member

    A quote from Toastman...

  32. JTD121

    JTD121 Addicted to LI Member

    Awesome sauce!

    Just decided to upgrade to the build a minute ago, and didn't check the thread first. Well see how it goes! Thanks for the reply!
  33. Toastman

    Toastman Super Moderator Staff Member Member

    Have a great Christmas, everybody!
  34. Catalin

    Catalin Addicted to LI Member

    You too, thanks for everything!
  35. adlerfra

    adlerfra LI Guru Member

    Just flashed Tomato Firmware v1.28.7630 -Toastman-IPT-ND-BETA ND Tiny to my WRT54GL V1.1. Erased NVRAM. Previously running Tomato Firmware v1.25.7515 .2. So far so good. Thank you Toastman for your fine work.
  36. Hackerivs

    Hackerivs Networkin' Nut Member

    toastman is there a way to print from WAN side?
  37. Hackerivs

    Hackerivs Networkin' Nut Member

    I found out how to print from wan side. If anyone is interested I could post a brief explanation how to do this.
  38. were55

    were55 Addicted to LI Member

    Hi Hackerivs, seems a good finding, could you share it the way?

    thanks a Merry Christmast for every body

  39. Hackerivs

    Hackerivs Networkin' Nut Member

    So! My configuration is as follows:
    I have a ASUS RT-N16 router that is bridged to a ADSL modem.
    On the router i have connected via usb the Brother HL-2030 printer. The printserver runs on port 9100, which is impossible to forward normally from the gui.
    To solve this problem, i made a basic iptables script that i put in scripts/firewall to start at every reboot:
    The port 9100 is well known, so I have forwarded it to a random port (in my case, a unassigned port 49450) in order to avoid malicious chinese or russian servers that would attack your printer and endlessly print some stupid things.
    As my router is bridged, I had to forward port 49450 from my adsl modem also.
    Now, I added a new printer (tcp/ip) to my computer which I stiched to my dyndns domain and the port 49450.
    this configuration works perfectly and i can print documents when i'm far away from home :)

    note: if your port is not 9100, simply replace it to the correct port in the startup script.
  40. scsiii

    scsiii Network Guru Member


    i have just bought an Asus RT-N16 and flashed it with v1.28.4493 MIPSR2-Toastman-VLAN-RT K26 USB VPN. After basic config I started to experiment with features I was not familiar with from original tomato. One of them is "Web usage". When I enable Web usage there is significant packet loss on WAN side, like you can see from the attached picture. Anyone else experiencing the same problem? Or have I chosen the wrong version of firmware?

  41. wit100

    wit100 Networkin' Nut Member

    Try the non-VLAN and non-USB version first using the same build batch?
  42. scsiii

    scsiii Network Guru Member

    I was playing around some more and the problem seems to be resolved after I have rebooted the router. Will try non-VLAN and non-USB versions when I find some time. Love the Web usage option, only thing I miss is a drop-down menu to filter output per IP.

    Thank you.

  43. RonV

    RonV Network Guru Member

    I love the Toastman ND-1.28.7630 build...flashed up from Tomato USB lite latests build on my Buffalo WHR-G54S, reset NVRAM and rebuilt my settings. The greatest thing is bandwidth by device now...really cool and helping me zero in on what my AT&T Microcell is up to.

    One thing I was playing around with was assigning the labels to my QOS settings which helps read the reports and graphs, but on the "view details" page link the report defaults back to the older labels (Highest, High, Medium, etc) just a cosmetic issue.

    The other one is it appears that "Reset class when changing settings" in the QOS settings didn't behave as it did under stock tomato USB. When I made a change to a rule from MAC to IP address (wrong mac for rule) the IP addressed device's connections did not re-classify into it's new category. I will play around more with QOS settings but I just wanted to let you know.

  44. someguyfromhell

    someguyfromhell Addicted to LI Member

    Hi Toastman,

    Thanks for creating a consolidated thread. Much better than before :p

    Can you consider putting up a compatibility list similar to TomatoUSB? Something like this:

    Also is the RT-N12 B1 supported?

    Many thanks :D
  45. valzi

    valzi Networkin' Nut Member

    Which firmware version is best for Buffalo WHR-HP-G54? The router needs to be able facilitate wireless gaming and regular internet use for two people at home.

    I'm currently running Victek's Tomato RAF Firmware v1.28.8515 _RAF ND Std, but I'm having lots of connectivity problems. I can't get games to keep connected long enough via the WAN to play, and I lose my wireless internet connection regularly as well (on two different computers.) Neither computer is doing anything other than playing Steam games over the WAN when connection is lost. Anyway, I thought I'd try upgrading to a better version to see if that improves matters. If you have a different suggestion, please make it. =)

    From reading Toastman's Build Guide, I think I should probably get tomato-K26USB-1.28.7821MIPSR1-Toastman-ND-Ext. Here's why: the WHR-HP-G54 seems to be old enough to be considered an older model, so I chose the ND folder. Then I chose RT because I can't think of any reason for me to have a VLAN. Then I chose Ext because I might as well have extra utilities. Does that make sense?

    Also, is DD-WRT more likely to do what I want? I don't mind learning how to use it if it will allow me to fix the gaming problems.
  46. Toastman

    Toastman Super Moderator Staff Member Member

    RonV - the "details" issue is a new one - never seen it or heard of it. It may be a browser cache issue. The "changing class" also worked OK here I believe, but I have no access to an online router to recheck. Maybe someone else will advise.

    Someguy... - Compatibility list is the same as TomatoUSB - the RT-N12B1 may be supported soon. Shibby supports it already if you want to try it!

    Valzi - Victek's 8515 was pretty good, I think something is maybe wrong with your setup. Anyway, should you wish to try it, my latest build (7630 K24 MIPSR1) is here:

    I see RonV (above) is using it on his Buffalo routers.

    Set a fixed IP on your PC and gateway to the router as DHCP is not enabled by default in my builds. Turn it on if you need it.

    I doubt whether you'll get DD-WRT to fix anything :)
  47. valzi

    valzi Networkin' Nut Member

    Toastman: I tried erasing all NVRAM and starting over with no changes to settings, but saw no improvement. Before that, the only unusual setting I had changed was enabling TCP Vegas and giving both PCs a static IP. Is there anything in particular you might suggest doing? I don't think I need to even enable QoS since there are only two of us using it and we turn off all internet-using programs when doing online gaming. Our internet connection is 1.5mbps. I hope it's not a dying router. Also, I'm using a cheap USB wifi adapter on my computer...

    For now, I'll try your tomato-K26USB-1.28.7821MIPSR1-Toastman-ND-Ext. Thanks!

    Edit: actually went with mini because it actually fits on my router. =) Will test and see if things improve!
  48. Toastman

    Toastman Super Moderator Staff Member Member

    Don't bother with TCP Vegas - it doesn't work for through connections on a router.

    Version 7630 has been verified as very stable, I would personally use it in preference to 7821

    This business of "BETA" builds is becoming a pain. ALL builds are BETA by their very nature. Only when they have been posted and tested by a lot of people could they be in any way considered "stable" - and then of course it's too late to change the "BETA" label :confused: Please, people, THERE IS NO SUCH THING AS A "STABLE" RELEASE !
  49. jsmiddleton4

    jsmiddleton4 Network Guru Member



    You need the K24 builds. I still have my Buffalo router. My kids use it when at college to share internet in their dorm room. It has a K24 Toastman version on it.
  50. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "35-Buffalo WHR-G54S - DD-WRT v23 SP2 (09/15/06) std"

  51. valzi

    valzi Networkin' Nut Member

    K26 is working on mine... Why do I need K24? Will it work better somehow?

    Why did you say 35-Buffalo? Does that mean something?
  52. Toastman

    Toastman Super Moderator Staff Member Member

    Does that router even have USB? I didn't think it did - but then, I never saw one. The USB builds are bigger. K2.6 builds are also bigger, slower, and less stable than K2.4.
  53. valzi

    valzi Networkin' Nut Member

    Okay, switching to K24. Will update with progress! Thanks!

    (I would have liked to start a thread about my issue, but this forum seems to only allow me to start a poll for some reason... Is that normal here?)
  54. Toastman

    Toastman Super Moderator Staff Member Member

    No, as far as I know you can start a thread.
  55. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Why did you say 35-Buffalo?

    Ron's sig shows he has 35 of them....

    "Okay, switching to K24."

    Much better version on the earlier 54G routers like Linksys 54's and Buffalo's.
  56. EpsilonX

    EpsilonX Network Guru Member

    1.PNG 2.PNG

    I believe this is what he meant...
    I tested using Chrome, which is my "clean" browser for testing purpose only, so no cache etc...
    1.28.7630, the labels in Details reverted to stock default...
    In this case "P2P/Bulk" into "Class D"...
    Can't remember what it showed in previous firmware... :D
  57. Toastman

    Toastman Super Moderator Staff Member Member

    I see, strange.
  58. RonV

    RonV Network Guru Member

    Yes I have 35 of those routers out in the field at restarunts, coffee shops, etc. I run the older DD-WRT on them for stability and remote mgmt. I do this in my spare time and the owners wanted cheap customer sollutions. So I purchased 128 of the Buffalo routers a long time ago on auction when Buffalo was prohibited from selling them and swap them if they go bad, test, and redeploy. Doesn't earn much but it's fun.

  59. RonV

    RonV Network Guru Member

    Yes no matter how you view reports, clicking on the pie slice, the legend, or just the full report. You get the default labels for the classes.

  60. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Just played with the last 2 k24's, including the xx30 beta, and the xx28.1 std fits just fine on the Buffalo. The xx30 won't fit. As noted it gets the mtd too big error. The IPT stuff?

    The xx30 beta fit on my WRT54G-TM.

    Edit: My bad. Grabbed the wrong one. Grabbed the USB one and not the std one. xx30 std fits fine.
  61. mtlf77

    mtlf77 Networkin' Nut Member

    Is there ipv6rd support? Could please some one point me to detailed development documentation? I've seen udhcpd patch to request option 212, does toastman build have this patch , if yes how can I extract that data?
  62. valzi

    valzi Networkin' Nut Member

    I found the DHCP setting! Things seem to be working at least as well as before. Now to see if the new firmware fixed my problem.

    [and later....]

    Everything is wonderful now! The firmware fixed my problems. Thanks a lot!
  63. Elbart

    Elbart LI Guru Member


    I upgraded from 7480 to 0493 today (Linksys E3000, also did a full nvram-erase before and after upgrading), and after configuring it everything works fine except one thing: the "toggle wireless"-feature works, but the wifi-LED doesn't turn on or off. The actual toggling works, just not the feedback via the wifi-LED.
    Is there a way to check for any errors via ssh? Or some undocumented nvram-setting? The log in the config-menu doesn't show any error except the normal button-message "Dec 30 14:46:09 unknown buttons[326]: SES pushed. Count was 1."
    Also, when I en-/disable wifi from within the config-menu (status-overview and basic-network), the LED doesn't change either.


    Nevermind, after rebooting the LED-feedback works fine. :D
  64. fubdap

    fubdap LI Guru Member

    This is how mine was setup and it works:

  65. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "The firmware fixed my problems."

    The K24 one is that correct?
  66. corncrake

    corncrake Networkin' Nut Member

    thanks, Corn
  67. adlerfra

    adlerfra LI Guru Member

    UPDATE: I see that the 1.28.7630 build has been labeled as STABLE on Toastman's Download site. I totally agree about stability. It has been rock solid and up since I installed it. CPU is overclocked to 250 , Wireless Transmit Power is set to 251, Country is set to Singapore, and Wireless Channel set to 6. Noise Floor is -93. Strong signal throughout my house with no dropped connections.
  68. pharma

    pharma Network Guru Member

    Great site to test the various IPv6 settings provided by your IP and the router is:

  69. RonV

    RonV Network Guru Member

    On the issue of the labels for the QOS classifications now showing right on the reports I loaded a new AUSU RT-N16 with Tomato-K26USB-1.28.7493MIPSR2-Toastman-RT-Std and all the reports look fine. Must be an issue with the 2.4 kernel build. Also all QOS rules are firing just fine. The RT-N16 router is definately faster that my older Buffalo's, purchased the router today at Fry's for $80 plus a $10 dollar rebate. I am only using it as a router and the other two WHR-G54S's are used as access points in my house.

    Thanks again Toastman for this great version of the router firmware.
  70. Toastman

    Toastman Super Moderator Staff Member Member

    cost21 likes this.
  71. GameDog

    GameDog Network Guru Member


    Awesome firmware , has been working without issue for the last month or so (just upgraded to an RT-N16 from an old WRT54G)

    I've setup syslog to write logs to the local USB memory stick, via the Administration -> Logging page. However, I can't find any means to set the size/rotation of the stored log file. I found some threads talking about a syslogd.cfg file. I tried that, but that didn't seem to work.

    How do I change the parameters used by syslog?


    On a side note, these are the default parameters used by syslog:
    syslogd -R -L -s 5000 -b 5 -O /mnt/FOR_ROUTER/logs/messages
    However, it seems like the rotation is not working:
    -rwxr-xr-x 1 root root 3788099 Jan 5 08:58 messages
    Is this a bug or some user error on my part?
  72. n00by

    n00by LI Guru Member

    Your Version of tomato is realy great. I like them. But i miss there one think.
    I use the firmware on a wrt54gs and there is a sdhc mod done. But i can't use my card.
    Is there any way to include the sdhc mod for wrt54x useres?

    Best regards
  73. Gustep

    Gustep Addicted to LI Member

    Hi Toastman, thanks for your work and forum contributions! I recently installed Tomato Firmware v1.28.7493 MIPSR2-Toastman-RT K26 Std on my Linksys E2000 router, and so far things seem to be working well. I have assigned a few static DHCP entries and a few are still fully automatic, and I can identify each and every client on my LAN, where all clients have IPs in the 192.168.1.* range.

    But there is one exception: I have activity from an apparently static mystery IP with no actual HW associated on my LAN. When I look in the QoS transfer rates section, I often see connections FROM to weird external IPs, like channel-jw-13-01-snc7.tfbnw(dot)net ( Traffic involving seems to be fairly low in volume: IP traffic monitoring has counted about 100KB downloaded per day, and nothing uploaded from A lot of the traffic is for port 443, which I think means https (?).

    TCP from to channel-jw-13-01-snc7.tfbnw(dot)net (, rate 0.0
    TCP from to channel-jw-13-01-snc7.tfbnw(dot)net (, rate 0.0

    This really bugs me, because no HW (MAC) address is associated with this IP. If I run arp in the Tomato command window, it lists a MAC for every other IP, but for it says <incomplete>:

    ? ( at <incomplete> on br0

    Do you understand what's going on? Is this unsolicited incoming traffic from the WAN which is directed at a computer on my LAN which formerly had this IP, but which currently has a different IP? Or does this mean there is some trojan or rootkit on one of my PCs? Or is this Tomato doing something all by itself?

    I have tried to drop inactive connections, that usually removes the entries, but not for long - they eventually reappear after a few minutes. Sometimes there is a burst of activity with lots of connections "from", but oftentimes it is just one or two to thefacebooknetwork. I also tried to reset the router, but the stuff still comes back.

    What can I do? I was thinking of trying to add TCPdump to tomato, or of inserting a mirroring switch and Wireshark between my E2000 and the cable modem...

    192-168-1-136 image5.PNG
  74. kthaddock

    kthaddock Network Guru Member

    Seems that IP comes from Facebook check what is running !

    NetRange: -
    OriginAS: AS32934
    NetName: TFBNET3
    NetHandle: NET-69-171-224-0-1
    Parent: NET-69-0-0-0-0
    NetType: Direct Assignment
    RegDate: 2010-08-05
    Updated: 2010-10-15

    OrgName: Facebook, Inc.
    OrgId: THEFA-3
    Address: 1601 S. California Ave
    City: Palo Alto
    StateProv: CA
    PostalCode: 94304
    Country: US
    RegDate: 2004-08-11
    Updated: 2011-09-24
  75. Toastman

    Toastman Super Moderator Staff Member Member

    They look like they may be incoming connections to something that no longer exists. Why would facebook be doing that, this is scary :eek:

    However, that would mean the connections actually stopped at the router, and therefore should show up as "unclassified" in QOS. "136" shown as source doesn't mean it initiated the connection, it just means it's the "local" IP.

    Does this "136" ever send any traffic? If it does you should be able to trace it .
  76. Gustep

    Gustep Addicted to LI Member

    Hi Toastman,

    I don't think so - in the daily summary of the IP traffic, it says about 100KB downloaded, nothing uploaded. Strange, though, that in the QoS Transfer Rates these connections appear to be outgoing (source = local). If someone from the WAN sends traffic destined to a local IP, wouldn't the WAN IP be the source?

    Overall this would make sense, this is probably an incoming connection, trying to connect to a local IP that no longer exists, and being stopped at the router. Maybe I forced a change in IPs without properly shutting down and/or logging out, and now external servers (facebook etc.) keep pushing traffic to a non-existing client.

    However, I don't understand how this can consistently result in the display of a local IP - I mean, who keeps track of the local IPs, who remembers it, other than my own router? And if I reset the router, wouldn't that erase any reference to that IP?I thought I rebooted it, and the issue did not go away.

    Let's assume that in the past, there used to be a computer on my LAN with, and I pulled the plug on my LAN and assigned new IPs without properly closing all the connections (which is entirely possible). How long does Tomato "remember" that certain - now undeliverable - packets were meant for Would Tomato's Conntrack memory (or is this IPtables?) be reset when I click on "Drop Idle Connections"? Or would I need a power cycle on the router? Or would not even that erase the Conntrack memory? ...

    When I get home I will probably try to force another unannounced IP change and see if that duplicates the issue.

    Also, is there any way of extracting more info from the router about this would-be traffic? I.e., can you tell me if I can run a binary of TCPdump (which one) on Tomato to capture one such packet?
  77. Gustep

    Gustep Addicted to LI Member

    Problem solved!! I still had configured a DMZ in Tomato for, and so a lot of incoming (and probably unsolicited) traffic was being routed to this non-existent location. I was really starting to be puzzled how even after a complete power cycle *something* kept remembering this IP.

    Anyways, so far this build is working very well on my Linksys E2000:

    - jffs2 enabled
    - lowered the default clock speed from 354 to 300 MHz
    - Measured routing throughput (WAN to LAN, LAN to WAN) as around 100 Mbps total (default clock, tested w/o QoS)
    - Seems solid and reliable so far

  78. Toastman

    Toastman Super Moderator Staff Member Member

    Ah, I was wondering how on earth .... but this nevertheless poses an interesting question as to what the hell is facebook doing trying to access that PC ? And how many millions of others too?
    eahm likes this.
  79. Tomiie

    Tomiie Networkin' Nut Member

    Hi Toastman,

    First of all, a big thank you for your firmwares.

    I noticed a couple of bugs in this version.

    1) The MAC ADDRESS clone for the wireless interface does not save properly. It works until a reboot. After a reboot, it will revert back to the original address.

    2) The CPU Frequency under Miscellaneous does not show the existing setting. Regardless of the setting, it shows 188,94.
  80. pharma

    pharma Network Guru Member


    What is the name your router and which firmware file did you flash?

  81. Tomiie

    Tomiie Networkin' Nut Member

    Hi pharma,

    Router: RT-N16
    Firmware: tomato-K26USB-1.28.7493MIPSR2-Toastman-RT-VPN-NOCAT.trx
  82. Toastman

    Toastman Super Moderator Staff Member Member

    January 9 2011 - 1.28.7494 and all variants

    1) fix bug in status-overview

    2) Extra models RT-N10U and RT-N12U

    3) Updates from Teaman:
    • Static ARP: minor fix at service shutdown
    • Static ARP: option to enable all known devices
    • IPTraffic: K24 ipt_account module updated to v0.1.20
    • httpd: increased limit for HTTP_MAX_LISTENERS
    • rc/firewall: add "Route Modem IP" iptables NAT rules first
    • rc/firewall: reorg ipt_account rules creation
    • IPTraffic: realtime stats gathering fixes
    • IPTraffic: get rid of nested loop for realtime conntrack counting
    • cstats: regular code maintenance
    • cstats/rstats: allow 'grace period' at shutdown
    4) NEW - QOS ingress for Tomato! Thanks to Tiomo for coding this:
    • Add IMQ based QOS ingress,
    • Incoming bandwidth pie chart

    For discussion or help with QOS features, please use the QOS thread here:
  83. bucher

    bucher Networkin' Nut Member

    When upgrading from 7493 to 7494 is nvram erase recommended? Can I backup settings, do a 30/30/30 and then put settings back on? It's a time consuming pain in the butt to redo all my settings and static ip assignments.
  84. LanceMoreland

    LanceMoreland Network Guru Member

    I upgrade firmware all the time without erasing nvram without any issues. It's three times the work for me because I have one main router and two access points running tomato. I know it's not recommended but it works for me. If we get snowed in this winter and boardam kicks in, I'll probably erase and reconfigure but all is good for now.
  85. dkirk

    dkirk Network Guru Member

    Using the newly released "v1.28.7494 MIPSR2-Toastman-RT K26 USB VPN" version and I did a nvram clear after firmware update. On the Administration/Admin Access page the "HTTP Port" always says "Admin" and the password at the bottom does not match. I can see that the http port is correctly set at 80 using the command-line "nvram" utility and yet the browser GUI shows that "Admin" instead of 80. I have no idea what the problem is with the password, but I can update both fields and all seems find but when I go back to that page those two values remain wrong.
  86. LanceMoreland

    LanceMoreland Network Guru Member

    Do a 30/30/30 reset and then use "root" as the user and "admin" as the password.
  87. mealto

    mealto LI Guru Member

    Hey Toastman, I have read somewhere that Tomato does not support Multicast. I need to tweak and up multicast (mbps) as some Airplay games from iPad to Apple TV is experiencing choppiness. Does your latest version allow Multicast bitrates to be changed?
  88. Toastman

    Toastman Super Moderator Staff Member Member

    mealto - Not sure exactly what you mean. The bitrate can be changed in Advanced/Wireless. UDPXY may help you with multicast streaming. IGMProxy, Efficient Multicast Forwarding & Wireless Multicast Forwarding is supported in the GUI. The best way to find out if it works well for you, is of course to try it :p

    dkirk - that would seem impossible, maybe it's a browser issue or a bad flash.

    bucher - before you upgrade save your settings using this method, then you won't have much problem reconfiguring after an upgrade (you can't just reinstate your old config as that is the same as not having erased) :
  89. kiRach

    kiRach Addicted to LI Member

    Hi! I've already installed last version of your build. Can you explain, please, does your build include Transmission? If yes, how can I active it? And how should I install optware packages? I've found different ways to do this: instructions from, and from What is more appropriate?
  90. Toastman

    Toastman Super Moderator Staff Member Member

    No, my builds are intended for routing, not as a christmas tree. They contain only mods or features that will assist in core routing, client monitoring, bandwidth control, and QOS. They don't contain useless functions. Refer to the "About" page or the "readme" files for the important differences.

    Try Shibby's builds.

    Re. optware, same applies. There are many guides though, you should be able to get assistance quite easily if you need it.
  91. tenskwatawa

    tenskwatawa Networkin' Nut Member

    on my RT-N16 I dont see Incoming bandwidth pie chart. And all data in the Incoming bandwidth table are 0

    Thank you for you good job!!!!
  92. GameDog

    GameDog Network Guru Member

  93. Toastman

    Toastman Super Moderator Staff Member Member

    Gamedog, doesn't the size and rotate function on the admin-log page work for you?
  94. GameDog

    GameDog Network Guru Member

    I don't see the option in the logging page. Am I looking in the wrong spot?

    Also, even the defaults didn't seem to rotate the log, the file size kept growing, so I turned it off.

    Attached Files:

  95. Fighter

    Fighter Networkin' Nut Member

    hi toastman, i use the firmware 1.28.0243 on E4200 V1 and i love it
    do you know the program tcping? that lets you check ping on tcp ports?
    i am getting weird pings when pinging with it especially to my router, while my friend has this router too but stock firmware, and gets 0.4ms pings

    Probing - Port is open - time=11.574ms
    Probing - Port is open - time=15.098ms
    Probing - Port is open - time=15.091ms
    Probing - Port is open - time=15.042ms

    Ping statistics for
    4 probes sent.
    4 successful, 0 failed.
    Approximate trip times in milli-seconds:
    Minimum = 11.574ms, Maximum = 15.098ms, Average = 14.201ms
  96. Toastman

    Toastman Super Moderator Staff Member Member


    I am not familiar with the use of tcp ping, but it isn't ICMP ping. Personally, I can't really see what use it is. Doesn't it work by opening a port and exchanging handshaking, then closing the port or something? I would expect that to take a long time! It will vary too, depending if the router has other work, if the http server is busy with another task, and so on.

    What do you get by a normal ping to the router? That is usually around 0.5mS.
  97. Fighter

    Fighter Networkin' Nut Member

    the tcping is used to check pings to servers that permits the use of tcp port only and block icmp like a world of warcraft server.
    for the version, sorry, i meant 2493, it was the latest that was available yesterday but i see now that you uploaded 0494.

    anyway, because that the program is having problems, i cant check accurate ping to the server outside the game and cant follow how my isp is improving after they have deployed a new undersea cable.

    the program is found here:
    the ip of the server is
    the syntax is: tcping 3724

    p.s: the ping to the router by windows ping, is under 1ms something like 0.5ms
  98. stuntsy99

    stuntsy99 Networkin' Nut Member

    Thanks Toastman (and Tiomo!). The graph looks lovely.

    Although im not sure if this is right... but it takes a while for the graph to 'settle down'. ie: after downloading a 200mb file (set to download class in QOS) it doesn't drop suddenly to 0kb/s, and it takes almost a minute to go to 0... is this meant to happen?
  99. bingo1105

    bingo1105 Networkin' Nut Member

    Just upgraded to 7493 from 7483.2 and everything is looking good... thanks for all you do, Toastman!

    Just one minor observation... in order to take advantage of the new IP traffic monitoring, I assigned a static DHCP reservation to my Roku box which doesn't allow static IP assignment. Upon reconnection, the Roku box asks for the IP it had previously been assigned from the DHCP pool since the lease has not yet timed out. I would expect dnsmasq to NACK the request and then offer the new statically reserved IP, but it instead offers the old IP. It's not a big deal... I can just reboot the Roku to clear the old assignment, but it's not technically the right behavior. Just thought I'd bring it up. ;-)
  100. Mercjoe

    Mercjoe Network Guru Member


    This had to have been one of the most difficult updates I have ever had.

    I flashed and reconfigured via the NVRAM method and PPPOe would reconnect and drop constantly. I had to flash and clear 4 times, I got a stable PPPOe connection only after I decided to do everything manually.

    Then I found that WDS would not come up. I had flashed and reset the remote router with the latest toastman build (Tomato Firmware v1.28.7631 -Toastman-VLAN-IPT-ND ND Std) just the other day and everything came back up the first time on the NVRAM reset/reboot on the remote router. Normally, I can flash I can just reset the NVRAM with the shortcut method and reboot and everything bounces back up. Not this time. So after the experience with getting PPPOe stable, I decided to do this one manually as well.

    To be honest I do not know how I got it reconnected. I changed so many settings over the last 3 hours that I lost track. It came back only AFTER I turned on ARP binding (which I have NEVER used on the WDS router IP before), but then it decided to stay connected and reconnect just fine when I turned ARP binding off to test if that was the source of the problem. Please note, the remote router configuration was never messed with except to turn all encryption off to try an establish just a basic link. I have no idea why it was such a bear this time. Once it DID connect, it has a stable 54/54 connection.

    The inbound IP graph does not work on my router as well. It just has a blank area where the graph should be and all the values on the chart are 0.00. It never worked any of the unstable PPPOe connects either. The other 2 graphs populate and show changes, but the bottom incoming one is dead.

    I think this one needs a BETA tag tossed on it big time.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice