Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. streetwolf

    streetwolf Networkin' Nut Member

    Hoping someone can help me with my problem.

    I have an Asus RT-N16 with Tomato Firmware v1.28.7494 MIPSR2-Toastman-RT K26 USB Ex. Attached to my router I have a Seagate 1TB USB2 hard drive as a NAS. Drive is formatted as EXT3. I use it as storage for my Boxee Box device.

    My problem is that on many occasions both my Boxee and my PC will either not render a particular video or sometimes it doesn't even show up in a file list At the moment I have a video that shows up in Explorer but when I try to play it it says file not found.

    I recall that everything was working fine a few builds back. What build was working I don't remember.

    Does anyone have any suggestions so that my files don't get borked? Perhaps some option or maybe a script?
  2. Beast

    Beast Network Guru Member

    I just upgraded to the 4494 on my RT-N16. I cleared Nvram after the update, and reconfigured manually for all. The QOS pie charts didnt do anything untill I clicked the refresh tab. So far everything seems to be working fine.

    OK, QOS does not seem to work. Testing with VUZE (P2P client) and it takes all the band width. I use the basic enable Qos and it has always worked flawless for me. I could do p2p and play online games at the same time with out chocking the game down..

    ??????? Rechecking all my settings, dont see anything out of place.

    Toastman ????
  3. pharma

    pharma Network Guru Member

    Just downgraded to previous firmware version (Signature) due to errors.

    In 2494 & 0494 version firmware flashed okay, but loading saved config file kept resulting in the following error:

    Invalid hardware type: 0000000C / 0000000D

    Was able to flash back to 7493 and load same saved config file without issue.

  4. gs44

    gs44 LI Guru Member

    Toastman, My E2000 has been running your newest 7494 build now with no issues at all. Ipv6 seems to function well with fast connection speeds for wireless and wired devices. All the new pie charts seem to work just fine. So far for me this firmware has been flawless, Great Work!!!

    @Pharma, If I understand your post correctly your trying to use a backup config file from an older firmware to restore config on a newer firmware? If this is the case you will definitly have errors... As the newer firmware has changed and offers newer features and so forth meaning useing a back up config file from older firmware will not work. The only way your going to get newer firmware to work is to follow the clearly stated directions which is when flashing, select the nvram erase option then after flash select thorough nvram erase option again and then manually config the router from scratch. There is away to "export certain settings" and then import them to newer firmware to help save some time when flashing to newer firmware that will work fine but simply using old backup config file from older firmware will just lead to big issues. Search the forum for how to export/import or maybye Toastman will post the link here again for you.
  5. pharma

    pharma Network Guru Member


    Thanks for commenting ... however does not apply in this case. The config file I was trying to load was created with the previously released version 2493. I well understand cases when when reloading saved configs would not apply, and in this case there aren't any groundbreaking "new features" which would make loading saved configs invalid.

    I think I saw another post where someone mentioned this was the hardest upgrade they ever did, which makes me think it may or may not be related.

  6. Toastman

    Toastman Super Moderator Staff Member Member

    It's interesting. I've flashed the same firmware on 9 different RT-N16's and one E3000 (remotely) and no issues at all either. There have been 367 downloads so far, with just a few people reporting problems, so let's see what else the day brings.

    There have been some changes that will impact nvram settings though, so I would recommend an nvram clear if you have weird issues, as always. 99.9% of all household germs are caused by not erasing NVRAM :cool:

    Having said that, the "invalid hardware" error is somewhat odd - this shouldn't be happening.
    gs44 likes this.
  7. Beast

    Beast Network Guru Member

    OK, QOS does not seem to work. Testing with VUZE (P2P client) and it takes all the band width. I use the basic enable Qos and it has always worked flawless for me. I could do p2p and play online games at the same time with out chocking the game down..

    ??????? Rechecking all my settings, dont see anything out of place.

    Toastman ????
  8. Toastman

    Toastman Super Moderator Staff Member Member

    Beast - When you say it doesn't work, do you see the 3 graphs? Are they populated? If so, then QOS is working. You may need to adjust the rate and ceiling in the incoming section now, as by default most classes are set to allow up to 100% ceiling. So it's vital to set the max bandwidths correctly.

    If there is no fault but just QOS issues, we'll continue this in the "Using QOS" thread.
  9. Beast

    Beast Network Guru Member

    The charts are fine.

    It has always worked for me to just enable QOS and set the in and out bound limits to my isp rates. And ive been using the same numbers for a long time. And all was fine. But now Vuze is using 100% .....
  10. Mercjoe

    Mercjoe Network Guru Member


    In the VLAN versions, we found that you had to add - iptables -A FORWARD -i $(nvram get lan_ifname) -o $(nvram get wan_ifname) -j ACCEPT - in the init script for the WDS to connect properly. It this added automatically now when WDS is selected in those versions are does it still have to be added manually??

    I added it to the INIT script each time and I just want to make sure I am not inducing an issue by having it in there twice. I am still learning about IPTABLES and unfortunately, I can not tell myself if it is.
  11. Jacques

    Jacques LI Guru Member

    Hi Toastman,
    Why 7494 don't show traffic of skype now not anything in bandwidth and ip traffic.
  12. Tomiie

    Tomiie Networkin' Nut Member

    Hi Toastman,

    The MAC ADDRESS for the wireless interface is still broken for 7494. It works fine when you manually edit the settings and click on the save button. However, once you reboot the router, the settings will be lost and reverts back to the default. Can you please advise? Thank you.
  13. Toastman

    Toastman Super Moderator Staff Member Member

    Jacques, I don't know. All my users have it classified under VOIP/Game, and seems to be showing OK in the graphs, but I'll keep an eye on it.

    Confirmed: Yep, three clients presently using skypetoskype audio, all classified by L7 into VOIP class, all reading correctly in BW and IPT graphs and stats. One now using video too, approx 1Mbps incoming video stream.

    Tomiie - will look into that, thanks.
    gs44 likes this.
  14. Reno

    Reno Networkin' Nut Member

    I have an e4200 v1 and was looking into flashing tomato only to get away from the WPS flaw. I've never flashed a router before. I would like the e4200 USB port to work and other than that I use VPN for work. I haven't figured out yet if I need the Toastman build w/ VPN or not. For work, I use the Cisco VPN client tool. I'd guess the Cisco tool creates and manages the VPN tunnel and I don't need anything on the router to support VPN?

    It looks like I should be downloading either:
    tomato-E4200USB-NVRAM60K-1.28.2494MIPSR2-Toastman- VLAN-RT-N-Ext.bin
    tomato-E4200USB-NVRAM60K-1.28.2494MIPSR2-Toastman- VLAN-RT-N-VPN.bin
    I'm still reading all over the place as firmware flashing and Tomato are totally new to me. Is there a step by step idiots guide for flashing and reverting Tomato firmware on the e4200? I found this for DD-WRT on the e4200 (I assume I could just follow the steps there to install tomato):

    Thanks for any help or tips - much appreciated.
  15. gs44

    gs44 LI Guru Member


    I hope you read this before its to late and will save a lot of uneeded steps..

    provided you did nothing to your router yet thats suggested in that dd-wrt link you can simply do it in 3 steps..

    1- Download either tomato firmwares you listed, it just depends on the features you want
    2- open your E4200 stock firmware and nav to page that lets you upgrade the firmware and select the tomato version you downloaded and flash it
    3- log into your router with new tomato firmware and go to admin page and select nvram erase thorough and then configure your settings

    no need to flash with this and that and 30/30/30 crap go straight from stock E4200 firmware to tomato
    Also as Toastman clearly states if you need DHCP please enable it as it is disabled by default
    default log info for tomato is:
    Password- Admin
  16. Reno

    Reno Networkin' Nut Member

    Thanks gs44.

    Man, that sounds a whole lot easier. I haven't done anything yet. I'm working from home today and was going to wait for lunch time or after work to flash. I remember reading about the DHCP setting, almost forgot about it (all DHCP right now - just need to remember to specify my home desktop IP and gateway).

    I actually ran across a similar "how-to" guide for Tomato that also lists all the 30/30/30 resets. I'd guess not doing the resets works 99% of the time and doing all the resets is just the anal fool-proof way of doing things things?

    Thanks again!
  17. gs44

    gs44 LI Guru Member

    Reno, No problem just trying to help

    I have never messed with the ddwrt stuff and I have never had to use the 30/30/30 stuff either and I have flashed my E2000 straight from Stock to Toastman's versions to Shibby's versions back to Stock and back to Toastman's versions roughly 100 times at least with no issues at all.

    It seems the same can be done with E4200 as I found a user who did so here

    So you shouldn't have any issues just going straight from stock to Tomato
    Hopefully someone with a E4200 will also comment as well to confirm all of this but I thank you will be fine
  18. gs44

    gs44 LI Guru Member


    To test this further, I flashed with newest build and then from scratch manualy configured the router and then made a backup config.. Next I did a thorough nvram erase and then with no issues at all I used my backup config file to restore my config in router... So obviously it is indeed the fact you are trying to use a backup config file from an older firmware version. Hope this helps you...
  19. Toink

    Toink Network Guru Member

    I actually experienced this in this build, as well as the last two builds. Not only in the MAC address, but also in the QOS Classification, port forwarding and port triggering 'tabs'.

    This is when I use the GREP commands for these settings to restore my old settings.

    As soon as I power cycle my routers, the settings are gone. What works is, as soon as I restore the settings via GREP commands, I click the save button 3 - 4 times for each of the said setting, then the routers would save them, or I manually change at least one of the setting in these tab, then save.

    So the trick is: click the save button at least thrice before power cycling your router/s. Bizzare! :confused:

    Note: I always do a hard reset of my routers before and after each flash.
  20. Toastman

    Toastman Super Moderator Staff Member Member

    So, if this first happened on build 7492.4 and was OK on 7429.3 - the only thing that changed was really the fix for w/l interface status "up" on the asp page, and some messing about with dropbear paths. Strange.

    367 downloads so far.
  21. mvsgeek

    mvsgeek LI Guru Member

    I encountered the MAC address issue after upgrading from 7625 to 7628 on my WRT54GL's. nvram set & commit via ssh didn't save the new address either. Noticed the same issue with 7493 on the RT-N16. Now when I add/replace routers, I just reconfigure WDS with the "real" MAC addresses. Bit of a pain, but less confusing:)
  22. kthaddock

    kthaddock Network Guru Member

    As usually no problem updating to 2494-nocat without any problem.
    Only thing I saw was error on line 46 in iptales, but disappear after config reboot.

  23. chunter2

    chunter2 Network Guru Member

    I just tried installing tomato-K26-1.28.7494MIPSR2-Toastman-RT-Std.trx on my WRT160N but it failed saying it was too big. I was upgrading from tomato-K26-1.28.9054MIPSR2-beta-Std.trx. I was able to get tomato-K26-1.28.7494MIPSR2-Toastman-RT-Mini.trx to load but really want CIFS. Any ideas?

  24. Reno

    Reno Networkin' Nut Member

    Ugly I'm stupid. Can't figure out where to enter a name and password for dsl
  25. dkirk

    dkirk Network Guru Member

    Try "admin" / "admin"
  26. Reno

    Reno Networkin' Nut Member

    The name/password worked after a 2nd reset of the router. Sorry about that. I stupidly missed where PPOE was in the WAN dropdown to. So now I'm in, PPOE is good, I have access to the Internet and DHCP is enabled.

    So, what to do next :p So many features and options... I'm trying to figure out where to setup wireless security now.
  27. kthaddock

    kthaddock Network Guru Member

  28. Reno

    Reno Networkin' Nut Member

    e4200 v1.

    Not sure if I did this right - setting the eth2 wireless to the same SSID and passphrase as the the 2.4Ghz Band? Thanks

  29. gfunkdave

    gfunkdave LI Guru Member

    They can be the same or different since they are two discrete networks. Many people (myself included) like them to be different so it's easy to verify which one you're connected to.
  30. pharma

    pharma Network Guru Member

    Welcome to the forum! I know you'll enjoy the variety of options Tomato firmware has to offer both hardcore and casual users.

    Normally when flashing I automatically opt for "Erasing NvRam" after the flash, and then load my saved config file. Doing this since "Tofu" days (pre-Tomato firmware) and only manually entering settings with major releases. However this update seems to be somewhat problematic for some people and I guess things will get straightened out. What I eventually did was flash the firmware w/o erasing nvram, while not the normal routine is used with non-major releases. No issues so far and at this point can create a new backup of my config settings if required in the future.

    It will be interesting to see if any other people with E4200 have issues restoring config files created with the previous release.

  31. Beast

    Beast Network Guru Member

    Build 4494 Vlan version on Rt-N16

    Can't select (Lan) without first selecting [ Inactive Rules Cleaning ] first!
  32. Mercjoe

    Mercjoe Network Guru Member


    Update on the WDS problem I had.

    As strange as this is, I found that the MAC address on the 'link with' in the wireless WDS wireless setup was the problem. But it turns out that all my setting changes only enabled me to link accidently.

    I assign my remote router a static IP so I can remote into it at any time. I used to use the MAC of the wireless on the remote modem to assign a IP address, but now you cannot.

    If you use the wireless MAC address of the remote router for this IP and in the 'link with' in the main router, the WDS can not be established.

    You have to use the wireless MAC address of the remote router in the 'link with' field, but you have to use the MAC address of the LAN port of the remote router to assign the static IP.

    I have pulled my older NVRAM saves and I was able to use the same MAC address in both fields without issue till this last update. No problem, now that I see what it going on. Just a change that took a while to sort out.


    The inbound connection graph on my router 'woke up' sometime overnight. Now it is populating the fields and displaying a graph. Strange.. and I have no explaination as to why. I had refresh going and it never showed a thing even when logging out and back into the router. Today, when I came back from work and sat down to figure out the WDS issue I found it was happily displaying data.
  33. Toastman

    Toastman Super Moderator Staff Member Member

    Seems like something strange going on!

    pharma and others

    Unfortunately, the vast majority of problems reported on the forums are because of old config. It is recommended to erase nvram after flashing so that old nvram settings which may conflict with the new version's requirements don't get used. But restoring the old config puts back everything you just erased, so it ends up exactly the same as it was before you began.

    As far as this build being "problematical" - I don't see how, I really don't. It reminds me of the time I changed a line in the "about" page and many people reported HDD/Wireless/Connectivity problems. So guys, now you know why I tend to ignore many posts on the forums.
  34. Jacques

    Jacques LI Guru Member

    Toasamn sorry for the confusion, everything work properly. The mistake was that I did a test on two PC in the local net, only now I realized it that.
  35. Toastman

    Toastman Super Moderator Staff Member Member

    Good news!

    I'm looking at the issue of the changed wl0 MAC address, for me it seems like the problem has been there since 7487. Anyone?
  36. Cynamiter

    Cynamiter Networkin' Nut Member

    I tried to restore my previous config for my E4200V1 created with 7493 (erased NVRAM after flashing to 7494), but I received an error message, when I tried to import the config file:

    Invalid hardware type: 0000000C / 0000000D

    Don't have that much to setup, though.

    Current firmware (USB RT-N Ext) version works okay, but W-LAN stability could be better.
  37. lissny

    lissny Networkin' Nut Member

    excuse me sir.. plz any one help me plz....... I have linksys E2500 router ...what version of firmware should I use.. There is no Support for e2500.. but only i can found there E2000; E3000; E4200; but for E2500 what should I use.. PLZ Help me... i need TOMATO,, Firmware.,,, It seems Good...
    Help ME PLZ
  38. JOllywombat

    JOllywombat Networkin' Nut Member

  39. Reno

    Reno Networkin' Nut Member

    Is it possible to include the e4200 v1 option that disables the rear port lights? There was never and option to disable the giant white-bright "cisco" logo on the front in the Linksys firmware (put a piece of electrical tape over that sucker though). I mean seriously - I like gaming and such in the dark and the Cisco logo on the front was worse than a bright night-light.

    Maybe I'm missing the option - sure would love to get it back if not. Thanks!
  40. LanceMoreland

    LanceMoreland Network Guru Member

    Everything is working great for me on 3 WNR3500L's.

    What is the advantage of the 60K builds and can they be used on the WNR3500L's?
  41. Jedis

    Jedis LI Guru Member


    I just upgraded my Victek RAF 1.25 firmware that I haven't touched in a couple years, because I wanted VPN capability for remote printing. I am using the version: Tomato Firmware v1.28.7632 -Toastman-VLAN-IPT-ND ND VPN

    However, I am missing a feature or cannot seem to locate it. In the Victek firmware, there was an ARP Binding option under QOS Bandwidth Limiting. Is this feature available here somewhere?

    Also, I did not wipe and reset to defaults - however, everything appears to be moved over and functioning correctly, including static DHCP entries, wireless settings, etc. I know the general rule of thumb is to always reset - what are the chances something will go awry?
  42. pharma

    pharma Network Guru Member

    Try under Basic --> DCHP/ARP/BW and click on Options to show hidden choices.

    In your case I'd probably reenter the settings since your are migrating from a Tomato base of 1.25 to 1.28 -- a lot has changed and you may have issues later which would be difficult to troubleshoot.
  43. pharma

    pharma Network Guru Member

    The port lights are not disabled by design...this is still a very minor "bug" that one day will be corrected.
  44. Jedis

    Jedis LI Guru Member

    Awesome, thanks! Way easier, no need to reenter the MACs with that checkbox!
  45. Toastman

    Toastman Super Moderator Staff Member Member

    LanceMoreland - your router can't use the 60K NVRAM builds - as it doesn't have 60K of NVRAM space. These are mostly for (Linksys ?) routers that don't have a special named (tailed) build for them.

    Cynamiter and others - this hardware default thing shouldn't happen. I'll look into it.

    But you're always advised to erase NVRAM and reconfigure when upgrading because of problems such as this. It's interesting that so many people still think they don't need to do it and then post in the forum when things go pear-shaped :eek: So I'll just remind people - if you don't erase and reconfigure, and you get a problem with ANYTHING at all, then before you post, erase NVRAM, reconfigure, check again.

    This is an easy way to re-enter settings:
  46. chunter2

    chunter2 Network Guru Member

    Any one have any ideas on this?

    Couple other things too. Not sure if they go here or not.

    I'm running tomato-ND-1.28.7632-Toastman-IPT-ND-VPN.trx on a WRT54G and when I click on the Device List it says Tomato RAF at the top. The other menu items seem to only show Tomato. Seems to be just cosmetic.

    On that same firmware the total IP traffic daily seems to be way more than the daily bandwidth monitor. Should they be the same or does the IP traffic measure local (internal network) traffic too?
  47. Toastman

    Toastman Super Moderator Staff Member Member

    Did that RAF thing surface again? I thought I fixed that long ago. tsk tsk..

    Yes, the IPTraffic monitor is not restricted to WAN traffic, read up on the mod on the forum for an explanation.
  48. scsiii

    scsiii Network Guru Member

    Hi, to post an update

    I have tried other versions, including tomato-K26USB-1.28.7494MIPSR2-Toastman-RT-Std and tomato-K26USB-1.28.RT5x-MIPSR2-083V-AIO but the problem with inbound ping loss still remains. So I have tried with original FW from asus RT-N16_3.0.0.3_84 and after going thru GUI setting by setting and testing I stoped having inbound ping loss after i have disabled HW Acclerator and then reenabled it as you can see in the picture, jumbo frames setting didn't have any effect on ping loss.[​IMG]

    Now I have no ping loss but am stuck with original FW. Is it possible I have received a defect RT-N16? Could any one post commands to disable/enable HW Accelerator in tomato via console? Any other suggestions welcome.

  49. teaman

    teaman LI Guru Member

    Confirmed (sorta: a first look at the git history indicates it's been like this since... July, 2011 ;) ).
    I'll look into it anyways - thanks for bringing this up!
  50. kthaddock

    kthaddock Network Guru Member

    And you can't choose only to apply Upnp without select LAN, then you can't only select
    "Show In My Network Places" and there set ports and protocol. (poor mans upnp)
  51. freemjax

    freemjax Networkin' Nut Member

    Hi All, I'm a new member, just getting into these new Tomato based firmwares after running straight official tomato for a couple years, on my antique WRT54GS v1. Had pretty good luck with 7630 code, playing with QOS, set up adblocker, etc. Just upgraded from tomato-ND-1.28.7630-Toastman-IPT-ND-BETA-VPN to tomato-ND-1.28.7632-Toastman-VLAN-IPT-ND-VPN mostly for the enhanced QOS. It is working, but I have a couple questions:

    I like the custom class names in QOS, but I noticed that the detail output lists still have the old standard class names (High, Low, etc), while the pie charts show the new custom names. Same thing in 7630 and 7632. Is this intended, or did I miss something? Cosmetic thing, not that critical.

    Seems like I lost jffs whcn I went to 7632, did we just lose that feature, or is there another sub-version that has it that I should have loaded? (if so, do I still have to clear nvram to switch over)?

  52. Toastman

    Toastman Super Moderator Staff Member Member

    Well, (cough)... there shouldn't be any difference. It seems that something has got snarled up a bit. I'll get around to fixing it soon, I hope. If you stick to this same VLAN version you shouldn't need to clear nvram.
  53. Riddlah

    Riddlah LI Guru Member

    Has anyone run into an issue turning on the OpenVPN server? I have tried multiple times to Start the service but it never actually does. Did multiple reflashes with full erase each time.

    Using build tomato-K26USB-1.28.2494MIPSR2-Toastman-VLAN-RT-N-VPN-NOCAT
  54. LanceMoreland

    LanceMoreland Network Guru Member

    Check to make sure you have all of your crt's in the proper place.

    Sent from my Xoom using Tapatalk
  55. teaman

    teaman LI Guru Member

    Fixed. Will be pushed to git soon.
    kthaddock likes this.
  56. Riddlah

    Riddlah LI Guru Member

    Had the crt's in the right place but it looked like there was something wrong with the data. Once i recreated them everything worked perfectly.

  57. Nitro

    Nitro Networkin' Nut Member

    I think by default the new toastman builds are set inbound at 16000kb/s (15.6Mbit/s) you need to manually change this to what ever your internet speed is minus a couple of percent to prevent 1 client from truly saturating the connection.
  58. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "I think by default the new toastman builds are set inbound at 16000kb/s (15.6Mbit/s)""

    If so isn't that set in the wireless driver from which the Tomato builds are assembled? In other words its not exactly an easily changed sorta thing.
  59. LanceMoreland

    LanceMoreland Network Guru Member

    I think they are talking about QOS setting defaults. I do not have QOS enabled and I can get the full bandwidth of 36Mbit/s through my wireless connection.
  60. jsmiddleton4

    jsmiddleton4 Network Guru Member

  61. Toastman

    Toastman Super Moderator Staff Member Member

    January 15 2012 - 1.28.7494.2 and variants

    Normal and VLAN builds are now in the same directory and bear the same release number.

    Just small bugfixes - nothing to get too excited about:

    - fix outgoing QOS prios
    increase HTB prios to 10
    change class prio assignment
    - nvram defaults now country=SG, txpwr=auto
    just an attempt to find some better defaults,
    SG has few restrictions, "auto" is safe for all routers.
    Change if you wish.
    - Revert "Static ARP: option to enable all known devices"
    - some display bugfixes

  62. Cynamiter

    Cynamiter Networkin' Nut Member

    Which version should I download, when my current version is: tomato-E4200USB-NVRAM60K-1.28.0494MIPSR2-Toastman-RT-Ext ?

    I can't find a similar new version.

    Edit: It seems that you are uploading the versions right now. (typo in file name for E4200 USB version => Toastma n-RT, remove space character please)
  63. eahm

    eahm LI Guru Member

    The new way is actually better.

    I should work for Wikipedia... :)
  64. streetwolf

    streetwolf Networkin' Nut Member

    1.28.7494.2 on an Asus RT-N16

    Changing the CPU frequency doesn't 'stick' after a reboot.
  65. LanceMoreland

    LanceMoreland Network Guru Member

    Are you sure you are clicking "Save" at the bottom of the page?
  66. Cynamiter

    Cynamiter Networkin' Nut Member

    New version didn't recognize my 5GHz-Band on E4200. Reverted back to previous version (works as it should).
  67. streetwolf

    streetwolf Networkin' Nut Member

    Yep and a reboot also.
  68. Nitro

    Nitro Networkin' Nut Member

    I also have an Asus RT-N16 and can confirm the options stick after saving however the Overview page never changes from "480MHz" even if say "500MHz" was selected. as stated on the selection page not all devices are supported, I'll assume that means atleast the asus rt-n16 is not supported :)

    I was also reading a previous thread that discussed UDP Time out settings, I currently have mines at Unreplied: 20sec Assured: 30sec, what is the recommended lowest settings i can go to without disrupting services like torrents, gaming, skype and other udp based applications.
  69. streetwolf

    streetwolf Networkin' Nut Member

    I flashed back to tomato-K26USB-1.28.7494MIPSR2-Toastman-RT-Ext.trx and the CPU frequency appears on the Overview page.
  70. Nitro

    Nitro Networkin' Nut Member

    I should have said that i was using: Tomato Firmware v1.28.7494.2 MIPSR2-Toastman-VLAN-RT K26 USB VPN-NOCAT
  71. streetwolf

    streetwolf Networkin' Nut Member

    The Configuration page always has the correct value, whereas the Overview page does not. So is this just a display bug on the Overview page and the frequency is actually what's on the Configuration page? Is there another way to tell the routers frequency?
  72. Beast

    Beast Network Guru Member

    Here is what I see

    tomato-K26USB-NVRAM60K-1.28.7494.2MIPSR2-Toastman- VLAN-RT-VPN.trx
    They all have the -NVRAM60K in their name. ???????
  73. Toastman

    Toastman Super Moderator Staff Member Member

    Correct frequency should be the one in the overview list. You can check by looking at your startup log.

    The display on the misc page is taken from what is found in nvram - but will only display correctly if it finds one of the settings in the dropdown selection list.

    i.e. if you make your own setting to a frequency that's not in that list, or with, say, only 2 parameters instead of 3, then it won't match. It must match one of them exactly. If not, the display on that page, in the dropdown list, will revert to the lowest in the list.

    In other words, if you want to make a change, you should save one of the settings from the dropdown menu. That's why it is there, these are known "safe" settings.
  74. Toastman

    Toastman Super Moderator Staff Member Member

    Guys, you must wait until the upload is finished, because the NVRAM60K versions may well upload FIRST. It can take a few hours to upload these files.

    Nitro - There are no "best" settings. You must experiment to see what works for you, using Google to locate info on "recommended" or "accepted as normal" settings. In practice, you can go right down to the minimum of 10 on all except the "established TCP" and mostly everything will work fine. You can't expire unused connections faster than this!

    A UDP "established" setting of 10 may stop some VOIP applications from working correctly, set to a higher value and reduce slowly until you find the threshold - 25 is often OK.

    You will find some advice, esp. in the RFC's, not to set certain parameters as low as 10, but in practice the negative effects are minimal. It's up to you to decide.
  75. streetwolf

    streetwolf Networkin' Nut Member

    I'm still not clear on the CPU frequency problem Toastman. Will it work with the new uploads or not?
  76. Toastman

    Toastman Super Moderator Staff Member Member

    Yes. I just delayed uploading these builds and deleted the ones already on 4shared while I checked this out :eek:

    Code is checked, the builds checked. Here at any rate, as far as the frequency settings are concerned, everything did exactly what it is supposed to - there is no problem. None of the builds I have uploaded have any problem with CPU setting or display on my RT-N16's.
  77. Nitro

    Nitro Networkin' Nut Member

    is it possible to have a build with a higher nvram say between 128k and 256k (atleast for the RT-N16 its got plenty to flash to spare)
  78. Toastman

    Toastman Super Moderator Staff Member Member

    No. All attempts to increase NVRAM so far have come to nothing. This needs to be done by the manufacturer in his cfe. Search this website and for past attempts.
  79. Nitro

    Nitro Networkin' Nut Member

    ok thanks for confirmation toastman

    p.s. was there also a reason for forcing QoS on downloads/inbound to "on" ? rather than having the original check box for inbound and outbound options
  80. boreas

    boreas Networkin' Nut Member

    I use 0494-2 version on E4200, I have an external HDD formatted in HFS+. I only can read from it, even I have set Read-Write parameter for my share folder. What can I do to fix it?
  81. brugar

    brugar Network Guru Member

    "Administration/JFFS" selection which was present in tomato-ND-1.28.7631-Toastman-VLAN-IPT-ND-VPN.trx appears to be missing in tomato-ND-1.28.7632.1-Toastman-VLAN-IPT-ND-VPN.trx

    Has the JFFS option been moved?

    I found JFFS useful to for saving Bandwidth and IP Traffic history on a weekly basis.
    fear_factory84 likes this.
  82. Cynamiter

    Cynamiter Networkin' Nut Member

    Thanks! I just flashed my E4200 to 0494.2, but the "About" page still says 0494, without .2. Build date is correct, though. I also noticed, that the file size is exactly the same as the previous version. Should it be like that?

    Version I use (should be 0494.2?) from log: Linksys E4200 v1: Tomato 1.28.0494 MIPSR2-Toastman-RT K26 USB Ext
  83. kthaddock

    kthaddock Network Guru Member

    Is this file for VLAN and RT-N driver ? I'm unsure about that.
    tomato-K26USB-128.0494.2MIPSR2-Toastman-VLAN-RT-V PN-NOCAT
  84. Toastman

    Toastman Super Moderator Staff Member Member

    Re. uploaded RT-N filenames - although 0494 is correct - the N is missing from the filenames. My bad. Some of my config files had got corrupted, and trying to rebuild them quickly has resulted in some hiccups and typos. Apologies.

    brugar - JFFS is now back. Download it again.

    nitro - QOS is either off or on. There never was an option not to have ingress switched on. And there wouldn't be much point in doing that. It would cripple QOS to the point of being useless. Tomato's QOS is already recognised as being superior to most others, and now it's just got better, thanks to work by Tiomo and Porter!
  85. tomatosauce

    tomatosauce Networkin' Nut Member

    I have the following devices:
    2 E3000
    4 E2000
    5 310n v2

    I was on DD-WRT with all just before. However, on 310n v2 with all DD-WRT builds I tried I faced severe stability issues with WDS. On the E2000 WDS works fine only in a "star" configuration with no STP not supporting the mesh character of WDS at all.
    So I decided to jump ship and ended up here.

    Now, my questions I try to phrase them short:
    a) Any chance to get the STD builds working on the 310n v2? Seems even though there is 4MB flash size, e.g. tomato-K26-1.28.7494MIPSR2-Toastman-RT-Std.trx or tomato-K26-1.28.7494MIPSR2-Toastman-RT-MiniIPv6.trx fail while the image size suggests they should fit (preferrably a VPN build though).
    b) wireless mode: I am used to be able to choose mixed (for b,g,n) and also specificy separately b+g, or g+n. There is no g+n selection anywhere. Why?
    c) WDS in auto mode - will this work well with 4-5 devices or will it start hanging?
    c1) in a 5Ghz n configuration, in a
    c2) 2.4Ghz mixed configuration​
    d) STP with WDS? yes required/no will cause problems/does not matter (Tomato is smart enough to detect duplicated packets)?
    e) what is the 0494 mentioned above - thought we are on 7493/7494?
  86. brugar

    brugar Network Guru Member

    "Administration/JFFS" selection which was present in tomato-ND-1.28.7631-Toastman-VLAN-IPT-ND-VPN.trx is still missing from tomato-ND-1.28.7632.1-Toastman-VLAN-IPT-ND-VPN.trx The old and new versions of 7632.1 are identical.

    7631 version has 3,680 KB and 7632.1 version has 3,472 KB. I am guessing that the missing JFFS is the reason 7632.1 is smaller.

    Thank you for y0ur efforts on improving and extending Tomato firmware. I hope you will be able to fix your configuration files without too much difficulty.

    Edit: I now see that a new, larger file has been posted for the 7632.1 version. Thank you: I will be installing it directly.
  87. kthaddock

    kthaddock Network Guru Member

    Thank you !
    No need to apologie, sh*t happends. No big deal if we have to wait a couple of days.
  88. Nitro

    Nitro Networkin' Nut Member

    I have also noticed that I cannot set my MTU manually Higher than 1492 when in PPPoE mode, even though my ISP support 1500MTU ..
  89. Toastman

    Toastman Super Moderator Staff Member Member

    brugar, try it now. Both normal and vlan versions should now have JFFS.


  90. Toastman

    Toastman Super Moderator Staff Member Member

    Oleg, since all your observations apply to all versions of Tomato, they really should be in a separate thread. I've moved them to the "Wireless and other issues" thread. You are, as it were, flogging a dead horse. This is all Old Stuff, been thrashed to death many times on two websites.
  91. Nitro

    Nitro Networkin' Nut Member

    ok thanks for all your help and patience toastman, its really appreciated. one last small thing I wanted to ask was,

    TomatoUSB had different themes (notably one was called USBRed which was easy on the eyes to navigate through) was there a reason these were removed and/or is it possible to maybe have them added back in. perhaps one of the plain colours such as olive or brown could be replaced by usbred, instead of having 4-5 themes with just a colour change.

    thanks for your time.

    I know this is just trivial to you but it matters for some of us :p
  92. Edrikk

    Edrikk Network Guru Member

    Hey Toastman,

    Out of curiosity, why did you change the default country from US to SG with this commit?
  93. Toastman

    Toastman Super Moderator Staff Member Member

    Nitro - No. Color changes involve no additional overheads. Themes do. They were removed to make room for more important things :) I greatly reduced the sizes of the remaining stuff too. What remains is my choice.

    Edrik - on the whole, over the last 2 years, I've found that country to give fewer "issues" than others. Nothing more. It's simply based on the fact I never seem to have any of the wireless connection and signal strength problems reported on these threads, so I am trying to find some better defaults for the release versions.
  94. chunter2

    chunter2 Network Guru Member

    Still trying to solve getting a standard load into 4MB flash devices. Is there a magic build size that will fit in 4MB of flash? I'm trying to load a file that's 3828KB. Should that not fit or is there some overhead that I don't know about?

  95. fear_factory84

    fear_factory84 Networkin' Nut Member

    Yesterday I upgraded my wrt54gl that was running an old tomato-vpn 1.27 version with 7632 build and I was getting mad about jffs as on dmesg it said there was some space for jffs.
    I went to the forum to check if someone had this issue, and bang, here is the fix! :D now I have to reflash it and reconfigure it. Can I use the cfg backup on the new build?

    Another thing (maybe this is answered somewhere but I don't have found it), what changes between nd ipt-smallvpn and nd ipt-vpn apart some more free space?

  96. brugar

    brugar Network Guru Member

    Based on the log entries for my Buffalo WHR54GS with a 4MB flash memory, the magic number is probably 3,776 KB (3,866,624 bytes)

    Dec 31 16:00:03 ap01 user.notice kernel: Creating 5 MTD partitions on "Physically mapped flash":
    Dec 31 16:00:03 ap01 user.notice kernel: 0x00000000-0x00040000 : "pmon"
    Dec 31 16:00:04 ap01 user.notice kernel: 0x00040000-0x003f0000 : "linux"
    Dec 31 16:00:04 ap01 user.notice kernel: 0x000bfc00-0x00380000 : "rootfs"
    Dec 31 16:00:04 ap01 user.notice kernel: 0x00380000-0x003f0000 : "jffs2"
    Dec 31 16:00:04 ap01 user.notice kernel: 0x003f0000-0x00400000 : "nvram"

    0x3f0000 - 0x40000 = 0x3b0000 = 3,866,624 = 3,776 x 1,024
  97. chunter2

    chunter2 Network Guru Member

    So it looks like 7487 is the last standard load that would work. That's too bad it's so close. Guess I'll have to stick with the mini version.
  98. Planiwa

    Planiwa Network Guru Member

    Or you could just do this:

    WRT# wc -c /dev/mtdblock/1
      3866624 /dev/mtdblock/1
  99. chunter2

    chunter2 Network Guru Member

    Just did a
    wc -c /dev/mtdblock1
    on my WRT160N and got 2912023. Not sure this makes sense since I'm running TomatoUSB v54 standard (tomato-K26-1.28.9054MIPSR2-beta-Std.trx) on this router and the file size for that is 3641344. How does that fit?
  100. Planiwa

    Planiwa Network Guru Member

    Hm. Here is what I do to see all the regions (and also the name):
    dmesg|egrep -i 'mtd|0-0';cat /proc/mtd
    This produces (on the RT-N16):
    Kernel command line: root=/dev/mtdblock2 noinitrd console=ttyS0,115200
    Creating 5 MTD partitions on "Physically mapped flash":
    0x00000000-0x00040000 : "pmon"
    0x00040000-0x01fe0000 : "linux"
    0x00124400-0x00740000 : "rootfs"
    0x00740000-0x01fe0000 : "jffs2"
    0x01fe0000-0x02000000 : "nvram"
    dev:    size  erasesize  name
    mtd0: 00040000 00020000 "pmon"
    mtd1: 01fa0000 00020000 "linux"
    mtd2: 0061bc00 00020000 "rootfs"
    mtd3: 018a0000 00020000 "jffs2"
    mtd4: 00020000 00020000 "nvram"
    One could convert the hex size to decimal like so:
    printf "%d\n" 0x01fa0000
    I wonder what the above reports for the WRT160N?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice