Tomato Toastman's Releases

Discussion in 'Tomato Firmware' started by Toastman, Dec 18, 2011.

  1. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Without further info it's difficult to know but I see this in the syslog:

    May 17 20:38:55 unknown pppd[7378]: No response to 5 echo-requests
    May 17 20:38:55 unknown daemon.notice pppd[7378]: Serial link appears to be disconnected.
    May 17 20:38:55 unknown pppd[7378]: Connect time 38.6 minutes.
    May 17 20:38:55 unknown pppd[7378]: Sent 1151 bytes, received 1776 bytes.
    May 17 20:38:58 unknown redial[7379]: WAN down. Reconnecting...
    Now, a) that's not exactly an busy link (!) and b) pppd tried to get 5 link echo responses and failed. Bear in mind that the link was up for 38 minutes. What I would try is setting up an IP ping every 30 secs or so, just to put a bit of traffic on the link. I'm wondering if your ISP doesn't count the LCP echos as an 'active' indicator and drops the link after 30 something minutes.

    Years ago I had a very strange ISP fault whereby the pppoe link was dropped silently, it looked to all intents & purposes like Tomato was the problem with certain firmware only...went and bought another router...similar issues but both the original firmware & the new router firmware masked them slightly better. Eventually ISP cleared the misconfiguration.
  2. M0g13r

    M0g13r Network Guru Member

    my first post about that ...

    Tomato RAF with included BitTorrent Client - beta testing

    @Toastman we need the lcp-echo-intervall option in gui too .... to set the intervall time

    lcp echo is for checking connection from router to isp ... if some isp's answer an echo only all 30 secs and u echo all 10 secs and one echo get really loosed .... and the isp answers only after 30 secs again ... there are 3 more that not answered echos ... now we have 5 ore more and connection drops :\

    and u don't really need the lcp echo thing at all .... the router checks itself if he has no connection :)

    there was long time ago a discuss with the robert schlabbach ... he wrote paspppoe ... about the same thing with lcp echo with same conclusion
  3. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    So what I think you're saying is that if 5 LCP echoes are lost IN TOTAL then ppp thinks the connection has gone away. Surely this is a ppp bug, it should be if 5 contiguous LCP echoes are lost then we should consider the link gone. In my opinion a successful LCP echo reply should reset the counter to 0. Every other solution is really a sticking plaster over the problem...either just not looking for echos are not worrying about how many are lost. I wonder what the RFCs say?

    Man page say:
    lcp-echo-failure nIf this option is given, pppd will presume the peer to be dead if n LCP echo-requests are sent without receiving a valid LCP echo-reply. If this happens, pppd will terminate the connection. Use of this option requires a non-zero value for the lcp-echo-interval parameter. This option can be used to enable pppd to terminate after the physical connection has been broken (e.g., the modem has hung up) in situations where no hardware modem control lines are available.

    this is ambiguous. It could be interpreted as saying 'if I get n LCP echo failures then the connection has dropped' - it doesn't say the failures have to be contiguous.

    The source code lcp-echo-failure option says 'number of consecutive echo failures....'

    I need to try and work out what the code is *really* doing.
  4. tvcat

    tvcat Networkin' Nut Member

    Ok i set pppoe_lei to 0 and restarted wan.
    I left the web config page open so it refresh every 3 seconds
    the result is it still disconnect after 2 hours something.
    below is the log.
  5. M0g13r

    M0g13r Network Guru Member

    in the GUI


    in the field Options u add .... lcp-echo-interval 0
    nothing else
  6. Lorenceo

    Lorenceo Networkin' Nut Member

    It has been almost a year since I first tried to bring attention to this, but it's still happening in the latest builds. :(

    My ISP gives out IPv6 addresses over VLAN tagged PPPoE via DHCPv6 with prefix delegation. This requires the MTU to be 1492, rather than 1500.
    On my RT-N16 (1.28.7501 MIPSR2Toastman-RT K26 USB Ext) when I enable IPv6 with router advertisements, radvd does not take the settings I enter into the GUI.
    It seems to use the default config file baked into the firmware, announcing a /64, the prefix information, recursive DNS server and the source link layer address.
    It does not use any information entered into the IPv6 GUI, such as static DNS or prefix length. Nor does it take into account that the MTU must be different for v6 traffic to flow properly, even though it has been set manually in the PPP settings.
    The stock Asus firmware reports via radvd that the MTU on v6 traffic should be 1480 when the WAN MTU is set to 1492.

    For almost a year I've had a varyingly reliable system with a script running every 2 minutes to check if radvd is running, and if it is not then to start it with a custom radvd.conf file with the correct settings in it.

    I was recently speaking with someone on the same ISP as me, they are using an Asus WL-500g running v1.28.7821 MIPSR1-Toastman-ND K26 USB VPN-NOCAT, and their radvd apparently does use the MTU and DNS settings assigned to it via the GUI.
    It'd be great if this could be looked into further and resolved.

  7. Dmitry

    Dmitry Networkin' Nut Member

    Hello Toastman,

    I'm using your builds since a long time being very satisfied with features and overall stability. Thank you for your great work!

    Now to the issue I've got.
    My ASUS RT-N16 is running Tomato Firmware v1.28.7501 MIPSR2Toastman-RT K26 USB VLAN-VPN.
    My WAN is an ADSL line 8mbit/s DL / 512kbit/s UL.

    On May 11, I've bought a new Windows Phone 8 based smartphone, Nokia Lumia 920.
    Look what Tomato shows for it on Daily Traffic history page:
    [​IMG] is my Lumia.
    Can you believe that smartphone could download ~40GB and upload ~3GB daily? :) Not to say I'm at home during working days only for about a half of day.
    For comparison, I've added to this list my laptop ( and my torrent box running transmission (, and their data look pretty reasonable.

    Btw, Realtime Bandwidth page shows almost no traffic for Lumia except tiny bursts for (I guess) push notifications and contacts/mail synchronization tasks.

    Any ideas what is this?
  8. tvcat

    tvcat Networkin' Nut Member

    I done that and reboot the router.
    After some time, I cant browse any website nor getting response from ping but the router is showing connected with an IP address so obviously it is disconnected.
    I checked the ADSL modem and the ADSL link is on show time so i dont think it lost its sync.
    Now i had to clear the value in the Options field and its back to frequent disconnecting again.....

    @Kevin Darbyshire-Bryant
    How do i set up and IP ping every 30 sec?
    Put the code below in the init script?
    sleep 30000
  9. Mercjoe

    Mercjoe Network Guru Member

    Your scale is set to KB, not GB so you are not moving near as much data as you think.

    Granted, for a phone you are still using a LOT of data, but not in the TB range.
  10. Dmitry

    Dmitry Networkin' Nut Member

    Oops, sorry, my mistake. 45,475,753.00 KB is ~45 GB, not TB of course. So the correct statement should be "Can you believe that smartphone could download ~40GB and upload ~3GB daily?"
    But this does not change my issue. Comparison with laptop and 24/7 torrent box is still valid.

    PS. I'll edit my original post to not confuse anybody once again.
  11. Mercjoe

    Mercjoe Network Guru Member

    Does the windows phone have a network usage tracker like Android? I would look at that and see how much Wi-Fi traffic has been used. If they agree then I would start looking at individual apps and see what is going on. If they don't agree.... then you may have found a newer bug.

    I wonder if this has to do with the patch RMerlin asked about back on posy #1892 of this thread?? He indicated that cstats would be affected and that is the source for the IP bandwidth data.
  12. Chad Burks

    Chad Burks Networkin' Nut Member

    Hi Everyone,
    I just tested the 1.28.0502.5 MIPSR2Toastman-RT-N K26 USB VPN-NOCAT build on both my E3200 and E4200. The IPv6 issue (with Hurricane Electric) is fixed in this least for me :) Thanks!
  13. Toastman

    Toastman Super Moderator Staff Member Member

    May 19 2013 - 1.28.7502.5 and variants - BETA BUILD FOR EVALUATION!

    • Cosmetics - Basic-Network page (change "Check Interval" to "Redial Interval")
    • cstats - Don't add traffic to the tree if we decided we weren't ready for an update - this would cause some traffic to be added twice
    • cstats - missing from 8d765d18aa25a4490cb4c4af7703f0a7f8c7689f
    And something for people to try, feedback welcome - Thanks to Kevin

    • Add GUI for manual IPv6RD configuration - Basic/untested

    Thanks to Kevin and RMerlin - and to everyone for the feedback :D

  14. Beast

    Beast Network Guru Member

    After setting up, 6rd Relay and finding it not working. The ( Disable ) Selection's Save Button does not seem to work.

    Latest 502.5 Beta on RT-N16
  15. Toastman

    Toastman Super Moderator Staff Member Member

    I'm using an RT-N16 - ext build - and although I can't set up a working tunnel at my location, the save button seems to work ok. Anyone else?
  16. Dmitry

    Dmitry Networkin' Nut Member

    Unfortunately, WP is more like iOS in its very restricted API, so no traffic counters here.
    But I don't need to count traffic on smatrphone to tell that Tomato is wrong. Look:

    Fresh daily summaries:

    Last 24 hour for Lumia, very few traffic, and note totals below the graph:

    For my laptop:[​IMG]

    And for torrent box:[​IMG]

    So I would tell that Tomato shows reasonably correlated data for laptop and for torrent box, but not for smartphone.

    By the way, can you imagine what battery drain would occur if smartphone constantly transfer such amounts of data? But my smartphone is pretty cool and long running. Just because it is idle.
  17. Toastman

    Toastman Super Moderator Staff Member Member

    yep. Doesn't make much sense to me, either.
  18. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    That's strange. I've swapped between '6 in 4 static tunnel', '6rd' and 'disabled' without problem (actually not strictly true - there's a slight oversight on my part with regard to ipv6_tun_mtu 'default' value....which is a bit of an 'oooops!' - Toastman I'll be in contact :) I did have a problem with connectivity 'cos I was using IPv6 to connect to the router at one point....probably best to use the IPv4 address whilst playing around with IPv6 tunnels etc otherwise it can look like the router has gone away :)

    Did you reset nvram after upgrade? There are some new nvram variables which if unset may be causing the gui some issues. What do you have set for the following vars? (nvram get varname)


    Also, when you said the tunnel didn't work a few questions:

    1) did you remove your tunnel set-up scripts in init etc and reboot the router?
    2) where did you test the basic ipv6 connectivity from? I'm hoping the router. If a PC then the PC might have needed a reboot as well. It's always worth doing basic ping tests from the router first - if they fail then the router is unhappy, if they succeed then it's something to do with IPv6 LAN addressing (dnsmasq)
    3) Did the router status page show any form of IPv6 address (LAN/WAN)

    Manual 6RD is not something I can test for real as my ISP doesn't use it, but it did at least attempt to set up a tunnel with what appeared to be sensible tunnel addresses when I tried.
  19. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    No that won't work. What I'd do instead is use an external monitoring service like - that way you get latency graphs 'n stuff as well.

    But I'm coming around to the opinion that there's nothing wrong with pppd and instead your ISP is doing something 'odd'.
  20. Victek

    Victek Network Guru Member

    Keith, I think you have still pending patches to apply.... there is a garbage of 32-bit counters lost data to be accounted.
  21. Toastman

    Toastman Super Moderator Staff Member Member

    Dmitry, are you using the latest version or still the old 7501 ? I believe this was fixed already.
  22. Dmitry

    Dmitry Networkin' Nut Member

    I'm still on Tomato Firmware v1.28.7501 MIPSR2Toastman-RT K26 USB VLAN-VPN
    Do you suggest me to upgrade to 7502.5 or wait for 7502.6?
    And I wonder if this beta version will work stable for me assuming I'm not using Ipv6?
  23. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    cstats (the thing that does the iptraffic stuff) has for a long time had some errrr 'features' about it. These features are gradually being squashed, there's been a big effort on this recently by Rmerlin, the results of his effort on the Asus version of the code have been ported (slightly erratically) to Toastman's & Victek's latest betas - I'd suggest upgrading AND deleting your cstats history if you have any.

    For those interested in such things, the majority of problems were caused by using 32 bit counter variables...and 4GB really isn't a lot of data these days :) It would also be fair to say that this area of the code is still being worked on.
  24. Dmitry

    Dmitry Networkin' Nut Member

    Ok, I'll try upgrading to the latest.
    But I wonder why my new WP smartphone is so special? I don't have any complaints on how traffic for my torrent box and laptop is calculated (and for other network devices that I'm not showing here - I have a few more devices - wife's laptop, kids' desktop, htpc, old winmobile smartphone, one android device).
    Anyway, I'll upgrade and let's see then.
  25. Beast

    Beast Network Guru Member

    Toastman and kevin, no I have not reset nvram for the last 3 updates. Will do that when I update to the .6 vlan version. Toastman, I was talking about the ability to choose DISABLE all IP6 stuff and then The SAVE button will not work for me. I will report back after the update, I still do not see any VLAN version yet.
  26. Dmitry

    Dmitry Networkin' Nut Member

    So I've upgraded to 7502.5, reset stats, and ran it for a few hours. The issue has gone. Now Tomato shows reasonable traffic for my Lumia as well as for other devices. Thanks everybody for your help!

    PS. I'm still curious why ONLY Lumia had garbage stats while on 7501? :confused:
  27. Orwell

    Orwell Serious Server Member


    Is it possible that your account will be updated? new builds 1.28.7634 (MIPSR1 K24) are missing.


  28. Beast

    Beast Network Guru Member

    Ok updated to .6 and reset nvram, 63d relay does not appear to work with charter. Getting mixed results. One thing I noticed is if I leave ALL U NEED ADBLOCK in WanUP --- IPV6--- Does Not work at all, and without this is the result in part. It does see a IPv6 IP and then this.

    Your IPv6 service appears to be: Teredo
    [​IMG] Your Internet Service Provider (ISP) appears to be CHARTER-NET-HKY-NC - Charter Communications
    [​IMG] Good news! Your current configuration will continue to work as web sites enable IPv6.
    [​IMG] You appear to be able to browse the IPv4 Internet only. You will not be able to reach IPv6-only sites.
    [​IMG] Your IPv6 connection appears to be using Teredo, a type of IPv4/IPv6 gateway; currently it connects only to direct IP's. Your browser will not be able to go to IPv6 sites by name. This means the current configuration is not useful for browsing IPv6 web sites.
    [​IMG] Your DNS server (possibly run by your ISP) appears to have no access to the IPv6 Internet, or is not configured to use it. This may in the future restrict your ability to reach IPv6-only sites. [more info]
  29. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Yeah a real mixed bag! :confused: I'll PM you with some things to try/send me - it would be really good to get 6RD working as a menu option rather than custom scripts etc. I was hoping it would all just work. Oh well :(
  30. adlerfra

    adlerfra LI Guru Member

    Running 7502.6 for 36 hours. 18 devices connected. Stable and web browsing is fast. Wireless signal is strong too on channel 11, N-only, Country/Region=US, and default transmit power of 17.
  31. Gitsum

    Gitsum LI Guru Member

    Change log for 7502.6?
  32. HunterZ

    HunterZ Network Guru Member

    By coincidence, I was looking to download the latest MIPSR2 RT K26 USB VPN build while toastman was in the middle of uploading 7502.6. I waited until it went up, then grabbed & flashed it with an NVRAM erase.

    I then meticulously migrated my settings from 7500, only to end up having to do an NVRAM reset later than night after temporarily bricking my router by doing something stupid. I ended up just loading my backup file from 7500 and not worrying about NVRAM compatibility issues, because at that point it was way past my bedtime on a work night.

    Anyways, it appears to be working fine. I even got DDNS (via No-IP) and OpenVPN server set up so that I can tunnel in with my Android phone (via Arne Schwabe's excellent "OpenVPN for Android" client, as the official OpenVPN Connect client wouldn't work for me for some reason).
  33. adlerfra

    adlerfra LI Guru Member

    Extracted from Toastman's change log:

    May 22 2013 - 1.28.7502.6 and variants

    - Allow 0 default value for ipv6 tunnel MTU
    - cstats fixes - a couple of places where uint64 vars were being printf'd etc...
    - Expose pppoe lcp echo parameters in gui
    Force prefix length of /64 in dnsmasq.conf

    "Will allow dnsmasq to start & perform RA on 1st all zeroes subnet
    of </64 prefixes. Which may in turn reduce the headaches of those
    blindly configuring /56 or /48 tunnels - at least some RA is done.
    If it's wrong, then use dnsmasq.custom. IPv6 is too big for us to
    cope with every option :)" - KDB

    Thanks to everyone for the feedback!

  34. Toastman

    Toastman Super Moderator Staff Member Member

    I am not at home, and 7502.6 was set to upload in my absence. Looks like it finished all but a few odd failed files, which I will fix now.

    Please download the latest uploaded version of 7502.6. I see that previously uploaded versions were showing as ready to download, but I didn't set permissions on the folders to do that yet.

    Thanks to Kevin for his work on the ipV6 and to RMerlin for cstats and other tips.
    bortle likes this.
  35. Noodle

    Noodle LI Guru Member

    Just download and installed 7502.6 on my E3000. I'm using ATT U-verse. So I select "6rd Relay" and "6rd Routed Prefix" 2602:300::, mask length: 28. But it still using 32 as mask length to calculate IPv6. I also tried different number, looks like "6rd Routed Mask Length" is not used but always 32.
  36. Toastman

    Toastman Super Moderator Staff Member Member


    I checked 7634 is still on the server and downloaded half a dozen files at random, and had no issues with the site.

    I will not keep the mediafire site current, it is too slow and bothersome to upload files to it.

    I may add a few changes to 7634 later, but there will not be anything startling.
  37. gs44

    gs44 LI Guru Member


    502.6 up and running in my E3000 and all is good so far, HE tunnel passes all IPV6 tests :)

    Thanks Toastman, Kevin and all
  38. Waester

    Waester Reformed Router Member

    FTP users permission dont register correctly. If I give for example "Waester" read/write (or any other permission) it wont get registered/saved to "/etc/vsftpd.users/Waester"
  39. bagu

    bagu Network Guru Member


    I just receive an RT-N66U and i wonder if it's possible to set up a guest wireless network only on the 2.4 band.
    This guest must acces to internet, but not on the lan.
    And, i wonder if i can set up a vlan with the same acces right.
    If it's possible, can you help me to do this ?

    P.S. : i use the Tomato Firmware v1.28.0502 MIPSR2Toastman-RT-N K26 USB VLAN-Ext
  40. HunterZ

    HunterZ Network Guru Member

    I think Toastman's experimental VLAN version may be able to do some or all of these things, but I've never tried it myself.
  41. bagu

    bagu Network Guru Member

  42. kthaddock

    kthaddock Network Guru Member


    If you test on Br0 and switch to Br3 then you have to relese dhcp on Br0 first. Then test on Br3.
  43. bagu

    bagu Network Guru Member

    Already done.
    Without success.
  44. khaosengine

    khaosengine Reformed Router Member

    Hay a friend of mind has a Cisco WRT 610n. Version 2. which version of toastman should I install for him? This router is in a business not at home.

    is this what he needs? tomato-K26-NVRAM60K-1.28.7501.3MIPSR2Toastman-RT-VLAN-Std

    Many thanks!
    (PS. I have a n16 that I use toastman on from the moment I got it home! never actually booted it with stock)
  45. Victek

    Victek Network Guru Member

    Use a 32KB nvram firmware version like as you use in RT-N16... doing 60KB nvram will brick router friend if nvram space is overpassed.
  46. khaosengine

    khaosengine Reformed Router Member

    thank you Victek. Shall I just use tomato-K26USB-1.28.7501.3MIPSR2Toastman-RT-VLAN-Ext or tomato-K26USB-1.28.RT-MIPSR2-109-AIO on the cisco wrt610n?

    How would the nvram space be overpassed?
  47. leshan

    leshan Network Guru Member

    Cisco WRT 610n. Version 2 can be converted to E3000 which is 60KB nvram. There's a tutorial on DD-WRT forum.
  48. khaosengine

    khaosengine Reformed Router Member

    is that worth doing for a business tho? i want this guy to have super stability, set it and forget! - he wont be able to re-flash all the time you see
  49. Victek

    Victek Network Guru Member

    Writing rules (iptables, scripts, cron) that can exhaust the space. Be sure about WRT610N version before trying to do so...
  50. Malitiacurt

    Malitiacurt Networkin' Nut Member


    You can't skip bridges. You need to use br1 or br2 before using br3.

    Either set your br3 to br1, or add a br1 and br2.

    You can skip vlan #'s, but not bridge #'s in tomato.
  51. bagu

    bagu Network Guru Member

    Oh my g.... That's it...

    Thanks a lot.

    An other question, i have set an smb share on my rt-n66u.
    I can see it on br0, but not on br1.
    Why, and how can i make it working on both vlan ?
  52. Toink

    Toink Network Guru Member

    I have one. And it's been working as stable as a brand new one for the past 3 years already. Upgrading it to E3000 was worth it - yes it's as easy as set and forget. (and updating using the firmware for E3000 from then on)...
  53. khaosengine

    khaosengine Reformed Router Member

    Thank you @Tonik @Victek. I appreciate it.
  54. Toastman

    Toastman Super Moderator Staff Member Member

    May 26 2013 - 1.28.7502.7 and variants

    - fix typo in manual 6RD entry that broke manual ipv6 address entry completely
    - Write ipv6 prefix when doing dhcp-pd

    May resolve dhcp-pd WAN type prefix advertising. Ensure 'enable IPv6 RA'
    is enabled under advance dns/dhcp

    Thanks Kevin!

    Thanks to everyone for the feedback...

    Elfew likes this.
  55. Noodle

    Noodle LI Guru Member

    Does this fix only accept 32 mask length issue?



  56. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Do you mean the 6rd prefix length or the ip4 mask length? I'm guessing you mean the 6rd prefix length (which is defaulted to 32) I think I've just spotted a really stupid typo in one of about 4 files that references the 6rd prefix length variable. (Toastman I'll get a patch to you as soon as I can)
  57. Noodle

    Noodle LI Guru Member

    Yes, you are right. I'm talking about 6rd prefix. In case of ATT U-verse, it's 28. Another issue, probably dnsmaq bug, it accept /64 only, and require br0 has /64 IPv6 address, but in U-verse case, it's /60. I'm currently set it to /64 manually, and that works.

  58. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Here you go Mr Toast :)

    @Noodle - SLAAC is only supposed to work with a /64 so arguably it's a bug in radvd that it let you configure a /56 or whatever whilst still setting the 'auto address' flag. :) </64 DHCP on dnsmasq doesn't work and I'm not sure it ever will. I am impressed that ATT U-verse allow a /60 - very sensible subnetting on nibble boundaries (helps reverse DNS no end!) If you've some experience with 6RD and the above patch when it makes it out doesn't fix the problem, I'd appreciate your help seeing as though you know how 6RD is supposed to work and I quite simply don't....well not with a non 32 6rd prefix.

    A recent commit forced dnsmasq to assume a /64 with the 'enable IPv6 RA' enabled, as a) that made it work out of the box and b) if you do need a /60 or whatever for real then you can configure dnsmasq.custom to suit.
  59. Toastman

    Toastman Super Moderator Staff Member Member

    Thanks Kevin!
  60. bagu

    bagu Network Guru Member


    Is there a way to save nvram value, but, only values wicht differ from default value ?
  61. Victek

    Victek Network Guru Member

    Well, this is the target.. we use nvram for variable values, all the rest should be in *.conf files... since you ask it.... did you found 'zombies' values in nvram?

  62. bagu

    bagu Network Guru Member

    I think i don't explain right.

    When i just flash a router, there are default value in nvram.
    And when i change settings, there are difference between original values and the current values.

    I try to export nvram variables wich are not the same as the original values (f.e to avoid saving cpu clock speed or router model name)

    If i can do that, i will be able to have the same config on different router with the same tomatousb firmware.
    I'l try to do this manually with the "| grep option" but i don't know every value name. So it's really hard to export the whole configuration.
  63. Victek

    Victek Network Guru Member

    well .. use diff tool, erase nvram, dump nvram.txt, configure && dump again nvram.txt once configured, make a diff = non default values = your configuration.
  64. bagu

    bagu Network Guru Member

    Argh, i've just finish to configure the router ^^
  65. JugsteR

    JugsteR Addicted to LI Member

    Argh? That is good news, then you've completed half the mission!
    Save this configuration and after you saved the default one you can use it from the saved file. Minimum amount of work, nearly.

    Good luck!

    Signature? Signature!
  66. HunterZ

    HunterZ Network Guru Member

    1. Save your current NVRAM to a file using the web interface's Backup page
    2. Erase your NVRAM (sets it back to defaults).
    3. Do a command-line NVRAM dump to get the "default" settings list.
    4. Restore your NVRAM backup from step 1.
    5. Do another command-line NVRAM dump to get your customized settings list.
    6. Do a diff between the two command-line dumps to see what changed.
    7. Make a list of variable names/categories from the diff that look important to you.
    8. Feed the list into something like this:
    9. Post your results here so that we can all benefit from your idea!
  67. bagu

    bagu Network Guru Member

    I don't know how to get only the line wich have change...
    The diff utility show me the old and the new line...

    Is there a way to get a txt file with only the new lines ?
  68. Victek

    Victek Network Guru Member

    Depending of the program you use .... in linux you can use meld or kompare and generate a patch.
  69. HunterZ

    HunterZ Network Guru Member

  70. bagu

    bagu Network Guru Member

    I'm on windows with diff.exe and

    diff --unchanged-line-format= --old-line-format= --new-line-format=%L filea fileb > diff.txt
    I get the right file (except some " missing).
    I will try to extract useful info from it.

    But i wonder if nvram set pci/2/1/ are really needed ?
  71. HunterZ

    HunterZ Network Guru Member

    I would expect not. If you can't find a corresponding field in the router's web interface, then it's probably some internal derived or dynamic data that doesn't need to be (or shouldn't be) migrated.
  72. bagu

    bagu Network Guru Member

    Ok, it's done.

    A small question. To make my vlan1 able to communicate with vlan3.
    I go in lan access under advanced.
    I have set :
    LAN (br0) - - LAN (br1) -

    And i can't ping from to

    I've try to set :
    LAN (br1) - - LAN (br0) -

    In addition, with no succes...What i have miss ?
  73. Bird333

    Bird333 Network Guru Member

    @Toastman - Why do the following commands work on a WRT54GSv3 but not on a WRTSL54GS running 'tomato-WRT54GS-1.28.7634Toastman-IPT-ND-VLAN-VPN' and 'tomato-WRTSL54GSUSB-1.28.7634Toastman-IPT-ND-VLAN-VPNNOCAT' respectively?
    1) Make sure you have a VLAN build of Tomato installed. I have a build of Toastman installed and I got it working. Unfortunately, I could not get it working properly on Shibby without having to always release and renew the DHCP address, so perhaps it's a bug. In addition, be sure to reset the router to default settings. This is to lesses change of some unknown configuration preventing the setup from working. To do so go to Administration --> Configuration. Under "Restore Default Configuration" NVRAM reset. Wait for about 5 minutes before proceeding.
    2) (Optional) Change the IP address of the router to something like and the DHCP range to something like Conflicts can happen if the hotel network and the repeater network are on the same subnet. is isolated enough so the chances of a conflict occuring is minimal.
    3) Change the Wireless Mode to "Wireless Client". Enter the SSID and configure the security for the network you want to repeat. This has to be done manually.
    4) Click save. Wait 2 minutes. At this point, your ethernet ports should work though this subnet and you should be getting internet. If you are getting internet, you are ready go continue.
    5) Go to Advanced --> Virtual Wireless. Create the "wl0.1" interface. Enter your desired SSID. For mode, select "Access Point". For bridge, select "LAN (bro0)". Click add.
    6) Enter your desired security settings. Then click "Overview" at the bottom right. Remember, your WPA/WPA2 password must be at least 8 characters.
    7) Click "Save" at the bottom right. Wait 2 minutes.
    8) Unplug and plug back your router. Wait 3 minutes.
  74. Malitiacurt

    Malitiacurt Networkin' Nut Member

    What is the point of having a guest wireless on a different VLAN if you want everyone on the main VLAN to be able to access the guests (and in turn vice versa.)

    You might as well just have the guest wireless network bridged it to vlan1 (aka same subnet/range of IP's as your main) or not even have the guest wireless network in the first place.
  75. Malitiacurt

    Malitiacurt Networkin' Nut Member

    Cause they have different wireless chips, aka corerev. Older versions don't support virtual wireless interfaces.

    The revision number means the following:

    • 0-4 The router does not support multiple SSIDs (with unique identifiers or otherwise)
    • 5-8 The router supports multiple SSIDs (but not with unique identifiers)
    • 9+ The router supports multiple SSIDs (with unique identifiers)

    See these posts for more info:

    Just do a google search regarding corerev wireless tomato or dd-wrt and there's a slew of info about this.
  76. bagu

    bagu Network Guru Member

    I just want one pc to be able to make data transfert between vlan1 and 3.
    But for test purpose, for the moment, i try to set the whole vlan1 to be able to make data transfert to vlan 3 (vlan 1 and 3 are not wireless network)
  77. Bird333

    Bird333 Network Guru Member

    Ok but both of these routers could use vif under DD-WRT. I don't remember the core revisions for them.

    EDIT: Just checked. Both routers are corerev 9.
  78. DJarvis1

    DJarvis1 Addicted to LI Member

    Hi, what is the latest version of toastmans q.o.s tomato for the E2000
    ??, I always get mixed up when looking through all the different versions.

    Sent from my HTC One using tapatalk
  79. Lorenceo

    Lorenceo Networkin' Nut Member

    Just tried 1.28.7502.7. It seems to completely break IPv6 connectivity via DHCPv6 with PD, both on clients and the router.
    The router can obtain a v6 address, but it cannot communicate with any v6 hosts.
    The router advertisements advertise the correct prefix, but still default to 1500 MTU despite the PPP MTU under basic > network being set to 1492.

    Good to see some progress on it after all this time, but for now I've gone back to 1.28.7501.3 and manually running radvd with a custom .conf file stored in the nvram.
  80. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Being 'unable to communicate with any v6 hosts' from the router, smells like a routing table problem to me. There's been a fair amount going on between 7501.3 & 7502.7 though in theory none of the DHCP-PD WAN side has been touched (well not by me at least :)
  81. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member


    I have a theory which I'm not going to expound at this time, but please, can you tell me if you erased NVRAM when you tried 7502.7? Also can you tell me the value you have in NVRAM for 'ipv6_accept_ra' please as you currently have it.

    Your answer may blow my theory out of the water....... :) On the other hand I may have a very easy fix!
  82. bagu

    bagu Network Guru Member

    I use 1.28.0502.7 vlan ext with ipv6 tunnel.
    I can ping v6 hosts and google in v6 also.

    Maybe it's only DHCPv6 witch don't work.
  83. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    I really need lorenceo to answer for *his* specific environment... I have a theory, which you nor I can test, only Lorenceo.
  84. DJarvis1

    DJarvis1 Addicted to LI Member


    Sent from my HTC One using tapatalk
  85. Lorenceo

    Lorenceo Networkin' Nut Member

    Yes, I did erase the NVRAM going between the two versions.
    The router advertisements that were being put out looked correct, apart from the default MTU of 1500.
    For whatever reason the PPP took a lot longer to authenticate on 7502.7 compared with 7501.3.

    Current IPv6 NVRAM parameters (with addresses removed):
    nvram set ipv6_dns=""
    nvram set ipv6_tun_v4end=""
    nvram set ipv6_accept_ra="0"
    nvram set ipv6_get_dns=""
    nvram set ipv6_prefix="2406:e000:XXXX::"
    nvram set ipv6_service="native-pd"
    nvram set ipv6_tun_addrlen="64"
    nvram set ipv6_ifname="six0"
    nvram set ipv6_prefix_length="48"
    nvram set ipv6_rtr_addr="2406:e000:XXX:0:XXX:XXX:XXX:XXX"
    nvram set ipv6_tun_mtu="0"
    nvram set ipv6_tun_addr=""
    nvram set ipv6_tun_ttl="255"
    nvram set ipv6_radvd="0"
    nvram set ipv6_relay="1" 
    radvd.conf set in NVRAM:
    nvram set FILE:/etc/radvd.conf="\\A4\\81~~p\\17\\16\\12interface br0\\0A{\\0A IgnoreIfMissing on;\\0A AdvSendAdvert on;\\0A AdvLinkMTU 1488;\\0A MaxRtrAdvInterval 60;\\0A AdvHomeAgentFlag off;\\0A AdvManagedFlag off;\\0A prefix ::/48 \\0A {\\0A  AdvOnLink on;\\0A  AdvAutonomous on;\\0A };\\0A RDNSS 2406:e000::100 {};\\0A };\\0A" 
    Script running every 2 minutes to check and restart radvd after it crashes:
    if top -b -n 1 | grep -v grep | grep radvd > /dev/null
    echo  radvd is running.
    echo  radvd is not running, starting.
    #start the process
  86. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Hi Lorenceo,

    Thanks for getting back to me. Unfortunately your answers appear to have blown my theory out of the water which is a shame. Let me expound the theory - In 502 there was a change which stopped a default IPv6 route being configured if using DHCPv6-PD The assumption is that the WAN will listen for IPv6 RA and add routes as required. As part of the fix, 'Accept RA from WAN' was defaulted on which is why I asked if you cleared NVRAM. However there's nothing to stop you unchecking 'Accept RA from WAN', thus you'd no longer have any routes to the IPv6 world and wouldn't be able to ping. The above is the only specific change to the DHCP-PD option that I can find and it does correspond nicely with your 'I've an address but cant ping anything IPv6 WAN side from the router' comment.

    I've subsequently asked a local IPv6 ISP if they do DHCP-PD (they do) and whether it is manadatory to provide RA (it isn't, so they in fact don't!) thus the current 'fix' will break different things for different people.

    I hate IPv6! :)
  87. biatche

    biatche Network Guru Member

    Toastman, I've this parameter in dnsmasq:

    This worked fine in 7501.3

    Now, having switched to 7502.7, it gives me:

    Jan  1 08:04:10 939-n16 daemon.crit dnsmasq[1441]: extraneous parameter at line 19 of /etc/dnsmasq.conf
    Jan  1 08:04:10 939-n16 daemon.crit dnsmasq[1441]: FAILED to start up
    Jan  1 08:04:10 939-n16 user.debug init[1]: dnsmasq terminated unexpectedly, restarting.
    Any clue? I'd like tftp only on br0 LAN, not br1 LAN (guest network)

    Removing that line allows dnsmasq to start.

    Another problem is:
    May 30 18:06:56 939-n16 user.warn cstats[1566]: Problem loading /cifs1/tomato_cstats_bcaec5c476ab.gz. Still trying...
    May 30 18:09:21 939-n16 user.warn cstats[1566]: Problem loading /cifs1/tomato_cstats_bcaec5c476ab.gz. Still trying...
    May 30 18:09:26 939-n16 user.warn cstats[1566]: Problem loading /cifs1/tomato_cstats_bcaec5c476ab.gz. Still trying...
    May 30 18:09:40 939-n16 user.warn cstats[1566]: Problem loading /cifs1/tomato_cstats_bcaec5c476ab.gz. Still trying...
    May 30 18:09:45 939-n16 user.warn cstats[1566]: Problem loading /cifs1/tomato_cstats_bcaec5c476ab.gz. Still trying...
    Since the last version, my bandwidth monitoring/logging hasnt been working. It worked a year ago though, whatever version that was...
  88. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    dnsmasq changelog

    " Remove the interface:<interface> argument in --dhcp-range, and
    the interface argument to --enable-tftp. These were a
    still-born attempt to allow automatic isolated
    configuration by libvirt, but have never (to my knowledge)
    been used, had very strange semantics, and have been
    superceded by other mechanisms. "

    --no-dhcp-interface=<interface name>
    Do not provide DHCP or TFTP on the specified interface, but do provide DNS service.
    I've had problems with cstats trying to use data from pre-patched files. Appears to be ok if a new file is created.
  89. DJarvis1

    DJarvis1 Addicted to LI Member

  90. biatche

    biatche Network Guru Member

    Ah, so if I want tftp+dhcp on br0 while dhcp only on br1 (different subnet) ... how should it be written?

    the cstats is new.
  91. Lorenceo

    Lorenceo Networkin' Nut Member

    IPv6 is the future. :p
    FWIW version of the Asus firmware seemed to work fine with IPv6. However I've only used that firmware for about an hour in the total time I've owned the router, so I can't comment on its reliability. v6 connectivity and MTU values in the router advertisements did work properly though.
    I notice that there's a new version of the stock firmware available, and one of the patch notes is fixed IPv6 over PPPoE interoperability issues. I wonder what they've changed?

    Router advertisements are supposed to only be seen within your own network, not on the wider IPv6 internet, I believe.
    Some extra information I may have forgotten to mention previously: In order to authenticate I need to tag WAN packets as VLAN 10. I doubt it'd make much difference to the radvd issues, though.
  92. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Go bug the maintainer of dnsmasq!
  93. Kevin Darbyshire-Bryant

    Kevin Darbyshire-Bryant Networkin' Nut Member

    Unfortunately I haven't got time/don't want to go digging through Asus' firmware to find out what was changed. I can tell you that there's no IPv6 firewall between WAN & LAN interfaces. And you're making a big assumption that this is a PPPoE thing, when I can see for a fact that 502 introduced a fundamental change to the ipv6 routing table for DHCP-PD. RAs may be provided by the ISP, some do, some don't it looks like - it's a learning curve for everyone!

    If you're using a recent toastman release then radvd isn't being used/may not even be there. VLANs brings a whole other dimension to it that may or may not have to be ruled out.

    So the problem has just exploded in complexity and it was complicated enough before. I'm trying to understand what the code does with regard to IPv6 under all circumstance but to say it's complicated & undocumented would be an understatement. Tomato could really benefit from a very good IPv6 aware developer. I am not that person. I'd like to feel that I'm not the only person making any sort of coding contribution toward Tomato & IPv6.

    Not aimed at anyone but there are lots of 'fans' saying 'oh this would be a good idea, why don't you do this, why doesn't this work' etc etc but very few actually *DOING*. Like Koitsu said a few weeks ago, I feel like I've been sucked into this forum & Tomato and it's pretty much taken over my life. I guess that's my fault, I shouldn't get so involved - so I'm going to back off for a while.

    Lorenceo, try enabling 'allow WAN RA' when you next try a recent build. If that doesn't cure it, then quite frankly I've no idea where to go from there. As regard MTU, dnsmasq picks it up from the local interface, which is likely to be br0 & hence 1500 bytes. And this is where my knowledge breaks 'cos I really don't know how tomato handles the case where the WAN & LAN effectively bridge IPv6 (ie share the prefix) across WAN & LAN interfaces.

    Like I said, the Tomato IPv6 code needs pulling apart to work out exactly what it's currently doing, evaluated & then re-assembled.
  94. DJarvis1

    DJarvis1 Addicted to LI Member is what I linked a couple of posts ago ok ?....

    Sent from my HTC One using tapatalk
  95. RMerlin

    RMerlin Network Guru Member

    One of the changes in 354 is that they disabled CTF when running IPv6, so it's possible that's what this fix is. They also upgraded rp-pppoe to a more recent version. . I don't remember if there were further changes specific to IPv6.
  96. bagu

    bagu Network Guru Member

    There is two errors in log strange :

    Is it normal ? (IPv6 removed in the last line)
  97. Lorenceo

    Lorenceo Networkin' Nut Member

    I'm not suggesting that this problem is PPPoE related. I just went to check if there was a newer version of the stock firmware and noticed that in the notes.
    The only place I'm pointing my finger is radvd running a default config when enabled in the GUI on build 7501.3 and below.

    Radvd is most definitely running on build 7501.3. I'm running it manually with the config above in order to get v6 connectivity working.
    If I do not run it manually with the custom config, radvd announces the correct prefix and router information, but does not announce the correct prefix length or MTU. This breaks v6 connectivity for a number of websites (most notably Facebook).

    I understand that it's a huge undertaking, and greatly appreciate the work that everyone does in contributing to it. I'm not trying to force things to be fixed, just trying to help make Tomato better for everyone. :)

    Will do, and will report back.

    Sounds good. The more people that are helping, the better, right? :p

    Another bug I noticed while running VLAN builds last year was that if there is a scheduled task running, the router seems to crash and reboot after it runs out of PIDs. Whether that is fixed or not, I don't know. Am currently running 7501.3 VLAN, so I'll likely find out sooner or later if this is still happening.
  98. DJarvis1

    DJarvis1 Addicted to LI Member

    Hi, so is my query in post #1991 correct ?...

    Sent from my HTC One using tapatalk
  99. HunterZ

    HunterZ Network Guru Member

    I'm seeing the following error when trying to save IPv6 6rd settings (edit: I'm a noob - see the bottom of this post, or better yet just don't read it at all):
    This is with tomato-K26USB-1.28.7502.7MIPSR2Toastman-RT-VPN, and I did an NVRAM erase and then applied individual nvram settings from a previous version that specifically did not include anything IPv6-related.

    Here's what's currently in my nvram:
    "ipv6_dns=2001:558:feed::1 2001:558:feed::2"
    I was trying to play with the settings listed here:

    Edit: I'm a noob. Putting "/32" at the end of the 6rd Routed Prefix setting is a no-no.
  100. chaohua27

    chaohua27 Serious Server Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice