Tomato v1.06 Firmware Released.

Discussion in 'Tomato Firmware' started by GeeTek, Mar 18, 2007.

  1. GeeTek

    GeeTek Guest

    * Fixed restore bandwidth doesn't work with IE.
    * Fixed executing a script via AOSS/SES button leaves zombies lying around.
    * Fixed scp to router not working.
    * Fixed reset/ses button on WRTSL54GS not working.
    * QOS htb burst does not use a fixed value anymore which may improve performance, especially for those with a high upload speed. If for some reason you want to use the old method: "nvram set qos_burst0=4; nvram set qos_burst1=2"
    * Added time zone for South Australia.
    * Added support for Asus WL-500G Premium without USB. Like the WRTSL54GS, this is a simple detection support without any additional USB goodies.
  2. Edhel

    Edhel Network Guru Member

    Managed to grab it, upgraded and seems to work fine so far. :)
  3. der_Kief

    der_Kief Super Moderator Staff Member Member


    just upgraded without any problems :biggrin: . Nice to see that Jon expand the range of routers.
    Nice work THX Jon. :thumbups:

  4. pharma

    pharma Network Guru Member

    Smooth upgrade and running with no problems! :biggrin:

    Thanks Jon!
  5. roadkill

    roadkill Super Moderator Staff Member Member

    Same Here :biggrin:
    it seems that 1.06 is a little snappier...
  6. denze

    denze Guest

    After reading the wiki and various posts.I think I'll try this on my newly aquired GL.


    wtf? this is my first post
  7. NateHoy

    NateHoy Network Guru Member

    Downloaded and installed. Upgrade went smooth as silk, as usual. I haven't tested it heavily yet, but my connection to my corporate VPN worked fine, and Vonage seems to be running just fine with BitTorrent banging away in the background as usual. Looks like Jon has done his usual excellent job.
  8. damko

    damko Network Guru Member

    Installed over 1.05. Up & running as expected :) Great work Jon.
  9. nsumner

    nsumner LI Guru Member


    I saw no reason to upgrade from 1.04 to 1.05 but like normal I did that anyways for both of my routers (connected via WDS).

    I saw little reason to go from 1.05 to 1.06 but hey why not.

    Like normal both upgrades went off without a hitch. Tomato is really starting to get boring. I haven't even had to do a reset in ages. Let alone short pins x and y to try and recover a bricked router... Ah well such is life:smile:
  10. GhaladReam

    GhaladReam Network Guru Member

    1.06 working great over here.

    Thanks Jon!

    Hehe... I don't think I've ever heard someone complain that a firmware/router is working TOO well. I know it's a joke, but that's just hilarious.
  11. Dwibbly

    Dwibbly Network Guru Member

    Excellant as always

    Just upgraded from 1.05 to 1.06 for myself and my girlfriends router, no problems here.

    Can you get a WRTSL54GS in england? Can't see on-line anywhere, is it any better than what I have?

    Can you add drives to the WRT54GS and Tomato use them for sharing to others?

    Keep up the good work with the firmware.
  12. paped

    paped LI Guru Member

    Upgraded tested and working...... Thanks....
  13. digitalgeek

    digitalgeek Network Guru Member

    Upgraded and stable for: 0 days, 22:04:05... Keep up the work Jon!
  14. Max Monroe

    Max Monroe LI Guru Member

    Slightly belated here, just thew the 1.06 on top of a... 1.03 :biggrin: Smooth sailing, as usual... Great job!
  15. devil-strike

    devil-strike Network Guru Member

    Works perfect now on asus wl500gp also wlan works now.

    Only whene do you planning support for usb?
  16. Buvana

    Buvana Guest

    Works fine, but tofu led-script don't work. (with 1.04 ok) However dd-wrt led script work now! :-o

  17. clawhammer

    clawhammer LI Guru Member

    RealTime bandwidth doesn't work with my WRT54GL firmware 1.06 (maybe because "Administration\Bandwidth Monitoring" is disabled)
    It was ok with 1.04 so I reverted back.

    Don't know if it's normal or not ?
  18. sillydoh

    sillydoh LI Guru Member

    would seem to make sense that if you disable it, it shouldn't be monitoring it. Perhaps he forgot about it and then decided to fix it for this release.
  19. Makaijin

    Makaijin LI Guru Member

    Finally more firmware to support the Asus WL-500g Premium. I can put my GL back in storage as backup and undust my Asus back to be my main router again. DD-WRT is getting too bloated for my liking and openwrt is a pain to setup.
  20. larsrya8

    larsrya8 LI Guru Member

    I don't see why it wouldn't monitor real time bandwidth, even with logging disabled. The only thing I notice is that there's no history prior to me opening the real time chart... but that's the idea. Sounds like something that is broken in 1.06.
  21. Rafatk

    Rafatk Network Guru Member

    Up and running fine over 24 hours now! Great firmware!
    Thnx Jon!
  22. sillydoh

    sillydoh LI Guru Member

    Well, the option is "Bandwidth Monitoring". So literally, if you don't have it enabled, it shouldn't be monitoring it. I guess it just goes to semantics. Anyway, why is it a big deal? Just enable the Bandwidth Monitoring feature and you'll get back your realtime bandwidth monitoring...
  23. pharma

    pharma Network Guru Member

    I don't think it is planned. Supporting the WRTSL54GS and the Asus was done with the understanding that usb support would not be coming - it is not installable. See version 5 release notes:
  24. NateHoy

    NateHoy Network Guru Member

    Uptime 3 days, 11:32:20 - and counting. Still going strong. Of course, I never had any problems with any previous releases. As long as QoS works well, I'm happy, and that's never been a problem in Tomato.
  25. Reiper

    Reiper LI Guru Member

    Upgraded fine, as usual... Just trying to figure out why ports 0 and 1 show as closed instead of stealth on a "shields up" test. Reverted to version 1.04 and still had the same problem so I'm investigating this with the ISP. Unfortunately my uptime had to start over last night due to me trying to figure out this other issue...
  26. NateHoy

    NateHoy Network Guru Member

    I ran the GRC shields up test, and my only failure was on the port I run my SSH server on. That one showed up as red, of course, since I have a logon server sitting there. Other than that, it was pretty green across the board.
  27. Reiper

    Reiper LI Guru Member

    I went back and forth with Jon trying to figure this out and he said my configuration looked good. In other words we couldn't find anything wrong with Tomato. At this point I'm assuming it is either a setting in my Motorola Canopy modem, or a front end router at my ISP. However, I'm trying to understand how this would have an impact on the Shields Up test as Shields Up says it is scanning the IP address that was assigned to the router by my ISP. I've asked the question to my ISP and we'll see what they say?
  28. NateHoy

    NateHoy Network Guru Member

    Well, if your modem were responding before even giving the packet to the router, I can see where that could happen. Similarly, if your ISP was somehow responding to packets, GRC may see a response.

    If your ISP is "blocking" the port, they may be replying with a "connection closed" error instead of properly stealthing it.

    You could try reverting to another firmware, or running a good software firewall and temporarily hooking a single machine up to the Canopy modem, to see if you can reproduce the issue without Tomato or even your router in the picture.
  29. Reiper

    Reiper LI Guru Member

    That makes sense! Thanks NateHoy!!
  30. clawhammer

    clawhammer LI Guru Member

    I agree with you ; Now only tomato chief can answer us.:)
  31. NateHoy

    NateHoy Network Guru Member

    As an experiment, I turned off Bandwidth Monitoring in Administration/Bandwidth Monitoring. Then I went to the Bandwidth charts.

    The "Real-Time" chart was simply blank. The other charts all had a warning message that told me that Bandwidth Monitoring was turned off and had a place to click to turn it back on.

    So, I strongly suspect that monitoring bandwidth, even Real Time, requires that the bandwidth monitoring service be turned on. Which kinda makes sense, since there is probably nothing at all for the charts to watch if the service is not writing bandwidth statistics somewhere.

    I never turned off the service in previous Tomato versions, so I can't say if this is a change from earlier versions or not.

    This may have been an optimization, and if so it's a seemingly sensible one - in order for the charts to work, something has to be in the router keeping track of stuff as it happens so the web interface can read it. It would make sense to not have that service running at all if you say to turn it off.

    The real time bandwidth charts do become active as soon as you go into Administration and turn on bandwidth monitoring, then you can turn the service off (if you want) afterward. Or you can leave them running - it doesn't seem to slow things down or take any huge amounts of memory from what I can see...

    I suppose Jon could detect if the service is running and launch it if not when you go into the real time bandwidth charts, then detect whether you wanted it on when you go to any other page, but that's some fairly complex coding to save a user from going into Admin and clicking on a checkbox IMHO. Probably simply adding the same "Bandwidth monitoring not enabled" error would be a better plan.
  32. unicorn02

    unicorn02 LI Guru Member

    Also upgraded from 1.04 to 1.06. Flawless! :coolest:
  33. Reiper

    Reiper LI Guru Member

    Well I connected my laptop directly to the modem and ran a shields up test on the Windows XP firewall... Sure enough, ports 0 and 1 were closed and the rest stealth. In other words my ISP and/or modem is responding to those particular packets prior to the router receiving the packets. Tomato is all good!!
  34. digitalgeek

    digitalgeek Network Guru Member

    I have been running 1.06 now for approx. 6 days (router up time) and I have been having wireless problems. The WDS connection will drop, or the overall connection to both of my laptops (Mac G4 and a linksys PCMCIA card) is less than what it was with 1.04 so I am seriously consider going back. Of course I will clear Nvram after perform the update.

    I have noticed that all my Advanced wireless settings reverted to their derfaults after the update to 1.06.
  35. Myriddin

    Myriddin LI Guru Member

    Just upograded

    All seems fine
    TNX Jon
  36. sumdumphat

    sumdumphat LI Guru Member

    1.06 has been running on my WR850GP for 3 days now.

    thanks Jon.
  37. der_Kief

    der_Kief Super Moderator Staff Member Member

    did you run this on your own risk or did you ask Jon if this unit (Motorola?) is supported inofficial ?

  38. sumdumphat

    sumdumphat LI Guru Member

    asked and got help from Jon.
  39. clawhammer

    clawhammer LI Guru Member

    Jon, can you answer us about "Bandwidth Monitoring" / "Real Time" (cf previous posts) ??

  40. GeeTek

    GeeTek Guest

    Jon is busy right now. This is what he says on his website;

    "here's 1.06... I wanted to clear this off quickly before I start working on something else (unrelated)."
  41. sillydoh

    sillydoh LI Guru Member

    It's not a big issue. Heck, it shouldn't be an issue at all. You realize that the real time graphs will show up when you enable bandwidth monitoring, right? (and as mentioned previously, it just makes more sense that it will show up only when bandwidth monitoring is enabled in the first place)
  42. pharma

    pharma Network Guru Member

    I upgraded when 1.06 came out without problems doing my normal upgrade routine - flash router & reboot without manually re-keying my settings. Everything was going fine until 3 days ago when a wireless laptop started to have problems accessing the internet. Couldn't find anything wrong so I re-installed the OS on the laptop thinking it got "botched". Had the same problem afterwards so started to focus on the router - nothing seemed out of place. I cleared NVRAM, rebooted and restored my back-up configuration file but still had the same wireless connection issue.

    Decided to finally use "NVRAM CLEAR" feature and manually re-key all my settings. Problem disappeared and have been running for 3 days without any problems. I created a new back-up of my router settings/configuration.

    I'm kind of glad I did this because now I can see and use the "new" default QOS Classification rules Jon added for the Outbound direction. :)

  43. Reiper

    Reiper LI Guru Member

    I've not had any problems with wireless networking, and my "Tomato" has an uptime of around 12 days. However, I always clear the NVRAM and re-key my settings when upgrading. I know they say you don't have to but I like to have a "clean" setup from the get go! Glad to hear it is working for you! :)
  44. RocketTeam

    RocketTeam LI Guru Member

    Thank you for make the WL-500G Premium support.
    My wish list is you add USB support for WL-500g Premium.
  45. m4r50v3c

    m4r50v3c Network Guru Member

    I upgraded from 1.04 to 1.06 four days ago; the performance in my small network is a lot better now.
  46. GeeTek

    GeeTek Guest

    I tried it intially on my WRT54G v2.0, then once I found out it would run on a WR850G v2 and v3, I loaded it on my two WR850G WDS distribution routers. Either way, my clients would lose their static DHCP after a while. So I removed it from my main router which serves up the static DHCP. So far it seems stable on the WDS distribution points though.

    *Update: Seems like the issue was likely not tomato static DHCP instability on the primary router. I am still testing to be certain, but when using WPA, the nas daemon was dying on the WDS remote access points just as had been found in dd-wrt. I wrote a script to run it again if it died but that that didn't really seem to restore stability 100%. The latest fix seems to have been to switch encryption to WPA/WPA2 mixed. I had it at WPA for interoperability with dd-wrt. But since I'm all tomato now there was nothing holding me to that now. It hasn't been long since I switched but seems a lot more stable. Seems that nas is a lot more stable running in this mode.

    It would be interesting to do a direct comparison to Tomato 1.04 to see if recent code changes are causing this problem.
  47. ntest7

    ntest7 Network Guru Member

    On Linksys WRT-54GSv3 with Tomato 1.06 the 'wl radio off' command turns off the wireless LED, but also causes the power light to blink.

    On a Buffalo WHR-G54S 'wl radio off' only affects the Wireless LED as expected.
  48. KillerDog

    KillerDog LI Guru Member

    Can someone please tell me why version wrt54gs rev 5 is NOT supported, and what will sopport it, many many thanks :)
  49. Reiper

    Reiper LI Guru Member

    They switched from a Linux OS to a VxWorks OS which doesn't require as much memory so they reduced the amount of memory these units ship with. The only other firmware (that I'm aware of) that will work with this version is DD-WRT micro. If you want to run other firmwares return the WRT54GS and get a WRT54GL!
  50. KillerDog

    KillerDog LI Guru Member

    Thankyou for your help :) Very much appreciated.
  51. Odin-60

    Odin-60 LI Guru Member

    This is a well-know problem, related with
    the (closed source) WLAN driver.

    Try "wl out" in place of "wl radio off",
    and "wl up" in place of "wl radio on".
    This seems not to affect the power LED.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice