Tomato v1.28.8754 ND USB vpn3.6 SAMBA Issues

Discussion in 'Tomato Firmware' started by Aquafire, Feb 16, 2011.

  1. Aquafire

    Aquafire LI Guru Member


    I am running Tomato Firmware v1.28.8754 ND USB vpn3.6 on Linksys WRTSL54GS. I have attached an NTFS formatted USB harddisk which is configured to be automatically detected and mounted as a SAMBA share. The share name is "MediaShare" Router IP is

    The SAMBA version built in tomato as reported is Samba 2.0.10-security-rollup.

    I have another NAS Device on the same network which is WD Mybook World Edition (MBWE) (Blue Ring 500GB) IP is I have enabled the SSH busybox access to this NAS device. I am trying to mount the shared SAMBA share on the router to a shared folder location on the MBWE .

    I have tried numerous options and various combination of the samba utilities on the MBWE , but somehow the share on the router refuses to be mounted with varying errors. I have loaded and tried with all possible arguments using smbmount, smbfs, mount -t smbfs utilities to mount the router share, however it ends with varying errors like

    Can't get /etc/mtab~ lock filesmbmnt failed: 1
    cannot mount on /shares/internal/PUBLIC/ms: Input/output error
    smbmnt failed: 1
    The only success is that I am able to get is when using smbclient on the MBWE to inquire status of SAMBA running on the linksys router

    [root@MyBookWorld ~]# smbclient -L
    added interface ip= bcast= nmask=
    Domain=[HOME] OS=[Unix] Server=[Samba 2.0.10-security-rollup]
            Sharename      Type      Comment
            ---------      ----      -------
            MediaShare     Disk      MediaShare
            IPC$           IPC       IPC Service (WRTSL54GS)
            Server               Comment
            ---------            -------
            AIRMAX               WRTSL54GS
    Using the smbclient command line, I am able to log in the SAMBA share remotely to browse its contents, which appear fine

    [root@MyBookWorld bin]# smbclient \\\\\\MediaShare
    Enter root's password:
    Anonymous login successful
    Domain=[HOME] OS=[Unix] Server=[Samba 2.0.10-security-rollup]
    smb: \> ls
      .                                   D        0  Thu Feb 10 20:02:41 2011
      ..                                  D        0  Tue Feb 15 15:10:13 2011
      $RECYCLE.BIN                        D        0  Fri Oct 29 18:14:46 2010
      autorun.inf                         A       63  Fri Jun 12 11:28:21 2009
      FreeAgentDesktop.ico                A    22486  Wed Dec 10 18:17:16 2008
      Movies                              D        0  Thu Jan 27 00:30:40 2011
      Music                               D        0  Fri Oct 29 23:44:22 2010
      Pictures                            D        0  Fri Oct 29 18:58:15 2010
      System Volume Information           D        0  Fri Jan 21 00:05:08 2011
                    59616 blocks of size 33553920. 9512 blocks available
    smb: \>
    I was trying with the stock SAMBA utilities provided with MBWE firmware , then upon some advice from MBWE forums, I installed the SAMBA2 from the optware repository by the following

    ipkg install samba2
    Then I tried the same endeavor of mounting without any success. Only the remote directory browsing using smbclient works. The dmesg | tail on the MBWE side gives varying errors like

    <3>smbfs: mount_data version 1919251317 is not supported
    <3>smbfs: failed to load nls 'iso8859-
    It is strange since I have loaded the smbfs module correctly on MBWE and is reported by the lsmod output. Somehow the SAMBA mount from MBWE is not handshaking with the SAMBA share on Tomato. The SMB.conf file on tomato is as follows :

     interfaces = br0
     bind interfaces only = yes
     workgroup = HOME
     netbios name = AirMax
     server string = WRTSL54GS
     guest account = nobody
     security = user
     map to guest = Bad User
     guest ok = yes
     guest only = no
     browseable = yes
     syslog only = yes
     timestamp logs = no
     syslog = 1
     encrypt passwords = yes
     preserve case = yes
     short preserve case = yes
     wins support = yes
     domain master = yes
     local master = yes
     preferred master = yes
     os level = 65
     client code page = 437
     coding system = utf8
     security = share
     log file = /tmp/var/log/smb
     path = /tmp/mnt/MybookWareHouse
     writable = yes
     delete readonly = yes
     force user = root
     comment = MediaShare
    The "failed to load nls 'iso8859-" error message is really strange as well on MBWE side, since coding system is set to "utf8" on the router's side

    I am beginning to think it is some peculiar behavior of the SAMBA in Tomato or a version mismatch between MBWE and Tomato.

    Can I upgrade the SAMBA version in Tomato or is it possible install SAMBA2 and effortlessly share the USB connected drives. How to handle the default builtin SAMBA sharing then.

    The smbclient on the MBWE side tell the following info

    [root@MyBookWorld bin]# smbclient -L
    added interface ip= bcast= nmask=
    Domain=[HOME] OS=[Unix] Server=[Samba 3.0.23c]
            Sharename      Type      Comment
            ---------      ----      -------
            PUBLIC         Disk
            IPC$           IPC       IPC Service (MyBookWorld)
            Server               Comment
            ---------            -------
            AIRMAX               WRTSL54GS
            MYBOOKWORLD          MyBookWorld
            Workgroup            Master
            ---------            -------
            HOME                 AIRMAX
    [root@MyBookWorld bin]#
    So it is ver 3.0.23 (MBWE) v/s Samba 2.0.10 (Tomato Linksys)

    Tomato SAMBA configuration screen shot


    Please share any guidance, opinion or remedy you have done with similar SAMBA problems in tomato or if any changes need to be done in SAMBA on MBWE side.

    Thanks for reading and replying.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice